Assimp Namespace

Main namespace - contains high level AssimpNet objects.
Classes
 | Class | Description
Public class | Animation | An animation consists of keyframe data for a number of nodes. For each node affected by the animation, a separate series of data is given.
Public class | AssimpContext | Represents an Assimp Import/Export context that load or save models using the unmanaged library. Additionally, conversion functionality is offered to bypass loading model data into managed memory.
Public class | AssimpException | AssimpNet general exception.
Public class | Bone | Represents a single bone of a mesh. A bone has a name which allows it to be found in the frame hierarchy and by which it can be addressed by animations. In addition it has a number of influences on vertices.
Public class | Camera | Describes a right-handed camera in the scene. An important aspect is that the camera itself is also part of the scenegraph, meaning any values such as the direction vector are not *absolute*, they can be relative to the coordinate system defined by the node which corresponds to the camera. This allows for camera animations.
Public class | ConsoleLogStream | Log stream that writes messages to the Console.
Public class | EmbeddedTexture | Represents an embedded texture. Some file formats directly embed texture assets. Embedded textures may be uncompressed, where the data is given in an uncompressed format. Or it may be compressed in a format like png or jpg. In the latter case, the raw file bytes are given so the application must utilize an image decoder (e.g. DevIL) to get access to the actual color data. This object represents both types, so some properties may or may not be valid depending if it is compressed or not.
Public class | ExportDataBlob | Describes a blob of exported scene data. Blobs can be nested - each blob may reference another blob, which in turn can reference another and so on. This is used to allow exporters to write more than one output for a given scene, such as material files. Existence of such files depends on the format.
Public class | ExportFormatDescription | Describes a file format which Assimp can export to.
Public class | Face | A single face in a mesh, referring to multiple vertices. This can be a triangle if the index count is equal to three, or a polygon if the count is greater than three. Since multiple primitive types can be contained in a single mesh, this approach allows you to better examine how the mesh is constructed. If you use the SortByPrimitiveType post process step flag during import, then each mesh will be homogenous where primitive type is concerned.
Public class | FileIOSystem | Simple implementation of an IOSystem that searches for files on the disk. This implementation can be given a number of search directories that it will attempt to locate the file in first, before using the file path given by Assimp. That way, you can load models that have files distributed in a number of other directories besides the root model's.
Public class | ImporterDescription | Metadata and feature support information for a given importer.
Public class | IOStream | Defines a stream to some file input or output source. This object is responsible for reading/writing data that is used by Assimp.
Public class | IOSystem | Defines a custom IO handler that can be registered to an importer that will handle I/O for assimp. This includes searching/opening files to read during import, and creating/writing to files during export.
Public class | Light | Describes a light source in the scene. Assimp supports multiple light sources including spot, point, and directional lights. All are defined by a single structure and distinguished by their parameters. Lights have corresponding nodes in the scenegraph. Some file formats such as 3DS and ASE export a "target point", e.g. the point a spot light is looking at (it can even be animated). Assimp writes the target point as a subnode of a spotlight's main node called "spotName.Target". However, this is just additional information then, the transform tracks of the main node make the spot light already point in the right direction.
Public class | LogStream | Represents a log stream, which receives all log messages and streams them somewhere.
Public class | Material | A material contains all the information that describes how to render a mesh. E.g. textures, colors, and render states. Internally all this information is stored as key-value pair properties. The class contains many convienence methods and properties for accessing non-texture/texture properties without having to know the Assimp material key names. Not all properties may be present, and if they aren't a default value will be returned.
Public class | MaterialProperty | A key-value pairing that represents some material property.
Public class | MemoryHelper | Helper static class containing functions that aid dealing with unmanaged memory to managed memory conversions.
Public class | Mesh | A mesh represents geometry with a single material.
Public class | MeshAnimationAttachment | A mesh attachment store per-vertex animations for a particular frame. You may think of this as a 'patch' for the host mesh, since the mesh attachment replaces only certain vertex data streams at a particular time. Each mesh stores 'n' attached meshes. The actual relationship between the time line and mesh attachments is established by the mesh animation channel, which references singular mesh attachments by their ID and binds them to a time offset.
Public class | MeshAnimationChannel | Describes vertex-based animations for a single mesh or a group of meshes. Meshes carry the animation data for each frame. The purpose of this object is to define keyframes, linking each mesh attachment to a particular point in a time.
Public class | MeshMorphAnimationChannel | Describes morph-based keyframe animations for a single mesh or a group of meshes.
Public class | MeshMorphKey | Binds a morph animation mesh to a specific point in time.
Public class | Metadata | Represents a container for holding metadata, representing as key-value pairs.
Public class | NativeCustomMarshalerAttribute | Attribute for assocating a type with an INativeCustomMarshaler instance.
Public class | Node | A node in the imported model hierarchy.
Public class | NodeAnimationChannel | Describes the animation of a single node. The name specifies the bone/node which is affected by this animation chanenl. The keyframes are given in three separate seties of values, one for each position, rotation, and scaling. The transformation matrix is computed from these values and replaces the node's original transformation matrix at a specific time. This means all keys are absolute and not relative to the bone default pose. The order which the transformations are to be applied is scaling, rotation, and translation (SRT). Keys are in chronological order and duplicate keys do not pass the validation step. There most likely will be no negative time values, but they are not forbidden.
Public class | NodeCollection | A collection of child nodes owned by a parent node. Manages access to the collection while maintaing parent-child linkage.
Public class | PostProcessPreset | Static class containing preset properties for post processing options.
Public class | Scene | Represents a completely imported model or scene. Everything that was imported from the given file can be accessed from here. Once the scene is loaded from unmanaged memory, it resides solely in managed memory and Assimp's read only copy is released.
Structures
 | Structure | Description
Public structure | Color3D | Represents a RGB color.
Public structure | Color4D | Represents a Red-Green-Blue-Alpha (RGBA) color. Color values range from 0 to 1.
Public structure | Matrix3x3 | Represents a 3x3 matrix. Assimp docs say their matrices are always row-major, and it looks like they're only describing the memory layout. Matrices are treated as column vectors however (X base in the first column, Y base the second, and Z base the third)
Public structure | Matrix4x4 | Represents a 4x4 column-vector matrix (X base is the first column, Y base is the second, Z base the third, and translation the fourth). Memory layout is row major. Right handed conventions are used by default.
Public structure | MeshKey | Binds an anim mesh (referenced by an index) to a specific point in time.
Public structure | MetadataEntry | Represents an entry in a metadata container.
Public structure | Plane | Represents a plane in three-dimensional euclidean space where A, B, C are components of the plane normal and D is the distance along the normal from the origin to the plane.
Public structure | Quaternion | A 4D vector that represents a rotation.
Public structure | QuaternionKey | Time-value pair specifying a rotation for a given time.
Public structure | Ray | Defines a 3D ray with a point of origin and a direction.
Public structure | Texel | Represents a texel in ARGB8888 format.
Public structure | TextureSlot | Describes all the values pertaining to a particular texture slot in a material.
Public structure | UVTransform | Defines how an UV channel is transformed.
Public structure | Vector2D | Represents a two-dimensional vector.
Public structure | Vector3D | Represents a three-dimensional vector.
Public structure | VectorKey | Time-value pair specifying a 3D vector for a given time.
Public structure | VertexWeight | Represents a single influence of a bone on a vertex.
Interfaces
 | Interface | Description
Public interface | IMarshalableManaged, Native | Represents an object that can be marshaled to and from a native representation.
Public interface | INativeCustomMarshaler | Custom marshaler for usage with the MemoryHelper for performing marshaling to-and-from unmanaged memory for non-blittable types. A type must be attributed with NativeCustomMarshalerAttribute to automatically have an instance of its marshaler be utilized.
Delegates
 | Delegate | Description
Public delegate | FreeNativeDelegate | Delegate for performing unmanaged memory cleanup.
Public delegate | LoggingCallback | Callback delegate for Assimp's LogStream.
Enumerations
Enumeration Description
Public enumeration AnimationBehaviour
Defines an animation channel behaves outside the defined time range. This corresponds to the prestate and poststates of the animation node.
Public enumeration BlendMode
Defines alpha blending flags, how the final color value of a pixel is computed, based on the following equation:

sourceColor * sourceBlend + destColor * destBlend

Where the destColor is the previous color in the frame buffer and sourceColor is the material color before the transparency calculation. This corresponds to the AI_MATKEY_BLEND_FUNC property.

Public enumeration CompileFlags
Enumerates how the native Assimp DLL was compiled
Public enumeration DefaultLogStream
Enumerates predefined log streaming destinations.
Public enumeration ExcludeComponent
Enumerates components of the scene or mesh data that can be excluded from the import using the post process step RemoveComponent.
Public enumeration FileIOMode
Defines the desired file I/O mode is when opening a new file.
Public enumeration ImporterFeatureFlags
Defines flags that indicate level of support for common features for a given importer.
Public enumeration LightSourceType
Enumerates all supported light sources.
Public enumeration MeshMorphingMethod
Defines the methods of mesh morphing supported.
Public enumeration MetaDataType
Enumerates metadata data types.
Public enumeration Origin
Seek origins for Assimp's virtual file system API.
Public enumeration PostProcessSteps
Post processing flag options, specifying a number of steps that can be run on the data to either generate additional vertex data or optimize the imported data.
Public enumeration PrimitiveType
Enumerates geometric primitive types.
Public enumeration PropertyType
Defines material property types.
Public enumeration ReturnCode
Enumerates Assimp function result codes.
Public enumeration SceneFlags
Defines the state of the imported scene data structure.
Public enumeration ShadingMode
Defines all shading models supported by the library.

The list of shading modes has been taken from Blender. See Blender documentation for more information.

Public enumeration TextureFlags
Defines some mixed flags for a particular texture. This corresponds to the AI_MAT_KEY_TEXFLAGS property.
Public enumeration TextureMapping
Defines how texture coordinates are generated

Real-time applications typically require full UV coordinates. So the use of GenerateUVCoords step is highly recommended. It generates proper UV channels for non-UV mapped objects, as long as an accurate description of how the mapping should look like is given.

Public enumeration TextureOperation
Defines how the Nth texture of a specific type is combined with the result of all previous layers.

Example (left: key, right: value):

Copy
DiffColor0     - gray
DiffTextureOp0 - TextureOperation.Multiply
DiffTexture0   - tex1.png
DiffTextureOp0 - TextureOperation.Add
DiffTexture1   - tex2.png

Written as an equation, the final diffuse term for a specific pixel would be:

Copy
diffFinal = DiffColor0 * sampleTex(DiffTexture0, UV0) + sampleTex(DiffTexture1, UV0) * diffContrib;

Public enumeration TextureType
Defines the purpose of a texture.
Public enumeration TextureWrapMode
Defines how UV coordinates outside the [0..1] range are handled. Commonly referred to as the 'wrapping mode'
Public enumeration UVTransformFlags
Defines how UV coordinates should be transformed.

Copyright © 2012-2018 AssimpNet - Nicholas Woodfield. All rights reserved.


Animation Class

An animation consists of keyframe data for a number of nodes. For each node affected by the animation, a separate series of data is given.
Inheritance Hierarchy
SystemObject
AssimpAnimation

Namespace: Assimp
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public sealed class Animation : IMarshalable<Animation, AiAnimation>

The Animation type exposes the following members.

Constructors
 | Name | Description
Public method | Animation | Constructs a new instance of the Animation class.
Top
Properties
 | Name | Description
Public property | DurationInTicks | Gets or sets the duration of the animation in number of ticks.
Public property | HasMeshAnimations | Gets if the animation has mesh animations.
Public property | HasNodeAnimations | Gets if the animation has node animation channels.
Public property | MeshAnimationChannelCount | Gets the number of mesh animation channels.
Public property | MeshAnimationChannels | Gets the mesh animation channels.
Public property | MeshMorphAnimationChannelCount | Gets the number of mesh morph animation channels.
Public property | MeshMorphAnimationChannels | Gets the mesh morph animation channels.
Public property | Name | Gets or sets the name of the animation. If the modeling package the data was exported from only supports a single animation channel, this name is usually empty.
Public property | NodeAnimationChannelCount | Gets the number of node animation channels where each channel affects a single node.
Public property | NodeAnimationChannels | Gets the node animation channels.
Public property | TicksPerSecond | Gets or sets the number of ticks per second. It may be zero if it is not specified in the imported file.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
 | FreeNative | Frees unmanaged memory created by ToNative(IntPtr, Native).
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference


Animation Constructor

Constructs a new instance of the Animation class.

Namespace: Assimp
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public Animation()
See Also

Reference

Animation Class


Animation Properties

The Animation type exposes the following members.

Properties
 | Name | Description
Public property | DurationInTicks | Gets or sets the duration of the animation in number of ticks.
Public property | HasMeshAnimations | Gets if the animation has mesh animations.
Public property | HasNodeAnimations | Gets if the animation has node animation channels.
Public property | MeshAnimationChannelCount | Gets the number of mesh animation channels.
Public property | MeshAnimationChannels | Gets the mesh animation channels.
Public property | MeshMorphAnimationChannelCount | Gets the number of mesh morph animation channels.
Public property | MeshMorphAnimationChannels | Gets the mesh morph animation channels.
Public property | Name | Gets or sets the name of the animation. If the modeling package the data was exported from only supports a single animation channel, this name is usually empty.
Public property | NodeAnimationChannelCount | Gets the number of node animation channels where each channel affects a single node.
Public property | NodeAnimationChannels | Gets the node animation channels.
Public property | TicksPerSecond | Gets or sets the number of ticks per second. It may be zero if it is not specified in the imported file.
Top
See Also

Reference

Animation Class


Animation.DurationInTicks Property

AssimpNet Documentation (October 2018)

AnimationDurationInTicks Property

Gets or sets the duration of the animation in number of ticks.

Namespace: Assimp
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public double DurationInTicks { get; set; }

Property Value

Type: Double
See Also

Reference

Animation Class


Animation.HasMeshAnimations Property

AnimationHasMeshAnimations Property

Gets if the animation has mesh animations.

Namespace: Assimp
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public bool HasMeshAnimations { get; }

Property Value

Type: Boolean
See Also

Reference

Animation Class


Animation.HasNodeAnimations Property

AnimationHasNodeAnimations Property

Gets if the animation has node animation channels.

Namespace: Assimp
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public bool HasNodeAnimations { get; }

Property Value

Type: Boolean
See Also

Reference

Animation Class


Animation.MeshAnimationChannelCount Property

AnimationMeshAnimationChannelCount Property

Gets the number of mesh animation channels.

Namespace: Assimp
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public int MeshAnimationChannelCount { get; }

Property Value

Type: Int32
See Also

Reference

Animation Class


Animation.MeshAnimationChannels Property

AnimationMeshAnimationChannels Property

Gets the mesh animation channels.

Namespace: Assimp
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public List MeshAnimationChannels { get; }

Property Value

Type: ListT
See Also

Reference

Animation Class


Animation.MeshMorphAnimationChannelCount Property

AnimationMeshMorphAnimationChannelCount Property

Gets the number of mesh morph animation channels.

Namespace: Assimp
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public int MeshMorphAnimationChannelCount { get; }

Property Value

Type: Int32
See Also

Reference

Animation Class


Animation.MeshMorphAnimationChannels Property

AnimationMeshMorphAnimationChannels Property

Gets the mesh morph animation channels.

Namespace: Assimp
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public List MeshMorphAnimationChannels { get; }

Property Value

Type: ListT
See Also

Reference

Animation Class


Animation.Name Property

AnimationName Property

Gets or sets the name of the animation. If the modeling package the data was exported from only supports a single animation channel, this name is usually empty.

Namespace: Assimp
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public string Name { get; set; }

Property Value

Type: String
See Also

Reference

Animation Class


Animation.NodeAnimationChannelCount Property

AnimationNodeAnimationChannelCount Property

Gets the number of node animation channels where each channel affects a single node.

Namespace: Assimp
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public int NodeAnimationChannelCount { get; }

Property Value

Type: Int32
See Also

Reference

Animation Class


Animation.NodeAnimationChannels Property

AnimationNodeAnimationChannels Property

Gets the node animation channels.

Namespace: Assimp
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public List NodeAnimationChannels { get; }

Property Value

Type: ListT
See Also

Reference

Animation Class


Animation.TicksPerSecond Property

AnimationTicksPerSecond Property

Gets or sets the number of ticks per second. It may be zero if it is not specified in the imported file.

Namespace: Assimp
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public double TicksPerSecond { get; set; }

Property Value

Type: Double
See Also

Reference

Animation Class


Animation Methods

The Animation type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
 | FreeNative | Frees unmanaged memory created by ToNative(IntPtr, Native).
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Animation Class


Animation.FreeNative Method

AnimationFreeNative Method

Frees unmanaged memory created by ToNative(IntPtr, Native).

Namespace: Assimp
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public static void FreeNative(
    IntPtr nativeValue,
    bool freeNative
)

Parameters

nativeValue
Type: SystemIntPtr
Native value to free
freeNative
Type: SystemBoolean
True if the unmanaged memory should be freed, false otherwise.
See Also

Reference

Animation Class


AnimationBehaviour Enumeration

Defines an animation channel behaves outside the defined time range. This corresponds to the prestate and poststates of the animation node.

Namespace: Assimp
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public enum AnimationBehaviour
Members
Member name | Value | Description
Default | 0 | The value from the default node transformation is taken.
Constant | 1 | The nearest key value is used without interpolation.
Linear | 2 | The value of the nearest two keys is linearly extrapolated for the current time value.
Repeat | 3 | The animation is repeated. If the animation key goes from n to m and the current time is t, use the value at (t - n ) % (|m-n|).
See Also

Reference


AssimpContext Class

Represents an Assimp Import/Export context that load or save models using the unmanaged library. Additionally, conversion functionality is offered to bypass loading model data into managed memory.
Inheritance Hierarchy
SystemObject
AssimpAssimpContext

Namespace: Assimp
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public sealed class AssimpContext : IDisposable

The AssimpContext type exposes the following members.

Constructors
 | Name | Description
Public method | AssimpContext | Constructs a new instance of the AssimpContext class.
Top
Properties
 | Name | Description
Public property | IsDisposed | Gets if the context has been disposed.
Public property | PropertyConfigurations | Gets the property configurations set to this context. This is only used during import.
Public property | Scale | Gets or sets the uniform scale for the model. This is multiplied with the existing root node's transform. This is only used during import.
Public property | UsingCustomIOSystem | Gets whether this context is using a user-defined IO system for file handling.
Public property | XAxisRotation | Gets or sets the model's rotation about the X-Axis, in degrees. This is multiplied with the existing root node's transform. This is only used during import.
Public property | YAxisRotation | Gets or sets the model's rotation abut the Y-Axis, in degrees. This is multiplied with the existing root node's transform. This is only used during import.
Public property | ZAxisRotation | Gets or sets the model's rotation about the Z-Axis, in degrees. This is multiplied with the existing root node's transform. This is only used during import.
Top
Methods
 | Name | Description
Public method | ContainsConfig | Checks if the context has a config set by the specified name.
Public method | ConvertFromFileToBlob(String, String) | Converts the model contained in the file to the specified format and save it to a data blob.
Public method | ConvertFromFileToBlob(String, String, PostProcessSteps) | Converts the model contained in the file to the specified format and save it to a data blob.
Public method | ConvertFromFileToBlob(String, PostProcessSteps, String, PostProcessSteps) | Converts the model contained in the file to the specified format and save it to a data blob.
Public method | ConvertFromFileToFile(String, String, String) | Converts the model contained in the file to the specified format and save it to a file.
Public method | ConvertFromFileToFile(String, String, String, PostProcessSteps) | Converts the model contained in the file to the specified format and save it to a file.
Public method | ConvertFromFileToFile(String, PostProcessSteps, String, String, PostProcessSteps) | Converts the model contained in the file to the specified format and save it to a file.
Public method | ConvertFromStreamToBlob(Stream, String, String) | Converts the model contained in the stream to the specified format and save it to a data blob. It is up to the caller to dispose of the stream. If the format is distributed across multiple files/streams, set a custom IOSystem and use the "ConvertFromFileToBlob" family of functions.
Public method | ConvertFromStreamToBlob(Stream, String, String, PostProcessSteps) | Converts the model contained in the stream to the specified format and save it to a data blob. It is up to the caller to dispose of the stream. If the format is distributed across multiple files/streams, set a custom IOSystem and use the "ConvertFromFileToBlob" family of functions.
Public method | ConvertFromStreamToBlob(Stream, String, PostProcessSteps, String, PostProcessSteps) | Converts the model contained in the stream to the specified format and save it to a data blob. It is up to the caller to dispose of the stream. If the format is distributed across multiple files/streams, set a custom IOSystem and use the "ConvertFromFileToBlob" family of functions.
Public method | ConvertFromStreamToFile(Stream, String, String, String) | Converts the model contained in the stream to the specified format and save it to a file. It is up to the caller to dispose of the stream. If the format is distributed across multiple files/streams, set a custom IOSystem and use the "ConvertFromFileToFile" family of functions.
Public method | ConvertFromStreamToFile(Stream, String, String, String, PostProcessSteps) | Converts the model contained in the stream to the specified format and save it to a file. It is up to the caller to dispose of the stream. If the format is distributed across multiple files/streams, set a custom IOSystem and use the "ConvertFromFileToFile" family of functions.
Public method | ConvertFromStreamToFile(Stream, String, PostProcessSteps, String, String, PostProcessSteps) | Converts the model contained in the stream to the specified format and save it to a file. It is up to the caller to dispose of the stream. If the format is distributed across multiple files/streams, set a custom IOSystem and use the "ConvertFromFileToFile" family of functions.
Public method | Dispose | Disposes of resources held by the context. These include IO systems still attached.
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | ExportFile(Scene, String, String) | Exports a scene to the specified format and writes it to a file.
Public method | ExportFile(Scene, String, String, PostProcessSteps) | Exports a scene to the specified format and writes it to a file.
Public method | ExportToBlob(Scene, String) | Exports a scene to the specified format and writes it to a data blob.
Public method | ExportToBlob(Scene, String, PostProcessSteps) | Exports a scene to the specified format and writes it to a data blob.
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetImporterDescriptionFor | Gets an importer description for the specified file extension. If no importers support it, null is returned. Multiple importers may support the file extension, they are called in the order that they were registered.
Public method | GetImporterDescriptions | Gets descriptions for each importer that assimp has registered.
Public method | GetSupportedExportFormats | Gets the model formats that are supported for export by Assimp.
Public method | GetSupportedImportFormats | Gets the model formats that are supported for import by Assimp.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ImportFile(String) | Imports a model from the specified file without running any post-process steps. The importer sets configurations and loads the model into managed memory, releasing the unmanaged memory used by Assimp.
Public method | ImportFile(String, PostProcessSteps) | Imports a model from the specified file. The importer sets configurations and loads the model into managed memory, releasing the unmanaged memory used by Assimp.
Public method | ImportFileFromStream(Stream, String) | Imports a model from the stream without running any post-process steps. The importer sets configurations and loads the model into managed memory, releasing the unmanaged memory used by Assimp. It is up to the caller to dispose of the stream. If the format is distributed across multiple files/streams, set a custom IOSystem and use the "ImportFile" family of functions.
Public method | ImportFileFromStream(Stream, PostProcessSteps, String) | Imports a model from the stream. The importer sets configurations and loads the model into managed memory, releasing the unmanaged memory used by Assimp. It is up to the caller to dispose of the stream. If the format is distributed across multiple files/streams, set a custom IOSystem and use the "ImportFile" family of functions.
Public method | IsExportFormatSupported | Checks if the format extension (e.g. ".dae" or ".obj") is supported for export.
Public method | IsImportFormatSupported | Checks if the format extension (e.g. ".dae" or ".obj") is supported for import.
Public method | RemoveConfig | Removes a set configuration property by name.
Public method | RemoveConfigs | Removes all configuration properties from the context.
Public method | RemoveIOSystem | Removes the currently set custom file system implementation from the importer.
Public method | SetConfig | Sets a configuration property to the context. This is only used during import.
Public method | SetIOSystem | Sets a custom file system implementation that is used by this importer. If it is null, then the default assimp file system is used instead.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference


AssimpContext Constructor

Constructs a new instance of the AssimpContext class.

Namespace: Assimp
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public AssimpContext()
See Also

Reference

AssimpContext Class


AssimpContext Properties

The AssimpContext type exposes the following members.

Properties
 | Name | Description
Public property | IsDisposed | Gets if the context has been disposed.
Public property | PropertyConfigurations | Gets the property configurations set to this context. This is only used during import.
Public property | Scale | Gets or sets the uniform scale for the model. This is multiplied with the existing root node's transform. This is only used during import.
Public property | UsingCustomIOSystem | Gets whether this context is using a user-defined IO system for file handling.
Public property | XAxisRotation | Gets or sets the model's rotation about the X-Axis, in degrees. This is multiplied with the existing root node's transform. This is only used during import.
Public property | YAxisRotation | Gets or sets the model's rotation abut the Y-Axis, in degrees. This is multiplied with the existing root node's transform. This is only used during import.
Public property | ZAxisRotation | Gets or sets the model's rotation about the Z-Axis, in degrees. This is multiplied with the existing root node's transform. This is only used during import.
Top
See Also

Reference

AssimpContext Class


AssimpContext.IsDisposed Property

AssimpContextIsDisposed Property

Gets if the context has been disposed.

Namespace: Assimp
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public bool IsDisposed { get; }

Property Value

Type: Boolean
See Also

Reference

AssimpContext Class


AssimpContext.PropertyConfigurations Property

AssimpContextPropertyConfigurations Property

Gets the property configurations set to this context. This is only used during import.

Namespace: Assimp
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public Dictionary PropertyConfigurations { get; }

Property Value

Type: DictionaryTKey, TValue
See Also

Reference

AssimpContext Class


AssimpContext.Scale Property

AssimpContextScale Property

Gets or sets the uniform scale for the model. This is multiplied with the existing root node's transform. This is only used during import.

Namespace: Assimp
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public float Scale { get; set; }

Property Value

Type: Single
See Also

Reference

AssimpContext Class


AssimpContext.UsingCustomIOSystem Property

AssimpContextUsingCustomIOSystem Property

Gets whether this context is using a user-defined IO system for file handling.

Namespace: Assimp
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public bool UsingCustomIOSystem { get; }

Property Value

Type: Boolean
See Also

Reference

AssimpContext Class


AssimpContext.XAxisRotation Property

AssimpContextXAxisRotation Property

Gets or sets the model's rotation about the X-Axis, in degrees. This is multiplied with the existing root node's transform. This is only used during import.

Namespace: Assimp
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public float XAxisRotation { get; set; }

Property Value

Type: Single
See Also

Reference

AssimpContext Class


AssimpContext.YAxisRotation Property

AssimpContextYAxisRotation Property

Gets or sets the model's rotation abut the Y-Axis, in degrees. This is multiplied with the existing root node's transform. This is only used during import.

Namespace: Assimp
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public float YAxisRotation { get; set; }

Property Value

Type: Single
See Also

Reference

AssimpContext Class


AssimpContext.ZAxisRotation Property

AssimpContextZAxisRotation Property

Gets or sets the model's rotation about the Z-Axis, in degrees. This is multiplied with the existing root node's transform. This is only used during import.

Namespace: Assimp
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public float ZAxisRotation { get; set; }

Property Value

Type: Single
See Also

Reference

AssimpContext Class


AssimpContext Methods

The AssimpContext type exposes the following members.

Methods
 | Name | Description
Public method | ContainsConfig | Checks if the context has a config set by the specified name.
Public method | ConvertFromFileToBlob(String, String) | Converts the model contained in the file to the specified format and save it to a data blob.
Public method | ConvertFromFileToBlob(String, String, PostProcessSteps) | Converts the model contained in the file to the specified format and save it to a data blob.
Public method | ConvertFromFileToBlob(String, PostProcessSteps, String, PostProcessSteps) | Converts the model contained in the file to the specified format and save it to a data blob.
Public method | ConvertFromFileToFile(String, String, String) | Converts the model contained in the file to the specified format and save it to a file.
Public method | ConvertFromFileToFile(String, String, String, PostProcessSteps) | Converts the model contained in the file to the specified format and save it to a file.
Public method | ConvertFromFileToFile(String, PostProcessSteps, String, String, PostProcessSteps) | Converts the model contained in the file to the specified format and save it to a file.
Public method | ConvertFromStreamToBlob(Stream, String, String) | Converts the model contained in the stream to the specified format and save it to a data blob. It is up to the caller to dispose of the stream. If the format is distributed across multiple files/streams, set a custom IOSystem and use the "ConvertFromFileToBlob" family of functions.
Public method | ConvertFromStreamToBlob(Stream, String, String, PostProcessSteps) | Converts the model contained in the stream to the specified format and save it to a data blob. It is up to the caller to dispose of the stream. If the format is distributed across multiple files/streams, set a custom IOSystem and use the "ConvertFromFileToBlob" family of functions.
Public method | ConvertFromStreamToBlob(Stream, String, PostProcessSteps, String, PostProcessSteps) | Converts the model contained in the stream to the specified format and save it to a data blob. It is up to the caller to dispose of the stream. If the format is distributed across multiple files/streams, set a custom IOSystem and use the "ConvertFromFileToBlob" family of functions.
Public method | ConvertFromStreamToFile(Stream, String, String, String) | Converts the model contained in the stream to the specified format and save it to a file. It is up to the caller to dispose of the stream. If the format is distributed across multiple files/streams, set a custom IOSystem and use the "ConvertFromFileToFile" family of functions.
Public method | ConvertFromStreamToFile(Stream, String, String, String, PostProcessSteps) | Converts the model contained in the stream to the specified format and save it to a file. It is up to the caller to dispose of the stream. If the format is distributed across multiple files/streams, set a custom IOSystem and use the "ConvertFromFileToFile" family of functions.
Public method | ConvertFromStreamToFile(Stream, String, PostProcessSteps, String, String, PostProcessSteps) | Converts the model contained in the stream to the specified format and save it to a file. It is up to the caller to dispose of the stream. If the format is distributed across multiple files/streams, set a custom IOSystem and use the "ConvertFromFileToFile" family of functions.
Public method | Dispose | Disposes of resources held by the context. These include IO systems still attached.
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | ExportFile(Scene, String, String) | Exports a scene to the specified format and writes it to a file.
Public method | ExportFile(Scene, String, String, PostProcessSteps) | Exports a scene to the specified format and writes it to a file.
Public method | ExportToBlob(Scene, String) | Exports a scene to the specified format and writes it to a data blob.
Public method | ExportToBlob(Scene, String, PostProcessSteps) | Exports a scene to the specified format and writes it to a data blob.
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetImporterDescriptionFor | Gets an importer description for the specified file extension. If no importers support it, null is returned. Multiple importers may support the file extension, they are called in the order that they were registered.
Public method | GetImporterDescriptions | Gets descriptions for each importer that assimp has registered.
Public method | GetSupportedExportFormats | Gets the model formats that are supported for export by Assimp.
Public method | GetSupportedImportFormats | Gets the model formats that are supported for import by Assimp.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ImportFile(String) | Imports a model from the specified file without running any post-process steps. The importer sets configurations and loads the model into managed memory, releasing the unmanaged memory used by Assimp.
Public method | ImportFile(String, PostProcessSteps) | Imports a model from the specified file. The importer sets configurations and loads the model into managed memory, releasing the unmanaged memory used by Assimp.
Public method | ImportFileFromStream(Stream, String) | Imports a model from the stream without running any post-process steps. The importer sets configurations and loads the model into managed memory, releasing the unmanaged memory used by Assimp. It is up to the caller to dispose of the stream. If the format is distributed across multiple files/streams, set a custom IOSystem and use the "ImportFile" family of functions.
Public method | ImportFileFromStream(Stream, PostProcessSteps, String) | Imports a model from the stream. The importer sets configurations and loads the model into managed memory, releasing the unmanaged memory used by Assimp. It is up to the caller to dispose of the stream. If the format is distributed across multiple files/streams, set a custom IOSystem and use the "ImportFile" family of functions.
Public method | IsExportFormatSupported | Checks if the format extension (e.g. ".dae" or ".obj") is supported for export.
Public method | IsImportFormatSupported | Checks if the format extension (e.g. ".dae" or ".obj") is supported for import.
Public method | RemoveConfig | Removes a set configuration property by name.
Public method | RemoveConfigs | Removes all configuration properties from the context.
Public method | RemoveIOSystem | Removes the currently set custom file system implementation from the importer.
Public method | SetConfig | Sets a configuration property to the context. This is only used during import.
Public method | SetIOSystem | Sets a custom file system implementation that is used by this importer. If it is null, then the default assimp file system is used instead.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

AssimpContext Class


AssimpContext.ContainsConfig Method

AssimpContextContainsConfig Method

Checks if the context has a config set by the specified name.

Namespace: Assimp
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public bool ContainsConfig(
    string configName
)

Parameters

configName
Type: SystemString
Name of the config property

Return Value

Type: Boolean
True if the config is present, false otherwise
See Also

Reference

AssimpContext Class


AssimpContext.ConvertFromFileToBlob Method

AssimpContextConvertFromFileToBlob Method

Overload List
 | Name | Description
Public method | ConvertFromFileToBlob(String, String) | Converts the model contained in the file to the specified format and save it to a data blob.
Public method | ConvertFromFileToBlob(String, String, PostProcessSteps) | Converts the model contained in the file to the specified format and save it to a data blob.
Public method | ConvertFromFileToBlob(String, PostProcessSteps, String, PostProcessSteps) | Converts the model contained in the file to the specified format and save it to a data blob.
Top
See Also

Reference

AssimpContext Class


AssimpContext.ConvertFromFileToBlob Method (String, String)

AssimpContextConvertFromFileToBlob Method (String, String)

Converts the model contained in the file to the specified format and save it to a data blob.

Namespace: Assimp
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public ExportDataBlob ConvertFromFileToBlob(
    string inputFilename,
    string exportFormatId
)

Parameters

inputFilename
Type: SystemString
Input file name to import
exportFormatId
Type: SystemString
Format id that specifies what format to export to

Return Value

Type: ExportDataBlob
Data blob containing the exported scene in a binary form
Exceptions
Exception | Condition
AssimpException | Thrown if there was a general error in importing the model.
FileNotFoundException | Thrown if the file could not be located.
ObjectDisposedException | Thrown if the context has already been disposed of.
See Also

Reference

AssimpContext Class
ConvertFromFileToBlob Overload


AssimpContext.ConvertFromFileToBlob Method (String, String, PostProcessSteps)

AssimpContextConvertFromFileToBlob Method (String, String, PostProcessSteps)

Converts the model contained in the file to the specified format and save it to a data blob.

Namespace: Assimp
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public ExportDataBlob ConvertFromFileToBlob(
    string inputFilename,
    string exportFormatId,
    PostProcessSteps exportProcessSteps
)

Parameters

inputFilename
Type: SystemString
Input file name to import
exportFormatId
Type: SystemString
Format id that specifies what format to export to
exportProcessSteps
Type: AssimpPostProcessSteps
Pre processing steps used for the export

Return Value

Type: ExportDataBlob
Data blob containing the exported scene in a binary form
Exceptions
Exception | Condition
AssimpException | Thrown if there was a general error in importing the model.
FileNotFoundException | Thrown if the file could not be located.
ObjectDisposedException | Thrown if the context has already been disposed of.
See Also

Reference

AssimpContext Class
ConvertFromFileToBlob Overload


AssimpContext.ConvertFromFileToBlob Method (String, PostProcessSteps, String, PostProcessSteps)

AssimpContextConvertFromFileToBlob Method (String, PostProcessSteps, String, PostProcessSteps)

Converts the model contained in the file to the specified format and save it to a data blob.

Namespace: Assimp
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public ExportDataBlob ConvertFromFileToBlob(
    string inputFilename,
    PostProcessSteps importProcessSteps,
    string exportFormatId,
    PostProcessSteps exportProcessSteps
)

Parameters

inputFilename
Type: SystemString
Input file name to import
importProcessSteps
Type: AssimpPostProcessSteps
Post processing steps used for the import
exportFormatId
Type: SystemString
Format id that specifies what format to export to
exportProcessSteps
Type: AssimpPostProcessSteps
Pre processing steps used for the export

Return Value

Type: ExportDataBlob
Data blob containing the exported scene in a binary form
Exceptions
Exception | Condition
AssimpException | Thrown if there was a general error in importing the model.
FileNotFoundException | Thrown if the file could not be located.
ObjectDisposedException | Thrown if the context has already been disposed of.
See Also

Reference

AssimpContext Class
ConvertFromFileToBlob Overload


AssimpContext.ConvertFromFileToFile Method

AssimpContextConvertFromFileToFile Method

Overload List
 | Name | Description
Public method | ConvertFromFileToFile(String, String, String) | Converts the model contained in the file to the specified format and save it to a file.
Public method | ConvertFromFileToFile(String, String, String, PostProcessSteps) | Converts the model contained in the file to the specified format and save it to a file.
Public method | ConvertFromFileToFile(String, PostProcessSteps, String, String, PostProcessSteps) | Converts the model contained in the file to the specified format and save it to a file.
Top
See Also

Reference

AssimpContext Class


AssimpContext.ConvertFromFileToFile Method (String, String, String)

AssimpContextConvertFromFileToFile Method (String, String, String)

Converts the model contained in the file to the specified format and save it to a file.

Namespace: Assimp
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public bool ConvertFromFileToFile(
    string inputFilename,
    string outputFilename,
    string exportFormatId
)

Parameters

inputFilename
Type: SystemString
Input file name to import
outputFilename
Type: SystemString
Output file name to export to
exportFormatId
Type: SystemString
Format id that specifies what format to export to

Return Value

Type: Boolean
True if the conversion was successful or not, false otherwise.
Exceptions
Exception | Condition
AssimpException | Thrown if there was a general error in importing the model.
FileNotFoundException | Thrown if the file could not be located.
ObjectDisposedException | Thrown if the context has already been disposed of.
See Also

Reference

AssimpContext Class
ConvertFromFileToFile Overload


AssimpContext.ConvertFromFileToFile Method (String, String, String, PostProcessSteps)

AssimpContextConvertFromFileToFile Method (String, String, String, PostProcessSteps)

Converts the model contained in the file to the specified format and save it to a file.

Namespace: Assimp
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public bool ConvertFromFileToFile(
    string inputFilename,
    string outputFilename,
    string exportFormatId,
    PostProcessSteps exportProcessSteps
)

Parameters

inputFilename
Type: SystemString
Input file name to import
outputFilename
Type: SystemString
Output file name to export to
exportFormatId
Type: SystemString
Format id that specifies what format to export to
exportProcessSteps
Type: AssimpPostProcessSteps
Pre processing steps used for the export

Return Value

Type: Boolean
True if the conversion was successful or not, false otherwise.
Exceptions
Exception | Condition
AssimpException | Thrown if there was a general error in importing the model.
FileNotFoundException | Thrown if the file could not be located.
ObjectDisposedException | Thrown if the context has already been disposed of.
See Also

Reference

AssimpContext Class
ConvertFromFileToFile Overload


AssimpContext.ConvertFromFileToFile Method (String, PostProcessSteps, String, String, PostProcessSteps)

AssimpContextConvertFromFileToFile Method (String, PostProcessSteps, String, String, PostProcessSteps)

Converts the model contained in the file to the specified format and save it to a file.

Namespace: Assimp
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public bool ConvertFromFileToFile(
    string inputFilename,
    PostProcessSteps importProcessSteps,
    string outputFilename,
    string exportFormatId,
    PostProcessSteps exportProcessSteps
)

Parameters

inputFilename
Type: SystemString
Input file name to import
importProcessSteps
Type: AssimpPostProcessSteps
Post processing steps used for the import
outputFilename
Type: SystemString
Output file name to export to
exportFormatId
Type: SystemString
Format id that specifies what format to export to
exportProcessSteps
Type: AssimpPostProcessSteps
Pre processing steps used for the export

Return Value

Type: Boolean
True if the conversion was successful or not, false otherwise.
Exceptions
Exception | Condition
AssimpException | Thrown if there was a general error in importing the model.
FileNotFoundException | Thrown if the file could not be located.
ObjectDisposedException | Thrown if the context has already been disposed of.
See Also

Reference

AssimpContext Class
ConvertFromFileToFile Overload


AssimpContext.ConvertFromStreamToBlob Method

AssimpContextConvertFromStreamToBlob Method

Overload List
 | Name | Description
Public method | ConvertFromStreamToBlob(Stream, String, String) | Converts the model contained in the stream to the specified format and save it to a data blob. It is up to the caller to dispose of the stream. If the format is distributed across multiple files/streams, set a custom IOSystem and use the "ConvertFromFileToBlob" family of functions.
Public method | ConvertFromStreamToBlob(Stream, String, String, PostProcessSteps) | Converts the model contained in the stream to the specified format and save it to a data blob. It is up to the caller to dispose of the stream. If the format is distributed across multiple files/streams, set a custom IOSystem and use the "ConvertFromFileToBlob" family of functions.
Public method | ConvertFromStreamToBlob(Stream, String, PostProcessSteps, String, PostProcessSteps) | Converts the model contained in the stream to the specified format and save it to a data blob. It is up to the caller to dispose of the stream. If the format is distributed across multiple files/streams, set a custom IOSystem and use the "ConvertFromFileToBlob" family of functions.
Top
See Also

Reference

AssimpContext Class


AssimpContext.ConvertFromStreamToBlob Method (Stream, String, String)

AssimpContextConvertFromStreamToBlob Method (Stream, String, String)

Converts the model contained in the stream to the specified format and save it to a data blob. It is up to the caller to dispose of the stream. If the format is distributed across multiple files/streams, set a custom IOSystem and use the "ConvertFromFileToBlob" family of functions.

Namespace: Assimp
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public ExportDataBlob ConvertFromStreamToBlob(
    Stream inputStream,
    string importFormatHint,
    string exportFormatId
)

Parameters

inputStream
Type: System.IOStream
Stream to read from
importFormatHint
Type: SystemString
Optional format extension to serve as a hint to Assimp to choose which importer to use. If null or empty, the system will try to detect what importer to use from the data which may or may not be successful
exportFormatId
Type: SystemString
Format id that specifies what format to export to

Return Value

Type: ExportDataBlob
Data blob containing the exported scene in a binary form
Exceptions
Exception | Condition
AssimpException | Thrown if the stream is not valid (null or write-only).
ObjectDisposedException | Thrown if the context has already been disposed of.
See Also

Reference

AssimpContext Class
ConvertFromStreamToBlob Overload


AssimpContext.ConvertFromStreamToBlob Method (Stream, String, String, PostProcessSteps)

AssimpContextConvertFromStreamToBlob Method (Stream, String, String, PostProcessSteps)

Converts the model contained in the stream to the specified format and save it to a data blob. It is up to the caller to dispose of the stream. If the format is distributed across multiple files/streams, set a custom IOSystem and use the "ConvertFromFileToBlob" family of functions.

Namespace: Assimp
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public ExportDataBlob ConvertFromStreamToBlob(
    Stream inputStream,
    string importFormatHint,
    string exportFormatId,
    PostProcessSteps exportProcessSteps
)

Parameters

inputStream
Type: System.IOStream
Stream to read from
importFormatHint
Type: SystemString
Optional format extension to serve as a hint to Assimp to choose which importer to use. If null or empty, the system will try to detect what importer to use from the data which may or may not be successful
exportFormatId
Type: SystemString
Format id that specifies what format to export to
exportProcessSteps
Type: AssimpPostProcessSteps
Pre processing steps used for the export

Return Value

Type: ExportDataBlob
Data blob containing the exported scene in a binary form
Exceptions
Exception | Condition
AssimpException | Thrown if the stream is not valid (null or write-only).
ObjectDisposedException | Thrown if the context has already been disposed of.
See Also

Reference

AssimpContext Class
ConvertFromStreamToBlob Overload


AssimpContext.ConvertFromStreamToBlob Method (Stream, String, PostProcessSteps, String, PostProcessSteps)

AssimpContextConvertFromStreamToBlob Method (Stream, String, PostProcessSteps, String, PostProcessSteps)

Converts the model contained in the stream to the specified format and save it to a data blob. It is up to the caller to dispose of the stream. If the format is distributed across multiple files/streams, set a custom IOSystem and use the "ConvertFromFileToBlob" family of functions.

Namespace: Assimp
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public ExportDataBlob ConvertFromStreamToBlob(
    Stream inputStream,
    string importFormatHint,
    PostProcessSteps importProcessSteps,
    string exportFormatId,
    PostProcessSteps exportProcessSteps
)

Parameters

inputStream
Type: System.IOStream
Stream to read from
importFormatHint
Type: SystemString
Optional format extension to serve as a hint to Assimp to choose which importer to use. If null or empty, the system will try to detect what importer to use from the data which may or may not be successful
importProcessSteps
Type: AssimpPostProcessSteps
Post processing steps used for import
exportFormatId
Type: SystemString
Format id that specifies what format to export to
exportProcessSteps
Type: AssimpPostProcessSteps
Pre processing steps used for the export

Return Value

Type: ExportDataBlob
Data blob containing the exported scene in a binary form
Exceptions
Exception | Condition
AssimpException | Thrown if the stream is not valid (null or write-only).
ObjectDisposedException | Thrown if the context has already been disposed of.
See Also

Reference

AssimpContext Class
ConvertFromStreamToBlob Overload


AssimpContext.ConvertFromStreamToFile Method

AssimpContextConvertFromStreamToFile Method

Overload List
 | Name | Description
Public method | ConvertFromStreamToFile(Stream, String, String, String) | Converts the model contained in the stream to the specified format and save it to a file. It is up to the caller to dispose of the stream. If the format is distributed across multiple files/streams, set a custom IOSystem and use the "ConvertFromFileToFile" family of functions.
Public method | ConvertFromStreamToFile(Stream, String, String, String, PostProcessSteps) | Converts the model contained in the stream to the specified format and save it to a file. It is up to the caller to dispose of the stream. If the format is distributed across multiple files/streams, set a custom IOSystem and use the "ConvertFromFileToFile" family of functions.
Public method | ConvertFromStreamToFile(Stream, String, PostProcessSteps, String, String, PostProcessSteps) | Converts the model contained in the stream to the specified format and save it to a file. It is up to the caller to dispose of the stream. If the format is distributed across multiple files/streams, set a custom IOSystem and use the "ConvertFromFileToFile" family of functions.
Top
See Also

Reference

AssimpContext Class


AssimpContext.ConvertFromStreamToFile Method (Stream, String, String, String)

AssimpContextConvertFromStreamToFile Method (Stream, String, String, String)

Converts the model contained in the stream to the specified format and save it to a file. It is up to the caller to dispose of the stream. If the format is distributed across multiple files/streams, set a custom IOSystem and use the "ConvertFromFileToFile" family of functions.

Namespace: Assimp
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public bool ConvertFromStreamToFile(
    Stream inputStream,
    string importFormatHint,
    string outputFilename,
    string exportFormatId
)

Parameters

inputStream
Type: System.IOStream
Stream to read from
importFormatHint
Type: SystemString
Optional format extension to serve as a hint to Assimp to choose which importer to use. If null or empty, the system will try to detect what importer to use from the data which may or may not be successful
outputFilename
Type: SystemString
Output file name to export to
exportFormatId
Type: SystemString
Format id that specifies what format to export to

Return Value

Type: Boolean
True if the conversion was successful or not, false otherwise.
Exceptions
Exception | Condition
AssimpException | Thrown if the stream is not valid (null or write-only).
ObjectDisposedException | Thrown if the context has already been disposed of.
See Also

Reference

AssimpContext Class
ConvertFromStreamToFile Overload


AssimpContext.ConvertFromStreamToFile Method (Stream, String, String, String, PostProcessSteps)

AssimpContextConvertFromStreamToFile Method (Stream, String, String, String, PostProcessSteps)

Converts the model contained in the stream to the specified format and save it to a file. It is up to the caller to dispose of the stream. If the format is distributed across multiple files/streams, set a custom IOSystem and use the "ConvertFromFileToFile" family of functions.

Namespace: Assimp
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public bool ConvertFromStreamToFile(
    Stream inputStream,
    string importFormatHint,
    string outputFilename,
    string exportFormatId,
    PostProcessSteps exportProcessSteps
)

Parameters

inputStream
Type: System.IOStream
Stream to read from
importFormatHint
Type: SystemString
Optional format extension to serve as a hint to Assimp to choose which importer to use. If null or empty, the system will try to detect what importer to use from the data which may or may not be successful
outputFilename
Type: SystemString
Output file name to export to
exportFormatId
Type: SystemString
Format id that specifies what format to export to
exportProcessSteps
Type: AssimpPostProcessSteps
Pre processing steps used for the export

Return Value

Type: Boolean
True if the conversion was successful or not, false otherwise.
Exceptions
Exception | Condition
AssimpException | Thrown if the stream is not valid (null or write-only).
ObjectDisposedException | Thrown if the context has already been disposed of.
See Also

Reference

AssimpContext Class
ConvertFromStreamToFile Overload


AssimpContext.ConvertFromStreamToFile Method (Stream, String, PostProcessSteps, String, String, PostProcessSteps)

AssimpContextConvertFromStreamToFile Method (Stream, String, PostProcessSteps, String, String, PostProcessSteps)

Converts the model contained in the stream to the specified format and save it to a file. It is up to the caller to dispose of the stream. If the format is distributed across multiple files/streams, set a custom IOSystem and use the "ConvertFromFileToFile" family of functions.

Namespace: Assimp
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public bool ConvertFromStreamToFile(
    Stream inputStream,
    string importFormatHint,
    PostProcessSteps importProcessSteps,
    string outputFilename,
    string exportFormatId,
    PostProcessSteps exportProcessSteps
)

Parameters

inputStream
Type: System.IOStream
Stream to read from
importFormatHint
Type: SystemString
Optional format extension to serve as a hint to Assimp to choose which importer to use. If null or empty, the system will try to detect what importer to use from the data which may or may not be successful
importProcessSteps
Type: AssimpPostProcessSteps
Post processing steps used for import
outputFilename
Type: SystemString
Output file name to export to
exportFormatId
Type: SystemString
Format id that specifies what format to export to
exportProcessSteps
Type: AssimpPostProcessSteps
Pre processing steps used for the export

Return Value

Type: Boolean
True if the conversion was successful or not, false otherwise.
Exceptions
Exception | Condition
AssimpException | Thrown if the stream is not valid (null or write-only).
ObjectDisposedException | Thrown if the context has already been disposed of.
See Also

Reference

AssimpContext Class
ConvertFromStreamToFile Overload


AssimpContext.Dispose Method

AssimpContextDispose Method

Disposes of resources held by the context. These include IO systems still attached.

Namespace: Assimp
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public void Dispose()

Implements

IDisposableDispose
See Also

Reference

AssimpContext Class


AssimpContext.ExportFile Method

AssimpContextExportFile Method

Overload List
 | Name | Description
Public method | ExportFile(Scene, String, String) | Exports a scene to the specified format and writes it to a file.
Public method | ExportFile(Scene, String, String, PostProcessSteps) | Exports a scene to the specified format and writes it to a file.
Top
See Also

Reference

AssimpContext Class


AssimpContext.ExportFile Method (Scene, String, String)

AssimpContextExportFile Method (Scene, String, String)

Exports a scene to the specified format and writes it to a file.

Namespace: Assimp
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public bool ExportFile(
    Scene scene,
    string fileName,
    string exportFormatId
)

Parameters

scene
Type: AssimpScene
Scene containing the model to export.
fileName
Type: SystemString
Path to the file.
exportFormatId
Type: SystemString
FormatID representing the format to export to.

Return Value

Type: Boolean
True if the scene was exported successfully, false otherwise.
Exceptions
Exception | Condition
ArgumentNullException | Thrown if the scene is null.
ObjectDisposedException | Thrown if the context has already been disposed of.
See Also

Reference

AssimpContext Class
ExportFile Overload


AssimpContext.ExportFile Method (Scene, String, String, PostProcessSteps)

AssimpContextExportFile Method (Scene, String, String, PostProcessSteps)

Exports a scene to the specified format and writes it to a file.

Namespace: Assimp
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public bool ExportFile(
    Scene scene,
    string fileName,
    string exportFormatId,
    PostProcessSteps preProcessing
)

Parameters

scene
Type: AssimpScene
Scene containing the model to export.
fileName
Type: SystemString
Path to the file.
exportFormatId
Type: SystemString
FormatID representing the format to export to.
preProcessing
Type: AssimpPostProcessSteps
Preprocessing flags to apply to the model before it is exported.

Return Value

Type: Boolean
True if the scene was exported successfully, false otherwise.
Exceptions
Exception | Condition
ArgumentNullException | Thrown if the scene is null.
ObjectDisposedException | Thrown if the context has already been disposed of.
See Also

Reference

AssimpContext Class
ExportFile Overload


AssimpContext.ExportToBlob Method

AssimpContextExportToBlob Method

Overload List
 | Name | Description
Public method | ExportToBlob(Scene, String) | Exports a scene to the specified format and writes it to a data blob.
Public method | ExportToBlob(Scene, String, PostProcessSteps) | Exports a scene to the specified format and writes it to a data blob.
Top
See Also

Reference

AssimpContext Class


AssimpContext.ExportToBlob Method (Scene, String)

AssimpContextExportToBlob Method (Scene, String)

Exports a scene to the specified format and writes it to a data blob.

Namespace: Assimp
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public ExportDataBlob ExportToBlob(
    Scene scene,
    string exportFormatId
)

Parameters

scene
Type: AssimpScene
Scene containing the model to export.
exportFormatId
Type: SystemString
FormatID representing the format to export to.

Return Value

Type: ExportDataBlob
The resulting data blob, or null if the export failed.
Exceptions
Exception | Condition
ArgumentNullException | Thrown if the scene is null.
ObjectDisposedException | Thrown if the context has already been disposed of.
See Also

Reference

AssimpContext Class
ExportToBlob Overload


AssimpContext.ExportToBlob Method (Scene, String, PostProcessSteps)

AssimpContextExportToBlob Method (Scene, String, PostProcessSteps)

Exports a scene to the specified format and writes it to a data blob.

Namespace: Assimp
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public ExportDataBlob ExportToBlob(
    Scene scene,
    string exportFormatId,
    PostProcessSteps preProcessing
)

Parameters

scene
Type: AssimpScene
Scene containing the model to export.
exportFormatId
Type: SystemString
FormatID representing the format to export to.
preProcessing
Type: AssimpPostProcessSteps
Preprocessing flags to apply to the model before it is exported.

Return Value

Type: ExportDataBlob
The resulting data blob, or null if the export failed.
Exceptions
Exception | Condition
ArgumentNullException | Thrown if the scene is null.
ObjectDisposedException | Thrown if the context has already been disposed of.
See Also

Reference

AssimpContext Class
ExportToBlob Overload


AssimpContext.GetImporterDescriptionFor Method

AssimpContextGetImporterDescriptionFor Method

Gets an importer description for the specified file extension. If no importers support it, null is returned. Multiple importers may support the file extension, they are called in the order that they were registered.

Namespace: Assimp
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public ImporterDescription GetImporterDescriptionFor(
    string fileExtension
)

Parameters

fileExtension
Type: SystemString
File extension to query importer support for.

Return Value

Type: ImporterDescription
Importer description or null if it does not exist.
See Also

Reference

AssimpContext Class


AssimpContext.GetImporterDescriptions Method

AssimpContextGetImporterDescriptions Method

Gets descriptions for each importer that assimp has registered.

Namespace: Assimp
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public ImporterDescription[] GetImporterDescriptions()

Return Value

Type: ImporterDescription
Descriptions of supported importers.
See Also

Reference

AssimpContext Class


AssimpContext.GetSupportedExportFormats Method

AssimpContextGetSupportedExportFormats Method

Gets the model formats that are supported for export by Assimp.

Namespace: Assimp
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public ExportFormatDescription[] GetSupportedExportFormats()

Return Value

Type: ExportFormatDescription
Export formats supported
See Also

Reference

AssimpContext Class


AssimpContext.GetSupportedImportFormats Method

AssimpContextGetSupportedImportFormats Method

Gets the model formats that are supported for import by Assimp.

Namespace: Assimp
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public string[] GetSupportedImportFormats()

Return Value

Type: String
Import formats supported
See Also

Reference

AssimpContext Class


AssimpContext.ImportFile Method

AssimpContextImportFile Method

Overload List
 | Name | Description
Public method | ImportFile(String) | Imports a model from the specified file without running any post-process steps. The importer sets configurations and loads the model into managed memory, releasing the unmanaged memory used by Assimp.
Public method | ImportFile(String, PostProcessSteps) | Imports a model from the specified file. The importer sets configurations and loads the model into managed memory, releasing the unmanaged memory used by Assimp.
Top
See Also

Reference

AssimpContext Class


AssimpContext.ImportFile Method (String)

AssimpContextImportFile Method (String)

Imports a model from the specified file without running any post-process steps. The importer sets configurations and loads the model into managed memory, releasing the unmanaged memory used by Assimp.

Namespace: Assimp
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public Scene ImportFile(
    string file
)

Parameters

file
Type: SystemString
Full path to the file

Return Value

Type: Scene
The imported scene
Exceptions
Exception | Condition
AssimpException | Thrown if there was a general error in importing the model.
FileNotFoundException | Thrown if the file could not be located.
ObjectDisposedException | Thrown if the context has already been disposed of.
See Also

Reference

AssimpContext Class
ImportFile Overload


AssimpContext.ImportFile Method (String, PostProcessSteps)

AssimpContextImportFile Method (String, PostProcessSteps)

Imports a model from the specified file. The importer sets configurations and loads the model into managed memory, releasing the unmanaged memory used by Assimp.

Namespace: Assimp
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public Scene ImportFile(
    string file,
    PostProcessSteps postProcessFlags
)

Parameters

file
Type: SystemString
Full path to the file
postProcessFlags
Type: AssimpPostProcessSteps
Post processing flags, if any

Return Value

Type: Scene
The imported scene
Exceptions
Exception | Condition
AssimpException | Thrown if there was a general error in importing the model.
FileNotFoundException | Thrown if the file could not be located.
ObjectDisposedException | Thrown if the context has already been disposed of.
See Also

Reference

AssimpContext Class
ImportFile Overload


AssimpContext.ImportFileFromStream Method

AssimpContextImportFileFromStream Method

Overload List
 | Name | Description
Public method | ImportFileFromStream(Stream, String) | Imports a model from the stream without running any post-process steps. The importer sets configurations and loads the model into managed memory, releasing the unmanaged memory used by Assimp. It is up to the caller to dispose of the stream. If the format is distributed across multiple files/streams, set a custom IOSystem and use the "ImportFile" family of functions.
Public method | ImportFileFromStream(Stream, PostProcessSteps, String) | Imports a model from the stream. The importer sets configurations and loads the model into managed memory, releasing the unmanaged memory used by Assimp. It is up to the caller to dispose of the stream. If the format is distributed across multiple files/streams, set a custom IOSystem and use the "ImportFile" family of functions.
Top
See Also

Reference

AssimpContext Class


AssimpContext.ImportFileFromStream Method (Stream, String)

AssimpContextImportFileFromStream Method (Stream, String)

Imports a model from the stream without running any post-process steps. The importer sets configurations and loads the model into managed memory, releasing the unmanaged memory used by Assimp. It is up to the caller to dispose of the stream. If the format is distributed across multiple files/streams, set a custom IOSystem and use the "ImportFile" family of functions.

Namespace: Assimp
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public Scene ImportFileFromStream(
    Stream stream,
    string formatHint = null
)

Parameters

stream
Type: System.IOStream
Stream to read from
formatHint (Optional)
Type: SystemString
Optional format extension to serve as a hint to Assimp to choose which importer to use. If null or empty, the system will try to detect what importer to use from the data which may or may not be successful.

Return Value

Type: Scene
The imported scene
Exceptions
Exception | Condition
AssimpException | Thrown if the stream is not valid (null or write-only).
ObjectDisposedException | Thrown if the context has already been disposed of.
See Also

Reference

AssimpContext Class
ImportFileFromStream Overload


AssimpContext.ImportFileFromStream Method (Stream, PostProcessSteps, String)

AssimpContextImportFileFromStream Method (Stream, PostProcessSteps, String)

Imports a model from the stream. The importer sets configurations and loads the model into managed memory, releasing the unmanaged memory used by Assimp. It is up to the caller to dispose of the stream. If the format is distributed across multiple files/streams, set a custom IOSystem and use the "ImportFile" family of functions.

Namespace: Assimp
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public Scene ImportFileFromStream(
    Stream stream,
    PostProcessSteps postProcessFlags,
    string formatHint = null
)

Parameters

stream
Type: System.IOStream
Stream to read from
postProcessFlags
Type: AssimpPostProcessSteps
Post processing flags, if any
formatHint (Optional)
Type: SystemString
Optional format extension to serve as a hint to Assimp to choose which importer to use. If null or empty, the system will try to detect what importer to use from the data which may or may not be successful.

Return Value

Type: Scene
The imported scene
Exceptions
Exception | Condition
AssimpException | Thrown if the stream is not valid (null or write-only).
ObjectDisposedException | Thrown if the context has already been disposed of.
See Also

Reference

AssimpContext Class
ImportFileFromStream Overload


AssimpContext.IsExportFormatSupported Method

AssimpContextIsExportFormatSupported Method

Checks if the format extension (e.g. ".dae" or ".obj") is supported for export.

Namespace: Assimp
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public bool IsExportFormatSupported(
    string format
)

Parameters

format
Type: SystemString
Model format

Return Value

Type: Boolean
True if the format is supported, false otherwise
See Also

Reference

AssimpContext Class


AssimpContext.IsImportFormatSupported Method

AssimpContextIsImportFormatSupported Method

Checks if the format extension (e.g. ".dae" or ".obj") is supported for import.

Namespace: Assimp
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public bool IsImportFormatSupported(
    string format
)

Parameters

format
Type: SystemString
Model format

Return Value

Type: Boolean
True if the format is supported, false otherwise
See Also

Reference

AssimpContext Class


AssimpContext.RemoveConfig Method

AssimpContextRemoveConfig Method

Removes a set configuration property by name.

Namespace: Assimp
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public void RemoveConfig(
    string configName
)

Parameters

configName
Type: SystemString
Name of the config property
See Also

Reference

AssimpContext Class


AssimpContext.RemoveConfigs Method

AssimpContextRemoveConfigs Method

Removes all configuration properties from the context.

Namespace: Assimp
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public void RemoveConfigs()
See Also

Reference

AssimpContext Class


AssimpContext.RemoveIOSystem Method

AssimpContextRemoveIOSystem Method

Removes the currently set custom file system implementation from the importer.

Namespace: Assimp
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public void RemoveIOSystem()
See Also

Reference

AssimpContext Class


AssimpContext.SetConfig Method

AssimpContextSetConfig Method

Sets a configuration property to the context. This is only used during import.

Namespace: Assimp
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public void SetConfig(
    PropertyConfig config
)

Parameters

config
Type: Assimp.ConfigsPropertyConfig
Config to set
See Also

Reference

AssimpContext Class


AssimpContext.SetIOSystem Method

AssimpContextSetIOSystem Method

Sets a custom file system implementation that is used by this importer. If it is null, then the default assimp file system is used instead.

Namespace: Assimp
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public void SetIOSystem(
    IOSystem ioSystem
)

Parameters

ioSystem
Type: AssimpIOSystem
Custom file system implementation
See Also

Reference

AssimpContext Class


AssimpException Class

AssimpNet general exception.
Inheritance Hierarchy
SystemObject
SystemException
AssimpAssimpException

Namespace: Assimp
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public class AssimpException : Exception

The AssimpException type exposes the following members.

Constructors
 | Name | Description
Public method | AssimpException | Initializes a new instance of the AssimpException class.
Public method | AssimpException(String) | Initializes a new instance of the AssimpException class.
Public method | AssimpException(String, Exception) | Initializes a new instance of the AssimpException class.
Public method | AssimpException(String, String) | Initializes a new instance of the AssimpException class.
Top
Properties
 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Public property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Gets a message that describes the current exception. (Inherited from Exception.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception.)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)
Top
Events
 | Name | Description
Protected event | SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Inherited from Exception.)
Top
See Also

Reference


AssimpException Constructor

Overload List
 | Name | Description
Public method | AssimpException | Initializes a new instance of the AssimpException class.
Public method | AssimpException(String) | Initializes a new instance of the AssimpException class.
Public method | AssimpException(String, Exception) | Initializes a new instance of the AssimpException class.
Public method | AssimpException(String, String) | Initializes a new instance of the AssimpException class.
Top
See Also

Reference

AssimpException Class


AssimpException Constructor

Initializes a new instance of the AssimpException class.

Namespace: Assimp
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public AssimpException()
See Also

Reference

AssimpException Class
AssimpException Overload


AssimpException Constructor (String)

Initializes a new instance of the AssimpException class.

Namespace: Assimp
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public AssimpException(
    string msg
)

Parameters

msg
Type: SystemString
The error message.
See Also

Reference

AssimpException Class
AssimpException Overload


AssimpException Constructor (String, Exception)

Initializes a new instance of the AssimpException class.

Namespace: Assimp
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public AssimpException(
    string msg,
    Exception innerException
)

Parameters

msg
Type: SystemString
The error message
innerException
Type: SystemException
The inner exception.
See Also

Reference

AssimpException Class
AssimpException Overload


AssimpException Constructor (String, String)

Initializes a new instance of the AssimpException class.

Namespace: Assimp
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public AssimpException(
    string paramName,
    string msg
)

Parameters

paramName
Type: SystemString
Name of the param.
msg
Type: SystemString
The error message.
See Also

Reference

AssimpException Class
AssimpException Overload


AssimpException Properties

The AssimpException type exposes the following members.

Properties
 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Public property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Gets a message that describes the current exception. (Inherited from Exception.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)
Top
See Also

Reference

AssimpException Class


AssimpException Methods

The AssimpException type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception.)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)
Top
See Also

Reference

AssimpException Class


AssimpException Events

The AssimpException type exposes the following members.

Events
 | Name | Description
Protected event | SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Inherited from Exception.)
Top
See Also

Reference

AssimpException Class


BlendMode Enumeration

Defines alpha blending flags, how the final color value of a pixel is computed, based on the following equation:

sourceColor * sourceBlend + destColor * destBlend

Where the destColor is the previous color in the frame buffer and sourceColor is the material color before the transparency calculation. This corresponds to the AI_MATKEY_BLEND_FUNC property.

Namespace: Assimp
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public enum BlendMode
Members
Member name | Value | Description
Default | 0 | Default blending: sourceColor * sourceAlpha + destColor * (1 - sourceAlpha)
Additive | 1 | Additive blending: sourcecolor * 1 + destColor * 1.
See Also

Reference


Bone Class

Represents a single bone of a mesh. A bone has a name which allows it to be found in the frame hierarchy and by which it can be addressed by animations. In addition it has a number of influences on vertices.
Inheritance Hierarchy
SystemObject
AssimpBone

Namespace: Assimp
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public sealed class Bone : IMarshalable<Bone, AiBone>

The Bone type exposes the following members.

Constructors
 | Name | Description
Public method | Bone | Constructs a new instance of the Bone class.
Public method | Bone(String, Matrix3x3, VertexWeight) | Constructs a new instance of the Bone class.
Top
Properties
 | Name | Description
Public property | HasVertexWeights | Gets if the bone has vertex weights - this should always be true.
Public property | Name | Gets or sets the name of the bone.
Public property | OffsetMatrix | Gets or sets the matrix that transforms from mesh space to bone space in bind pose.
Public property | VertexWeightCount | Gets the number of vertex influences the bone contains.
Public property | VertexWeights | Gets the vertex weights owned by the bone.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
 | FreeNative | Frees unmanaged memory created by ToNative(IntPtr, Native).
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference


Bone Constructor

Overload List
 | Name | Description
Public method | Bone | Constructs a new instance of the Bone class.
Public method | Bone(String, Matrix3x3, VertexWeight) | Constructs a new instance of the Bone class.
Top
See Also

Reference

Bone Class


Bone Constructor

Constructs a new instance of the Bone class.

Namespace: Assimp
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public Bone()
See Also

Reference

Bone Class
Bone Overload


Bone Constructor (String, Matrix3x3, VertexWeight[])

Bone Constructor (String, Matrix3x3, VertexWeight)

Constructs a new instance of the Bone class.

Namespace: Assimp
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public Bone(
    string name,
    Matrix3x3 offsetMatrix,
    VertexWeight[] weights
)

Parameters

name
Type: SystemString
Name of the bone
offsetMatrix
Type: AssimpMatrix3x3
Bone's offset matrix
weights
Type: AssimpVertexWeight
Vertex weights
See Also

Reference

Bone Class
Bone Overload


Bone Properties

The Bone type exposes the following members.

Properties
 | Name | Description
Public property | HasVertexWeights | Gets if the bone has vertex weights - this should always be true.
Public property | Name | Gets or sets the name of the bone.
Public property | OffsetMatrix | Gets or sets the matrix that transforms from mesh space to bone space in bind pose.
Public property | VertexWeightCount | Gets the number of vertex influences the bone contains.
Public property | VertexWeights | Gets the vertex weights owned by the bone.
Top
See Also

Reference

Bone Class


Bone.HasVertexWeights Property

BoneHasVertexWeights Property

Gets if the bone has vertex weights - this should always be true.

Namespace: Assimp
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public bool HasVertexWeights { get; }

Property Value

Type: Boolean
See Also

Reference

Bone Class


Bone.Name Property

BoneName Property

Gets or sets the name of the bone.

Namespace: Assimp
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public string Name { get; set; }

Property Value

Type: String
See Also

Reference

Bone Class


Bone.OffsetMatrix Property

BoneOffsetMatrix Property

Gets or sets the matrix that transforms from mesh space to bone space in bind pose.

Namespace: Assimp
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public Matrix4x4 OffsetMatrix { get; set; }

Property Value

Type: Matrix4x4
See Also

Reference

Bone Class


Bone.VertexWeightCount Property

BoneVertexWeightCount Property

Gets the number of vertex influences the bone contains.

Namespace: Assimp
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public int VertexWeightCount { get; }

Property Value

Type: Int32
See Also

Reference

Bone Class


Bone.VertexWeights Property

BoneVertexWeights Property

Gets the vertex weights owned by the bone.

Namespace: Assimp
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public List VertexWeights { get; }

Property Value

Type: ListT
See Also

Reference

Bone Class


Bone Methods

The Bone type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
 | FreeNative | Frees unmanaged memory created by ToNative(IntPtr, Native).
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Bone Class


Bone.FreeNative Method

BoneFreeNative Method

Frees unmanaged memory created by ToNative(IntPtr, Native).

Namespace: Assimp
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public static void FreeNative(
    IntPtr nativeValue,
    bool freeNative
)

Parameters

nativeValue
Type: SystemIntPtr
Native value to free
freeNative
Type: SystemBoolean
True if the unmanaged memory should be freed, false otherwise.
See Also

Reference

Bone Class


Camera Class

Describes a right-handed camera in the scene. An important aspect is that the camera itself is also part of the scenegraph, meaning any values such as the direction vector are not *absolute*, they can be relative to the coordinate system defined by the node which corresponds to the camera. This allows for camera animations.
Inheritance Hierarchy
SystemObject
AssimpCamera

Namespace: Assimp
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public sealed class Camera : IMarshalable<Camera, AiCamera>

The Camera type exposes the following members.

Constructors
 | Name | Description
Public method | Camera | Constructs a new instance of the Camera class.
Top
Properties
 | Name | Description
Public property | AspectRatio | Gets or sets the screen aspect ratio. This is the ratio between the width and height of the screen. Typical values are 4/3, 1/2, or 1/1. This value is 0 if the aspect ratio is not defined in the source file. The default value is zero.
Public property | ClipPlaneFar | Gets or sets the distance of the far clipping plane from the camera. The far clippling plane must be further than the near clippling plane. The default value is 1000.0f. The ratio between the near and far plane should not be too large (between 1000 - 10000 should be ok) to avoid floating-point inaccuracies which can lead to z-fighting.
Public property | ClipPlaneNear | Gets or sets the distance of the near clipping plane from the camera. The value may not be 0.0f for arithmetic reasons to prevent a division through zero. The default value is 0.1f;
Public property | Direction | Gets or sets the viewing direction of the camera, relative to the coordinate space defined by the corresponding node. The default value is 0|0|1.
Public property | FieldOfview | Gets or sets the half horizontal field of view angle, in radians. The FoV angle is the angle between the center line of the screen and the left or right border. The default value is 1/4PI.
Public property | Name | Gets or sets the name of the camera. This corresponds to a node in the scenegraph with the same name. This node specifies the position of the camera in the scene hierarchy and can be animated.
Public property | Position | Gets or sets the position of the camera relative to the coordinate space defined by the corresponding node. THe default value is 0|0|0.
Public property | Up | Gets or sets the 'up' vector of the camera, relative to the coordinate space defined by the corresponding node. The 'right' vector of the camera is the cross product of the up and direction vectors. The default value is 0|1|0.
Public property | ViewMatrix | Gets a right-handed view matrix.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
 | FreeNative | Frees unmanaged memory created by ToNative(IntPtr, Native).
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference


Camera Constructor

Constructs a new instance of the Camera class.

Namespace: Assimp
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public Camera()
See Also

Reference

Camera Class


Camera Properties

The Camera type exposes the following members.

Properties
 | Name | Description
Public property | AspectRatio | Gets or sets the screen aspect ratio. This is the ratio between the width and height of the screen. Typical values are 4/3, 1/2, or 1/1. This value is 0 if the aspect ratio is not defined in the source file. The default value is zero.
Public property | ClipPlaneFar | Gets or sets the distance of the far clipping plane from the camera. The far clippling plane must be further than the near clippling plane. The default value is 1000.0f. The ratio between the near and far plane should not be too large (between 1000 - 10000 should be ok) to avoid floating-point inaccuracies which can lead to z-fighting.
Public property | ClipPlaneNear | Gets or sets the distance of the near clipping plane from the camera. The value may not be 0.0f for arithmetic reasons to prevent a division through zero. The default value is 0.1f;
Public property | Direction | Gets or sets the viewing direction of the camera, relative to the coordinate space defined by the corresponding node. The default value is 0|0|1.
Public property | FieldOfview | Gets or sets the half horizontal field of view angle, in radians. The FoV angle is the angle between the center line of the screen and the left or right border. The default value is 1/4PI.
Public property | Name | Gets or sets the name of the camera. This corresponds to a node in the scenegraph with the same name. This node specifies the position of the camera in the scene hierarchy and can be animated.
Public property | Position | Gets or sets the position of the camera relative to the coordinate space defined by the corresponding node. THe default value is 0|0|0.
Public property | Up | Gets or sets the 'up' vector of the camera, relative to the coordinate space defined by the corresponding node. The 'right' vector of the camera is the cross product of the up and direction vectors. The default value is 0|1|0.
Public property | ViewMatrix | Gets a right-handed view matrix.
Top
See Also

Reference

Camera Class


Camera.AspectRatio Property

CameraAspectRatio Property

Gets or sets the screen aspect ratio. This is the ratio between the width and height of the screen. Typical values are 4/3, 1/2, or 1/1. This value is 0 if the aspect ratio is not defined in the source file. The default value is zero.

Namespace: Assimp
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public float AspectRatio { get; set; }

Property Value

Type: Single
See Also

Reference

Camera Class


Camera.ClipPlaneFar Property

CameraClipPlaneFar Property

Gets or sets the distance of the far clipping plane from the camera. The far clippling plane must be further than the near clippling plane. The default value is 1000.0f. The ratio between the near and far plane should not be too large (between 1000 - 10000 should be ok) to avoid floating-point inaccuracies which can lead to z-fighting.

Namespace: Assimp
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public float ClipPlaneFar { get; set; }

Property Value

Type: Single
See Also

Reference

Camera Class


Camera.ClipPlaneNear Property

CameraClipPlaneNear Property

Gets or sets the distance of the near clipping plane from the camera. The value may not be 0.0f for arithmetic reasons to prevent a division through zero. The default value is 0.1f;

Namespace: Assimp
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public float ClipPlaneNear { get; set; }

Property Value

Type: Single
See Also

Reference

Camera Class


Camera.Direction Property

CameraDirection Property

Gets or sets the viewing direction of the camera, relative to the coordinate space defined by the corresponding node. The default value is 0|0|1.

Namespace: Assimp
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public Vector3D Direction { get; set; }

Property Value

Type: Vector3D
See Also

Reference

Camera Class


Camera.FieldOfview Property

CameraFieldOfview Property

Gets or sets the half horizontal field of view angle, in radians. The FoV angle is the angle between the center line of the screen and the left or right border. The default value is 1/4PI.

Namespace: Assimp
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public float FieldOfview { get; set; }

Property Value

Type: Single
See Also

Reference

Camera Class


Camera.Name Property

CameraName Property

Gets or sets the name of the camera. This corresponds to a node in the scenegraph with the same name. This node specifies the position of the camera in the scene hierarchy and can be animated.

Namespace: Assimp
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public string Name { get; set; }

Property Value

Type: String
See Also

Reference

Camera Class


Camera.Position Property

CameraPosition Property

Gets or sets the position of the camera relative to the coordinate space defined by the corresponding node. THe default value is 0|0|0.

Namespace: Assimp
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public Vector3D Position { get; set; }

Property Value

Type: Vector3D
See Also

Reference

Camera Class


Camera.Up Property

CameraUp Property

Gets or sets the 'up' vector of the camera, relative to the coordinate space defined by the corresponding node. The 'right' vector of the camera is the cross product of the up and direction vectors. The default value is 0|1|0.

Namespace: Assimp
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public Vector3D Up { get; set; }

Property Value

Type: Vector3D
See Also

Reference

Camera Class


Camera.ViewMatrix Property

CameraViewMatrix Property

Gets a right-handed view matrix.

Namespace: Assimp
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public Matrix4x4 ViewMatrix { get; }

Property Value

Type: Matrix4x4
See Also

Reference

Camera Class


Camera Methods

The Camera type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
 | FreeNative | Frees unmanaged memory created by ToNative(IntPtr, Native).
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Camera Class


Camera.FreeNative Method

CameraFreeNative Method

Frees unmanaged memory created by ToNative(IntPtr, Native).

Namespace: Assimp
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public static void FreeNative(
    IntPtr nativeValue,
    bool freeNative
)

Parameters

nativeValue
Type: SystemIntPtr
Native value to free
freeNative
Type: SystemBoolean
True if the unmanaged memory should be freed, false otherwise.
See Also

Reference

Camera Class


Color3D Structure

Represents a RGB color.

Namespace: Assimp
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public struct Color3D

The Color3D type exposes the following members.

Constructors
 | Name | Description
Public method | Color3D(Single) | Constructs a Color3D where each component is set to the same value.
Public method | Color3D(Single, Single, Single) | Constructs a Color3D.
Top
Properties
 | Name | Description
Public property | Item | Gets or sets the component value at the specified zero-based index in the order of RGBA (index 0 access R, 1 access G, etc). If the index is not in range, a value of zero is returned.
Top
Methods
 | Name | Description
Public method | Equals(Object) | Tests equality between this color and another object. (Overrides ValueTypeEquals(Object).)
Public method | Equals(Color3D) | Tests equality between this color and another color
Public method | GetHashCode | Returns a hash code for this instance. (Overrides ValueTypeGetHashCode.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsBlack | Determines if the color is black, or close to being black.
Public method | ToString | Returns a String that represents this instance. (Overrides ValueTypeToString.)
Top
Operators
Name | Description
Addition(Single, Color3D) | Adds the value to each of the components of the color.
Addition(Color3D, Color3D) | Adds the two colors together.
Addition(Color3D, Single) | Adds the value to each of the components of the color.
Division(Color3D, Color3D) | Divides the first color by the second color, component wise.
Division(Color3D, Single) | Divides the color by a divisor value.
Equality | Tets equality between two colors.
Inequality | Tets inequality between two colors.
Multiply(Single, Color3D) | Multiplies the color by a scalar value, component wise.
Multiply(Color3D, Color3D) | Multiplies the two colors.
Multiply(Color3D, Single) | Multiplies the color by a scalar value, component wise.
Subtraction(Single, Color3D) | Subtracts the color's components from the value, returning the result as a new color. Same as new Color4D(value) - color
Subtraction(Color3D, Color3D) | Subtracts the second color from the first color.
Subtraction(Color3D, Single) | Subtracts the value from each of the color's components.
Top
Fields
 | Name | Description
Public field | B | Blue component.
Public field | G | Green component.
Public field | R | Red component.
Top
See Also

Reference


Color3D Constructor

Overload List
 | Name | Description
Public method | Color3D(Single) | Constructs a Color3D where each component is set to the same value.
Public method | Color3D(Single, Single, Single) | Constructs a Color3D.
Top
See Also

Reference

Color3D Structure


Color3D Constructor (Single)

Constructs a Color3D where each component is set to the same value.

Namespace: Assimp
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public Color3D(
    float value
)

Parameters

value
Type: SystemSingle
Value to set R, G, B components
See Also

Reference

Color3D Structure
Color3D Overload


Color3D Constructor (Single, Single, Single)

Constructs a Color3D.

Namespace: Assimp
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public Color3D(
    float r,
    float g,
    float b
)

Parameters

r
Type: SystemSingle
Red component
g
Type: SystemSingle
Green component
b
Type: SystemSingle
Blue component
See Also

Reference

Color3D Structure
Color3D Overload


Color3D Properties

The Color3D type exposes the following members.

Properties
 | Name | Description
Public property | Item | Gets or sets the component value at the specified zero-based index in the order of RGBA (index 0 access R, 1 access G, etc). If the index is not in range, a value of zero is returned.
Top
See Also

Reference

Color3D Structure


Color3D.Item Property

Color3DItem Property

Gets or sets the component value at the specified zero-based index in the order of RGBA (index 0 access R, 1 access G, etc). If the index is not in range, a value of zero is returned.

Namespace: Assimp
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public float this[
    int index
] { get; set; }

Parameters

index
Type: SystemInt32
Zero-based index.

Return Value

Type: Single
The component value
See Also

Reference

Color3D Structure


Color3D Methods

The Color3D type exposes the following members.

Methods
 | Name | Description
Public method | Equals(Object) | Tests equality between this color and another object. (Overrides ValueTypeEquals(Object).)
Public method | Equals(Color3D) | Tests equality between this color and another color
Public method | GetHashCode | Returns a hash code for this instance. (Overrides ValueTypeGetHashCode.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsBlack | Determines if the color is black, or close to being black.
Public method | ToString | Returns a String that represents this instance. (Overrides ValueTypeToString.)
Top
See Also

Reference

Color3D Structure


Color3D.Equals Method

Color3DEquals Method

Overload List
 | Name | Description
Public method | Equals(Object) | Tests equality between this color and another object. (Overrides ValueTypeEquals(Object).)
Public method | Equals(Color3D) | Tests equality between this color and another color
Top
See Also

Reference

Color3D Structure


Color3D.Equals Method (Object)

Color3DEquals Method (Object)

Tests equality between this color and another object.

Namespace: Assimp
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public override bool Equals(
    Object obj
)

Parameters

obj
Type: SystemObject
Object to test against

Return Value

Type: Boolean
True if the object is a color and the components are equal
See Also

Reference

Color3D Structure
Equals Overload


Color3D.Equals Method (Color3D)

Color3DEquals Method (Color3D)

Tests equality between this color and another color

Namespace: Assimp
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public bool Equals(
    Color3D other
)

Parameters

other
Type: AssimpColor3D
Color to test against

Return Value

Type: Boolean
True if components are equal
See Also

Reference

Color3D Structure
Equals Overload


Color3D.GetHashCode Method

Color3DGetHashCode Method

Returns a hash code for this instance.

Namespace: Assimp
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public override int GetHashCode()

Return Value

Type: Int32
A hash code for this instance, suitable for use in hashing algorithms and data structures like a hash table.
See Also

Reference

Color3D Structure


Color3D.IsBlack Method

Color3DIsBlack Method

Determines if the color is black, or close to being black.

Namespace: Assimp
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public bool IsBlack()

Return Value

Type: Boolean
True if the color is black/nearly block, false otherwise.
See Also

Reference

Color3D Structure


Color3D.ToString Method

Color3DToString Method

Returns a String that represents this instance.

Namespace: Assimp
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public override string ToString()

Return Value

Type: String
A String that represents this instance.
See Also

Reference

Color3D Structure


Color3D Operators

The Color3D type exposes the following members.

Operators
Name | Description
Addition(Single, Color3D) | Adds the value to each of the components of the color.
Addition(Color3D, Color3D) | Adds the two colors together.
Addition(Color3D, Single) | Adds the value to each of the components of the color.
Division(Color3D, Color3D) | Divides the first color by the second color, component wise.
Division(Color3D, Single) | Divides the color by a divisor value.
Equality | Tets equality between two colors.
Inequality | Tets inequality between two colors.
Multiply(Single, Color3D) | Multiplies the color by a scalar value, component wise.
Multiply(Color3D, Color3D) | Multiplies the two colors.
Multiply(Color3D, Single) | Multiplies the color by a scalar value, component wise.
Subtraction(Single, Color3D) | Subtracts the color's components from the value, returning the result as a new color. Same as new Color4D(value) - color
Subtraction(Color3D, Color3D) | Subtracts the second color from the first color.
Subtraction(Color3D, Single) | Subtracts the value from each of the color's components.
Top
See Also

Reference

Color3D Structure


Color3D.Addition Operator

Color3DAddition Operator

Overload List
Name | Description
Addition(Single, Color3D) | Adds the value to each of the components of the color.
Addition(Color3D, Color3D) | Adds the two colors together.
Addition(Color3D, Single) | Adds the value to each of the components of the color.
Top
See Also

Reference

Color3D Structure


Color3D.Addition Operator (Single, Color3D)

Color3DAddition Operator (Single, Color3D)

Adds the value to each of the components of the color.

Namespace: Assimp
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public static Color3D operator +(
    float value,
    Color3D color
)

Parameters

value
Type: SystemSingle
Value to add to each component
color
Type: AssimpColor3D
Source color

Return Value

Type: Color3D
Added color
See Also

Reference

Color3D Structure
Addition Overload


Color3D.Addition Operator (Color3D, Color3D)

Color3DAddition Operator (Color3D, Color3D)

Adds the two colors together.

Namespace: Assimp
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public static Color3D operator +(
    Color3D a,
    Color3D b
)

Parameters

a
Type: AssimpColor3D
First color
b
Type: AssimpColor3D
Second color

Return Value

Type: Color3D
Added color
See Also

Reference

Color3D Structure
Addition Overload


Color3D.Addition Operator (Color3D, Single)

Color3DAddition Operator (Color3D, Single)

Adds the value to each of the components of the color.

Namespace: Assimp
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public static Color3D operator +(
    Color3D color,
    float value
)

Parameters

color
Type: AssimpColor3D
Source color
value
Type: SystemSingle
Value to add to each component

Return Value

Type: Color3D
Added color
See Also

Reference

Color3D Structure
Addition Overload


Color3D.Division Operator

Color3DDivision Operator

Overload List
Name | Description
Division(Color3D, Color3D) | Divides the first color by the second color, component wise.
Division(Color3D, Single) | Divides the color by a divisor value.
Top
See Also

Reference

Color3D Structure


Color3D.Division Operator (Color3D, Color3D)

Color3DDivision Operator (Color3D, Color3D)

Divides the first color by the second color, component wise.

Namespace: Assimp
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public static Color3D operator /(
    Color3D a,
    Color3D b
)

Parameters

a
Type: AssimpColor3D
First color
b
Type: AssimpColor3D
Second color

Return Value

Type: Color3D
Resulting color
See Also

Reference

Color3D Structure
Division Overload


Color3D.Division Operator (Color3D, Single)

Color3DDivision Operator (Color3D, Single)

Divides the color by a divisor value.

Namespace: Assimp
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public static Color3D operator /(
    Color3D color,
    float divisor
)

Parameters

color
Type: AssimpColor3D
Source color
divisor
Type: SystemSingle
Divisor

Return Value

Type: Color3D
Resulting color
See Also

Reference

Color3D Structure
Division Overload


Color3D.Equality Operator

Color3DEquality Operator

Tets equality between two colors.

Namespace: Assimp
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public static bool operator ==(
    Color3D a,
    Color3D b
)

Parameters

a
Type: AssimpColor3D
First color
b
Type: AssimpColor3D
Second color

Return Value

Type: Boolean
True if the colors are equal, false otherwise
See Also

Reference

Color3D Structure


Color3D.Inequality Operator

Color3DInequality Operator

Tets inequality between two colors.

Namespace: Assimp
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public static bool operator !=(
    Color3D a,
    Color3D b
)

Parameters

a
Type: AssimpColor3D
First color
b
Type: AssimpColor3D
Second color

Return Value

Type: Boolean
True if the colors are not equal, false otherwise
See Also

Reference

Color3D Structure


Color3D.Multiply Operator

Color3DMultiply Operator

Overload List
Name | Description
Multiply(Single, Color3D) | Multiplies the color by a scalar value, component wise.
Multiply(Color3D, Color3D) | Multiplies the two colors.
Multiply(Color3D, Single) | Multiplies the color by a scalar value, component wise.
Top
See Also

Reference

Color3D Structure


Color3D.Multiply Operator (Single, Color3D)

Color3DMultiply Operator (Single, Color3D)

Multiplies the color by a scalar value, component wise.

Namespace: Assimp
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public static Color3D operator *(
    float scale,
    Color3D value
)

Parameters

scale
Type: SystemSingle
Scalar value
value
Type: AssimpColor3D
Source color

Return Value

Type: Color3D
Resulting color
See Also

Reference

Color3D Structure
Multiply Overload


Color3D.Multiply Operator (Color3D, Color3D)

Color3DMultiply Operator (Color3D, Color3D)

Multiplies the two colors.

Namespace: Assimp
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public static Color3D operator *(
    Color3D a,
    Color3D b
)

Parameters

a
Type: AssimpColor3D
First color
b
Type: AssimpColor3D
Second color

Return Value

Type: Color3D
Multiplied color.
See Also

Reference

Color3D Structure
Multiply Overload


Color3D.Multiply Operator (Color3D, Single)

Color3DMultiply Operator (Color3D, Single)

Multiplies the color by a scalar value, component wise.

Namespace: Assimp
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public static Color3D operator *(
    Color3D value,
    float scale
)

Parameters

value
Type: AssimpColor3D
Source color
scale
Type: SystemSingle
Scalar value

Return Value

Type: Color3D
Resulting color
See Also

Reference

Color3D Structure
Multiply Overload


Color3D.Subtraction Operator

Color3DSubtraction Operator

Overload List
Name | Description
Subtraction(Single, Color3D) | Subtracts the color's components from the value, returning the result as a new color. Same as new Color4D(value) - color
Subtraction(Color3D, Color3D) | Subtracts the second color from the first color.
Subtraction(Color3D, Single) | Subtracts the value from each of the color's components.
Top
See Also

Reference

Color3D Structure


Color3D.Subtraction Operator (Single, Color3D)

Color3DSubtraction Operator (Single, Color3D)

Subtracts the color's components from the value, returning the result as a new color. Same as new Color4D(value) - color

Namespace: Assimp
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public static Color3D operator -(
    float value,
    Color3D color
)

Parameters

value
Type: SystemSingle
Value for each component of the first color
color
Type: AssimpColor3D
Second color

Return Value

Type: Color3D
Resulting color
See Also

Reference

Color3D Structure
Subtraction Overload


Color3D.Subtraction Operator (Color3D, Color3D)

Color3DSubtraction Operator (Color3D, Color3D)

Subtracts the second color from the first color.

Namespace: Assimp
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public static Color3D operator -(
    Color3D a,
    Color3D b
)

Parameters

a
Type: AssimpColor3D
First color
b
Type: AssimpColor3D
Second color

Return Value

Type: Color3D
Resulting color
See Also

Reference

Color3D Structure
Subtraction Overload


Color3D.Subtraction Operator (Color3D, Single)

Color3DSubtraction Operator (Color3D, Single)

Subtracts the value from each of the color's components.

Namespace: Assimp
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public static Color3D operator -(
    Color3D color,
    float value
)

Parameters

color
Type: AssimpColor3D
Source color
value
Type: SystemSingle
Value to subtract from each component

Return Value

Type: Color3D
Resulting color
See Also

Reference

Color3D Structure
Subtraction Overload


Color3D Fields

The Color3D type exposes the following members.

Fields
 | Name | Description
Public field | B | Blue component.
Public field | G | Green component.
Public field | R | Red component.
Top
See Also

Reference

Color3D Structure


Color3D.B Field

Color3DB Field

Blue component.

Namespace: Assimp
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public float B

Field Value

Type: Single
See Also

Reference

Color3D Structure


Color3D.G Field

Color3DG Field

Green component.

Namespace: Assimp
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public float G

Field Value

Type: Single
See Also

Reference

Color3D Structure


Color3D.R Field

Color3DR Field

Red component.

Namespace: Assimp
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public float R

Field Value

Type: Single
See Also

Reference

Color3D Structure


Color4D Structure

Represents a Red-Green-Blue-Alpha (RGBA) color. Color values range from 0 to 1.

Namespace: Assimp
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public struct Color4D : IEquatable<Color4D>

The Color4D type exposes the following members.

Constructors
 | Name | Description
Public method | Color4D(Single) | Constructs a Color4D where each component is set to the same value.
Public method | Color4D(Color3D) | Constructs a Color4D from a Color3D. Alpha is set to 1.0.
Public method | Color4D(Color3D, Single) | Constructs a Color4D from a Color3D and alpha value.
Public method | Color4D(Single, Single, Single) | Constructs a Color4D. Alpha is set to 1.0.
Public method | Color4D(Single, Single, Single, Single) | Constructs a Color4D.
Top
Properties
 | Name | Description
Public property | Item | Gets or sets the component value at the specified zero-based index in the order of RGBA (index 0 access R, 1 access G, etc). If the index is not in range, a value of zero is returned.
Top
Methods
 | Name | Description
Public method | Equals(Object) | Tests equality between this color and another object. (Overrides ValueTypeEquals(Object).)
Public method | Equals(Color4D) | Tests equality between this color and another color
Public method | GetHashCode | Returns a hash code for this instance. (Overrides ValueTypeGetHashCode.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsBlack | Determines if the color is black, or close to being black.
Public method | ToString | Returns a String that represents this instance. (Overrides ValueTypeToString.)
Top
Operators
Name | Description
Addition(Single, Color4D) | Adds the value to each of the components of the color.
Addition(Color4D, Color4D) | Adds the two colors together.
Addition(Color4D, Single) | Adds the value to each of the components of the color.
Division(Color4D, Color4D) | Divides the first color by the second color, component wise.
Division(Color4D, Single) | Divides the color by a divisor value.
Equality | Tets equality between two colors.
Inequality | Tets inequality between two colors.
Multiply(Single, Color4D) | Multiplies the color by a scalar value, component wise.
Multiply(Color4D, Color4D) | Multiplies the two colors.
Multiply(Color4D, Single) | Multiplies the color by a scalar value, component wise.
Subtraction(Single, Color4D) | Subtracts the color's components from the value, returning the result as a new color. Same as new Color4D(value) - color
Subtraction(Color4D, Color4D) | Subtracts the second color from the first color.
Subtraction(Color4D, Single) | Subtracts the value from each of the color's components.
Top
Fields
 | Name | Description
Public field | A | Alpha component.
Public field | B | Blue component.
Public field | G | Green component.
Public field | R | Red component.
Top
See Also

Reference


Color4D Constructor

Overload List
 | Name | Description
Public method | Color4D(Single) | Constructs a Color4D where each component is set to the same value.
Public method | Color4D(Color3D) | Constructs a Color4D from a Color3D. Alpha is set to 1.0.
Public method | Color4D(Color3D, Single) | Constructs a Color4D from a Color3D and alpha value.
Public method | Color4D(Single, Single, Single) | Constructs a Color4D. Alpha is set to 1.0.
Public method | Color4D(Single, Single, Single, Single) | Constructs a Color4D.
Top
See Also

Reference

Color4D Structure


Color4D Constructor (Single)

Constructs a Color4D where each component is set to the same value.

Namespace: Assimp
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public Color4D(
    float value
)

Parameters

value
Type: SystemSingle
Value to set R, G, B, A components
See Also

Reference

Color4D Structure
Color4D Overload


Color4D Constructor (Color3D)

Constructs a Color4D from a Color3D. Alpha is set to 1.0.

Namespace: Assimp
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public Color4D(
    Color3D rgb
)

Parameters

rgb
Type: AssimpColor3D
RGB values
See Also

Reference

Color4D Structure
Color4D Overload


Color4D Constructor (Color3D, Single)

Constructs a Color4D from a Color3D and alpha value.

Namespace: Assimp
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public Color4D(
    Color3D rgb,
    float alpha
)

Parameters

rgb
Type: AssimpColor3D
RGB values
alpha
Type: SystemSingle
Alpha value
See Also

Reference

Color4D Structure
Color4D Overload


Color4D Constructor (Single, Single, Single)

Constructs a Color4D. Alpha is set to 1.0.

Namespace: Assimp
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public Color4D(
    float r,
    float g,
    float b
)

Parameters

r
Type: SystemSingle
Red component
g
Type: SystemSingle
Green component
b
Type: SystemSingle
Blue component
See Also

Reference

Color4D Structure
Color4D Overload


Color4D Constructor (Single, Single, Single, Single)

Constructs a Color4D.

Namespace: Assimp
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public Color4D(
    float r,
    float g,
    float b,
    float a
)

Parameters

r
Type: SystemSingle
Red component
g
Type: SystemSingle
Green component
b
Type: SystemSingle
Blue component
a
Type: SystemSingle
Alpha component
See Also

Reference

Color4D Structure
Color4D Overload


Color4D Properties

The Color4D type exposes the following members.

Properties
 | Name | Description
Public property | Item | Gets or sets the component value at the specified zero-based index in the order of RGBA (index 0 access R, 1 access G, etc). If the index is not in range, a value of zero is returned.
Top
See Also

Reference

Color4D Structure


Color4D.Item Property

Color4DItem Property

Gets or sets the component value at the specified zero-based index in the order of RGBA (index 0 access R, 1 access G, etc). If the index is not in range, a value of zero is returned.

Namespace: Assimp
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public float this[
    int index
] { get; set; }

Parameters

index
Type: SystemInt32
Zero-based index.

Return Value

Type: Single
The component value
See Also

Reference

Color4D Structure


Color4D Methods

The Color4D type exposes the following members.

Methods
 | Name | Description
Public method | Equals(Object) | Tests equality between this color and another object. (Overrides ValueTypeEquals(Object).)
Public method | Equals(Color4D) | Tests equality between this color and another color
Public method | GetHashCode | Returns a hash code for this instance. (Overrides ValueTypeGetHashCode.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsBlack | Determines if the color is black, or close to being black.
Public method | ToString | Returns a String that represents this instance. (Overrides ValueTypeToString.)
Top
See Also

Reference

Color4D Structure


Color4D.Equals Method

Color4DEquals Method

Overload List
 | Name | Description
Public method | Equals(Object) | Tests equality between this color and another object. (Overrides ValueTypeEquals(Object).)
Public method | Equals(Color4D) | Tests equality between this color and another color
Top
See Also

Reference

Color4D Structure


Color4D.Equals Method (Object)

Color4DEquals Method (Object)

Tests equality between this color and another object.

Namespace: Assimp
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public override bool Equals(
    Object obj
)

Parameters

obj
Type: SystemObject
Object to test against

Return Value

Type: Boolean
True if the object is a color and the components are equal
See Also

Reference

Color4D Structure
Equals Overload


Color4D.Equals Method (Color4D)

Color4DEquals Method (Color4D)

Tests equality between this color and another color

Namespace: Assimp
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public bool Equals(
    Color4D other
)

Parameters

other
Type: AssimpColor4D
Color to test against

Return Value

Type: Boolean
True if components are equal

Implements

IEquatableTEquals(T)
See Also

Reference

Color4D Structure
Equals Overload


Color4D.GetHashCode Method

Color4DGetHashCode Method

Returns a hash code for this instance.

Namespace: Assimp
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public override int GetHashCode()

Return Value

Type: Int32
A hash code for this instance, suitable for use in hashing algorithms and data structures like a hash table.
See Also

Reference

Color4D Structure


Color4D.IsBlack Method

Color4DIsBlack Method

Determines if the color is black, or close to being black.

Namespace: Assimp
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public bool IsBlack()

Return Value

Type: Boolean
True if the color is black/nearly block, false otherwise.
See Also

Reference

Color4D Structure


Color4D.ToString Method

Color4DToString Method

Returns a String that represents this instance.

Namespace: Assimp
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public override string ToString()

Return Value

Type: String
A String that represents this instance.
See Also

Reference

Color4D Structure


Color4D Operators

The Color4D type exposes the following members.

Operators
Name | Description
Addition(Single, Color4D) | Adds the value to each of the components of the color.
Addition(Color4D, Color4D) | Adds the two colors together.
Addition(Color4D, Single) | Adds the value to each of the components of the color.
Division(Color4D, Color4D) | Divides the first color by the second color, component wise.
Division(Color4D, Single) | Divides the color by a divisor value.
Equality | Tets equality between two colors.
Inequality | Tets inequality between two colors.
Multiply(Single, Color4D) | Multiplies the color by a scalar value, component wise.
Multiply(Color4D, Color4D) | Multiplies the two colors.
Multiply(Color4D, Single) | Multiplies the color by a scalar value, component wise.
Subtraction(Single, Color4D) | Subtracts the color's components from the value, returning the result as a new color. Same as new Color4D(value) - color
Subtraction(Color4D, Color4D) | Subtracts the second color from the first color.
Subtraction(Color4D, Single) | Subtracts the value from each of the color's components.
Top
See Also

Reference

Color4D Structure


Color4D.Addition Operator

Color4DAddition Operator

Overload List
Name | Description
Addition(Single, Color4D) | Adds the value to each of the components of the color.
Addition(Color4D, Color4D) | Adds the two colors together.
Addition(Color4D, Single) | Adds the value to each of the components of the color.
Top
See Also

Reference

Color4D Structure


Color4D.Addition Operator (Single, Color4D)

Color4DAddition Operator (Single, Color4D)

Adds the value to each of the components of the color.

Namespace: Assimp
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public static Color4D operator +(
    float value,
    Color4D color
)

Parameters

value
Type: SystemSingle
Value to add to each component
color
Type: AssimpColor4D
Source color

Return Value

Type: Color4D
Added color
See Also

Reference

Color4D Structure
Addition Overload


Color4D.Addition Operator (Color4D, Color4D)

Color4DAddition Operator (Color4D, Color4D)

Adds the two colors together.

Namespace: Assimp
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public static Color4D operator +(
    Color4D a,
    Color4D b
)

Parameters

a
Type: AssimpColor4D
First color
b
Type: AssimpColor4D
Second color

Return Value

Type: Color4D
Added color
See Also

Reference

Color4D Structure
Addition Overload


Color4D.Addition Operator (Color4D, Single)

Color4DAddition Operator (Color4D, Single)

Adds the value to each of the components of the color.

Namespace: Assimp
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public static Color4D operator +(
    Color4D color,
    float value
)

Parameters

color
Type: AssimpColor4D
Source color
value
Type: SystemSingle
Value to add to each component

Return Value

Type: Color4D
Added color
See Also

Reference

Color4D Structure
Addition Overload


Color4D.Division Operator

Color4DDivision Operator

Overload List
Name | Description
Division(Color4D, Color4D) | Divides the first color by the second color, component wise.
Division(Color4D, Single) | Divides the color by a divisor value.
Top
See Also

Reference

Color4D Structure


Color4D.Division Operator (Color4D, Color4D)

Color4DDivision Operator (Color4D, Color4D)

Divides the first color by the second color, component wise.

Namespace: Assimp
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public static Color4D operator /(
    Color4D a,
    Color4D b
)

Parameters

a
Type: AssimpColor4D
First color
b
Type: AssimpColor4D
Second color

Return Value

Type: Color4D
Resulting color
See Also

Reference

Color4D Structure
Division Overload


Color4D.Division Operator (Color4D, Single)

Color4DDivision Operator (Color4D, Single)

Divides the color by a divisor value.

Namespace: Assimp
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public static Color4D operator /(
    Color4D color,
    float divisor
)

Parameters

color
Type: AssimpColor4D
Source color
divisor
Type: SystemSingle
Divisor

Return Value

Type: Color4D
Resulting color
See Also

Reference

Color4D Structure
Division Overload


Color4D.Equality Operator

Color4DEquality Operator

Tets equality between two colors.

Namespace: Assimp
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public static bool operator ==(
    Color4D a,
    Color4D b
)

Parameters

a
Type: AssimpColor4D
First color
b
Type: AssimpColor4D
Second color

Return Value

Type: Boolean
True if the colors are equal, false otherwise
See Also

Reference

Color4D Structure


Color4D.Inequality Operator

Color4DInequality Operator

Tets inequality between two colors.

Namespace: Assimp
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public static bool operator !=(
    Color4D a,
    Color4D b
)

Parameters

a
Type: AssimpColor4D
First color
b
Type: AssimpColor4D
Second color

Return Value

Type: Boolean
True if the colors are not equal, false otherwise
See Also

Reference

Color4D Structure


Color4D.Multiply Operator

Color4DMultiply Operator

Overload List
Name | Description
Multiply(Single, Color4D) | Multiplies the color by a scalar value, component wise.
Multiply(Color4D, Color4D) | Multiplies the two colors.
Multiply(Color4D, Single) | Multiplies the color by a scalar value, component wise.
Top
See Also

Reference

Color4D Structure


Color4D.Multiply Operator (Single, Color4D)

Color4DMultiply Operator (Single, Color4D)

Multiplies the color by a scalar value, component wise.

Namespace: Assimp
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public static Color4D operator *(
    float scale,
    Color4D value
)

Parameters

scale
Type: SystemSingle
Scalar value
value
Type: AssimpColor4D
Source color

Return Value

Type: Color4D
Resulting color
See Also

Reference

Color4D Structure
Multiply Overload


Color4D.Multiply Operator (Color4D, Color4D)

Color4DMultiply Operator (Color4D, Color4D)

Multiplies the two colors.

Namespace: Assimp
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public static Color4D operator *(
    Color4D a,
    Color4D b
)

Parameters

a
Type: AssimpColor4D
First color
b
Type: AssimpColor4D
Second color

Return Value

Type: Color4D
Multiplied color.
See Also

Reference

Color4D Structure
Multiply Overload


Color4D.Multiply Operator (Color4D, Single)

Color4DMultiply Operator (Color4D, Single)

Multiplies the color by a scalar value, component wise.

Namespace: Assimp
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public static Color4D operator *(
    Color4D value,
    float scale
)

Parameters

value
Type: AssimpColor4D
Source color
scale
Type: SystemSingle
Scalar value

Return Value

Type: Color4D
Resulting color
See Also

Reference

Color4D Structure
Multiply Overload


Color4D.Subtraction Operator

Color4DSubtraction Operator

Overload List
Name | Description
Subtraction(Single, Color4D) | Subtracts the color's components from the value, returning the result as a new color. Same as new Color4D(value) - color
Subtraction(Color4D, Color4D) | Subtracts the second color from the first color.
Subtraction(Color4D, Single) | Subtracts the value from each of the color's components.
Top
See Also

Reference

Color4D Structure


Color4D.Subtraction Operator (Single, Color4D)

Color4DSubtraction Operator (Single, Color4D)

Subtracts the color's components from the value, returning the result as a new color. Same as new Color4D(value) - color

Namespace: Assimp
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public static Color4D operator -(
    float value,
    Color4D color
)

Parameters

value
Type: SystemSingle
Value for each component of the first color
color
Type: AssimpColor4D
Second color

Return Value

Type: Color4D
Resulting color
See Also

Reference

Color4D Structure
Subtraction Overload


Color4D.Subtraction Operator (Color4D, Color4D)

Color4DSubtraction Operator (Color4D, Color4D)

Subtracts the second color from the first color.

Namespace: Assimp
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public static Color4D operator -(
    Color4D a,
    Color4D b
)

Parameters

a
Type: AssimpColor4D
First color
b
Type: AssimpColor4D
Second color

Return Value

Type: Color4D
Resulting color
See Also

Reference

Color4D Structure
Subtraction Overload


Color4D.Subtraction Operator (Color4D, Single)

Color4DSubtraction Operator (Color4D, Single)

Subtracts the value from each of the color's components.

Namespace: Assimp
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public static Color4D operator -(
    Color4D color,
    float value
)

Parameters

color
Type: AssimpColor4D
Source color
value
Type: SystemSingle
Value to subtract from each component

Return Value

Type: Color4D
Resulting color
See Also

Reference

Color4D Structure
Subtraction Overload


Color4D Fields

The Color4D type exposes the following members.

Fields
 | Name | Description
Public field | A | Alpha component.
Public field | B | Blue component.
Public field | G | Green component.
Public field | R | Red component.
Top
See Also

Reference

Color4D Structure


Color4D.A Field

Color4DA Field

Alpha component.

Namespace: Assimp
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public float A

Field Value

Type: Single
See Also

Reference

Color4D Structure


Color4D.B Field

Color4DB Field

Blue component.

Namespace: Assimp
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public float B

Field Value

Type: Single
See Also

Reference

Color4D Structure


Color4D.G Field

Color4DG Field

Green component.

Namespace: Assimp
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public float G

Field Value

Type: Single
See Also

Reference

Color4D Structure


Color4D.R Field

Color4DR Field

Red component.

Namespace: Assimp
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public float R

Field Value

Type: Single
See Also

Reference

Color4D Structure


CompileFlags Enumeration

Enumerates how the native Assimp DLL was compiled

Namespace: Assimp
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public enum CompileFlags
Members
Member name | Value | Description
Shared | 1 | Assimp compiled as a shared object (Windows: DLL);
STLport | 2 | Assimp was compiled against STLport
Debug | 4 | Assimp was compiled as a debug build
NoBoost | 8 | Assimp was compiled with the boost work around.
SingleThreaded | 16 | Assimp was compiled built to run single threaded.
See Also

Reference


ConsoleLogStream Class

Log stream that writes messages to the Console.
Inheritance Hierarchy
SystemObject
AssimpLogStream
AssimpConsoleLogStream

Namespace: Assimp
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public sealed class ConsoleLogStream : LogStream

The ConsoleLogStream type exposes the following members.

Constructors
 | Name | Description
Public method | ConsoleLogStream | Constructs a new console logstream.
Public method | ConsoleLogStream(String) | Constructs a new console logstream.
Top
Properties
 | Name | Description
Public property | IsAttached | Gets whether or not the logstream is currently attached to the library. (Inherited from LogStream.)
Public property | IsDisposed | Gets whether the logstream has been disposed or not. (Inherited from LogStream.)
Public property | UserData | Gets or sets the user data to be passed to the callback. (Inherited from LogStream.)
Top
Methods
 | Name | Description
Public method | Attach | Attaches the logstream to the library. (Inherited from LogStream.)
Public method | Detach | Detaches the logstream from the library. (Inherited from LogStream.)
Public method | Dispose | Releases unmanaged resources held by the LogStream. This should not be called by the user if the logstream is currently attached to an assimp importer. (Inherited from LogStream.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Log | Logs a message. (Inherited from LogStream.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference


ConsoleLogStream Constructor

Overload List
 | Name | Description
Public method | ConsoleLogStream | Constructs a new console logstream.
Public method | ConsoleLogStream(String) | Constructs a new console logstream.
Top
See Also

Reference

ConsoleLogStream Class


ConsoleLogStream Constructor

Constructs a new console logstream.

Namespace: Assimp
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public ConsoleLogStream()
See Also

Reference

ConsoleLogStream Class
ConsoleLogStream Overload


ConsoleLogStream Constructor (String)

Constructs a new console logstream.

Namespace: Assimp
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public ConsoleLogStream(
    string userData
)

Parameters

userData
Type: SystemString
User supplied data
See Also

Reference

ConsoleLogStream Class
ConsoleLogStream Overload


ConsoleLogStream Properties

The ConsoleLogStream type exposes the following members.

Properties
 | Name | Description
Public property | IsAttached | Gets whether or not the logstream is currently attached to the library. (Inherited from LogStream.)
Public property | IsDisposed | Gets whether the logstream has been disposed or not. (Inherited from LogStream.)
Public property | UserData | Gets or sets the user data to be passed to the callback. (Inherited from LogStream.)
Top
See Also

Reference

ConsoleLogStream Class


ConsoleLogStream Methods

The ConsoleLogStream type exposes the following members.

Methods
 | Name | Description
Public method | Attach | Attaches the logstream to the library. (Inherited from LogStream.)
Public method | Detach | Detaches the logstream from the library. (Inherited from LogStream.)
Public method | Dispose | Releases unmanaged resources held by the LogStream. This should not be called by the user if the logstream is currently attached to an assimp importer. (Inherited from LogStream.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Log | Logs a message. (Inherited from LogStream.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

ConsoleLogStream Class


DefaultLogStream Enumeration

Enumerates predefined log streaming destinations.

Namespace: Assimp
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
[FlagsAttribute]
public enum DefaultLogStream
Members
Member name | Value | Description
File | 1 | Stream log to a file
StdOut | 2 | Stream log to the standard output
StdErr | 4 | Stream log to the standard error output.
Debugger | 8 | MSVC only: Stream the log to the debugger (this relies on OutputDebugString from the Win32 SDK).
See Also

Reference


EmbeddedTexture Class

Represents an embedded texture. Some file formats directly embed texture assets. Embedded textures may be uncompressed, where the data is given in an uncompressed format. Or it may be compressed in a format like png or jpg. In the latter case, the raw file bytes are given so the application must utilize an image decoder (e.g. DevIL) to get access to the actual color data. This object represents both types, so some properties may or may not be valid depending if it is compressed or not.
Inheritance Hierarchy
SystemObject
AssimpEmbeddedTexture

Namespace: Assimp
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public sealed class EmbeddedTexture : IMarshalable<EmbeddedTexture, AiTexture>

The EmbeddedTexture type exposes the following members.

Constructors
 | Name | Description
Public method | EmbeddedTexture | Constructs a new instance of the EmbeddedTexture class. Should use only if reading from a native value.
Public method | EmbeddedTexture(String, Byte) | Constructs a new instance of the EmbeddedTexture class. This creates a compressed embedded texture.
Public method | EmbeddedTexture(Int32, Int32, Texel) | Constructs a new instance of the EmbeddedTexture class. This creates an uncompressed embedded texture.
Top
Properties
 | Name | Description
Public property | CompressedData | Gets the raw byte data representing the compressed texture. Only valid for compressed textures.
Public property | CompressedDataSize | Gets the size of the compressed data. Only valid for compressed textures.
Public property | CompressedFormatHint | Gets the format hint to determine the type of compressed data. This hint is a three-character lower-case hint like "dds", "jpg", "png".
Public property | HasCompressedData | Gets if the embedded texture has compressed data. Only valid for compressed textures.
Public property | HasNonCompressedData | Gets if the texture has non-compressed texel data. Only valid for non-compressed textures.
Public property | Height | Gets the height of the texture in pixels. Only valid for non-compressed textures.
Public property | IsCompressed | Gets if the texture is compressed or not.
Public property | NonCompressedData | Gets the non-compressed texel data, the array is of size Width * Height. Only valid for non-compressed textures.
Public property | NonCompressedDataSize | Gets the size of the non-compressed texel data. Only valid for non-compressed textures.
Public property | Width | Gets the width of the texture in pixels. Only valid for non-compressed textures.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
 | FreeNative | Frees unmanaged memory created by ToNative(IntPtr, Native).
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference


EmbeddedTexture Constructor

Overload List
 | Name | Description
Public method | EmbeddedTexture | Constructs a new instance of the EmbeddedTexture class. Should use only if reading from a native value.
Public method | EmbeddedTexture(String, Byte) | Constructs a new instance of the EmbeddedTexture class. This creates a compressed embedded texture.
Public method | EmbeddedTexture(Int32, Int32, Texel) | Constructs a new instance of the EmbeddedTexture class. This creates an uncompressed embedded texture.
Top
See Also

Reference

EmbeddedTexture Class


EmbeddedTexture Constructor

Constructs a new instance of the EmbeddedTexture class. Should use only if reading from a native value.

Namespace: Assimp
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public EmbeddedTexture()
See Also

Reference

EmbeddedTexture Class
EmbeddedTexture Overload


EmbeddedTexture Constructor (String, Byte[])

EmbeddedTexture Constructor (String, Byte)

Constructs a new instance of the EmbeddedTexture class. This creates a compressed embedded texture.

Namespace: Assimp
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public EmbeddedTexture(
    string compressedFormatHint,
    byte[] compressedData
)

Parameters

compressedFormatHint
Type: SystemString
The 3 character format hint.
compressedData
Type: SystemByte
The compressed data.
See Also

Reference

EmbeddedTexture Class
EmbeddedTexture Overload


EmbeddedTexture Constructor (Int32, Int32, Texel[])

EmbeddedTexture Constructor (Int32, Int32, Texel)

Constructs a new instance of the EmbeddedTexture class. This creates an uncompressed embedded texture.

Namespace: Assimp
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public EmbeddedTexture(
    int width,
    int height,
    Texel[] uncompressedData
)

Parameters

width
Type: SystemInt32
Width of the texture
height
Type: SystemInt32
Height of the texture
uncompressedData
Type: AssimpTexel
Color data
Exceptions
Exception | Condition
ArgumentException | Thrown if the data size does not match width * height.
See Also

Reference

EmbeddedTexture Class
EmbeddedTexture Overload


EmbeddedTexture Properties

The EmbeddedTexture type exposes the following members.

Properties
 | Name | Description
Public property | CompressedData | Gets the raw byte data representing the compressed texture. Only valid for compressed textures.
Public property | CompressedDataSize | Gets the size of the compressed data. Only valid for compressed textures.
Public property | CompressedFormatHint | Gets the format hint to determine the type of compressed data. This hint is a three-character lower-case hint like "dds", "jpg", "png".
Public property | HasCompressedData | Gets if the embedded texture has compressed data. Only valid for compressed textures.
Public property | HasNonCompressedData | Gets if the texture has non-compressed texel data. Only valid for non-compressed textures.
Public property | Height | Gets the height of the texture in pixels. Only valid for non-compressed textures.
Public property | IsCompressed | Gets if the texture is compressed or not.
Public property | NonCompressedData | Gets the non-compressed texel data, the array is of size Width * Height. Only valid for non-compressed textures.
Public property | NonCompressedDataSize | Gets the size of the non-compressed texel data. Only valid for non-compressed textures.
Public property | Width | Gets the width of the texture in pixels. Only valid for non-compressed textures.
Top
See Also

Reference

EmbeddedTexture Class


EmbeddedTexture.CompressedData Property

EmbeddedTextureCompressedData Property

Gets the raw byte data representing the compressed texture. Only valid for compressed textures.

Namespace: Assimp
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public byte[] CompressedData { get; }

Property Value

Type: Byte
See Also

Reference

EmbeddedTexture Class


EmbeddedTexture.CompressedDataSize Property

EmbeddedTextureCompressedDataSize Property

Gets the size of the compressed data. Only valid for compressed textures.

Namespace: Assimp
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public int CompressedDataSize { get; }

Property Value

Type: Int32
See Also

Reference

EmbeddedTexture Class


EmbeddedTexture.CompressedFormatHint Property

EmbeddedTextureCompressedFormatHint Property

Gets the format hint to determine the type of compressed data. This hint is a three-character lower-case hint like "dds", "jpg", "png".

Namespace: Assimp
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public string CompressedFormatHint { get; }

Property Value

Type: String
See Also

Reference

EmbeddedTexture Class


EmbeddedTexture.HasCompressedData Property

EmbeddedTextureHasCompressedData Property

Gets if the embedded texture has compressed data. Only valid for compressed textures.

Namespace: Assimp
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public bool HasCompressedData { get; }

Property Value

Type: Boolean
See Also

Reference

EmbeddedTexture Class


EmbeddedTexture.HasNonCompressedData Property

EmbeddedTextureHasNonCompressedData Property

Gets if the texture has non-compressed texel data. Only valid for non-compressed textures.

Namespace: Assimp
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public bool HasNonCompressedData { get; }

Property Value

Type: Boolean
See Also

Reference

EmbeddedTexture Class


EmbeddedTexture.Height Property

EmbeddedTextureHeight Property

Gets the height of the texture in pixels. Only valid for non-compressed textures.

Namespace: Assimp
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public int Height { get; }

Property Value

Type: Int32
See Also

Reference

EmbeddedTexture Class


EmbeddedTexture.IsCompressed Property

EmbeddedTextureIsCompressed Property

Gets if the texture is compressed or not.

Namespace: Assimp
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public bool IsCompressed { get; }

Property Value

Type: Boolean
See Also

Reference

EmbeddedTexture Class


EmbeddedTexture.NonCompressedData Property

EmbeddedTextureNonCompressedData Property

Gets the non-compressed texel data, the array is of size Width * Height. Only valid for non-compressed textures.

Namespace: Assimp
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public Texel[] NonCompressedData { get; }

Property Value

Type: Texel
See Also

Reference

EmbeddedTexture Class


EmbeddedTexture.NonCompressedDataSize Property

EmbeddedTextureNonCompressedDataSize Property

Gets the size of the non-compressed texel data. Only valid for non-compressed textures.

Namespace: Assimp
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public int NonCompressedDataSize { get; }

Property Value

Type: Int32
See Also

Reference

EmbeddedTexture Class


EmbeddedTexture.Width Property

EmbeddedTextureWidth Property

Gets the width of the texture in pixels. Only valid for non-compressed textures.

Namespace: Assimp
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public int Width { get; }

Property Value

Type: Int32
See Also

Reference

EmbeddedTexture Class


EmbeddedTexture Methods

The EmbeddedTexture type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
 | FreeNative | Frees unmanaged memory created by ToNative(IntPtr, Native).
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

EmbeddedTexture Class


EmbeddedTexture.FreeNative Method

EmbeddedTextureFreeNative Method

Frees unmanaged memory created by ToNative(IntPtr, Native).

Namespace: Assimp
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public static void FreeNative(
    IntPtr nativeValue,
    bool freeNative
)

Parameters

nativeValue
Type: SystemIntPtr
Native value to free
freeNative
Type: SystemBoolean
True if the unmanaged memory should be freed, false otherwise.
See Also

Reference

EmbeddedTexture Class


ExcludeComponent Enumeration

Enumerates components of the scene or mesh data that can be excluded from the import using the post process step RemoveComponent.

Namespace: Assimp
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
[FlagsAttribute]
public enum ExcludeComponent
Members
Member name | Value | Description
None | 0 | No components to be excluded.
Normals | 2 | Removes normal vectors
TangentBasis | 4 | Removes tangents/binormals
Colors | 8 | Removes all color sets.
TexCoords | 16 | Removes all texture UV sets.
Boneweights | 32 | Remove all boneweights from all meshes. Scenegraph nodes corresponding to the bones are NOT removed. Use OptimizeGraph step to remove them.
Animations | 64 | Removes all node animations. Coressponding scenegraph nodes are NOT removed. Use OptimizeGraph step to remove them.
Textures | 128 | Removes all embedded textures.
Lights | 256 | Removes all light sources. The corresponding scenegraph nodes are NOT removed. Use the OptimizeGraph step to do this.
Cameras | 512 | Removes all cameras. The corresponding scenegraph nodes are NOT removed. Use the OptimizeGraph step to do this.
Meshes | 1024 | Removes all meshes.
Materials | 2048 | Removes all materials. One default material will be generated.
See Also

Reference


ExportDataBlob Class

Describes a blob of exported scene data. Blobs can be nested - each blob may reference another blob, which in turn can reference another and so on. This is used to allow exporters to write more than one output for a given scene, such as material files. Existence of such files depends on the format.
Inheritance Hierarchy
SystemObject
AssimpExportDataBlob

Namespace: Assimp
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public sealed class ExportDataBlob

The ExportDataBlob type exposes the following members.

Properties
 | Name | Description
Public property | Data | Get the blob data.
Public property | HasData | Gets if the blob data is valid.
Public property | Name | Gets the name of the blob. The first and primary blob always has an empty string for a name. Auxillary files that are nested will have names.
Public property | NextBlob | Gets the next data blob.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
 | FromStream | Reads a data blob from the specified stream.
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToStream | Writes the data blob to the specified stream.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Remarks
The stream representation of an ExportDataBlob is as follows:
Copy
String: Name of the Blob
int: Length of Binary Data
byte[]: Binary Data
bool: If has next data blob
    String: Name of nested blob
    int: Length of nested blob binary data
    byte[]: Nested blob binary data
    bool: If nested blob has next data blob
    ....
See Also

Reference


ExportDataBlob Properties

The ExportDataBlob type exposes the following members.

Properties
 | Name | Description
Public property | Data | Get the blob data.
Public property | HasData | Gets if the blob data is valid.
Public property | Name | Gets the name of the blob. The first and primary blob always has an empty string for a name. Auxillary files that are nested will have names.
Public property | NextBlob | Gets the next data blob.
Top
See Also

Reference

ExportDataBlob Class


ExportDataBlob.Data Property

ExportDataBlobData Property

Get the blob data.

Namespace: Assimp
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public byte[] Data { get; }

Property Value

Type: Byte
See Also

Reference

ExportDataBlob Class


ExportDataBlob.HasData Property

ExportDataBlobHasData Property

Gets if the blob data is valid.

Namespace: Assimp
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public bool HasData { get; }

Property Value

Type: Boolean
See Also

Reference

ExportDataBlob Class


ExportDataBlob.Name Property

ExportDataBlobName Property

Gets the name of the blob. The first and primary blob always has an empty string for a name. Auxillary files that are nested will have names.

Namespace: Assimp
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public string Name { get; }

Property Value

Type: String
See Also

Reference

ExportDataBlob Class


ExportDataBlob.NextBlob Property

ExportDataBlobNextBlob Property

Gets the next data blob.

Namespace: Assimp
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public ExportDataBlob NextBlob { get; }

Property Value

Type: ExportDataBlob
See Also

Reference

ExportDataBlob Class


ExportDataBlob Methods

The ExportDataBlob type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
 | FromStream | Reads a data blob from the specified stream.
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToStream | Writes the data blob to the specified stream.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

ExportDataBlob Class


ExportDataBlob.FromStream Method

ExportDataBlobFromStream Method

Reads a data blob from the specified stream.

Namespace: Assimp
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public static ExportDataBlob FromStream(
    Stream stream
)

Parameters

stream
Type: System.IOStream
Input stream

Return Value

Type: ExportDataBlob
Data blob
See Also

Reference

ExportDataBlob Class


ExportDataBlob.ToStream Method

ExportDataBlobToStream Method

Writes the data blob to the specified stream.

Namespace: Assimp
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public void ToStream(
    Stream stream
)

Parameters

stream
Type: System.IOStream
Output stream
See Also

Reference

ExportDataBlob Class


ExportFormatDescription Class

Describes a file format which Assimp can export to.
Inheritance Hierarchy
SystemObject
AssimpExportFormatDescription

Namespace: Assimp
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public sealed class ExportFormatDescription

The ExportFormatDescription type exposes the following members.

Properties
 | Name | Description
Public property | Description | Gets a short description of the file format to present to users.
Public property | FileExtension | Gets the recommended file extension for the exported file in lower case.
Public property | FormatId | Gets a short string ID to uniquely identify the export format. E.g. "collada" or "obj".
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference


ExportFormatDescription Properties

The ExportFormatDescription type exposes the following members.

Properties
 | Name | Description
Public property | Description | Gets a short description of the file format to present to users.
Public property | FileExtension | Gets the recommended file extension for the exported file in lower case.
Public property | FormatId | Gets a short string ID to uniquely identify the export format. E.g. "collada" or "obj".
Top
See Also

Reference

ExportFormatDescription Class


ExportFormatDescription.Description Property

ExportFormatDescriptionDescription Property

Gets a short description of the file format to present to users.

Namespace: Assimp
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public string Description { get; }

Property Value

Type: String
See Also

Reference

ExportFormatDescription Class


ExportFormatDescription.FileExtension Property

ExportFormatDescriptionFileExtension Property

Gets the recommended file extension for the exported file in lower case.

Namespace: Assimp
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public string FileExtension { get; }

Property Value

Type: String
See Also

Reference

ExportFormatDescription Class


ExportFormatDescription.FormatId Property

ExportFormatDescriptionFormatId Property

Gets a short string ID to uniquely identify the export format. E.g. "collada" or "obj".

Namespace: Assimp
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public string FormatId { get; }

Property Value

Type: String
See Also

Reference

ExportFormatDescription Class


ExportFormatDescription Methods

The ExportFormatDescription type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

ExportFormatDescription Class


Face Class

A single face in a mesh, referring to multiple vertices. This can be a triangle if the index count is equal to three, or a polygon if the count is greater than three. Since multiple primitive types can be contained in a single mesh, this approach allows you to better examine how the mesh is constructed. If you use the SortByPrimitiveType post process step flag during import, then each mesh will be homogenous where primitive type is concerned.
Inheritance Hierarchy
SystemObject
AssimpFace

Namespace: Assimp
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public sealed class Face : IMarshalable<Face, AiFace>

The Face type exposes the following members.

Constructors
 | Name | Description
Public method | Face | Constructs a new instance of the Face class.
Public method | Face(Int32) | Constructs a new instance of the Face class.
Top
Properties
 | Name | Description
Public property | HasIndices | Gets if the face has faces (should always be true).
Public property | IndexCount | Gets the number of indices defined in the face.
Public property | Indices | Gets or sets the indices that refer to positions of vertex data in the mesh's vertex arrays.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
 | FreeNative | Frees unmanaged memory created by ToNative(IntPtr, Native).
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference


Face Constructor

Overload List
 | Name | Description
Public method | Face | Constructs a new instance of the Face class.
Public method | Face(Int32) | Constructs a new instance of the Face class.
Top
See Also

Reference

Face Class


Face Constructor

Constructs a new instance of the Face class.

Namespace: Assimp
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public Face()
See Also

Reference

Face Class
Face Overload


Face Constructor (Int32[])

Face Constructor (Int32)

Constructs a new instance of the Face class.

Namespace: Assimp
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public Face(
    int[] indices
)

Parameters

indices
Type: SystemInt32
Face indices
See Also

Reference

Face Class
Face Overload


Face Properties

The Face type exposes the following members.

Properties
 | Name | Description
Public property | HasIndices | Gets if the face has faces (should always be true).
Public property | IndexCount | Gets the number of indices defined in the face.
Public property | Indices | Gets or sets the indices that refer to positions of vertex data in the mesh's vertex arrays.
Top
See Also

Reference

Face Class


Face.HasIndices Property

FaceHasIndices Property

Gets if the face has faces (should always be true).

Namespace: Assimp
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public bool HasIndices { get; }

Property Value

Type: Boolean
See Also

Reference

Face Class


Face.IndexCount Property

FaceIndexCount Property

Gets the number of indices defined in the face.

Namespace: Assimp
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public int IndexCount { get; }

Property Value

Type: Int32
See Also

Reference

Face Class


Face.Indices Property

FaceIndices Property

Gets or sets the indices that refer to positions of vertex data in the mesh's vertex arrays.

Namespace: Assimp
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public List Indices { get; }

Property Value

Type: ListT
See Also

Reference

Face Class


Face Methods

The Face type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
 | FreeNative | Frees unmanaged memory created by ToNative(IntPtr, Native).
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Face Class


Face.FreeNative Method

FaceFreeNative Method

Frees unmanaged memory created by ToNative(IntPtr, Native).

Namespace: Assimp
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public static void FreeNative(
    IntPtr nativeValue,
    bool freeNative
)

Parameters

nativeValue
Type: SystemIntPtr
Native value to free
freeNative
Type: SystemBoolean
True if the unmanaged memory should be freed, false otherwise.
See Also

Reference

Face Class


FileIOMode Enumeration

Defines the desired file I/O mode is when opening a new file.

Namespace: Assimp
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public enum FileIOMode
Members
Member name | Value | Description
Write | 0 | Open the file for writing.
WriteBinary | 1 | Open the file for writing binary data to it.
WriteText | 2 | Open the file for writing text data to it.
Read | 3 | Open the file for reading.
ReadBinary | 4 | Open the file for reading binary data from it.
ReadText | 5 | Open the file for reading text data from it.
See Also

Reference


FileIOSystem Class

Simple implementation of an IOSystem that searches for files on the disk. This implementation can be given a number of search directories that it will attempt to locate the file in first, before using the file path given by Assimp. That way, you can load models that have files distributed in a number of other directories besides the root model's.
Inheritance Hierarchy
SystemObject
AssimpIOSystem
AssimpFileIOSystem

Namespace: Assimp
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public class FileIOSystem : IOSystem

The FileIOSystem type exposes the following members.

Constructors
 | Name | Description
Public method | FileIOSystem | Constructs a new FileIOSystem that does not have any search directories.
Public method | FileIOSystem(String) | Constructs a new FileIOSystem that uses the specified search directories.
Top
Properties
 | Name | Description
Public property | IsDisposed | Gets whether or not this IOSystem has been disposed. (Inherited from IOSystem.)
Public property | OpenFileCount | Gets the number of currently opened streams. (Inherited from IOSystem.)
Top
Methods
 | Name | Description
Public method | CloseAllFiles | Closes all outstanding streams owned by this IOSystem. (Inherited from IOSystem.)
Public method | CloseFile | Closes a stream that is owned by this IOSystem. (Inherited from IOSystem.)
Public method | Dispose | Disposes of all resources held by this object. (Inherited from IOSystem.)
Protected method | Dispose(Boolean) | Releases unmanaged and - optionally - managed resources. (Inherited from IOSystem.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Finalizes an instance of the IOSystem class. (Inherited from IOSystem.)
Public method | FindFile | Finds the first file that matches the file name (name + extension) in the search paths.
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetSearchDirectories | Gets the search directories the FileIOSystem is using.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | OpenFile | Opens a stream to a file. (Overrides IOSystemOpenFile(String, FileIOMode).)
Public method | SetSearchDirectories | Sets the search directories the FileIOSystem will use when searching for files.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference


FileIOSystem Constructor

Overload List
 | Name | Description
Public method | FileIOSystem | Constructs a new FileIOSystem that does not have any search directories.
Public method | FileIOSystem(String) | Constructs a new FileIOSystem that uses the specified search directories.
Top
See Also

Reference

FileIOSystem Class


FileIOSystem Constructor

Constructs a new FileIOSystem that does not have any search directories.

Namespace: Assimp
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public FileIOSystem()
See Also

Reference

FileIOSystem Class
FileIOSystem Overload


FileIOSystem Constructor (String[])

FileIOSystem Constructor (String)

Constructs a new FileIOSystem that uses the specified search directories.

Namespace: Assimp
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public FileIOSystem(
    params string[] searchPaths
)

Parameters

searchPaths
Type: SystemString
Search directories to search for files in
See Also

Reference

FileIOSystem Class
FileIOSystem Overload


FileIOSystem Properties

The FileIOSystem type exposes the following members.

Properties
 | Name | Description
Public property | IsDisposed | Gets whether or not this IOSystem has been disposed. (Inherited from IOSystem.)
Public property | OpenFileCount | Gets the number of currently opened streams. (Inherited from IOSystem.)
Top
See Also

Reference

FileIOSystem Class


FileIOSystem Methods

The FileIOSystem type exposes the following members.

Methods
 | Name | Description
Public method | CloseAllFiles | Closes all outstanding streams owned by this IOSystem. (Inherited from IOSystem.)
Public method | CloseFile | Closes a stream that is owned by this IOSystem. (Inherited from IOSystem.)
Public method | Dispose | Disposes of all resources held by this object. (Inherited from IOSystem.)
Protected method | Dispose(Boolean) | Releases unmanaged and - optionally - managed resources. (Inherited from IOSystem.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Finalizes an instance of the IOSystem class. (Inherited from IOSystem.)
Public method | FindFile | Finds the first file that matches the file name (name + extension) in the search paths.
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetSearchDirectories | Gets the search directories the FileIOSystem is using.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | OpenFile | Opens a stream to a file. (Overrides IOSystemOpenFile(String, FileIOMode).)
Public method | SetSearchDirectories | Sets the search directories the FileIOSystem will use when searching for files.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

FileIOSystem Class


FileIOSystem.FindFile Method

FileIOSystemFindFile Method

Finds the first file that matches the file name (name + extension) in the search paths.

Namespace: Assimp
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public bool FindFile(
    string fileName,
    out string pathToFile
)

Parameters

fileName
Type: SystemString
File name (+ extension) to search for
pathToFile
Type: SystemString
Found file path

Return Value

Type: Boolean
True if the file was found, false otherwise
See Also

Reference

FileIOSystem Class


FileIOSystem.GetSearchDirectories Method

FileIOSystemGetSearchDirectories Method

Gets the search directories the FileIOSystem is using.

Namespace: Assimp
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public string[] GetSearchDirectories()

Return Value

Type: String
Directory paths
See Also

Reference

FileIOSystem Class


FileIOSystem.OpenFile Method

FileIOSystemOpenFile Method

Opens a stream to a file.

Namespace: Assimp
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public override IOStream OpenFile(
    string pathToFile,
    FileIOMode fileMode
)

Parameters

pathToFile
Type: SystemString
Path to the file
fileMode
Type: AssimpFileIOMode
Desired file access mode

Return Value

Type: IOStream
The IO stream
See Also

Reference

FileIOSystem Class


FileIOSystem.SetSearchDirectories Method

FileIOSystemSetSearchDirectories Method

Sets the search directories the FileIOSystem will use when searching for files.

Namespace: Assimp
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public void SetSearchDirectories(
    params string[] searchPaths
)

Parameters

searchPaths
Type: SystemString
Directory paths
See Also

Reference

FileIOSystem Class


FreeNativeDelegate Delegate

Delegate for performing unmanaged memory cleanup.

Namespace: Assimp
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public delegate void FreeNativeDelegate(
    IntPtr nativeValue,
    bool freeNative
)

Parameters

nativeValue
Type: SystemIntPtr
Location in unmanaged memory of the value to cleanup
freeNative
Type: SystemBoolean
True if the unmanaged memory should be freed, false otherwise
See Also

Reference


IMarshalable(Managed, Native) Interface

IMarshalableManaged, Native Interface

Represents an object that can be marshaled to and from a native representation.

Namespace: Assimp
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public interface IMarshalable<Managed, Native>
where Managed : class, new()
where Native : struct, new()

Type Parameters

Managed
Managed object type
Native
Native value type

The IMarshalableManaged, Native type exposes the following members.

Properties
 | Name | Description
Public property | IsNativeBlittable | Gets if the native value type is blittable (that is, does not require marshaling by the runtime, e.g. has MarshalAs attributes).
Top
Methods
 | Name | Description
Public method | FromNative |
Public method | ToNative | Writes the managed data to the native value.
Top
See Also

Reference


IMarshalable(Managed, Native) Properties

IMarshalableManaged, Native Properties

The IMarshalableManaged, Native generic type exposes the following members.

Properties
 | Name | Description
Public property | IsNativeBlittable | Gets if the native value type is blittable (that is, does not require marshaling by the runtime, e.g. has MarshalAs attributes).
Top
See Also

Reference

IMarshalableManaged, Native Interface


IMarshalable(Managed, Native).IsNativeBlittable Property

IMarshalableManaged, NativeIsNativeBlittable Property

Gets if the native value type is blittable (that is, does not require marshaling by the runtime, e.g. has MarshalAs attributes).

Namespace: Assimp
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
bool IsNativeBlittable { get; }

Property Value

Type: Boolean
See Also

Reference

IMarshalableManaged, Native Interface


IMarshalable(Managed, Native) Methods

IMarshalableManaged, Native Methods

The IMarshalableManaged, Native generic type exposes the following members.

Methods
 | Name | Description
Public method | FromNative |
Public method | ToNative | Writes the managed data to the native value.
Top
See Also

Reference

IMarshalableManaged, Native Interface


IMarshalable(Managed, Native).FromNative Method

IMarshalableManaged, NativeFromNative Method

[Missing <summary> documentation for "M:Assimp.IMarshalable`2.FromNative(`1@|System.Runtime.InteropServices.InAttribute)"]

Namespace: Assimp
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
void FromNative(
    ref Native nativeValue
)

Parameters

nativeValue
Type: Native InAttribute

[Missing <param name="nativeValue"/> documentation for "M:Assimp.IMarshalable`2.FromNative(`1@|System.Runtime.InteropServices.InAttribute)"]

See Also

Reference

IMarshalableManaged, Native Interface


IMarshalable(Managed, Native).ToNative Method

IMarshalableManaged, NativeToNative Method

Writes the managed data to the native value.

Namespace: Assimp
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
void ToNative(
    IntPtr thisPtr,
    out Native nativeValue
)

Parameters

thisPtr
Type: SystemIntPtr
Optional pointer to the memory that will hold the native value.
nativeValue
Type: Native
Output native value
See Also

Reference

IMarshalableManaged, Native Interface


ImporterDescription Class

Metadata and feature support information for a given importer.
Inheritance Hierarchy
SystemObject
AssimpImporterDescription

Namespace: Assimp
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public sealed class ImporterDescription

The ImporterDescription type exposes the following members.

Properties
 | Name | Description
Public property | Author | Gets the original author (blank if unknown or assimp team).
Public property | Comments | Gets any implementation comments.
Public property | FeatureFlags | Gets the features supported by the importer.
Public property | FileExtensions | Gets the list of file extensions the importer can handle. All entries are lower case and do NOT have a leading dot.
Public property | Maintainer | Gets the name of the current maintainer, if empty then the author maintains.
Public property | MaxVersion | Gets the maximum version of the file format supported. If no version scheme, forwards compatible, or importer doesn't care, major/min will be zero.
Public property | MinVersion | Gets the minimum version of the file format supported. If no version scheme, forwards compatible, or importer doesn't care, major/min will be zero.
Public property | Name | Gets the name of the importer (e.g. Blender3D Importer)
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference


ImporterDescription Properties

The ImporterDescription type exposes the following members.

Properties
 | Name | Description
Public property | Author | Gets the original author (blank if unknown or assimp team).
Public property | Comments | Gets any implementation comments.
Public property | FeatureFlags | Gets the features supported by the importer.
Public property | FileExtensions | Gets the list of file extensions the importer can handle. All entries are lower case and do NOT have a leading dot.
Public property | Maintainer | Gets the name of the current maintainer, if empty then the author maintains.
Public property | MaxVersion | Gets the maximum version of the file format supported. If no version scheme, forwards compatible, or importer doesn't care, major/min will be zero.
Public property | MinVersion | Gets the minimum version of the file format supported. If no version scheme, forwards compatible, or importer doesn't care, major/min will be zero.
Public property | Name | Gets the name of the importer (e.g. Blender3D Importer)
Top
See Also

Reference

ImporterDescription Class


ImporterDescription.Author Property

ImporterDescriptionAuthor Property

Gets the original author (blank if unknown or assimp team).

Namespace: Assimp
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public string Author { get; }

Property Value

Type: String
See Also

Reference

ImporterDescription Class


ImporterDescription.Comments Property

ImporterDescriptionComments Property

Gets any implementation comments.

Namespace: Assimp
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public string Comments { get; }

Property Value

Type: String
See Also

Reference

ImporterDescription Class


ImporterDescription.FeatureFlags Property

ImporterDescriptionFeatureFlags Property

Gets the features supported by the importer.

Namespace: Assimp
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public ImporterFeatureFlags FeatureFlags { get; }

Property Value

Type: ImporterFeatureFlags
See Also

Reference

ImporterDescription Class


ImporterDescription.FileExtensions Property

ImporterDescriptionFileExtensions Property

Gets the list of file extensions the importer can handle. All entries are lower case and do NOT have a leading dot.

Namespace: Assimp
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public string[] FileExtensions { get; }

Property Value

Type: String
See Also

Reference

ImporterDescription Class


ImporterDescription.Maintainer Property

ImporterDescriptionMaintainer Property

Gets the name of the current maintainer, if empty then the author maintains.

Namespace: Assimp
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public string Maintainer { get; }

Property Value

Type: String
See Also

Reference

ImporterDescription Class


ImporterDescription.MaxVersion Property

ImporterDescriptionMaxVersion Property

Gets the maximum version of the file format supported. If no version scheme, forwards compatible, or importer doesn't care, major/min will be zero.

Namespace: Assimp
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public Version MaxVersion { get; }

Property Value

Type: Version
See Also

Reference

ImporterDescription Class


ImporterDescription.MinVersion Property

ImporterDescriptionMinVersion Property

Gets the minimum version of the file format supported. If no version scheme, forwards compatible, or importer doesn't care, major/min will be zero.

Namespace: Assimp
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public Version MinVersion { get; }

Property Value

Type: Version
See Also

Reference

ImporterDescription Class


ImporterDescription.Name Property

ImporterDescriptionName Property

Gets the name of the importer (e.g. Blender3D Importer)

Namespace: Assimp
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public string Name { get; }

Property Value

Type: String
See Also

Reference

ImporterDescription Class


ImporterDescription Methods

The ImporterDescription type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

ImporterDescription Class


ImporterFeatureFlags Enumeration

Defines flags that indicate level of support for common features for a given importer.

Namespace: Assimp
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
[FlagsAttribute]
public enum ImporterFeatureFlags
Members
Member name | Value | Description
SupportsText | 1 | Indicates there is a textual encoding of the file format and it is supported.
SupportsBinary | 2 | Indicates there is a binary encoding of the file format and it is supported.
SupportsCompressed | 4 | Indicates there is a compressed encoding of the file format and it is supported.
LimitedSupport | 8 | Indicates that the importer reads only a very particular subset of the file format. This is common for formats that cannot easily be mapped to the Scene data structure.
Experimental | 16 | Indicates that the importer is experimental and used with caution - this is only reserved for importers still in development, and not typically yet in released production code.
See Also

Reference


INativeCustomMarshaler Interface

Custom marshaler for usage with the MemoryHelper for performing marshaling to-and-from unmanaged memory for non-blittable types. A type must be attributed with NativeCustomMarshalerAttribute to automatically have an instance of its marshaler be utilized.

Namespace: Assimp
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public interface INativeCustomMarshaler

The INativeCustomMarshaler type exposes the following members.

Properties
 | Name | Description
Public property | NativeDataSize | Gets the native data size in bytes.
Top
Methods
 | Name | Description
Public method | MarshalManagedToNative | Marshals the managed object to the unmanaged chunk of memory.
Public method | MarshalNativeToManaged | Marshals the managed object from the unmanaged chunk of memory.
Top
See Also

Reference


INativeCustomMarshaler Properties

The INativeCustomMarshaler type exposes the following members.

Properties
 | Name | Description
Public property | NativeDataSize | Gets the native data size in bytes.
Top
See Also

Reference

INativeCustomMarshaler Interface


INativeCustomMarshaler.NativeDataSize Property

INativeCustomMarshalerNativeDataSize Property

Gets the native data size in bytes.

Namespace: Assimp
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
int NativeDataSize { get; }

Property Value

Type: Int32
See Also

Reference

INativeCustomMarshaler Interface


INativeCustomMarshaler Methods

The INativeCustomMarshaler type exposes the following members.

Methods
 | Name | Description
Public method | MarshalManagedToNative | Marshals the managed object to the unmanaged chunk of memory.
Public method | MarshalNativeToManaged | Marshals the managed object from the unmanaged chunk of memory.
Top
See Also

Reference

INativeCustomMarshaler Interface


INativeCustomMarshaler.MarshalManagedToNative Method

INativeCustomMarshalerMarshalManagedToNative Method

Marshals the managed object to the unmanaged chunk of memory.

Namespace: Assimp
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
void MarshalManagedToNative(
    Object managedObj,
    IntPtr nativeData
)

Parameters

managedObj
Type: SystemObject
Managed object to marshal.
nativeData
Type: SystemIntPtr
Unmanaged chunk of memory to write to.
See Also

Reference

INativeCustomMarshaler Interface


INativeCustomMarshaler.MarshalNativeToManaged Method

INativeCustomMarshalerMarshalNativeToManaged Method

Marshals the managed object from the unmanaged chunk of memory.

Namespace: Assimp
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
Object MarshalNativeToManaged(
    IntPtr nativeData
)

Parameters

nativeData
Type: SystemIntPtr
Unmanaged chunk of memory to read from.

Return Value

Type: Object
Managed object marshaled.
See Also

Reference

INativeCustomMarshaler Interface


IOStream Class

Defines a stream to some file input or output source. This object is responsible for reading/writing data that is used by Assimp.
Inheritance Hierarchy
SystemObject
AssimpIOStream

Namespace: Assimp
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public abstract class IOStream : IDisposable

The IOStream type exposes the following members.

Constructors
 | Name | Description
Public method | IOStream | Constructs a new IOStream.
Top
Properties
 | Name | Description
Public property | FileMode | Gets the original desired file access mode.
Public property | IsDisposed | Gets whether or not this IOStream has been disposed.
Public property | IsValid | Gets whether the stream is in fact valid - that is, the input/output has been properly located and can be read/written.
Public property | PathToFile | Gets the original path to file given by Assimp.
Top
Methods
 | Name | Description
Public method | Close | Closes the stream - flushing any data not yet read/written and disposes of resources.
Public method | Dispose | Disposes of resources held by the IOStream.
Protected method | Dispose(Boolean) | Releases unmanaged and - optionally - managed resources.
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Finalizes an instance of the IOStream class. (Overrides ObjectFinalize.)
Public method | Flush | Flushes all data currently in the stream buffers.
Public method | GetFileSize | Gets the total file size (in bytes).
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetPosition | Gets the current file position pointer (in bytes).
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Read | Reads data from the stream.
Public method | Seek | Sets the current file position pointer.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | Write | Writes data to the stream.
Top
See Also

Reference


IOStream Constructor

Constructs a new IOStream.

Namespace: Assimp
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public IOStream(
    string pathToFile,
    FileIOMode fileMode
)

Parameters

pathToFile
Type: SystemString
Path to file given by Assimp
fileMode
Type: AssimpFileIOMode
Desired file access mode
See Also

Reference

IOStream Class


IOStream Properties

The IOStream type exposes the following members.

Properties
 | Name | Description
Public property | FileMode | Gets the original desired file access mode.
Public property | IsDisposed | Gets whether or not this IOStream has been disposed.
Public property | IsValid | Gets whether the stream is in fact valid - that is, the input/output has been properly located and can be read/written.
Public property | PathToFile | Gets the original path to file given by Assimp.
Top
See Also

Reference

IOStream Class


IOStream.FileMode Property

IOStreamFileMode Property

Gets the original desired file access mode.

Namespace: Assimp
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public FileIOMode FileMode { get; }

Property Value

Type: FileIOMode
See Also

Reference

IOStream Class


IOStream.IsDisposed Property

IOStreamIsDisposed Property

Gets whether or not this IOStream has been disposed.

Namespace: Assimp
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public bool IsDisposed { get; }

Property Value

Type: Boolean
See Also

Reference

IOStream Class


IOStream.IsValid Property

IOStreamIsValid Property

Gets whether the stream is in fact valid - that is, the input/output has been properly located and can be read/written.

Namespace: Assimp
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public abstract bool IsValid { get; }

Property Value

Type: Boolean
See Also

Reference

IOStream Class


IOStream.PathToFile Property

IOStreamPathToFile Property

Gets the original path to file given by Assimp.

Namespace: Assimp
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public string PathToFile { get; }

Property Value

Type: String
See Also

Reference

IOStream Class


IOStream Methods

The IOStream type exposes the following members.

Methods
 | Name | Description
Public method | Close | Closes the stream - flushing any data not yet read/written and disposes of resources.
Public method | Dispose | Disposes of resources held by the IOStream.
Protected method | Dispose(Boolean) | Releases unmanaged and - optionally - managed resources.
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Finalizes an instance of the IOStream class. (Overrides ObjectFinalize.)
Public method | Flush | Flushes all data currently in the stream buffers.
Public method | GetFileSize | Gets the total file size (in bytes).
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetPosition | Gets the current file position pointer (in bytes).
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Read | Reads data from the stream.
Public method | Seek | Sets the current file position pointer.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | Write | Writes data to the stream.
Top
See Also

Reference

IOStream Class


IOStream.Close Method

IOStreamClose Method

Closes the stream - flushing any data not yet read/written and disposes of resources.

Namespace: Assimp
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public virtual void Close()
See Also

Reference

IOStream Class


IOStream.Dispose Method

IOStreamDispose Method

Overload List
 | Name | Description
Public method | Dispose | Disposes of resources held by the IOStream.
Protected method | Dispose(Boolean) | Releases unmanaged and - optionally - managed resources.
Top
See Also

Reference

IOStream Class


IOStream.Dispose Method

IOStreamDispose Method

Disposes of resources held by the IOStream.

Namespace: Assimp
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public void Dispose()

Implements

IDisposableDispose
See Also

Reference

IOStream Class
Dispose Overload


IOStream.Dispose Method (Boolean)

IOStreamDispose Method (Boolean)

Releases unmanaged and - optionally - managed resources.

Namespace: Assimp
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
protected virtual void Dispose(
    bool disposing
)

Parameters

disposing
Type: SystemBoolean
True to release both managed and unmanaged resources; False to release only unmanaged resources.
See Also

Reference

IOStream Class
Dispose Overload


IOStream.Finalize Method

IOStreamFinalize Method

Finalizes an instance of the IOStream class.

Namespace: Assimp
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
protected override void Finalize()

Implements

ObjectFinalize
See Also

Reference

IOStream Class


IOStream.Flush Method

IOStreamFlush Method

Flushes all data currently in the stream buffers.

Namespace: Assimp
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public abstract void Flush()
See Also

Reference

IOStream Class


IOStream.GetFileSize Method

IOStreamGetFileSize Method

Gets the total file size (in bytes).

Namespace: Assimp
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public abstract long GetFileSize()

Return Value

Type: Int64
File size in bytes
See Also

Reference

IOStream Class


IOStream.GetPosition Method

IOStreamGetPosition Method

Gets the current file position pointer (in bytes).

Namespace: Assimp
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public abstract long GetPosition()

Return Value

Type: Int64
Current file position pointer (in bytes)
See Also

Reference

IOStream Class


IOStream.Read Method

IOStreamRead Method

Reads data from the stream.

Namespace: Assimp
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public abstract long Read(
    byte[] dataRead,
    long count
)

Parameters

dataRead
Type: SystemByte
Byte buffer to store the read data in
count
Type: SystemInt64
Number of bytes to read

Return Value

Type: Int64
Number of bytes actually read. Should be equal to the specified count, unless if EoF was hit or an error occured.
See Also

Reference

IOStream Class


IOStream.Seek Method

IOStreamSeek Method

Sets the current file position pointer.

Namespace: Assimp
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public abstract ReturnCode Seek(
    long offset,
    Origin seekOrigin
)

Parameters

offset
Type: SystemInt64
Offset in bytes from the origin
seekOrigin
Type: AssimpOrigin
Origin reference

Return Value

Type: ReturnCode
ReturnCode indicating success or failure.
See Also

Reference

IOStream Class


IOStream.Write Method

IOStreamWrite Method

Writes data to the stream.

Namespace: Assimp
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public abstract long Write(
    byte[] dataToWrite,
    long count
)

Parameters

dataToWrite
Type: SystemByte
Data to write
count
Type: SystemInt64
Number of bytes to write

Return Value

Type: Int64
Number of bytes actually written. Should be equal to the specified count, unless if EoF was hit or an error occured.
See Also

Reference

IOStream Class


IOSystem Class

Defines a custom IO handler that can be registered to an importer that will handle I/O for assimp. This includes searching/opening files to read during import, and creating/writing to files during export.
Inheritance Hierarchy
SystemObject
AssimpIOSystem
AssimpFileIOSystem

Namespace: Assimp
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public abstract class IOSystem : IDisposable

The IOSystem type exposes the following members.

Constructors
 | Name | Description
Public method | IOSystem | Constructs a new IOSystem.
Top
Properties
 | Name | Description
Public property | IsDisposed | Gets whether or not this IOSystem has been disposed.
Public property | OpenFileCount | Gets the number of currently opened streams.
Top
Methods
 | Name | Description
Public method | CloseAllFiles | Closes all outstanding streams owned by this IOSystem.
Public method | CloseFile | Closes a stream that is owned by this IOSystem.
Public method | Dispose | Disposes of all resources held by this object.
Protected method | Dispose(Boolean) | Releases unmanaged and - optionally - managed resources.
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Finalizes an instance of the IOSystem class. (Overrides ObjectFinalize.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | OpenFile | Opens a stream to a file.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference


IOSystem Constructor

Constructs a new IOSystem.

Namespace: Assimp
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public IOSystem()
See Also

Reference

IOSystem Class


IOSystem Properties

The IOSystem type exposes the following members.

Properties
 | Name | Description
Public property | IsDisposed | Gets whether or not this IOSystem has been disposed.
Public property | OpenFileCount | Gets the number of currently opened streams.
Top
See Also

Reference

IOSystem Class


IOSystem.IsDisposed Property

IOSystemIsDisposed Property

Gets whether or not this IOSystem has been disposed.

Namespace: Assimp
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public bool IsDisposed { get; }

Property Value

Type: Boolean
See Also

Reference

IOSystem Class


IOSystem.OpenFileCount Property

IOSystemOpenFileCount Property

Gets the number of currently opened streams.

Namespace: Assimp
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public int OpenFileCount { get; }

Property Value

Type: Int32
See Also

Reference

IOSystem Class


IOSystem Methods

The IOSystem type exposes the following members.

Methods
 | Name | Description
Public method | CloseAllFiles | Closes all outstanding streams owned by this IOSystem.
Public method | CloseFile | Closes a stream that is owned by this IOSystem.
Public method | Dispose | Disposes of all resources held by this object.
Protected method | Dispose(Boolean) | Releases unmanaged and - optionally - managed resources.
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Finalizes an instance of the IOSystem class. (Overrides ObjectFinalize.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | OpenFile | Opens a stream to a file.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

IOSystem Class


IOSystem.CloseAllFiles Method

IOSystemCloseAllFiles Method

Closes all outstanding streams owned by this IOSystem.

Namespace: Assimp
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public virtual void CloseAllFiles()
See Also

Reference

IOSystem Class


IOSystem.CloseFile Method

IOSystemCloseFile Method

Closes a stream that is owned by this IOSystem.

Namespace: Assimp
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public virtual void CloseFile(
    IOStream stream
)

Parameters

stream
Type: AssimpIOStream
Stream to close
See Also

Reference

IOSystem Class


IOSystem.Dispose Method

IOSystemDispose Method

Overload List
 | Name | Description
Public method | Dispose | Disposes of all resources held by this object.
Protected method | Dispose(Boolean) | Releases unmanaged and - optionally - managed resources.
Top
See Also

Reference

IOSystem Class


IOSystem.Dispose Method

IOSystemDispose Method

Disposes of all resources held by this object.

Namespace: Assimp
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public void Dispose()

Implements

IDisposableDispose
See Also

Reference

IOSystem Class
Dispose Overload


IOSystem.Dispose Method (Boolean)

IOSystemDispose Method (Boolean)

Releases unmanaged and - optionally - managed resources.

Namespace: Assimp
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
protected virtual void Dispose(
    bool disposing
)

Parameters

disposing
Type: SystemBoolean
True to release both managed and unmanaged resources; False to release only unmanaged resources.
See Also

Reference

IOSystem Class
Dispose Overload


IOSystem.Finalize Method

IOSystemFinalize Method

Finalizes an instance of the IOSystem class.

Namespace: Assimp
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
protected override void Finalize()

Implements

ObjectFinalize
See Also

Reference

IOSystem Class


IOSystem.OpenFile Method

IOSystemOpenFile Method

Opens a stream to a file.

Namespace: Assimp
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public abstract IOStream OpenFile(
    string pathToFile,
    FileIOMode fileMode
)

Parameters

pathToFile
Type: SystemString
Path to the file
fileMode
Type: AssimpFileIOMode
Desired file access mode

Return Value

Type: IOStream
The IO stream
See Also

Reference

IOSystem Class


Light Class

Describes a light source in the scene. Assimp supports multiple light sources including spot, point, and directional lights. All are defined by a single structure and distinguished by their parameters. Lights have corresponding nodes in the scenegraph.

Some file formats such as 3DS and ASE export a "target point", e.g. the point a spot light is looking at (it can even be animated). Assimp writes the target point as a subnode of a spotlight's main node called "spotName.Target". However, this is just additional information then, the transform tracks of the main node make the spot light already point in the right direction.

Inheritance Hierarchy
SystemObject
AssimpLight

Namespace: Assimp
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public sealed class Light : IMarshalable<Light, AiLight>

The Light type exposes the following members.

Constructors
 | Name | Description
Public method | Light | Constructs a new instance of the Light class.
Top
Properties
Name Description
Public property AngleInnerCone
Gets or sets the inner angle of a spot light's light cone. The spot light has maximum influence on objects inside this angle. The angle is given in radians, it is 2PI for point lights and defined for directional lights.
Public property AngleOuterCone
Gets or sets the outer angle of a spot light's light cone. The spot light does not affect objects outside this angle. The angle is given in radians. It is 2PI for point lights and undefined for directional lights. The outer angle must be greater than or equal to the inner angle.
Public property AreaSize
Gets or sets the Width (X) and Height (Y) of the area that represents an Area light.
Public property AttenuationConstant
Gets or sets the constant light attenuation factor. The intensity of the light source at a given distance 'd' from the light position is
Copy
Atten = 1 / (att0 + att1 * d + att2 * d*d)
.

This member corresponds to the att0 variable in the equation and is undefined for directional lights.

Public property AttenuationLinear
Gets or sets the linear light attenuation factor. The intensity of the light source at a given distance 'd' from the light position is
Copy
Atten = 1 / (att0 + att1 * d + att2 * d*d)

This member corresponds to the att1 variable in the equation and is undefined for directional lights.

Public property AttenuationQuadratic
Gets or sets the quadratic light attenuation factor. The intensity of the light source at a given distance 'd' from the light position is
Copy
Atten = 1 / (att0 + att1 * d + att2 * d*d)
.

This member corresponds to the att2 variable in the equation and is undefined for directional lights.

Public property ColorAmbient
Gets or sets the ambient color of the light source. The ambient light color is multiplied with the ambient material color to obtain the final color that contributes to the ambient shading term.
Public property ColorDiffuse
Gets or sets the diffuse color of the light source. The diffuse light color is multiplied with the diffuse material color to obtain the final color that contributes to the diffuse shading term.
Public property ColorSpecular
Gets or sets the specular color of the light source. The specular light color is multiplied with the specular material color to obtain the final color that contributes to the specular shading term.
Public property Direction
Gets or sets the direction of the light source in space, relative to the transformation of the node corresponding to the light. This is undefined for point lights.
Public property LightType
Gets or sets the type of light source. This should never be undefined.
Public property Name
Gets or sets the name of the light source. This corresponds to a node present in the scenegraph.
Public property Position
Gets or sets the position of the light source in space, relative to the transformation of the node corresponding to the light. This is undefined for directional lights.
Public property Up
Gets or sets the up vector of the light source in space, relative to the transformation of the node corresponding to the light. This is undefined for point lights.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
 | FreeNative | Frees unmanaged memory created by ToNative(IntPtr, Native).
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference


Light Constructor

Constructs a new instance of the Light class.

Namespace: Assimp
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public Light()
See Also

Reference

Light Class


Light Properties

The Light type exposes the following members.

Properties
Name Description
Public property AngleInnerCone
Gets or sets the inner angle of a spot light's light cone. The spot light has maximum influence on objects inside this angle. The angle is given in radians, it is 2PI for point lights and defined for directional lights.
Public property AngleOuterCone
Gets or sets the outer angle of a spot light's light cone. The spot light does not affect objects outside this angle. The angle is given in radians. It is 2PI for point lights and undefined for directional lights. The outer angle must be greater than or equal to the inner angle.
Public property AreaSize
Gets or sets the Width (X) and Height (Y) of the area that represents an Area light.
Public property AttenuationConstant
Gets or sets the constant light attenuation factor. The intensity of the light source at a given distance 'd' from the light position is
Copy
Atten = 1 / (att0 + att1 * d + att2 * d*d)
.

This member corresponds to the att0 variable in the equation and is undefined for directional lights.

Public property AttenuationLinear
Gets or sets the linear light attenuation factor. The intensity of the light source at a given distance 'd' from the light position is
Copy
Atten = 1 / (att0 + att1 * d + att2 * d*d)

This member corresponds to the att1 variable in the equation and is undefined for directional lights.

Public property AttenuationQuadratic
Gets or sets the quadratic light attenuation factor. The intensity of the light source at a given distance 'd' from the light position is
Copy
Atten = 1 / (att0 + att1 * d + att2 * d*d)
.

This member corresponds to the att2 variable in the equation and is undefined for directional lights.

Public property ColorAmbient
Gets or sets the ambient color of the light source. The ambient light color is multiplied with the ambient material color to obtain the final color that contributes to the ambient shading term.
Public property ColorDiffuse
Gets or sets the diffuse color of the light source. The diffuse light color is multiplied with the diffuse material color to obtain the final color that contributes to the diffuse shading term.
Public property ColorSpecular
Gets or sets the specular color of the light source. The specular light color is multiplied with the specular material color to obtain the final color that contributes to the specular shading term.
Public property Direction
Gets or sets the direction of the light source in space, relative to the transformation of the node corresponding to the light. This is undefined for point lights.
Public property LightType
Gets or sets the type of light source. This should never be undefined.
Public property Name
Gets or sets the name of the light source. This corresponds to a node present in the scenegraph.
Public property Position
Gets or sets the position of the light source in space, relative to the transformation of the node corresponding to the light. This is undefined for directional lights.
Public property Up
Gets or sets the up vector of the light source in space, relative to the transformation of the node corresponding to the light. This is undefined for point lights.
Top
See Also

Reference

Light Class


Light.AngleInnerCone Property

LightAngleInnerCone Property

Gets or sets the inner angle of a spot light's light cone. The spot light has maximum influence on objects inside this angle. The angle is given in radians, it is 2PI for point lights and defined for directional lights.

Namespace: Assimp
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public float AngleInnerCone { get; set; }

Property Value

Type: Single
See Also

Reference

Light Class


Light.AngleOuterCone Property

LightAngleOuterCone Property

Gets or sets the outer angle of a spot light's light cone. The spot light does not affect objects outside this angle. The angle is given in radians. It is 2PI for point lights and undefined for directional lights. The outer angle must be greater than or equal to the inner angle.

Namespace: Assimp
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public float AngleOuterCone { get; set; }

Property Value

Type: Single
See Also

Reference

Light Class


Light.AreaSize Property

LightAreaSize Property

Gets or sets the Width (X) and Height (Y) of the area that represents an Area light.

Namespace: Assimp
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public Vector2D AreaSize { get; set; }

Property Value

Type: Vector2D
See Also

Reference

Light Class


Light.AttenuationConstant Property

LightAttenuationConstant Property

Gets or sets the constant light attenuation factor. The intensity of the light source at a given distance 'd' from the light position is
Copy
Atten = 1 / (att0 + att1 * d + att2 * d*d)
.

This member corresponds to the att0 variable in the equation and is undefined for directional lights.

Namespace: Assimp
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public float AttenuationConstant { get; set; }

Property Value

Type: Single
See Also

Reference

Light Class


Light.AttenuationLinear Property

LightAttenuationLinear Property

Gets or sets the linear light attenuation factor. The intensity of the light source at a given distance 'd' from the light position is
Copy
Atten = 1 / (att0 + att1 * d + att2 * d*d)

This member corresponds to the att1 variable in the equation and is undefined for directional lights.

Namespace: Assimp
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public float AttenuationLinear { get; set; }

Property Value

Type: Single
See Also

Reference

Light Class


Light.AttenuationQuadratic Property

LightAttenuationQuadratic Property

Gets or sets the quadratic light attenuation factor. The intensity of the light source at a given distance 'd' from the light position is
Copy
Atten = 1 / (att0 + att1 * d + att2 * d*d)
.

This member corresponds to the att2 variable in the equation and is undefined for directional lights.

Namespace: Assimp
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public float AttenuationQuadratic { get; set; }

Property Value

Type: Single
See Also

Reference

Light Class


Light.ColorAmbient Property

LightColorAmbient Property

Gets or sets the ambient color of the light source. The ambient light color is multiplied with the ambient material color to obtain the final color that contributes to the ambient shading term.

Namespace: Assimp
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public Color3D ColorAmbient { get; set; }

Property Value

Type: Color3D
See Also

Reference

Light Class


Light.ColorDiffuse Property

LightColorDiffuse Property

Gets or sets the diffuse color of the light source. The diffuse light color is multiplied with the diffuse material color to obtain the final color that contributes to the diffuse shading term.

Namespace: Assimp
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public Color3D ColorDiffuse { get; set; }

Property Value

Type: Color3D
See Also

Reference

Light Class


Light.ColorSpecular Property

LightColorSpecular Property

Gets or sets the specular color of the light source. The specular light color is multiplied with the specular material color to obtain the final color that contributes to the specular shading term.

Namespace: Assimp
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public Color3D ColorSpecular { get; set; }

Property Value

Type: Color3D
See Also

Reference

Light Class


Light.Direction Property

LightDirection Property

Gets or sets the direction of the light source in space, relative to the transformation of the node corresponding to the light. This is undefined for point lights.

Namespace: Assimp
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public Vector3D Direction { get; set; }

Property Value

Type: Vector3D
See Also

Reference

Light Class


Light.LightType Property

LightLightType Property

Gets or sets the type of light source. This should never be undefined.

Namespace: Assimp
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public LightSourceType LightType { get; set; }

Property Value

Type: LightSourceType
See Also

Reference

Light Class


Light.Name Property

LightName Property

Gets or sets the name of the light source. This corresponds to a node present in the scenegraph.

Namespace: Assimp
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public string Name { get; set; }

Property Value

Type: String
See Also

Reference

Light Class


Light.Position Property

LightPosition Property

Gets or sets the position of the light source in space, relative to the transformation of the node corresponding to the light. This is undefined for directional lights.

Namespace: Assimp
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public Vector3D Position { get; set; }

Property Value

Type: Vector3D
See Also

Reference

Light Class


Light.Up Property

LightUp Property

Gets or sets the up vector of the light source in space, relative to the transformation of the node corresponding to the light. This is undefined for point lights.

Namespace: Assimp
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public Vector3D Up { get; set; }

Property Value

Type: Vector3D
See Also

Reference

Light Class


Light Methods

The Light type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
 | FreeNative | Frees unmanaged memory created by ToNative(IntPtr, Native).
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Light Class


Light.FreeNative Method

LightFreeNative Method

Frees unmanaged memory created by ToNative(IntPtr, Native).

Namespace: Assimp
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public static void FreeNative(
    IntPtr nativeValue,
    bool freeNative
)

Parameters

nativeValue
Type: SystemIntPtr
Native value to free
freeNative
Type: SystemBoolean
True if the unmanaged memory should be freed, false otherwise.
See Also

Reference

Light Class


LightSourceType Enumeration

Enumerates all supported light sources.

Namespace: Assimp
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public enum LightSourceType
Members
Member name | Value | Description
Undefined | 0 | Unknown light.
Directional | 1 | Directional light source that has a well-defined direction but is infinitely far away, e.g. the sun.
Point | 2 | Point light source that has a well-defined position in space but is omni-directional, e.g. a light bulb.
Spot | 3 | Spot light source emits light from a position in space, in a certain direction that is limited by an angle, like a cone.
Ambient | 4 | Generic light level of the world, including the bounces of all other light sources. Typically, there's at most one ambient light in a scene and is usually just a constant color. This light does not have a valid position, direction, or other properties - just the color.
Area | 5 | An area light is a rectangle with a predefined size that uniformly emits light from one of its sides. The position is center of the rectangle and the direction is its normal vector.
See Also

Reference


LoggingCallback Delegate

Callback delegate for Assimp's LogStream.

Namespace: Assimp
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public delegate void LoggingCallback(
    string msg,
    string userData
)

Parameters

msg
Type: SystemString
Log message
userData
Type: SystemString
Supplied user data
See Also

Reference


LogStream Class

Represents a log stream, which receives all log messages and streams them somewhere.
Inheritance Hierarchy
SystemObject
AssimpLogStream
AssimpConsoleLogStream

Namespace: Assimp
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public class LogStream : IDisposable

The LogStream type exposes the following members.

Constructors
 | Name | Description
Protected method | LogStream | Constructs a new LogStream.
Protected method | LogStream(String) | Constructs a new LogStream.
Public method | LogStream(LoggingCallback) | Constructs a new LogStream.
Public method | LogStream(LoggingCallback, String) | Constructs a new LogStream.
Top
Properties
 | Name | Description
Public property | IsAttached | Gets whether or not the logstream is currently attached to the library.
Public property | IsDisposed | Gets whether the logstream has been disposed or not.
 | IsVerboseLoggingEnabled | Gets or sets, if verbose logging is enabled globally.
Public property | UserData | Gets or sets the user data to be passed to the callback.
Top
Methods
 | Name | Description
Public method | Attach | Attaches the logstream to the library.
Public method | Detach | Detaches the logstream from the library.
 | DetachAllLogstreams | Detaches all active logstreams from the library.
Public method | Dispose | Releases unmanaged resources held by the LogStream. This should not be called by the user if the logstream is currently attached to an assimp importer.
Protected method | Dispose(Boolean) | Releases unmanaged and - optionally - managed resources.
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Finalizes an instance of the LogStream class. (Overrides ObjectFinalize.)
 | GetAttachedLogStreams | Gets all active logstreams that are currently attached to the library.
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Log | Logs a message.
Protected method | LogMessage | Override this method to log a message for a subclass of Logstream, if no callback was set.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | OnAttach | Called when the log stream has been attached to the assimp importer. At this point it may start receiving messages.
Protected method | OnDetach | Called when the log stream has been detatched from the assimp importer. After this point it will stop receiving messages until it is re-attached.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference


LogStream Constructor

Overload List
 | Name | Description
Protected method | LogStream | Constructs a new LogStream.
Protected method | LogStream(String) | Constructs a new LogStream.
Public method | LogStream(LoggingCallback) | Constructs a new LogStream.
Public method | LogStream(LoggingCallback, String) | Constructs a new LogStream.
Top
See Also

Reference

LogStream Class


LogStream Constructor

Constructs a new LogStream.

Namespace: Assimp
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
protected LogStream()
See Also

Reference

LogStream Class
LogStream Overload


LogStream Constructor (String)

Constructs a new LogStream.

Namespace: Assimp
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
protected LogStream(
    string userData
)

Parameters

userData
Type: SystemString
User-supplied data
See Also

Reference

LogStream Class
LogStream Overload


LogStream Constructor (LoggingCallback)

Constructs a new LogStream.

Namespace: Assimp
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public LogStream(
    LoggingCallback callback
)

Parameters

callback
Type: AssimpLoggingCallback
Logging callback that is called when messages are received by the log stream.
See Also

Reference

LogStream Class
LogStream Overload


LogStream Constructor (LoggingCallback, String)

Constructs a new LogStream.

Namespace: Assimp
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public LogStream(
    LoggingCallback callback,
    string userData
)

Parameters

callback
Type: AssimpLoggingCallback
Logging callback that is called when messages are received by the log stream.
userData
Type: SystemString
User-supplied data
See Also

Reference

LogStream Class
LogStream Overload


LogStream Properties

The LogStream type exposes the following members.

Properties
 | Name | Description
Public property | IsAttached | Gets whether or not the logstream is currently attached to the library.
Public property | IsDisposed | Gets whether the logstream has been disposed or not.
 | IsVerboseLoggingEnabled | Gets or sets, if verbose logging is enabled globally.
Public property | UserData | Gets or sets the user data to be passed to the callback.
Top
See Also

Reference

LogStream Class


LogStream.IsAttached Property

LogStreamIsAttached Property

Gets whether or not the logstream is currently attached to the library.

Namespace: Assimp
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public bool IsAttached { get; }

Property Value

Type: Boolean
See Also

Reference

LogStream Class


LogStream.IsDisposed Property

LogStreamIsDisposed Property

Gets whether the logstream has been disposed or not.

Namespace: Assimp
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public bool IsDisposed { get; }

Property Value

Type: Boolean
See Also

Reference

LogStream Class


LogStream.IsVerboseLoggingEnabled Property

LogStreamIsVerboseLoggingEnabled Property

Gets or sets, if verbose logging is enabled globally.

Namespace: Assimp
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public static bool IsVerboseLoggingEnabled { get; set; }

Property Value

Type: Boolean
See Also

Reference

LogStream Class


LogStream.UserData Property

LogStreamUserData Property

Gets or sets the user data to be passed to the callback.

Namespace: Assimp
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public string UserData { get; set; }

Property Value

Type: String
See Also

Reference

LogStream Class


LogStream Methods

The LogStream type exposes the following members.

Methods
 | Name | Description
Public method | Attach | Attaches the logstream to the library.
Public method | Detach | Detaches the logstream from the library.
 | DetachAllLogstreams | Detaches all active logstreams from the library.
Public method | Dispose | Releases unmanaged resources held by the LogStream. This should not be called by the user if the logstream is currently attached to an assimp importer.
Protected method | Dispose(Boolean) | Releases unmanaged and - optionally - managed resources.
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Finalizes an instance of the LogStream class. (Overrides ObjectFinalize.)
 | GetAttachedLogStreams | Gets all active logstreams that are currently attached to the library.
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Log | Logs a message.
Protected method | LogMessage | Override this method to log a message for a subclass of Logstream, if no callback was set.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | OnAttach | Called when the log stream has been attached to the assimp importer. At this point it may start receiving messages.
Protected method | OnDetach | Called when the log stream has been detatched from the assimp importer. After this point it will stop receiving messages until it is re-attached.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

LogStream Class


LogStream.Attach Method

LogStreamAttach Method

Attaches the logstream to the library.

Namespace: Assimp
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public void Attach()
See Also

Reference

LogStream Class


LogStream.Detach Method

LogStreamDetach Method

Detaches the logstream from the library.

Namespace: Assimp
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public void Detach()
See Also

Reference

LogStream Class


LogStream.DetachAllLogstreams Method

LogStreamDetachAllLogstreams Method

Detaches all active logstreams from the library.

Namespace: Assimp
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public static void DetachAllLogstreams()
See Also

Reference

LogStream Class


LogStream.Dispose Method

LogStreamDispose Method

Overload List
 | Name | Description
Public method | Dispose | Releases unmanaged resources held by the LogStream. This should not be called by the user if the logstream is currently attached to an assimp importer.
Protected method | Dispose(Boolean) | Releases unmanaged and - optionally - managed resources.
Top
See Also

Reference

LogStream Class


LogStream.Dispose Method

LogStreamDispose Method

Releases unmanaged resources held by the LogStream. This should not be called by the user if the logstream is currently attached to an assimp importer.

Namespace: Assimp
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public void Dispose()

Implements

IDisposableDispose
See Also

Reference

LogStream Class
Dispose Overload


LogStream.Dispose Method (Boolean)

LogStreamDispose Method (Boolean)

Releases unmanaged and - optionally - managed resources.

Namespace: Assimp
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
protected virtual void Dispose(
    bool disposing
)

Parameters

disposing
Type: SystemBoolean
True to release both managed and unmanaged resources; False to release only unmanaged resources.
See Also

Reference

LogStream Class
Dispose Overload


LogStream.Finalize Method

LogStreamFinalize Method

Finalizes an instance of the LogStream class.

Namespace: Assimp
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
protected override void Finalize()

Implements

ObjectFinalize
See Also

Reference

LogStream Class


LogStream.GetAttachedLogStreams Method

LogStreamGetAttachedLogStreams Method

Gets all active logstreams that are currently attached to the library.

Namespace: Assimp
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public static IEnumerable<LogStream> GetAttachedLogStreams()

Return Value

Type: IEnumerable LogStream
Collection of active logstreams attached to the library.
See Also

Reference

LogStream Class


LogStream.Log Method

LogStreamLog Method

Logs a message.

Namespace: Assimp
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public void Log(
    string msg
)

Parameters

msg
Type: SystemString
Message contents
See Also

Reference

LogStream Class


LogStream.LogMessage Method

LogStreamLogMessage Method

Override this method to log a message for a subclass of Logstream, if no callback was set.

Namespace: Assimp
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
protected virtual void LogMessage(
    string msg,
    string userData
)

Parameters

msg
Type: SystemString
Message
userData
Type: SystemString
User data
See Also

Reference

LogStream Class


LogStream.OnAttach Method

LogStreamOnAttach Method

Called when the log stream has been attached to the assimp importer. At this point it may start receiving messages.

Namespace: Assimp
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
protected virtual void OnAttach()
See Also

Reference

LogStream Class


LogStream.OnDetach Method

LogStreamOnDetach Method

Called when the log stream has been detatched from the assimp importer. After this point it will stop receiving messages until it is re-attached.

Namespace: Assimp
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
protected virtual void OnDetach()
See Also

Reference

LogStream Class


Material Class

A material contains all the information that describes how to render a mesh. E.g. textures, colors, and render states. Internally all this information is stored as key-value pair properties. The class contains many convienence methods and properties for accessing non-texture/texture properties without having to know the Assimp material key names. Not all properties may be present, and if they aren't a default value will be returned.
Inheritance Hierarchy
SystemObject
AssimpMaterial

Namespace: Assimp
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public sealed class Material : IMarshalable<Material, AiMaterial>

The Material type exposes the following members.

Constructors
 | Name | Description
Public method | Material | Constructs a new instance of the Material class.
Top
Properties
 | Name | Description
Public property | BlendMode | Gets the blending mode. Default value is Default.
Public property | BumpScaling | Gets the bump scaling. Default value is 0.0f;
Public property | ColorAmbient | Gets the color ambient. Default value is (.2f, .2f, .2f, 1.0f).
Public property | ColorDiffuse | Gets the color diffuse. Default value is white.
Public property | ColorEmissive | Gets the color emissive. Default value is black.
Public property | ColorReflective | Gets the color reflective. Default value is black.
Public property | ColorSpecular | Gets the color specular. Default value is black.
Public property | ColorTransparent | Gets the color transparent. Default value is black.
Public property | HasBlendMode | Checks if the material has a blend mode property.
Public property | HasBumpScaling | Checks if the material has a bump scaling property.
Public property | HasColorAmbient | Checks if the material has a color ambient property.
Public property | HasColorDiffuse | Checks if the material has a color diffuse property.
Public property | HasColorEmissive | Checks if the material has a color emissive property.
Public property | HasColorReflective | Checks if the material has a color reflective property.
Public property | HasColorSpecular | Checks if the material has a color specular property.
Public property | HasColorTransparent | Checks if the material has a color transparent property.
Public property | HasName | Checks if the material has a name property.
Public property | HasOpacity | Checks if the material has an opacity property.
Public property | HasReflectivity | Checks if the material has a reflectivty property.
Public property | HasShadingMode | Checks if the material has a shading-mode property.
Public property | HasShininess | Checks if the material has a shininess property.
Public property | HasShininessStrength | Checks if the material has a shininess strength property.
Public property | HasTextureAmbient | Gets if the material has a ambient texture in the first texture index.
Public property | HasTextureDiffuse | Gets if the material has a diffuse texture in the first texture index.
Public property | HasTextureDisplacement | Gets if the material has a displacement texture in the first texture index.
Public property | HasTextureEmissive | Gets if the material has a emissive texture in the first texture index.
Public property | HasTextureHeight | Gets if the material has a height texture in the first texture index.
Public property | HasTextureLightMap | Gets if the material has a light map texture in the first texture index.
Public property | HasTextureNormal | Gets if the material has a normal texture in the first texture index.
Public property | HasTextureOpacity | Gets if the material has an opacity texture in the first texture index.
Public property | HasTextureReflection | Gets if the material has a reflection texture in the first texture index.
Public property | HasTextureSpecular | Gets if the material has a specular texture in the first texture index.
Public property | HasTwoSided | Checks if the material has a two-sided property.
Public property | HasWireFrame | Checks if the material has a wireframe property.
Public property | IsTwoSided | Gets if the material should be rendered as two-sided. Default value is false.
Public property | IsWireFrameEnabled | Gets if wireframe should be enabled. Default value is false.
Public property | Name | Gets the material name value, if any. Default value is an empty string.
Public property | Opacity | Gets the opacity. Default value is 1.0f.
Public property | PropertyCount | Gets the number of properties contained in the material.
Public property | Reflectivity | Gets the reflectivity. Default value is 0.0f;
Public property | ShadingMode | Gets the shading mode. Default value is None, meaning it is not defined.
Public property | Shininess | Gets the shininess. Default value is 0.0f;
Public property | ShininessStrength | Gets the shininess strength. Default vaulue is 1.0f.
Public property | TextureAmbient | Gets or sets ambient texture properties in the first texture index.
Public property | TextureDiffuse | Gets or sets diffuse texture properties in the first texture index.
Public property | TextureDisplacement | Gets or sets displacement texture properties in the first texture index.
Public property | TextureEmissive | Gets or sets emissive texture properties in the first texture index.
Public property | TextureHeight | Gets or sets height texture properties in the first texture index.
Public property | TextureLightMap | Gets or sets light map texture properties in the first texture index.
Public property | TextureNormal | Gets or sets normal texture properties in the first texture index.
Public property | TextureOpacity | Gets or sets opacity texture properties in the first texture index.
Public property | TextureReflection | Gets or sets reflection texture properties in the first texture index.
Public property | TextureSpecular | Gets or sets specular texture properties in the first texture index.
Top
Methods
 | Name | Description
Public method | AddMaterialTexture(TextureSlot) | Adds a texture to the material - this bulk creates a property for each field. This will either create properties or overwrite existing properties. If the texture has no file path, nothing is added.
Public method | AddMaterialTexture(TextureSlot, Boolean) | Adds a texture to the material - this bulk creates a property for each field. This will either create properties or overwrite existing properties. If the texture has no file path, nothing is added.
Public method | AddProperty | Adds a property to this material.
Public method | Clear | Removes all properties from the material;
 | CreateFullyQualifiedName | Helper method to construct a fully qualified name from the input parameters. All the input parameters are combined into the fully qualified name: {baseName},{texType},{texIndex}. E.g. "$clr.diffuse,0,0" or "$tex.file,1,0". This is the name that is used as the material dictionary key.
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
 | FreeNative | Frees unmanaged memory created by ToNative(IntPtr, Native).
Public method | GetAllMaterialTextures | Gets all textures in the material.
Public method | GetAllProperties | Gets -all- properties contained in the Material.
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetMaterialTexture | Gets a texture that corresponds to the type/index.
Public method | GetMaterialTextureCount | Gets all the number of textures that are of the specified texture type.
Public method | GetMaterialTextures | Gets all textures that correspond to the type.
Public method | GetNonTextureProperty | Gets the non-texture properties contained in this Material. The name should be the "base name", as in it should not contain texture type/texture index information. E.g. "$clr.diffuse" rather than "$clr.diffuse,0,0". The extra data will be filled in automatically.
Public method | GetProperty(String) | Gets the material property by its fully qualified name. The format is: {baseName},{texType},{texIndex}. E.g. "$clr.diffuse,0,0" or "$tex.file,1,0".
Public method | GetProperty(String, TextureType, Int32) | Gets the material property. All the input parameters are combined into the fully qualified name: {baseName},{texType},{texIndex}. E.g. "$clr.diffuse,0,0" or "$tex.file,1,0".
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | HasNonTextureProperty | Checks if the material has the specified non-texture property. The name should be the "base name", as in it should not contain texture type/texture index information. E.g. "$clr.diffuse" rather than "$clr.diffuse,0,0". The extra data will be filled in automatically.
Public method | HasProperty(String) | Checks if the material has the specified property by looking up its fully qualified name. The format is: {baseName},{texType},{texIndex}. E.g. "$clr.diffuse,0,0" or "$tex.file,1,0".
Public method | HasProperty(String, TextureType, Int32) | Checks if the material has the specified property. All the input parameters are combined into the fully qualified name: {baseName},{texType},{texIndex}. E.g. "$clr.diffuse,0,0" or "$tex.file,1,0".
Public method | RemoveMaterialTexture | Removes a texture from the material - this bulk removes a property for each field. If the texture has no file path, nothing is removed
Public method | RemoveNonTextureProperty | Removes a non-texture property from the material.
Public method | RemoveProperty(String) | Removes a property from the material.
Public method | RemoveProperty(String, TextureType, Int32) | Removes a property from the material.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference


Material Constructor

Constructs a new instance of the Material class.

Namespace: Assimp
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public Material()
See Also

Reference

Material Class


Material Properties

The Material type exposes the following members.

Properties
 | Name | Description
Public property | BlendMode | Gets the blending mode. Default value is Default.
Public property | BumpScaling | Gets the bump scaling. Default value is 0.0f;
Public property | ColorAmbient | Gets the color ambient. Default value is (.2f, .2f, .2f, 1.0f).
Public property | ColorDiffuse | Gets the color diffuse. Default value is white.
Public property | ColorEmissive | Gets the color emissive. Default value is black.
Public property | ColorReflective | Gets the color reflective. Default value is black.
Public property | ColorSpecular | Gets the color specular. Default value is black.
Public property | ColorTransparent | Gets the color transparent. Default value is black.
Public property | HasBlendMode | Checks if the material has a blend mode property.
Public property | HasBumpScaling | Checks if the material has a bump scaling property.
Public property | HasColorAmbient | Checks if the material has a color ambient property.
Public property | HasColorDiffuse | Checks if the material has a color diffuse property.
Public property | HasColorEmissive | Checks if the material has a color emissive property.
Public property | HasColorReflective | Checks if the material has a color reflective property.
Public property | HasColorSpecular | Checks if the material has a color specular property.
Public property | HasColorTransparent | Checks if the material has a color transparent property.
Public property | HasName | Checks if the material has a name property.
Public property | HasOpacity | Checks if the material has an opacity property.
Public property | HasReflectivity | Checks if the material has a reflectivty property.
Public property | HasShadingMode | Checks if the material has a shading-mode property.
Public property | HasShininess | Checks if the material has a shininess property.
Public property | HasShininessStrength | Checks if the material has a shininess strength property.
Public property | HasTextureAmbient | Gets if the material has a ambient texture in the first texture index.
Public property | HasTextureDiffuse | Gets if the material has a diffuse texture in the first texture index.
Public property | HasTextureDisplacement | Gets if the material has a displacement texture in the first texture index.
Public property | HasTextureEmissive | Gets if the material has a emissive texture in the first texture index.
Public property | HasTextureHeight | Gets if the material has a height texture in the first texture index.
Public property | HasTextureLightMap | Gets if the material has a light map texture in the first texture index.
Public property | HasTextureNormal | Gets if the material has a normal texture in the first texture index.
Public property | HasTextureOpacity | Gets if the material has an opacity texture in the first texture index.
Public property | HasTextureReflection | Gets if the material has a reflection texture in the first texture index.
Public property | HasTextureSpecular | Gets if the material has a specular texture in the first texture index.
Public property | HasTwoSided | Checks if the material has a two-sided property.
Public property | HasWireFrame | Checks if the material has a wireframe property.
Public property | IsTwoSided | Gets if the material should be rendered as two-sided. Default value is false.
Public property | IsWireFrameEnabled | Gets if wireframe should be enabled. Default value is false.
Public property | Name | Gets the material name value, if any. Default value is an empty string.
Public property | Opacity | Gets the opacity. Default value is 1.0f.
Public property | PropertyCount | Gets the number of properties contained in the material.
Public property | Reflectivity | Gets the reflectivity. Default value is 0.0f;
Public property | ShadingMode | Gets the shading mode. Default value is None, meaning it is not defined.
Public property | Shininess | Gets the shininess. Default value is 0.0f;
Public property | ShininessStrength | Gets the shininess strength. Default vaulue is 1.0f.
Public property | TextureAmbient | Gets or sets ambient texture properties in the first texture index.
Public property | TextureDiffuse | Gets or sets diffuse texture properties in the first texture index.
Public property | TextureDisplacement | Gets or sets displacement texture properties in the first texture index.
Public property | TextureEmissive | Gets or sets emissive texture properties in the first texture index.
Public property | TextureHeight | Gets or sets height texture properties in the first texture index.
Public property | TextureLightMap | Gets or sets light map texture properties in the first texture index.
Public property | TextureNormal | Gets or sets normal texture properties in the first texture index.
Public property | TextureOpacity | Gets or sets opacity texture properties in the first texture index.
Public property | TextureReflection | Gets or sets reflection texture properties in the first texture index.
Public property | TextureSpecular | Gets or sets specular texture properties in the first texture index.
Top
See Also

Reference

Material Class


Material.BlendMode Property

MaterialBlendMode Property

Gets the blending mode. Default value is Default.

Namespace: Assimp
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public BlendMode BlendMode { get; set; }

Property Value

Type: BlendMode
See Also

Reference

Material Class


Material.BumpScaling Property

MaterialBumpScaling Property

Gets the bump scaling. Default value is 0.0f;

Namespace: Assimp
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public float BumpScaling { get; set; }

Property Value

Type: Single
See Also

Reference

Material Class


Material.ColorAmbient Property

MaterialColorAmbient Property

Gets the color ambient. Default value is (.2f, .2f, .2f, 1.0f).

Namespace: Assimp
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public Color4D ColorAmbient { get; set; }

Property Value

Type: Color4D
See Also

Reference

Material Class


Material.ColorDiffuse Property

MaterialColorDiffuse Property

Gets the color diffuse. Default value is white.

Namespace: Assimp
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public Color4D ColorDiffuse { get; set; }

Property Value

Type: Color4D
See Also

Reference

Material Class


Material.ColorEmissive Property

MaterialColorEmissive Property

Gets the color emissive. Default value is black.

Namespace: Assimp
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public Color4D ColorEmissive { get; set; }

Property Value

Type: Color4D
See Also

Reference

Material Class


Material.ColorReflective Property

MaterialColorReflective Property

Gets the color reflective. Default value is black.

Namespace: Assimp
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public Color4D ColorReflective { get; set; }

Property Value

Type: Color4D
See Also

Reference

Material Class


Material.ColorSpecular Property

MaterialColorSpecular Property

Gets the color specular. Default value is black.

Namespace: Assimp
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public Color4D ColorSpecular { get; set; }

Property Value

Type: Color4D
See Also

Reference

Material Class


Material.ColorTransparent Property

MaterialColorTransparent Property

Gets the color transparent. Default value is black.

Namespace: Assimp
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public Color4D ColorTransparent { get; set; }

Property Value

Type: Color4D
See Also

Reference

Material Class


Material.HasBlendMode Property

MaterialHasBlendMode Property

Checks if the material has a blend mode property.

Namespace: Assimp
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public bool HasBlendMode { get; }

Property Value

Type: Boolean
See Also

Reference

Material Class


Material.HasBumpScaling Property

MaterialHasBumpScaling Property

Checks if the material has a bump scaling property.

Namespace: Assimp
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public bool HasBumpScaling { get; }

Property Value

Type: Boolean
See Also

Reference

Material Class


Material.HasColorAmbient Property

MaterialHasColorAmbient Property

Checks if the material has a color ambient property.

Namespace: Assimp
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public bool HasColorAmbient { get; }

Property Value

Type: Boolean
See Also

Reference

Material Class


Material.HasColorDiffuse Property

MaterialHasColorDiffuse Property

Checks if the material has a color diffuse property.

Namespace: Assimp
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public bool HasColorDiffuse { get; }

Property Value

Type: Boolean
See Also

Reference

Material Class


Material.HasColorEmissive Property

MaterialHasColorEmissive Property

Checks if the material has a color emissive property.

Namespace: Assimp
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public bool HasColorEmissive { get; }

Property Value

Type: Boolean
See Also

Reference

Material Class


Material.HasColorReflective Property

MaterialHasColorReflective Property

Checks if the material has a color reflective property.

Namespace: Assimp
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public bool HasColorReflective { get; }

Property Value

Type: Boolean
See Also

Reference

Material Class


Material.HasColorSpecular Property

MaterialHasColorSpecular Property

Checks if the material has a color specular property.

Namespace: Assimp
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public bool HasColorSpecular { get; }

Property Value

Type: Boolean
See Also

Reference

Material Class


Material.HasColorTransparent Property

MaterialHasColorTransparent Property

Checks if the material has a color transparent property.

Namespace: Assimp
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public bool HasColorTransparent { get; }

Property Value

Type: Boolean
See Also

Reference

Material Class


Material.HasName Property

MaterialHasName Property

Checks if the material has a name property.

Namespace: Assimp
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public bool HasName { get; }

Property Value

Type: Boolean
See Also

Reference

Material Class


Material.HasOpacity Property

MaterialHasOpacity Property

Checks if the material has an opacity property.

Namespace: Assimp
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public bool HasOpacity { get; }

Property Value

Type: Boolean
See Also

Reference

Material Class


Material.HasReflectivity Property

MaterialHasReflectivity Property

Checks if the material has a reflectivty property.

Namespace: Assimp
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public bool HasReflectivity { get; }

Property Value

Type: Boolean
See Also

Reference

Material Class


Material.HasShadingMode Property

MaterialHasShadingMode Property

Checks if the material has a shading-mode property.

Namespace: Assimp
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public bool HasShadingMode { get; }

Property Value

Type: Boolean
See Also

Reference

Material Class


Material.HasShininess Property

MaterialHasShininess Property

Checks if the material has a shininess property.

Namespace: Assimp
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public bool HasShininess { get; }

Property Value

Type: Boolean
See Also

Reference

Material Class


Material.HasShininessStrength Property

MaterialHasShininessStrength Property

Checks if the material has a shininess strength property.

Namespace: Assimp
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public bool HasShininessStrength { get; }

Property Value

Type: Boolean
See Also

Reference

Material Class


Material.HasTextureAmbient Property

MaterialHasTextureAmbient Property

Gets if the material has a ambient texture in the first texture index.

Namespace: Assimp
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public bool HasTextureAmbient { get; }

Property Value

Type: Boolean
See Also

Reference

Material Class


Material.HasTextureDiffuse Property

MaterialHasTextureDiffuse Property

Gets if the material has a diffuse texture in the first texture index.

Namespace: Assimp
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public bool HasTextureDiffuse { get; }

Property Value

Type: Boolean
See Also

Reference

Material Class


Material.HasTextureDisplacement Property

MaterialHasTextureDisplacement Property

Gets if the material has a displacement texture in the first texture index.

Namespace: Assimp
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public bool HasTextureDisplacement { get; }

Property Value

Type: Boolean
See Also

Reference

Material Class


Material.HasTextureEmissive Property

MaterialHasTextureEmissive Property

Gets if the material has a emissive texture in the first texture index.

Namespace: Assimp
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public bool HasTextureEmissive { get; }

Property Value

Type: Boolean
See Also

Reference

Material Class


Material.HasTextureHeight Property

MaterialHasTextureHeight Property

Gets if the material has a height texture in the first texture index.

Namespace: Assimp
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public bool HasTextureHeight { get; }

Property Value

Type: Boolean
See Also

Reference

Material Class


Material.HasTextureLightMap Property

MaterialHasTextureLightMap Property

Gets if the material has a light map texture in the first texture index.

Namespace: Assimp
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public bool HasTextureLightMap { get; }

Property Value

Type: Boolean
See Also

Reference

Material Class


Material.HasTextureNormal Property

MaterialHasTextureNormal Property

Gets if the material has a normal texture in the first texture index.

Namespace: Assimp
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public bool HasTextureNormal { get; }

Property Value

Type: Boolean
See Also

Reference

Material Class


Material.HasTextureOpacity Property

MaterialHasTextureOpacity Property

Gets if the material has an opacity texture in the first texture index.

Namespace: Assimp
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public bool HasTextureOpacity { get; }

Property Value

Type: Boolean
See Also

Reference

Material Class


Material.HasTextureReflection Property

MaterialHasTextureReflection Property

Gets if the material has a reflection texture in the first texture index.

Namespace: Assimp
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public bool HasTextureReflection { get; }

Property Value

Type: Boolean
See Also

Reference

Material Class


Material.HasTextureSpecular Property

MaterialHasTextureSpecular Property

Gets if the material has a specular texture in the first texture index.

Namespace: Assimp
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public bool HasTextureSpecular { get; }

Property Value

Type: Boolean
See Also

Reference

Material Class


Material.HasTwoSided Property

MaterialHasTwoSided Property

Checks if the material has a two-sided property.

Namespace: Assimp
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public bool HasTwoSided { get; }

Property Value

Type: Boolean
See Also

Reference

Material Class


Material.HasWireFrame Property

MaterialHasWireFrame Property

Checks if the material has a wireframe property.

Namespace: Assimp
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public bool HasWireFrame { get; }

Property Value

Type: Boolean
See Also

Reference

Material Class


Material.IsTwoSided Property

MaterialIsTwoSided Property

Gets if the material should be rendered as two-sided. Default value is false.

Namespace: Assimp
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public bool IsTwoSided { get; set; }

Property Value

Type: Boolean
See Also

Reference

Material Class


Material.IsWireFrameEnabled Property

MaterialIsWireFrameEnabled Property

Gets if wireframe should be enabled. Default value is false.

Namespace: Assimp
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public bool IsWireFrameEnabled { get; set; }

Property Value

Type: Boolean
See Also

Reference

Material Class


Material.Name Property

MaterialName Property

Gets the material name value, if any. Default value is an empty string.

Namespace: Assimp
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public string Name { get; set; }

Property Value

Type: String
See Also

Reference

Material Class


Material.Opacity Property

MaterialOpacity Property

Gets the opacity. Default value is 1.0f.

Namespace: Assimp
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public float Opacity { get; set; }

Property Value

Type: Single
See Also

Reference

Material Class


Material.PropertyCount Property

MaterialPropertyCount Property

Gets the number of properties contained in the material.

Namespace: Assimp
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public int PropertyCount { get; }

Property Value

Type: Int32
See Also

Reference

Material Class


Material.Reflectivity Property

MaterialReflectivity Property

Gets the reflectivity. Default value is 0.0f;

Namespace: Assimp
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public float Reflectivity { get; set; }

Property Value

Type: Single
See Also

Reference

Material Class


Material.ShadingMode Property

MaterialShadingMode Property

Gets the shading mode. Default value is None, meaning it is not defined.

Namespace: Assimp
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public ShadingMode ShadingMode { get; set; }

Property Value

Type: ShadingMode
See Also

Reference

Material Class


Material.Shininess Property

MaterialShininess Property

Gets the shininess. Default value is 0.0f;

Namespace: Assimp
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public float Shininess { get; set; }

Property Value

Type: Single
See Also

Reference

Material Class


Material.ShininessStrength Property

MaterialShininessStrength Property

Gets the shininess strength. Default vaulue is 1.0f.

Namespace: Assimp
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public float ShininessStrength { get; set; }

Property Value

Type: Single
See Also

Reference

Material Class


Material.TextureAmbient Property

MaterialTextureAmbient Property

Gets or sets ambient texture properties in the first texture index.

Namespace: Assimp
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public TextureSlot TextureAmbient { get; set; }

Property Value

Type: TextureSlot
See Also

Reference

Material Class


Material.TextureDiffuse Property

MaterialTextureDiffuse Property

Gets or sets diffuse texture properties in the first texture index.

Namespace: Assimp
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public TextureSlot TextureDiffuse { get; set; }

Property Value

Type: TextureSlot
See Also

Reference

Material Class


Material.TextureDisplacement Property

MaterialTextureDisplacement Property

Gets or sets displacement texture properties in the first texture index.

Namespace: Assimp
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public TextureSlot TextureDisplacement { get; set; }

Property Value

Type: TextureSlot
See Also

Reference

Material Class


Material.TextureEmissive Property

MaterialTextureEmissive Property

Gets or sets emissive texture properties in the first texture index.

Namespace: Assimp
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public TextureSlot TextureEmissive { get; set; }

Property Value

Type: TextureSlot
See Also

Reference

Material Class


Material.TextureHeight Property

MaterialTextureHeight Property

Gets or sets height texture properties in the first texture index.

Namespace: Assimp
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public TextureSlot TextureHeight { get; set; }

Property Value

Type: TextureSlot
See Also

Reference

Material Class


Material.TextureLightMap Property

MaterialTextureLightMap Property

Gets or sets light map texture properties in the first texture index.

Namespace: Assimp
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public TextureSlot TextureLightMap { get; set; }

Property Value

Type: TextureSlot
See Also

Reference

Material Class


Material.TextureNormal Property

MaterialTextureNormal Property

Gets or sets normal texture properties in the first texture index.

Namespace: Assimp
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public TextureSlot TextureNormal { get; set; }

Property Value

Type: TextureSlot
See Also

Reference

Material Class


Material.TextureOpacity Property

MaterialTextureOpacity Property

Gets or sets opacity texture properties in the first texture index.

Namespace: Assimp
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public TextureSlot TextureOpacity { get; set; }

Property Value

Type: TextureSlot
See Also

Reference

Material Class


Material.TextureReflection Property

MaterialTextureReflection Property

Gets or sets reflection texture properties in the first texture index.

Namespace: Assimp
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public TextureSlot TextureReflection { get; set; }

Property Value

Type: TextureSlot
See Also

Reference

Material Class


Material.TextureSpecular Property

MaterialTextureSpecular Property

Gets or sets specular texture properties in the first texture index.

Namespace: Assimp
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public TextureSlot TextureSpecular { get; set; }

Property Value

Type: TextureSlot
See Also

Reference

Material Class


Material Methods

The Material type exposes the following members.

Methods
 | Name | Description
Public method | AddMaterialTexture(TextureSlot) | Adds a texture to the material - this bulk creates a property for each field. This will either create properties or overwrite existing properties. If the texture has no file path, nothing is added.
Public method | AddMaterialTexture(TextureSlot, Boolean) | Adds a texture to the material - this bulk creates a property for each field. This will either create properties or overwrite existing properties. If the texture has no file path, nothing is added.
Public method | AddProperty | Adds a property to this material.
Public method | Clear | Removes all properties from the material;
 | CreateFullyQualifiedName | Helper method to construct a fully qualified name from the input parameters. All the input parameters are combined into the fully qualified name: {baseName},{texType},{texIndex}. E.g. "$clr.diffuse,0,0" or "$tex.file,1,0". This is the name that is used as the material dictionary key.
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
 | FreeNative | Frees unmanaged memory created by ToNative(IntPtr, Native).
Public method | GetAllMaterialTextures | Gets all textures in the material.
Public method | GetAllProperties | Gets -all- properties contained in the Material.
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetMaterialTexture | Gets a texture that corresponds to the type/index.
Public method | GetMaterialTextureCount | Gets all the number of textures that are of the specified texture type.
Public method | GetMaterialTextures | Gets all textures that correspond to the type.
Public method | GetNonTextureProperty | Gets the non-texture properties contained in this Material. The name should be the "base name", as in it should not contain texture type/texture index information. E.g. "$clr.diffuse" rather than "$clr.diffuse,0,0". The extra data will be filled in automatically.
Public method | GetProperty(String) | Gets the material property by its fully qualified name. The format is: {baseName},{texType},{texIndex}. E.g. "$clr.diffuse,0,0" or "$tex.file,1,0".
Public method | GetProperty(String, TextureType, Int32) | Gets the material property. All the input parameters are combined into the fully qualified name: {baseName},{texType},{texIndex}. E.g. "$clr.diffuse,0,0" or "$tex.file,1,0".
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | HasNonTextureProperty | Checks if the material has the specified non-texture property. The name should be the "base name", as in it should not contain texture type/texture index information. E.g. "$clr.diffuse" rather than "$clr.diffuse,0,0". The extra data will be filled in automatically.
Public method | HasProperty(String) | Checks if the material has the specified property by looking up its fully qualified name. The format is: {baseName},{texType},{texIndex}. E.g. "$clr.diffuse,0,0" or "$tex.file,1,0".
Public method | HasProperty(String, TextureType, Int32) | Checks if the material has the specified property. All the input parameters are combined into the fully qualified name: {baseName},{texType},{texIndex}. E.g. "$clr.diffuse,0,0" or "$tex.file,1,0".
Public method | RemoveMaterialTexture | Removes a texture from the material - this bulk removes a property for each field. If the texture has no file path, nothing is removed
Public method | RemoveNonTextureProperty | Removes a non-texture property from the material.
Public method | RemoveProperty(String) | Removes a property from the material.
Public method | RemoveProperty(String, TextureType, Int32) | Removes a property from the material.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Material Class


Material.AddMaterialTexture Method

MaterialAddMaterialTexture Method

Overload List
 | Name | Description
Public method | AddMaterialTexture(TextureSlot) | Adds a texture to the material - this bulk creates a property for each field. This will either create properties or overwrite existing properties. If the texture has no file path, nothing is added.
Public method | AddMaterialTexture(TextureSlot, Boolean) | Adds a texture to the material - this bulk creates a property for each field. This will either create properties or overwrite existing properties. If the texture has no file path, nothing is added.
Top
See Also

Reference

Material Class


Material.AddMaterialTexture Method (TextureSlot)

MaterialAddMaterialTexture Method (TextureSlot)

Adds a texture to the material - this bulk creates a property for each field. This will either create properties or overwrite existing properties. If the texture has no file path, nothing is added.

Namespace: Assimp
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public bool AddMaterialTexture(
    ref TextureSlot texture
)

Parameters

texture
Type: AssimpTextureSlot
Texture to add

Return Value

Type: Boolean
True if the texture properties were added or modified
See Also

Reference

Material Class
AddMaterialTexture Overload


Material.AddMaterialTexture Method (TextureSlot, Boolean)

MaterialAddMaterialTexture Method (TextureSlot, Boolean)

Adds a texture to the material - this bulk creates a property for each field. This will either create properties or overwrite existing properties. If the texture has no file path, nothing is added.

Namespace: Assimp
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public bool AddMaterialTexture(
    ref TextureSlot texture,
    bool onlySetFilePath
)

Parameters

texture
Type: AssimpTextureSlot
Texture to add
onlySetFilePath
Type: SystemBoolean
True to only set the texture's file path, false otherwise

Return Value

Type: Boolean
True if the texture properties were added or modified
See Also

Reference

Material Class
AddMaterialTexture Overload


Material.AddProperty Method

MaterialAddProperty Method

Adds a property to this material.

Namespace: Assimp
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public bool AddProperty(
    MaterialProperty matProp
)

Parameters

matProp
Type: AssimpMaterialProperty
Material property

Return Value

Type: Boolean
True if the property was successfully added, false otherwise (e.g. null or key already present).
See Also

Reference

Material Class


Material.Clear Method

MaterialClear Method

Removes all properties from the material;

Namespace: Assimp
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public void Clear()
See Also

Reference

Material Class


Material.CreateFullyQualifiedName Method

MaterialCreateFullyQualifiedName Method

Helper method to construct a fully qualified name from the input parameters. All the input parameters are combined into the fully qualified name: {baseName},{texType},{texIndex}. E.g. "$clr.diffuse,0,0" or "$tex.file,1,0". This is the name that is used as the material dictionary key.

Namespace: Assimp
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public static string CreateFullyQualifiedName(
    string baseName,
    TextureType texType,
    int texIndex
)

Parameters

baseName
Type: SystemString
Key basename, this must not be null or empty
texType
Type: AssimpTextureType
Texture type; non-texture properties should leave this None
texIndex
Type: SystemInt32
Texture index; non-texture properties should leave this zero.

Return Value

Type: String
The fully qualified name
See Also

Reference

Material Class


Material.FreeNative Method

MaterialFreeNative Method

Frees unmanaged memory created by ToNative(IntPtr, Native).

Namespace: Assimp
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public static void FreeNative(
    IntPtr nativeValue,
    bool freeNative
)

Parameters

nativeValue
Type: SystemIntPtr
Native value to free
freeNative
Type: SystemBoolean
True if the unmanaged memory should be freed, false otherwise.
See Also

Reference

Material Class


Material.GetAllMaterialTextures Method

MaterialGetAllMaterialTextures Method

Gets all textures in the material.

Namespace: Assimp
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public TextureSlot[] GetAllMaterialTextures()

Return Value

Type: TextureSlot
The array of textures
See Also

Reference

Material Class


Material.GetAllProperties Method

MaterialGetAllProperties Method

Gets -all- properties contained in the Material.

Namespace: Assimp
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public MaterialProperty[] GetAllProperties()

Return Value

Type: MaterialProperty
All properties in the material property map.
See Also

Reference

Material Class


Material.GetMaterialTexture Method

MaterialGetMaterialTexture Method

Gets a texture that corresponds to the type/index.

Namespace: Assimp
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public bool GetMaterialTexture(
    TextureType texType,
    int texIndex,
    out TextureSlot texture
)

Parameters

texType
Type: AssimpTextureType
Texture type
texIndex
Type: SystemInt32
Texture index
texture
Type: AssimpTextureSlot
Texture description

Return Value

Type: Boolean
True if the texture was found in the material
See Also

Reference

Material Class


Material.GetMaterialTextureCount Method

MaterialGetMaterialTextureCount Method

Gets all the number of textures that are of the specified texture type.

Namespace: Assimp
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public int GetMaterialTextureCount(
    TextureType texType
)

Parameters

texType
Type: AssimpTextureType
Texture type

Return Value

Type: Int32
Texture count
See Also

Reference

Material Class


Material.GetMaterialTextures Method

MaterialGetMaterialTextures Method

Gets all textures that correspond to the type.

Namespace: Assimp
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public TextureSlot[] GetMaterialTextures(
    TextureType type
)

Parameters

type
Type: AssimpTextureType
Texture type

Return Value

Type: TextureSlot
The array of textures
See Also

Reference

Material Class


Material.GetNonTextureProperty Method

MaterialGetNonTextureProperty Method

Gets the non-texture properties contained in this Material. The name should be the "base name", as in it should not contain texture type/texture index information. E.g. "$clr.diffuse" rather than "$clr.diffuse,0,0". The extra data will be filled in automatically.

Namespace: Assimp
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public MaterialProperty GetNonTextureProperty(
    string baseName
)

Parameters

baseName
Type: SystemString
Key basename

Return Value

Type: MaterialProperty
The material property, if it exists
See Also

Reference

Material Class


Material.GetProperty Method

MaterialGetProperty Method

Overload List
 | Name | Description
Public method | GetProperty(String) | Gets the material property by its fully qualified name. The format is: {baseName},{texType},{texIndex}. E.g. "$clr.diffuse,0,0" or "$tex.file,1,0".
Public method | GetProperty(String, TextureType, Int32) | Gets the material property. All the input parameters are combined into the fully qualified name: {baseName},{texType},{texIndex}. E.g. "$clr.diffuse,0,0" or "$tex.file,1,0".
Top
See Also

Reference

Material Class


Material.GetProperty Method (String)

MaterialGetProperty Method (String)

Gets the material property by its fully qualified name. The format is: {baseName},{texType},{texIndex}. E.g. "$clr.diffuse,0,0" or "$tex.file,1,0".

Namespace: Assimp
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public MaterialProperty GetProperty(
    string fullyQualifiedName
)

Parameters

fullyQualifiedName
Type: SystemString
Fully qualified name of the property

Return Value

Type: MaterialProperty
The material property, if it exists
See Also

Reference

Material Class
GetProperty Overload


Material.GetProperty Method (String, TextureType, Int32)

MaterialGetProperty Method (String, TextureType, Int32)

Gets the material property. All the input parameters are combined into the fully qualified name: {baseName},{texType},{texIndex}. E.g. "$clr.diffuse,0,0" or "$tex.file,1,0".

Namespace: Assimp
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public MaterialProperty GetProperty(
    string baseName,
    TextureType texType,
    int texIndex
)

Parameters

baseName
Type: SystemString
Key basename
texType
Type: AssimpTextureType
Texture type; non-texture properties should leave this None
texIndex
Type: SystemInt32
Texture index; non-texture properties should leave this zero.

Return Value

Type: MaterialProperty
The material property, if it exists
See Also

Reference

Material Class
GetProperty Overload


Material.HasNonTextureProperty Method

MaterialHasNonTextureProperty Method

Checks if the material has the specified non-texture property. The name should be the "base name", as in it should not contain texture type/texture index information. E.g. "$clr.diffuse" rather than "$clr.diffuse,0,0". The extra data will be filled in automatically.

Namespace: Assimp
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public bool HasNonTextureProperty(
    string baseName
)

Parameters

baseName
Type: SystemString
Key basename

Return Value

Type: Boolean
True if the property exists, false otherwise.
See Also

Reference

Material Class


Material.HasProperty Method

MaterialHasProperty Method

Overload List
 | Name | Description
Public method | HasProperty(String) | Checks if the material has the specified property by looking up its fully qualified name. The format is: {baseName},{texType},{texIndex}. E.g. "$clr.diffuse,0,0" or "$tex.file,1,0".
Public method | HasProperty(String, TextureType, Int32) | Checks if the material has the specified property. All the input parameters are combined into the fully qualified name: {baseName},{texType},{texIndex}. E.g. "$clr.diffuse,0,0" or "$tex.file,1,0".
Top
See Also

Reference

Material Class


Material.HasProperty Method (String)

MaterialHasProperty Method (String)

Checks if the material has the specified property by looking up its fully qualified name. The format is: {baseName},{texType},{texIndex}. E.g. "$clr.diffuse,0,0" or "$tex.file,1,0".

Namespace: Assimp
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public bool HasProperty(
    string fullyQualifiedName
)

Parameters

fullyQualifiedName
Type: SystemString
Fully qualified name of the property

Return Value

Type: Boolean
True if the property exists, false otherwise.
See Also

Reference

Material Class
HasProperty Overload


Material.HasProperty Method (String, TextureType, Int32)

MaterialHasProperty Method (String, TextureType, Int32)

Checks if the material has the specified property. All the input parameters are combined into the fully qualified name: {baseName},{texType},{texIndex}. E.g. "$clr.diffuse,0,0" or "$tex.file,1,0".

Namespace: Assimp
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public bool HasProperty(
    string baseName,
    TextureType texType,
    int texIndex
)

Parameters

baseName
Type: SystemString
Key basename
texType
Type: AssimpTextureType
Texture type; non-texture properties should leave this None
texIndex
Type: SystemInt32
Texture index; non-texture properties should leave this zero.

Return Value

Type: Boolean
True if the property exists, false otherwise.
See Also

Reference

Material Class
HasProperty Overload


Material.RemoveMaterialTexture Method

MaterialRemoveMaterialTexture Method

Removes a texture from the material - this bulk removes a property for each field. If the texture has no file path, nothing is removed

Namespace: Assimp
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public bool RemoveMaterialTexture(
    ref TextureSlot texture
)

Parameters

texture
Type: AssimpTextureSlot
Texture to remove

Return Value

Type: Boolean
True if the texture was removed, false otherwise.
See Also

Reference

Material Class


Material.RemoveNonTextureProperty Method

MaterialRemoveNonTextureProperty Method

Removes a non-texture property from the material.

Namespace: Assimp
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public bool RemoveNonTextureProperty(
    string baseName
)

Parameters

baseName
Type: SystemString
Property name

Return Value

Type: Boolean
True if the property was removed, false otherwise
See Also

Reference

Material Class


Material.RemoveProperty Method

MaterialRemoveProperty Method

Overload List
 | Name | Description
Public method | RemoveProperty(String) | Removes a property from the material.
Public method | RemoveProperty(String, TextureType, Int32) | Removes a property from the material.
Top
See Also

Reference

Material Class


Material.RemoveProperty Method (String)

MaterialRemoveProperty Method (String)

Removes a property from the material.

Namespace: Assimp
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public bool RemoveProperty(
    string fullyQualifiedName
)

Parameters

fullyQualifiedName
Type: SystemString
Fully qualified name of the property ({basename},{texType},{texIndex})

Return Value

Type: Boolean
True if the property was removed, false otherwise
See Also

Reference

Material Class
RemoveProperty Overload


Material.RemoveProperty Method (String, TextureType, Int32)

MaterialRemoveProperty Method (String, TextureType, Int32)

Removes a property from the material.

Namespace: Assimp
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public bool RemoveProperty(
    string baseName,
    TextureType texType,
    int texIndex
)

Parameters

baseName
Type: SystemString
Name of the property
texType
Type: AssimpTextureType
Property texture type
texIndex
Type: SystemInt32
Property texture index

Return Value

Type: Boolean
True if the property was removed, false otherwise
See Also

Reference

Material Class
RemoveProperty Overload


MaterialProperty Class

A key-value pairing that represents some material property.
Inheritance Hierarchy
SystemObject
AssimpMaterialProperty

Namespace: Assimp
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public sealed class MaterialProperty : IMarshalable<MaterialProperty, AiMaterialProperty>

The MaterialProperty type exposes the following members.

Constructors
 | Name | Description
Public method | MaterialProperty | Constructs a new instance of the MaterialProperty class.
Public method | MaterialProperty(String, Color3D) | Constructs a new instance of the MaterialProperty class. Creates a Color3D property.
Public method | MaterialProperty(String, Color4D) | Constructs a new instance of the MaterialProperty class. Creates a Color4D property.
Public method | MaterialProperty(String, Boolean) | Constructs a new instance of the MaterialProperty class. Constructs a boolean property.
Public method | MaterialProperty(String, Byte) | Constructs a new instance of the MaterialProperty class. Constructs a buffer property.
Public method | MaterialProperty(String, Int32) | Constructs a new instance of the MaterialProperty class. Constructs an integer property.
Public method | MaterialProperty(String, Int32) | Constructs a new instance of the MaterialProperty class. Creates a int array property.
Public method | MaterialProperty(String, Single) | Constructs a new instance of the MaterialProperty class. Constructs a float property.
Public method | MaterialProperty(String, Single) | Constructs a new instance of the MaterialProperty class. Creates a float array property.
Public method | MaterialProperty(String, String) | Constructs a new instance of the MaterialProperty class. Creates a string property.
Public method | MaterialProperty(String, String, TextureType, Int32) | Constructs a new instance of the MaterialProperty class. Creates a texture property.
Top
Properties
 | Name | Description
Public property | ByteCount | Gets the raw byte data count.
Public property | FullyQualifiedName | Gets the property's fully qualified name. Format: "{base name},{texture type semantic},{texture index}". E.g. "$clr.diffuse,0,0". This is the key that is used to index the property in the material property map.
Public property | HasRawData | Checks if the property has data.
Public property | Name | Gets or sets the property key name. E.g. $tex.file. This corresponds to the "AiMatKeys" base name constants.
Public property | PropertyType | Gets or sets the type of property.
Public property | RawData | Gets the raw byte data. To modify/read this data, see the Get/SetXXXValue methods.
Public property | TextureIndex | Gets or sets the texture index, for non-texture properties this is always zero.
Public property | TextureType | Gets or sets the texture type semantic, for non-texture properties this is always None.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
 | FreeNative | Frees unmanaged memory created by ToNative(IntPtr, Native).
Public method | GetBooleanValue | Gets the property raw data as a boolean.
Public method | GetColor3DValue | Gets the property raw data as a Color3D.
Public method | GetColor4DValue | Gets the property raw data as a Color4D.
Public method | GetDoubleArrayValue | Gets the property raw data as a double array.
Public method | GetDoubleValue | Gets the property raw data as a double.
Public method | GetFloatArrayValue | Gets the property raw data as a float array.
Public method | GetFloatArrayValue(Int32) | Gets the property raw data as a float array.
Public method | GetFloatValue | Gets the property raw data as a float.
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetIntegerArrayValue | Gets the property raw data as an integer array.
Public method | GetIntegerArrayValue(Int32) | Gets the property raw data as an integer array.
Public method | GetIntegerValue | Gets the property raw data as an integer.
Public method | GetStringValue | Gets the property raw data as a string.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | SetBooleanValue | Sets the property raw data as a boolean.
Public method | SetColor3DValue | Sets the property raw data as a Color3D.
Public method | SetColor4DValue | Sets the property raw data as a Color4D.
Public method | SetDoubleArrayValue | Sets the property raw data as a double array.
Public method | SetDoubleValue | Sets the property raw data with a double.
Public method | SetFloatArrayValue | Sets the property raw data as a float array.
Public method | SetFloatValue | Sets the property raw data with a float.
Public method | SetIntegerArrayValue | Sets the property raw data as an integer array.
Public method | SetIntegerValue | Sets the property raw data as an integer.
Public method | SetStringValue | Sets the property raw data as string.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference


MaterialProperty Constructor

Overload List
 | Name | Description
Public method | MaterialProperty | Constructs a new instance of the MaterialProperty class.
Public method | MaterialProperty(String, Color3D) | Constructs a new instance of the MaterialProperty class. Creates a Color3D property.
Public method | MaterialProperty(String, Color4D) | Constructs a new instance of the MaterialProperty class. Creates a Color4D property.
Public method | MaterialProperty(String, Boolean) | Constructs a new instance of the MaterialProperty class. Constructs a boolean property.
Public method | MaterialProperty(String, Byte) | Constructs a new instance of the MaterialProperty class. Constructs a buffer property.
Public method | MaterialProperty(String, Int32) | Constructs a new instance of the MaterialProperty class. Constructs an integer property.
Public method | MaterialProperty(String, Int32) | Constructs a new instance of the MaterialProperty class. Creates a int array property.
Public method | MaterialProperty(String, Single) | Constructs a new instance of the MaterialProperty class. Constructs a float property.
Public method | MaterialProperty(String, Single) | Constructs a new instance of the MaterialProperty class. Creates a float array property.
Public method | MaterialProperty(String, String) | Constructs a new instance of the MaterialProperty class. Creates a string property.
Public method | MaterialProperty(String, String, TextureType, Int32) | Constructs a new instance of the MaterialProperty class. Creates a texture property.
Top
See Also

Reference

MaterialProperty Class


MaterialProperty Constructor

Constructs a new instance of the MaterialProperty class.

Namespace: Assimp
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public MaterialProperty()
See Also

Reference

MaterialProperty Class
MaterialProperty Overload


MaterialProperty Constructor (String, Color3D)

Constructs a new instance of the MaterialProperty class. Creates a Color3D property.

Namespace: Assimp
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public MaterialProperty(
    string baseName,
    Color3D value
)

Parameters

baseName
Type: SystemString
Base name of the property
value
Type: AssimpColor3D
Property value
See Also

Reference

MaterialProperty Class
MaterialProperty Overload


MaterialProperty Constructor (String, Color4D)

Constructs a new instance of the MaterialProperty class. Creates a Color4D property.

Namespace: Assimp
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public MaterialProperty(
    string baseName,
    Color4D value
)

Parameters

baseName
Type: SystemString
Base name of the property
value
Type: AssimpColor4D
Property value
See Also

Reference

MaterialProperty Class
MaterialProperty Overload


MaterialProperty Constructor (String, Boolean)

Constructs a new instance of the MaterialProperty class. Constructs a boolean property.

Namespace: Assimp
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public MaterialProperty(
    string baseName,
    bool value
)

Parameters

baseName
Type: SystemString
Name of the property
value
Type: SystemBoolean
Property value
See Also

Reference

MaterialProperty Class
MaterialProperty Overload


MaterialProperty Constructor (String, Byte[])

MaterialProperty Constructor (String, Byte)

Constructs a new instance of the MaterialProperty class. Constructs a buffer property.

Namespace: Assimp
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public MaterialProperty(
    string baseName,
    byte[] buffer
)

Parameters

baseName
Type: SystemString
Base name of the property
buffer
Type: SystemByte
Property value
See Also

Reference

MaterialProperty Class
MaterialProperty Overload


MaterialProperty Constructor (String, Int32)

Constructs a new instance of the MaterialProperty class. Constructs an integer property.

Namespace: Assimp
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public MaterialProperty(
    string baseName,
    int value
)

Parameters

baseName
Type: SystemString
Base name of the property
value
Type: SystemInt32
Property value
See Also

Reference

MaterialProperty Class
MaterialProperty Overload


MaterialProperty Constructor (String, Int32[])

MaterialProperty Constructor (String, Int32)

Constructs a new instance of the MaterialProperty class. Creates a int array property.

Namespace: Assimp
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public MaterialProperty(
    string baseName,
    int[] values
)

Parameters

baseName
Type: SystemString
Base name of the property
values
Type: SystemInt32
Property values
See Also

Reference

MaterialProperty Class
MaterialProperty Overload


MaterialProperty Constructor (String, Single)

Constructs a new instance of the MaterialProperty class. Constructs a float property.

Namespace: Assimp
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public MaterialProperty(
    string baseName,
    float value
)

Parameters

baseName
Type: SystemString
Base name of the property
value
Type: SystemSingle
Property value
See Also

Reference

MaterialProperty Class
MaterialProperty Overload


MaterialProperty Constructor (String, Single[])

MaterialProperty Constructor (String, Single)

Constructs a new instance of the MaterialProperty class. Creates a float array property.

Namespace: Assimp
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public MaterialProperty(
    string baseName,
    float[] values
)

Parameters

baseName
Type: SystemString
Base name of the property
values
Type: SystemSingle
Property values
See Also

Reference

MaterialProperty Class
MaterialProperty Overload


MaterialProperty Constructor (String, String)

Constructs a new instance of the MaterialProperty class. Creates a string property.

Namespace: Assimp
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public MaterialProperty(
    string baseName,
    string value
)

Parameters

baseName
Type: SystemString
Base name of the property
value
Type: SystemString
Property value
See Also

Reference

MaterialProperty Class
MaterialProperty Overload


MaterialProperty Constructor (String, String, TextureType, Int32)

Constructs a new instance of the MaterialProperty class. Creates a texture property.

Namespace: Assimp
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public MaterialProperty(
    string baseName,
    string value,
    TextureType texType,
    int textureIndex
)

Parameters

baseName
Type: SystemString
Base name of the property
value
Type: SystemString
Property value
texType
Type: AssimpTextureType
Texture type
textureIndex
Type: SystemInt32
Texture index
See Also

Reference

MaterialProperty Class
MaterialProperty Overload


MaterialProperty Properties

The MaterialProperty type exposes the following members.

Properties
 | Name | Description
Public property | ByteCount | Gets the raw byte data count.
Public property | FullyQualifiedName | Gets the property's fully qualified name. Format: "{base name},{texture type semantic},{texture index}". E.g. "$clr.diffuse,0,0". This is the key that is used to index the property in the material property map.
Public property | HasRawData | Checks if the property has data.
Public property | Name | Gets or sets the property key name. E.g. $tex.file. This corresponds to the "AiMatKeys" base name constants.
Public property | PropertyType | Gets or sets the type of property.
Public property | RawData | Gets the raw byte data. To modify/read this data, see the Get/SetXXXValue methods.
Public property | TextureIndex | Gets or sets the texture index, for non-texture properties this is always zero.
Public property | TextureType | Gets or sets the texture type semantic, for non-texture properties this is always None.
Top
See Also

Reference

MaterialProperty Class


MaterialProperty.ByteCount Property

MaterialPropertyByteCount Property

Gets the raw byte data count.

Namespace: Assimp
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public int ByteCount { get; }

Property Value

Type: Int32
See Also

Reference

MaterialProperty Class


MaterialProperty.FullyQualifiedName Property

MaterialPropertyFullyQualifiedName Property

Gets the property's fully qualified name. Format: "{base name},{texture type semantic},{texture index}". E.g. "$clr.diffuse,0,0". This is the key that is used to index the property in the material property map.

Namespace: Assimp
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public string FullyQualifiedName { get; }

Property Value

Type: String
See Also

Reference

MaterialProperty Class


MaterialProperty.HasRawData Property

MaterialPropertyHasRawData Property

Checks if the property has data.

Namespace: Assimp
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public bool HasRawData { get; }

Property Value

Type: Boolean
See Also

Reference

MaterialProperty Class


MaterialProperty.Name Property

MaterialPropertyName Property

Gets or sets the property key name. E.g. $tex.file. This corresponds to the "AiMatKeys" base name constants.

Namespace: Assimp
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public string Name { get; set; }

Property Value

Type: String
See Also

Reference

MaterialProperty Class


MaterialProperty.PropertyType Property

MaterialPropertyPropertyType Property

Gets or sets the type of property.

Namespace: Assimp
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public PropertyType PropertyType { get; set; }

Property Value

Type: PropertyType
See Also

Reference

MaterialProperty Class


MaterialProperty.RawData Property

MaterialPropertyRawData Property

Gets the raw byte data. To modify/read this data, see the Get/SetXXXValue methods.

Namespace: Assimp
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public byte[] RawData { get; }

Property Value

Type: Byte
See Also

Reference

MaterialProperty Class


MaterialProperty.TextureIndex Property

MaterialPropertyTextureIndex Property

Gets or sets the texture index, for non-texture properties this is always zero.

Namespace: Assimp
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public int TextureIndex { get; set; }

Property Value

Type: Int32
See Also

Reference

MaterialProperty Class


MaterialProperty.TextureType Property

MaterialPropertyTextureType Property

Gets or sets the texture type semantic, for non-texture properties this is always None.

Namespace: Assimp
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public TextureType TextureType { get; set; }

Property Value

Type: TextureType
See Also

Reference

MaterialProperty Class


MaterialProperty Methods

The MaterialProperty type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
 | FreeNative | Frees unmanaged memory created by ToNative(IntPtr, Native).
Public method | GetBooleanValue | Gets the property raw data as a boolean.
Public method | GetColor3DValue | Gets the property raw data as a Color3D.
Public method | GetColor4DValue | Gets the property raw data as a Color4D.
Public method | GetDoubleArrayValue | Gets the property raw data as a double array.
Public method | GetDoubleValue | Gets the property raw data as a double.
Public method | GetFloatArrayValue | Gets the property raw data as a float array.
Public method | GetFloatArrayValue(Int32) | Gets the property raw data as a float array.
Public method | GetFloatValue | Gets the property raw data as a float.
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetIntegerArrayValue | Gets the property raw data as an integer array.
Public method | GetIntegerArrayValue(Int32) | Gets the property raw data as an integer array.
Public method | GetIntegerValue | Gets the property raw data as an integer.
Public method | GetStringValue | Gets the property raw data as a string.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | SetBooleanValue | Sets the property raw data as a boolean.
Public method | SetColor3DValue | Sets the property raw data as a Color3D.
Public method | SetColor4DValue | Sets the property raw data as a Color4D.
Public method | SetDoubleArrayValue | Sets the property raw data as a double array.
Public method | SetDoubleValue | Sets the property raw data with a double.
Public method | SetFloatArrayValue | Sets the property raw data as a float array.
Public method | SetFloatValue | Sets the property raw data with a float.
Public method | SetIntegerArrayValue | Sets the property raw data as an integer array.
Public method | SetIntegerValue | Sets the property raw data as an integer.
Public method | SetStringValue | Sets the property raw data as string.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

MaterialProperty Class


MaterialProperty.FreeNative Method

MaterialPropertyFreeNative Method

Frees unmanaged memory created by ToNative(IntPtr, Native).

Namespace: Assimp
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public static void FreeNative(
    IntPtr nativeValue,
    bool freeNative
)

Parameters

nativeValue
Type: SystemIntPtr
Native value to free
freeNative
Type: SystemBoolean
True if the unmanaged memory should be freed, false otherwise.
See Also

Reference

MaterialProperty Class


MaterialProperty.GetBooleanValue Method

MaterialPropertyGetBooleanValue Method

Gets the property raw data as a boolean.

Namespace: Assimp
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public bool GetBooleanValue()

Return Value

Type: Boolean
Boolean
See Also

Reference

MaterialProperty Class


MaterialProperty.GetColor3DValue Method

MaterialPropertyGetColor3DValue Method

Gets the property raw data as a Color3D.

Namespace: Assimp
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public Color3D GetColor3DValue()

Return Value

Type: Color3D
Color3D
See Also

Reference

MaterialProperty Class


MaterialProperty.GetColor4DValue Method

MaterialPropertyGetColor4DValue Method

Gets the property raw data as a Color4D.

Namespace: Assimp
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public Color4D GetColor4DValue()

Return Value

Type: Color4D
Color4D
See Also

Reference

MaterialProperty Class


MaterialProperty.GetDoubleArrayValue Method

MaterialPropertyGetDoubleArrayValue Method

Gets the property raw data as a double array.

Namespace: Assimp
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public double[] GetDoubleArrayValue()

Return Value

Type: Double
Double array
See Also

Reference

MaterialProperty Class


MaterialProperty.GetDoubleValue Method

MaterialPropertyGetDoubleValue Method

Gets the property raw data as a double.

Namespace: Assimp
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public double GetDoubleValue()

Return Value

Type: Double
Double
See Also

Reference

MaterialProperty Class


MaterialProperty.GetFloatArrayValue Method

MaterialPropertyGetFloatArrayValue Method

Overload List
 | Name | Description
Public method | GetFloatArrayValue | Gets the property raw data as a float array.
Public method | GetFloatArrayValue(Int32) | Gets the property raw data as a float array.
Top
See Also

Reference

MaterialProperty Class


MaterialProperty.GetFloatArrayValue Method

MaterialPropertyGetFloatArrayValue Method

Gets the property raw data as a float array.

Namespace: Assimp
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public float[] GetFloatArrayValue()

Return Value

Type: Single
Float array
See Also

Reference

MaterialProperty Class
GetFloatArrayValue Overload


MaterialProperty.GetFloatArrayValue Method (Int32)

MaterialPropertyGetFloatArrayValue Method (Int32)

Gets the property raw data as a float array.

Namespace: Assimp
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public float[] GetFloatArrayValue(
    int count
)

Parameters

count
Type: SystemInt32
Number of elements to get

Return Value

Type: Single
Float array
See Also

Reference

MaterialProperty Class
GetFloatArrayValue Overload


MaterialProperty.GetFloatValue Method

MaterialPropertyGetFloatValue Method

Gets the property raw data as a float.

Namespace: Assimp
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public float GetFloatValue()

Return Value

Type: Single
Float
See Also

Reference

MaterialProperty Class


MaterialProperty.GetIntegerArrayValue Method

MaterialPropertyGetIntegerArrayValue Method

Overload List
 | Name | Description
Public method | GetIntegerArrayValue | Gets the property raw data as an integer array.
Public method | GetIntegerArrayValue(Int32) | Gets the property raw data as an integer array.
Top
See Also

Reference

MaterialProperty Class


MaterialProperty.GetIntegerArrayValue Method

MaterialPropertyGetIntegerArrayValue Method

Gets the property raw data as an integer array.

Namespace: Assimp
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public int[] GetIntegerArrayValue()

Return Value

Type: Int32
Integer array
See Also

Reference

MaterialProperty Class
GetIntegerArrayValue Overload


MaterialProperty.GetIntegerArrayValue Method (Int32)

MaterialPropertyGetIntegerArrayValue Method (Int32)

Gets the property raw data as an integer array.

Namespace: Assimp
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public int[] GetIntegerArrayValue(
    int count
)

Parameters

count
Type: SystemInt32
Number of elements to get

Return Value

Type: Int32
Integer array
See Also

Reference

MaterialProperty Class
GetIntegerArrayValue Overload


MaterialProperty.GetIntegerValue Method

MaterialPropertyGetIntegerValue Method

Gets the property raw data as an integer.

Namespace: Assimp
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public int GetIntegerValue()

Return Value

Type: Int32
Integer
See Also

Reference

MaterialProperty Class


MaterialProperty.GetStringValue Method

MaterialPropertyGetStringValue Method

Gets the property raw data as a string.

Namespace: Assimp
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public string GetStringValue()

Return Value

Type: String
String
See Also

Reference

MaterialProperty Class


MaterialProperty.SetBooleanValue Method

MaterialPropertySetBooleanValue Method

Sets the property raw data as a boolean.

Namespace: Assimp
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public bool SetBooleanValue(
    bool value
)

Parameters

value
Type: SystemBoolean
Boolean value

Return Value

Type: Boolean
True if successful, false otherwise
See Also

Reference

MaterialProperty Class


MaterialProperty.SetColor3DValue Method

MaterialPropertySetColor3DValue Method

Sets the property raw data as a Color3D.

Namespace: Assimp
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public bool SetColor3DValue(
    Color3D value
)

Parameters

value
Type: AssimpColor3D
Color3D

Return Value

Type: Boolean
True if successful, false otherwise
See Also

Reference

MaterialProperty Class


MaterialProperty.SetColor4DValue Method

MaterialPropertySetColor4DValue Method

Sets the property raw data as a Color4D.

Namespace: Assimp
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public bool SetColor4DValue(
    Color4D value
)

Parameters

value
Type: AssimpColor4D
Color4D

Return Value

Type: Boolean
True if successful, false otherwise
See Also

Reference

MaterialProperty Class


MaterialProperty.SetDoubleArrayValue Method

MaterialPropertySetDoubleArrayValue Method

Sets the property raw data as a double array.

Namespace: Assimp
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public bool SetDoubleArrayValue(
    double[] values
)

Parameters

values
Type: SystemDouble
Values to set

Return Value

Type: Boolean
True if successful, otherwise false
See Also

Reference

MaterialProperty Class


MaterialProperty.SetDoubleValue Method

MaterialPropertySetDoubleValue Method

Sets the property raw data with a double.

Namespace: Assimp
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public bool SetDoubleValue(
    double value
)

Parameters

value
Type: SystemDouble
Double.

Return Value

Type: Boolean
True if successful, false otherwise.
See Also

Reference

MaterialProperty Class


MaterialProperty.SetFloatArrayValue Method

MaterialPropertySetFloatArrayValue Method

Sets the property raw data as a float array.

Namespace: Assimp
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public bool SetFloatArrayValue(
    float[] values
)

Parameters

values
Type: SystemSingle
Values to set

Return Value

Type: Boolean
True if successful, otherwise false
See Also

Reference

MaterialProperty Class


MaterialProperty.SetFloatValue Method

MaterialPropertySetFloatValue Method

Sets the property raw data with a float.

Namespace: Assimp
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public bool SetFloatValue(
    float value
)

Parameters

value
Type: SystemSingle
Float.

Return Value

Type: Boolean
True if successful, false otherwise
See Also

Reference

MaterialProperty Class


MaterialProperty.SetIntegerArrayValue Method

MaterialPropertySetIntegerArrayValue Method

Sets the property raw data as an integer array.

Namespace: Assimp
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public bool SetIntegerArrayValue(
    int[] values
)

Parameters

values
Type: SystemInt32
Values to set

Return Value

Type: Boolean
True if successful, otherwise false
See Also

Reference

MaterialProperty Class


MaterialProperty.SetIntegerValue Method

MaterialPropertySetIntegerValue Method

Sets the property raw data as an integer.

Namespace: Assimp
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public bool SetIntegerValue(
    int value
)

Parameters

value
Type: SystemInt32
Integer

Return Value

Type: Boolean
True if successful, false otherwise
See Also

Reference

MaterialProperty Class


MaterialProperty.SetStringValue Method

MaterialPropertySetStringValue Method

Sets the property raw data as string.

Namespace: Assimp
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public bool SetStringValue(
    string value
)

Parameters

value
Type: SystemString
String

Return Value

Type: Boolean
True if successful, false otherwise
See Also

Reference

MaterialProperty Class


Matrix3x3 Structure

Represents a 3x3 matrix. Assimp docs say their matrices are always row-major, and it looks like they're only describing the memory layout. Matrices are treated as column vectors however (X base in the first column, Y base the second, and Z base the third)

Namespace: Assimp
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public struct Matrix3x3 : IEquatable<Matrix3x3>

The Matrix3x3 type exposes the following members.

Constructors
 | Name | Description
Public method | Matrix3x3(Matrix4x4) | Constructs a new Matrix3x3.
Public method | Matrix3x3(Single, Single, Single, Single, Single, Single, Single, Single, Single) | Constructs a new Matrix3x3.
Top
Properties
 | Name | Description
 | Identity | Gets the identity matrix.
Public property | IsIdentity | Gets if this matrix is an identity matrix.
Public property | Item | Gets or sets the value at the specific one-based row, column index. E.g. i = 1, j = 2 gets the value in row 1, column 2 (MA2). Indices out of range return a value of zero.
Top
Methods
 | Name | Description
Public method | Determinant | Compute the determinant of this matrix.
Public method | Equals(Object) | Determines whether the specified Object is equal to this instance. (Overrides ValueTypeEquals(Object).)
Public method | Equals(Matrix3x3) | Tests equality between this matrix and another.
 | FromAngleAxis | Creates a rotation matrix for a rotation about an arbitrary axis.
 | FromEulerAnglesXYZ(Vector3D) | Creates a rotation matrix from a set of euler angles.
 | FromEulerAnglesXYZ(Single, Single, Single) | Creates a rotation matrix from a set of euler angles.
 | FromRotationX | Creates a rotation matrix for a rotation about the x-axis.
 | FromRotationY | Creates a rotation matrix for a rotation about the y-axis.
 | FromRotationZ | Creates a rotation matrix for a rotation about the z-axis.
 | FromScaling | Creates a scaling matrix.
 | FromToMatrix | Creates a rotation matrix that rotates a vector called "from" into another vector called "to". Based on an algorithm by Tomas Moller and John Hudges: "Efficiently Building a Matrix to Rotate One Vector to Another" Journal of Graphics Tools, 4(4):1-4, 1999
Public method | GetHashCode | Returns a hash code for this instance. (Overrides ValueTypeGetHashCode.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Inverse | Inverts the matrix. If the matrix is *not* invertible all elements are set to NaN.
Public method | ToString | Returns a String that represents this instance. (Overrides ValueTypeToString.)
Public method | Transpose | Transposes this matrix (rows become columns, vice versa).
Top
Operators
Name | Description
Equality | Tests equality between two matrices.
(Matrix4x4 to Matrix3x3) | Implicit conversion from a 4x4 matrix to a 3x3 matrix.
Inequality | Tests inequality between two matrices.
Multiply | Performs matrix multiplication.Multiplication order is B x A. That way, SRT concatenations are left to right.
Top
Fields
 | Name | Description
Public field | A1 | Value at row 1, column 1 of the matrix
Public field | A2 | Value at row 1, column 2 of the matrix
Public field | A3 | Value at row 1, column 3 of the matrix
Public field | B1 | Value at row 2, column 1 of the matrix
Public field | B2 | Value at row 2, column 2 of the matrix
Public field | B3 | Value at row 2, column 3 of the matrix
Public field | C1 | Value at row 3, column 1 of the matrix
Public field | C2 | Value at row 3, column 2 of the matrix
Public field | C3 | Value at row 3, column 3 of the matrix
Top
See Also

Reference


Matrix3x3 Constructor

Overload List
 | Name | Description
Public method | Matrix3x3(Matrix4x4) | Constructs a new Matrix3x3.
Public method | Matrix3x3(Single, Single, Single, Single, Single, Single, Single, Single, Single) | Constructs a new Matrix3x3.
Top
See Also

Reference

Matrix3x3 Structure


Matrix3x3 Constructor (Matrix4x4)

Constructs a new Matrix3x3.

Namespace: Assimp
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public Matrix3x3(
    Matrix4x4 rotMatrix
)

Parameters

rotMatrix
Type: AssimpMatrix4x4
A 4x4 matrix to construct from, only taking the rotation/scaling part.
See Also

Reference

Matrix3x3 Structure
Matrix3x3 Overload


Matrix3x3 Constructor (Single, Single, Single, Single, Single, Single, Single, Single, Single)

Constructs a new Matrix3x3.

Namespace: Assimp
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public Matrix3x3(
    float a1,
    float a2,
    float a3,
    float b1,
    float b2,
    float b3,
    float c1,
    float c2,
    float c3
)

Parameters

a1
Type: SystemSingle
Element at row 1, column 1
a2
Type: SystemSingle
Element at row 1, column 2
a3
Type: SystemSingle
Element at row 1, column 3
b1
Type: SystemSingle
Element at row 2, column 1
b2
Type: SystemSingle
Element at row 2, column 2
b3
Type: SystemSingle
Element at row 2, column 3
c1
Type: SystemSingle
Element at row 3, column 1
c2
Type: SystemSingle
Element at row 3, column 2
c3
Type: SystemSingle
Element at row 3, column 3
See Also

Reference

Matrix3x3 Structure
Matrix3x3 Overload


Matrix3x3 Properties

The Matrix3x3 type exposes the following members.

Properties
 | Name | Description
 | Identity | Gets the identity matrix.
Public property | IsIdentity | Gets if this matrix is an identity matrix.
Public property | Item | Gets or sets the value at the specific one-based row, column index. E.g. i = 1, j = 2 gets the value in row 1, column 2 (MA2). Indices out of range return a value of zero.
Top
See Also

Reference

Matrix3x3 Structure


Matrix3x3.Identity Property

Matrix3x3Identity Property

Gets the identity matrix.

Namespace: Assimp
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public static Matrix3x3 Identity { get; }

Property Value

Type: Matrix3x3
See Also

Reference

Matrix3x3 Structure


Matrix3x3.IsIdentity Property

Matrix3x3IsIdentity Property

Gets if this matrix is an identity matrix.

Namespace: Assimp
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public bool IsIdentity { get; }

Property Value

Type: Boolean
See Also

Reference

Matrix3x3 Structure


Matrix3x3.Item Property

Matrix3x3Item Property

Gets or sets the value at the specific one-based row, column index. E.g. i = 1, j = 2 gets the value in row 1, column 2 (MA2). Indices out of range return a value of zero.

Namespace: Assimp
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public float this[
    int i,
    int j
] { get; set; }

Parameters

i
Type: SystemInt32
One-based Row index
j
Type: SystemInt32
One-based Column index

Return Value

Type: Single
Matrix value
See Also

Reference

Matrix3x3 Structure


Matrix3x3 Methods

The Matrix3x3 type exposes the following members.

Methods
 | Name | Description
Public method | Determinant | Compute the determinant of this matrix.
Public method | Equals(Object) | Determines whether the specified Object is equal to this instance. (Overrides ValueTypeEquals(Object).)
Public method | Equals(Matrix3x3) | Tests equality between this matrix and another.
 | FromAngleAxis | Creates a rotation matrix for a rotation about an arbitrary axis.
 | FromEulerAnglesXYZ(Vector3D) | Creates a rotation matrix from a set of euler angles.
 | FromEulerAnglesXYZ(Single, Single, Single) | Creates a rotation matrix from a set of euler angles.
 | FromRotationX | Creates a rotation matrix for a rotation about the x-axis.
 | FromRotationY | Creates a rotation matrix for a rotation about the y-axis.
 | FromRotationZ | Creates a rotation matrix for a rotation about the z-axis.
 | FromScaling | Creates a scaling matrix.
 | FromToMatrix | Creates a rotation matrix that rotates a vector called "from" into another vector called "to". Based on an algorithm by Tomas Moller and John Hudges: "Efficiently Building a Matrix to Rotate One Vector to Another" Journal of Graphics Tools, 4(4):1-4, 1999
Public method | GetHashCode | Returns a hash code for this instance. (Overrides ValueTypeGetHashCode.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Inverse | Inverts the matrix. If the matrix is *not* invertible all elements are set to NaN.
Public method | ToString | Returns a String that represents this instance. (Overrides ValueTypeToString.)
Public method | Transpose | Transposes this matrix (rows become columns, vice versa).
Top
See Also

Reference

Matrix3x3 Structure


Matrix3x3.Determinant Method

Matrix3x3Determinant Method

Compute the determinant of this matrix.

Namespace: Assimp
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public float Determinant()

Return Value

Type: Single
The determinant
See Also

Reference

Matrix3x3 Structure


Matrix3x3.Equals Method

Matrix3x3Equals Method

Overload List
 | Name | Description
Public method | Equals(Object) | Determines whether the specified Object is equal to this instance. (Overrides ValueTypeEquals(Object).)
Public method | Equals(Matrix3x3) | Tests equality between this matrix and another.
Top
See Also

Reference

Matrix3x3 Structure


Matrix3x3.Equals Method (Object)

Matrix3x3Equals Method (Object)

Determines whether the specified Object is equal to this instance.

Namespace: Assimp
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public override bool Equals(
    Object obj
)

Parameters

obj
Type: SystemObject
The Object to compare with this instance.

Return Value

Type: Boolean
true if the specified Object is equal to this instance; otherwise, false.
See Also

Reference

Matrix3x3 Structure
Equals Overload


Matrix3x3.Equals Method (Matrix3x3)

Matrix3x3Equals Method (Matrix3x3)

Tests equality between this matrix and another.

Namespace: Assimp
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public bool Equals(
    Matrix3x3 other
)

Parameters

other
Type: AssimpMatrix3x3
Other matrix to test

Return Value

Type: Boolean
True if the matrices are equal, false otherwise

Implements

IEquatableTEquals(T)
See Also

Reference

Matrix3x3 Structure
Equals Overload


Matrix3x3.FromAngleAxis Method

Matrix3x3FromAngleAxis Method

Creates a rotation matrix for a rotation about an arbitrary axis.

Namespace: Assimp
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public static Matrix3x3 FromAngleAxis(
    float radians,
    Vector3D axis
)

Parameters

radians
Type: SystemSingle
Rotation angle, in radians
axis
Type: AssimpVector3D
Rotation axis, which should be a normalized vector.

Return Value

Type: Matrix3x3
The rotation matrix
See Also

Reference

Matrix3x3 Structure


Matrix3x3.FromEulerAnglesXYZ Method

Matrix3x3FromEulerAnglesXYZ Method

Overload List
Name | Description
FromEulerAnglesXYZ(Vector3D) | Creates a rotation matrix from a set of euler angles.
FromEulerAnglesXYZ(Single, Single, Single) | Creates a rotation matrix from a set of euler angles.
Top
See Also

Reference

Matrix3x3 Structure


Matrix3x3.FromEulerAnglesXYZ Method (Vector3D)

Matrix3x3FromEulerAnglesXYZ Method (Vector3D)

Creates a rotation matrix from a set of euler angles.

Namespace: Assimp
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public static Matrix3x3 FromEulerAnglesXYZ(
    Vector3D angles
)

Parameters

angles
Type: AssimpVector3D
Vector containing the rotation angles about the x, y, z axes, in radians.

Return Value

Type: Matrix3x3
The rotation matrix
See Also

Reference

Matrix3x3 Structure
FromEulerAnglesXYZ Overload


Matrix3x3.FromEulerAnglesXYZ Method (Single, Single, Single)

Matrix3x3FromEulerAnglesXYZ Method (Single, Single, Single)

Creates a rotation matrix from a set of euler angles.

Namespace: Assimp
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public static Matrix3x3 FromEulerAnglesXYZ(
    float x,
    float y,
    float z
)

Parameters

x
Type: SystemSingle
Rotation angle about the x-axis, in radians.
y
Type: SystemSingle
Rotation angle about the y-axis, in radians.
z
Type: SystemSingle
Rotation angle about the z-axis, in radians.

Return Value

Type: Matrix3x3
The rotation matrix
See Also

Reference

Matrix3x3 Structure
FromEulerAnglesXYZ Overload


Matrix3x3.FromRotationX Method

Matrix3x3FromRotationX Method

Creates a rotation matrix for a rotation about the x-axis.

Namespace: Assimp
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public static Matrix3x3 FromRotationX(
    float radians
)

Parameters

radians
Type: SystemSingle
Rotation angle in radians.

Return Value

Type: Matrix3x3
The rotation matrix
See Also

Reference

Matrix3x3 Structure


Matrix3x3.FromRotationY Method

Matrix3x3FromRotationY Method

Creates a rotation matrix for a rotation about the y-axis.

Namespace: Assimp
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public static Matrix3x3 FromRotationY(
    float radians
)

Parameters

radians
Type: SystemSingle
Rotation angle in radians.

Return Value

Type: Matrix3x3
The rotation matrix
See Also

Reference

Matrix3x3 Structure


Matrix3x3.FromRotationZ Method

Matrix3x3FromRotationZ Method

Creates a rotation matrix for a rotation about the z-axis.

Namespace: Assimp
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public static Matrix3x3 FromRotationZ(
    float radians
)

Parameters

radians
Type: SystemSingle
Rotation angle in radians.

Return Value

Type: Matrix3x3
The rotation matrix
See Also

Reference

Matrix3x3 Structure


Matrix3x3.FromScaling Method

Matrix3x3FromScaling Method

Creates a scaling matrix.

Namespace: Assimp
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public static Matrix3x3 FromScaling(
    Vector3D scaling
)

Parameters

scaling
Type: AssimpVector3D
Scaling vector

Return Value

Type: Matrix3x3
The scaling vector
See Also

Reference

Matrix3x3 Structure


Matrix3x3.FromToMatrix Method

Matrix3x3FromToMatrix Method

Creates a rotation matrix that rotates a vector called "from" into another vector called "to". Based on an algorithm by Tomas Moller and John Hudges:

"Efficiently Building a Matrix to Rotate One Vector to Another" Journal of Graphics Tools, 4(4):1-4, 1999

Namespace: Assimp
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public static Matrix3x3 FromToMatrix(
    Vector3D from,
    Vector3D to
)

Parameters

from
Type: AssimpVector3D
Starting vector
to
Type: AssimpVector3D
Ending vector

Return Value

Type: Matrix3x3
Rotation matrix to rotate from the start to end.
See Also

Reference

Matrix3x3 Structure


Matrix3x3.GetHashCode Method

Matrix3x3GetHashCode Method

Returns a hash code for this instance.

Namespace: Assimp
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public override int GetHashCode()

Return Value

Type: Int32
A hash code for this instance, suitable for use in hashing algorithms and data structures like a hash table.
See Also

Reference

Matrix3x3 Structure


Matrix3x3.Inverse Method

Matrix3x3Inverse Method

Inverts the matrix. If the matrix is *not* invertible all elements are set to NaN.

Namespace: Assimp
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public void Inverse()
See Also

Reference

Matrix3x3 Structure


Matrix3x3.ToString Method

Matrix3x3ToString Method

Returns a String that represents this instance.

Namespace: Assimp
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public override string ToString()

Return Value

Type: String
A String that represents this instance.
See Also

Reference

Matrix3x3 Structure


Matrix3x3.Transpose Method

Matrix3x3Transpose Method

Transposes this matrix (rows become columns, vice versa).

Namespace: Assimp
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public void Transpose()
See Also

Reference

Matrix3x3 Structure


Matrix3x3 Operators and Type Conversions

The Matrix3x3 type exposes the following members.

Operators
Name | Description
Equality | Tests equality between two matrices.
(Matrix4x4 to Matrix3x3) | Implicit conversion from a 4x4 matrix to a 3x3 matrix.
Inequality | Tests inequality between two matrices.
Multiply | Performs matrix multiplication.Multiplication order is B x A. That way, SRT concatenations are left to right.
Top
See Also

Reference

Matrix3x3 Structure


Matrix3x3.Equality Operator

Matrix3x3Equality Operator

Tests equality between two matrices.

Namespace: Assimp
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public static bool operator ==(
    Matrix3x3 a,
    Matrix3x3 b
)

Parameters

a
Type: AssimpMatrix3x3
First matrix
b
Type: AssimpMatrix3x3
Second matrix

Return Value

Type: Boolean
True if the matrices are equal, false otherwise
See Also

Reference

Matrix3x3 Structure


Matrix3x3 Implicit Conversion (Matrix4x4 to Matrix3x3)

Matrix3x3 Conversion (Matrix4x4 to Matrix3x3)

Implicit conversion from a 4x4 matrix to a 3x3 matrix.

Namespace: Assimp
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public static implicit operator Matrix3x3 (
    Matrix4x4 mat
)

Parameters

mat
Type: AssimpMatrix4x4
4x4 matrix

Return Value

Type: Matrix3x3
3x3 matrix
See Also

Reference

Matrix3x3 Structure


Matrix3x3.Inequality Operator

Matrix3x3Inequality Operator

Tests inequality between two matrices.

Namespace: Assimp
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public static bool operator !=(
    Matrix3x3 a,
    Matrix3x3 b
)

Parameters

a
Type: AssimpMatrix3x3
First matrix
b
Type: AssimpMatrix3x3
Second matrix

Return Value

Type: Boolean
True if the matrices are not equal, false otherwise
See Also

Reference

Matrix3x3 Structure


Matrix3x3.Multiply Operator

Matrix3x3Multiply Operator

Performs matrix multiplication.Multiplication order is B x A. That way, SRT concatenations are left to right.

Namespace: Assimp
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public static Matrix3x3 operator *(
    Matrix3x3 a,
    Matrix3x3 b
)

Parameters

a
Type: AssimpMatrix3x3
First matrix
b
Type: AssimpMatrix3x3
Second matrix

Return Value

Type: Matrix3x3
Multiplied matrix
See Also

Reference

Matrix3x3 Structure


Matrix3x3 Fields

The Matrix3x3 type exposes the following members.

Fields
 | Name | Description
Public field | A1 | Value at row 1, column 1 of the matrix
Public field | A2 | Value at row 1, column 2 of the matrix
Public field | A3 | Value at row 1, column 3 of the matrix
Public field | B1 | Value at row 2, column 1 of the matrix
Public field | B2 | Value at row 2, column 2 of the matrix
Public field | B3 | Value at row 2, column 3 of the matrix
Public field | C1 | Value at row 3, column 1 of the matrix
Public field | C2 | Value at row 3, column 2 of the matrix
Public field | C3 | Value at row 3, column 3 of the matrix
Top
See Also

Reference

Matrix3x3 Structure


Matrix3x3.A1 Field

Matrix3x3A1 Field

Value at row 1, column 1 of the matrix

Namespace: Assimp
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public float A1

Field Value

Type: Single
See Also

Reference

Matrix3x3 Structure


Matrix3x3.A2 Field

Matrix3x3A2 Field

Value at row 1, column 2 of the matrix

Namespace: Assimp
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public float A2

Field Value

Type: Single
See Also

Reference

Matrix3x3 Structure


Matrix3x3.A3 Field

Matrix3x3A3 Field

Value at row 1, column 3 of the matrix

Namespace: Assimp
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public float A3

Field Value

Type: Single
See Also

Reference

Matrix3x3 Structure


Matrix3x3.B1 Field

Matrix3x3B1 Field

Value at row 2, column 1 of the matrix

Namespace: Assimp
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public float B1

Field Value

Type: Single
See Also

Reference

Matrix3x3 Structure


Matrix3x3.B2 Field

Matrix3x3B2 Field

Value at row 2, column 2 of the matrix

Namespace: Assimp
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public float B2

Field Value

Type: Single
See Also

Reference

Matrix3x3 Structure


Matrix3x3.B3 Field

Matrix3x3B3 Field

Value at row 2, column 3 of the matrix

Namespace: Assimp
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public float B3

Field Value

Type: Single
See Also

Reference

Matrix3x3 Structure


Matrix3x3.C1 Field

Matrix3x3C1 Field

Value at row 3, column 1 of the matrix

Namespace: Assimp
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public float C1

Field Value

Type: Single
See Also

Reference

Matrix3x3 Structure


Matrix3x3.C2 Field

Matrix3x3C2 Field

Value at row 3, column 2 of the matrix

Namespace: Assimp
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public float C2

Field Value

Type: Single
See Also

Reference

Matrix3x3 Structure


Matrix3x3.C3 Field

Matrix3x3C3 Field

Value at row 3, column 3 of the matrix

Namespace: Assimp
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public float C3

Field Value

Type: Single
See Also

Reference

Matrix3x3 Structure


Matrix4x4 Structure

Represents a 4x4 column-vector matrix (X base is the first column, Y base is the second, Z base the third, and translation the fourth). Memory layout is row major. Right handed conventions are used by default.

Namespace: Assimp
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public struct Matrix4x4 : IEquatable<Matrix4x4>

The Matrix4x4 type exposes the following members.

Constructors
 | Name | Description
Public method | Matrix4x4(Matrix3x3) | Constructs a new Matrix4x4.
Public method | Matrix4x4(Single, Single, Single, Single, Single, Single, Single, Single, Single, Single, Single, Single, Single, Single, Single, Single) | Constructs a new Matrix4x4.
Top
Properties
 | Name | Description
 | Identity | Gets the identity matrix.
Public property | IsIdentity | Gets if this matrix is an identity matrix.
Public property | Item | Gets or sets the value at the specific one-based row, column index. E.g. i = 1, j = 2 gets the value in row 1, column 2 (MA2). Indices out of range return a value of zero.
Top
Methods
 | Name | Description
Public method | Decompose | Decomposes a transformation matrix into its original scale, rotation, and translation components. The scaling vector receives the scaling for the x, y, z axes. The rotation is returned as a hamilton quaternion. And the translation is the output position for the x, y, z axes.
Public method | DecomposeNoScaling | Decomposes a transformation matrix with no scaling. The rotation is returned as a hamilton quaternion. The translation receives the output position for the x, y, z axes.
Public method | Determinant | Compute the determinant of this matrix.
Public method | Equals(Object) | Determines whether the specified Object is equal to this instance. (Overrides ValueTypeEquals(Object).)
Public method | Equals(Matrix4x4) | Tests equality between this matrix and another.
 | FromAngleAxis | Creates a rotation matrix for a rotation about an arbitrary axis.
 | FromEulerAnglesXYZ(Vector3D) | Creates a rotation matrix from a set of euler angles.
 | FromEulerAnglesXYZ(Single, Single, Single) | Creates a rotation matrix from a set of euler angles.
 | FromRotationX | Creates a rotation matrix for a rotation about the x-axis.
 | FromRotationY | Creates a rotation matrix for a rotation about the y-axis.
 | FromRotationZ | Creates a rotation matrix for a rotation about the z-axis.
 | FromScaling | Creates a scaling matrix.
 | FromToMatrix | Creates a rotation matrix that rotates a vector called "from" into another vector called "to". Based on an algorithm by Tomas Moller and John Hudges: "Efficiently Building a Matrix to Rotate One Vector to Another" Journal of Graphics Tools, 4(4):1-4, 1999
 | FromTranslation | Creates a translation matrix.
Public method | GetHashCode | Returns a hash code for this instance. (Overrides ValueTypeGetHashCode.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Inverse | Inverts the matrix. If the matrix is *not* invertible all elements are set to NaN.
Public method | ToString | Returns a String that represents this instance. (Overrides ValueTypeToString.)
Public method | Transpose | Transposes this matrix (rows become columns, vice versa).
Top
Operators
Name | Description
Equality | Tests equality between two matrices.
(Matrix3x3 to Matrix4x4) | Implicit conversion from a 3x3 matrix to a 4x4 matrix.
Inequality | Tests inequality between two matrices.
Multiply | Performs matrix multiplication. Multiplication order is B x A. That way, SRT concatenations are left to right.
Top
Fields
 | Name | Description
Public field | A1 | Value at row 1, column 1 of the matrix
Public field | A2 | Value at row 1, column 2 of the matrix
Public field | A3 | Value at row 1, column 3 of the matrix
Public field | A4 | Value at row 1, column 4 of the matrix
Public field | B1 | Value at row 2, column 1 of the matrix
Public field | B2 | Value at row 2, column 2 of the matrix
Public field | B3 | Value at row 2, column 3 of the matrix
Public field | B4 | Value at row 2, column 4 of the matrix
Public field | C1 | Value at row 3, column 1 of the matrix
Public field | C2 | Value at row 3, column 2 of the matrix
Public field | C3 | Value at row 3, column 3 of the matrix
Public field | C4 | Value at row 3, column 4 of the matrix
Public field | D1 | Value at row 4, column 1 of the matrix
Public field | D2 | Value at row 4, column 2 of the matrix
Public field | D3 | Value at row 4, column 3 of the matrix
Public field | D4 | Value at row 4, column 4 of the matrix
Top
See Also

Reference


Matrix4x4 Constructor

Overload List
 | Name | Description
Public method | Matrix4x4(Matrix3x3) | Constructs a new Matrix4x4.
Public method | Matrix4x4(Single, Single, Single, Single, Single, Single, Single, Single, Single, Single, Single, Single, Single, Single, Single, Single) | Constructs a new Matrix4x4.
Top
See Also

Reference

Matrix4x4 Structure


Matrix4x4 Constructor (Matrix3x3)

Constructs a new Matrix4x4.

Namespace: Assimp
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public Matrix4x4(
    Matrix3x3 rotMatrix
)

Parameters

rotMatrix
Type: AssimpMatrix3x3
Rotation matrix to copy values from.
See Also

Reference

Matrix4x4 Structure
Matrix4x4 Overload


Matrix4x4 Constructor (Single, Single, Single, Single, Single, Single, Single, Single, Single, Single, Single, Single, Single, Single, Single, Single)

Constructs a new Matrix4x4.

Namespace: Assimp
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public Matrix4x4(
    float a1,
    float a2,
    float a3,
    float a4,
    float b1,
    float b2,
    float b3,
    float b4,
    float c1,
    float c2,
    float c3,
    float c4,
    float d1,
    float d2,
    float d3,
    float d4
)

Parameters

a1
Type: SystemSingle
Element at row 1, column 1
a2
Type: SystemSingle
Element at row 1, column 2
a3
Type: SystemSingle
Element at row 1, column 3
a4
Type: SystemSingle
Element at row 1, column 4
b1
Type: SystemSingle
Element at row 2, column 1
b2
Type: SystemSingle
Element at row 2, column 2
b3
Type: SystemSingle
Element at row 2, column 3
b4
Type: SystemSingle
Element at row 2, column 4
c1
Type: SystemSingle
Element at row 3, column 1
c2
Type: SystemSingle
Element at row 3, column 2
c3
Type: SystemSingle
Element at row 3, column 3
c4
Type: SystemSingle
Element at row 3, column 4
d1
Type: SystemSingle
Element at row 4, column 1
d2
Type: SystemSingle
Element at row 4, column 2
d3
Type: SystemSingle
Element at row 4, column 3
d4
Type: SystemSingle
Element at row 4, column 4
See Also

Reference

Matrix4x4 Structure
Matrix4x4 Overload


Matrix4x4 Properties

The Matrix4x4 type exposes the following members.

Properties
 | Name | Description
 | Identity | Gets the identity matrix.
Public property | IsIdentity | Gets if this matrix is an identity matrix.
Public property | Item | Gets or sets the value at the specific one-based row, column index. E.g. i = 1, j = 2 gets the value in row 1, column 2 (MA2). Indices out of range return a value of zero.
Top
See Also

Reference

Matrix4x4 Structure


Matrix4x4.Identity Property

Matrix4x4Identity Property

Gets the identity matrix.

Namespace: Assimp
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public static Matrix4x4 Identity { get; }

Property Value

Type: Matrix4x4
See Also

Reference

Matrix4x4 Structure


Matrix4x4.IsIdentity Property

Matrix4x4IsIdentity Property

Gets if this matrix is an identity matrix.

Namespace: Assimp
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public bool IsIdentity { get; }

Property Value

Type: Boolean
See Also

Reference

Matrix4x4 Structure


Matrix4x4.Item Property

Matrix4x4Item Property

Gets or sets the value at the specific one-based row, column index. E.g. i = 1, j = 2 gets the value in row 1, column 2 (MA2). Indices out of range return a value of zero.

Namespace: Assimp
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public float this[
    int i,
    int j
] { get; set; }

Parameters

i
Type: SystemInt32
One-based Row index
j
Type: SystemInt32
One-based Column index

Return Value

Type: Single
Matrix value
See Also

Reference

Matrix4x4 Structure


Matrix4x4 Methods

The Matrix4x4 type exposes the following members.

Methods
 | Name | Description
Public method | Decompose | Decomposes a transformation matrix into its original scale, rotation, and translation components. The scaling vector receives the scaling for the x, y, z axes. The rotation is returned as a hamilton quaternion. And the translation is the output position for the x, y, z axes.
Public method | DecomposeNoScaling | Decomposes a transformation matrix with no scaling. The rotation is returned as a hamilton quaternion. The translation receives the output position for the x, y, z axes.
Public method | Determinant | Compute the determinant of this matrix.
Public method | Equals(Object) | Determines whether the specified Object is equal to this instance. (Overrides ValueTypeEquals(Object).)
Public method | Equals(Matrix4x4) | Tests equality between this matrix and another.
 | FromAngleAxis | Creates a rotation matrix for a rotation about an arbitrary axis.
 | FromEulerAnglesXYZ(Vector3D) | Creates a rotation matrix from a set of euler angles.
 | FromEulerAnglesXYZ(Single, Single, Single) | Creates a rotation matrix from a set of euler angles.
 | FromRotationX | Creates a rotation matrix for a rotation about the x-axis.
 | FromRotationY | Creates a rotation matrix for a rotation about the y-axis.
 | FromRotationZ | Creates a rotation matrix for a rotation about the z-axis.
 | FromScaling | Creates a scaling matrix.
 | FromToMatrix | Creates a rotation matrix that rotates a vector called "from" into another vector called "to". Based on an algorithm by Tomas Moller and John Hudges: "Efficiently Building a Matrix to Rotate One Vector to Another" Journal of Graphics Tools, 4(4):1-4, 1999
 | FromTranslation | Creates a translation matrix.
Public method | GetHashCode | Returns a hash code for this instance. (Overrides ValueTypeGetHashCode.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Inverse | Inverts the matrix. If the matrix is *not* invertible all elements are set to NaN.
Public method | ToString | Returns a String that represents this instance. (Overrides ValueTypeToString.)
Public method | Transpose | Transposes this matrix (rows become columns, vice versa).
Top
See Also

Reference

Matrix4x4 Structure


Matrix4x4.Decompose Method

Matrix4x4Decompose Method

Decomposes a transformation matrix into its original scale, rotation, and translation components. The scaling vector receives the scaling for the x, y, z axes. The rotation is returned as a hamilton quaternion. And the translation is the output position for the x, y, z axes.

Namespace: Assimp
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public void Decompose(
    out Vector3D scaling,
    out Quaternion rotation,
    out Vector3D translation
)

Parameters

scaling
Type: AssimpVector3D
Vector to hold the scaling component
rotation
Type: AssimpQuaternion
Quaternion to hold the rotation component
translation
Type: AssimpVector3D
Vector to hold the translation component
See Also

Reference

Matrix4x4 Structure


Matrix4x4.DecomposeNoScaling Method

Matrix4x4DecomposeNoScaling Method

Decomposes a transformation matrix with no scaling. The rotation is returned as a hamilton quaternion. The translation receives the output position for the x, y, z axes.

Namespace: Assimp
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public void DecomposeNoScaling(
    out Quaternion rotation,
    out Vector3D translation
)

Parameters

rotation
Type: AssimpQuaternion
Quaternion to hold the rotation component
translation
Type: AssimpVector3D
Vector to hold the translation component
See Also

Reference

Matrix4x4 Structure


Matrix4x4.Determinant Method

Matrix4x4Determinant Method

Compute the determinant of this matrix.

Namespace: Assimp
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public float Determinant()

Return Value

Type: Single
The determinant
See Also

Reference

Matrix4x4 Structure


Matrix4x4.Equals Method

Matrix4x4Equals Method

Overload List
 | Name | Description
Public method | Equals(Object) | Determines whether the specified Object is equal to this instance. (Overrides ValueTypeEquals(Object).)
Public method | Equals(Matrix4x4) | Tests equality between this matrix and another.
Top
See Also

Reference

Matrix4x4 Structure


Matrix4x4.Equals Method (Object)

Matrix4x4Equals Method (Object)

Determines whether the specified Object is equal to this instance.

Namespace: Assimp
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public override bool Equals(
    Object obj
)

Parameters

obj
Type: SystemObject
The Object to compare with this instance.

Return Value

Type: Boolean
true if the specified Object is equal to this instance; otherwise, false.
See Also

Reference

Matrix4x4 Structure
Equals Overload


Matrix4x4.Equals Method (Matrix4x4)

Matrix4x4Equals Method (Matrix4x4)

Tests equality between this matrix and another.

Namespace: Assimp
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public bool Equals(
    Matrix4x4 other
)

Parameters

other
Type: AssimpMatrix4x4
Other matrix to test

Return Value

Type: Boolean
True if the matrices are equal, false otherwise

Implements

IEquatableTEquals(T)
See Also

Reference

Matrix4x4 Structure
Equals Overload


Matrix4x4.FromAngleAxis Method

Matrix4x4FromAngleAxis Method

Creates a rotation matrix for a rotation about an arbitrary axis.

Namespace: Assimp
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public static Matrix4x4 FromAngleAxis(
    float radians,
    Vector3D axis
)

Parameters

radians
Type: SystemSingle
Rotation angle, in radians
axis
Type: AssimpVector3D
Rotation axis, which should be a normalized vector.

Return Value

Type: Matrix4x4
The rotation matrix
See Also

Reference

Matrix4x4 Structure


Matrix4x4.FromEulerAnglesXYZ Method

Matrix4x4FromEulerAnglesXYZ Method

Overload List
Name | Description
FromEulerAnglesXYZ(Vector3D) | Creates a rotation matrix from a set of euler angles.
FromEulerAnglesXYZ(Single, Single, Single) | Creates a rotation matrix from a set of euler angles.
Top
See Also

Reference

Matrix4x4 Structure


Matrix4x4.FromEulerAnglesXYZ Method (Vector3D)

Matrix4x4FromEulerAnglesXYZ Method (Vector3D)

Creates a rotation matrix from a set of euler angles.

Namespace: Assimp
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public static Matrix4x4 FromEulerAnglesXYZ(
    Vector3D angles
)

Parameters

angles
Type: AssimpVector3D
Vector containing the rotation angles about the x, y, z axes, in radians.

Return Value

Type: Matrix4x4
The rotation matrix
See Also

Reference

Matrix4x4 Structure
FromEulerAnglesXYZ Overload


Matrix4x4.FromEulerAnglesXYZ Method (Single, Single, Single)

Matrix4x4FromEulerAnglesXYZ Method (Single, Single, Single)

Creates a rotation matrix from a set of euler angles.

Namespace: Assimp
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public static Matrix4x4 FromEulerAnglesXYZ(
    float x,
    float y,
    float z
)

Parameters

x
Type: SystemSingle
Rotation angle about the x-axis, in radians.
y
Type: SystemSingle
Rotation angle about the y-axis, in radians.
z
Type: SystemSingle
Rotation angle about the z-axis, in radians.

Return Value

Type: Matrix4x4
The rotation matrix
See Also

Reference

Matrix4x4 Structure
FromEulerAnglesXYZ Overload


Matrix4x4.FromRotationX Method

Matrix4x4FromRotationX Method

Creates a rotation matrix for a rotation about the x-axis.

Namespace: Assimp
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public static Matrix4x4 FromRotationX(
    float radians
)

Parameters

radians
Type: SystemSingle
Rotation angle in radians.

Return Value

Type: Matrix4x4
The rotation matrix
See Also

Reference

Matrix4x4 Structure


Matrix4x4.FromRotationY Method

Matrix4x4FromRotationY Method

Creates a rotation matrix for a rotation about the y-axis.

Namespace: Assimp
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public static Matrix4x4 FromRotationY(
    float radians
)

Parameters

radians
Type: SystemSingle
Rotation angle in radians.

Return Value

Type: Matrix4x4
The rotation matrix
See Also

Reference

Matrix4x4 Structure


Matrix4x4.FromRotationZ Method

Matrix4x4FromRotationZ Method

Creates a rotation matrix for a rotation about the z-axis.

Namespace: Assimp
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public static Matrix4x4 FromRotationZ(
    float radians
)

Parameters

radians
Type: SystemSingle
Rotation angle in radians.

Return Value

Type: Matrix4x4
The rotation matrix
See Also

Reference

Matrix4x4 Structure


Matrix4x4.FromScaling Method

Matrix4x4FromScaling Method

Creates a scaling matrix.

Namespace: Assimp
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public static Matrix4x4 FromScaling(
    Vector3D scaling
)

Parameters

scaling
Type: AssimpVector3D
Scaling vector

Return Value

Type: Matrix4x4
The scaling vector
See Also

Reference

Matrix4x4 Structure


Matrix4x4.FromToMatrix Method

Matrix4x4FromToMatrix Method

Creates a rotation matrix that rotates a vector called "from" into another vector called "to". Based on an algorithm by Tomas Moller and John Hudges:

"Efficiently Building a Matrix to Rotate One Vector to Another" Journal of Graphics Tools, 4(4):1-4, 1999

Namespace: Assimp
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public static Matrix4x4 FromToMatrix(
    Vector3D from,
    Vector3D to
)

Parameters

from
Type: AssimpVector3D
Starting vector
to
Type: AssimpVector3D
Ending vector

Return Value

Type: Matrix4x4
Rotation matrix to rotate from the start to end.
See Also

Reference

Matrix4x4 Structure


Matrix4x4.FromTranslation Method

Matrix4x4FromTranslation Method

Creates a translation matrix.

Namespace: Assimp
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public static Matrix4x4 FromTranslation(
    Vector3D translation
)

Parameters

translation
Type: AssimpVector3D
Translation vector

Return Value

Type: Matrix4x4
The translation matrix
See Also

Reference

Matrix4x4 Structure


Matrix4x4.GetHashCode Method

Matrix4x4GetHashCode Method

Returns a hash code for this instance.

Namespace: Assimp
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public override int GetHashCode()

Return Value

Type: Int32
A hash code for this instance, suitable for use in hashing algorithms and data structures like a hash table.
See Also

Reference

Matrix4x4 Structure


Matrix4x4.Inverse Method

Matrix4x4Inverse Method

Inverts the matrix. If the matrix is *not* invertible all elements are set to NaN.

Namespace: Assimp
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public void Inverse()
See Also

Reference

Matrix4x4 Structure


Matrix4x4.ToString Method

Matrix4x4ToString Method

Returns a String that represents this instance.

Namespace: Assimp
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public override string ToString()

Return Value

Type: String
A String that represents this instance.
See Also

Reference

Matrix4x4 Structure


Matrix4x4.Transpose Method

Matrix4x4Transpose Method

Transposes this matrix (rows become columns, vice versa).

Namespace: Assimp
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public void Transpose()
See Also

Reference

Matrix4x4 Structure


Matrix4x4 Operators and Type Conversions

The Matrix4x4 type exposes the following members.

Operators
Name | Description
Equality | Tests equality between two matrices.
(Matrix3x3 to Matrix4x4) | Implicit conversion from a 3x3 matrix to a 4x4 matrix.
Inequality | Tests inequality between two matrices.
Multiply | Performs matrix multiplication. Multiplication order is B x A. That way, SRT concatenations are left to right.
Top
See Also

Reference

Matrix4x4 Structure


Matrix4x4.Equality Operator

Matrix4x4Equality Operator

Tests equality between two matrices.

Namespace: Assimp
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public static bool operator ==(
    Matrix4x4 a,
    Matrix4x4 b
)

Parameters

a
Type: AssimpMatrix4x4
First matrix
b
Type: AssimpMatrix4x4
Second matrix

Return Value

Type: Boolean
True if the matrices are equal, false otherwise
See Also

Reference

Matrix4x4 Structure


Matrix4x4 Implicit Conversion (Matrix3x3 to Matrix4x4)

Matrix4x4 Conversion (Matrix3x3 to Matrix4x4)

Implicit conversion from a 3x3 matrix to a 4x4 matrix.

Namespace: Assimp
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public static implicit operator Matrix4x4 (
    Matrix3x3 mat
)

Parameters

mat
Type: AssimpMatrix3x3
3x3 matrix

Return Value

Type: Matrix4x4
4x4 matrix
See Also

Reference

Matrix4x4 Structure


Matrix4x4.Inequality Operator

Matrix4x4Inequality Operator

Tests inequality between two matrices.

Namespace: Assimp
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public static bool operator !=(
    Matrix4x4 a,
    Matrix4x4 b
)

Parameters

a
Type: AssimpMatrix4x4
First matrix
b
Type: AssimpMatrix4x4
Second matrix

Return Value

Type: Boolean
True if the matrices are not equal, false otherwise
See Also

Reference

Matrix4x4 Structure


Matrix4x4.Multiply Operator

Matrix4x4Multiply Operator

Performs matrix multiplication. Multiplication order is B x A. That way, SRT concatenations are left to right.

Namespace: Assimp
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public static Matrix4x4 operator *(
    Matrix4x4 a,
    Matrix4x4 b
)

Parameters

a
Type: AssimpMatrix4x4
First matrix
b
Type: AssimpMatrix4x4
Second matrix

Return Value

Type: Matrix4x4
Multiplied matrix
See Also

Reference

Matrix4x4 Structure


Matrix4x4 Fields

The Matrix4x4 type exposes the following members.

Fields
 | Name | Description
Public field | A1 | Value at row 1, column 1 of the matrix
Public field | A2 | Value at row 1, column 2 of the matrix
Public field | A3 | Value at row 1, column 3 of the matrix
Public field | A4 | Value at row 1, column 4 of the matrix
Public field | B1 | Value at row 2, column 1 of the matrix
Public field | B2 | Value at row 2, column 2 of the matrix
Public field | B3 | Value at row 2, column 3 of the matrix
Public field | B4 | Value at row 2, column 4 of the matrix
Public field | C1 | Value at row 3, column 1 of the matrix
Public field | C2 | Value at row 3, column 2 of the matrix
Public field | C3 | Value at row 3, column 3 of the matrix
Public field | C4 | Value at row 3, column 4 of the matrix
Public field | D1 | Value at row 4, column 1 of the matrix
Public field | D2 | Value at row 4, column 2 of the matrix
Public field | D3 | Value at row 4, column 3 of the matrix
Public field | D4 | Value at row 4, column 4 of the matrix
Top
See Also

Reference

Matrix4x4 Structure


Matrix4x4.A1 Field

Matrix4x4A1 Field

Value at row 1, column 1 of the matrix

Namespace: Assimp
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public float A1

Field Value

Type: Single
See Also

Reference

Matrix4x4 Structure


Matrix4x4.A2 Field

Matrix4x4A2 Field

Value at row 1, column 2 of the matrix

Namespace: Assimp
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public float A2

Field Value

Type: Single
See Also

Reference

Matrix4x4 Structure


Matrix4x4.A3 Field

Matrix4x4A3 Field

Value at row 1, column 3 of the matrix

Namespace: Assimp
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public float A3

Field Value

Type: Single
See Also

Reference

Matrix4x4 Structure


Matrix4x4.A4 Field

Matrix4x4A4 Field

Value at row 1, column 4 of the matrix

Namespace: Assimp
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public float A4

Field Value

Type: Single
See Also

Reference

Matrix4x4 Structure


Matrix4x4.B1 Field

Matrix4x4B1 Field

Value at row 2, column 1 of the matrix

Namespace: Assimp
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public float B1

Field Value

Type: Single
See Also

Reference

Matrix4x4 Structure


Matrix4x4.B2 Field

Matrix4x4B2 Field

Value at row 2, column 2 of the matrix

Namespace: Assimp
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public float B2

Field Value

Type: Single
See Also

Reference

Matrix4x4 Structure


Matrix4x4.B3 Field

Matrix4x4B3 Field

Value at row 2, column 3 of the matrix

Namespace: Assimp
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public float B3

Field Value

Type: Single
See Also

Reference

Matrix4x4 Structure


Matrix4x4.B4 Field

Matrix4x4B4 Field

Value at row 2, column 4 of the matrix

Namespace: Assimp
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public float B4

Field Value

Type: Single
See Also

Reference

Matrix4x4 Structure


Matrix4x4.C1 Field

Matrix4x4C1 Field

Value at row 3, column 1 of the matrix

Namespace: Assimp
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public float C1

Field Value

Type: Single
See Also

Reference

Matrix4x4 Structure


Matrix4x4.C2 Field

Matrix4x4C2 Field

Value at row 3, column 2 of the matrix

Namespace: Assimp
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public float C2

Field Value

Type: Single
See Also

Reference

Matrix4x4 Structure


Matrix4x4.C3 Field

Matrix4x4C3 Field

Value at row 3, column 3 of the matrix

Namespace: Assimp
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public float C3

Field Value

Type: Single
See Also

Reference

Matrix4x4 Structure


Matrix4x4.C4 Field

Matrix4x4C4 Field

Value at row 3, column 4 of the matrix

Namespace: Assimp
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public float C4

Field Value

Type: Single
See Also

Reference

Matrix4x4 Structure


Matrix4x4.D1 Field

Matrix4x4D1 Field

Value at row 4, column 1 of the matrix

Namespace: Assimp
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public float D1

Field Value

Type: Single
See Also

Reference

Matrix4x4 Structure


Matrix4x4.D2 Field

Matrix4x4D2 Field

Value at row 4, column 2 of the matrix

Namespace: Assimp
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public float D2

Field Value

Type: Single
See Also

Reference

Matrix4x4 Structure


Matrix4x4.D3 Field

Matrix4x4D3 Field

Value at row 4, column 3 of the matrix

Namespace: Assimp
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public float D3

Field Value

Type: Single
See Also

Reference

Matrix4x4 Structure


Matrix4x4.D4 Field

Matrix4x4D4 Field

Value at row 4, column 4 of the matrix

Namespace: Assimp
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public float D4

Field Value

Type: Single
See Also

Reference

Matrix4x4 Structure


MemoryHelper Class

Helper static class containing functions that aid dealing with unmanaged memory to managed memory conversions.
Inheritance Hierarchy
SystemObject
AssimpMemoryHelper

Namespace: Assimp
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public static class MemoryHelper

The MemoryHelper type exposes the following members.

Methods
Name | Description
AddIntPtr | Adds an offset to the pointer.
AllocateClearedMemory | Allocates unmanaged memory that is cleared to a certain value. This memory should only be freed by this helper.
AllocateMemory | Allocates unmanaged memory. This memory should only be freed by this helper.
AsTFrom, TTo | Casts one by-ref type to another, unsafely.
AsPointerT | Casts the by-ref value into a pointer.
AsPointerReadonlyT | Casts the readonly by-ref value into a pointer.
AsReadonlyTFrom, TTo | Casts one readonly by-ref type to another, unsafely.
AsRefT | Casts the pointer into a by-ref value of the specified type.
CastToEnumV, T | Casts an underlying value type to an enum type, WITHOUT first casting the value to an Object. So this avoid boxing the value.
ClearMemory | Clears the memory to the specified value.
Compare | Compares two arrays of bytes for equivalence.
ComputeFNVModifiedHashCode | Computes a hash code using the FNV modified algorithmm.
CopyBytesT(Byte, Int32, T, Int32, Int32) | Copies bytes from a byte array to an element array.
CopyBytesT(T, Int32, Byte, Int32, Int32) | Copies bytes from an element array to a byte array.
CopyMemory | Performs a memcopy that copies data from the memory pointed to by the source pointer to the memory pointer by the destination pointer.
CountT | Returns the number of elements in the enumerable.
DisposeCollectionT | Convienence method to dispose all items in the collection
FreeMemory | Frees unmanaged memory that was allocated by this helper.
FreeNativeArrayT(IntPtr, Int32, FreeNativeDelegate) | Frees an unmanaged array and performs cleanup for each value. This can be used on any type that can be marshaled into unmanaged memory.
FreeNativeArrayT(IntPtr, Int32, FreeNativeDelegate, Boolean) | Frees an unmanaged array and performs cleanup for each value. Optionally can free an array of pointers. This can be used on any type that can be marshaled into unmanaged memory.
FromByteArrayT | Converts a byte array to a typed element array.
FromNativeArrayT(IntPtr, Int32) | Marshals an array of blittable structs from a c-style unmanaged array (void*). This should not be used on non-blittable types that require marshaling by the runtime (e.g. has MarshalAs attributes).
FromNativeArrayManaged, Native(IntPtr, Int32) | Marshals an array of managed values from a c-style unmanaged array (void*).
FromNativeArrayManaged, Native(IntPtr, Int32, Boolean) | Marshals an array of managed values from a c-style unmanaged array (void*). This also can optionally marshal from an unmanaged array of pointers (void**).
FromNativePointerManaged, Native | Marshals a managed value from unmanaged memory.
IsMemoryAligned | Checks if the memory is aligned to the specified alignment.
MarshalPointerT | Convienence method for marshaling a structure to a pointer. Only use if the type is not blittable, otherwise use the write methods for blittable types.
MarshalSizeOfT | Computes the size of the struct type using Marshal SizeOf. Only use if the type is not blittable, thus requiring marshaling by the runtime, (e.g. has MarshalAs attributes), otherwise use the SizeOf methods for blittable types.
MarshalSizeOfT(T) | Computes the size of the struct array using Marshal SizeOf. Only use if the type is not blittable, thus requiring marshaling by the runtime, (e.g. has MarshalAs attributes), otherwise use the SizeOf methods for blittable types.
MarshalStructureT(IntPtr) | Convienence method for marshaling a pointer to a structure. Only use if the type is not blittable, otherwise use the read methods for blittable types.
MarshalStructureT(IntPtr, T) | Convienence method for marshaling a pointer to a structure. Only use if the type is not blittable, otherwise use the read methods for blittable types.
PinObject | Pins an object in memory, which allows a pointer to it to be returned. While the object remains pinned the runtime cannot move the object around in memory, which may degrade performance.
ReadT(IntPtr) | Reads a single element from the memory location.
ReadT(IntPtr, T) | Reads a single element from the memory location.
ReadT(IntPtr, T, Int32, Int32) | Reads data from the memory location into the array.
ReadStreamFully | Reads a stream until the end is reached into a byte array. Based on Jon Skeet's implementation. It is up to the caller to dispose of the stream.
SizeOfT | Computes the size of the struct type.
SizeOfT(T) | Computes the size of the struct array.
SwapT | Swaps the value between two references.
ToByteArrayT | Converts typed element array to a byte array.
ToNativeArrayT(T) | Marshals an array of blittable structs to a c-style unmanaged array (void*). This should not be used on non-blittable types that require marshaling by the runtime (e.g. has MarshalAs attributes).
ToNativeArrayManaged, Native(Managed) | Marshals an array of managed values to a c-style unmanaged array (void*).
ToNativeArrayManaged, Native(Managed, Boolean) | Marshals an array of managed values to a c-style unmanaged array (void*). This also can optionally marshal to an unmanaged array of pointers (void**).
ToNativePointerManaged, Native | Marshals a managed value to unmanaged memory.
UnpinObject | Unpins an object in memory, allowing it to once again freely be moved around by the runtime.
WriteT(IntPtr, T) | Writes a single element to the memory location.
WriteT(IntPtr, T, Int32, Int32) | Writes data from the array to the memory location.
Top
See Also

Reference


MemoryHelper Methods

The MemoryHelper type exposes the following members.

Methods
Name | Description
AddIntPtr | Adds an offset to the pointer.
AllocateClearedMemory | Allocates unmanaged memory that is cleared to a certain value. This memory should only be freed by this helper.
AllocateMemory | Allocates unmanaged memory. This memory should only be freed by this helper.
AsTFrom, TTo | Casts one by-ref type to another, unsafely.
AsPointerT | Casts the by-ref value into a pointer.
AsPointerReadonlyT | Casts the readonly by-ref value into a pointer.
AsReadonlyTFrom, TTo | Casts one readonly by-ref type to another, unsafely.
AsRefT | Casts the pointer into a by-ref value of the specified type.
CastToEnumV, T | Casts an underlying value type to an enum type, WITHOUT first casting the value to an Object. So this avoid boxing the value.
ClearMemory | Clears the memory to the specified value.
Compare | Compares two arrays of bytes for equivalence.
ComputeFNVModifiedHashCode | Computes a hash code using the FNV modified algorithmm.
CopyBytesT(Byte, Int32, T, Int32, Int32) | Copies bytes from a byte array to an element array.
CopyBytesT(T, Int32, Byte, Int32, Int32) | Copies bytes from an element array to a byte array.
CopyMemory | Performs a memcopy that copies data from the memory pointed to by the source pointer to the memory pointer by the destination pointer.
CountT | Returns the number of elements in the enumerable.
DisposeCollectionT | Convienence method to dispose all items in the collection
FreeMemory | Frees unmanaged memory that was allocated by this helper.
FreeNativeArrayT(IntPtr, Int32, FreeNativeDelegate) | Frees an unmanaged array and performs cleanup for each value. This can be used on any type that can be marshaled into unmanaged memory.
FreeNativeArrayT(IntPtr, Int32, FreeNativeDelegate, Boolean) | Frees an unmanaged array and performs cleanup for each value. Optionally can free an array of pointers. This can be used on any type that can be marshaled into unmanaged memory.
FromByteArrayT | Converts a byte array to a typed element array.
FromNativeArrayT(IntPtr, Int32) | Marshals an array of blittable structs from a c-style unmanaged array (void*). This should not be used on non-blittable types that require marshaling by the runtime (e.g. has MarshalAs attributes).
FromNativeArrayManaged, Native(IntPtr, Int32) | Marshals an array of managed values from a c-style unmanaged array (void*).
FromNativeArrayManaged, Native(IntPtr, Int32, Boolean) | Marshals an array of managed values from a c-style unmanaged array (void*). This also can optionally marshal from an unmanaged array of pointers (void**).
FromNativePointerManaged, Native | Marshals a managed value from unmanaged memory.
IsMemoryAligned | Checks if the memory is aligned to the specified alignment.
MarshalPointerT | Convienence method for marshaling a structure to a pointer. Only use if the type is not blittable, otherwise use the write methods for blittable types.
MarshalSizeOfT | Computes the size of the struct type using Marshal SizeOf. Only use if the type is not blittable, thus requiring marshaling by the runtime, (e.g. has MarshalAs attributes), otherwise use the SizeOf methods for blittable types.
MarshalSizeOfT(T) | Computes the size of the struct array using Marshal SizeOf. Only use if the type is not blittable, thus requiring marshaling by the runtime, (e.g. has MarshalAs attributes), otherwise use the SizeOf methods for blittable types.
MarshalStructureT(IntPtr) | Convienence method for marshaling a pointer to a structure. Only use if the type is not blittable, otherwise use the read methods for blittable types.
MarshalStructureT(IntPtr, T) | Convienence method for marshaling a pointer to a structure. Only use if the type is not blittable, otherwise use the read methods for blittable types.
PinObject | Pins an object in memory, which allows a pointer to it to be returned. While the object remains pinned the runtime cannot move the object around in memory, which may degrade performance.
ReadT(IntPtr) | Reads a single element from the memory location.
ReadT(IntPtr, T) | Reads a single element from the memory location.
ReadT(IntPtr, T, Int32, Int32) | Reads data from the memory location into the array.
ReadStreamFully | Reads a stream until the end is reached into a byte array. Based on Jon Skeet's implementation. It is up to the caller to dispose of the stream.
SizeOfT | Computes the size of the struct type.
SizeOfT(T) | Computes the size of the struct array.
SwapT | Swaps the value between two references.
ToByteArrayT | Converts typed element array to a byte array.
ToNativeArrayT(T) | Marshals an array of blittable structs to a c-style unmanaged array (void*). This should not be used on non-blittable types that require marshaling by the runtime (e.g. has MarshalAs attributes).
ToNativeArrayManaged, Native(Managed) | Marshals an array of managed values to a c-style unmanaged array (void*).
ToNativeArrayManaged, Native(Managed, Boolean) | Marshals an array of managed values to a c-style unmanaged array (void*). This also can optionally marshal to an unmanaged array of pointers (void**).
ToNativePointerManaged, Native | Marshals a managed value to unmanaged memory.
UnpinObject | Unpins an object in memory, allowing it to once again freely be moved around by the runtime.
WriteT(IntPtr, T) | Writes a single element to the memory location.
WriteT(IntPtr, T, Int32, Int32) | Writes data from the array to the memory location.
Top
See Also

Reference

MemoryHelper Class


MemoryHelper.AddIntPtr Method

MemoryHelperAddIntPtr Method

Adds an offset to the pointer.

Namespace: Assimp
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public static IntPtr AddIntPtr(
    IntPtr ptr,
    int offset
)

Parameters

ptr
Type: SystemIntPtr
Pointer
offset
Type: SystemInt32
Offset

Return Value

Type: IntPtr
Pointer plus the offset
See Also

Reference

MemoryHelper Class


MemoryHelper.AllocateClearedMemory Method

MemoryHelperAllocateClearedMemory Method

Allocates unmanaged memory that is cleared to a certain value. This memory should only be freed by this helper.

Namespace: Assimp
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public static IntPtr AllocateClearedMemory(
    int sizeInBytes,
    byte clearValue = 0,
    int alignment = 16
)

Parameters

sizeInBytes
Type: SystemInt32
Size to allocate
clearValue (Optional)
Type: SystemByte
Value the memory will be cleared to, by default zero.
alignment (Optional)
Type: SystemInt32
Alignment of the memory, by default aligned along 16-byte boundary.

Return Value

Type: IntPtr
Pointer to the allocated unmanaged memory.
See Also

Reference

MemoryHelper Class


MemoryHelper.AllocateMemory Method

MemoryHelperAllocateMemory Method

Allocates unmanaged memory. This memory should only be freed by this helper.

Namespace: Assimp
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public static IntPtr AllocateMemory(
    int sizeInBytes,
    int alignment = 16
)

Parameters

sizeInBytes
Type: SystemInt32
Size to allocate
alignment (Optional)
Type: SystemInt32
Alignment of the memory, by default aligned along 16-byte boundary.

Return Value

Type: IntPtr
Pointer to the allocated unmanaged memory.
See Also

Reference

MemoryHelper Class


MemoryHelper.As(TFrom, TTo) Method

MemoryHelperAsTFrom, TTo Method

Casts one by-ref type to another, unsafely.

Namespace: Assimp
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public static TTo As<TFrom, TTo>(
    ref TFrom src
)
where TFrom : struct, new()
where TTo : struct, new()

Parameters

src
Type: TFrom
Source by-ref value.

Type Parameters

TFrom
From struct type
TTo
To struct type

Return Value

Type: TTo
Reference as the from type.
See Also

Reference

MemoryHelper Class


MemoryHelper.AsPointer(T) Method

MemoryHelperAsPointerT Method

Casts the by-ref value into a pointer.

Namespace: Assimp
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public static IntPtr AsPointer<T>(
    ref T src
)
where T : struct, new()

Parameters

src
Type: T
By-ref value.

Type Parameters

T
Struct type.

Return Value

Type: IntPtr
Pointer to the value.
See Also

Reference

MemoryHelper Class


MemoryHelper.AsPointerReadonly(T) Method

MemoryHelperAsPointerReadonlyT Method

Casts the readonly by-ref value into a pointer.

Namespace: Assimp
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public static IntPtr AsPointerReadonly<T>(
    ref T src
)
where T : struct, new()

Parameters

src
Type: T
By-ref value.

Type Parameters

T
Struct type.

Return Value

Type: IntPtr
Pointer to the value.
See Also

Reference

MemoryHelper Class


MemoryHelper.AsReadonly(TFrom, TTo) Method

MemoryHelperAsReadonlyTFrom, TTo Method

Casts one readonly by-ref type to another, unsafely.

Namespace: Assimp
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public static TTo AsReadonly<TFrom, TTo>(
    ref TFrom src
)
where TFrom : struct, new()
where TTo : struct, new()

Parameters

src
Type: TFrom
Source by-ref value.

Type Parameters

TFrom
From struct type
TTo
To struct type

Return Value

Type: TTo InAttribute
Reference as the from type.
See Also

Reference

MemoryHelper Class


MemoryHelper.AsRef(T) Method

MemoryHelperAsRefT Method

Casts the pointer into a by-ref value of the specified type.

Namespace: Assimp
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public static T AsRef<T>(
    IntPtr pSrc
)
where T : struct, new()

Parameters

pSrc
Type: SystemIntPtr
Memory location.

Type Parameters

T
Struct type.

Return Value

Type: T
By-ref value.
See Also

Reference

MemoryHelper Class


MemoryHelper.CastToEnum(V, T) Method

MemoryHelperCastToEnumV, T Method

Casts an underlying value type to an enum type, WITHOUT first casting the value to an Object. So this avoid boxing the value.

Namespace: Assimp
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public static T CastToEnum<V, T>(
    V value
)
where V : struct, new(), Object
where T : Enum

Parameters

value
Type: V
Value to cast.

Type Parameters

V
Underlying value type.
T
Enum type.

Return Value

Type: T
Enum value.
See Also

Reference

MemoryHelper Class


MemoryHelper.ClearMemory Method

MemoryHelperClearMemory Method

Clears the memory to the specified value.

Namespace: Assimp
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public static void ClearMemory(
    IntPtr memoryPtr,
    byte clearValue,
    int sizeInBytesToClear
)

Parameters

memoryPtr
Type: SystemIntPtr
Pointer to the memory.
clearValue
Type: SystemByte
Value the memory will be cleared to.
sizeInBytesToClear
Type: SystemInt32
Number of bytes, starting from the memory pointer, to clear.
See Also

Reference

MemoryHelper Class


MemoryHelper.Compare Method

MemoryHelperCompare Method

Compares two arrays of bytes for equivalence.

Namespace: Assimp
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public static bool Compare(
    byte[] firstData,
    byte[] secondData
)

Parameters

firstData
Type: SystemByte
First array of data.
secondData
Type: SystemByte
Second array of data.

Return Value

Type: Boolean
True if both arrays contain the same data, false otherwise.
See Also

Reference

MemoryHelper Class


MemoryHelper.ComputeFNVModifiedHashCode Method

MemoryHelperComputeFNVModifiedHashCode Method

Computes a hash code using the FNV modified algorithmm.

Namespace: Assimp
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public static int ComputeFNVModifiedHashCode(
    byte[] data
)

Parameters

data
Type: SystemByte
Byte data to hash.

Return Value

Type: Int32
Hash code for the data.
See Also

Reference

MemoryHelper Class


MemoryHelper.CopyBytes Method

MemoryHelperCopyBytes Method

Overload List
Name | Description
CopyBytesT(Byte, Int32, T, Int32, Int32) | Copies bytes from a byte array to an element array.
CopyBytesT(T, Int32, Byte, Int32, Int32) | Copies bytes from an element array to a byte array.
Top
See Also

Reference

MemoryHelper Class


MemoryHelper.CopyBytes(T) Method (Byte[], Int32, T[], Int32, Int32)

MemoryHelperCopyBytesT Method (Byte, Int32, T, Int32, Int32)

Copies bytes from a byte array to an element array.

Namespace: Assimp
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public static void CopyBytes<T>(
    byte[] srcArray,
    int srcStartIndex,
    T[] destArray,
    int destStartIndex,
    int count
)
where T : struct, new()

Parameters

srcArray
Type: SystemByte
Source byte array
srcStartIndex
Type: SystemInt32
Starting index in destination array
destArray
Type: T
Destination element array
destStartIndex
Type: SystemInt32
Starting index in destination array
count
Type: SystemInt32
Number of elements to copy

Type Parameters

T
Struct type
See Also

Reference

MemoryHelper Class
CopyBytes Overload


MemoryHelper.CopyBytes(T) Method (T[], Int32, Byte[], Int32, Int32)

MemoryHelperCopyBytesT Method (T, Int32, Byte, Int32, Int32)

Copies bytes from an element array to a byte array.

Namespace: Assimp
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public static void CopyBytes<T>(
    T[] srcArray,
    int srcStartIndex,
    byte[] destArray,
    int destStartIndex,
    int count
)
where T : struct, new()

Parameters

srcArray
Type: T
Source element array
srcStartIndex
Type: SystemInt32
Starting index in source array
destArray
Type: SystemByte
Destination byte array
destStartIndex
Type: SystemInt32
Starting index in destination array
count
Type: SystemInt32
Number of elements to copy

Type Parameters

T
Struct type
See Also

Reference

MemoryHelper Class
CopyBytes Overload


MemoryHelper.CopyMemory Method

MemoryHelperCopyMemory Method

Performs a memcopy that copies data from the memory pointed to by the source pointer to the memory pointer by the destination pointer.

Namespace: Assimp
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public static void CopyMemory(
    IntPtr pDest,
    IntPtr pSrc,
    int sizeInBytesToCopy
)

Parameters

pDest
Type: SystemIntPtr
Destination memory location
pSrc
Type: SystemIntPtr
Source memory location
sizeInBytesToCopy
Type: SystemInt32
Number of bytes to copy
See Also

Reference

MemoryHelper Class


MemoryHelper.Count(T) Method

MemoryHelperCountT Method

Returns the number of elements in the enumerable.

Namespace: Assimp
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public static int Count<T>(
    IEnumerable<T> source
)

Parameters

source
Type: System.Collections.GenericIEnumerable T
Enumerable collection

Type Parameters

T
Type of element in collection.

Return Value

Type: Int32
The number of elements in the enumerable collection.
See Also

Reference

MemoryHelper Class


MemoryHelper.DisposeCollection(T) Method

MemoryHelperDisposeCollectionT Method

Convienence method to dispose all items in the collection

Namespace: Assimp
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public static void DisposeCollection<T>(
    ICollection<T> collection
)
where T : IDisposable

Parameters

collection
Type: System.Collections.GenericICollection T
Collection of disposables

Type Parameters

T
IDisposable type
See Also

Reference

MemoryHelper Class


MemoryHelper.FreeMemory Method

MemoryHelperFreeMemory Method

Frees unmanaged memory that was allocated by this helper.

Namespace: Assimp
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public static void FreeMemory(
    IntPtr memoryPtr
)

Parameters

memoryPtr
Type: SystemIntPtr
Pointer to unmanaged memory to free.
See Also

Reference

MemoryHelper Class


MemoryHelper.FreeNativeArray Method

MemoryHelperFreeNativeArray Method

Overload List
Name | Description
FreeNativeArrayT(IntPtr, Int32, FreeNativeDelegate) | Frees an unmanaged array and performs cleanup for each value. This can be used on any type that can be marshaled into unmanaged memory.
FreeNativeArrayT(IntPtr, Int32, FreeNativeDelegate, Boolean) | Frees an unmanaged array and performs cleanup for each value. Optionally can free an array of pointers. This can be used on any type that can be marshaled into unmanaged memory.
Top
See Also

Reference

MemoryHelper Class


MemoryHelper.FreeNativeArray(T) Method (IntPtr, Int32, FreeNativeDelegate)

MemoryHelperFreeNativeArrayT Method (IntPtr, Int32, FreeNativeDelegate)

Frees an unmanaged array and performs cleanup for each value. This can be used on any type that can be marshaled into unmanaged memory.

Namespace: Assimp
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public static void FreeNativeArray<T>(
    IntPtr nativeArray,
    int length,
    FreeNativeDelegate action
)
where T : struct, new()

Parameters

nativeArray
Type: SystemIntPtr
Pointer to unmanaged memory
length
Type: SystemInt32
Number of elements to free
action
Type: AssimpFreeNativeDelegate
Delegate that performs the necessary cleanup

Type Parameters

T
Struct type
See Also

Reference

MemoryHelper Class
FreeNativeArray Overload


MemoryHelper.FreeNativeArray(T) Method (IntPtr, Int32, FreeNativeDelegate, Boolean)

MemoryHelperFreeNativeArrayT Method (IntPtr, Int32, FreeNativeDelegate, Boolean)

Frees an unmanaged array and performs cleanup for each value. Optionally can free an array of pointers. This can be used on any type that can be marshaled into unmanaged memory.

Namespace: Assimp
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public static void FreeNativeArray<T>(
    IntPtr nativeArray,
    int length,
    FreeNativeDelegate action,
    bool arrayOfPointers
)
where T : struct, new()

Parameters

nativeArray
Type: SystemIntPtr
Pointer to unmanaged memory
length
Type: SystemInt32
Number of elements to free
action
Type: AssimpFreeNativeDelegate
Delegate that performs the necessary cleanup
arrayOfPointers
Type: SystemBoolean
True if the pointer is an array of pointers, false otherwise.

Type Parameters

T
Struct type
See Also

Reference

MemoryHelper Class
FreeNativeArray Overload


MemoryHelper.FromByteArray(T) Method

MemoryHelperFromByteArrayT Method

Converts a byte array to a typed element array.

Namespace: Assimp
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public static T[] FromByteArray<T>(
    byte[] source
)
where T : struct, new()

Parameters

source
Type: SystemByte
Byte array

Type Parameters

T
Struct type

Return Value

Type: T
Typed element array or null if the source array was not valid.
See Also

Reference

MemoryHelper Class


MemoryHelper.FromNativeArray Method

MemoryHelperFromNativeArray Method

Overload List
Name | Description
FromNativeArrayManaged, Native(IntPtr, Int32) | Marshals an array of managed values from a c-style unmanaged array (void*).
FromNativeArrayT(IntPtr, Int32) | Marshals an array of blittable structs from a c-style unmanaged array (void*). This should not be used on non-blittable types that require marshaling by the runtime (e.g. has MarshalAs attributes).
FromNativeArrayManaged, Native(IntPtr, Int32, Boolean) | Marshals an array of managed values from a c-style unmanaged array (void*). This also can optionally marshal from an unmanaged array of pointers (void**).
Top
See Also

Reference

MemoryHelper Class


MemoryHelper.FromNativeArray(Managed, Native) Method (IntPtr, Int32)

MemoryHelperFromNativeArrayManaged, Native Method (IntPtr, Int32)

Marshals an array of managed values from a c-style unmanaged array (void*).

Namespace: Assimp
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public static Managed[] FromNativeArray<Managed, Native>(
    IntPtr nativeArray,
    int length
)
where Managed : class, new(), Object, IMarshalable<Managed, Native>
where Native : struct, new()

Parameters

nativeArray
Type: SystemIntPtr
Pointer to unmanaged memory
length
Type: SystemInt32
Number of elements to marshal

Type Parameters

Managed
Managed type
Native
Native type

Return Value

Type: Managed
Marshaled managed values
See Also

Reference

MemoryHelper Class
FromNativeArray Overload


MemoryHelper.FromNativeArray(T) Method (IntPtr, Int32)

MemoryHelperFromNativeArrayT Method (IntPtr, Int32)

Marshals an array of blittable structs from a c-style unmanaged array (void*). This should not be used on non-blittable types that require marshaling by the runtime (e.g. has MarshalAs attributes).

Namespace: Assimp
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public static T[] FromNativeArray<T>(
    IntPtr nativeArray,
    int length
)
where T : struct, new()

Parameters

nativeArray
Type: SystemIntPtr
Pointer to unmanaged memory
length
Type: SystemInt32
Number of elements to read

Type Parameters

T
Struct type

Return Value

Type: T
Managed array
See Also

Reference

MemoryHelper Class
FromNativeArray Overload


MemoryHelper.FromNativeArray(Managed, Native) Method (IntPtr, Int32, Boolean)

MemoryHelperFromNativeArrayManaged, Native Method (IntPtr, Int32, Boolean)

Marshals an array of managed values from a c-style unmanaged array (void*). This also can optionally marshal from an unmanaged array of pointers (void**).

Namespace: Assimp
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public static Managed[] FromNativeArray<Managed, Native>(
    IntPtr nativeArray,
    int length,
    bool arrayOfPointers
)
where Managed : class, new(), Object, IMarshalable<Managed, Native>
where Native : struct, new()

Parameters

nativeArray
Type: SystemIntPtr
Pointer to unmanaged memory
length
Type: SystemInt32
Number of elements to marshal
arrayOfPointers
Type: SystemBoolean
True if the pointer is an array of pointers, false otherwise.

Type Parameters

Managed
Managed type
Native
Native type

Return Value

Type: Managed
Marshaled managed values
See Also

Reference

MemoryHelper Class
FromNativeArray Overload


MemoryHelper.FromNativePointer(Managed, Native) Method

MemoryHelperFromNativePointerManaged, Native Method

Marshals a managed value from unmanaged memory.

Namespace: Assimp
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public static Managed FromNativePointer<Managed, Native>(
    IntPtr ptr
)
where Managed : class, new(), Object, IMarshalable<Managed, Native>
where Native : struct, new()

Parameters

ptr
Type: SystemIntPtr
Pointer to unmanaged memory

Type Parameters

Managed
Managed type
Native
Unmanaged type

Return Value

Type: Managed
The marshaled managed value
See Also

Reference

MemoryHelper Class


MemoryHelper.IsMemoryAligned Method

MemoryHelperIsMemoryAligned Method

Checks if the memory is aligned to the specified alignment.

Namespace: Assimp
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public static bool IsMemoryAligned(
    IntPtr memoryPtr,
    int alignment = 16
)

Parameters

memoryPtr
Type: SystemIntPtr
Pointer to the memory
alignment (Optional)
Type: SystemInt32
Alignment value, by defauly 16-byte

Return Value

Type: Boolean
True if is aligned, false otherwise.
See Also

Reference

MemoryHelper Class


MemoryHelper.MarshalPointer(T) Method

MemoryHelperMarshalPointerT Method

Convienence method for marshaling a structure to a pointer. Only use if the type is not blittable, otherwise use the write methods for blittable types.

Namespace: Assimp
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public static void MarshalPointer<T>(
    ref T value,
    IntPtr ptr
)
where T : struct, new()

Parameters

value
Type: T
Struct to marshal
ptr
Type: SystemIntPtr
Pointer to unmanaged chunk of memory which must be allocated prior to this call

Type Parameters

T
Struct type
See Also

Reference

MemoryHelper Class


MemoryHelper.MarshalSizeOf Method

MemoryHelperMarshalSizeOf Method

Overload List
Name | Description
MarshalSizeOfT | Computes the size of the struct type using Marshal SizeOf. Only use if the type is not blittable, thus requiring marshaling by the runtime, (e.g. has MarshalAs attributes), otherwise use the SizeOf methods for blittable types.
MarshalSizeOfT(T) | Computes the size of the struct array using Marshal SizeOf. Only use if the type is not blittable, thus requiring marshaling by the runtime, (e.g. has MarshalAs attributes), otherwise use the SizeOf methods for blittable types.
Top
See Also

Reference

MemoryHelper Class


MemoryHelper.MarshalSizeOf(T) Method

MemoryHelperMarshalSizeOfT Method

Computes the size of the struct type using Marshal SizeOf. Only use if the type is not blittable, thus requiring marshaling by the runtime, (e.g. has MarshalAs attributes), otherwise use the SizeOf methods for blittable types.

Namespace: Assimp
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public static int MarshalSizeOf<T>()
where T : struct, new()

Type Parameters

T
Struct type

Return Value

Type: Int32
Size of the struct in bytes.
See Also

Reference

MemoryHelper Class
MarshalSizeOf Overload


MemoryHelper.MarshalSizeOf(T) Method (T[])

MemoryHelperMarshalSizeOfT Method (T)

Computes the size of the struct array using Marshal SizeOf. Only use if the type is not blittable, thus requiring marshaling by the runtime, (e.g. has MarshalAs attributes), otherwise use the SizeOf methods for blittable types.

Namespace: Assimp
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public static int MarshalSizeOf<T>(
    T[] array
)
where T : struct, new()

Parameters

array
Type: T
Array of structs

Type Parameters

T
Struct type

Return Value

Type: Int32
Total size, in bytes, of the array's contents.
See Also

Reference

MemoryHelper Class
MarshalSizeOf Overload


MemoryHelper.MarshalStructure Method

MemoryHelperMarshalStructure Method

Overload List
Name | Description
MarshalStructureT(IntPtr) | Convienence method for marshaling a pointer to a structure. Only use if the type is not blittable, otherwise use the read methods for blittable types.
MarshalStructureT(IntPtr, T) | Convienence method for marshaling a pointer to a structure. Only use if the type is not blittable, otherwise use the read methods for blittable types.
Top
See Also

Reference

MemoryHelper Class


MemoryHelper.MarshalStructure(T) Method (IntPtr)

MemoryHelperMarshalStructureT Method (IntPtr)

Convienence method for marshaling a pointer to a structure. Only use if the type is not blittable, otherwise use the read methods for blittable types.

Namespace: Assimp
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public static T MarshalStructure<T>(
    IntPtr ptr
)
where T : struct, new()

Parameters

ptr
Type: SystemIntPtr
Pointer to marshal

Type Parameters

T
Struct type

Return Value

Type: T
The marshaled structure
See Also

Reference

MemoryHelper Class
MarshalStructure Overload


MemoryHelper.MarshalStructure(T) Method (IntPtr, T)

MemoryHelperMarshalStructureT Method (IntPtr, T)

Convienence method for marshaling a pointer to a structure. Only use if the type is not blittable, otherwise use the read methods for blittable types.

Namespace: Assimp
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public static void MarshalStructure<T>(
    IntPtr ptr,
    out T value
)
where T : struct, new()

Parameters

ptr
Type: SystemIntPtr
Pointer to marshal
value
Type: T
The marshaled structure

Type Parameters

T
Struct type
See Also

Reference

MemoryHelper Class
MarshalStructure Overload


MemoryHelper.PinObject Method

MemoryHelperPinObject Method

Pins an object in memory, which allows a pointer to it to be returned. While the object remains pinned the runtime cannot move the object around in memory, which may degrade performance.

Namespace: Assimp
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public static IntPtr PinObject(
    Object obj
)

Parameters

obj
Type: SystemObject
Object to pin.

Return Value

Type: IntPtr
Pointer to pinned object's memory location.
See Also

Reference

MemoryHelper Class


MemoryHelper.Read Method

MemoryHelperRead Method

Overload List
Name | Description
ReadT(IntPtr) | Reads a single element from the memory location.
ReadT(IntPtr, T) | Reads a single element from the memory location.
ReadT(IntPtr, T, Int32, Int32) | Reads data from the memory location into the array.
Top
See Also

Reference

MemoryHelper Class


MemoryHelper.Read(T) Method (IntPtr)

MemoryHelperReadT Method (IntPtr)

Reads a single element from the memory location.

Namespace: Assimp
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public static T Read<T>(
    IntPtr pSrc
)
where T : struct, new()

Parameters

pSrc
Type: SystemIntPtr
Pointer to memory location

Type Parameters

T
Struct type

Return Value

Type: T
The read value
See Also

Reference

MemoryHelper Class
Read Overload


MemoryHelper.Read(T) Method (IntPtr, T)

MemoryHelperReadT Method (IntPtr, T)

Reads a single element from the memory location.

Namespace: Assimp
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public static void Read<T>(
    IntPtr pSrc,
    out T value
)
where T : struct, new()

Parameters

pSrc
Type: SystemIntPtr
Pointer to memory location
value
Type: T
The read value.

Type Parameters

T
Struct type
See Also

Reference

MemoryHelper Class
Read Overload


MemoryHelper.Read(T) Method (IntPtr, T[], Int32, Int32)

MemoryHelperReadT Method (IntPtr, T, Int32, Int32)

Reads data from the memory location into the array.

Namespace: Assimp
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public static void Read<T>(
    IntPtr pSrc,
    T[] data,
    int startIndexInArray,
    int count
)
where T : struct, new()

Parameters

pSrc
Type: SystemIntPtr
Pointer to memory location
data
Type: T
Array to store the copied data
startIndexInArray
Type: SystemInt32
Zero-based element index to start writing data to in the element array.
count
Type: SystemInt32
Number of elements to copy

Type Parameters

T
Struct type
See Also

Reference

MemoryHelper Class
Read Overload


MemoryHelper.ReadStreamFully Method

MemoryHelperReadStreamFully Method

Reads a stream until the end is reached into a byte array. Based on Jon Skeet's implementation. It is up to the caller to dispose of the stream.

Namespace: Assimp
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public static byte[] ReadStreamFully(
    Stream stream,
    int initialLength
)

Parameters

stream
Type: System.IOStream
Stream to read all bytes from
initialLength
Type: SystemInt32
Initial buffer length, default is 32K

Return Value

Type: Byte
The byte array containing all the bytes from the stream
See Also

Reference

MemoryHelper Class


MemoryHelper.SizeOf Method

MemoryHelperSizeOf Method

Overload List
Name | Description
SizeOfT | Computes the size of the struct type.
SizeOfT(T) | Computes the size of the struct array.
Top
See Also

Reference

MemoryHelper Class


MemoryHelper.SizeOf(T) Method

MemoryHelperSizeOfT Method

Computes the size of the struct type.

Namespace: Assimp
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public static int SizeOf<T>()
where T : struct, new()

Type Parameters

T
Struct type

Return Value

Type: Int32
Size of the struct in bytes.
See Also

Reference

MemoryHelper Class
SizeOf Overload


MemoryHelper.SizeOf(T) Method (T[])

MemoryHelperSizeOfT Method (T)

Computes the size of the struct array.

Namespace: Assimp
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public static int SizeOf<T>(
    T[] array
)
where T : struct, new()

Parameters

array
Type: T
Array of structs

Type Parameters

T
Struct type

Return Value

Type: Int32
Total size, in bytes, of the array's contents.
See Also

Reference

MemoryHelper Class
SizeOf Overload


MemoryHelper.Swap(T) Method

MemoryHelperSwapT Method

Swaps the value between two references.

Namespace: Assimp
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public static void Swap<T>(
    ref T left,
    ref T right
)

Parameters

left
Type: T
First reference
right
Type: T
Second reference

Type Parameters

T
Type of data to swap.
See Also

Reference

MemoryHelper Class


MemoryHelper.ToByteArray(T) Method

MemoryHelperToByteArrayT Method

Converts typed element array to a byte array.

Namespace: Assimp
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public static byte[] ToByteArray<T>(
    T[] source
)
where T : struct, new()

Parameters

source
Type: T
Element array

Type Parameters

T
Struct type

Return Value

Type: Byte
Byte array copy or null if the source array was not valid.
See Also

Reference

MemoryHelper Class


MemoryHelper.ToNativeArray Method

MemoryHelperToNativeArray Method

Overload List
Name | Description
ToNativeArrayManaged, Native(Managed) | Marshals an array of managed values to a c-style unmanaged array (void*).
ToNativeArrayT(T) | Marshals an array of blittable structs to a c-style unmanaged array (void*). This should not be used on non-blittable types that require marshaling by the runtime (e.g. has MarshalAs attributes).
ToNativeArrayManaged, Native(Managed, Boolean) | Marshals an array of managed values to a c-style unmanaged array (void*). This also can optionally marshal to an unmanaged array of pointers (void**).
Top
See Also

Reference

MemoryHelper Class


MemoryHelper.ToNativeArray(Managed, Native) Method (Managed[])

MemoryHelperToNativeArrayManaged, Native Method (Managed)

Marshals an array of managed values to a c-style unmanaged array (void*).

Namespace: Assimp
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public static IntPtr ToNativeArray<Managed, Native>(
    Managed[] managedArray
)
where Managed : class, new(), Object, IMarshalable<Managed, Native>
where Native : struct, new()

Parameters

managedArray
Type: Managed
Array of managed values

Type Parameters

Managed
Managed type
Native
Native type

Return Value

Type: IntPtr
Pointer to unmanaged memory
See Also

Reference

MemoryHelper Class
ToNativeArray Overload


MemoryHelper.ToNativeArray(T) Method (T[])

MemoryHelperToNativeArrayT Method (T)

Marshals an array of blittable structs to a c-style unmanaged array (void*). This should not be used on non-blittable types that require marshaling by the runtime (e.g. has MarshalAs attributes).

Namespace: Assimp
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public static IntPtr ToNativeArray<T>(
    T[] managedArray
)
where T : struct, new()

Parameters

managedArray
Type: T
Managed array of structs

Type Parameters

T
Struct type

Return Value

Type: IntPtr
Pointer to unmanaged memory
See Also

Reference

MemoryHelper Class
ToNativeArray Overload


MemoryHelper.ToNativeArray(Managed, Native) Method (Managed[], Boolean)

MemoryHelperToNativeArrayManaged, Native Method (Managed, Boolean)

Marshals an array of managed values to a c-style unmanaged array (void*). This also can optionally marshal to an unmanaged array of pointers (void**).

Namespace: Assimp
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public static IntPtr ToNativeArray<Managed, Native>(
    Managed[] managedArray,
    bool arrayOfPointers
)
where Managed : class, new(), Object, IMarshalable<Managed, Native>
where Native : struct, new()

Parameters

managedArray
Type: Managed
Array of managed values
arrayOfPointers
Type: SystemBoolean
True if the pointer is an array of pointers, false otherwise.

Type Parameters

Managed
Managed type
Native
Native type

Return Value

Type: IntPtr
Pointer to unmanaged memory
See Also

Reference

MemoryHelper Class
ToNativeArray Overload


MemoryHelper.ToNativePointer(Managed, Native) Method

MemoryHelperToNativePointerManaged, Native Method

Marshals a managed value to unmanaged memory.

Namespace: Assimp
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public static IntPtr ToNativePointer<Managed, Native>(
    Managed managedValue
)
where Managed : class, new(), Object, IMarshalable<Managed, Native>
where Native : struct, new()

Parameters

managedValue
Type: Managed
Managed value to marshal

Type Parameters

Managed
Managed type
Native
Unmanaged type

Return Value

Type: IntPtr
Pointer to unmanaged memory
See Also

Reference

MemoryHelper Class


MemoryHelper.UnpinObject Method

MemoryHelperUnpinObject Method

Unpins an object in memory, allowing it to once again freely be moved around by the runtime.

Namespace: Assimp
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public static void UnpinObject(
    Object obj
)

Parameters

obj
Type: SystemObject
Object to unpin.
See Also

Reference

MemoryHelper Class


MemoryHelper.Write Method

MemoryHelperWrite Method

Overload List
Name | Description
WriteT(IntPtr, T) | Writes a single element to the memory location.
WriteT(IntPtr, T, Int32, Int32) | Writes data from the array to the memory location.
Top
See Also

Reference

MemoryHelper Class


MemoryHelper.Write(T) Method (IntPtr, T)

MemoryHelperWriteT Method (IntPtr, T)

Writes a single element to the memory location.

Namespace: Assimp
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public static void Write<T>(
    IntPtr pDest,
    ref T data
)
where T : struct, new()

Parameters

pDest
Type: SystemIntPtr
Pointer to memory location
data
Type: T
The value to write

Type Parameters

T
Struct type
See Also

Reference

MemoryHelper Class
Write Overload


MemoryHelper.Write(T) Method (IntPtr, T[], Int32, Int32)

MemoryHelperWriteT Method (IntPtr, T, Int32, Int32)

Writes data from the array to the memory location.

Namespace: Assimp
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public static void Write<T>(
    IntPtr pDest,
    T[] data,
    int startIndexInArray,
    int count
)
where T : struct, new()

Parameters

pDest
Type: SystemIntPtr
Pointer to memory location
data
Type: T
Array containing data to write
startIndexInArray
Type: SystemInt32
Zero-based element index to start reading data from in the element array.
count
Type: SystemInt32
Number of elements to copy

Type Parameters

T
Struct type
See Also

Reference

MemoryHelper Class
Write Overload


Mesh Class

A mesh represents geometry with a single material.
Inheritance Hierarchy
SystemObject
AssimpMesh

Namespace: Assimp
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public sealed class Mesh : IMarshalable<Mesh, AiMesh>

The Mesh type exposes the following members.

Constructors
 | Name | Description
Public method | Mesh | Constructs a new instance of the Mesh class.
Public method | Mesh(String) | Constructs a new instance of the Mesh class.
Public method | Mesh(PrimitiveType) | Constructs a new instance of the Mesh class.
Public method | Mesh(String, PrimitiveType) | Constructs a new instance of the Mesh class.
Top
Properties
 | Name | Description
Public property | BiTangents | Gets the vertex bitangent list.
Public property | BoneCount | Gets the number of bones that influence this mesh.
Public property | Bones | Gets the bones that influence this mesh.
Public property | FaceCount | Gets the number of faces contained in the mesh.
Public property | Faces | Gets the mesh's faces. Each face will contain indices to the vertices.
Public property | HasBones | Gets if this mesh has bones.
Public property | HasFaces | Gets if the mesh contains faces. If no special scene flags are set, this should always return true.
Public property | HasMeshAnimationAttachments | Gets if this mesh has mesh animation attachments.
Public property | HasNormals | Gets if the mesh as normals. If it does exist, the count should be the same as the vertex count.
Public property | HasTangentBasis | Gets if the mesh has tangents and bitangents. It is not possible for one to be without the other. If it does exist, the count should be the same as the vertex count.
Public property | HasVertices | Gets if the mesh has a vertex array. This should always return true provided no special scene flags are set.
Public property | MaterialIndex | Gets or sets the index of the material associated with this mesh.
Public property | MeshAnimationAttachmentCount | Gets the number of mesh animation attachments that influence this mesh.
Public property | MeshAnimationAttachments | Gets the mesh animation attachments that influence this mesh.
Public property | MorphMethod | Gets or sets the morph method used when animation attachments are used.
Public property | Name | Gets or sets the mesh name. This tends to be used when formats name nodes and meshes independently, vertex animations refer to meshes by their names, or importers split meshes up, each mesh will reference the same (dummy) name.
Public property | Normals | Gets the vertex normal list.
Public property | PrimitiveType | Gets or sets the primitive type. This may contain more than one type unless if SortByPrimitiveType option is not set.
Public property | Tangents | Gets the vertex tangent list.
Public property | TextureCoordinateChannelCount | Gets the number of valid texture coordinate channels contained in the mesh (list is not empty/not null). This can be a value between zero and the maximum texture coordinate count. Each individual channel should be the size of VertexCount.
Public property | TextureCoordinateChannels | Gets the array that contains each texture coordinate channel, by default all are lists of zero (but can be set to null). Each index in the array corresponds to the texture coordinate channel. The length of the array corresponds to Assimp's maximum UV channel limit.
Public property | UVComponentCount | Gets the array that contains the count of UV(W) components for each texture coordinate channel, usually 2 (UV) or 3 (UVW). A component value of zero means the texture coordinate channel does not exist. The channel index (index in the array) corresponds to the texture coordinate channel index.
Public property | VertexColorChannelCount | Gets the number of valid vertex color channels contained in the mesh (list is not empty/not null). This can be a value between zero and the maximum vertex color count. Each individual channel should be the size of VertexCount.
Public property | VertexColorChannels | Gets the array that contains each vertex color channels, by default all are lists of zero (but can be set to null). Each index in the array corresponds to the texture coordinate channel. The length of the array corresponds to Assimp's maximum vertex color channel limit.
Public property | VertexCount | Gets the number of vertices in this mesh. This is the count that all per-vertex lists should be the size of.
Public property | Vertices | Gets the vertex position list.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
 | FreeNative | Frees unmanaged memory created by ToNative(IntPtr, Native).
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetIndices | Convienence method for accumulating all face indices into a single index array.
Public method | GetShortIndices | Convienence method for accumulating all face indices into a single index array.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetUnsignedIndices | Convienence method for accumulating all face indices into a single index array as unsigned integers (the default from Assimp, if you need them).
Public method | HasTextureCoords | Checks if the mesh has texture coordinates for the specified channel. This returns false if the list is null or empty. The channel, if it exists, should contain the same number of entries as VertexCount.
Public method | HasVertexColors | Checks if the mesh has vertex colors for the specified channel. This returns false if the list is null or empty. The channel, if it exists, should contain the same number of entries as VertexCount.
Public method | SetIndices | Convienence method for setting this meshe's face list from an index buffer.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference


Mesh Constructor

Overload List
 | Name | Description
Public method | Mesh | Constructs a new instance of the Mesh class.
Public method | Mesh(String) | Constructs a new instance of the Mesh class.
Public method | Mesh(PrimitiveType) | Constructs a new instance of the Mesh class.
Public method | Mesh(String, PrimitiveType) | Constructs a new instance of the Mesh class.
Top
See Also

Reference

Mesh Class


Mesh Constructor

Constructs a new instance of the Mesh class.

Namespace: Assimp
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public Mesh()
See Also

Reference

Mesh Class
Mesh Overload


Mesh Constructor (String)

Constructs a new instance of the Mesh class.

Namespace: Assimp
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public Mesh(
    string name
)

Parameters

name
Type: SystemString
Name of the mesh.
See Also

Reference

Mesh Class
Mesh Overload


Mesh Constructor (PrimitiveType)

Constructs a new instance of the Mesh class.

Namespace: Assimp
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public Mesh(
    PrimitiveType primType
)

Parameters

primType
Type: AssimpPrimitiveType
Primitive types contained in the mesh.
See Also

Reference

Mesh Class
Mesh Overload


Mesh Constructor (String, PrimitiveType)

Constructs a new instance of the Mesh class.

Namespace: Assimp
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public Mesh(
    string name,
    PrimitiveType primType
)

Parameters

name
Type: SystemString
Name of the mesh
primType
Type: AssimpPrimitiveType
Primitive types contained in the mesh.
See Also

Reference

Mesh Class
Mesh Overload


Mesh Properties

The Mesh type exposes the following members.

Properties
 | Name | Description
Public property | BiTangents | Gets the vertex bitangent list.
Public property | BoneCount | Gets the number of bones that influence this mesh.
Public property | Bones | Gets the bones that influence this mesh.
Public property | FaceCount | Gets the number of faces contained in the mesh.
Public property | Faces | Gets the mesh's faces. Each face will contain indices to the vertices.
Public property | HasBones | Gets if this mesh has bones.
Public property | HasFaces | Gets if the mesh contains faces. If no special scene flags are set, this should always return true.
Public property | HasMeshAnimationAttachments | Gets if this mesh has mesh animation attachments.
Public property | HasNormals | Gets if the mesh as normals. If it does exist, the count should be the same as the vertex count.
Public property | HasTangentBasis | Gets if the mesh has tangents and bitangents. It is not possible for one to be without the other. If it does exist, the count should be the same as the vertex count.
Public property | HasVertices | Gets if the mesh has a vertex array. This should always return true provided no special scene flags are set.
Public property | MaterialIndex | Gets or sets the index of the material associated with this mesh.
Public property | MeshAnimationAttachmentCount | Gets the number of mesh animation attachments that influence this mesh.
Public property | MeshAnimationAttachments | Gets the mesh animation attachments that influence this mesh.
Public property | MorphMethod | Gets or sets the morph method used when animation attachments are used.
Public property | Name | Gets or sets the mesh name. This tends to be used when formats name nodes and meshes independently, vertex animations refer to meshes by their names, or importers split meshes up, each mesh will reference the same (dummy) name.
Public property | Normals | Gets the vertex normal list.
Public property | PrimitiveType | Gets or sets the primitive type. This may contain more than one type unless if SortByPrimitiveType option is not set.
Public property | Tangents | Gets the vertex tangent list.
Public property | TextureCoordinateChannelCount | Gets the number of valid texture coordinate channels contained in the mesh (list is not empty/not null). This can be a value between zero and the maximum texture coordinate count. Each individual channel should be the size of VertexCount.
Public property | TextureCoordinateChannels | Gets the array that contains each texture coordinate channel, by default all are lists of zero (but can be set to null). Each index in the array corresponds to the texture coordinate channel. The length of the array corresponds to Assimp's maximum UV channel limit.
Public property | UVComponentCount | Gets the array that contains the count of UV(W) components for each texture coordinate channel, usually 2 (UV) or 3 (UVW). A component value of zero means the texture coordinate channel does not exist. The channel index (index in the array) corresponds to the texture coordinate channel index.
Public property | VertexColorChannelCount | Gets the number of valid vertex color channels contained in the mesh (list is not empty/not null). This can be a value between zero and the maximum vertex color count. Each individual channel should be the size of VertexCount.
Public property | VertexColorChannels | Gets the array that contains each vertex color channels, by default all are lists of zero (but can be set to null). Each index in the array corresponds to the texture coordinate channel. The length of the array corresponds to Assimp's maximum vertex color channel limit.
Public property | VertexCount | Gets the number of vertices in this mesh. This is the count that all per-vertex lists should be the size of.
Public property | Vertices | Gets the vertex position list.
Top
See Also

Reference

Mesh Class


Mesh.BiTangents Property

MeshBiTangents Property

Gets the vertex bitangent list.

Namespace: Assimp
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public List BiTangents { get; }

Property Value

Type: ListT
See Also

Reference

Mesh Class


Mesh.BoneCount Property

MeshBoneCount Property

Gets the number of bones that influence this mesh.

Namespace: Assimp
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public int BoneCount { get; }

Property Value

Type: Int32
See Also

Reference

Mesh Class


Mesh.Bones Property

MeshBones Property

Gets the bones that influence this mesh.

Namespace: Assimp
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public List Bones { get; }

Property Value

Type: ListT
See Also

Reference

Mesh Class


Mesh.FaceCount Property

MeshFaceCount Property

Gets the number of faces contained in the mesh.

Namespace: Assimp
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public int FaceCount { get; }

Property Value

Type: Int32
See Also

Reference

Mesh Class


Mesh.Faces Property

MeshFaces Property

Gets the mesh's faces. Each face will contain indices to the vertices.

Namespace: Assimp
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public List Faces { get; }

Property Value

Type: ListT
See Also

Reference

Mesh Class


Mesh.HasBones Property

MeshHasBones Property

Gets if this mesh has bones.

Namespace: Assimp
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public bool HasBones { get; }

Property Value

Type: Boolean
See Also

Reference

Mesh Class


Mesh.HasFaces Property

MeshHasFaces Property

Gets if the mesh contains faces. If no special scene flags are set, this should always return true.

Namespace: Assimp
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public bool HasFaces { get; }

Property Value

Type: Boolean
See Also

Reference

Mesh Class


Mesh.HasMeshAnimationAttachments Property

MeshHasMeshAnimationAttachments Property

Gets if this mesh has mesh animation attachments.

Namespace: Assimp
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public bool HasMeshAnimationAttachments { get; }

Property Value

Type: Boolean
See Also

Reference

Mesh Class


Mesh.HasNormals Property

MeshHasNormals Property

Gets if the mesh as normals. If it does exist, the count should be the same as the vertex count.

Namespace: Assimp
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public bool HasNormals { get; }

Property Value

Type: Boolean
See Also

Reference

Mesh Class


Mesh.HasTangentBasis Property

MeshHasTangentBasis Property

Gets if the mesh has tangents and bitangents. It is not possible for one to be without the other. If it does exist, the count should be the same as the vertex count.

Namespace: Assimp
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public bool HasTangentBasis { get; }

Property Value

Type: Boolean
See Also

Reference

Mesh Class


Mesh.HasVertices Property

MeshHasVertices Property

Gets if the mesh has a vertex array. This should always return true provided no special scene flags are set.

Namespace: Assimp
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public bool HasVertices { get; }

Property Value

Type: Boolean
See Also

Reference

Mesh Class


Mesh.MaterialIndex Property

MeshMaterialIndex Property

Gets or sets the index of the material associated with this mesh.

Namespace: Assimp
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public int MaterialIndex { get; set; }

Property Value

Type: Int32
See Also

Reference

Mesh Class


Mesh.MeshAnimationAttachmentCount Property

MeshMeshAnimationAttachmentCount Property

Gets the number of mesh animation attachments that influence this mesh.

Namespace: Assimp
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public int MeshAnimationAttachmentCount { get; }

Property Value

Type: Int32
See Also

Reference

Mesh Class


Mesh.MeshAnimationAttachments Property

MeshMeshAnimationAttachments Property

Gets the mesh animation attachments that influence this mesh.

Namespace: Assimp
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public List MeshAnimationAttachments { get; }

Property Value

Type: ListT
See Also

Reference

Mesh Class


Mesh.MorphMethod Property

MeshMorphMethod Property

Gets or sets the morph method used when animation attachments are used.

Namespace: Assimp
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public MeshMorphingMethod MorphMethod { get; set; }

Property Value

Type: MeshMorphingMethod
See Also

Reference

Mesh Class


Mesh.Name Property

MeshName Property

Gets or sets the mesh name. This tends to be used when formats name nodes and meshes independently, vertex animations refer to meshes by their names, or importers split meshes up, each mesh will reference the same (dummy) name.

Namespace: Assimp
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public string Name { get; set; }

Property Value

Type: String
See Also

Reference

Mesh Class


Mesh.Normals Property

MeshNormals Property

Gets the vertex normal list.

Namespace: Assimp
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public List Normals { get; }

Property Value

Type: ListT
See Also

Reference

Mesh Class


Mesh.PrimitiveType Property

MeshPrimitiveType Property

Gets or sets the primitive type. This may contain more than one type unless if SortByPrimitiveType option is not set.

Namespace: Assimp
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public PrimitiveType PrimitiveType { get; set; }

Property Value

Type: PrimitiveType
See Also

Reference

Mesh Class


Mesh.Tangents Property

MeshTangents Property

Gets the vertex tangent list.

Namespace: Assimp
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public List Tangents { get; }

Property Value

Type: ListT
See Also

Reference

Mesh Class


Mesh.TextureCoordinateChannelCount Property

MeshTextureCoordinateChannelCount Property

Gets the number of valid texture coordinate channels contained in the mesh (list is not empty/not null). This can be a value between zero and the maximum texture coordinate count. Each individual channel should be the size of VertexCount.

Namespace: Assimp
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public int TextureCoordinateChannelCount { get; }

Property Value

Type: Int32
See Also

Reference

Mesh Class


Mesh.TextureCoordinateChannels Property

MeshTextureCoordinateChannels Property

Gets the array that contains each texture coordinate channel, by default all are lists of zero (but can be set to null). Each index in the array corresponds to the texture coordinate channel. The length of the array corresponds to Assimp's maximum UV channel limit.

Namespace: Assimp
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public List[] TextureCoordinateChannels { get; }

Property Value

Type: ListT
See Also

Reference

Mesh Class


Mesh.UVComponentCount Property

MeshUVComponentCount Property

Gets the array that contains the count of UV(W) components for each texture coordinate channel, usually 2 (UV) or 3 (UVW). A component value of zero means the texture coordinate channel does not exist. The channel index (index in the array) corresponds to the texture coordinate channel index.

Namespace: Assimp
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public int[] UVComponentCount { get; }

Property Value

Type: Int32
See Also

Reference

Mesh Class


Mesh.VertexColorChannelCount Property

MeshVertexColorChannelCount Property

Gets the number of valid vertex color channels contained in the mesh (list is not empty/not null). This can be a value between zero and the maximum vertex color count. Each individual channel should be the size of VertexCount.

Namespace: Assimp
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public int VertexColorChannelCount { get; }

Property Value

Type: Int32
See Also

Reference

Mesh Class


Mesh.VertexColorChannels Property

MeshVertexColorChannels Property

Gets the array that contains each vertex color channels, by default all are lists of zero (but can be set to null). Each index in the array corresponds to the texture coordinate channel. The length of the array corresponds to Assimp's maximum vertex color channel limit.

Namespace: Assimp
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public List[] VertexColorChannels { get; }

Property Value

Type: ListT
See Also

Reference

Mesh Class


Mesh.VertexCount Property

MeshVertexCount Property

Gets the number of vertices in this mesh. This is the count that all per-vertex lists should be the size of.

Namespace: Assimp
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public int VertexCount { get; }

Property Value

Type: Int32
See Also

Reference

Mesh Class


Mesh.Vertices Property

MeshVertices Property

Gets the vertex position list.

Namespace: Assimp
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public List Vertices { get; }

Property Value

Type: ListT
See Also

Reference

Mesh Class


Mesh Methods

The Mesh type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
 | FreeNative | Frees unmanaged memory created by ToNative(IntPtr, Native).
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetIndices | Convienence method for accumulating all face indices into a single index array.
Public method | GetShortIndices | Convienence method for accumulating all face indices into a single index array.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetUnsignedIndices | Convienence method for accumulating all face indices into a single index array as unsigned integers (the default from Assimp, if you need them).
Public method | HasTextureCoords | Checks if the mesh has texture coordinates for the specified channel. This returns false if the list is null or empty. The channel, if it exists, should contain the same number of entries as VertexCount.
Public method | HasVertexColors | Checks if the mesh has vertex colors for the specified channel. This returns false if the list is null or empty. The channel, if it exists, should contain the same number of entries as VertexCount.
Public method | SetIndices | Convienence method for setting this meshe's face list from an index buffer.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Mesh Class


Mesh.FreeNative Method

MeshFreeNative Method

Frees unmanaged memory created by ToNative(IntPtr, Native).

Namespace: Assimp
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public static void FreeNative(
    IntPtr nativeValue,
    bool freeNative
)

Parameters

nativeValue
Type: SystemIntPtr
Native value to free
freeNative
Type: SystemBoolean
True if the unmanaged memory should be freed, false otherwise.
See Also

Reference

Mesh Class


Mesh.GetIndices Method

MeshGetIndices Method

Convienence method for accumulating all face indices into a single index array.

Namespace: Assimp
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public int[] GetIndices()

Return Value

Type: Int32
int index array
See Also

Reference

Mesh Class


Mesh.GetShortIndices Method

MeshGetShortIndices Method

Convienence method for accumulating all face indices into a single index array.

Namespace: Assimp
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public short[] GetShortIndices()

Return Value

Type: Int16
short index array
See Also

Reference

Mesh Class


Mesh.GetUnsignedIndices Method

MeshGetUnsignedIndices Method

Convienence method for accumulating all face indices into a single index array as unsigned integers (the default from Assimp, if you need them).

Namespace: Assimp
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public uint[] GetUnsignedIndices()

Return Value

Type: UInt32
uint index array
See Also

Reference

Mesh Class


Mesh.HasTextureCoords Method

MeshHasTextureCoords Method

Checks if the mesh has texture coordinates for the specified channel. This returns false if the list is null or empty. The channel, if it exists, should contain the same number of entries as VertexCount.

Namespace: Assimp
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public bool HasTextureCoords(
    int channelIndex
)

Parameters

channelIndex
Type: SystemInt32
Channel index

Return Value

Type: Boolean
True if texture coordinates are present in the channel.
See Also

Reference

Mesh Class


Mesh.HasVertexColors Method

MeshHasVertexColors Method

Checks if the mesh has vertex colors for the specified channel. This returns false if the list is null or empty. The channel, if it exists, should contain the same number of entries as VertexCount.

Namespace: Assimp
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public bool HasVertexColors(
    int channelIndex
)

Parameters

channelIndex
Type: SystemInt32
Channel index

Return Value

Type: Boolean
True if vertex colors are present in the channel.
See Also

Reference

Mesh Class


Mesh.SetIndices Method

MeshSetIndices Method

Convienence method for setting this meshe's face list from an index buffer.

Namespace: Assimp
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public bool SetIndices(
    int[] indices,
    int indicesPerFace
)

Parameters

indices
Type: SystemInt32
Index buffer
indicesPerFace
Type: SystemInt32
Indices per face

Return Value

Type: Boolean
True if the operation succeeded, false otherwise (e.g. not enough data)
See Also

Reference

Mesh Class


MeshAnimationAttachment Class

A mesh attachment store per-vertex animations for a particular frame. You may think of this as a 'patch' for the host mesh, since the mesh attachment replaces only certain vertex data streams at a particular time. Each mesh stores 'n' attached meshes. The actual relationship between the time line and mesh attachments is established by the mesh animation channel, which references singular mesh attachments by their ID and binds them to a time offset.
Inheritance Hierarchy
SystemObject
AssimpMeshAnimationAttachment

Namespace: Assimp
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public sealed class MeshAnimationAttachment : IMarshalable<MeshAnimationAttachment, AiAnimMesh>

The MeshAnimationAttachment type exposes the following members.

Constructors
 | Name | Description
Public method | MeshAnimationAttachment | Constructs a new instance of the MeshAnimationAttachment class.
Top
Properties
 | Name | Description
Public property | BiTangents | Gets the vertex bitangent list.
Public property | HasNormals | Checks whether the attachment mesh overrides the vertex normals of its host mesh.
Public property | HasTangentBasis | Checks whether the attachment mesh overrides the vertex tangents and bitangents of its host mesh.
Public property | HasVertices | Checks whether the attachment mesh overrides the vertex positions of its host mesh.
Public property | Normals | Gets the vertex normal list.
Public property | Tangents | Gets the vertex tangent list.
Public property | TextureCoordinateChannelCount | Gets the number of valid texture coordinate channels contained in the mesh (list is not empty/not null). This can be a value between zero and the maximum texture coordinate count. Each individual channel should be the size of VertexCount.
Public property | TextureCoordinateChannels | Gets the array that contains each texture coordinate channel that override a specific channel in the host mesh, by default all are lists of zero (but can be set to null). Each index in the array corresponds to the texture coordinate channel. The length of the array corresponds to Assimp's maximum UV channel limit.
Public property | VertexColorChannelCount | Gets the number of valid vertex color channels contained in the mesh (list is not empty/not null). This can be a value between zero and the maximum vertex color count. Each individual channel should be the size of VertexCount.
Public property | VertexColorChannels | Gets the array that contains each vertex color channels that override a specific channel in the host mesh, by default all are lists of zero (but can be set to null). Each index in the array corresponds to the texture coordinate channel. The length of the array corresponds to Assimp's maximum vertex color channel limit.
Public property | VertexCount | Gets the number of vertices in this mesh. This is a replacement for the host mesh's vertex count. Likewise, a mesh attachment cannot add or remove per-vertex attributes, therefore the existance of vertex data will match the existance of data in the mesh.
Public property | Vertices | Gets the vertex position list.
Public property | Weight | Gets or sets the weight of the mesh animation.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
 | FreeNative | Frees unmanaged memory created by ToNative(IntPtr, Native).
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | HasTextureCoords | Checks if the mesh attachment overrides a particular set of texture coordinates on the host mesh. This returns false if the list is null or empty. The index is between zero and the maximum number of texture coordinate channels.
Public method | HasVertexColors | Checks if the mesh attachment overrides a particular set of vertex colors on the host mesh. This returns false if the list is null or empty. The index is between zero and the maximumb number of vertex color channels.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference


MeshAnimationAttachment Constructor

Constructs a new instance of the MeshAnimationAttachment class.

Namespace: Assimp
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public MeshAnimationAttachment()
See Also

Reference

MeshAnimationAttachment Class


MeshAnimationAttachment Properties

The MeshAnimationAttachment type exposes the following members.

Properties
 | Name | Description
Public property | BiTangents | Gets the vertex bitangent list.
Public property | HasNormals | Checks whether the attachment mesh overrides the vertex normals of its host mesh.
Public property | HasTangentBasis | Checks whether the attachment mesh overrides the vertex tangents and bitangents of its host mesh.
Public property | HasVertices | Checks whether the attachment mesh overrides the vertex positions of its host mesh.
Public property | Normals | Gets the vertex normal list.
Public property | Tangents | Gets the vertex tangent list.
Public property | TextureCoordinateChannelCount | Gets the number of valid texture coordinate channels contained in the mesh (list is not empty/not null). This can be a value between zero and the maximum texture coordinate count. Each individual channel should be the size of VertexCount.
Public property | TextureCoordinateChannels | Gets the array that contains each texture coordinate channel that override a specific channel in the host mesh, by default all are lists of zero (but can be set to null). Each index in the array corresponds to the texture coordinate channel. The length of the array corresponds to Assimp's maximum UV channel limit.
Public property | VertexColorChannelCount | Gets the number of valid vertex color channels contained in the mesh (list is not empty/not null). This can be a value between zero and the maximum vertex color count. Each individual channel should be the size of VertexCount.
Public property | VertexColorChannels | Gets the array that contains each vertex color channels that override a specific channel in the host mesh, by default all are lists of zero (but can be set to null). Each index in the array corresponds to the texture coordinate channel. The length of the array corresponds to Assimp's maximum vertex color channel limit.
Public property | VertexCount | Gets the number of vertices in this mesh. This is a replacement for the host mesh's vertex count. Likewise, a mesh attachment cannot add or remove per-vertex attributes, therefore the existance of vertex data will match the existance of data in the mesh.
Public property | Vertices | Gets the vertex position list.
Public property | Weight | Gets or sets the weight of the mesh animation.
Top
See Also

Reference

MeshAnimationAttachment Class


MeshAnimationAttachment.BiTangents Property

MeshAnimationAttachmentBiTangents Property

Gets the vertex bitangent list.

Namespace: Assimp
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public List BiTangents { get; }

Property Value

Type: ListT
See Also

Reference

MeshAnimationAttachment Class


MeshAnimationAttachment.HasNormals Property

MeshAnimationAttachmentHasNormals Property

Checks whether the attachment mesh overrides the vertex normals of its host mesh.

Namespace: Assimp
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public bool HasNormals { get; }

Property Value

Type: Boolean
See Also

Reference

MeshAnimationAttachment Class


MeshAnimationAttachment.HasTangentBasis Property

MeshAnimationAttachmentHasTangentBasis Property

Checks whether the attachment mesh overrides the vertex tangents and bitangents of its host mesh.

Namespace: Assimp
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public bool HasTangentBasis { get; }

Property Value

Type: Boolean
See Also

Reference

MeshAnimationAttachment Class


MeshAnimationAttachment.HasVertices Property

MeshAnimationAttachmentHasVertices Property

Checks whether the attachment mesh overrides the vertex positions of its host mesh.

Namespace: Assimp
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public bool HasVertices { get; }

Property Value

Type: Boolean
See Also

Reference

MeshAnimationAttachment Class


MeshAnimationAttachment.Normals Property

MeshAnimationAttachmentNormals Property

Gets the vertex normal list.

Namespace: Assimp
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public List Normals { get; }

Property Value

Type: ListT
See Also

Reference

MeshAnimationAttachment Class


MeshAnimationAttachment.Tangents Property

MeshAnimationAttachmentTangents Property

Gets the vertex tangent list.

Namespace: Assimp
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public List Tangents { get; }

Property Value

Type: ListT
See Also

Reference

MeshAnimationAttachment Class


MeshAnimationAttachment.TextureCoordinateChannelCount Property

MeshAnimationAttachmentTextureCoordinateChannelCount Property

Gets the number of valid texture coordinate channels contained in the mesh (list is not empty/not null). This can be a value between zero and the maximum texture coordinate count. Each individual channel should be the size of VertexCount.

Namespace: Assimp
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public int TextureCoordinateChannelCount { get; }

Property Value

Type: Int32
See Also

Reference

MeshAnimationAttachment Class


MeshAnimationAttachment.TextureCoordinateChannels Property

MeshAnimationAttachmentTextureCoordinateChannels Property

Gets the array that contains each texture coordinate channel that override a specific channel in the host mesh, by default all are lists of zero (but can be set to null). Each index in the array corresponds to the texture coordinate channel. The length of the array corresponds to Assimp's maximum UV channel limit.

Namespace: Assimp
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public List[] TextureCoordinateChannels { get; }

Property Value

Type: ListT
See Also

Reference

MeshAnimationAttachment Class


MeshAnimationAttachment.VertexColorChannelCount Property

MeshAnimationAttachmentVertexColorChannelCount Property

Gets the number of valid vertex color channels contained in the mesh (list is not empty/not null). This can be a value between zero and the maximum vertex color count. Each individual channel should be the size of VertexCount.

Namespace: Assimp
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public int VertexColorChannelCount { get; }

Property Value

Type: Int32
See Also

Reference

MeshAnimationAttachment Class


MeshAnimationAttachment.VertexColorChannels Property

MeshAnimationAttachmentVertexColorChannels Property

Gets the array that contains each vertex color channels that override a specific channel in the host mesh, by default all are lists of zero (but can be set to null). Each index in the array corresponds to the texture coordinate channel. The length of the array corresponds to Assimp's maximum vertex color channel limit.

Namespace: Assimp
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public List[] VertexColorChannels { get; }

Property Value

Type: ListT
See Also

Reference

MeshAnimationAttachment Class


MeshAnimationAttachment.VertexCount Property

MeshAnimationAttachmentVertexCount Property

Gets the number of vertices in this mesh. This is a replacement for the host mesh's vertex count. Likewise, a mesh attachment cannot add or remove per-vertex attributes, therefore the existance of vertex data will match the existance of data in the mesh.

Namespace: Assimp
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public int VertexCount { get; }

Property Value

Type: Int32
See Also

Reference

MeshAnimationAttachment Class


MeshAnimationAttachment.Vertices Property

MeshAnimationAttachmentVertices Property

Gets the vertex position list.

Namespace: Assimp
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public List Vertices { get; }

Property Value

Type: ListT
See Also

Reference

MeshAnimationAttachment Class


MeshAnimationAttachment.Weight Property

MeshAnimationAttachmentWeight Property

Gets or sets the weight of the mesh animation.

Namespace: Assimp
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public float Weight { get; set; }

Property Value

Type: Single
See Also

Reference

MeshAnimationAttachment Class


MeshAnimationAttachment Methods

The MeshAnimationAttachment type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
 | FreeNative | Frees unmanaged memory created by ToNative(IntPtr, Native).
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | HasTextureCoords | Checks if the mesh attachment overrides a particular set of texture coordinates on the host mesh. This returns false if the list is null or empty. The index is between zero and the maximum number of texture coordinate channels.
Public method | HasVertexColors | Checks if the mesh attachment overrides a particular set of vertex colors on the host mesh. This returns false if the list is null or empty. The index is between zero and the maximumb number of vertex color channels.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

MeshAnimationAttachment Class


MeshAnimationAttachment.FreeNative Method

MeshAnimationAttachmentFreeNative Method

Frees unmanaged memory created by ToNative(IntPtr, Native).

Namespace: Assimp
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public static void FreeNative(
    IntPtr nativeValue,
    bool freeNative
)

Parameters

nativeValue
Type: SystemIntPtr
Native value to free
freeNative
Type: SystemBoolean
True if the unmanaged memory should be freed, false otherwise.
See Also

Reference

MeshAnimationAttachment Class


MeshAnimationAttachment.HasTextureCoords Method

MeshAnimationAttachmentHasTextureCoords Method

Checks if the mesh attachment overrides a particular set of texture coordinates on the host mesh. This returns false if the list is null or empty. The index is between zero and the maximum number of texture coordinate channels.

Namespace: Assimp
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public bool HasTextureCoords(
    int channelIndex
)

Parameters

channelIndex
Type: SystemInt32
Channel index

Return Value

Type: Boolean
True if texture coordinates are present in the channel.
See Also

Reference

MeshAnimationAttachment Class


MeshAnimationAttachment.HasVertexColors Method

MeshAnimationAttachmentHasVertexColors Method

Checks if the mesh attachment overrides a particular set of vertex colors on the host mesh. This returns false if the list is null or empty. The index is between zero and the maximumb number of vertex color channels.

Namespace: Assimp
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public bool HasVertexColors(
    int channelIndex
)

Parameters

channelIndex
Type: SystemInt32
Channel index

Return Value

Type: Boolean
True if vertex colors are present in the channel.
See Also

Reference

MeshAnimationAttachment Class


MeshAnimationChannel Class

Describes vertex-based animations for a single mesh or a group of meshes. Meshes carry the animation data for each frame. The purpose of this object is to define keyframes, linking each mesh attachment to a particular point in a time.
Inheritance Hierarchy
SystemObject
AssimpMeshAnimationChannel

Namespace: Assimp
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public sealed class MeshAnimationChannel : IMarshalable<MeshAnimationChannel, AiMeshAnim>

The MeshAnimationChannel type exposes the following members.

Constructors
 | Name | Description
Public method | MeshAnimationChannel | Constructs a new instance of the MeshAnimationChannel class.
Top
Properties
 | Name | Description
Public property | HasMeshKeys | Gets if this animation channel has mesh keys - this should always be true.
Public property | MeshKeyCount | Gets the number of meshkeys in this animation channel. There will always be at least one key.
Public property | MeshKeys | Gets the mesh keyframes of the animation. This should not be null.
Public property | MeshName | Gets or sets the name of the mesh to be animated. Empty strings are not allowed, animation meshes need to be named (not necessarily uniquely, the name can basically serve as a wildcard to select a group of meshes with similar animation setup).
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
 | FreeNative | Frees unmanaged memory created by ToNative(IntPtr, Native).
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference


MeshAnimationChannel Constructor

Constructs a new instance of the MeshAnimationChannel class.

Namespace: Assimp
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public MeshAnimationChannel()
See Also

Reference

MeshAnimationChannel Class


MeshAnimationChannel Properties

The MeshAnimationChannel type exposes the following members.

Properties
 | Name | Description
Public property | HasMeshKeys | Gets if this animation channel has mesh keys - this should always be true.
Public property | MeshKeyCount | Gets the number of meshkeys in this animation channel. There will always be at least one key.
Public property | MeshKeys | Gets the mesh keyframes of the animation. This should not be null.
Public property | MeshName | Gets or sets the name of the mesh to be animated. Empty strings are not allowed, animation meshes need to be named (not necessarily uniquely, the name can basically serve as a wildcard to select a group of meshes with similar animation setup).
Top
See Also

Reference

MeshAnimationChannel Class


MeshAnimationChannel.HasMeshKeys Property

MeshAnimationChannelHasMeshKeys Property

Gets if this animation channel has mesh keys - this should always be true.

Namespace: Assimp
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public bool HasMeshKeys { get; }

Property Value

Type: Boolean
See Also

Reference

MeshAnimationChannel Class


MeshAnimationChannel.MeshKeyCount Property

MeshAnimationChannelMeshKeyCount Property

Gets the number of meshkeys in this animation channel. There will always be at least one key.

Namespace: Assimp
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public int MeshKeyCount { get; }

Property Value

Type: Int32
See Also

Reference

MeshAnimationChannel Class


MeshAnimationChannel.MeshKeys Property

MeshAnimationChannelMeshKeys Property

Gets the mesh keyframes of the animation. This should not be null.

Namespace: Assimp
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public List MeshKeys { get; }

Property Value

Type: ListT
See Also

Reference

MeshAnimationChannel Class


MeshAnimationChannel.MeshName Property

MeshAnimationChannelMeshName Property

Gets or sets the name of the mesh to be animated. Empty strings are not allowed, animation meshes need to be named (not necessarily uniquely, the name can basically serve as a wildcard to select a group of meshes with similar animation setup).

Namespace: Assimp
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public string MeshName { get; set; }

Property Value

Type: String
See Also

Reference

MeshAnimationChannel Class


MeshAnimationChannel Methods

The MeshAnimationChannel type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
 | FreeNative | Frees unmanaged memory created by ToNative(IntPtr, Native).
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

MeshAnimationChannel Class


MeshAnimationChannel.FreeNative Method

MeshAnimationChannelFreeNative Method

Frees unmanaged memory created by ToNative(IntPtr, Native).

Namespace: Assimp
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public static void FreeNative(
    IntPtr nativeValue,
    bool freeNative
)

Parameters

nativeValue
Type: SystemIntPtr
Native value to free
freeNative
Type: SystemBoolean
True if the unmanaged memory should be freed, false otherwise.
See Also

Reference

MeshAnimationChannel Class


MeshKey Structure

Binds an anim mesh (referenced by an index) to a specific point in time.

Namespace: Assimp
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public struct MeshKey : IEquatable<MeshKey>

The MeshKey type exposes the following members.

Constructors
 | Name | Description
Public method | MeshKey | Constructs a new MeshKey.
Top
Methods
 | Name | Description
Public method | Equals(Object) | Determines whether the specified Object is equal to this instance. (Overrides ValueTypeEquals(Object).)
Public method | Equals(MeshKey) | Tests equality between this key and another.
Public method | GetHashCode | Returns a hash code for this instance. (Overrides ValueTypeGetHashCode.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents this instance. (Overrides ValueTypeToString.)
Top
Operators
Name | Description
Equality | Tests equality between two keys.
GreaterThan | Tests inequality between two keys.
Inequality | Tests inequality between two keys.
LessThan | Tests inequality between two keys.
Top
Fields
 | Name | Description
Public field | Time | The time of this key.
Public field | Value | Index of the anim mesh that corresponds to this keyframe.
Top
See Also

Reference


MeshKey Constructor

Constructs a new MeshKey.

Namespace: Assimp
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public MeshKey(
    double time,
    int index
)

Parameters

time
Type: SystemDouble
The time of this key.
index
Type: SystemInt32
Index of the anim mesh that corresponds to this keyframe.
See Also

Reference

MeshKey Structure


MeshKey Methods

The MeshKey type exposes the following members.

Methods
 | Name | Description
Public method | Equals(Object) | Determines whether the specified Object is equal to this instance. (Overrides ValueTypeEquals(Object).)
Public method | Equals(MeshKey) | Tests equality between this key and another.
Public method | GetHashCode | Returns a hash code for this instance. (Overrides ValueTypeGetHashCode.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents this instance. (Overrides ValueTypeToString.)
Top
See Also

Reference

MeshKey Structure


MeshKey.Equals Method

MeshKeyEquals Method

Overload List
 | Name | Description
Public method | Equals(Object) | Determines whether the specified Object is equal to this instance. (Overrides ValueTypeEquals(Object).)
Public method | Equals(MeshKey) | Tests equality between this key and another.
Top
See Also

Reference

MeshKey Structure


MeshKey.Equals Method (Object)

MeshKeyEquals Method (Object)

Determines whether the specified Object is equal to this instance.

Namespace: Assimp
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public override bool Equals(
    Object obj
)

Parameters

obj
Type: SystemObject
The Object to compare with this instance.

Return Value

Type: Boolean
true if the specified Object is equal to this instance; otherwise, false.
See Also

Reference

MeshKey Structure
Equals Overload


MeshKey.Equals Method (MeshKey)

MeshKeyEquals Method (MeshKey)

Tests equality between this key and another.

Namespace: Assimp
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public bool Equals(
    MeshKey key
)

Parameters

key
Type: AssimpMeshKey
Other key to test

Return Value

Type: Boolean
True if their indices are equal

Implements

IEquatableTEquals(T)
See Also

Reference

MeshKey Structure
Equals Overload


MeshKey.GetHashCode Method

MeshKeyGetHashCode Method

Returns a hash code for this instance.

Namespace: Assimp
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public override int GetHashCode()

Return Value

Type: Int32
A hash code for this instance, suitable for use in hashing algorithms and data structures like a hash table.
See Also

Reference

MeshKey Structure


MeshKey.ToString Method

MeshKeyToString Method

Returns a String that represents this instance.

Namespace: Assimp
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public override string ToString()

Return Value

Type: String
A String that represents this instance.
See Also

Reference

MeshKey Structure


MeshKey Operators

The MeshKey type exposes the following members.

Operators
Name | Description
Equality | Tests equality between two keys.
GreaterThan | Tests inequality between two keys.
Inequality | Tests inequality between two keys.
LessThan | Tests inequality between two keys.
Top
See Also

Reference

MeshKey Structure


MeshKey.Equality Operator

MeshKeyEquality Operator

Tests equality between two keys.

Namespace: Assimp
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public static bool operator ==(
    MeshKey a,
    MeshKey b
)

Parameters

a
Type: AssimpMeshKey
The first key
b
Type: AssimpMeshKey
The second key

Return Value

Type: Boolean
True if the key's indices are the same, false otherwise
See Also

Reference

MeshKey Structure


MeshKey.GreaterThan Operator

MeshKeyGreaterThan Operator

Tests inequality between two keys.

Namespace: Assimp
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public static bool operator >(
    MeshKey a,
    MeshKey b
)

Parameters

a
Type: AssimpMeshKey
The first key
b
Type: AssimpMeshKey
The second key

Return Value

Type: Boolean
True if the first key's time is greater than the second key's.
See Also

Reference

MeshKey Structure


MeshKey.Inequality Operator

MeshKeyInequality Operator

Tests inequality between two keys.

Namespace: Assimp
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public static bool operator !=(
    MeshKey a,
    MeshKey b
)

Parameters

a
Type: AssimpMeshKey
The first key
b
Type: AssimpMeshKey
The second key

Return Value

Type: Boolean
True if the key's indices are not equal, false otherwise.
See Also

Reference

MeshKey Structure


MeshKey.LessThan Operator

MeshKeyLessThan Operator

Tests inequality between two keys.

Namespace: Assimp
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public static bool operator <(
    MeshKey a,
    MeshKey b
)

Parameters

a
Type: AssimpMeshKey
The first key
b
Type: AssimpMeshKey
The second key

Return Value

Type: Boolean
True if the first key's time is less than the second key's.
See Also

Reference

MeshKey Structure


MeshKey Fields

The MeshKey type exposes the following members.

Fields
 | Name | Description
Public field | Time | The time of this key.
Public field | Value | Index of the anim mesh that corresponds to this keyframe.
Top
See Also

Reference

MeshKey Structure


MeshKey.Time Field

MeshKeyTime Field

The time of this key.

Namespace: Assimp
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public double Time

Field Value

Type: Double
See Also

Reference

MeshKey Structure


MeshKey.Value Field

MeshKeyValue Field

Index of the anim mesh that corresponds to this keyframe.

Namespace: Assimp
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public int Value

Field Value

Type: Int32
See Also

Reference

MeshKey Structure


MeshMorphAnimationChannel Class

Describes morph-based keyframe animations for a single mesh or a group of meshes.
Inheritance Hierarchy
SystemObject
AssimpMeshMorphAnimationChannel

Namespace: Assimp
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public sealed class MeshMorphAnimationChannel : IMarshalable<MeshMorphAnimationChannel, AiMeshMorphAnim>

The MeshMorphAnimationChannel type exposes the following members.

Constructors
 | Name | Description
Public method | MeshMorphAnimationChannel | Constructs a new instance of the MeshMorphAnimationChannel class.
Top
Properties
 | Name | Description
Public property | HasMeshMorphKeys | Gets if this animation channel has mesh keys - this should always be true.
Public property | MeshMorphKeyCount | Gets the number of mesh morph keys in this animation channel. There will always be at least one key.
Public property | MeshMorphKeys | Gets the mesh morph keyframes of the animation. This should not be null.
Public property | Name | Gets or sets the name of the mesh to be animated. Empty strings are not allowed, animation meshes need to be named (not necessarily uniquely, the name can basically serve as a wildcard to select a group of meshes with similar animation setup).
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
 | FreeNative | Frees unmanaged memory created by ToNative(IntPtr, Native).
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference


MeshMorphAnimationChannel Constructor

Constructs a new instance of the MeshMorphAnimationChannel class.

Namespace: Assimp
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public MeshMorphAnimationChannel()
See Also

Reference

MeshMorphAnimationChannel Class


MeshMorphAnimationChannel Properties

The MeshMorphAnimationChannel type exposes the following members.

Properties
 | Name | Description
Public property | HasMeshMorphKeys | Gets if this animation channel has mesh keys - this should always be true.
Public property | MeshMorphKeyCount | Gets the number of mesh morph keys in this animation channel. There will always be at least one key.
Public property | MeshMorphKeys | Gets the mesh morph keyframes of the animation. This should not be null.
Public property | Name | Gets or sets the name of the mesh to be animated. Empty strings are not allowed, animation meshes need to be named (not necessarily uniquely, the name can basically serve as a wildcard to select a group of meshes with similar animation setup).
Top
See Also

Reference

MeshMorphAnimationChannel Class


MeshMorphAnimationChannel.HasMeshMorphKeys Property

MeshMorphAnimationChannelHasMeshMorphKeys Property

Gets if this animation channel has mesh keys - this should always be true.

Namespace: Assimp
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public bool HasMeshMorphKeys { get; }

Property Value

Type: Boolean
See Also

Reference

MeshMorphAnimationChannel Class


MeshMorphAnimationChannel.MeshMorphKeyCount Property

MeshMorphAnimationChannelMeshMorphKeyCount Property

Gets the number of mesh morph keys in this animation channel. There will always be at least one key.

Namespace: Assimp
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public int MeshMorphKeyCount { get; }

Property Value

Type: Int32
See Also

Reference

MeshMorphAnimationChannel Class


MeshMorphAnimationChannel.MeshMorphKeys Property

MeshMorphAnimationChannelMeshMorphKeys Property

Gets the mesh morph keyframes of the animation. This should not be null.

Namespace: Assimp
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public List MeshMorphKeys { get; }

Property Value

Type: ListT
See Also

Reference

MeshMorphAnimationChannel Class


MeshMorphAnimationChannel.Name Property

MeshMorphAnimationChannelName Property

Gets or sets the name of the mesh to be animated. Empty strings are not allowed, animation meshes need to be named (not necessarily uniquely, the name can basically serve as a wildcard to select a group of meshes with similar animation setup).

Namespace: Assimp
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public string Name { get; set; }

Property Value

Type: String
See Also

Reference

MeshMorphAnimationChannel Class


MeshMorphAnimationChannel Methods

The MeshMorphAnimationChannel type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
 | FreeNative | Frees unmanaged memory created by ToNative(IntPtr, Native).
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

MeshMorphAnimationChannel Class


MeshMorphAnimationChannel.FreeNative Method

MeshMorphAnimationChannelFreeNative Method

Frees unmanaged memory created by ToNative(IntPtr, Native).

Namespace: Assimp
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public static void FreeNative(
    IntPtr nativeValue,
    bool freeNative
)

Parameters

nativeValue
Type: SystemIntPtr
Native value to free
freeNative
Type: SystemBoolean
True if the unmanaged memory should be freed, false otherwise.
See Also

Reference

MeshMorphAnimationChannel Class


MeshMorphingMethod Enumeration

Defines the methods of mesh morphing supported.

Namespace: Assimp
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public enum MeshMorphingMethod
Members
Member name | Value | Description
None | 0 | No morphing.
VertexBlend | 1 | Interpolation between morph targets.
MorphNormalized | 2 | Normalized morphing between morph targets.
MorphRelative | 3 | Relative morphing between morph targets.
See Also

Reference


MeshMorphKey Class

Binds a morph animation mesh to a specific point in time.
Inheritance Hierarchy
SystemObject
AssimpMeshMorphKey

Namespace: Assimp
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public sealed class MeshMorphKey : IMarshalable<MeshMorphKey, AiMeshMorphKey>

The MeshMorphKey type exposes the following members.

Constructors
 | Name | Description
Public method | MeshMorphKey | Constructs a new instance of the MeshMorphKey class.
Top
Properties
 | Name | Description
Public property | Time | Gets or sets the time of this keyframe.
Public property | Values | Gets the values at the time of this keyframe. Number of values must equal number of weights.
Public property | Weights | Gets the weights at the time of this keyframe. Number of weights must equal number of values.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
 | FreeNative | Frees unmanaged memory created by ToNative(IntPtr, Native).
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference


MeshMorphKey Constructor

Constructs a new instance of the MeshMorphKey class.

Namespace: Assimp
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public MeshMorphKey()
See Also

Reference

MeshMorphKey Class


MeshMorphKey Properties

The MeshMorphKey type exposes the following members.

Properties
 | Name | Description
Public property | Time | Gets or sets the time of this keyframe.
Public property | Values | Gets the values at the time of this keyframe. Number of values must equal number of weights.
Public property | Weights | Gets the weights at the time of this keyframe. Number of weights must equal number of values.
Top
See Also

Reference

MeshMorphKey Class


MeshMorphKey.Time Property

MeshMorphKeyTime Property

Gets or sets the time of this keyframe.

Namespace: Assimp
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public double Time { get; set; }

Property Value

Type: Double
See Also

Reference

MeshMorphKey Class


MeshMorphKey.Values Property

MeshMorphKeyValues Property

Gets the values at the time of this keyframe. Number of values must equal number of weights.

Namespace: Assimp
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public List Values { get; }

Property Value

Type: ListT
See Also

Reference

MeshMorphKey Class


MeshMorphKey.Weights Property

MeshMorphKeyWeights Property

Gets the weights at the time of this keyframe. Number of weights must equal number of values.

Namespace: Assimp
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public List Weights { get; }

Property Value

Type: ListT
See Also

Reference

MeshMorphKey Class


MeshMorphKey Methods

The MeshMorphKey type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
 | FreeNative | Frees unmanaged memory created by ToNative(IntPtr, Native).
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

MeshMorphKey Class


MeshMorphKey.FreeNative Method

MeshMorphKeyFreeNative Method

Frees unmanaged memory created by ToNative(IntPtr, Native).

Namespace: Assimp
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public static void FreeNative(
    IntPtr nativeValue,
    bool freeNative
)

Parameters

nativeValue
Type: SystemIntPtr
Native value to free
freeNative
Type: SystemBoolean
True if the unmanaged memory should be freed, false otherwise.
See Also

Reference

MeshMorphKey Class


Metadata Class

Represents a container for holding metadata, representing as key-value pairs.
Inheritance Hierarchy
System.Collections.GenericDictionaryTKey, TValue
AssimpMetadata

Namespace: Assimp
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public sealed class Metadata : Dictionary,
    IMarshalable<Metadata, AiMetadata>

The Metadata type exposes the following members.

Constructors
 | Name | Description
Public method | Metadata | Constructs a new instance of the Metadata class.
Top
Methods
Name | Description
FreeNative | Frees unmanaged memory created by ToNative(IntPtr, Native).
Top
See Also

Reference


Metadata Constructor

Constructs a new instance of the Metadata class.

Namespace: Assimp
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public Metadata()
See Also

Reference

Metadata Class


Metadata Methods

The Metadata type exposes the following members.

Methods
Name | Description
FreeNative | Frees unmanaged memory created by ToNative(IntPtr, Native).
Top
See Also

Reference

Metadata Class


Metadata.FreeNative Method

MetadataFreeNative Method

Frees unmanaged memory created by ToNative(IntPtr, Native).

Namespace: Assimp
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public static void FreeNative(
    IntPtr nativeValue,
    bool freeNative
)

Parameters

nativeValue
Type: SystemIntPtr
Native value to free
freeNative
Type: SystemBoolean
True if the unmanaged memory should be freed, false otherwise.
See Also

Reference

Metadata Class


Metadata.Entry Structure

MetadataEntry Structure

Represents an entry in a metadata container.

Namespace: Assimp
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public struct Entry : IEquatable<MetadataEntry>

The MetadataEntry type exposes the following members.

Constructors
 | Name | Description
Public method | MetadataEntry | Constructs a new instance of the MetadataEntry struct.
Top
Properties
 | Name | Description
Public property | Data | Gets the metadata data stored in this entry.
Public property | DataType | Gets the type of metadata.
Top
Methods
 | Name | Description
Public method | DataAsT | Gets the data as the specified type. If it cannot be casted to the type, then null is returned.
Public method | Equals(Object) | Determines whether the specified Object is equal to this instance. (Overrides ValueTypeEquals(Object).)
Public method | Equals(MetadataEntry) | Indicates whether the current object is equal to another object of the same type.
Public method | GetHashCode | Returns a hash code for this instance. (Overrides ValueTypeGetHashCode.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns the fully qualified type name of this instance. (Overrides ValueTypeToString.)
Top
Operators
Name | Description
Equality | Tests equality between two entries.
Inequality | Tests inequality between two entries.
Top
See Also

Reference


Metadata.Entry Constructor

MetadataEntry Constructor

Constructs a new instance of the MetadataEntry struct.

Namespace: Assimp
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public Entry(
    MetaDataType dataType,
    Object data
)

Parameters

dataType
Type: AssimpMetaDataType
Type of the data.
data
Type: SystemObject
The data.
See Also

Reference

MetadataEntry Structure


Entry Properties

The MetadataEntry type exposes the following members.

Properties
 | Name | Description
Public property | Data | Gets the metadata data stored in this entry.
Public property | DataType | Gets the type of metadata.
Top
See Also

Reference

MetadataEntry Structure


Metadata.Entry.Data Property

MetadataEntryData Property

Gets the metadata data stored in this entry.

Namespace: Assimp
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public Object Data { get; }

Property Value

Type: Object
See Also

Reference

MetadataEntry Structure


Metadata.Entry.DataType Property

MetadataEntryDataType Property

Gets the type of metadata.

Namespace: Assimp
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public MetaDataType DataType { get; }

Property Value

Type: MetaDataType
See Also

Reference

MetadataEntry Structure


Entry Methods

The MetadataEntry type exposes the following members.

Methods
 | Name | Description
Public method | DataAsT | Gets the data as the specified type. If it cannot be casted to the type, then null is returned.
Public method | Equals(Object) | Determines whether the specified Object is equal to this instance. (Overrides ValueTypeEquals(Object).)
Public method | Equals(MetadataEntry) | Indicates whether the current object is equal to another object of the same type.
Public method | GetHashCode | Returns a hash code for this instance. (Overrides ValueTypeGetHashCode.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns the fully qualified type name of this instance. (Overrides ValueTypeToString.)
Top
See Also

Reference

MetadataEntry Structure


Metadata.Entry.DataAs(T) Method

MetadataEntryDataAsT Method

Gets the data as the specified type. If it cannot be casted to the type, then null is returned.

Namespace: Assimp
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public Nullable<T> DataAs<T>()
where T : struct, new()

Type Parameters

T
Type to cast the data to.

Return Value

Type: Nullable T
Casted data or null.
See Also

Reference

MetadataEntry Structure


Entry.Equals Method

EntryEquals Method

Overload List
 | Name | Description
Public method | Equals(Object) | Determines whether the specified Object is equal to this instance. (Overrides ValueTypeEquals(Object).)
Public method | Equals(MetadataEntry) | Indicates whether the current object is equal to another object of the same type.
Top
See Also

Reference

MetadataEntry Structure


Metadata.Entry.Equals Method (Object)

MetadataEntryEquals Method (Object)

Determines whether the specified Object is equal to this instance.

Namespace: Assimp
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public override bool Equals(
    Object obj
)

Parameters

obj
Type: SystemObject
The Object to compare with this instance.

Return Value

Type: Boolean
True if the specified Object is equal to this instance; otherwise, false.
See Also

Reference

MetadataEntry Structure
Equals Overload


Metadata.Entry.Equals Method (Metadata.Entry)

MetadataEntryEquals Method (MetadataEntry)

Indicates whether the current object is equal to another object of the same type.

Namespace: Assimp
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public bool Equals(
    MetadataEntry other
)

Parameters

other
Type: AssimpMetadataEntry
An object to compare with this object.

Return Value

Type: Boolean
True if the current object is equal to the other parameter; otherwise, false.

Implements

IEquatableTEquals(T)
See Also

Reference

MetadataEntry Structure
Equals Overload


Metadata.Entry.GetHashCode Method

MetadataEntryGetHashCode Method

Returns a hash code for this instance.

Namespace: Assimp
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public override int GetHashCode()

Return Value

Type: Int32
A hash code for this instance, suitable for use in hashing algorithms and data structures like a hash table.
See Also

Reference

MetadataEntry Structure


Metadata.Entry.ToString Method

MetadataEntryToString Method

Returns the fully qualified type name of this instance.

Namespace: Assimp
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public override string ToString()

Return Value

Type: String
A String containing a fully qualified type name.
See Also

Reference

MetadataEntry Structure


Entry Operators

The MetadataEntry type exposes the following members.

Operators
Name | Description
Equality | Tests equality between two entries.
Inequality | Tests inequality between two entries.
Top
See Also

Reference

MetadataEntry Structure


Metadata.Entry.Equality Operator

MetadataEntryEquality Operator

Tests equality between two entries.

Namespace: Assimp
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public static bool operator ==(
    MetadataEntry a,
    MetadataEntry b
)

Parameters

a
Type: AssimpMetadataEntry
First entry
b
Type: AssimpMetadataEntry
Second entry

Return Value

Type: Boolean
True if the entries are equal, false otherwise
See Also

Reference

MetadataEntry Structure


Metadata.Entry.Inequality Operator

MetadataEntryInequality Operator

Tests inequality between two entries.

Namespace: Assimp
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public static bool operator !=(
    MetadataEntry a,
    MetadataEntry b
)

Parameters

a
Type: AssimpMetadataEntry
First entry
b
Type: AssimpMetadataEntry
Second entry

Return Value

Type: Boolean
True if the entries are not equal, false otherwise
See Also

Reference

MetadataEntry Structure


MetaDataType Enumeration

Enumerates metadata data types.

Namespace: Assimp
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public enum MetaDataType
Members
Member name | Value | Description
Bool | 0 | Metadata is a boolean.
Int32 | 1 | Metadata is an integer.
UInt64 | 2 | Metadata is an unsigned 64-bit integer.
Float | 3 | Metadata is a float.
Double | 4 | Metadata is a double.
String | 5 | Metadata is a string.
Vector3D | 6 | Metadata is a Vector3D.
See Also

Reference


NativeCustomMarshalerAttribute Class

Attribute for assocating a type with an INativeCustomMarshaler instance.
Inheritance Hierarchy
SystemObject
SystemAttribute
AssimpNativeCustomMarshalerAttribute

Namespace: Assimp
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public sealed class NativeCustomMarshalerAttribute : Attribute

The NativeCustomMarshalerAttribute type exposes the following members.

Constructors
 | Name | Description
Public method | NativeCustomMarshalerAttribute | Constructs a new instance of the NativeCustomMarshalerAttribute class.
Top
Properties
 | Name | Description
Public property | Marshaler | Gets the associated marshaler.
Public property | TypeId | When implemented in a derived class, gets a unique identifier for this Attribute. (Inherited from Attribute.)
Top
Methods
 | Name | Description
Public method | Equals | Returns a value that indicates whether this instance is equal to a specified object. (Inherited from Attribute.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from Attribute.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsDefaultAttribute | When overridden in a derived class, indicates whether the value of this instance is the default value for the derived class. (Inherited from Attribute.)
Public method | Match | When overridden in a derived class, returns a value that indicates whether this instance equals a specified object. (Inherited from Attribute.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference


NativeCustomMarshalerAttribute Constructor

Constructs a new instance of the NativeCustomMarshalerAttribute class.

Namespace: Assimp
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public NativeCustomMarshalerAttribute(
    Type type
)

Parameters

type
Type: SystemType
Type that implements INativeCustomMarshaler
Exceptions
Exception | Condition
NullReferenceException | Thrown if the type is null.
ArgumentException | Thrown if the type does not implement INativeCustomMarshaler.
See Also

Reference

NativeCustomMarshalerAttribute Class


NativeCustomMarshalerAttribute Properties

The NativeCustomMarshalerAttribute type exposes the following members.

Properties
 | Name | Description
Public property | Marshaler | Gets the associated marshaler.
Public property | TypeId | When implemented in a derived class, gets a unique identifier for this Attribute. (Inherited from Attribute.)
Top
See Also

Reference

NativeCustomMarshalerAttribute Class


NativeCustomMarshalerAttribute.Marshaler Property

NativeCustomMarshalerAttributeMarshaler Property

Gets the associated marshaler.

Namespace: Assimp
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public INativeCustomMarshaler Marshaler { get; }

Property Value

Type: INativeCustomMarshaler
See Also

Reference

NativeCustomMarshalerAttribute Class


NativeCustomMarshalerAttribute Methods

The NativeCustomMarshalerAttribute type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Returns a value that indicates whether this instance is equal to a specified object. (Inherited from Attribute.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from Attribute.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsDefaultAttribute | When overridden in a derived class, indicates whether the value of this instance is the default value for the derived class. (Inherited from Attribute.)
Public method | Match | When overridden in a derived class, returns a value that indicates whether this instance equals a specified object. (Inherited from Attribute.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

NativeCustomMarshalerAttribute Class


Node Class

A node in the imported model hierarchy.
Inheritance Hierarchy
SystemObject
AssimpNode

Namespace: Assimp
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public sealed class Node : IMarshalable<Node, AiNode>

The Node type exposes the following members.

Constructors
 | Name | Description
Public method | Node | Constructs a new instance of the Node class.
Public method | Node(String) | Constructs a new instance of the Node class.
Public method | Node(String, Node) | Constructs a new instance of the Node class.
Top
Properties
 | Name | Description
Public property | ChildCount | Gets the number of children that is owned by this node.
Public property | Children | Gets the node's children.
Public property | HasChildren | Gets if the node contains children.
Public property | HasMeshes | Gets if the node contains mesh references.
Public property | MeshCount | Gets the number of meshes referenced by this node.
Public property | MeshIndices | Gets the indices of the meshes referenced by this node. Meshes can be shared between nodes, so there is a mesh collection owned by the scene that each node can reference.
Public property | Metadata | Gets the node's metadata container.
Public property | Name | Gets or sets the name of the node.
Public property | Parent | Gets the node's parent, if it exists.
Public property | Transform | Gets or sets the transformation of the node relative to its parent.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | FindNode | Finds a node with the specific name, which may be this node or any children or children's children, and so on, if it exists.
 | FreeNative | Frees unmanaged memory created by ToNative(IntPtr, Native).
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference


Node Constructor

Overload List
 | Name | Description
Public method | Node | Constructs a new instance of the Node class.
Public method | Node(String) | Constructs a new instance of the Node class.
Public method | Node(String, Node) | Constructs a new instance of the Node class.
Top
See Also

Reference

Node Class


Node Constructor

Constructs a new instance of the Node class.

Namespace: Assimp
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public Node()
See Also

Reference

Node Class
Node Overload


Node Constructor (String)

Constructs a new instance of the Node class.

Namespace: Assimp
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public Node(
    string name
)

Parameters

name
Type: SystemString
Name of the node
See Also

Reference

Node Class
Node Overload


Node Constructor (String, Node)

Constructs a new instance of the Node class.

Namespace: Assimp
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public Node(
    string name,
    Node parent
)

Parameters

name
Type: SystemString
Name of the node
parent
Type: AssimpNode
Parent of the node
See Also

Reference

Node Class
Node Overload


Node Properties

The Node type exposes the following members.

Properties
 | Name | Description
Public property | ChildCount | Gets the number of children that is owned by this node.
Public property | Children | Gets the node's children.
Public property | HasChildren | Gets if the node contains children.
Public property | HasMeshes | Gets if the node contains mesh references.
Public property | MeshCount | Gets the number of meshes referenced by this node.
Public property | MeshIndices | Gets the indices of the meshes referenced by this node. Meshes can be shared between nodes, so there is a mesh collection owned by the scene that each node can reference.
Public property | Metadata | Gets the node's metadata container.
Public property | Name | Gets or sets the name of the node.
Public property | Parent | Gets the node's parent, if it exists.
Public property | Transform | Gets or sets the transformation of the node relative to its parent.
Top
See Also

Reference

Node Class


Node.ChildCount Property

NodeChildCount Property

Gets the number of children that is owned by this node.

Namespace: Assimp
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public int ChildCount { get; }

Property Value

Type: Int32
See Also

Reference

Node Class


Node.Children Property

NodeChildren Property

Gets the node's children.

Namespace: Assimp
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public NodeCollection Children { get; }

Property Value

Type: NodeCollection
See Also

Reference

Node Class


Node.HasChildren Property

NodeHasChildren Property

Gets if the node contains children.

Namespace: Assimp
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public bool HasChildren { get; }

Property Value

Type: Boolean
See Also

Reference

Node Class


Node.HasMeshes Property

NodeHasMeshes Property

Gets if the node contains mesh references.

Namespace: Assimp
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public bool HasMeshes { get; }

Property Value

Type: Boolean
See Also

Reference

Node Class


Node.MeshCount Property

NodeMeshCount Property

Gets the number of meshes referenced by this node.

Namespace: Assimp
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public int MeshCount { get; }

Property Value

Type: Int32
See Also

Reference

Node Class


Node.MeshIndices Property

NodeMeshIndices Property

Gets the indices of the meshes referenced by this node. Meshes can be shared between nodes, so there is a mesh collection owned by the scene that each node can reference.

Namespace: Assimp
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public List MeshIndices { get; }

Property Value

Type: ListT
See Also

Reference

Node Class


Node.Metadata Property

NodeMetadata Property

Gets the node's metadata container.

Namespace: Assimp
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public Metadata Metadata { get; }

Property Value

Type: Metadata
See Also

Reference

Node Class


Node.Name Property

NodeName Property

Gets or sets the name of the node.

Namespace: Assimp
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public string Name { get; set; }

Property Value

Type: String
See Also

Reference

Node Class


Node.Parent Property

NodeParent Property

Gets the node's parent, if it exists.

Namespace: Assimp
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public Node Parent { get; }

Property Value

Type: Node
See Also

Reference

Node Class


Node.Transform Property

NodeTransform Property

Gets or sets the transformation of the node relative to its parent.

Namespace: Assimp
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public Matrix4x4 Transform { get; set; }

Property Value

Type: Matrix4x4
See Also

Reference

Node Class


Node Methods

The Node type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | FindNode | Finds a node with the specific name, which may be this node or any children or children's children, and so on, if it exists.
 | FreeNative | Frees unmanaged memory created by ToNative(IntPtr, Native).
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Node Class


Node.FindNode Method

NodeFindNode Method

Finds a node with the specific name, which may be this node or any children or children's children, and so on, if it exists.

Namespace: Assimp
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public Node FindNode(
    string name
)

Parameters

name
Type: SystemString
Node name

Return Value

Type: Node
The node or null if it does not exist
See Also

Reference

Node Class


Node.FreeNative Method

NodeFreeNative Method

Frees unmanaged memory created by ToNative(IntPtr, Native).

Namespace: Assimp
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public static void FreeNative(
    IntPtr nativeValue,
    bool freeNative
)

Parameters

nativeValue
Type: SystemIntPtr
Native value to free
freeNative
Type: SystemBoolean
True if the unmanaged memory should be freed, false otherwise.
See Also

Reference

Node Class


NodeAnimationChannel Class

Describes the animation of a single node. The name specifies the bone/node which is affected by this animation chanenl. The keyframes are given in three separate seties of values, one for each position, rotation, and scaling. The transformation matrix is computed from these values and replaces the node's original transformation matrix at a specific time.

This means all keys are absolute and not relative to the bone default pose. The order which the transformations are to be applied is scaling, rotation, and translation (SRT).

Keys are in chronological order and duplicate keys do not pass the validation step. There most likely will be no negative time values, but they are not forbidden.

Inheritance Hierarchy
SystemObject
AssimpNodeAnimationChannel

Namespace: Assimp
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public sealed class NodeAnimationChannel : IMarshalable<NodeAnimationChannel, AiNodeAnim>

The NodeAnimationChannel type exposes the following members.

Constructors
 | Name | Description
Public method | NodeAnimationChannel | Constructs a new instance of the NodeAnimationChannel class.
Top
Properties
 | Name | Description
Public property | HasPositionKeys | Gets if this animation channel contains position keys.
Public property | HasRotationKeys | Gets if the animation channel contains rotation keys.
Public property | HasScalingKeys | Gets if the animation channel contains scaling keys.
Public property | NodeName | Gets or sets the name of the node affected by this animation. It must exist and it must be unique.
Public property | PositionKeyCount | Gets the number of position keys in the animation channel.
Public property | PositionKeys | Gets the position keys of this animation channel. Positions are specified as a 3D vector. If there are position keys, there should also be -at least- one scaling and one rotation key.
Public property | PostState | Gets or sets how the animation behaves after the last key was processed. By default the original transformation matrix of the affected node is taken.
Public property | PreState | Gets or sets how the animation behaves before the first key is encountered. By default the original transformation matrix of the affected node is used.
Public property | RotationKeyCount | Gets the number of rotation keys in the animation channel.
Public property | RotationKeys | Gets the rotation keys of this animation channel. Rotations are given as quaternions. If this exists, there should be -at least- one scaling and one position key.
Public property | ScalingKeyCount | Gets the number of scaling keys in the animation channel.
Public property | ScalingKeys | Gets the scaling keys of this animation channel. Scalings are specified in a 3D vector. If there are scaling keys, there should also be -at least- one position and one rotation key.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
 | FreeNative | Frees unmanaged memory created by ToNative(IntPtr, Native).
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference


NodeAnimationChannel Constructor

Constructs a new instance of the NodeAnimationChannel class.

Namespace: Assimp
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public NodeAnimationChannel()
See Also

Reference

NodeAnimationChannel Class


NodeAnimationChannel Properties

The NodeAnimationChannel type exposes the following members.

Properties
 | Name | Description
Public property | HasPositionKeys | Gets if this animation channel contains position keys.
Public property | HasRotationKeys | Gets if the animation channel contains rotation keys.
Public property | HasScalingKeys | Gets if the animation channel contains scaling keys.
Public property | NodeName | Gets or sets the name of the node affected by this animation. It must exist and it must be unique.
Public property | PositionKeyCount | Gets the number of position keys in the animation channel.
Public property | PositionKeys | Gets the position keys of this animation channel. Positions are specified as a 3D vector. If there are position keys, there should also be -at least- one scaling and one rotation key.
Public property | PostState | Gets or sets how the animation behaves after the last key was processed. By default the original transformation matrix of the affected node is taken.
Public property | PreState | Gets or sets how the animation behaves before the first key is encountered. By default the original transformation matrix of the affected node is used.
Public property | RotationKeyCount | Gets the number of rotation keys in the animation channel.
Public property | RotationKeys | Gets the rotation keys of this animation channel. Rotations are given as quaternions. If this exists, there should be -at least- one scaling and one position key.
Public property | ScalingKeyCount | Gets the number of scaling keys in the animation channel.
Public property | ScalingKeys | Gets the scaling keys of this animation channel. Scalings are specified in a 3D vector. If there are scaling keys, there should also be -at least- one position and one rotation key.
Top
See Also

Reference

NodeAnimationChannel Class


NodeAnimationChannel.HasPositionKeys Property

NodeAnimationChannelHasPositionKeys Property

Gets if this animation channel contains position keys.

Namespace: Assimp
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public bool HasPositionKeys { get; }

Property Value

Type: Boolean
See Also

Reference

NodeAnimationChannel Class


NodeAnimationChannel.HasRotationKeys Property

NodeAnimationChannelHasRotationKeys Property

Gets if the animation channel contains rotation keys.

Namespace: Assimp
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public bool HasRotationKeys { get; }

Property Value

Type: Boolean
See Also

Reference

NodeAnimationChannel Class


NodeAnimationChannel.HasScalingKeys Property

NodeAnimationChannelHasScalingKeys Property

Gets if the animation channel contains scaling keys.

Namespace: Assimp
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public bool HasScalingKeys { get; }

Property Value

Type: Boolean
See Also

Reference

NodeAnimationChannel Class


NodeAnimationChannel.NodeName Property

NodeAnimationChannelNodeName Property

Gets or sets the name of the node affected by this animation. It must exist and it must be unique.

Namespace: Assimp
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public string NodeName { get; set; }

Property Value

Type: String
See Also

Reference

NodeAnimationChannel Class


NodeAnimationChannel.PositionKeyCount Property

NodeAnimationChannelPositionKeyCount Property

Gets the number of position keys in the animation channel.

Namespace: Assimp
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public int PositionKeyCount { get; }

Property Value

Type: Int32
See Also

Reference

NodeAnimationChannel Class


NodeAnimationChannel.PositionKeys Property

NodeAnimationChannelPositionKeys Property

Gets the position keys of this animation channel. Positions are specified as a 3D vector. If there are position keys, there should also be -at least- one scaling and one rotation key.

Namespace: Assimp
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public List PositionKeys { get; }

Property Value

Type: ListT
See Also

Reference

NodeAnimationChannel Class


NodeAnimationChannel.PostState Property

NodeAnimationChannelPostState Property

Gets or sets how the animation behaves after the last key was processed. By default the original transformation matrix of the affected node is taken.

Namespace: Assimp
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public AnimationBehaviour PostState { get; set; }

Property Value

Type: AnimationBehaviour
See Also

Reference

NodeAnimationChannel Class


NodeAnimationChannel.PreState Property

NodeAnimationChannelPreState Property

Gets or sets how the animation behaves before the first key is encountered. By default the original transformation matrix of the affected node is used.

Namespace: Assimp
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public AnimationBehaviour PreState { get; set; }

Property Value

Type: AnimationBehaviour
See Also

Reference

NodeAnimationChannel Class


NodeAnimationChannel.RotationKeyCount Property

NodeAnimationChannelRotationKeyCount Property

Gets the number of rotation keys in the animation channel.

Namespace: Assimp
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public int RotationKeyCount { get; }

Property Value

Type: Int32
See Also

Reference

NodeAnimationChannel Class


NodeAnimationChannel.RotationKeys Property

NodeAnimationChannelRotationKeys Property

Gets the rotation keys of this animation channel. Rotations are given as quaternions. If this exists, there should be -at least- one scaling and one position key.

Namespace: Assimp
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public List RotationKeys { get; }

Property Value

Type: ListT
See Also

Reference

NodeAnimationChannel Class


NodeAnimationChannel.ScalingKeyCount Property

NodeAnimationChannelScalingKeyCount Property

Gets the number of scaling keys in the animation channel.

Namespace: Assimp
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public int ScalingKeyCount { get; }

Property Value

Type: Int32
See Also

Reference

NodeAnimationChannel Class


NodeAnimationChannel.ScalingKeys Property

NodeAnimationChannelScalingKeys Property

Gets the scaling keys of this animation channel. Scalings are specified in a 3D vector. If there are scaling keys, there should also be -at least- one position and one rotation key.

Namespace: Assimp
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public List ScalingKeys { get; }

Property Value

Type: ListT
See Also

Reference

NodeAnimationChannel Class


NodeAnimationChannel Methods

The NodeAnimationChannel type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
 | FreeNative | Frees unmanaged memory created by ToNative(IntPtr, Native).
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

NodeAnimationChannel Class


NodeAnimationChannel.FreeNative Method

NodeAnimationChannelFreeNative Method

Frees unmanaged memory created by ToNative(IntPtr, Native).

Namespace: Assimp
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public static void FreeNative(
    IntPtr nativeValue,
    bool freeNative
)

Parameters

nativeValue
Type: SystemIntPtr
Native value to free
freeNative
Type: SystemBoolean
True if the unmanaged memory should be freed, false otherwise.
See Also

Reference

NodeAnimationChannel Class


NodeCollection Class

A collection of child nodes owned by a parent node. Manages access to the collection while maintaing parent-child linkage.
Inheritance Hierarchy
SystemObject
AssimpNodeCollection

Namespace: Assimp
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public sealed class NodeCollection : IList<Node>,
    ICollection<Node>, IEnumerable<Node>, IEnumerable

The NodeCollection type exposes the following members.

Properties
 | Name | Description
Public property | Count | Gets the number of elements contained in the ICollectionT.
Public property | IsReadOnly | Gets a value indicating whether the ICollectionT is read-only.
Public property | Item | Gets or sets the element at the specified index.
Top
Methods
 | Name | Description
Public method | Add | Adds an item to the ICollectionT.
Public method | AddRange | Adds a range of items to the list.
Public method | Clear | Removes all items from the ICollectionT.
Public method | Contains | Determines whether the ICollectionT contains a specific value.
Public method | CopyTo | Copies collection contents to the array
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetEnumerator | Returns an enumerator that iterates through the collection.
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IndexOf | Determines the index of a specific item in the IListT.
Public method | Insert | Inserts an item to the IListT at the specified index.
Public method | Remove | Removes the first occurrence of a specific object from the ICollectionT.
Public method | RemoveAt | Removes the IListT item at the specified index.
Public method | ToArray | Copies elements in the collection to a new array.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference


NodeCollection Properties

The NodeCollection type exposes the following members.

Properties
 | Name | Description
Public property | Count | Gets the number of elements contained in the ICollectionT.
Public property | IsReadOnly | Gets a value indicating whether the ICollectionT is read-only.
Public property | Item | Gets or sets the element at the specified index.
Top
See Also

Reference

NodeCollection Class


NodeCollection.Count Property

NodeCollectionCount Property

Gets the number of elements contained in the ICollectionT.

Namespace: Assimp
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public int Count { get; }

Property Value

Type: Int32

Implements

ICollectionTCount
See Also

Reference

NodeCollection Class


NodeCollection.IsReadOnly Property

NodeCollectionIsReadOnly Property

Gets a value indicating whether the ICollectionT is read-only.

Namespace: Assimp
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public bool IsReadOnly { get; }

Return Value

Type: Boolean
true if the ICollectionT is read-only; otherwise, false.

Implements

ICollectionTIsReadOnly
See Also

Reference

NodeCollection Class


NodeCollection.Item Property

NodeCollectionItem Property

Gets or sets the element at the specified index.

Namespace: Assimp
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public Node this[
    int index
] { get; set; }

Parameters

index
Type: SystemInt32
The child index

Property Value

Type: Node

Implements

IListTItemInt32
See Also

Reference

NodeCollection Class


NodeCollection Methods

The NodeCollection type exposes the following members.

Methods
 | Name | Description
Public method | Add | Adds an item to the ICollectionT.
Public method | AddRange | Adds a range of items to the list.
Public method | Clear | Removes all items from the ICollectionT.
Public method | Contains | Determines whether the ICollectionT contains a specific value.
Public method | CopyTo | Copies collection contents to the array
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetEnumerator | Returns an enumerator that iterates through the collection.
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IndexOf | Determines the index of a specific item in the IListT.
Public method | Insert | Inserts an item to the IListT at the specified index.
Public method | Remove | Removes the first occurrence of a specific object from the ICollectionT.
Public method | RemoveAt | Removes the IListT item at the specified index.
Public method | ToArray | Copies elements in the collection to a new array.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

NodeCollection Class


NodeCollection.Add Method

NodeCollectionAdd Method

Adds an item to the ICollectionT.

Namespace: Assimp
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public void Add(
    Node item
)

Parameters

item
Type: AssimpNode
The object to add to the ICollectionT.

Implements

ICollectionTAdd(T)
See Also

Reference

NodeCollection Class


NodeCollection.AddRange Method

NodeCollectionAddRange Method

Adds a range of items to the list.

Namespace: Assimp
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public void AddRange(
    Node[] items
)

Parameters

items
Type: AssimpNode
Item array
See Also

Reference

NodeCollection Class


NodeCollection.Clear Method

NodeCollectionClear Method

Removes all items from the ICollectionT.

Namespace: Assimp
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public void Clear()

Implements

ICollectionTClear
See Also

Reference

NodeCollection Class


NodeCollection.Contains Method

NodeCollectionContains Method

Determines whether the ICollectionT contains a specific value.

Namespace: Assimp
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public bool Contains(
    Node item
)

Parameters

item
Type: AssimpNode
The object to locate in the ICollectionT.

Return Value

Type: Boolean
true if item is found in the ICollectionT; otherwise, false.

Implements

ICollectionTContains(T)
See Also

Reference

NodeCollection Class


NodeCollection.CopyTo Method

NodeCollectionCopyTo Method

Copies collection contents to the array

Namespace: Assimp
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public void CopyTo(
    Node[] array,
    int arrayIndex
)

Parameters

array
Type: AssimpNode
The array to copy to.
arrayIndex
Type: SystemInt32
Index of the array to start copying.

Implements

ICollectionTCopyTo(T, Int32)
See Also

Reference

NodeCollection Class


NodeCollection.GetEnumerator Method

NodeCollectionGetEnumerator Method

Returns an enumerator that iterates through the collection.

Namespace: Assimp
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public IEnumerator<Node> GetEnumerator()

Return Value

Type: IEnumerator Node
A IEnumeratorT that can be used to iterate through the collection.

Implements

IEnumerableTGetEnumerator
See Also

Reference

NodeCollection Class


NodeCollection.IndexOf Method

NodeCollectionIndexOf Method

Determines the index of a specific item in the IListT.

Namespace: Assimp
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public int IndexOf(
    Node item
)

Parameters

item
Type: AssimpNode
The object to locate in the IListT.

Return Value

Type: Int32
The index of item if found in the list; otherwise, -1.

Implements

IListTIndexOf(T)
See Also

Reference

NodeCollection Class


NodeCollection.Insert Method

NodeCollectionInsert Method

Inserts an item to the IListT at the specified index.

Namespace: Assimp
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public void Insert(
    int index,
    Node item
)

Parameters

index
Type: SystemInt32
The zero-based index at which item should be inserted.
item
Type: AssimpNode
The object to insert into the IListT.

Implements

IListTInsert(Int32, T)
See Also

Reference

NodeCollection Class


NodeCollection.Remove Method

NodeCollectionRemove Method

Removes the first occurrence of a specific object from the ICollectionT.

Namespace: Assimp
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public bool Remove(
    Node item
)

Parameters

item
Type: AssimpNode
The object to remove from the ICollectionT.

Return Value

Type: Boolean
true if item was successfully removed from the ICollectionT; otherwise, false. This method also returns false if item is not found in the original ICollectionT.

Implements

ICollectionTRemove(T)
See Also

Reference

NodeCollection Class


NodeCollection.RemoveAt Method

NodeCollectionRemoveAt Method

Removes the IListT item at the specified index.

Namespace: Assimp
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public void RemoveAt(
    int index
)

Parameters

index
Type: SystemInt32
The zero-based index of the item to remove.

Implements

IListTRemoveAt(Int32)
See Also

Reference

NodeCollection Class


NodeCollection.ToArray Method

NodeCollectionToArray Method

Copies elements in the collection to a new array.

Namespace: Assimp
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public Node[] ToArray()

Return Value

Type: Node
Array of copied elements
See Also

Reference

NodeCollection Class


Origin Enumeration

Seek origins for Assimp's virtual file system API.

Namespace: Assimp
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public enum Origin
Members
Member name | Value | Description
Set | 0 | Beginning of the file
Current | 1 | Current position of the file pointer.
End | 2 | End of the file, offsets must be negative.
See Also

Reference


Plane Structure

Represents a plane in three-dimensional euclidean space where A, B, C are components of the plane normal and D is the distance along the normal from the origin to the plane.

Namespace: Assimp
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public struct Plane

The Plane type exposes the following members.

Constructors
 | Name | Description
Public method | Plane | Constructs a new Plane.
Top
Methods
 | Name | Description
Public method | Equals | Indicates whether this instance and a specified object are equal. (Inherited from ValueType.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from ValueType.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns the fully qualified type name of this instance. (Inherited from ValueType.)
Top
Fields
 | Name | Description
Public field | A | X component of the normal vector.
Public field | B | Y component of the normal vector.
Public field | C | Z component of the normal vector.
Public field | D | Distance from the origin to the plane along the normal vector.
Top
See Also

Reference


Plane Constructor

Constructs a new Plane.

Namespace: Assimp
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public Plane(
    float a,
    float b,
    float c,
    float d
)

Parameters

a
Type: SystemSingle
X component of the normal vector.
b
Type: SystemSingle
Y component of the normal vector.
c
Type: SystemSingle
Z component of the normal vector.
d
Type: SystemSingle
Distance from the origin to the plane along the normal vector.
See Also

Reference

Plane Structure


Plane Methods

The Plane type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Indicates whether this instance and a specified object are equal. (Inherited from ValueType.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from ValueType.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns the fully qualified type name of this instance. (Inherited from ValueType.)
Top
See Also

Reference

Plane Structure


Plane Fields

The Plane type exposes the following members.

Fields
 | Name | Description
Public field | A | X component of the normal vector.
Public field | B | Y component of the normal vector.
Public field | C | Z component of the normal vector.
Public field | D | Distance from the origin to the plane along the normal vector.
Top
See Also

Reference

Plane Structure


Plane.A Field

PlaneA Field

X component of the normal vector.

Namespace: Assimp
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public float A

Field Value

Type: Single
See Also

Reference

Plane Structure


Plane.B Field

PlaneB Field

Y component of the normal vector.

Namespace: Assimp
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public float B

Field Value

Type: Single
See Also

Reference

Plane Structure


Plane.C Field

PlaneC Field

Z component of the normal vector.

Namespace: Assimp
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public float C

Field Value

Type: Single
See Also

Reference

Plane Structure


Plane.D Field

PlaneD Field

Distance from the origin to the plane along the normal vector.

Namespace: Assimp
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public float D

Field Value

Type: Single
See Also

Reference

Plane Structure


PostProcessPreset Class

Static class containing preset properties for post processing options.
Inheritance Hierarchy
SystemObject
AssimpPostProcessPreset

Namespace: Assimp
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public static class PostProcessPreset

The PostProcessPreset type exposes the following members.

Properties
Name | Description
ConvertToLeftHanded | PostProcess configuration for (some) Direct3D conventions, left handed geometry, upper left origin for UV coordinates, and clockwise face order, suitable for CCW culling.
TargetRealTimeFast | PostProcess configuration for optimizing data for real-time. Does the following steps: CalculateTangentSpace, GenerateNormals, JoinIdenticalVertices, Triangulate, GenerateUVCoords, and SortByPrimitiveType
TargetRealTimeMaximumQuality | PostProcess configuration for heavily optimizing the data for real-time rendering. Includes all flags in TargetRealTimeQuality as well as FindInstances, ValidateDataStructure, and OptimizeMeshes
TargetRealTimeQuality | PostProcess configuration for optimizing data for real-time rendering. Does the following steps: CalculateTangentSpace, GenerateSmoothNormals, JoinIdenticalVertices, Triangulate, GenerateUVCoords, SortByPrimitiveType LimitBoneWeights, RemoveRedundantMaterials, SplitLargeMeshes, FindDegenerates, and FindInvalidData
Top
See Also

Reference


PostProcessPreset Properties

The PostProcessPreset type exposes the following members.

Properties
Name | Description
ConvertToLeftHanded | PostProcess configuration for (some) Direct3D conventions, left handed geometry, upper left origin for UV coordinates, and clockwise face order, suitable for CCW culling.
TargetRealTimeFast | PostProcess configuration for optimizing data for real-time. Does the following steps: CalculateTangentSpace, GenerateNormals, JoinIdenticalVertices, Triangulate, GenerateUVCoords, and SortByPrimitiveType
TargetRealTimeMaximumQuality | PostProcess configuration for heavily optimizing the data for real-time rendering. Includes all flags in TargetRealTimeQuality as well as FindInstances, ValidateDataStructure, and OptimizeMeshes
TargetRealTimeQuality | PostProcess configuration for optimizing data for real-time rendering. Does the following steps: CalculateTangentSpace, GenerateSmoothNormals, JoinIdenticalVertices, Triangulate, GenerateUVCoords, SortByPrimitiveType LimitBoneWeights, RemoveRedundantMaterials, SplitLargeMeshes, FindDegenerates, and FindInvalidData
Top
See Also

Reference

PostProcessPreset Class


PostProcessPreset.ConvertToLeftHanded Property

PostProcessPresetConvertToLeftHanded Property

PostProcess configuration for (some) Direct3D conventions, left handed geometry, upper left origin for UV coordinates, and clockwise face order, suitable for CCW culling.

Namespace: Assimp
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public static PostProcessSteps ConvertToLeftHanded { get; }

Property Value

Type: PostProcessSteps
See Also

Reference

PostProcessPreset Class


PostProcessPreset.TargetRealTimeFast Property

PostProcessPresetTargetRealTimeFast Property

PostProcess configuration for optimizing data for real-time. Does the following steps: CalculateTangentSpace, GenerateNormals, JoinIdenticalVertices, Triangulate, GenerateUVCoords, and SortByPrimitiveType

Namespace: Assimp
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public static PostProcessSteps TargetRealTimeFast { get; }

Property Value

Type: PostProcessSteps
See Also

Reference

PostProcessPreset Class


PostProcessPreset.TargetRealTimeMaximumQuality Property

PostProcessPresetTargetRealTimeMaximumQuality Property

PostProcess configuration for heavily optimizing the data for real-time rendering. Includes all flags in TargetRealTimeQuality as well as FindInstances, ValidateDataStructure, and OptimizeMeshes

Namespace: Assimp
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public static PostProcessSteps TargetRealTimeMaximumQuality { get; }

Property Value

Type: PostProcessSteps
See Also

Reference

PostProcessPreset Class


PostProcessPreset.TargetRealTimeQuality Property

PostProcessPresetTargetRealTimeQuality Property

PostProcess configuration for optimizing data for real-time rendering. Does the following steps: CalculateTangentSpace, GenerateSmoothNormals, JoinIdenticalVertices, Triangulate, GenerateUVCoords, SortByPrimitiveType LimitBoneWeights, RemoveRedundantMaterials, SplitLargeMeshes, FindDegenerates, and FindInvalidData

Namespace: Assimp
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public static PostProcessSteps TargetRealTimeQuality { get; }

Property Value

Type: PostProcessSteps
See Also

Reference

PostProcessPreset Class


PostProcessSteps Enumeration

Post processing flag options, specifying a number of steps that can be run on the data to either generate additional vertex data or optimize the imported data.

Namespace: Assimp
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
[FlagsAttribute]
public enum PostProcessSteps
Members
Member name | Value | Description
None | 0 | No flags enabled.
CalculateTangentSpace 1 Calculates the tangents and binormals (bitangents) for the imported meshes.

This does nothing if a mesh does not have normals. You might want this post processing step to be executed if you plan to use tangent space calculations such as normal mapping. There is a config setting AI_CONFIG_PP_CT_MAX_SMOOTHING_ANGLE which allows you to specify a maximimum smoothing angle for the algorithm. However, usually you'll want to leave it at the default value.

JoinIdenticalVertices 2 Identifies and joins identical vertex data sets within all imported meshes.

After this step is run each mesh does contain only unique vertices anymore, so a vertex is possibly used by multiple faces. You usually want to use this post processing step. If your application deals with indexed geometry, this step is compulsory or you'll just waste rendering time.

If this flag is not specified, no vertices are referenced by more than one face and no index buffer is required for rendering.

MakeLeftHanded 4 Converts all imported data to a left handed coordinate space.

By default the data is returned in a right-handed coordinate space, where +X points to the right, +Z towards the viewer, and +Y upwards.

Triangulate 8 Triangulates all faces of all meshes.

By default the imported mesh data might contain faces with more than three indices. For rendering you'll usually want all faces to be triangles. This post processing step splits up all higher faces to triangles. Line and point primitives are *not* modified. If you want 'triangles only' with no other kinds of primitives, try the following:

  1. Specify both Triangulate and SortByPrimitiveType.
  2. Ignore all point and line meshes when you process Assimp's output
RemoveComponent 16 Removes some parts of the data structure (animations, materials, light sources, cameras, textures, vertex components).

The components to be removed are specified in a separate configuration option, AI_CONFIG_PP_RVC_FLAGS. This is quite useful if you don't need all parts of the output structure. Especially vertex colors are rarely used today...calling this step to remove unrequired stuff from the pipeline as early as possible results in an increased performance and a better optimized output data structure.

This step is also useful if you want to force Assimp to recompute normals or tangents. the corresponding steps don't recompute them if they're already there (loaded from the source asset). By using this step you can make sure they are NOT there.

GenerateNormals 32 Generates normals for all faces of all meshes. It may not be specified together with GenerateSmoothNormals.

This is ignored if normals are already there at the time where this flag is evaluated. Model importers try to load them from the source file, so they're usually already there. Face normals are shared between all points of a single face, so a single point can have multiple normals, which in other words, forces the library to duplicate vertices in some cases. This makes JoinIdenticalVertices senseless then.

GenerateSmoothNormals 64 Generates smooth normals for all vertices of all meshes. It may not be specified together with GenerateNormals.

This is ignored if normals are already there at the time where this flag is evaluated. Model importers try to load them from the source file, so they're usually already there.

The configuration option AI_CONFIG_PP_GSN_MAX_SMOOTHING_ANGLE allows you to specify an angle maximum for the normal smoothing algorithm. Normals exceeding this limit are not smoothed, resulting in a 'hard' seam between two faces. using a decent angle here (e.g. 80 degrees) results in a very good visual appearance.

SplitLargeMeshes 128 Splits large meshes into smaller submeshes.

This is useful for realtime rendering where the number of triangles which can be maximally processed in a single draw call is usually limited by the video driver/hardware. The maximum vertex buffer is usually limited, too. Both requirements can be met with this step: you may specify both a triangle and a vertex limit for a single mesh.

The split limits can be set through the AI_CONFIG_PP_SLM_VERTEX_LIMIT and AI_CONFIG_PP_SLM_TRIANGLE_LIMIT config settings. The default values are 1,000,000.

Warning: This can be a time consuming task.

PreTransformVertices 256 Removes the node graph and "bakes" (pre-transforms) all vertices with the local transformation matrices of their nodes. The output scene does still contain nodes, however, there is only a root node with children, each one referencing only one mesh. Each mesh referencing one material. For rendering, you can simply render all meshes in order, you don't need to pay attention to local transformations and the node hierarchy.

Warning: Animations are removed during this step.

LimitBoneWeights 512 Limits the number of bones simultaneously affecting a single vertex to a maximum value.

If any vertex is affected by more than that number of bones, the least important vertex weights are removed and the remaining vertex weights are re-normalized so that the weights still sum up to 1.

The default bone weight limit is 4 and uses the AI_LMW_MAX_WEIGHTS config. If you intend to perform the skinning in hardware, this post processing step might be of interest for you.

ValidateDataStructure 1024 Validates the imported scene data structure.

This makes sure that all indices are valid, all animations and bones are linked correctly, all material references are correct, etc.

It is recommended to capture Assimp's log output if you use this flag, so you can easily find out what's actually wrong if a file fails the validation. The validator is quite rude and will find *all* inconsistencies in the data structure. There are two types of failures:
  • Error: There's something wrong with the imported data. Further postprocessing is not possible and the data is not usable at all. The import fails.
  • Warning: There are some minor issues (e.g. 1000000 animation keyframes with the same time), but further postprocessing and use of the data structure is still safe. Warning details are written to the log file.
ImproveCacheLocality 2048 Re-orders triangles for better vertex cache locality.

This step tries to improve the ACMR (average post-transform vertex cache miss ratio) for all meshes. The implementation runs in O(n) time and is roughly based on the 'tipsify' algorithm.

If you intend to render huge models in hardware, this step might be of interest for you. The AI_CONFIG_PP_ICL_PTCACHE_SIZE config setting can be used to fine tune the cache optimization.

RemoveRedundantMaterials 4096 Searches for redundant/unreferenced materials and removes them.

This is especially useful in combination with the PreTransformVertices and OptimizeMeshes flags. Both join small meshes with equal characteristics, but they can't do their work if two meshes have different materials. Because several material settings are always lost during Assimp's import filders and because many exporters don't check for redundant materials, huge models often have materials which are defined several times with exactly the same settings.

Several material settings not contributing to the final appearance of a surface are ignored in all comparisons ... the material name is one of them. So, if you're passing additional information through the content pipeline (probably using *magic* material names), don't specify this flag. Alternatively, take a look at the AI_CONFIG_PP_RRM_EXCLUDE_LIST setting.

FixInFacingNormals 8192 This step tries to determine which meshes have normal vectors that are facing inwards.

The algorithm is simple but effective:

The bounding box of all vertices and their normals are compared against the volume of the bounding box of all vertices without their normals. This works well for most objects, problems might occur with planar surfaces. However, the step tries to filter such cases. The step inverts all in-facing normals. Generally, it is recommended to enable this step, although the result is not always correct.

SortByPrimitiveType 32768 This step splits meshes with more than one primitive type in homogeneous submeshes.

This step is executed after triangulation and after it returns, just one bit is set in aiMesh:mPrimitiveTypes. This is especially useful for real-time rendering where point and line primitives are often ignored or rendered separately.

You can use AI_CONFIG_PP_SBP_REMOVE option to specify which primitive types you need. This can be used to easily exclude lines and points, which are rarely used, from the import.

FindDegenerates 65536 This step searches all meshes for degenerated primitives and converts them to proper lines or points. A face is 'degenerated' if one or more of its points are identical.

To have degenerated primitives removed, specify the FindDegenerates flag try one of the following procedures:

To support lines and points: Set the AI_CONFIG_PP_FD_REMOVE option to one. This will cause the step to remove degenerated triangles as soon as they are detected. They won't pass any further pipeline steps.If you don't support lines and points: Specify SortByPrimitiveType flag, which will move line and point primitives to separate meshes. Then set the AI_CONFIG_PP_SBP_REMOVE option to Point and Line to cause SortByPrimitiveType step to reject point and line meshes from the scene.

Degenerated polygons are not necessarily evil and that's why they are not removed by default. There are several file formats which do not support lines or points where exporters bypass the format specification and write them as degenerated triangles instead.

FindInvalidData 131072 This step searches all meshes for invalid data, such as zeroed normal vectors or invalid UV coordinates and removes or fixes them. This is intended to get rid of some common exporter rrors.

This is especially useful for normals. If they are invalid, and the step recognizes this, they will be removed and can later be recomputed, e.g. by the GenerateSmoothNormals flag. The step will also remove meshes that are infinitely small and reduce animation tracks consisting of hundreds of redundant keys to a single key. The AI_CONFIG_PP_FID_ANIM_ACCURACY config property decides the accuracy of the check for duplicate animation tracks.

GenerateUVCoords 262144 This step converts non-UV mappings (such as spherical or cylindrical mapping) to proper texture coordinate channels.

Most applications will support UV mapping only, so you will probably want to specify this step in every case. Note that Assimp is not always able to match the original mapping implementation of the 3D app which produced a model perfectly. It's always better to let the father app compute the UV channels, at least 3DS max, maya, blender, lightwave, modo, .... are able to achieve this.

If this step is not requested, you'll need to process the MATKEY_MAPPING material property in order to display all assets properly.

TransformUVCoords 524288 Applies per-texture UV transformations and bakes them to stand-alone vtexture coordinate channels.

UV Transformations are specified per-texture - see the MATKEY_UVTRANSFORM material key for more information. This step processes all textures with transformed input UV coordinates and generates new (pretransformed) UV channel transformations, so you will probably want to specify this step.

UV transformations are usually implemented in realtime apps by transforming texture coordinates in a vertex shader stage with a 3x3 (homogenous) transformation matrix.

FindInstances 1048576 Searches for duplicated meshes and replaces them with a reference to the first mesh.

This is time consuming, so don't use it if you have no time. Its main purpose is to work around the limitation with some file formats that don't support instanced meshes, so exporters duplicate meshes.

OptimizeMeshes 2097152 Attempts to reduce the number of meshes (and draw calls).

This is recommended to be used together with OptimizeGraph and is fully compatible with both SplitLargeMeshes and SortByPrimitiveType.

OptimizeGraph 4194304 Optimizes scene hierarchy. Nodes with no animations, bones, lights, or cameras assigned are collapsed and joined.

Node names can be lost during this step, you can specify names of nodes that should'nt be touched or modified with AI_CONFIG_PP_OG_EXCLUDE_LIST.

Use this flag with caution. Most simple files will be collapsed to a single node, complex hierarchies are usually completely lost. That's not the right choice for editor environments, but probably a very effective optimization if you just want to get the model data, convert it to your own format and render it as fast as possible.

This flag is designed to be used with OptimizeMeshes for best results.

Scenes with thousands of extremely small meshes packed in deeply nested nodes exist for almost all file formats. Usage of this and OptimizeMeshes usually fixes them all and makes them renderable.

FlipUVs | 8388608 | Flips all UV coordinates along the y-axis and adjusts material settings/bitangents accordingly.
FlipWindingOrder | 16777216 | Flips face winding order from CCW (default) to CW.
SplitByBoneCount | 33554432 | Splits meshes with many bones into submeshes so that each submesh has fewer or as many bones as a given limit.
Debone 67108864

Removes bones losslessly or according to some threshold. In some cases (e.g. formats that require it) exporters are faced to assign dummy bone weights to otherwise static meshes assigned to animated meshes. Full, weight-based skinning is expensive while animating nodes is extremely cheap, so this step is offered to clean up the data in that regard.

Usage of the configuration AI_CONFIG_PP_DB_THRESHOLD to control the threshold and AI_CONFIG_PP_DB_ALL_OR_NONE if you want bones removed if and only if all bones within the scene qualify for removal.

GlobalScale | 134217728 | This step will perform a global scale of the model. Some importers provide a mechanism to define a scaling unit for the model, which this processing step can utilize. Use AI_CONFIG_GLOBAL_SCALE_FACTOR_KEY to control this.
See Also

Reference


PrimitiveType Enumeration

Enumerates geometric primitive types.

Namespace: Assimp
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
[FlagsAttribute]
public enum PrimitiveType
Members
Member name | Value | Description
Point | 1 | Point primitive. This is just a single vertex in the virtual world. A face has one index for such a primitive.
Line | 2 | Line primitive. This is a line defined through a start and an end position. A face contains exactly two indices for such a primitive.
Triangle | 4 | Triangle primitive, consisting of three indices.
Polygon | 8 | A n-Gon that has more than three edges (thus is not a triangle).
See Also

Reference


PropertyType Enumeration

Defines material property types.

Namespace: Assimp
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public enum PropertyType
Members
Member name | Value | Description
Float | 1 | Array of single-precision (32 bit) floats.
Double | 2 | Array of double-precision (64 bit) floats.
String | 3 | Property is a string.
Integer | 4 | Array of 32 bit integers.
Buffer | 5 | Byte buffer where the content is undefined.
See Also

Reference


Quaternion Structure

A 4D vector that represents a rotation.

Namespace: Assimp
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public struct Quaternion : IEquatable<Quaternion>

The Quaternion type exposes the following members.

Constructors
 | Name | Description
Public method | Quaternion(Matrix3x3) | Constructs a new Quaternion from a rotation matrix.
Public method | Quaternion(Vector3D, Single) | Constructs a new Quaternion from an axis-angle.
Public method | Quaternion(Single, Single, Single) | Constructs a new Quaternion from three euler angles.
Public method | Quaternion(Single, Single, Single, Single) | Constructs a new Quaternion.
Top
Methods
 | Name | Description
Public method | Conjugate | Transforms this quaternion into its conjugate.
Public method | Equals(Object) | Tests equality between this color and another object. (Overrides ValueTypeEquals(Object).)
Public method | Equals(Quaternion) | Tests equality between two quaternions.
Public method | GetHashCode | Returns a hash code for this instance. (Overrides ValueTypeGetHashCode.)
Public method | GetMatrix | Returns a matrix representation of the quaternion.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Normalize | Normalizes the quaternion.
 | Rotate | Rotates a point by this quaternion.
 | Slerp | Spherical interpolation between two quaternions.
Public method | ToString | Returns a String that represents this instance. (Overrides ValueTypeToString.)
Top
Operators
Name | Description
Equality | Tests equality between two quaternions.
Inequality | Tests inequality between two quaternions.
Multiply | Multiplies two quaternions.
Top
Fields
 | Name | Description
Public field | W | Rotation component of the quaternion/
Public field | X | X component of the vector part of the quaternion.
Public field | Y | Y component of the vector part of the quaternion.
Public field | Z | Z component of the vector part of the quaternion.
Top
See Also

Reference


Quaternion Constructor

Overload List
 | Name | Description
Public method | Quaternion(Matrix3x3) | Constructs a new Quaternion from a rotation matrix.
Public method | Quaternion(Vector3D, Single) | Constructs a new Quaternion from an axis-angle.
Public method | Quaternion(Single, Single, Single) | Constructs a new Quaternion from three euler angles.
Public method | Quaternion(Single, Single, Single, Single) | Constructs a new Quaternion.
Top
See Also

Reference

Quaternion Structure


Quaternion Constructor (Matrix3x3)

Constructs a new Quaternion from a rotation matrix.

Namespace: Assimp
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public Quaternion(
    Matrix3x3 matrix
)

Parameters

matrix
Type: AssimpMatrix3x3
Rotation matrix to create the Quaternion from.
See Also

Reference

Quaternion Structure
Quaternion Overload


Quaternion Constructor (Vector3D, Single)

Constructs a new Quaternion from an axis-angle.

Namespace: Assimp
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public Quaternion(
    Vector3D axis,
    float angle
)

Parameters

axis
Type: AssimpVector3D
Axis
angle
Type: SystemSingle
Angle about the axis
See Also

Reference

Quaternion Structure
Quaternion Overload


Quaternion Constructor (Single, Single, Single)

Constructs a new Quaternion from three euler angles.

Namespace: Assimp
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public Quaternion(
    float pitch,
    float yaw,
    float roll
)

Parameters

pitch
Type: SystemSingle
Pitch
yaw
Type: SystemSingle
Yaw
roll
Type: SystemSingle
Roll
See Also

Reference

Quaternion Structure
Quaternion Overload


Quaternion Constructor (Single, Single, Single, Single)

Constructs a new Quaternion.

Namespace: Assimp
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public Quaternion(
    float w,
    float x,
    float y,
    float z
)

Parameters

w
Type: SystemSingle
W component
x
Type: SystemSingle
X component
y
Type: SystemSingle
Y component
z
Type: SystemSingle
Z component
See Also

Reference

Quaternion Structure
Quaternion Overload


Quaternion Methods

The Quaternion type exposes the following members.

Methods
 | Name | Description
Public method | Conjugate | Transforms this quaternion into its conjugate.
Public method | Equals(Object) | Tests equality between this color and another object. (Overrides ValueTypeEquals(Object).)
Public method | Equals(Quaternion) | Tests equality between two quaternions.
Public method | GetHashCode | Returns a hash code for this instance. (Overrides ValueTypeGetHashCode.)
Public method | GetMatrix | Returns a matrix representation of the quaternion.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Normalize | Normalizes the quaternion.
 | Rotate | Rotates a point by this quaternion.
 | Slerp | Spherical interpolation between two quaternions.
Public method | ToString | Returns a String that represents this instance. (Overrides ValueTypeToString.)
Top
See Also

Reference

Quaternion Structure


Quaternion.Conjugate Method

QuaternionConjugate Method

Transforms this quaternion into its conjugate.

Namespace: Assimp
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public void Conjugate()
See Also

Reference

Quaternion Structure


Quaternion.Equals Method

QuaternionEquals Method

Overload List
 | Name | Description
Public method | Equals(Object) | Tests equality between this color and another object. (Overrides ValueTypeEquals(Object).)
Public method | Equals(Quaternion) | Tests equality between two quaternions.
Top
See Also

Reference

Quaternion Structure


Quaternion.Equals Method (Object)

QuaternionEquals Method (Object)

Tests equality between this color and another object.

Namespace: Assimp
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public override bool Equals(
    Object obj
)

Parameters

obj
Type: SystemObject
Object to test against

Return Value

Type: Boolean
True if the object is a color and the components are equal
See Also

Reference

Quaternion Structure
Equals Overload


Quaternion.Equals Method (Quaternion)

QuaternionEquals Method (Quaternion)

Tests equality between two quaternions.

Namespace: Assimp
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public bool Equals(
    Quaternion other
)

Parameters

other
Type: AssimpQuaternion
Quaternion to compare

Return Value

Type: Boolean
True if the quaternions are equal.

Implements

IEquatableTEquals(T)
See Also

Reference

Quaternion Structure
Equals Overload


Quaternion.GetHashCode Method

QuaternionGetHashCode Method

Returns a hash code for this instance.

Namespace: Assimp
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public override int GetHashCode()

Return Value

Type: Int32
A hash code for this instance, suitable for use in hashing algorithms and data structures like a hash table.
See Also

Reference

Quaternion Structure


Quaternion.GetMatrix Method

QuaternionGetMatrix Method

Returns a matrix representation of the quaternion.

Namespace: Assimp
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public Matrix3x3 GetMatrix()

Return Value

Type: Matrix3x3
Rotation matrix representing the quaternion.
See Also

Reference

Quaternion Structure


Quaternion.Normalize Method

QuaternionNormalize Method

Normalizes the quaternion.

Namespace: Assimp
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public void Normalize()
See Also

Reference

Quaternion Structure


Quaternion.Rotate Method

QuaternionRotate Method

Rotates a point by this quaternion.

Namespace: Assimp
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public static Vector3D Rotate(
    Vector3D pt,
    Quaternion quat
)

Parameters

pt
Type: AssimpVector3D
Point to rotate
quat
Type: AssimpQuaternion
Quaternion representing the rotation

Return Value

Type: Vector3D
Rotated point.
See Also

Reference

Quaternion Structure


Quaternion.Slerp Method

QuaternionSlerp Method

Spherical interpolation between two quaternions.

Namespace: Assimp
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public static Quaternion Slerp(
    Quaternion start,
    Quaternion end,
    float factor
)

Parameters

start
Type: AssimpQuaternion
Start rotation when factor == 0
end
Type: AssimpQuaternion
End rotation when factor == 1
factor
Type: SystemSingle
Interpolation factor between 0 and 1, values beyond this range yield undefined values

Return Value

Type: Quaternion
Interpolated quaternion.
See Also

Reference

Quaternion Structure


Quaternion.ToString Method

QuaternionToString Method

Returns a String that represents this instance.

Namespace: Assimp
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public override string ToString()

Return Value

Type: String
A String that represents this instance.
See Also

Reference

Quaternion Structure


Quaternion Operators

The Quaternion type exposes the following members.

Operators
Name | Description
Equality | Tests equality between two quaternions.
Inequality | Tests inequality between two quaternions.
Multiply | Multiplies two quaternions.
Top
See Also

Reference

Quaternion Structure


Quaternion.Equality Operator

QuaternionEquality Operator

Tests equality between two quaternions.

Namespace: Assimp
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public static bool operator ==(
    Quaternion a,
    Quaternion b
)

Parameters

a
Type: AssimpQuaternion
First quaternion
b
Type: AssimpQuaternion
Second quaternion

Return Value

Type: Boolean
True if the quaternions are equal, false otherwise.
See Also

Reference

Quaternion Structure


Quaternion.Inequality Operator

QuaternionInequality Operator

Tests inequality between two quaternions.

Namespace: Assimp
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public static bool operator !=(
    Quaternion a,
    Quaternion b
)

Parameters

a
Type: AssimpQuaternion
First quaternion
b
Type: AssimpQuaternion
Second quaternion

Return Value

Type: Boolean
True if the quaternions are not equal, false otherwise.
See Also

Reference

Quaternion Structure


Quaternion.Multiply Operator

QuaternionMultiply Operator

Multiplies two quaternions.

Namespace: Assimp
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public static Quaternion operator *(
    Quaternion a,
    Quaternion b
)

Parameters

a
Type: AssimpQuaternion
First quaternion
b
Type: AssimpQuaternion
Second quaternion

Return Value

Type: Quaternion
Resulting quaternion
See Also

Reference

Quaternion Structure


Quaternion Fields

The Quaternion type exposes the following members.

Fields
 | Name | Description
Public field | W | Rotation component of the quaternion/
Public field | X | X component of the vector part of the quaternion.
Public field | Y | Y component of the vector part of the quaternion.
Public field | Z | Z component of the vector part of the quaternion.
Top
See Also

Reference

Quaternion Structure


Quaternion.W Field

QuaternionW Field

Rotation component of the quaternion/

Namespace: Assimp
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public float W

Field Value

Type: Single
See Also

Reference

Quaternion Structure


Quaternion.X Field

QuaternionX Field

X component of the vector part of the quaternion.

Namespace: Assimp
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public float X

Field Value

Type: Single
See Also

Reference

Quaternion Structure


Quaternion.Y Field

QuaternionY Field

Y component of the vector part of the quaternion.

Namespace: Assimp
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public float Y

Field Value

Type: Single
See Also

Reference

Quaternion Structure


Quaternion.Z Field

QuaternionZ Field

Z component of the vector part of the quaternion.

Namespace: Assimp
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public float Z

Field Value

Type: Single
See Also

Reference

Quaternion Structure


QuaternionKey Structure

Time-value pair specifying a rotation for a given time.

Namespace: Assimp
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public struct QuaternionKey : IEquatable<QuaternionKey>

The QuaternionKey type exposes the following members.

Constructors
 | Name | Description
Public method | QuaternionKey | Constructs a new QuaternionKey.
Top
Methods
 | Name | Description
Public method | Equals(Object) | Determines whether the specified Object is equal to this instance. (Overrides ValueTypeEquals(Object).)
Public method | Equals(QuaternionKey) | Tests equality between this key and another.
Public method | GetHashCode | Returns a hash code for this instance. (Overrides ValueTypeGetHashCode.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents this instance. (Overrides ValueTypeToString.)
Top
Operators
Name | Description
Equality | Tests equality between two keys.
GreaterThan | Tests inequality between two keys.
Inequality | Tests inequality between two keys.
LessThan | Tests inequality between two keys.
Top
Fields
 | Name | Description
Public field | Time | The time of this key.
Public field | Value | The rotation of this key.
Top
See Also

Reference


QuaternionKey Constructor

Constructs a new QuaternionKey.

Namespace: Assimp
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public QuaternionKey(
    double time,
    Quaternion rot
)

Parameters

time
Type: SystemDouble
Time of the key.
rot
Type: AssimpQuaternion
Quaternion rotation at the time frame.
See Also

Reference

QuaternionKey Structure


QuaternionKey Methods

The QuaternionKey type exposes the following members.

Methods
 | Name | Description
Public method | Equals(Object) | Determines whether the specified Object is equal to this instance. (Overrides ValueTypeEquals(Object).)
Public method | Equals(QuaternionKey) | Tests equality between this key and another.
Public method | GetHashCode | Returns a hash code for this instance. (Overrides ValueTypeGetHashCode.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents this instance. (Overrides ValueTypeToString.)
Top
See Also

Reference

QuaternionKey Structure


QuaternionKey.Equals Method

QuaternionKeyEquals Method

Overload List
 | Name | Description
Public method | Equals(Object) | Determines whether the specified Object is equal to this instance. (Overrides ValueTypeEquals(Object).)
Public method | Equals(QuaternionKey) | Tests equality between this key and another.
Top
See Also

Reference

QuaternionKey Structure


QuaternionKey.Equals Method (Object)

QuaternionKeyEquals Method (Object)

Determines whether the specified Object is equal to this instance.

Namespace: Assimp
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public override bool Equals(
    Object obj
)

Parameters

obj
Type: SystemObject
The Object to compare with this instance.

Return Value

Type: Boolean
true if the specified Object is equal to this instance; otherwise, false.
See Also

Reference

QuaternionKey Structure
Equals Overload


QuaternionKey.Equals Method (QuaternionKey)

QuaternionKeyEquals Method (QuaternionKey)

Tests equality between this key and another.

Namespace: Assimp
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public bool Equals(
    QuaternionKey key
)

Parameters

key
Type: AssimpQuaternionKey
Other key to test

Return Value

Type: Boolean
True if their rotations are equal.

Implements

IEquatableTEquals(T)
See Also

Reference

QuaternionKey Structure
Equals Overload


QuaternionKey.GetHashCode Method

QuaternionKeyGetHashCode Method

Returns a hash code for this instance.

Namespace: Assimp
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public override int GetHashCode()

Return Value

Type: Int32
A hash code for this instance, suitable for use in hashing algorithms and data structures like a hash table.
See Also

Reference

QuaternionKey Structure


QuaternionKey.ToString Method

QuaternionKeyToString Method

Returns a String that represents this instance.

Namespace: Assimp
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public override string ToString()

Return Value

Type: String
A String that represents this instance.
See Also

Reference

QuaternionKey Structure


QuaternionKey Operators

The QuaternionKey type exposes the following members.

Operators
Name | Description
Equality | Tests equality between two keys.
GreaterThan | Tests inequality between two keys.
Inequality | Tests inequality between two keys.
LessThan | Tests inequality between two keys.
Top
See Also

Reference

QuaternionKey Structure


QuaternionKey.Equality Operator

QuaternionKeyEquality Operator

Tests equality between two keys.

Namespace: Assimp
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public static bool operator ==(
    QuaternionKey a,
    QuaternionKey b
)

Parameters

a
Type: AssimpQuaternionKey
The first key
b
Type: AssimpQuaternionKey
The second key

Return Value

Type: Boolean
True if the key's rotations are the same, false otherwise.
See Also

Reference

QuaternionKey Structure


QuaternionKey.GreaterThan Operator

QuaternionKeyGreaterThan Operator

Tests inequality between two keys.

Namespace: Assimp
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public static bool operator >(
    QuaternionKey a,
    QuaternionKey b
)

Parameters

a
Type: AssimpQuaternionKey
The first key
b
Type: AssimpQuaternionKey
The second key

Return Value

Type: Boolean
True if the first key's time is greater than the second key's.
See Also

Reference

QuaternionKey Structure


QuaternionKey.Inequality Operator

QuaternionKeyInequality Operator

Tests inequality between two keys.

Namespace: Assimp
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public static bool operator !=(
    QuaternionKey a,
    QuaternionKey b
)

Parameters

a
Type: AssimpQuaternionKey
The first key
b
Type: AssimpQuaternionKey
The second key

Return Value

Type: Boolean
True if the key's rotations are not the same, false otherwise.
See Also

Reference

QuaternionKey Structure


QuaternionKey.LessThan Operator

QuaternionKeyLessThan Operator

Tests inequality between two keys.

Namespace: Assimp
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public static bool operator <(
    QuaternionKey a,
    QuaternionKey b
)

Parameters

a
Type: AssimpQuaternionKey
The first key
b
Type: AssimpQuaternionKey
The second key

Return Value

Type: Boolean
True if the first key's time is less than the second key's.
See Also

Reference

QuaternionKey Structure


QuaternionKey Fields

The QuaternionKey type exposes the following members.

Fields
 | Name | Description
Public field | Time | The time of this key.
Public field | Value | The rotation of this key.
Top
See Also

Reference

QuaternionKey Structure


QuaternionKey.Time Field

QuaternionKeyTime Field

The time of this key.

Namespace: Assimp
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public double Time

Field Value

Type: Double
See Also

Reference

QuaternionKey Structure


QuaternionKey.Value Field

QuaternionKeyValue Field

The rotation of this key.

Namespace: Assimp
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public Quaternion Value

Field Value

Type: Quaternion
See Also

Reference

QuaternionKey Structure


Ray Structure

Defines a 3D ray with a point of origin and a direction.

Namespace: Assimp
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public struct Ray

The Ray type exposes the following members.

Constructors
 | Name | Description
Public method | Ray | Constructs a new Ray.
Top
Methods
 | Name | Description
Public method | Equals | Indicates whether this instance and a specified object are equal. (Inherited from ValueType.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from ValueType.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns the fully qualified type name of this instance. (Inherited from ValueType.)
Top
Fields
 | Name | Description
Public field | Direction | Direction of the ray.
Public field | Position | Origin of the ray in space.
Top
See Also

Reference


Ray Constructor

Constructs a new Ray.

Namespace: Assimp
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public Ray(
    Vector3D pos,
    Vector3D dir
)

Parameters

pos
Type: AssimpVector3D
Origin of the ray.
dir
Type: AssimpVector3D
Direction of the ray.
See Also

Reference

Ray Structure


Ray Methods

The Ray type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Indicates whether this instance and a specified object are equal. (Inherited from ValueType.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from ValueType.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns the fully qualified type name of this instance. (Inherited from ValueType.)
Top
See Also

Reference

Ray Structure


Ray Fields

The Ray type exposes the following members.

Fields
 | Name | Description
Public field | Direction | Direction of the ray.
Public field | Position | Origin of the ray in space.
Top
See Also

Reference

Ray Structure


Ray.Direction Field

RayDirection Field

Direction of the ray.

Namespace: Assimp
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public Vector3D Direction

Field Value

Type: Vector3D
See Also

Reference

Ray Structure


Ray.Position Field

RayPosition Field

Origin of the ray in space.

Namespace: Assimp
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public Vector3D Position

Field Value

Type: Vector3D
See Also

Reference

Ray Structure


ReturnCode Enumeration

Enumerates Assimp function result codes.

Namespace: Assimp
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public enum ReturnCode
Members
Member name | Value | Description
Success | 0 | Function returned successfully.
Failure | -1 | There was an error.
OutOfMemory | -3 | Assimp ran out of memory.
See Also

Reference


Scene Class

Represents a completely imported model or scene. Everything that was imported from the given file can be accessed from here. Once the scene is loaded from unmanaged memory, it resides solely in managed memory and Assimp's read only copy is released.
Inheritance Hierarchy
SystemObject
AssimpScene

Namespace: Assimp
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public sealed class Scene : IMarshalable<Scene, AiScene>

The Scene type exposes the following members.

Constructors
 | Name | Description
Public method | Scene | Constructs a new instance of the Scene class.
Top
Properties
 | Name | Description
Public property | AnimationCount | Gets the number of animations in the scene.
Public property | Animations | Gets the animations in the scene, if any.
Public property | CameraCount | Gets the number of cameras in the scene.
Public property | Cameras | Gets the cameras in the scene, if any.
Public property | HasAnimations | Gets if the scene contains any animations.
Public property | HasCameras | Gets if the scene contains any cameras.
Public property | HasLights | Gets if the scene contains any lights.
Public property | HasMaterials | Gets if the scene contains any materials. There should always be at least the default Assimp material if no materials were loaded.
Public property | HasMeshes | Gets if the scene contains meshes. Unless if no special scene flags are set this should always be true.
Public property | HasTextures | Gets if the scene contains embedded textures.
Public property | LightCount | Gets the number of lights in the scene.
Public property | Lights | Gets the lights in the scene, if any.
Public property | MaterialCount | Gets the number of materials in the scene. There should always be at least the default Assimp material if no materials were loaded.
Public property | Materials | Gets the materials in the scene.
Public property | MeshCount | Gets the number of meshes in the scene.
Public property | Meshes | Gets the meshes contained in the scene, if any.
Public property | RootNode | Gets or sets the root node of the scene graph. There will always be at least the root node if the import was successful and no special flags have been set. Presence of further nodes depends on the format and content of the imported file.
Public property | SceneFlags | Gets or sets the state of the imported scene. By default no flags are set, but issues can arise if the flag is set to incomplete.
Public property | TextureCount | Gets the number of embedded textures in the scene.
Public property | Textures | Gets the embedded textures in the scene, if any.
Top
Methods
 | Name | Description
Public method | Clear | Clears the scene of all components.
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
 | FreeNative | Frees unmanaged memory created by ToNative(IntPtr, Native).
 | FreeUnmanagedScene | Frees unmanaged memory allocated -ONLY- in ToUnmanagedScene(Scene). To free an unmanaged scene allocated by the unmanaged Assimp library, call the appropiate ReleaseImport(IntPtr) function.
 | FromUnmanagedScene | Marshals an unmanaged scene to managed memory. This does not free the unmanaged memory.
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
 | ToUnmanagedScene | Marshals a managed scene to unmanaged memory. The unmanaged memory must be freed with a call to FreeUnmanagedScene(IntPtr), the memory is owned by AssimpNet and cannot be freed by the native library.
Top
See Also

Reference


Scene Constructor

Constructs a new instance of the Scene class.

Namespace: Assimp
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public Scene()
See Also

Reference

Scene Class


Scene Properties

The Scene type exposes the following members.

Properties
 | Name | Description
Public property | AnimationCount | Gets the number of animations in the scene.
Public property | Animations | Gets the animations in the scene, if any.
Public property | CameraCount | Gets the number of cameras in the scene.
Public property | Cameras | Gets the cameras in the scene, if any.
Public property | HasAnimations | Gets if the scene contains any animations.
Public property | HasCameras | Gets if the scene contains any cameras.
Public property | HasLights | Gets if the scene contains any lights.
Public property | HasMaterials | Gets if the scene contains any materials. There should always be at least the default Assimp material if no materials were loaded.
Public property | HasMeshes | Gets if the scene contains meshes. Unless if no special scene flags are set this should always be true.
Public property | HasTextures | Gets if the scene contains embedded textures.
Public property | LightCount | Gets the number of lights in the scene.
Public property | Lights | Gets the lights in the scene, if any.
Public property | MaterialCount | Gets the number of materials in the scene. There should always be at least the default Assimp material if no materials were loaded.
Public property | Materials | Gets the materials in the scene.
Public property | MeshCount | Gets the number of meshes in the scene.
Public property | Meshes | Gets the meshes contained in the scene, if any.
Public property | RootNode | Gets or sets the root node of the scene graph. There will always be at least the root node if the import was successful and no special flags have been set. Presence of further nodes depends on the format and content of the imported file.
Public property | SceneFlags | Gets or sets the state of the imported scene. By default no flags are set, but issues can arise if the flag is set to incomplete.
Public property | TextureCount | Gets the number of embedded textures in the scene.
Public property | Textures | Gets the embedded textures in the scene, if any.
Top
See Also

Reference

Scene Class


Scene.AnimationCount Property

SceneAnimationCount Property

Gets the number of animations in the scene.

Namespace: Assimp
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public int AnimationCount { get; }

Property Value

Type: Int32
See Also

Reference

Scene Class


Scene.Animations Property

SceneAnimations Property

Gets the animations in the scene, if any.

Namespace: Assimp
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public List Animations { get; }

Property Value

Type: ListT
See Also

Reference

Scene Class


Scene.CameraCount Property

SceneCameraCount Property

Gets the number of cameras in the scene.

Namespace: Assimp
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public int CameraCount { get; }

Property Value

Type: Int32
See Also

Reference

Scene Class


Scene.Cameras Property

SceneCameras Property

Gets the cameras in the scene, if any.

Namespace: Assimp
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public List Cameras { get; }

Property Value

Type: ListT
See Also

Reference

Scene Class


Scene.HasAnimations Property

SceneHasAnimations Property

Gets if the scene contains any animations.

Namespace: Assimp
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public bool HasAnimations { get; }

Property Value

Type: Boolean
See Also

Reference

Scene Class


Scene.HasCameras Property

SceneHasCameras Property

Gets if the scene contains any cameras.

Namespace: Assimp
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public bool HasCameras { get; }

Property Value

Type: Boolean
See Also

Reference

Scene Class


Scene.HasLights Property

SceneHasLights Property

Gets if the scene contains any lights.

Namespace: Assimp
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public bool HasLights { get; }

Property Value

Type: Boolean
See Also

Reference

Scene Class


Scene.HasMaterials Property

SceneHasMaterials Property

Gets if the scene contains any materials. There should always be at least the default Assimp material if no materials were loaded.

Namespace: Assimp
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public bool HasMaterials { get; }

Property Value

Type: Boolean
See Also

Reference

Scene Class


Scene.HasMeshes Property

SceneHasMeshes Property

Gets if the scene contains meshes. Unless if no special scene flags are set this should always be true.

Namespace: Assimp
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public bool HasMeshes { get; }

Property Value

Type: Boolean
See Also

Reference

Scene Class


Scene.HasTextures Property

SceneHasTextures Property

Gets if the scene contains embedded textures.

Namespace: Assimp
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public bool HasTextures { get; }

Property Value

Type: Boolean
See Also

Reference

Scene Class


Scene.LightCount Property

SceneLightCount Property

Gets the number of lights in the scene.

Namespace: Assimp
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public int LightCount { get; }

Property Value

Type: Int32
See Also

Reference

Scene Class


Scene.Lights Property

SceneLights Property

Gets the lights in the scene, if any.

Namespace: Assimp
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public List Lights { get; }

Property Value

Type: ListT
See Also

Reference

Scene Class


Scene.MaterialCount Property

SceneMaterialCount Property

Gets the number of materials in the scene. There should always be at least the default Assimp material if no materials were loaded.

Namespace: Assimp
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public int MaterialCount { get; }

Property Value

Type: Int32
See Also

Reference

Scene Class


Scene.Materials Property

SceneMaterials Property

Gets the materials in the scene.

Namespace: Assimp
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public List Materials { get; }

Property Value

Type: ListT
See Also

Reference

Scene Class


Scene.MeshCount Property

SceneMeshCount Property

Gets the number of meshes in the scene.

Namespace: Assimp
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public int MeshCount { get; }

Property Value

Type: Int32
See Also

Reference

Scene Class


Scene.Meshes Property

SceneMeshes Property

Gets the meshes contained in the scene, if any.

Namespace: Assimp
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public List Meshes { get; }

Property Value

Type: ListT
See Also

Reference

Scene Class


Scene.RootNode Property

SceneRootNode Property

Gets or sets the root node of the scene graph. There will always be at least the root node if the import was successful and no special flags have been set. Presence of further nodes depends on the format and content of the imported file.

Namespace: Assimp
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public Node RootNode { get; set; }

Property Value

Type: Node
See Also

Reference

Scene Class


Scene.SceneFlags Property

SceneSceneFlags Property

Gets or sets the state of the imported scene. By default no flags are set, but issues can arise if the flag is set to incomplete.

Namespace: Assimp
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public SceneFlags SceneFlags { get; set; }

Property Value

Type: SceneFlags
See Also

Reference

Scene Class


Scene.TextureCount Property

SceneTextureCount Property

Gets the number of embedded textures in the scene.

Namespace: Assimp
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public int TextureCount { get; }

Property Value

Type: Int32
See Also

Reference

Scene Class


Scene.Textures Property

SceneTextures Property

Gets the embedded textures in the scene, if any.

Namespace: Assimp
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public List Textures { get; }

Property Value

Type: ListT
See Also

Reference

Scene Class


Scene Methods

The Scene type exposes the following members.

Methods
 | Name | Description
Public method | Clear | Clears the scene of all components.
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
 | FreeNative | Frees unmanaged memory created by ToNative(IntPtr, Native).
 | FreeUnmanagedScene | Frees unmanaged memory allocated -ONLY- in ToUnmanagedScene(Scene). To free an unmanaged scene allocated by the unmanaged Assimp library, call the appropiate ReleaseImport(IntPtr) function.
 | FromUnmanagedScene | Marshals an unmanaged scene to managed memory. This does not free the unmanaged memory.
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
 | ToUnmanagedScene | Marshals a managed scene to unmanaged memory. The unmanaged memory must be freed with a call to FreeUnmanagedScene(IntPtr), the memory is owned by AssimpNet and cannot be freed by the native library.
Top
See Also

Reference

Scene Class


Scene.Clear Method

SceneClear Method

Clears the scene of all components.

Namespace: Assimp
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public void Clear()
See Also

Reference

Scene Class


Scene.FreeNative Method

SceneFreeNative Method

Frees unmanaged memory created by ToNative(IntPtr, Native).

Namespace: Assimp
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public static void FreeNative(
    IntPtr nativeValue,
    bool freeNative
)

Parameters

nativeValue
Type: SystemIntPtr
Native value to free
freeNative
Type: SystemBoolean
True if the unmanaged memory should be freed, false otherwise.
See Also

Reference

Scene Class


Scene.FreeUnmanagedScene Method

SceneFreeUnmanagedScene Method

Frees unmanaged memory allocated -ONLY- in ToUnmanagedScene(Scene). To free an unmanaged scene allocated by the unmanaged Assimp library, call the appropiate ReleaseImport(IntPtr) function.

Namespace: Assimp
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public static void FreeUnmanagedScene(
    IntPtr scenePtr
)

Parameters

scenePtr
Type: SystemIntPtr
Pointer to unmanaged scene data.
See Also

Reference

Scene Class


Scene.FromUnmanagedScene Method

SceneFromUnmanagedScene Method

Marshals an unmanaged scene to managed memory. This does not free the unmanaged memory.

Namespace: Assimp
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public static Scene FromUnmanagedScene(
    IntPtr scenePtr
)

Parameters

scenePtr
Type: SystemIntPtr
The unmanaged scene data

Return Value

Type: Scene
The managed scene, or null if the pointer is NULL
See Also

Reference

Scene Class


Scene.ToUnmanagedScene Method

SceneToUnmanagedScene Method

Marshals a managed scene to unmanaged memory. The unmanaged memory must be freed with a call to FreeUnmanagedScene(IntPtr), the memory is owned by AssimpNet and cannot be freed by the native library.

Namespace: Assimp
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public static IntPtr ToUnmanagedScene(
    Scene scene
)

Parameters

scene
Type: AssimpScene
Scene data

Return Value

Type: IntPtr
Unmanaged scene or NULL if the scene is null.
See Also

Reference

Scene Class


SceneFlags Enumeration

Defines the state of the imported scene data structure.

Namespace: Assimp
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
[FlagsAttribute]
public enum SceneFlags
Members
Member name | Value | Description
None | 0 | Default state of the scene, it imported successfully.
Incomplete | 1 | Specifies that the scene data structure that was imported is not complete. This flag bypasses some internal validations and allows the import of animation skeletons, material libaries, or camera animation paths using Assimp. Most applications won't support such data.
Validated | 2 | This flag is set by the ValidateDataStructure post process step if validation is successful. In a validated scene you can be sure that any cross references in the data structure (e.g. vertex indices) are valid.
ValidationWarning | 4 | This flag is set by the ValidateDataStructure post process step if validation is successful, but some issues have been found. This can for example mean that a texture that does not exist is referenced by a material or that the bone weights for a vertex do not sum to 1.0. In most cases you should still be able to use the import. This flag can be useful for applications which do not capture Assimp's log output.
NonVerboseFormat | 8 | This flag is set by the JoinIdenticalVertices post process step. It indicates that the vertices of the output mesh are not in the internal verbose format anymore. In the verbose format, all vertices are unique where no vertex is ever referenced by more than one face.
Terrain | 16 | Denotes the scene is pure height-map terrain data. Pure terrains usually consist of quads, sometimes triangles, in a regular grid. The x,y coordinates of all vertex positions refer to the x,y coordinates on the terrain height map, the z-axis stores the elevation at a specific point. TER (Terragen) and HMP (3D Game Studio) are height map formats.
AllowShared | 32 | Specifies that the scene data can be shared between structures. For example: one vertex in a few faces. This differs from NonVerboseFormat as that has internal meanings about postprocessing steps.
See Also

Reference


ShadingMode Enumeration

Defines all shading models supported by the library.

The list of shading modes has been taken from Blender. See Blender documentation for more information.

Namespace: Assimp
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public enum ShadingMode
Members
Member name | Value | Description
None | 0 | No shading mode defined.
Flat | 1 | Flat shading. Shading is done on a per-face basis and is diffuse only. Also known as 'faceted shading'.
Gouraud | 2 | Simple Gouraud shading.
Phong | 3 | Phong Shading.
Blinn | 4 | Phong-Blinn Shading.
Toon | 5 | Toon-shading, also known as a 'comic' shader.
OrenNayar | 6 | OrenNayer shading model. Extension to standard Lambertian shading, taking the roughness of the material into account.
Minnaert | 7 | Minnaert shading model. Extension to standard Lambertian shading, taking the "darkness" of the material into account.
CookTorrance | 8 | CookTorrance shading model. Special shader for metallic surfaces.
NoShading | 9 | No shading at all. Constant light influence of 1.0.
Fresnel | 10 | Fresnel shading.
See Also

Reference


Texel Structure

Represents a texel in ARGB8888 format.

Namespace: Assimp
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public struct Texel : IEquatable<Texel>

The Texel type exposes the following members.

Constructors
 | Name | Description
Public method | Texel | Constructs a new Texel.
Top
Methods
 | Name | Description
Public method | Equals(Object) | Determines whether the specified Object is equal to this instance. (Overrides ValueTypeEquals(Object).)
Public method | Equals(Texel) | Tests equality between this key and another.
Public method | GetHashCode | Returns a hash code for this instance. (Overrides ValueTypeGetHashCode.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents this instance. (Overrides ValueTypeToString.)
Top
Operators
Name | Description
Equality | Tests equality between two texels.
(Texel to Color4D) | Implicitly converts a texel to a Color4D.
Inequality | Tests inequality between two texels.
Top
Fields
 | Name | Description
Public field | A | Alpha component.
Public field | B | Blue component.
Public field | G | Green component.
Public field | R | Red component.
Top
See Also

Reference


Texel Constructor

Constructs a new Texel.

Namespace: Assimp
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public Texel(
    byte b,
    byte g,
    byte r,
    byte a
)

Parameters

b
Type: SystemByte
Blue component.
g
Type: SystemByte
Green component.
r
Type: SystemByte
Red component.
a
Type: SystemByte
Alpha component.
See Also

Reference

Texel Structure


Texel Methods

The Texel type exposes the following members.

Methods
 | Name | Description
Public method | Equals(Object) | Determines whether the specified Object is equal to this instance. (Overrides ValueTypeEquals(Object).)
Public method | Equals(Texel) | Tests equality between this key and another.
Public method | GetHashCode | Returns a hash code for this instance. (Overrides ValueTypeGetHashCode.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents this instance. (Overrides ValueTypeToString.)
Top
See Also

Reference

Texel Structure


Texel.Equals Method

TexelEquals Method

Overload List
 | Name | Description
Public method | Equals(Object) | Determines whether the specified Object is equal to this instance. (Overrides ValueTypeEquals(Object).)
Public method | Equals(Texel) | Tests equality between this key and another.
Top
See Also

Reference

Texel Structure


Texel.Equals Method (Object)

TexelEquals Method (Object)

Determines whether the specified Object is equal to this instance.

Namespace: Assimp
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public override bool Equals(
    Object obj
)

Parameters

obj
Type: SystemObject
The Object to compare with this instance.

Return Value

Type: Boolean
true if the specified Object is equal to this instance; otherwise, false.
See Also

Reference

Texel Structure
Equals Overload


Texel.Equals Method (Texel)

TexelEquals Method (Texel)

Tests equality between this key and another.

Namespace: Assimp
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public bool Equals(
    Texel other
)

Parameters

other
Type: AssimpTexel
Other key to test

Return Value

Type: Boolean
True if their indices are equal

Implements

IEquatableTEquals(T)
See Also

Reference

Texel Structure
Equals Overload


Texel.GetHashCode Method

TexelGetHashCode Method

Returns a hash code for this instance.

Namespace: Assimp
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public override int GetHashCode()

Return Value

Type: Int32
A hash code for this instance, suitable for use in hashing algorithms and data structures like a hash table.
See Also

Reference

Texel Structure


Texel.ToString Method

TexelToString Method

Returns a String that represents this instance.

Namespace: Assimp
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public override string ToString()

Return Value

Type: String
A String that represents this instance.
See Also

Reference

Texel Structure


Texel Operators and Type Conversions

The Texel type exposes the following members.

Operators
Name | Description
Equality | Tests equality between two texels.
(Texel to Color4D) | Implicitly converts a texel to a Color4D.
Inequality | Tests inequality between two texels.
Top
See Also

Reference

Texel Structure


Texel.Equality Operator

TexelEquality Operator

Tests equality between two texels.

Namespace: Assimp
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public static bool operator ==(
    Texel a,
    Texel b
)

Parameters

a
Type: AssimpTexel
First texel
b
Type: AssimpTexel
Second texel

Return Value

Type: Boolean
True if the texels are equal, false otherwise.
See Also

Reference

Texel Structure


Texel Implicit Conversion (Texel to Color4D)

Texel Conversion (Texel to Color4D)

Implicitly converts a texel to a Color4D.

Namespace: Assimp
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public static implicit operator Color4D (
    Texel texel
)

Parameters

texel
Type: AssimpTexel
Texel to convert

Return Value

Type: Color4D
Converted Color4D
See Also

Reference

Texel Structure


Texel.Inequality Operator

TexelInequality Operator

Tests inequality between two texels.

Namespace: Assimp
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public static bool operator !=(
    Texel a,
    Texel b
)

Parameters

a
Type: AssimpTexel
First texel
b
Type: AssimpTexel
Second texel

Return Value

Type: Boolean
True if the texels are not equal, false otherwise.
See Also

Reference

Texel Structure


Texel Fields

The Texel type exposes the following members.

Fields
 | Name | Description
Public field | A | Alpha component.
Public field | B | Blue component.
Public field | G | Green component.
Public field | R | Red component.
Top
See Also

Reference

Texel Structure


Texel.A Field

TexelA Field

Alpha component.

Namespace: Assimp
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public byte A

Field Value

Type: Byte
See Also

Reference

Texel Structure


Texel.B Field

TexelB Field

Blue component.

Namespace: Assimp
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public byte B

Field Value

Type: Byte
See Also

Reference

Texel Structure


Texel.G Field

TexelG Field

Green component.

Namespace: Assimp
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public byte G

Field Value

Type: Byte
See Also

Reference

Texel Structure


Texel.R Field

TexelR Field

Red component.

Namespace: Assimp
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public byte R

Field Value

Type: Byte
See Also

Reference

Texel Structure


TextureFlags Enumeration

Defines some mixed flags for a particular texture. This corresponds to the AI_MAT_KEY_TEXFLAGS property.

Namespace: Assimp
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
[FlagsAttribute]
public enum TextureFlags
Members
Member name | Value | Description
Invert | 1 | The texture's color values have to be inverted (componentwise 1-n).
UseAlpha | 2 | Explicit request to the application to process the alpha channel of the texture. This is mutually exclusive with IgnoreAlpha. These flags are set if the library can say for sure that the alpha channel is used/is not used. If the model format does not define this, iti s left to the application to decide whether the texture alpha channel - if any - is evaluated or not.
IgnoreAlpha | 4 | Explicit request to the application to ignore the alpha channel of the texture. This is mutually exclusive with UseAlpha.
See Also

Reference


TextureMapping Enumeration

Defines how texture coordinates are generated

Real-time applications typically require full UV coordinates. So the use of GenerateUVCoords step is highly recommended. It generates proper UV channels for non-UV mapped objects, as long as an accurate description of how the mapping should look like is given.

Namespace: Assimp
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public enum TextureMapping
Members
Member name | Value | Description
FromUV | 0 | Coordinates are taken from the an existing UV channel. The AI_MATKEY_UVWSRC key specifies from the UV channel the texture coordinates are to be taken from since meshes can have more than one UV channel.
Sphere | 1 | Spherical mapping
Cylinder | 2 | Cylinder mapping
Box | 3 | Cubic mapping
Plane | 4 | Planar mapping
Unknown | 5 | Unknown mapping that is not recognied.
See Also

Reference


TextureOperation Enumeration

Defines how the Nth texture of a specific type is combined with the result of all previous layers.

Example (left: key, right: value):

Copy
DiffColor0     - gray
DiffTextureOp0 - TextureOperation.Multiply
DiffTexture0   - tex1.png
DiffTextureOp0 - TextureOperation.Add
DiffTexture1   - tex2.png

Written as an equation, the final diffuse term for a specific pixel would be:

Copy
diffFinal = DiffColor0 * sampleTex(DiffTexture0, UV0) + sampleTex(DiffTexture1, UV0) * diffContrib;

Namespace: Assimp
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public enum TextureOperation
Members
Member name | Value | Description
Multiply | 0 | T = T1 * T2
Add | 1 | T = T1 + T2
Subtract | 2 | T = T1 - T2
Divide | 3 | T = T1 / T2
SmoothAdd | 4 | T = (T1 + T2) - (T1 * T2)
SignedAdd | 5 | T = T1 + (T2 - 0.5)
See Also

Reference


TextureSlot Structure

Describes all the values pertaining to a particular texture slot in a material.

Namespace: Assimp
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public struct TextureSlot

The TextureSlot type exposes the following members.

Constructors
 | Name | Description
Public method | TextureSlot | Constructs a new TextureSlot.
Top
Methods
 | Name | Description
Public method | Equals | Indicates whether this instance and a specified object are equal. (Inherited from ValueType.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from ValueType.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns the fully qualified type name of this instance. (Inherited from ValueType.)
Top
Fields
 | Name | Description
Public field | BlendFactor | Gets the blend factor.
Public field | FilePath | Gets the texture file path.
Public field | Flags | Gets misc flags.
Public field | Mapping | Gets the texture mapping.
Public field | Operation | Gets the texture operation.
Public field | TextureIndex | Gets the texture index in the material.
Public field | TextureType | Gets the texture type semantic.
Public field | UVIndex | Gets the UV channel index that corresponds to this texture from the mesh.
Public field | WrapModeU | Gets the texture wrap mode for the U coordinate.
Public field | WrapModeV | Gets the texture wrap mode for the V coordinate.
Top
See Also

Reference


TextureSlot Constructor

Constructs a new TextureSlot.

Namespace: Assimp
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public TextureSlot(
    string filePath,
    TextureType typeSemantic,
    int texIndex,
    TextureMapping mapping,
    int uvIndex,
    float blendFactor,
    TextureOperation texOp,
    TextureWrapMode wrapModeU,
    TextureWrapMode wrapModeV,
    int flags
)

Parameters

filePath
Type: SystemString
Texture filepath
typeSemantic
Type: AssimpTextureType
Texture type semantic
texIndex
Type: SystemInt32
Texture index in the material
mapping
Type: AssimpTextureMapping
Texture mapping
uvIndex
Type: SystemInt32
UV channel in mesh that corresponds to this texture
blendFactor
Type: SystemSingle
Blend factor
texOp
Type: AssimpTextureOperation
Texture operation
wrapModeU
Type: AssimpTextureWrapMode
Texture wrap mode for U coordinate
wrapModeV
Type: AssimpTextureWrapMode
Texture wrap mode for V coordinate
flags
Type: SystemInt32
Misc flags
See Also

Reference

TextureSlot Structure


TextureSlot Methods

The TextureSlot type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Indicates whether this instance and a specified object are equal. (Inherited from ValueType.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from ValueType.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns the fully qualified type name of this instance. (Inherited from ValueType.)
Top
See Also

Reference

TextureSlot Structure


TextureSlot Fields

The TextureSlot type exposes the following members.

Fields
 | Name | Description
Public field | BlendFactor | Gets the blend factor.
Public field | FilePath | Gets the texture file path.
Public field | Flags | Gets misc flags.
Public field | Mapping | Gets the texture mapping.
Public field | Operation | Gets the texture operation.
Public field | TextureIndex | Gets the texture index in the material.
Public field | TextureType | Gets the texture type semantic.
Public field | UVIndex | Gets the UV channel index that corresponds to this texture from the mesh.
Public field | WrapModeU | Gets the texture wrap mode for the U coordinate.
Public field | WrapModeV | Gets the texture wrap mode for the V coordinate.
Top
See Also

Reference

TextureSlot Structure


TextureSlot.BlendFactor Field

TextureSlotBlendFactor Field

Gets the blend factor.

Namespace: Assimp
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public float BlendFactor

Field Value

Type: Single
See Also

Reference

TextureSlot Structure


TextureSlot.FilePath Field

TextureSlotFilePath Field

Gets the texture file path.

Namespace: Assimp
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public string FilePath

Field Value

Type: String
See Also

Reference

TextureSlot Structure


TextureSlot.Flags Field

TextureSlotFlags Field

Gets misc flags.

Namespace: Assimp
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public int Flags

Field Value

Type: Int32
See Also

Reference

TextureSlot Structure


TextureSlot.Mapping Field

TextureSlotMapping Field

Gets the texture mapping.

Namespace: Assimp
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public TextureMapping Mapping

Field Value

Type: TextureMapping
See Also

Reference

TextureSlot Structure


TextureSlot.Operation Field

TextureSlotOperation Field

Gets the texture operation.

Namespace: Assimp
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public TextureOperation Operation

Field Value

Type: TextureOperation
See Also

Reference

TextureSlot Structure


TextureSlot.TextureIndex Field

TextureSlotTextureIndex Field

Gets the texture index in the material.

Namespace: Assimp
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public int TextureIndex

Field Value

Type: Int32
See Also

Reference

TextureSlot Structure


TextureSlot.TextureType Field

TextureSlotTextureType Field

Gets the texture type semantic.

Namespace: Assimp
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public TextureType TextureType

Field Value

Type: TextureType
See Also

Reference

TextureSlot Structure


TextureSlot.UVIndex Field

TextureSlotUVIndex Field

Gets the UV channel index that corresponds to this texture from the mesh.

Namespace: Assimp
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public int UVIndex

Field Value

Type: Int32
See Also

Reference

TextureSlot Structure


TextureSlot.WrapModeU Field

TextureSlotWrapModeU Field

Gets the texture wrap mode for the U coordinate.

Namespace: Assimp
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public TextureWrapMode WrapModeU

Field Value

Type: TextureWrapMode
See Also

Reference

TextureSlot Structure


TextureSlot.WrapModeV Field

TextureSlotWrapModeV Field

Gets the texture wrap mode for the V coordinate.

Namespace: Assimp
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public TextureWrapMode WrapModeV

Field Value

Type: TextureWrapMode
See Also

Reference

TextureSlot Structure


TextureType Enumeration

Defines the purpose of a texture.

Namespace: Assimp
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public enum TextureType
Members
Member name | Value | Description
None | 0 | No texture, but the value can be used as a 'texture semantic'.
Diffuse | 1 | A diffuse texture that is combined with the result of the diffuse lighting equation.
Specular | 2 | A specular texture that is combined with the result of the specular lighting equation.
Ambient | 3 | An ambient texture that is combined with the ambient lighting equation.
Emissive | 4 | An emissive texture that is added to the result of the lighting calculation. It is not influenced by incoming light, instead it represents the light that the object is naturally emitting.
Height | 5 | A height map texture. by convention, higher gray-scale values stand for higher elevations from some base height.
Normals | 6 | A tangent-space normal map. There are several conventions for normal maps and Assimp does (intentionally) not distinguish here.
Shininess | 7 | A texture that defines the glossiness of the material. This is the exponent of the specular (phong) lighting equation. Usually there is a conversion function defined to map the linear color values in the texture to a suitable exponent.
Opacity | 8 | The texture defines per-pixel opacity. usually 'white' means opaque and 'black' means 'transparency. Or quite the opposite.
Displacement | 9 | A displacement texture. The exact purpose and format is application-dependent. Higher color values stand for higher vertex displacements.
Lightmap | 10 | A lightmap texture (aka Ambient occlusion). Both 'lightmaps' and dedicated 'ambient occlusion maps' are covered by this material property. The texture contains a scaling value for the final color value of a pixel. Its intensity is not affected by incoming light.
Reflection | 11 | A reflection texture. Contains the color of a perfect mirror reflection. This is rarely used, almost never for real-time applications.
Unknown | 12 | An unknown texture that does not mention any of the defined texture type definitions. It is still imported, but is excluded from any further postprocessing.
See Also

Reference


TextureWrapMode Enumeration

Defines how UV coordinates outside the [0..1] range are handled. Commonly referred to as the 'wrapping mode'

Namespace: Assimp
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public enum TextureWrapMode
Members
Member name | Value | Description
Wrap | 0 | A texture coordinate u|v is translated to u % 1| v % 1.
Clamp | 1 | Texture coordinates outside [0...1] are clamped to the nearest valid value.
Mirror | 2 | A texture coordinate u|v becomes u1|v1 if (u - (u % 1)) % 2 is zero and 1 - (u % 1) | 1 - (v % 1) otherwise.
Decal | 3 | If the texture coordinates for a pixel are outside [0...1] the texture is not applied to that pixel.
See Also

Reference


UVTransform Structure

Defines how an UV channel is transformed.

Namespace: Assimp
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public struct UVTransform

The UVTransform type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Indicates whether this instance and a specified object are equal. (Inherited from ValueType.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from ValueType.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns the fully qualified type name of this instance. (Inherited from ValueType.)
Top
Fields
 | Name | Description
Public field | Rotation | Rotation in counter-clockwise direction, specfied in radians. The rotation center is 0.5f|0.5f and the default value is zero.
Public field | Scaling | Scaling on the U and V axes. Default is 1|1.
Public field | Translation | Translation on the U and V axes. Default is 0|0
Top
See Also

Reference


UVTransform Methods

The UVTransform type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Indicates whether this instance and a specified object are equal. (Inherited from ValueType.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from ValueType.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns the fully qualified type name of this instance. (Inherited from ValueType.)
Top
See Also

Reference

UVTransform Structure


UVTransform Fields

The UVTransform type exposes the following members.

Fields
 | Name | Description
Public field | Rotation | Rotation in counter-clockwise direction, specfied in radians. The rotation center is 0.5f|0.5f and the default value is zero.
Public field | Scaling | Scaling on the U and V axes. Default is 1|1.
Public field | Translation | Translation on the U and V axes. Default is 0|0
Top
See Also

Reference

UVTransform Structure


UVTransform.Rotation Field

UVTransformRotation Field

Rotation in counter-clockwise direction, specfied in radians. The rotation center is 0.5f|0.5f and the default value is zero.

Namespace: Assimp
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public float Rotation

Field Value

Type: Single
See Also

Reference

UVTransform Structure


UVTransform.Scaling Field

UVTransformScaling Field

Scaling on the U and V axes. Default is 1|1.

Namespace: Assimp
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public Vector2D Scaling

Field Value

Type: Vector2D
See Also

Reference

UVTransform Structure


UVTransform.Translation Field

UVTransformTranslation Field

Translation on the U and V axes. Default is 0|0

Namespace: Assimp
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public Vector2D Translation

Field Value

Type: Vector2D
See Also

Reference

UVTransform Structure


UVTransformFlags Enumeration

Defines how UV coordinates should be transformed.

Namespace: Assimp
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
[FlagsAttribute]
public enum UVTransformFlags
Members
Member name | Value | Description
Scaling | 1 | Scaling is evaluated.
Rotation | 2 | Rotation is evaluated.
Translation | 4 | Translation is evaluated.
See Also

Reference


Vector2D Structure

Represents a two-dimensional vector.

Namespace: Assimp
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public struct Vector2D : IEquatable<Vector2D>

The Vector2D type exposes the following members.

Constructors
 | Name | Description
Public method | Vector2D(Single) | Constructs a new Vector2D with both components set the same value.
Public method | Vector2D(Single, Single) | Constructs a new Vector2D.
Top
Properties
 | Name | Description
Public property | Item | Gets or sets the component value at the specified zero-based index in the order of XY (index 0 access X, 1 access Y. If the index is not in range, a value of zero is returned.
Top
Methods
 | Name | Description
Public method | Equals(Object) | Tests equality between this vector and another object. (Overrides ValueTypeEquals(Object).)
Public method | Equals(Vector2D) | Tests equality between this vector and another vector.
Public method | GetHashCode | Returns a hash code for this instance. (Overrides ValueTypeGetHashCode.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Length | Calculates the length of the vector.
Public method | LengthSquared | Calculates the length of the vector squared.
Public method | Negate | Negates the vector.
Public method | Normalize | Normalizes the vector where all components add to one (Unit Vector), but preserves the direction that the vector represents.
Public method | Set | Sets the X and Y values.
Public method | ToString | Returns a String that represents this instance. (Overrides ValueTypeToString.)
Top
Operators
Name | Description
Addition | Adds two vectors together.
Division(Vector2D, Vector2D) | Divides the first vector by the second vector.
Division(Vector2D, Single) | Divides the vector by a divisor value.
Equality | Tests equality between two vectors.
Inequality | Tests inequality between two vectors.
Multiply(Single, Vector2D) | Multiplies a vector by a scalar.
Multiply(Vector2D, Vector2D) | Multiplies two vectors together.
Multiply(Vector2D, Single) | Multiplies a vector by a scalar.
Subtraction | Subtracts the second vector from the first vector.
UnaryNegation | Negates the vector.
Top
Fields
 | Name | Description
Public field | X | X component.
Public field | Y | Y component
Top
See Also

Reference


Vector2D Constructor

Overload List
 | Name | Description
Public method | Vector2D(Single) | Constructs a new Vector2D with both components set the same value.
Public method | Vector2D(Single, Single) | Constructs a new Vector2D.
Top
See Also

Reference

Vector2D Structure


Vector2D Constructor (Single)

Constructs a new Vector2D with both components set the same value.

Namespace: Assimp
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public Vector2D(
    float value
)

Parameters

value
Type: SystemSingle
Value to set both X and Y to
See Also

Reference

Vector2D Structure
Vector2D Overload


Vector2D Constructor (Single, Single)

Constructs a new Vector2D.

Namespace: Assimp
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public Vector2D(
    float x,
    float y
)

Parameters

x
Type: SystemSingle
X component
y
Type: SystemSingle
Y component
See Also

Reference

Vector2D Structure
Vector2D Overload


Vector2D Properties

The Vector2D type exposes the following members.

Properties
 | Name | Description
Public property | Item | Gets or sets the component value at the specified zero-based index in the order of XY (index 0 access X, 1 access Y. If the index is not in range, a value of zero is returned.
Top
See Also

Reference

Vector2D Structure


Vector2D.Item Property

Vector2DItem Property

Gets or sets the component value at the specified zero-based index in the order of XY (index 0 access X, 1 access Y. If the index is not in range, a value of zero is returned.

Namespace: Assimp
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public float this[
    int index
] { get; set; }

Parameters

index
Type: SystemInt32
Zero-based index.

Return Value

Type: Single
The component value
See Also

Reference

Vector2D Structure


Vector2D Methods

The Vector2D type exposes the following members.

Methods
 | Name | Description
Public method | Equals(Object) | Tests equality between this vector and another object. (Overrides ValueTypeEquals(Object).)
Public method | Equals(Vector2D) | Tests equality between this vector and another vector.
Public method | GetHashCode | Returns a hash code for this instance. (Overrides ValueTypeGetHashCode.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Length | Calculates the length of the vector.
Public method | LengthSquared | Calculates the length of the vector squared.
Public method | Negate | Negates the vector.
Public method | Normalize | Normalizes the vector where all components add to one (Unit Vector), but preserves the direction that the vector represents.
Public method | Set | Sets the X and Y values.
Public method | ToString | Returns a String that represents this instance. (Overrides ValueTypeToString.)
Top
See Also

Reference

Vector2D Structure


Vector2D.Equals Method

Vector2DEquals Method

Overload List
 | Name | Description
Public method | Equals(Object) | Tests equality between this vector and another object. (Overrides ValueTypeEquals(Object).)
Public method | Equals(Vector2D) | Tests equality between this vector and another vector.
Top
See Also

Reference

Vector2D Structure


Vector2D.Equals Method (Object)

Vector2DEquals Method (Object)

Tests equality between this vector and another object.

Namespace: Assimp
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public override bool Equals(
    Object obj
)

Parameters

obj
Type: SystemObject
Object to test against

Return Value

Type: Boolean
True if the object is a vector and the components are equal
See Also

Reference

Vector2D Structure
Equals Overload


Vector2D.Equals Method (Vector2D)

Vector2DEquals Method (Vector2D)

Tests equality between this vector and another vector.

Namespace: Assimp
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public bool Equals(
    Vector2D other
)

Parameters

other
Type: AssimpVector2D
Vector to test against

Return Value

Type: Boolean
True if components are equal

Implements

IEquatableTEquals(T)
See Also

Reference

Vector2D Structure
Equals Overload


Vector2D.GetHashCode Method

Vector2DGetHashCode Method

Returns a hash code for this instance.

Namespace: Assimp
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public override int GetHashCode()

Return Value

Type: Int32
A hash code for this instance, suitable for use in hashing algorithms and data structures like a hash table.
See Also

Reference

Vector2D Structure


Vector2D.Length Method

Vector2DLength Method

Calculates the length of the vector.

Namespace: Assimp
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public float Length()

Return Value

Type: Single
Vector's length
See Also

Reference

Vector2D Structure


Vector2D.LengthSquared Method

Vector2DLengthSquared Method

Calculates the length of the vector squared.

Namespace: Assimp
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public float LengthSquared()

Return Value

Type: Single
Vector's length squared
See Also

Reference

Vector2D Structure


Vector2D.Negate Method

Vector2DNegate Method

Negates the vector.

Namespace: Assimp
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public void Negate()
See Also

Reference

Vector2D Structure


Vector2D.Normalize Method

Vector2DNormalize Method

Normalizes the vector where all components add to one (Unit Vector), but preserves the direction that the vector represents.

Namespace: Assimp
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public void Normalize()
See Also

Reference

Vector2D Structure


Vector2D.Set Method

Vector2DSet Method

Sets the X and Y values.

Namespace: Assimp
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public void Set(
    float x,
    float y
)

Parameters

x
Type: SystemSingle
X component
y
Type: SystemSingle
Y component
See Also

Reference

Vector2D Structure


Vector2D.ToString Method

Vector2DToString Method

Returns a String that represents this instance.

Namespace: Assimp
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public override string ToString()

Return Value

Type: String
A String that represents this instance.
See Also

Reference

Vector2D Structure


Vector2D Operators

The Vector2D type exposes the following members.

Operators
Name | Description
Addition | Adds two vectors together.
Division(Vector2D, Vector2D) | Divides the first vector by the second vector.
Division(Vector2D, Single) | Divides the vector by a divisor value.
Equality | Tests equality between two vectors.
Inequality | Tests inequality between two vectors.
Multiply(Single, Vector2D) | Multiplies a vector by a scalar.
Multiply(Vector2D, Vector2D) | Multiplies two vectors together.
Multiply(Vector2D, Single) | Multiplies a vector by a scalar.
Subtraction | Subtracts the second vector from the first vector.
UnaryNegation | Negates the vector.
Top
See Also

Reference

Vector2D Structure


Vector2D.Addition Operator

Vector2DAddition Operator

Adds two vectors together.

Namespace: Assimp
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public static Vector2D operator +(
    Vector2D a,
    Vector2D b
)

Parameters

a
Type: AssimpVector2D
First vector
b
Type: AssimpVector2D
Second vector

Return Value

Type: Vector2D
Added vector
See Also

Reference

Vector2D Structure


Vector2D.Division Operator

Vector2DDivision Operator

Overload List
Name | Description
Division(Vector2D, Vector2D) | Divides the first vector by the second vector.
Division(Vector2D, Single) | Divides the vector by a divisor value.
Top
See Also

Reference

Vector2D Structure


Vector2D.Division Operator (Vector2D, Vector2D)

Vector2DDivision Operator (Vector2D, Vector2D)

Divides the first vector by the second vector.

Namespace: Assimp
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public static Vector2D operator /(
    Vector2D a,
    Vector2D b
)

Parameters

a
Type: AssimpVector2D
First vector
b
Type: AssimpVector2D
Second vector

Return Value

Type: Vector2D
Divided vector
See Also

Reference

Vector2D Structure
Division Overload


Vector2D.Division Operator (Vector2D, Single)

Vector2DDivision Operator (Vector2D, Single)

Divides the vector by a divisor value.

Namespace: Assimp
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public static Vector2D operator /(
    Vector2D value,
    float divisor
)

Parameters

value
Type: AssimpVector2D
Source vector
divisor
Type: SystemSingle
Divisor

Return Value

Type: Vector2D
Divided vector
See Also

Reference

Vector2D Structure
Division Overload


Vector2D.Equality Operator

Vector2DEquality Operator

Tests equality between two vectors.

Namespace: Assimp
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public static bool operator ==(
    Vector2D a,
    Vector2D b
)

Parameters

a
Type: AssimpVector2D
First vector
b
Type: AssimpVector2D
Second vector

Return Value

Type: Boolean
True if the vectors are equal, false otherwise
See Also

Reference

Vector2D Structure


Vector2D.Inequality Operator

Vector2DInequality Operator

Tests inequality between two vectors.

Namespace: Assimp
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public static bool operator !=(
    Vector2D a,
    Vector2D b
)

Parameters

a
Type: AssimpVector2D
First vector
b
Type: AssimpVector2D
Second vector

Return Value

Type: Boolean
True if the vectors are not equal, false otherwise
See Also

Reference

Vector2D Structure


Vector2D.Multiply Operator

Vector2DMultiply Operator

Overload List
Name | Description
Multiply(Single, Vector2D) | Multiplies a vector by a scalar.
Multiply(Vector2D, Vector2D) | Multiplies two vectors together.
Multiply(Vector2D, Single) | Multiplies a vector by a scalar.
Top
See Also

Reference

Vector2D Structure


Vector2D.Multiply Operator (Single, Vector2D)

Vector2DMultiply Operator (Single, Vector2D)

Multiplies a vector by a scalar.

Namespace: Assimp
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public static Vector2D operator *(
    float scale,
    Vector2D value
)

Parameters

scale
Type: SystemSingle
Scalar value
value
Type: AssimpVector2D
Source vector

Return Value

Type: Vector2D
Scaled vector
See Also

Reference

Vector2D Structure
Multiply Overload


Vector2D.Multiply Operator (Vector2D, Vector2D)

Vector2DMultiply Operator (Vector2D, Vector2D)

Multiplies two vectors together.

Namespace: Assimp
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public static Vector2D operator *(
    Vector2D a,
    Vector2D b
)

Parameters

a
Type: AssimpVector2D
First vector
b
Type: AssimpVector2D
Second vector

Return Value

Type: Vector2D
Multiplied vector
See Also

Reference

Vector2D Structure
Multiply Overload


Vector2D.Multiply Operator (Vector2D, Single)

Vector2DMultiply Operator (Vector2D, Single)

Multiplies a vector by a scalar.

Namespace: Assimp
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public static Vector2D operator *(
    Vector2D value,
    float scale
)

Parameters

value
Type: AssimpVector2D
Source vector
scale
Type: SystemSingle
Scalar value

Return Value

Type: Vector2D
Scaled vector
See Also

Reference

Vector2D Structure
Multiply Overload


Vector2D.Subtraction Operator

Vector2DSubtraction Operator

Subtracts the second vector from the first vector.

Namespace: Assimp
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public static Vector2D operator -(
    Vector2D a,
    Vector2D b
)

Parameters

a
Type: AssimpVector2D
First vector
b
Type: AssimpVector2D
Second vector

Return Value

Type: Vector2D
Resulting vector
See Also

Reference

Vector2D Structure


Vector2D.UnaryNegation Operator

Vector2DUnaryNegation Operator

Negates the vector.

Namespace: Assimp
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public static Vector2D operator -(
    Vector2D value
)

Parameters

value
Type: AssimpVector2D
Source vector

Return Value

Type: Vector2D
Negated vector
See Also

Reference

Vector2D Structure


Vector2D Fields

The Vector2D type exposes the following members.

Fields
 | Name | Description
Public field | X | X component.
Public field | Y | Y component
Top
See Also

Reference

Vector2D Structure


Vector2D.X Field

Vector2DX Field

X component.

Namespace: Assimp
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public float X

Field Value

Type: Single
See Also

Reference

Vector2D Structure


Vector2D.Y Field

Vector2DY Field

Y component

Namespace: Assimp
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public float Y

Field Value

Type: Single
See Also

Reference

Vector2D Structure


Vector3D Structure

Represents a three-dimensional vector.

Namespace: Assimp
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public struct Vector3D : IEquatable<Vector3D>

The Vector3D type exposes the following members.

Constructors
 | Name | Description
Public method | Vector3D(Single) | Constructs a new Vector3D where each component is set to the same value.
Public method | Vector3D(Vector2D, Single) | Constructs a new Vector3D.
Public method | Vector3D(Single, Single, Single) | Constructs a new Vector3D.
Top
Properties
 | Name | Description
Public property | Item | Gets or sets the component value at the specified zero-based index in the order of XYZ (index 0 access X, 1 access Y, etc). If the index is not in range, a value of zero is returned.
Top
Methods
 | Name | Description
 | Cross | Calculates the cross product of two vectors.
 | Dot | Calculates the dot product of two vectors.
Public method | Equals(Object) | Tests equality between this vector and another object. (Overrides ValueTypeEquals(Object).)
Public method | Equals(Vector3D) | Tests equality between this vector and another vector.
Public method | GetHashCode | Returns a hash code for this instance. (Overrides ValueTypeGetHashCode.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Length | Calculates the length of the vector.
Public method | LengthSquared | Calculates the length of the vector squared.
Public method | Negate | Negates the vector.
Public method | Normalize | Normalizes the vector where all components add to one (Unit Vector), but preserves the direction that the vector represents.
Public method | Set | Sets the X, Y, and Z values.
Public method | ToString | Returns a String that represents this instance. (Overrides ValueTypeToString.)
Top
Operators
Name | Description
Addition | Adds two vectors together.
Division(Vector3D, Vector3D) | Divides the first vector by the second vector.
Division(Vector3D, Single) | Divides the vector by a divisor value.
Equality | Tests equality between two vectors.
Inequality | Tests inequality between two vectors.
Multiply(Single, Vector3D) | Multiplies a vector by a scalar.
Multiply(Matrix3x3, Vector3D) | Transforms this vector by a 3x3 matrix. This "post-multiplies" the two.
Multiply(Matrix4x4, Vector3D) | Transforms this vector by a 4x4 matrix. This "post-multiplies" the two.
Multiply(Vector3D, Vector3D) | Multiplies two vectors together.
Multiply(Vector3D, Single) | Multiplies a vector by a scalar.
Subtraction | Subtracts the second vector from the first vector.
UnaryNegation | Negates the vector.
Top
Fields
 | Name | Description
Public field | X | X component.
Public field | Y | Y component.
Public field | Z | Z component.
Top
See Also

Reference


Vector3D Constructor

Overload List
 | Name | Description
Public method | Vector3D(Single) | Constructs a new Vector3D where each component is set to the same value.
Public method | Vector3D(Vector2D, Single) | Constructs a new Vector3D.
Public method | Vector3D(Single, Single, Single) | Constructs a new Vector3D.
Top
See Also

Reference

Vector3D Structure


Vector3D Constructor (Single)

Constructs a new Vector3D where each component is set to the same value.

Namespace: Assimp
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public Vector3D(
    float value
)

Parameters

value
Type: SystemSingle
Value to set X, Y, and Z to
See Also

Reference

Vector3D Structure
Vector3D Overload


Vector3D Constructor (Vector2D, Single)

Constructs a new Vector3D.

Namespace: Assimp
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public Vector3D(
    Vector2D value,
    float z
)

Parameters

value
Type: AssimpVector2D
Vector2D containing the X, Y values
z
Type: SystemSingle
Z component
See Also

Reference

Vector3D Structure
Vector3D Overload


Vector3D Constructor (Single, Single, Single)

Constructs a new Vector3D.

Namespace: Assimp
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public Vector3D(
    float x,
    float y,
    float z
)

Parameters

x
Type: SystemSingle
X component
y
Type: SystemSingle
Y component
z
Type: SystemSingle
Z component
See Also

Reference

Vector3D Structure
Vector3D Overload


Vector3D Properties

The Vector3D type exposes the following members.

Properties
 | Name | Description
Public property | Item | Gets or sets the component value at the specified zero-based index in the order of XYZ (index 0 access X, 1 access Y, etc). If the index is not in range, a value of zero is returned.
Top
See Also

Reference

Vector3D Structure


Vector3D.Item Property

Vector3DItem Property

Gets or sets the component value at the specified zero-based index in the order of XYZ (index 0 access X, 1 access Y, etc). If the index is not in range, a value of zero is returned.

Namespace: Assimp
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public float this[
    int index
] { get; set; }

Parameters

index
Type: SystemInt32
Zero-based index.

Return Value

Type: Single
The component value
See Also

Reference

Vector3D Structure


Vector3D Methods

The Vector3D type exposes the following members.

Methods
 | Name | Description
 | Cross | Calculates the cross product of two vectors.
 | Dot | Calculates the dot product of two vectors.
Public method | Equals(Object) | Tests equality between this vector and another object. (Overrides ValueTypeEquals(Object).)
Public method | Equals(Vector3D) | Tests equality between this vector and another vector.
Public method | GetHashCode | Returns a hash code for this instance. (Overrides ValueTypeGetHashCode.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Length | Calculates the length of the vector.
Public method | LengthSquared | Calculates the length of the vector squared.
Public method | Negate | Negates the vector.
Public method | Normalize | Normalizes the vector where all components add to one (Unit Vector), but preserves the direction that the vector represents.
Public method | Set | Sets the X, Y, and Z values.
Public method | ToString | Returns a String that represents this instance. (Overrides ValueTypeToString.)
Top
See Also

Reference

Vector3D Structure


Vector3D.Cross Method

Vector3DCross Method

Calculates the cross product of two vectors.

Namespace: Assimp
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public static Vector3D Cross(
    Vector3D a,
    Vector3D b
)

Parameters

a
Type: AssimpVector3D
First vector
b
Type: AssimpVector3D
Second vector

Return Value

Type: Vector3D
Resulting vector
See Also

Reference

Vector3D Structure


Vector3D.Dot Method

Vector3DDot Method

Calculates the dot product of two vectors.

Namespace: Assimp
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public static float Dot(
    Vector3D a,
    Vector3D b
)

Parameters

a
Type: AssimpVector3D
First vector
b
Type: AssimpVector3D
Second vector

Return Value

Type: Single
Resulting vector
See Also

Reference

Vector3D Structure


Vector3D.Equals Method

Vector3DEquals Method

Overload List
 | Name | Description
Public method | Equals(Object) | Tests equality between this vector and another object. (Overrides ValueTypeEquals(Object).)
Public method | Equals(Vector3D) | Tests equality between this vector and another vector.
Top
See Also

Reference

Vector3D Structure


Vector3D.Equals Method (Object)

Vector3DEquals Method (Object)

Tests equality between this vector and another object.

Namespace: Assimp
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public override bool Equals(
    Object obj
)

Parameters

obj
Type: SystemObject
Object to test against

Return Value

Type: Boolean
True if the object is a vector and the components are equal
See Also

Reference

Vector3D Structure
Equals Overload


Vector3D.Equals Method (Vector3D)

Vector3DEquals Method (Vector3D)

Tests equality between this vector and another vector.

Namespace: Assimp
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public bool Equals(
    Vector3D other
)

Parameters

other
Type: AssimpVector3D
Vector to test against

Return Value

Type: Boolean
True if components are equal

Implements

IEquatableTEquals(T)
See Also

Reference

Vector3D Structure
Equals Overload


Vector3D.GetHashCode Method

Vector3DGetHashCode Method

Returns a hash code for this instance.

Namespace: Assimp
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public override int GetHashCode()

Return Value

Type: Int32
A hash code for this instance, suitable for use in hashing algorithms and data structures like a hash table.
See Also

Reference

Vector3D Structure


Vector3D.Length Method

Vector3DLength Method

Calculates the length of the vector.

Namespace: Assimp
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public float Length()

Return Value

Type: Single
Vector's length
See Also

Reference

Vector3D Structure


Vector3D.LengthSquared Method

Vector3DLengthSquared Method

Calculates the length of the vector squared.

Namespace: Assimp
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public float LengthSquared()

Return Value

Type: Single
Vector's length squared
See Also

Reference

Vector3D Structure


Vector3D.Negate Method

Vector3DNegate Method

Negates the vector.

Namespace: Assimp
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public void Negate()
See Also

Reference

Vector3D Structure


Vector3D.Normalize Method

Vector3DNormalize Method

Normalizes the vector where all components add to one (Unit Vector), but preserves the direction that the vector represents.

Namespace: Assimp
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public void Normalize()
See Also

Reference

Vector3D Structure


Vector3D.Set Method

Vector3DSet Method

Sets the X, Y, and Z values.

Namespace: Assimp
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public void Set(
    float x,
    float y,
    float z
)

Parameters

x
Type: SystemSingle
X component
y
Type: SystemSingle
Y component
z
Type: SystemSingle
Z component
See Also

Reference

Vector3D Structure


Vector3D.ToString Method

Vector3DToString Method

Returns a String that represents this instance.

Namespace: Assimp
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public override string ToString()

Return Value

Type: String
A String that represents this instance.
See Also

Reference

Vector3D Structure


Vector3D Operators

The Vector3D type exposes the following members.

Operators
Name | Description
Addition | Adds two vectors together.
Division(Vector3D, Vector3D) | Divides the first vector by the second vector.
Division(Vector3D, Single) | Divides the vector by a divisor value.
Equality | Tests equality between two vectors.
Inequality | Tests inequality between two vectors.
Multiply(Single, Vector3D) | Multiplies a vector by a scalar.
Multiply(Matrix3x3, Vector3D) | Transforms this vector by a 3x3 matrix. This "post-multiplies" the two.
Multiply(Matrix4x4, Vector3D) | Transforms this vector by a 4x4 matrix. This "post-multiplies" the two.
Multiply(Vector3D, Vector3D) | Multiplies two vectors together.
Multiply(Vector3D, Single) | Multiplies a vector by a scalar.
Subtraction | Subtracts the second vector from the first vector.
UnaryNegation | Negates the vector.
Top
See Also

Reference

Vector3D Structure


Vector3D.Addition Operator

Vector3DAddition Operator

Adds two vectors together.

Namespace: Assimp
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public static Vector3D operator +(
    Vector3D a,
    Vector3D b
)

Parameters

a
Type: AssimpVector3D
First vector
b
Type: AssimpVector3D
Second vector

Return Value

Type: Vector3D
Added vector
See Also

Reference

Vector3D Structure


Vector3D.Division Operator

Vector3DDivision Operator

Overload List
Name | Description
Division(Vector3D, Vector3D) | Divides the first vector by the second vector.
Division(Vector3D, Single) | Divides the vector by a divisor value.
Top
See Also

Reference

Vector3D Structure


Vector3D.Division Operator (Vector3D, Vector3D)

Vector3DDivision Operator (Vector3D, Vector3D)

Divides the first vector by the second vector.

Namespace: Assimp
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public static Vector3D operator /(
    Vector3D a,
    Vector3D b
)

Parameters

a
Type: AssimpVector3D
First vector
b
Type: AssimpVector3D
Second vector

Return Value

Type: Vector3D
Divided vector
See Also

Reference

Vector3D Structure
Division Overload


Vector3D.Division Operator (Vector3D, Single)

Vector3DDivision Operator (Vector3D, Single)

Divides the vector by a divisor value.

Namespace: Assimp
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public static Vector3D operator /(
    Vector3D value,
    float divisor
)

Parameters

value
Type: AssimpVector3D
Source vector
divisor
Type: SystemSingle
Divisor

Return Value

Type: Vector3D
Divided vector
See Also

Reference

Vector3D Structure
Division Overload


Vector3D.Equality Operator

Vector3DEquality Operator

Tests equality between two vectors.

Namespace: Assimp
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public static bool operator ==(
    Vector3D a,
    Vector3D b
)

Parameters

a
Type: AssimpVector3D
First vector
b
Type: AssimpVector3D
Second vector

Return Value

Type: Boolean
True if the vectors are equal, false otherwise
See Also

Reference

Vector3D Structure


Vector3D.Inequality Operator

Vector3DInequality Operator

Tests inequality between two vectors.

Namespace: Assimp
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public static bool operator !=(
    Vector3D a,
    Vector3D b
)

Parameters

a
Type: AssimpVector3D
First vector
b
Type: AssimpVector3D
Second vector

Return Value

Type: Boolean
True if the vectors are not equal, false otherwise
See Also

Reference

Vector3D Structure


Vector3D.Multiply Operator

Vector3DMultiply Operator

Overload List
Name | Description
Multiply(Single, Vector3D) | Multiplies a vector by a scalar.
Multiply(Matrix3x3, Vector3D) | Transforms this vector by a 3x3 matrix. This "post-multiplies" the two.
Multiply(Matrix4x4, Vector3D) | Transforms this vector by a 4x4 matrix. This "post-multiplies" the two.
Multiply(Vector3D, Vector3D) | Multiplies two vectors together.
Multiply(Vector3D, Single) | Multiplies a vector by a scalar.
Top
See Also

Reference

Vector3D Structure


Vector3D.Multiply Operator (Single, Vector3D)

Vector3DMultiply Operator (Single, Vector3D)

Multiplies a vector by a scalar.

Namespace: Assimp
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public static Vector3D operator *(
    float scale,
    Vector3D value
)

Parameters

scale
Type: SystemSingle
Scalar value
value
Type: AssimpVector3D
Source vector

Return Value

Type: Vector3D
Scaled vector
See Also

Reference

Vector3D Structure
Multiply Overload


Vector3D.Multiply Operator (Matrix3x3, Vector3D)

Vector3DMultiply Operator (Matrix3x3, Vector3D)

Transforms this vector by a 3x3 matrix. This "post-multiplies" the two.

Namespace: Assimp
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public static Vector3D operator *(
    Matrix3x3 matrix,
    Vector3D vector
)

Parameters

matrix
Type: AssimpMatrix3x3
Source matrix
vector
Type: AssimpVector3D
Source vector

Return Value

Type: Vector3D
Transformed vector
See Also

Reference

Vector3D Structure
Multiply Overload


Vector3D.Multiply Operator (Matrix4x4, Vector3D)

Vector3DMultiply Operator (Matrix4x4, Vector3D)

Transforms this vector by a 4x4 matrix. This "post-multiplies" the two.

Namespace: Assimp
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public static Vector3D operator *(
    Matrix4x4 matrix,
    Vector3D vector
)

Parameters

matrix
Type: AssimpMatrix4x4
Source matrix
vector
Type: AssimpVector3D
Source vector

Return Value

Type: Vector3D
Transformed vector
See Also

Reference

Vector3D Structure
Multiply Overload


Vector3D.Multiply Operator (Vector3D, Vector3D)

Vector3DMultiply Operator (Vector3D, Vector3D)

Multiplies two vectors together.

Namespace: Assimp
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public static Vector3D operator *(
    Vector3D a,
    Vector3D b
)

Parameters

a
Type: AssimpVector3D
First vector
b
Type: AssimpVector3D
Second vector

Return Value

Type: Vector3D
Multiplied vector
See Also

Reference

Vector3D Structure
Multiply Overload


Vector3D.Multiply Operator (Vector3D, Single)

Vector3DMultiply Operator (Vector3D, Single)

Multiplies a vector by a scalar.

Namespace: Assimp
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public static Vector3D operator *(
    Vector3D value,
    float scale
)

Parameters

value
Type: AssimpVector3D
Source vector
scale
Type: SystemSingle
Scalar value

Return Value

Type: Vector3D
Scaled vector
See Also

Reference

Vector3D Structure
Multiply Overload


Vector3D.Subtraction Operator

Vector3DSubtraction Operator

Subtracts the second vector from the first vector.

Namespace: Assimp
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public static Vector3D operator -(
    Vector3D a,
    Vector3D b
)

Parameters

a
Type: AssimpVector3D
First vector
b
Type: AssimpVector3D
Second vector

Return Value

Type: Vector3D
Resulting vector
See Also

Reference

Vector3D Structure


Vector3D.UnaryNegation Operator

Vector3DUnaryNegation Operator

Negates the vector.

Namespace: Assimp
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public static Vector3D operator -(
    Vector3D value
)

Parameters

value
Type: AssimpVector3D
Source vector

Return Value

Type: Vector3D
Negated vector
See Also

Reference

Vector3D Structure


Vector3D Fields

The Vector3D type exposes the following members.

Fields
 | Name | Description
Public field | X | X component.
Public field | Y | Y component.
Public field | Z | Z component.
Top
See Also

Reference

Vector3D Structure


Vector3D.X Field

Vector3DX Field

X component.

Namespace: Assimp
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public float X

Field Value

Type: Single
See Also

Reference

Vector3D Structure


Vector3D.Y Field

Vector3DY Field

Y component.

Namespace: Assimp
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public float Y

Field Value

Type: Single
See Also

Reference

Vector3D Structure


Vector3D.Z Field

Vector3DZ Field

Z component.

Namespace: Assimp
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public float Z

Field Value

Type: Single
See Also

Reference

Vector3D Structure


VectorKey Structure

Time-value pair specifying a 3D vector for a given time.

Namespace: Assimp
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public struct VectorKey : IEquatable<VectorKey>

The VectorKey type exposes the following members.

Constructors
 | Name | Description
Public method | VectorKey | Constructs a new VectorKey.
Top
Methods
 | Name | Description
Public method | Equals(Object) | Determines whether the specified Object is equal to this instance. (Overrides ValueTypeEquals(Object).)
Public method | Equals(VectorKey) | Tests equality between this key and another.
Public method | GetHashCode | Returns a hash code for this instance. (Overrides ValueTypeGetHashCode.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents this instance. (Overrides ValueTypeToString.)
Top
Operators
Name | Description
Equality | Tests equality between two keys.
GreaterThan | Tests inequality between two keys.
Inequality | Tests inequality between two keys.
LessThan | Tests inequality between two keys.
Top
Fields
 | Name | Description
Public field | Time | The time of this key.
Public field | Value | The 3D vector value of this key.
Top
See Also

Reference


VectorKey Constructor

Constructs a new VectorKey.

Namespace: Assimp
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public VectorKey(
    double time,
    Vector3D vector
)

Parameters

time
Type: SystemDouble
The time of this key.
vector
Type: AssimpVector3D
The 3D vector value of this key.
See Also

Reference

VectorKey Structure


VectorKey Methods

The VectorKey type exposes the following members.

Methods
 | Name | Description
Public method | Equals(Object) | Determines whether the specified Object is equal to this instance. (Overrides ValueTypeEquals(Object).)
Public method | Equals(VectorKey) | Tests equality between this key and another.
Public method | GetHashCode | Returns a hash code for this instance. (Overrides ValueTypeGetHashCode.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents this instance. (Overrides ValueTypeToString.)
Top
See Also

Reference

VectorKey Structure


VectorKey.Equals Method

VectorKeyEquals Method

Overload List
 | Name | Description
Public method | Equals(Object) | Determines whether the specified Object is equal to this instance. (Overrides ValueTypeEquals(Object).)
Public method | Equals(VectorKey) | Tests equality between this key and another.
Top
See Also

Reference

VectorKey Structure


VectorKey.Equals Method (Object)

VectorKeyEquals Method (Object)

Determines whether the specified Object is equal to this instance.

Namespace: Assimp
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public override bool Equals(
    Object obj
)

Parameters

obj
Type: SystemObject
The Object to compare with this instance.

Return Value

Type: Boolean
true if the specified Object is equal to this instance; otherwise, false.
See Also

Reference

VectorKey Structure
Equals Overload


VectorKey.Equals Method (VectorKey)

VectorKeyEquals Method (VectorKey)

Tests equality between this key and another.

Namespace: Assimp
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public bool Equals(
    VectorKey key
)

Parameters

key
Type: AssimpVectorKey
Other key to test

Return Value

Type: Boolean
True if their 3D vectors are equal.

Implements

IEquatableTEquals(T)
See Also

Reference

VectorKey Structure
Equals Overload


VectorKey.GetHashCode Method

VectorKeyGetHashCode Method

Returns a hash code for this instance.

Namespace: Assimp
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public override int GetHashCode()

Return Value

Type: Int32
A hash code for this instance, suitable for use in hashing algorithms and data structures like a hash table.
See Also

Reference

VectorKey Structure


VectorKey.ToString Method

VectorKeyToString Method

Returns a String that represents this instance.

Namespace: Assimp
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public override string ToString()

Return Value

Type: String
A String that represents this instance.
See Also

Reference

VectorKey Structure


VectorKey Operators

The VectorKey type exposes the following members.

Operators
Name | Description
Equality | Tests equality between two keys.
GreaterThan | Tests inequality between two keys.
Inequality | Tests inequality between two keys.
LessThan | Tests inequality between two keys.
Top
See Also

Reference

VectorKey Structure


VectorKey.Equality Operator

VectorKeyEquality Operator

Tests equality between two keys.

Namespace: Assimp
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public static bool operator ==(
    VectorKey a,
    VectorKey b
)

Parameters

a
Type: AssimpVectorKey
The first key
b
Type: AssimpVectorKey
The second key

Return Value

Type: Boolean
True if the key's 3D vectors are the same, false otherwise.
See Also

Reference

VectorKey Structure


VectorKey.GreaterThan Operator

VectorKeyGreaterThan Operator

Tests inequality between two keys.

Namespace: Assimp
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public static bool operator >(
    VectorKey a,
    VectorKey b
)

Parameters

a
Type: AssimpVectorKey
The first key
b
Type: AssimpVectorKey
The second key

Return Value

Type: Boolean
True if the first key's time is greater than the second key's.
See Also

Reference

VectorKey Structure


VectorKey.Inequality Operator

VectorKeyInequality Operator

Tests inequality between two keys.

Namespace: Assimp
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public static bool operator !=(
    VectorKey a,
    VectorKey b
)

Parameters

a
Type: AssimpVectorKey
The first key
b
Type: AssimpVectorKey
The second key

Return Value

Type: Boolean
True if the key's 3D vectors are not the same, false otherwise.
See Also

Reference

VectorKey Structure


VectorKey.LessThan Operator

VectorKeyLessThan Operator

Tests inequality between two keys.

Namespace: Assimp
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public static bool operator <(
    VectorKey a,
    VectorKey b
)

Parameters

a
Type: AssimpVectorKey
The first key
b
Type: AssimpVectorKey
The second key

Return Value

Type: Boolean
True if the first key's time is less than the second key's.
See Also

Reference

VectorKey Structure


VectorKey Fields

The VectorKey type exposes the following members.

Fields
 | Name | Description
Public field | Time | The time of this key.
Public field | Value | The 3D vector value of this key.
Top
See Also

Reference

VectorKey Structure


VectorKey.Time Field

VectorKeyTime Field

The time of this key.

Namespace: Assimp
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public double Time

Field Value

Type: Double
See Also

Reference

VectorKey Structure


VectorKey.Value Field

VectorKeyValue Field

The 3D vector value of this key.

Namespace: Assimp
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public Vector3D Value

Field Value

Type: Vector3D
See Also

Reference

VectorKey Structure


VertexWeight Structure

Represents a single influence of a bone on a vertex.

Namespace: Assimp
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public struct VertexWeight

The VertexWeight type exposes the following members.

Constructors
 | Name | Description
Public method | VertexWeight | Constructs a new VertexWeight.
Top
Methods
 | Name | Description
Public method | Equals | Indicates whether this instance and a specified object are equal. (Inherited from ValueType.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from ValueType.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents this instance. (Overrides ValueTypeToString.)
Top
Fields
 | Name | Description
Public field | VertexID | Index of the vertex which is influenced by the bone.
Public field | Weight | Strength of the influence in range of (0...1). All influences from all bones at one vertex amounts to 1.
Top
See Also

Reference


VertexWeight Constructor

Constructs a new VertexWeight.

Namespace: Assimp
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public VertexWeight(
    int vertID,
    float weight
)

Parameters

vertID
Type: SystemInt32
Index of the vertex.
weight
Type: SystemSingle
Weight of the influence.
See Also

Reference

VertexWeight Structure


VertexWeight Methods

The VertexWeight type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Indicates whether this instance and a specified object are equal. (Inherited from ValueType.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from ValueType.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents this instance. (Overrides ValueTypeToString.)
Top
See Also

Reference

VertexWeight Structure


VertexWeight.ToString Method

VertexWeightToString Method

Returns a String that represents this instance.

Namespace: Assimp
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public override string ToString()

Return Value

Type: String
A String that represents this instance.
See Also

Reference

VertexWeight Structure


VertexWeight Fields

The VertexWeight type exposes the following members.

Fields
 | Name | Description
Public field | VertexID | Index of the vertex which is influenced by the bone.
Public field | Weight | Strength of the influence in range of (0...1). All influences from all bones at one vertex amounts to 1.
Top
See Also

Reference

VertexWeight Structure


VertexWeight.VertexID Field

VertexWeightVertexID Field

Index of the vertex which is influenced by the bone.

Namespace: Assimp
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public int VertexID

Field Value

Type: Int32
See Also

Reference

VertexWeight Structure


VertexWeight.Weight Field

VertexWeightWeight Field

Strength of the influence in range of (0...1). All influences from all bones at one vertex amounts to 1.

Namespace: Assimp
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public float Weight

Field Value

Type: Single
See Also

Reference

VertexWeight Structure


Assimp.Configs Namespace

Contains all the Assimp importer configuration objects.
Classes
Class Description
Public class ACEvaluateSubdivisionConfig
Configures whether the AC loader evaluates subdivision surfaces (indicated by the presence of the 'subdiv' attribute in the file). By default, Assimp performs the subdivision using the standard Catmull-Clark algorithm. The default value is true.
Public class ACSeparateBackfaceCullConfig
Configures the AC loader to collect all surfaces which have the "Backface cull" flag set in separate meshes. The default value is true.
Public class AnimationAccuracyConfig
Configuration for the FindInvalidData step that specifies the floating point accuracy for animation values, specifically the episilon during comparisons. The default value is 0.0f.
Public class ASEReconstructNormalsConfig
Configures the ASE loader to always reconstruct normal vectors basing on the smoothing groups loaded from the file. Some ASE files carry invalid normals, others don't. The default value is true.
Public class BooleanPropertyConfig
Describes a boolean configuration property.
Public class ColladaIgnoreUpDirectionConfig
Specifies whether the collada loader will ignore the up direction. Default is false.
Public class DeboneAllOrNoneConfig
Configuration that requires all bones to qualify for deboning before any are removed.
Public class DeboneThresholdConfig
Configures the Debone threshold that is used to determine what bones are removed.
Public class FavorSpeedConfig
Configuration that is a hint to Assimp to favor speed against import quality. Enabling this option may result in faster loading, or it may not. It is just a hint to loaders and post-process steps to use faster code paths if possible. The default value is false.
Public class FBXImportAllGeometryLayersConfig
Specifies whether the FBX importer will merge all geometry layers present in the source file or import only the first. Default is true.
Public class FBXImportAllMaterialsConfig
Specifies whether the FBX importer will import all materials present in the source file or take only the referenced materials, if the importer is configured to import materials at all. Otherwise this will have no effect. Default is false.
Public class FBXImportAnimationsConfig
Specifies whether the FBX importer will import animations. Default is true.
Public class FBXImportCamerasConfig
Specifies whether the FBX importer will import cameras. Default is true.
Public class FBXImportEmbeddedTexturesConfig
Specifies whether the FBX importer will import embedded textures. Default is true.
Public class FBXImportLightsConfig
Specifies whether the FBX importer will import lights. Default is true.
Public class FBXImportMaterialsConfig
Specifies whether the FBX importer will import materials. Default is true.
Public class FBXImportSearchEmbeddedTexturesConfig
Specifies if the FBX importer should search for embedded loaded textures, where no embedded texture data is provided. Default is false.
Public class FBXOptimizeEmptyAnimationCurvesConfig
Specifies whether the importer will drop empty animation curves or animation curves which match the bind pose transformation over their entire defined range. Default value is true.
Public class FBXPreservePivotsConfig
Specifies whether the FBX importer will preserve pivot points for transformations (as extra nodes). If set to false, pivots and offsets will be evaluated whenever possible. Default value is true.
Public class FBXStrictModeConfig
Specifies whether the FBX importer will act in strict mode in which only the FBX 2013 format is supported and any other sub formats are rejected. FBX 2013 is the primary target for the importer, so this format is best supported and well-tested. Default is false.
Public class FloatPropertyConfig
Describes a float configuration property.
Public class GlobalKeyFrameImportConfig
Sets the vertex animation keyframe to be imported. Assimp does not support vertex keyframes (only bone animation is supported). the library reads only one keyframe with vertex animations. By default this is the first frame. This config sets the "global" keyframe that will be imported. There are other configs for specific importers that will override the global setting.
Public class GlobalScaleConfig
Configures the GlobalScale step to scale the entire scene by a certain amount. Some importers provide a mechanism to define a scaling unit for the model, which this processing step can utilize.
Public class IFCCylindricalTessellationConfig
Specifies the tessellation for IFC cylindrical shapes. E.g. the number of segments used to approximate a circle. Accepted range of values is between [3, 180].
Public class IFCSkipSpaceRepresentationsConfig
Specifies whether the IFC loader skips over IfcSpace elements. IfcSpace elements (and their geometric representations) are used to represent free space in a building story.
Public class IFCSmoothingAngleConfig
Specifies the tessellation conic angle for IFC smoothing curves. Accepted range of values is between [5, 120]
Public class IFCUseCustomTriangulationConfig
Specifies whether the IFC loader will use its own, custom triangulation algorithm to triangulate wall and floor meshes. If this is set to false, walls will be either triangulated by the post process triangulation or will be passed through as huge polygons with faked holes (e.g. holes that are connected with the outer boundary using a dummy edge). It is highly recommended to leave this property set to true as the default post process has some known issues with these kind of polygons.
Public class IntegerPropertyConfig
Describes an integer configuration property.
Public class IRRAnimationFrameRateConfig
Defines the output frame rate of the IRR loader.

IRR animations are difficult to convert for Assimp and there will always be a loss of quality. This setting defines how many keys per second are returned by the converter.

The default value is 100 frames per second.
Public class KeepSceneHierarchyConfig
Configuration for the PreTransformVertices step to keep the scene hierarchy. Meshes are moved to worldspace, but no optimization is performed where meshes with the same materials are not joined. This option can be useful if you have a scene hierarchy that contains important additional information which you intend to parse. The default value is false.
Public class LWOImportOneLayerConfig
Configures the LWO loader to load just one layer from the model.

LWO files consist of layers and in some cases it could be useful to load only one of them. This property can be either a string - which specifies the name of the layer - or an integer - the index of the layer. If the property is not set then the whole LWO model is loaded. Loading fails if the requested layer is not vailable. The layer index is zero-based and the layer name may not be empty

The default value is false (all layers are loaded).
Public class LWSAnimationEndConfig
Defines the ending of the time range for which the LWS loader evaluates animations and computes AiNodeAnim's. The default value is the one taken from the file

Assimp provides full conversion of Lightwave's envelope system, including pre and post conditions. The loader computes linearly subsampled animation channels with the frame rate given in the LWS file. This property defines the end time.

Animation channels are only generated if a node has at least one envelope with more than one key assigned. This property is given in frames where '0' is the first. By default, if this property is not set, the importer takes the animation end from the input LWS file.

Public class LWSAnimationStartConfig
Defines the beginning of the time range for which the LWS loader evaluates animations and computes AiNodeAnim's. The default value is the one taken from the file.

Assimp provides full conversion of Lightwave's envelope system, including pre and post conditions. The loader computes linearly subsampled animation channels with the frame rate given in the LWS file. This property defines the start time.

Animation channels are only generated if a node has at least one envelope with more than one key assigned. This property is given in frames where '0' is the first. By default, if this property is not set, the importer takes the animation start from the input LWS file ('FirstFrame' line)

Public class MaterialExcludeListConfig
Configuration for the the RemoveRedundantMaterials step to determine what materials to keep. If a material matches one of these names it will not be modified or removed by the post processing step. Default is an empty string.
Public class MatrixPropertyConfig
Describes a Matrix4x4 configuration property.
Public class MaxBoneCountConfig
Configures the maximum bone count per mesh for the SplitByBoneCount step. Meshes are split until the maximum number of bones is reached.
Public class MD2KeyFrameImportConfig
Sets the vertex animation keyframe to be imported. Assimp does not support vertex keyframes (only bone animation is supported). the library reads only one keyframe with vertex animations. By default this is the first frame. This config sets the global override for the MD2 format.
Public class MD3HandleMultiPartConfig
Configures the M3D loader to detect and process multi-part Quake player models. These models usually consit of three files, lower.md3, upper.md3 and head.md3. If this propery is set to true, Assimp will try to load and combine all three files if one of them is loaded. The default value is true.
Public class MD3KeyFrameImportConfig
Sets the vertex animation keyframe to be imported. Assimp does not support vertex keyframes (only bone animation is supported). the library reads only one keyframe with vertex animations. By default this is the first frame. This config sets the global override for the MD3 format.
Public class MD3ShaderSourceConfig
Specifies the Quake 3 shader file to be used for a particular MD3 file. This can be a full path or relative to where all MD3 shaders reside. the default string value is an empty string.
Public class MD3SkinNameConfig
Tells the MD3 loader which skin files to load. When loading MD3 files, Assimp checks whether a file named "md3_file_name"_"skin_name".skin exists. These files are used by Quake III to be able to assign different skins (e.g. red and blue team) to models. 'default', 'red', 'blue' are typical skin names. The default string value is "default".
Public class MD5NoAnimationAutoLoadConfig
Configures the MD5 loader to not load the MD5ANIM file for a MD5MESH file automatically. The default value is false.

The default strategy is to look for a file with the same name but with the MD5ANIm extension in the same directory. If it is found it is loaded and combined with the MD5MESH file. This configuration option can be used to disable this behavior.

Public class MDLColorMapConfig
Configuration to set the colormap (palette) to be used to decode embedded textures in MDL (Quake or 3DG5) files. This must be a valid path to a file. The file is 768 (256 * 3) bytes alrge and contains RGB triplets for each of the 256 palette entries. If the file is not found, a default palette (from Quake 1) is used. The default value is "colormap.lmp".
Public class MDLKeyFrameImportConfig
Sets the vertex animation keyframe to be imported. Assimp does not support vertex keyframes (only bone animation is supported). the library reads only one keyframe with vertex animations. By default this is the first frame. This config sets the global override for the MDL format.
Public class MeasureTimeConfig
Configuration to enable time measurements. If enabled, each part of the loading process is timed and logged. Default value is false.
Public class MeshTriangleLimitConfig
Configuration for the SplitLargeMeshes step that specifies the maximum number of triangles a mesh can contain. The default value is MeshTriangleLimitConfigDefaultValue.
Public class MeshVertexLimitConfig
Configuration for the SplitLargeMeshes step that specifies the maximum number of vertices a mesh can contain. The default value is MeshVertexLimitConfigDefaultValue.
Public class MultithreadingConfig
Configuration to set Assimp's multithreading policy. Possible values are -1 to let Assimp decide, 0 to disable multithreading, or any number larger than zero to force a specific number of threads. This is only a hint and may be ignored by Assimp. Default value is -1.
Public class NodeExcludeListConfig
Configuration for the OptimizeGraph step to preserve nodes matching a name in the given list. Nodes that match the names in the list will not be modified or removed. Identifiers containing whitespaces must be enclosed in single quotation marks. The default value is an empty string.
Public class NormalizeVertexComponentsConfig
Configuration for the PreTransformVertices step to normalize all vertex components into the -1...1 range. The default value is false.
Public class NormalSmoothingAngleConfig
Configuration to set the maximum angle between two face normals at a vertex when they are smoothed during the step to calculate smooth normals. This is frequently called the "crease angle". The maximum and default value is 175 degrees.
Public class NoSkeletonMeshesConfig
Global setting to disable generation of skeleton dummy meshes. These are generated as a visualization aid in cases which the input data contains no geometry, but only animation data. So the geometry are visualizing the bones. Default value is false.
Public class OgreMaterialFileConfig
The Ogre importer will try to load this MaterialFile. Ogre meshes reference with material names, this does not tell Assimp where the file is located. Assimp will try to find the source file in the following order: [material-name].material, [mesh-filename-base].material, and lastly the material name defined by this config property. The default value is "Scene.Material".
Public class OgreTextureTypeFromFilenameConfig
The Ogre importer will detect the texture usage from the filename. Normally a texture is loaded as a color map, if no target is specified in the material file. If this is enabled, then Assimp will try to detect the type from the texture filename postfix:
  • Normal Maps: _n, _nrm, _nrml, _normal, _normals, _normalmap
  • Specular Maps: _s, _spec, _specular, _specularmap
  • Light Maps: _l, _light, _lightmap, _occ, _occlusion
  • Displacement Maps: _dis, _displacement
The matching is case insensitive. Postfix is taken between the last "_" and last ".". The default behavior is to detect type from lower cased texture unit name by matching against: normalmap, specularmap, lightmap, and displacementmap. For both cases if no match is found then, Diffuse is used. The default value is false.
Public class PropertyConfig
Base property config.
Public class RemoveComponentConfig
Configuration for the RemoveComponent step that specifies which parts of the data structure is to be removed. If no valid mesh remains after the step, the import fails. The default value i None.
Public class RemoveDegeneratePrimitivesCheckAreaConfig
Configuration for the FindDegenerates step. If true, the area of the triangles are checked to see if they are greater than 1e-6. If so, the triangle is removed if RemoveDegeneratePrimitivesConfig is set to true.
Public class RemoveDegeneratePrimitivesConfig
Configuration for the FindDegenerates step to remove degenerted primitives from the import immediately. The default value is false, where degenerated triangles are converted to lines, and degenerated lines to points.
Public class RootTransformationConfig
Configuration for PreTransformVertices that sets a user defined matrix as the scene root node transformation before transforming vertices. Default value is the identity matrix.
Public class SMDKeyFrameImportConfig
Sets the vertex animation keyframe to be imported. Assimp does not support vertex keyframes (only bone animation is supported). the library reads only one keyframe with vertex animations. By default this is the first frame. This config sets the global override for the SMD format.
Public class SortByPrimitiveTypeConfig
Configuration for the SortByPrimitiveType step that specifies which primitive types are to be removed by the step. Specifying all primitive types is illegal. The default value is zero specifying none.
Public class StringPropertyConfig
Describes a string configuration property.
Public class TangentSmoothingAngleConfig
Configuration to set the maximum angle that may be between two vertex tangents/bitangents when they are smoothed during the step to calculate the tangent basis. The default value is 45 degrees.
Public class TangentTextureChannelIndexConfig
Configures which texture channel is used for tangent space computations. The channel must exist or an error will be raised.
Public class TerragenComputeTexCoordsConfig
Configures the terragen import plugin to compute UV's for terrains, if they are not given. Furthermore, a default texture is assigned. The default value is false.

UV coordinates for terrains are so simple to compute that you'll usually want to compute them on your own, if you need them. This option is intended for model viewers which want to offer an easy way to apply textures to terrains.

Public class TransformUVConfig
Configuration for the TransformUVCoords step that specifies which UV transformations are to be evaluated. The default value is for all combinations (scaling, rotation, translation).
Public class UnrealHandleFlagsConfig
Configures the UNREAL 3D loader to separate faces with different surface flags (e.g. two-sided vs single-sided). The default value is true.
Public class UnrealKeyFrameImportConfig
Sets the vertex animation keyframe to be imported. Assimp does not support vertex keyframes (only bone animation is supported). the library reads only one keyframe with vertex animations. By default this is the first frame. This config sets the global override for the Unreal format.
Public class VertexBoneWeightLimitConfig
Configuration for the LimitBoneWeights step that specifies the maximum number of bone weights per vertex. The default value is VertexBoneWeightLimitConfigDefaultValue.
Public class VertexCacheSizeConfig
Configuration for the ImproveCacheLocality step that specifies the size of the post-transform vertex cache. The size is given in number of vertices and the default value is VertexCacheSizeConfigDefaultValue.
Public class XFileUseDoublesConfig
Specifies if the X-file exporter should use 64-bit doubles rather than 32-bit floats.


ACEvaluateSubdivisionConfig Class

Configures whether the AC loader evaluates subdivision surfaces (indicated by the presence of the 'subdiv' attribute in the file). By default, Assimp performs the subdivision using the standard Catmull-Clark algorithm. The default value is true.
Inheritance Hierarchy
SystemObject
Assimp.ConfigsPropertyConfig
Assimp.ConfigsBooleanPropertyConfig
Assimp.ConfigsACEvaluateSubdivisionConfig

Namespace: Assimp.Configs
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public sealed class ACEvaluateSubdivisionConfig : BooleanPropertyConfig

The ACEvaluateSubdivisionConfig type exposes the following members.

Constructors
 | Name | Description
Public method | ACEvaluateSubdivisionConfig | Constructs a new ACEvaluateSubdivisionConfig.
Top
Properties
 | Name | Description
 | ACEvaluateSubdivisionConfigName | Gets the string name used by ACEvaluateSubdivisionConfig.
Public property | DefaultValue | Gets the default property value. (Inherited from BooleanPropertyConfig.)
Public property | Name | Gets the property name. (Inherited from PropertyConfig.)
Public property | Value | Gets the property value. (Inherited from BooleanPropertyConfig.)
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | SetDefaultValue | Sets the current value to the default value. (Inherited from BooleanPropertyConfig.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Assimp.Configs Namespace


ACEvaluateSubdivisionConfig Constructor

Constructs a new ACEvaluateSubdivisionConfig.

Namespace: Assimp.Configs
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public ACEvaluateSubdivisionConfig(
    bool evaluateSubdivision
)

Parameters

evaluateSubdivision
Type: SystemBoolean
True if the AC loader should evaluate subdivisions, false otherwise.
See Also

Reference

ACEvaluateSubdivisionConfig Class
Assimp.Configs Namespace


ACEvaluateSubdivisionConfig Properties

The ACEvaluateSubdivisionConfig type exposes the following members.

Properties
 | Name | Description
 | ACEvaluateSubdivisionConfigName | Gets the string name used by ACEvaluateSubdivisionConfig.
Public property | DefaultValue | Gets the default property value. (Inherited from BooleanPropertyConfig.)
Public property | Name | Gets the property name. (Inherited from PropertyConfig.)
Public property | Value | Gets the property value. (Inherited from BooleanPropertyConfig.)
Top
See Also

Reference

ACEvaluateSubdivisionConfig Class
Assimp.Configs Namespace


ACEvaluateSubdivisionConfig.ACEvaluateSubdivisionConfigName Property

ACEvaluateSubdivisionConfigACEvaluateSubdivisionConfigName Property

Gets the string name used by ACEvaluateSubdivisionConfig.

Namespace: Assimp.Configs
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public static string ACEvaluateSubdivisionConfigName { get; }

Property Value

Type: String
See Also

Reference

ACEvaluateSubdivisionConfig Class
Assimp.Configs Namespace


ACEvaluateSubdivisionConfig Methods

The ACEvaluateSubdivisionConfig type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | SetDefaultValue | Sets the current value to the default value. (Inherited from BooleanPropertyConfig.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

ACEvaluateSubdivisionConfig Class
Assimp.Configs Namespace


ACSeparateBackfaceCullConfig Class

Configures the AC loader to collect all surfaces which have the "Backface cull" flag set in separate meshes. The default value is true.
Inheritance Hierarchy
SystemObject
Assimp.ConfigsPropertyConfig
Assimp.ConfigsBooleanPropertyConfig
Assimp.ConfigsACSeparateBackfaceCullConfig

Namespace: Assimp.Configs
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public sealed class ACSeparateBackfaceCullConfig : BooleanPropertyConfig

The ACSeparateBackfaceCullConfig type exposes the following members.

Constructors
 | Name | Description
Public method | ACSeparateBackfaceCullConfig | Constructs a new ACSeparateBackfaceCullConfig.
Top
Properties
 | Name | Description
 | ACSeparateBackfaceCullConfigName | Gets the string name used by ACSeparateBackfaceCullConfig.
Public property | DefaultValue | Gets the default property value. (Inherited from BooleanPropertyConfig.)
Public property | Name | Gets the property name. (Inherited from PropertyConfig.)
Public property | Value | Gets the property value. (Inherited from BooleanPropertyConfig.)
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | SetDefaultValue | Sets the current value to the default value. (Inherited from BooleanPropertyConfig.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Assimp.Configs Namespace


ACSeparateBackfaceCullConfig Constructor

Constructs a new ACSeparateBackfaceCullConfig.

Namespace: Assimp.Configs
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public ACSeparateBackfaceCullConfig(
    bool separateBackfaces
)

Parameters

separateBackfaces
Type: SystemBoolean
True if all surfaces that have the "backface cull" flag set should be collected in separate meshes, false otherwise.
See Also

Reference

ACSeparateBackfaceCullConfig Class
Assimp.Configs Namespace


ACSeparateBackfaceCullConfig Properties

The ACSeparateBackfaceCullConfig type exposes the following members.

Properties
 | Name | Description
 | ACSeparateBackfaceCullConfigName | Gets the string name used by ACSeparateBackfaceCullConfig.
Public property | DefaultValue | Gets the default property value. (Inherited from BooleanPropertyConfig.)
Public property | Name | Gets the property name. (Inherited from PropertyConfig.)
Public property | Value | Gets the property value. (Inherited from BooleanPropertyConfig.)
Top
See Also

Reference

ACSeparateBackfaceCullConfig Class
Assimp.Configs Namespace


ACSeparateBackfaceCullConfig.ACSeparateBackfaceCullConfigName Property

ACSeparateBackfaceCullConfigACSeparateBackfaceCullConfigName Property

Gets the string name used by ACSeparateBackfaceCullConfig.

Namespace: Assimp.Configs
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public static string ACSeparateBackfaceCullConfigName { get; }

Property Value

Type: String
See Also

Reference

ACSeparateBackfaceCullConfig Class
Assimp.Configs Namespace


ACSeparateBackfaceCullConfig Methods

The ACSeparateBackfaceCullConfig type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | SetDefaultValue | Sets the current value to the default value. (Inherited from BooleanPropertyConfig.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

ACSeparateBackfaceCullConfig Class
Assimp.Configs Namespace


AnimationAccuracyConfig Class

Configuration for the FindInvalidData step that specifies the floating point accuracy for animation values, specifically the episilon during comparisons. The default value is 0.0f.
Inheritance Hierarchy
SystemObject
Assimp.ConfigsPropertyConfig
Assimp.ConfigsFloatPropertyConfig
Assimp.ConfigsAnimationAccuracyConfig

Namespace: Assimp.Configs
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public sealed class AnimationAccuracyConfig : FloatPropertyConfig

The AnimationAccuracyConfig type exposes the following members.

Constructors
 | Name | Description
Public method | AnimationAccuracyConfig | Constructs a new AnimationAccuracyConfig.
Top
Properties
 | Name | Description
 | AnimationAccuracyConfigName | Gets the string name used by AnimationAccuracyConfig.
Public property | DefaultValue | Gets the default property value. (Inherited from FloatPropertyConfig.)
Public property | Name | Gets the property name. (Inherited from PropertyConfig.)
Public property | Value | Gets the property value. (Inherited from FloatPropertyConfig.)
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | SetDefaultValue | Sets the current value to the default value. (Inherited from FloatPropertyConfig.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Assimp.Configs Namespace


AnimationAccuracyConfig Constructor

Constructs a new AnimationAccuracyConfig.

Namespace: Assimp.Configs
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public AnimationAccuracyConfig(
    float episilon
)

Parameters

episilon
Type: SystemSingle
Episilon for animation value comparisons.
See Also

Reference

AnimationAccuracyConfig Class
Assimp.Configs Namespace


AnimationAccuracyConfig Properties

The AnimationAccuracyConfig type exposes the following members.

Properties
 | Name | Description
 | AnimationAccuracyConfigName | Gets the string name used by AnimationAccuracyConfig.
Public property | DefaultValue | Gets the default property value. (Inherited from FloatPropertyConfig.)
Public property | Name | Gets the property name. (Inherited from PropertyConfig.)
Public property | Value | Gets the property value. (Inherited from FloatPropertyConfig.)
Top
See Also

Reference

AnimationAccuracyConfig Class
Assimp.Configs Namespace


AnimationAccuracyConfig.AnimationAccuracyConfigName Property

AnimationAccuracyConfigAnimationAccuracyConfigName Property

Gets the string name used by AnimationAccuracyConfig.

Namespace: Assimp.Configs
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public static string AnimationAccuracyConfigName { get; }

Property Value

Type: String
See Also

Reference

AnimationAccuracyConfig Class
Assimp.Configs Namespace


AnimationAccuracyConfig Methods

The AnimationAccuracyConfig type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | SetDefaultValue | Sets the current value to the default value. (Inherited from FloatPropertyConfig.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

AnimationAccuracyConfig Class
Assimp.Configs Namespace


ASEReconstructNormalsConfig Class

Configures the ASE loader to always reconstruct normal vectors basing on the smoothing groups loaded from the file. Some ASE files carry invalid normals, others don't. The default value is true.
Inheritance Hierarchy
SystemObject
Assimp.ConfigsPropertyConfig
Assimp.ConfigsBooleanPropertyConfig
Assimp.ConfigsASEReconstructNormalsConfig

Namespace: Assimp.Configs
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public sealed class ASEReconstructNormalsConfig : BooleanPropertyConfig

The ASEReconstructNormalsConfig type exposes the following members.

Constructors
 | Name | Description
Public method | ASEReconstructNormalsConfig | Constructs a new ASEReconstructNormalsConfig.
Top
Properties
 | Name | Description
 | ASEReconstructNormalsConfigName | Gets the string name used by ASEReconstructNormalsConfig.
Public property | DefaultValue | Gets the default property value. (Inherited from BooleanPropertyConfig.)
Public property | Name | Gets the property name. (Inherited from PropertyConfig.)
Public property | Value | Gets the property value. (Inherited from BooleanPropertyConfig.)
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | SetDefaultValue | Sets the current value to the default value. (Inherited from BooleanPropertyConfig.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Assimp.Configs Namespace


ASEReconstructNormalsConfig Constructor

Constructs a new ASEReconstructNormalsConfig.

Namespace: Assimp.Configs
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public ASEReconstructNormalsConfig(
    bool reconstructNormals
)

Parameters

reconstructNormals
Type: SystemBoolean
True if normals should be re-computed, false otherwise.
See Also

Reference

ASEReconstructNormalsConfig Class
Assimp.Configs Namespace


ASEReconstructNormalsConfig Properties

The ASEReconstructNormalsConfig type exposes the following members.

Properties
 | Name | Description
 | ASEReconstructNormalsConfigName | Gets the string name used by ASEReconstructNormalsConfig.
Public property | DefaultValue | Gets the default property value. (Inherited from BooleanPropertyConfig.)
Public property | Name | Gets the property name. (Inherited from PropertyConfig.)
Public property | Value | Gets the property value. (Inherited from BooleanPropertyConfig.)
Top
See Also

Reference

ASEReconstructNormalsConfig Class
Assimp.Configs Namespace


ASEReconstructNormalsConfig.ASEReconstructNormalsConfigName Property

ASEReconstructNormalsConfigASEReconstructNormalsConfigName Property

Gets the string name used by ASEReconstructNormalsConfig.

Namespace: Assimp.Configs
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public static string ASEReconstructNormalsConfigName { get; }

Property Value

Type: String
See Also

Reference

ASEReconstructNormalsConfig Class
Assimp.Configs Namespace


ASEReconstructNormalsConfig Methods

The ASEReconstructNormalsConfig type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | SetDefaultValue | Sets the current value to the default value. (Inherited from BooleanPropertyConfig.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

ASEReconstructNormalsConfig Class
Assimp.Configs Namespace


BooleanPropertyConfig Class

Describes a boolean configuration property.
Inheritance Hierarchy
SystemObject
Assimp.ConfigsPropertyConfig
Assimp.ConfigsBooleanPropertyConfig
More...

Namespace: Assimp.Configs
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public class BooleanPropertyConfig : PropertyConfig

The BooleanPropertyConfig type exposes the following members.

Constructors
 | Name | Description
Public method | BooleanPropertyConfig(String, Boolean) | Constructs a new BooleanPropertyConfig.
Public method | BooleanPropertyConfig(String, Boolean, Boolean) | Constructs a new BooleanPropertyConfig with a default value.
Top
Properties
 | Name | Description
Public property | DefaultValue | Gets the default property value.
Public property | Name | Gets the property name. (Inherited from PropertyConfig.)
Public property | Value | Gets the property value.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | OnApplyValue | Applies the property value to the given Assimp property store. (Overrides PropertyConfigOnApplyValue(IntPtr).)
Public method | SetDefaultValue | Sets the current value to the default value. (Overrides PropertyConfigSetDefaultValue.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Assimp.Configs Namespace
Inheritance Hierarchy
SystemObject
Assimp.ConfigsPropertyConfig
Assimp.ConfigsBooleanPropertyConfig
Assimp.ConfigsACEvaluateSubdivisionConfig
Assimp.ConfigsACSeparateBackfaceCullConfig
Assimp.ConfigsASEReconstructNormalsConfig
Assimp.ConfigsColladaIgnoreUpDirectionConfig
Assimp.ConfigsDeboneAllOrNoneConfig
Assimp.ConfigsFavorSpeedConfig
Assimp.ConfigsFBXImportAllGeometryLayersConfig
Assimp.ConfigsFBXImportAllMaterialsConfig
Assimp.ConfigsFBXImportAnimationsConfig
Assimp.ConfigsFBXImportCamerasConfig
Assimp.ConfigsFBXImportEmbeddedTexturesConfig
Assimp.ConfigsFBXImportLightsConfig
Assimp.ConfigsFBXImportMaterialsConfig
Assimp.ConfigsFBXImportSearchEmbeddedTexturesConfig
Assimp.ConfigsFBXOptimizeEmptyAnimationCurvesConfig
Assimp.ConfigsFBXPreservePivotsConfig
Assimp.ConfigsFBXStrictModeConfig
Assimp.ConfigsIFCSkipSpaceRepresentationsConfig
Assimp.ConfigsIFCUseCustomTriangulationConfig
Assimp.ConfigsKeepSceneHierarchyConfig
Assimp.ConfigsLWOImportOneLayerConfig
Assimp.ConfigsMD3HandleMultiPartConfig
Assimp.ConfigsMD5NoAnimationAutoLoadConfig
Assimp.ConfigsMeasureTimeConfig
Assimp.ConfigsNormalizeVertexComponentsConfig
Assimp.ConfigsNoSkeletonMeshesConfig
Assimp.ConfigsOgreTextureTypeFromFilenameConfig
Assimp.ConfigsRemoveDegeneratePrimitivesCheckAreaConfig
Assimp.ConfigsRemoveDegeneratePrimitivesConfig
Assimp.ConfigsTerragenComputeTexCoordsConfig
Assimp.ConfigsUnrealHandleFlagsConfig
Assimp.ConfigsXFileUseDoublesConfig


BooleanPropertyConfig Constructor

Overload List
 | Name | Description
Public method | BooleanPropertyConfig(String, Boolean) | Constructs a new BooleanPropertyConfig.
Public method | BooleanPropertyConfig(String, Boolean, Boolean) | Constructs a new BooleanPropertyConfig with a default value.
Top
See Also

Reference

BooleanPropertyConfig Class
Assimp.Configs Namespace


BooleanPropertyConfig Constructor (String, Boolean)

Constructs a new BooleanPropertyConfig.

Namespace: Assimp.Configs
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public BooleanPropertyConfig(
    string name,
    bool value
)

Parameters

name
Type: SystemString
Name of the property
value
Type: SystemBoolean
Property value
See Also

Reference

BooleanPropertyConfig Class
BooleanPropertyConfig Overload
Assimp.Configs Namespace


BooleanPropertyConfig Constructor (String, Boolean, Boolean)

Constructs a new BooleanPropertyConfig with a default value.

Namespace: Assimp.Configs
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public BooleanPropertyConfig(
    string name,
    bool value,
    bool defaultValue
)

Parameters

name
Type: SystemString
Name of the property
value
Type: SystemBoolean
Property value
defaultValue
Type: SystemBoolean
The default property value
See Also

Reference

BooleanPropertyConfig Class
BooleanPropertyConfig Overload
Assimp.Configs Namespace


BooleanPropertyConfig Properties

The BooleanPropertyConfig type exposes the following members.

Properties
 | Name | Description
Public property | DefaultValue | Gets the default property value.
Public property | Name | Gets the property name. (Inherited from PropertyConfig.)
Public property | Value | Gets the property value.
Top
See Also

Reference

BooleanPropertyConfig Class
Assimp.Configs Namespace


BooleanPropertyConfig.DefaultValue Property

BooleanPropertyConfigDefaultValue Property

Gets the default property value.

Namespace: Assimp.Configs
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public bool DefaultValue { get; }

Property Value

Type: Boolean
See Also

Reference

BooleanPropertyConfig Class
Assimp.Configs Namespace


BooleanPropertyConfig.Value Property

BooleanPropertyConfigValue Property

Gets the property value.

Namespace: Assimp.Configs
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public bool Value { get; set; }

Property Value

Type: Boolean
See Also

Reference

BooleanPropertyConfig Class
Assimp.Configs Namespace


BooleanPropertyConfig Methods

The BooleanPropertyConfig type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | OnApplyValue | Applies the property value to the given Assimp property store. (Overrides PropertyConfigOnApplyValue(IntPtr).)
Public method | SetDefaultValue | Sets the current value to the default value. (Overrides PropertyConfigSetDefaultValue.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

BooleanPropertyConfig Class
Assimp.Configs Namespace


BooleanPropertyConfig.OnApplyValue Method

BooleanPropertyConfigOnApplyValue Method

Applies the property value to the given Assimp property store.

Namespace: Assimp.Configs
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
protected override void OnApplyValue(
    IntPtr propStore
)

Parameters

propStore
Type: SystemIntPtr
Assimp property store
See Also

Reference

BooleanPropertyConfig Class
Assimp.Configs Namespace


BooleanPropertyConfig.SetDefaultValue Method

BooleanPropertyConfigSetDefaultValue Method

Sets the current value to the default value.

Namespace: Assimp.Configs
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public override void SetDefaultValue()
See Also

Reference

BooleanPropertyConfig Class
Assimp.Configs Namespace


ColladaIgnoreUpDirectionConfig Class

Specifies whether the collada loader will ignore the up direction. Default is false.
Inheritance Hierarchy
SystemObject
Assimp.ConfigsPropertyConfig
Assimp.ConfigsBooleanPropertyConfig
Assimp.ConfigsColladaIgnoreUpDirectionConfig

Namespace: Assimp.Configs
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public sealed class ColladaIgnoreUpDirectionConfig : BooleanPropertyConfig

The ColladaIgnoreUpDirectionConfig type exposes the following members.

Constructors
 | Name | Description
Public method | ColladaIgnoreUpDirectionConfig | Constructs a new ColladaIgnoreUpDirectionConfig.
Top
Properties
 | Name | Description
 | ColladaIgnoreUpDirectionConfigName | Gets the string name used by ColladaIgnoreUpDirectionConfig.
Public property | DefaultValue | Gets the default property value. (Inherited from BooleanPropertyConfig.)
Public property | Name | Gets the property name. (Inherited from PropertyConfig.)
Public property | Value | Gets the property value. (Inherited from BooleanPropertyConfig.)
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | SetDefaultValue | Sets the current value to the default value. (Inherited from BooleanPropertyConfig.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Assimp.Configs Namespace


ColladaIgnoreUpDirectionConfig Constructor

Constructs a new ColladaIgnoreUpDirectionConfig.

Namespace: Assimp.Configs
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public ColladaIgnoreUpDirectionConfig(
    bool ignoreUpDirection
)

Parameters

ignoreUpDirection
Type: SystemBoolean
True if the loader should ignore the up direction, false otherwise.
See Also

Reference

ColladaIgnoreUpDirectionConfig Class
Assimp.Configs Namespace


ColladaIgnoreUpDirectionConfig Properties

The ColladaIgnoreUpDirectionConfig type exposes the following members.

Properties
 | Name | Description
 | ColladaIgnoreUpDirectionConfigName | Gets the string name used by ColladaIgnoreUpDirectionConfig.
Public property | DefaultValue | Gets the default property value. (Inherited from BooleanPropertyConfig.)
Public property | Name | Gets the property name. (Inherited from PropertyConfig.)
Public property | Value | Gets the property value. (Inherited from BooleanPropertyConfig.)
Top
See Also

Reference

ColladaIgnoreUpDirectionConfig Class
Assimp.Configs Namespace


ColladaIgnoreUpDirectionConfig.ColladaIgnoreUpDirectionConfigName Property

ColladaIgnoreUpDirectionConfigColladaIgnoreUpDirectionConfigName Property

Gets the string name used by ColladaIgnoreUpDirectionConfig.

Namespace: Assimp.Configs
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public static string ColladaIgnoreUpDirectionConfigName { get; }

Property Value

Type: String
See Also

Reference

ColladaIgnoreUpDirectionConfig Class
Assimp.Configs Namespace


ColladaIgnoreUpDirectionConfig Methods

The ColladaIgnoreUpDirectionConfig type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | SetDefaultValue | Sets the current value to the default value. (Inherited from BooleanPropertyConfig.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

ColladaIgnoreUpDirectionConfig Class
Assimp.Configs Namespace


DeboneAllOrNoneConfig Class

Configuration that requires all bones to qualify for deboning before any are removed.
Inheritance Hierarchy
SystemObject
Assimp.ConfigsPropertyConfig
Assimp.ConfigsBooleanPropertyConfig
Assimp.ConfigsDeboneAllOrNoneConfig

Namespace: Assimp.Configs
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public sealed class DeboneAllOrNoneConfig : BooleanPropertyConfig

The DeboneAllOrNoneConfig type exposes the following members.

Constructors
 | Name | Description
Public method | DeboneAllOrNoneConfig | Constructs a new DeboneAllOrNoneConfig.
Top
Properties
 | Name | Description
 | DeboneAllOrNoneConfigName | Gets the string name used by DeboneAllOrNoneConfig.
Public property | DefaultValue | Gets the default property value. (Inherited from BooleanPropertyConfig.)
Public property | Name | Gets the property name. (Inherited from PropertyConfig.)
Public property | Value | Gets the property value. (Inherited from BooleanPropertyConfig.)
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | SetDefaultValue | Sets the current value to the default value. (Inherited from BooleanPropertyConfig.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Assimp.Configs Namespace


DeboneAllOrNoneConfig Constructor

Constructs a new DeboneAllOrNoneConfig.

Namespace: Assimp.Configs
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public DeboneAllOrNoneConfig(
    bool allOrNone
)

Parameters

allOrNone
Type: SystemBoolean
True if all are required, false if none need to qualify.
See Also

Reference

DeboneAllOrNoneConfig Class
Assimp.Configs Namespace


DeboneAllOrNoneConfig Properties

The DeboneAllOrNoneConfig type exposes the following members.

Properties
 | Name | Description
 | DeboneAllOrNoneConfigName | Gets the string name used by DeboneAllOrNoneConfig.
Public property | DefaultValue | Gets the default property value. (Inherited from BooleanPropertyConfig.)
Public property | Name | Gets the property name. (Inherited from PropertyConfig.)
Public property | Value | Gets the property value. (Inherited from BooleanPropertyConfig.)
Top
See Also

Reference

DeboneAllOrNoneConfig Class
Assimp.Configs Namespace


DeboneAllOrNoneConfig.DeboneAllOrNoneConfigName Property

DeboneAllOrNoneConfigDeboneAllOrNoneConfigName Property

Gets the string name used by DeboneAllOrNoneConfig.

Namespace: Assimp.Configs
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public static string DeboneAllOrNoneConfigName { get; }

Property Value

Type: String
See Also

Reference

DeboneAllOrNoneConfig Class
Assimp.Configs Namespace


DeboneAllOrNoneConfig Methods

The DeboneAllOrNoneConfig type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | SetDefaultValue | Sets the current value to the default value. (Inherited from BooleanPropertyConfig.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

DeboneAllOrNoneConfig Class
Assimp.Configs Namespace


DeboneThresholdConfig Class

Configures the Debone threshold that is used to determine what bones are removed.
Inheritance Hierarchy
SystemObject
Assimp.ConfigsPropertyConfig
Assimp.ConfigsFloatPropertyConfig
Assimp.ConfigsDeboneThresholdConfig

Namespace: Assimp.Configs
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public sealed class DeboneThresholdConfig : FloatPropertyConfig

The DeboneThresholdConfig type exposes the following members.

Constructors
 | Name | Description
Public method | DeboneThresholdConfig | Constructs a new DeboneThresholdConfig.
Top
Properties
 | Name | Description
 | DeboneThresholdConfigName | Gets the string name used by DeboneThresholdConfig.
Public property | DefaultValue | Gets the default property value. (Inherited from FloatPropertyConfig.)
Public property | Name | Gets the property name. (Inherited from PropertyConfig.)
Public property | Value | Gets the property value. (Inherited from FloatPropertyConfig.)
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | SetDefaultValue | Sets the current value to the default value. (Inherited from FloatPropertyConfig.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Assimp.Configs Namespace


DeboneThresholdConfig Constructor

Constructs a new DeboneThresholdConfig.

Namespace: Assimp.Configs
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public DeboneThresholdConfig(
    float threshold
)

Parameters

threshold
Type: SystemSingle
The debone threshold.
See Also

Reference

DeboneThresholdConfig Class
Assimp.Configs Namespace


DeboneThresholdConfig Properties

The DeboneThresholdConfig type exposes the following members.

Properties
 | Name | Description
 | DeboneThresholdConfigName | Gets the string name used by DeboneThresholdConfig.
Public property | DefaultValue | Gets the default property value. (Inherited from FloatPropertyConfig.)
Public property | Name | Gets the property name. (Inherited from PropertyConfig.)
Public property | Value | Gets the property value. (Inherited from FloatPropertyConfig.)
Top
See Also

Reference

DeboneThresholdConfig Class
Assimp.Configs Namespace


DeboneThresholdConfig.DeboneThresholdConfigName Property

DeboneThresholdConfigDeboneThresholdConfigName Property

Gets the string name used by DeboneThresholdConfig.

Namespace: Assimp.Configs
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public static string DeboneThresholdConfigName { get; }

Property Value

Type: String
See Also

Reference

DeboneThresholdConfig Class
Assimp.Configs Namespace


DeboneThresholdConfig Methods

The DeboneThresholdConfig type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | SetDefaultValue | Sets the current value to the default value. (Inherited from FloatPropertyConfig.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

DeboneThresholdConfig Class
Assimp.Configs Namespace


FavorSpeedConfig Class

Configuration that is a hint to Assimp to favor speed against import quality. Enabling this option may result in faster loading, or it may not. It is just a hint to loaders and post-process steps to use faster code paths if possible. The default value is false.
Inheritance Hierarchy
SystemObject
Assimp.ConfigsPropertyConfig
Assimp.ConfigsBooleanPropertyConfig
Assimp.ConfigsFavorSpeedConfig

Namespace: Assimp.Configs
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public sealed class FavorSpeedConfig : BooleanPropertyConfig

The FavorSpeedConfig type exposes the following members.

Constructors
 | Name | Description
Public method | FavorSpeedConfig | Constructs a new FavorSpeedConfig.
Top
Properties
 | Name | Description
Public property | DefaultValue | Gets the default property value. (Inherited from BooleanPropertyConfig.)
 | FavorSpeedConfigName | Gets the string name used by FavorSpeedConfig.
Public property | Name | Gets the property name. (Inherited from PropertyConfig.)
Public property | Value | Gets the property value. (Inherited from BooleanPropertyConfig.)
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | SetDefaultValue | Sets the current value to the default value. (Inherited from BooleanPropertyConfig.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Assimp.Configs Namespace


FavorSpeedConfig Constructor

Constructs a new FavorSpeedConfig.

Namespace: Assimp.Configs
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public FavorSpeedConfig(
    bool favorSpeed
)

Parameters

favorSpeed
Type: SystemBoolean
True if Assimp should favor speed at the expense of quality, false otherwise.
See Also

Reference

FavorSpeedConfig Class
Assimp.Configs Namespace


FavorSpeedConfig Properties

The FavorSpeedConfig type exposes the following members.

Properties
 | Name | Description
Public property | DefaultValue | Gets the default property value. (Inherited from BooleanPropertyConfig.)
 | FavorSpeedConfigName | Gets the string name used by FavorSpeedConfig.
Public property | Name | Gets the property name. (Inherited from PropertyConfig.)
Public property | Value | Gets the property value. (Inherited from BooleanPropertyConfig.)
Top
See Also

Reference

FavorSpeedConfig Class
Assimp.Configs Namespace


FavorSpeedConfig.FavorSpeedConfigName Property

FavorSpeedConfigFavorSpeedConfigName Property

Gets the string name used by FavorSpeedConfig.

Namespace: Assimp.Configs
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public static string FavorSpeedConfigName { get; }

Property Value

Type: String
See Also

Reference

FavorSpeedConfig Class
Assimp.Configs Namespace


FavorSpeedConfig Methods

The FavorSpeedConfig type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | SetDefaultValue | Sets the current value to the default value. (Inherited from BooleanPropertyConfig.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

FavorSpeedConfig Class
Assimp.Configs Namespace


FBXImportAllGeometryLayersConfig Class

Specifies whether the FBX importer will merge all geometry layers present in the source file or import only the first. Default is true.
Inheritance Hierarchy
SystemObject
Assimp.ConfigsPropertyConfig
Assimp.ConfigsBooleanPropertyConfig
Assimp.ConfigsFBXImportAllGeometryLayersConfig

Namespace: Assimp.Configs
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public sealed class FBXImportAllGeometryLayersConfig : BooleanPropertyConfig

The FBXImportAllGeometryLayersConfig type exposes the following members.

Constructors
 | Name | Description
Public method | FBXImportAllGeometryLayersConfig | Constructs a new FBXImportAllGeometryLayersConfig.
Top
Properties
 | Name | Description
Public property | DefaultValue | Gets the default property value. (Inherited from BooleanPropertyConfig.)
 | FBXImportAllGeometryLayersConfigName | Gets the string name used by FBXImportAllGeometryLayersConfig.
Public property | Name | Gets the property name. (Inherited from PropertyConfig.)
Public property | Value | Gets the property value. (Inherited from BooleanPropertyConfig.)
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | SetDefaultValue | Sets the current value to the default value. (Inherited from BooleanPropertyConfig.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Assimp.Configs Namespace


FBXImportAllGeometryLayersConfig Constructor

Constructs a new FBXImportAllGeometryLayersConfig.

Namespace: Assimp.Configs
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public FBXImportAllGeometryLayersConfig(
    bool importAllGeometryLayers
)

Parameters

importAllGeometryLayers
Type: SystemBoolean
True if all geometry layers should be merged, false otherwise to take only the first layer.
See Also

Reference

FBXImportAllGeometryLayersConfig Class
Assimp.Configs Namespace


FBXImportAllGeometryLayersConfig Properties

The FBXImportAllGeometryLayersConfig type exposes the following members.

Properties
 | Name | Description
Public property | DefaultValue | Gets the default property value. (Inherited from BooleanPropertyConfig.)
 | FBXImportAllGeometryLayersConfigName | Gets the string name used by FBXImportAllGeometryLayersConfig.
Public property | Name | Gets the property name. (Inherited from PropertyConfig.)
Public property | Value | Gets the property value. (Inherited from BooleanPropertyConfig.)
Top
See Also

Reference

FBXImportAllGeometryLayersConfig Class
Assimp.Configs Namespace


FBXImportAllGeometryLayersConfig.FBXImportAllGeometryLayersConfigName Property

FBXImportAllGeometryLayersConfigFBXImportAllGeometryLayersConfigName Property

Gets the string name used by FBXImportAllGeometryLayersConfig.

Namespace: Assimp.Configs
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public static string FBXImportAllGeometryLayersConfigName { get; }

Property Value

Type: String
See Also

Reference

FBXImportAllGeometryLayersConfig Class
Assimp.Configs Namespace


FBXImportAllGeometryLayersConfig Methods

The FBXImportAllGeometryLayersConfig type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | SetDefaultValue | Sets the current value to the default value. (Inherited from BooleanPropertyConfig.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

FBXImportAllGeometryLayersConfig Class
Assimp.Configs Namespace


FBXImportAllMaterialsConfig Class

Specifies whether the FBX importer will import all materials present in the source file or take only the referenced materials, if the importer is configured to import materials at all. Otherwise this will have no effect. Default is false.
Inheritance Hierarchy
SystemObject
Assimp.ConfigsPropertyConfig
Assimp.ConfigsBooleanPropertyConfig
Assimp.ConfigsFBXImportAllMaterialsConfig

Namespace: Assimp.Configs
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public sealed class FBXImportAllMaterialsConfig : BooleanPropertyConfig

The FBXImportAllMaterialsConfig type exposes the following members.

Constructors
 | Name | Description
Public method | FBXImportAllMaterialsConfig | Constructs a new FBXImportAllMaterialsConfig.
Top
Properties
 | Name | Description
Public property | DefaultValue | Gets the default property value. (Inherited from BooleanPropertyConfig.)
 | FBXImportAllMaterialsConfigName | Gets the string name used by FBXImportAllMaterialsConfig.
Public property | Name | Gets the property name. (Inherited from PropertyConfig.)
Public property | Value | Gets the property value. (Inherited from BooleanPropertyConfig.)
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | SetDefaultValue | Sets the current value to the default value. (Inherited from BooleanPropertyConfig.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Assimp.Configs Namespace


FBXImportAllMaterialsConfig Constructor

Constructs a new FBXImportAllMaterialsConfig.

Namespace: Assimp.Configs
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public FBXImportAllMaterialsConfig(
    bool importAllMaterials
)

Parameters

importAllMaterials
Type: SystemBoolean
True if the FBX importer should import ALL materials even if not referenced, false otherwise (take only the referenced materials).
See Also

Reference

FBXImportAllMaterialsConfig Class
Assimp.Configs Namespace


FBXImportAllMaterialsConfig Properties

The FBXImportAllMaterialsConfig type exposes the following members.

Properties
 | Name | Description
Public property | DefaultValue | Gets the default property value. (Inherited from BooleanPropertyConfig.)
 | FBXImportAllMaterialsConfigName | Gets the string name used by FBXImportAllMaterialsConfig.
Public property | Name | Gets the property name. (Inherited from PropertyConfig.)
Public property | Value | Gets the property value. (Inherited from BooleanPropertyConfig.)
Top
See Also

Reference

FBXImportAllMaterialsConfig Class
Assimp.Configs Namespace


FBXImportAllMaterialsConfig.FBXImportAllMaterialsConfigName Property

FBXImportAllMaterialsConfigFBXImportAllMaterialsConfigName Property

Gets the string name used by FBXImportAllMaterialsConfig.

Namespace: Assimp.Configs
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public static string FBXImportAllMaterialsConfigName { get; }

Property Value

Type: String
See Also

Reference

FBXImportAllMaterialsConfig Class
Assimp.Configs Namespace


FBXImportAllMaterialsConfig Methods

The FBXImportAllMaterialsConfig type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | SetDefaultValue | Sets the current value to the default value. (Inherited from BooleanPropertyConfig.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

FBXImportAllMaterialsConfig Class
Assimp.Configs Namespace


FBXImportAnimationsConfig Class

Specifies whether the FBX importer will import animations. Default is true.
Inheritance Hierarchy
SystemObject
Assimp.ConfigsPropertyConfig
Assimp.ConfigsBooleanPropertyConfig
Assimp.ConfigsFBXImportAnimationsConfig

Namespace: Assimp.Configs
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public sealed class FBXImportAnimationsConfig : BooleanPropertyConfig

The FBXImportAnimationsConfig type exposes the following members.

Constructors
 | Name | Description
Public method | FBXImportAnimationsConfig | Constructs a new FBXImportAnimationsConfig.
Top
Properties
 | Name | Description
Public property | DefaultValue | Gets the default property value. (Inherited from BooleanPropertyConfig.)
 | FBXImportAnimationsConfigName | Gets the string name used by FBXImportAnimationsConfig.
Public property | Name | Gets the property name. (Inherited from PropertyConfig.)
Public property | Value | Gets the property value. (Inherited from BooleanPropertyConfig.)
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | SetDefaultValue | Sets the current value to the default value. (Inherited from BooleanPropertyConfig.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Assimp.Configs Namespace


FBXImportAnimationsConfig Constructor

Constructs a new FBXImportAnimationsConfig.

Namespace: Assimp.Configs
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public FBXImportAnimationsConfig(
    bool importAnimations
)

Parameters

importAnimations
Type: SystemBoolean
True if the FBX importer should import animations, false otherwise.
See Also

Reference

FBXImportAnimationsConfig Class
Assimp.Configs Namespace


FBXImportAnimationsConfig Properties

The FBXImportAnimationsConfig type exposes the following members.

Properties
 | Name | Description
Public property | DefaultValue | Gets the default property value. (Inherited from BooleanPropertyConfig.)
 | FBXImportAnimationsConfigName | Gets the string name used by FBXImportAnimationsConfig.
Public property | Name | Gets the property name. (Inherited from PropertyConfig.)
Public property | Value | Gets the property value. (Inherited from BooleanPropertyConfig.)
Top
See Also

Reference

FBXImportAnimationsConfig Class
Assimp.Configs Namespace


FBXImportAnimationsConfig.FBXImportAnimationsConfigName Property

FBXImportAnimationsConfigFBXImportAnimationsConfigName Property

Gets the string name used by FBXImportAnimationsConfig.

Namespace: Assimp.Configs
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public static string FBXImportAnimationsConfigName { get; }

Property Value

Type: String
See Also

Reference

FBXImportAnimationsConfig Class
Assimp.Configs Namespace


FBXImportAnimationsConfig Methods

The FBXImportAnimationsConfig type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | SetDefaultValue | Sets the current value to the default value. (Inherited from BooleanPropertyConfig.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

FBXImportAnimationsConfig Class
Assimp.Configs Namespace


FBXImportCamerasConfig Class

Specifies whether the FBX importer will import cameras. Default is true.
Inheritance Hierarchy
SystemObject
Assimp.ConfigsPropertyConfig
Assimp.ConfigsBooleanPropertyConfig
Assimp.ConfigsFBXImportCamerasConfig

Namespace: Assimp.Configs
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public sealed class FBXImportCamerasConfig : BooleanPropertyConfig

The FBXImportCamerasConfig type exposes the following members.

Constructors
 | Name | Description
Public method | FBXImportCamerasConfig | Constructs a new FBXImportCamerasConfig.
Top
Properties
 | Name | Description
Public property | DefaultValue | Gets the default property value. (Inherited from BooleanPropertyConfig.)
 | FBXImportCamerasConfigName | Gets the string name used by FBXImportCamerasConfig.
Public property | Name | Gets the property name. (Inherited from PropertyConfig.)
Public property | Value | Gets the property value. (Inherited from BooleanPropertyConfig.)
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | SetDefaultValue | Sets the current value to the default value. (Inherited from BooleanPropertyConfig.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Assimp.Configs Namespace


FBXImportCamerasConfig Constructor

Constructs a new FBXImportCamerasConfig.

Namespace: Assimp.Configs
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public FBXImportCamerasConfig(
    bool importCameras
)

Parameters

importCameras
Type: SystemBoolean
True if the FBX importer should import cameras, false otherwise.
See Also

Reference

FBXImportCamerasConfig Class
Assimp.Configs Namespace


FBXImportCamerasConfig Properties

The FBXImportCamerasConfig type exposes the following members.

Properties
 | Name | Description
Public property | DefaultValue | Gets the default property value. (Inherited from BooleanPropertyConfig.)
 | FBXImportCamerasConfigName | Gets the string name used by FBXImportCamerasConfig.
Public property | Name | Gets the property name. (Inherited from PropertyConfig.)
Public property | Value | Gets the property value. (Inherited from BooleanPropertyConfig.)
Top
See Also

Reference

FBXImportCamerasConfig Class
Assimp.Configs Namespace


FBXImportCamerasConfig.FBXImportCamerasConfigName Property

FBXImportCamerasConfigFBXImportCamerasConfigName Property

Gets the string name used by FBXImportCamerasConfig.

Namespace: Assimp.Configs
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public static string FBXImportCamerasConfigName { get; }

Property Value

Type: String
See Also

Reference

FBXImportCamerasConfig Class
Assimp.Configs Namespace


FBXImportCamerasConfig Methods

The FBXImportCamerasConfig type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | SetDefaultValue | Sets the current value to the default value. (Inherited from BooleanPropertyConfig.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

FBXImportCamerasConfig Class
Assimp.Configs Namespace


FBXImportEmbeddedTexturesConfig Class

Specifies whether the FBX importer will import embedded textures. Default is true.
Inheritance Hierarchy
SystemObject
Assimp.ConfigsPropertyConfig
Assimp.ConfigsBooleanPropertyConfig
Assimp.ConfigsFBXImportEmbeddedTexturesConfig

Namespace: Assimp.Configs
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public sealed class FBXImportEmbeddedTexturesConfig : BooleanPropertyConfig

The FBXImportEmbeddedTexturesConfig type exposes the following members.

Constructors
 | Name | Description
Public method | FBXImportEmbeddedTexturesConfig | Constructs a new FBXImportEmbeddedTexturesConfig.
Top
Properties
 | Name | Description
Public property | DefaultValue | Gets the default property value. (Inherited from BooleanPropertyConfig.)
 | FBXImportEmbeddedTexturesConfigName | Gets the string name used by FBXImportEmbeddedTexturesConfig.
Public property | Name | Gets the property name. (Inherited from PropertyConfig.)
Public property | Value | Gets the property value. (Inherited from BooleanPropertyConfig.)
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | SetDefaultValue | Sets the current value to the default value. (Inherited from BooleanPropertyConfig.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Assimp.Configs Namespace
Assimp.ConfigsBooleanPropertyConfig


FBXImportEmbeddedTexturesConfig Constructor

Constructs a new FBXImportEmbeddedTexturesConfig.

Namespace: Assimp.Configs
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public FBXImportEmbeddedTexturesConfig(
    bool importTextures
)

Parameters

importTextures
Type: SystemBoolean
True if the FBX importer should import embedded textures, false otherwise.
See Also

Reference

FBXImportEmbeddedTexturesConfig Class
Assimp.Configs Namespace


FBXImportEmbeddedTexturesConfig Properties

The FBXImportEmbeddedTexturesConfig type exposes the following members.

Properties
 | Name | Description
Public property | DefaultValue | Gets the default property value. (Inherited from BooleanPropertyConfig.)
 | FBXImportEmbeddedTexturesConfigName | Gets the string name used by FBXImportEmbeddedTexturesConfig.
Public property | Name | Gets the property name. (Inherited from PropertyConfig.)
Public property | Value | Gets the property value. (Inherited from BooleanPropertyConfig.)
Top
See Also

Reference

FBXImportEmbeddedTexturesConfig Class
Assimp.Configs Namespace


FBXImportEmbeddedTexturesConfig.FBXImportEmbeddedTexturesConfigName Property

FBXImportEmbeddedTexturesConfigFBXImportEmbeddedTexturesConfigName Property

Gets the string name used by FBXImportEmbeddedTexturesConfig.

Namespace: Assimp.Configs
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public static string FBXImportEmbeddedTexturesConfigName { get; }

Property Value

Type: String
See Also

Reference

FBXImportEmbeddedTexturesConfig Class
Assimp.Configs Namespace


FBXImportEmbeddedTexturesConfig Methods

The FBXImportEmbeddedTexturesConfig type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | SetDefaultValue | Sets the current value to the default value. (Inherited from BooleanPropertyConfig.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

FBXImportEmbeddedTexturesConfig Class
Assimp.Configs Namespace


FBXImportLightsConfig Class

Specifies whether the FBX importer will import lights. Default is true.
Inheritance Hierarchy
SystemObject
Assimp.ConfigsPropertyConfig
Assimp.ConfigsBooleanPropertyConfig
Assimp.ConfigsFBXImportLightsConfig

Namespace: Assimp.Configs
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public sealed class FBXImportLightsConfig : BooleanPropertyConfig

The FBXImportLightsConfig type exposes the following members.

Constructors
 | Name | Description
Public method | FBXImportLightsConfig | Constructs a new FBXImportLightsConfig.
Top
Properties
 | Name | Description
Public property | DefaultValue | Gets the default property value. (Inherited from BooleanPropertyConfig.)
 | FBXImportLightsConfigName | Gets the string name used by FBXImportLightsConfig.
Public property | Name | Gets the property name. (Inherited from PropertyConfig.)
Public property | Value | Gets the property value. (Inherited from BooleanPropertyConfig.)
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | SetDefaultValue | Sets the current value to the default value. (Inherited from BooleanPropertyConfig.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Assimp.Configs Namespace


FBXImportLightsConfig Constructor

Constructs a new FBXImportLightsConfig.

Namespace: Assimp.Configs
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public FBXImportLightsConfig(
    bool importLights
)

Parameters

importLights
Type: SystemBoolean
True if the FBX importer should import lights, false otherwise.
See Also

Reference

FBXImportLightsConfig Class
Assimp.Configs Namespace


FBXImportLightsConfig Properties

The FBXImportLightsConfig type exposes the following members.

Properties
 | Name | Description
Public property | DefaultValue | Gets the default property value. (Inherited from BooleanPropertyConfig.)
 | FBXImportLightsConfigName | Gets the string name used by FBXImportLightsConfig.
Public property | Name | Gets the property name. (Inherited from PropertyConfig.)
Public property | Value | Gets the property value. (Inherited from BooleanPropertyConfig.)
Top
See Also

Reference

FBXImportLightsConfig Class
Assimp.Configs Namespace


FBXImportLightsConfig.FBXImportLightsConfigName Property

FBXImportLightsConfigFBXImportLightsConfigName Property

Gets the string name used by FBXImportLightsConfig.

Namespace: Assimp.Configs
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public static string FBXImportLightsConfigName { get; }

Property Value

Type: String
See Also

Reference

FBXImportLightsConfig Class
Assimp.Configs Namespace


FBXImportLightsConfig Methods

The FBXImportLightsConfig type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | SetDefaultValue | Sets the current value to the default value. (Inherited from BooleanPropertyConfig.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

FBXImportLightsConfig Class
Assimp.Configs Namespace


FBXImportMaterialsConfig Class

Specifies whether the FBX importer will import materials. Default is true.
Inheritance Hierarchy
SystemObject
Assimp.ConfigsPropertyConfig
Assimp.ConfigsBooleanPropertyConfig
Assimp.ConfigsFBXImportMaterialsConfig

Namespace: Assimp.Configs
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public sealed class FBXImportMaterialsConfig : BooleanPropertyConfig

The FBXImportMaterialsConfig type exposes the following members.

Constructors
 | Name | Description
Public method | FBXImportMaterialsConfig | Constructs a new FBXImportMaterialsConfig.
Top
Properties
 | Name | Description
Public property | DefaultValue | Gets the default property value. (Inherited from BooleanPropertyConfig.)
 | FBXImportMaterialsConfigName | Gets the string name used by FBXImportMaterialsConfig.
Public property | Name | Gets the property name. (Inherited from PropertyConfig.)
Public property | Value | Gets the property value. (Inherited from BooleanPropertyConfig.)
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | SetDefaultValue | Sets the current value to the default value. (Inherited from BooleanPropertyConfig.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Assimp.Configs Namespace


FBXImportMaterialsConfig Constructor

Constructs a new FBXImportMaterialsConfig.

Namespace: Assimp.Configs
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public FBXImportMaterialsConfig(
    bool importMaterials
)

Parameters

importMaterials
Type: SystemBoolean
True if the FBX importer should import materials, false otherwise.
See Also

Reference

FBXImportMaterialsConfig Class
Assimp.Configs Namespace


FBXImportMaterialsConfig Properties

The FBXImportMaterialsConfig type exposes the following members.

Properties
 | Name | Description
Public property | DefaultValue | Gets the default property value. (Inherited from BooleanPropertyConfig.)
 | FBXImportMaterialsConfigName | Gets the string name used by FBXImportMaterialsConfig.
Public property | Name | Gets the property name. (Inherited from PropertyConfig.)
Public property | Value | Gets the property value. (Inherited from BooleanPropertyConfig.)
Top
See Also

Reference

FBXImportMaterialsConfig Class
Assimp.Configs Namespace


FBXImportMaterialsConfig.FBXImportMaterialsConfigName Property

FBXImportMaterialsConfigFBXImportMaterialsConfigName Property

Gets the string name used by FBXImportMaterialsConfig.

Namespace: Assimp.Configs
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public static string FBXImportMaterialsConfigName { get; }

Property Value

Type: String
See Also

Reference

FBXImportMaterialsConfig Class
Assimp.Configs Namespace


FBXImportMaterialsConfig Methods

The FBXImportMaterialsConfig type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | SetDefaultValue | Sets the current value to the default value. (Inherited from BooleanPropertyConfig.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

FBXImportMaterialsConfig Class
Assimp.Configs Namespace


FBXImportSearchEmbeddedTexturesConfig Class

Specifies if the FBX importer should search for embedded loaded textures, where no embedded texture data is provided. Default is false.
Inheritance Hierarchy
SystemObject
Assimp.ConfigsPropertyConfig
Assimp.ConfigsBooleanPropertyConfig
Assimp.ConfigsFBXImportSearchEmbeddedTexturesConfig

Namespace: Assimp.Configs
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public sealed class FBXImportSearchEmbeddedTexturesConfig : BooleanPropertyConfig

The FBXImportSearchEmbeddedTexturesConfig type exposes the following members.

Constructors
 | Name | Description
Public method | FBXImportSearchEmbeddedTexturesConfig | Constructs a new FBXImportSearchEmbeddedTexturesConfig.
Top
Properties
 | Name | Description
Public property | DefaultValue | Gets the default property value. (Inherited from BooleanPropertyConfig.)
 | FBXImportSearchEmbeddedTexturesConfigName | Gets the string name used by FBXImportSearchEmbeddedTexturesConfig.
Public property | Name | Gets the property name. (Inherited from PropertyConfig.)
Public property | Value | Gets the property value. (Inherited from BooleanPropertyConfig.)
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | SetDefaultValue | Sets the current value to the default value. (Inherited from BooleanPropertyConfig.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Assimp.Configs Namespace


FBXImportSearchEmbeddedTexturesConfig Constructor

Constructs a new FBXImportSearchEmbeddedTexturesConfig.

Namespace: Assimp.Configs
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public FBXImportSearchEmbeddedTexturesConfig(
    bool searchEmbeddedTextures
)

Parameters

searchEmbeddedTextures
Type: SystemBoolean
True if the FBX importer should search for embedded loaded textures, where no embedded texture data is provided.
See Also

Reference

FBXImportSearchEmbeddedTexturesConfig Class
Assimp.Configs Namespace


FBXImportSearchEmbeddedTexturesConfig Properties

The FBXImportSearchEmbeddedTexturesConfig type exposes the following members.

Properties
 | Name | Description
Public property | DefaultValue | Gets the default property value. (Inherited from BooleanPropertyConfig.)
 | FBXImportSearchEmbeddedTexturesConfigName | Gets the string name used by FBXImportSearchEmbeddedTexturesConfig.
Public property | Name | Gets the property name. (Inherited from PropertyConfig.)
Public property | Value | Gets the property value. (Inherited from BooleanPropertyConfig.)
Top
See Also

Reference

FBXImportSearchEmbeddedTexturesConfig Class
Assimp.Configs Namespace


FBXImportSearchEmbeddedTexturesConfig.FBXImportSearchEmbeddedTexturesConfigName Property

FBXImportSearchEmbeddedTexturesConfigFBXImportSearchEmbeddedTexturesConfigName Property

Gets the string name used by FBXImportSearchEmbeddedTexturesConfig.

Namespace: Assimp.Configs
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public static string FBXImportSearchEmbeddedTexturesConfigName { get; }

Property Value

Type: String
See Also

Reference

FBXImportSearchEmbeddedTexturesConfig Class
Assimp.Configs Namespace


FBXImportSearchEmbeddedTexturesConfig Methods

The FBXImportSearchEmbeddedTexturesConfig type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | SetDefaultValue | Sets the current value to the default value. (Inherited from BooleanPropertyConfig.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

FBXImportSearchEmbeddedTexturesConfig Class
Assimp.Configs Namespace


FBXOptimizeEmptyAnimationCurvesConfig Class

Specifies whether the importer will drop empty animation curves or animation curves which match the bind pose transformation over their entire defined range. Default value is true.
Inheritance Hierarchy
SystemObject
Assimp.ConfigsPropertyConfig
Assimp.ConfigsBooleanPropertyConfig
Assimp.ConfigsFBXOptimizeEmptyAnimationCurvesConfig

Namespace: Assimp.Configs
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public sealed class FBXOptimizeEmptyAnimationCurvesConfig : BooleanPropertyConfig

The FBXOptimizeEmptyAnimationCurvesConfig type exposes the following members.

Constructors
 | Name | Description
Public method | FBXOptimizeEmptyAnimationCurvesConfig | Constructs a new FBXOptimizeEmptyAnimationCurvesConfig.
Top
Properties
 | Name | Description
Public property | DefaultValue | Gets the default property value. (Inherited from BooleanPropertyConfig.)
 | FBXOptimizeEmptyAnimationCurvesConfigName | Gets the string name used by FBXOptimizeEmptyAnimationCurvesConfig.
Public property | Name | Gets the property name. (Inherited from PropertyConfig.)
Public property | Value | Gets the property value. (Inherited from BooleanPropertyConfig.)
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | SetDefaultValue | Sets the current value to the default value. (Inherited from BooleanPropertyConfig.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Assimp.Configs Namespace


FBXOptimizeEmptyAnimationCurvesConfig Constructor

Constructs a new FBXOptimizeEmptyAnimationCurvesConfig.

Namespace: Assimp.Configs
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public FBXOptimizeEmptyAnimationCurvesConfig(
    bool optimizeEmptyAnimations
)

Parameters

optimizeEmptyAnimations
Type: SystemBoolean
True if empty animation curves should be dropped, false otherwise.
See Also

Reference

FBXOptimizeEmptyAnimationCurvesConfig Class
Assimp.Configs Namespace


FBXOptimizeEmptyAnimationCurvesConfig Properties

The FBXOptimizeEmptyAnimationCurvesConfig type exposes the following members.

Properties
 | Name | Description
Public property | DefaultValue | Gets the default property value. (Inherited from BooleanPropertyConfig.)
 | FBXOptimizeEmptyAnimationCurvesConfigName | Gets the string name used by FBXOptimizeEmptyAnimationCurvesConfig.
Public property | Name | Gets the property name. (Inherited from PropertyConfig.)
Public property | Value | Gets the property value. (Inherited from BooleanPropertyConfig.)
Top
See Also

Reference

FBXOptimizeEmptyAnimationCurvesConfig Class
Assimp.Configs Namespace


FBXOptimizeEmptyAnimationCurvesConfig.FBXOptimizeEmptyAnimationCurvesConfigName Property

FBXOptimizeEmptyAnimationCurvesConfigFBXOptimizeEmptyAnimationCurvesConfigName Property

Gets the string name used by FBXOptimizeEmptyAnimationCurvesConfig.

Namespace: Assimp.Configs
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public static string FBXOptimizeEmptyAnimationCurvesConfigName { get; }

Property Value

Type: String
See Also

Reference

FBXOptimizeEmptyAnimationCurvesConfig Class
Assimp.Configs Namespace


FBXOptimizeEmptyAnimationCurvesConfig Methods

The FBXOptimizeEmptyAnimationCurvesConfig type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | SetDefaultValue | Sets the current value to the default value. (Inherited from BooleanPropertyConfig.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

FBXOptimizeEmptyAnimationCurvesConfig Class
Assimp.Configs Namespace


FBXPreservePivotsConfig Class

Specifies whether the FBX importer will preserve pivot points for transformations (as extra nodes). If set to false, pivots and offsets will be evaluated whenever possible. Default value is true.
Inheritance Hierarchy
SystemObject
Assimp.ConfigsPropertyConfig
Assimp.ConfigsBooleanPropertyConfig
Assimp.ConfigsFBXPreservePivotsConfig

Namespace: Assimp.Configs
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public sealed class FBXPreservePivotsConfig : BooleanPropertyConfig

The FBXPreservePivotsConfig type exposes the following members.

Constructors
 | Name | Description
Public method | FBXPreservePivotsConfig | Constructs a new FBXPreservePivotsConfig.
Top
Properties
 | Name | Description
Public property | DefaultValue | Gets the default property value. (Inherited from BooleanPropertyConfig.)
 | FBXPreservePivotsConfigName | Gets the string name used by FBXPreservePivotsConfig.
Public property | Name | Gets the property name. (Inherited from PropertyConfig.)
Public property | Value | Gets the property value. (Inherited from BooleanPropertyConfig.)
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | SetDefaultValue | Sets the current value to the default value. (Inherited from BooleanPropertyConfig.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Assimp.Configs Namespace


FBXPreservePivotsConfig Constructor

Constructs a new FBXPreservePivotsConfig.

Namespace: Assimp.Configs
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public FBXPreservePivotsConfig(
    bool preservePivots
)

Parameters

preservePivots
Type: SystemBoolean
True if pivots should be preserved, false otherwise.
See Also

Reference

FBXPreservePivotsConfig Class
Assimp.Configs Namespace


FBXPreservePivotsConfig Properties

The FBXPreservePivotsConfig type exposes the following members.

Properties
 | Name | Description
Public property | DefaultValue | Gets the default property value. (Inherited from BooleanPropertyConfig.)
 | FBXPreservePivotsConfigName | Gets the string name used by FBXPreservePivotsConfig.
Public property | Name | Gets the property name. (Inherited from PropertyConfig.)
Public property | Value | Gets the property value. (Inherited from BooleanPropertyConfig.)
Top
See Also

Reference

FBXPreservePivotsConfig Class
Assimp.Configs Namespace


FBXPreservePivotsConfig.FBXPreservePivotsConfigName Property

FBXPreservePivotsConfigFBXPreservePivotsConfigName Property

Gets the string name used by FBXPreservePivotsConfig.

Namespace: Assimp.Configs
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public static string FBXPreservePivotsConfigName { get; }

Property Value

Type: String
See Also

Reference

FBXPreservePivotsConfig Class
Assimp.Configs Namespace


FBXPreservePivotsConfig Methods

The FBXPreservePivotsConfig type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | SetDefaultValue | Sets the current value to the default value. (Inherited from BooleanPropertyConfig.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

FBXPreservePivotsConfig Class
Assimp.Configs Namespace


FBXStrictModeConfig Class

Specifies whether the FBX importer will act in strict mode in which only the FBX 2013 format is supported and any other sub formats are rejected. FBX 2013 is the primary target for the importer, so this format is best supported and well-tested. Default is false.
Inheritance Hierarchy
SystemObject
Assimp.ConfigsPropertyConfig
Assimp.ConfigsBooleanPropertyConfig
Assimp.ConfigsFBXStrictModeConfig

Namespace: Assimp.Configs
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public sealed class FBXStrictModeConfig : BooleanPropertyConfig

The FBXStrictModeConfig type exposes the following members.

Constructors
 | Name | Description
Public method | FBXStrictModeConfig | Constructs a new FBXStrictModeConfig.
Top
Properties
 | Name | Description
Public property | DefaultValue | Gets the default property value. (Inherited from BooleanPropertyConfig.)
 | FBXStrictModeConfigName | Gets the string name used by FBXStrictModeConfig.
Public property | Name | Gets the property name. (Inherited from PropertyConfig.)
Public property | Value | Gets the property value. (Inherited from BooleanPropertyConfig.)
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | SetDefaultValue | Sets the current value to the default value. (Inherited from BooleanPropertyConfig.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Assimp.Configs Namespace


FBXStrictModeConfig Constructor

Constructs a new FBXStrictModeConfig.

Namespace: Assimp.Configs
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public FBXStrictModeConfig(
    bool useStrictMode
)

Parameters

useStrictMode
Type: SystemBoolean
True if FBX strict mode should be used, false otherwise.
See Also

Reference

FBXStrictModeConfig Class
Assimp.Configs Namespace


FBXStrictModeConfig Properties

The FBXStrictModeConfig type exposes the following members.

Properties
 | Name | Description
Public property | DefaultValue | Gets the default property value. (Inherited from BooleanPropertyConfig.)
 | FBXStrictModeConfigName | Gets the string name used by FBXStrictModeConfig.
Public property | Name | Gets the property name. (Inherited from PropertyConfig.)
Public property | Value | Gets the property value. (Inherited from BooleanPropertyConfig.)
Top
See Also

Reference

FBXStrictModeConfig Class
Assimp.Configs Namespace


FBXStrictModeConfig.FBXStrictModeConfigName Property

FBXStrictModeConfigFBXStrictModeConfigName Property

Gets the string name used by FBXStrictModeConfig.

Namespace: Assimp.Configs
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public static string FBXStrictModeConfigName { get; }

Property Value

Type: String
See Also

Reference

FBXStrictModeConfig Class
Assimp.Configs Namespace


FBXStrictModeConfig Methods

The FBXStrictModeConfig type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | SetDefaultValue | Sets the current value to the default value. (Inherited from BooleanPropertyConfig.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

FBXStrictModeConfig Class
Assimp.Configs Namespace


FloatPropertyConfig Class

Describes a float configuration property.
Inheritance Hierarchy
SystemObject
Assimp.ConfigsPropertyConfig
Assimp.ConfigsFloatPropertyConfig
More...

Namespace: Assimp.Configs
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public class FloatPropertyConfig : PropertyConfig

The FloatPropertyConfig type exposes the following members.

Constructors
 | Name | Description
Public method | FloatPropertyConfig(String, Single) | Constructs a new FloatPropertyConfig.
Public method | FloatPropertyConfig(String, Single, Single) | Constructs a new FloatPropertyConfig with a default value.
Top
Properties
 | Name | Description
Public property | DefaultValue | Gets the default property value.
Public property | Name | Gets the property name. (Inherited from PropertyConfig.)
Public property | Value | Gets the property value.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | OnApplyValue | Applies the property value to the given Assimp property store. (Overrides PropertyConfigOnApplyValue(IntPtr).)
Public method | SetDefaultValue | Sets the current value to the default value. (Overrides PropertyConfigSetDefaultValue.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Assimp.Configs Namespace
Inheritance Hierarchy
SystemObject
Assimp.ConfigsPropertyConfig
Assimp.ConfigsFloatPropertyConfig
Assimp.ConfigsAnimationAccuracyConfig
Assimp.ConfigsDeboneThresholdConfig
Assimp.ConfigsGlobalScaleConfig
Assimp.ConfigsIFCSmoothingAngleConfig
Assimp.ConfigsNormalSmoothingAngleConfig
Assimp.ConfigsTangentSmoothingAngleConfig


FloatPropertyConfig Constructor

Overload List
 | Name | Description
Public method | FloatPropertyConfig(String, Single) | Constructs a new FloatPropertyConfig.
Public method | FloatPropertyConfig(String, Single, Single) | Constructs a new FloatPropertyConfig with a default value.
Top
See Also

Reference

FloatPropertyConfig Class
Assimp.Configs Namespace


FloatPropertyConfig Constructor (String, Single)

Constructs a new FloatPropertyConfig.

Namespace: Assimp.Configs
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public FloatPropertyConfig(
    string name,
    float value
)

Parameters

name
Type: SystemString
Name of the property
value
Type: SystemSingle
Property value
See Also

Reference

FloatPropertyConfig Class
FloatPropertyConfig Overload
Assimp.Configs Namespace


FloatPropertyConfig Constructor (String, Single, Single)

Constructs a new FloatPropertyConfig with a default value.

Namespace: Assimp.Configs
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public FloatPropertyConfig(
    string name,
    float value,
    float defaultValue
)

Parameters

name
Type: SystemString
Name of the property
value
Type: SystemSingle
Property value
defaultValue
Type: SystemSingle
The default property value
See Also

Reference

FloatPropertyConfig Class
FloatPropertyConfig Overload
Assimp.Configs Namespace


FloatPropertyConfig Properties

The FloatPropertyConfig type exposes the following members.

Properties
 | Name | Description
Public property | DefaultValue | Gets the default property value.
Public property | Name | Gets the property name. (Inherited from PropertyConfig.)
Public property | Value | Gets the property value.
Top
See Also

Reference

FloatPropertyConfig Class
Assimp.Configs Namespace


FloatPropertyConfig.DefaultValue Property

FloatPropertyConfigDefaultValue Property

Gets the default property value.

Namespace: Assimp.Configs
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public float DefaultValue { get; }

Property Value

Type: Single
See Also

Reference

FloatPropertyConfig Class
Assimp.Configs Namespace


FloatPropertyConfig.Value Property

FloatPropertyConfigValue Property

Gets the property value.

Namespace: Assimp.Configs
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public float Value { get; set; }

Property Value

Type: Single
See Also

Reference

FloatPropertyConfig Class
Assimp.Configs Namespace


FloatPropertyConfig Methods

The FloatPropertyConfig type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | OnApplyValue | Applies the property value to the given Assimp property store. (Overrides PropertyConfigOnApplyValue(IntPtr).)
Public method | SetDefaultValue | Sets the current value to the default value. (Overrides PropertyConfigSetDefaultValue.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

FloatPropertyConfig Class
Assimp.Configs Namespace


FloatPropertyConfig.OnApplyValue Method

FloatPropertyConfigOnApplyValue Method

Applies the property value to the given Assimp property store.

Namespace: Assimp.Configs
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
protected override void OnApplyValue(
    IntPtr propStore
)

Parameters

propStore
Type: SystemIntPtr
Assimp property store
See Also

Reference

FloatPropertyConfig Class
Assimp.Configs Namespace


FloatPropertyConfig.SetDefaultValue Method

FloatPropertyConfigSetDefaultValue Method

Sets the current value to the default value.

Namespace: Assimp.Configs
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public override void SetDefaultValue()
See Also

Reference

FloatPropertyConfig Class
Assimp.Configs Namespace


GlobalKeyFrameImportConfig Class

Sets the vertex animation keyframe to be imported. Assimp does not support vertex keyframes (only bone animation is supported). the library reads only one keyframe with vertex animations. By default this is the first frame. This config sets the "global" keyframe that will be imported. There are other configs for specific importers that will override the global setting.
Inheritance Hierarchy
SystemObject
Assimp.ConfigsPropertyConfig
Assimp.ConfigsIntegerPropertyConfig
Assimp.ConfigsGlobalKeyFrameImportConfig

Namespace: Assimp.Configs
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public sealed class GlobalKeyFrameImportConfig : IntegerPropertyConfig

The GlobalKeyFrameImportConfig type exposes the following members.

Constructors
 | Name | Description
Public method | GlobalKeyFrameImportConfig | Constructs a new GlobalKeyFrameImportConfig.
Top
Properties
 | Name | Description
Public property | DefaultValue | Gets the default property value. (Inherited from IntegerPropertyConfig.)
 | GlobalKeyFrameImportConfigName | Gets the string name used by GlobalKeyFrameImportConfig.
Public property | Name | Gets the property name. (Inherited from PropertyConfig.)
Public property | Value | Gets the property value. (Inherited from IntegerPropertyConfig.)
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | SetDefaultValue | Sets the current value to the default value. (Inherited from IntegerPropertyConfig.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Assimp.Configs Namespace


GlobalKeyFrameImportConfig Constructor

Constructs a new GlobalKeyFrameImportConfig.

Namespace: Assimp.Configs
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public GlobalKeyFrameImportConfig(
    int keyFrame
)

Parameters

keyFrame
Type: SystemInt32
Keyframe index
See Also

Reference

GlobalKeyFrameImportConfig Class
Assimp.Configs Namespace


GlobalKeyFrameImportConfig Properties

The GlobalKeyFrameImportConfig type exposes the following members.

Properties
 | Name | Description
Public property | DefaultValue | Gets the default property value. (Inherited from IntegerPropertyConfig.)
 | GlobalKeyFrameImportConfigName | Gets the string name used by GlobalKeyFrameImportConfig.
Public property | Name | Gets the property name. (Inherited from PropertyConfig.)
Public property | Value | Gets the property value. (Inherited from IntegerPropertyConfig.)
Top
See Also

Reference

GlobalKeyFrameImportConfig Class
Assimp.Configs Namespace


GlobalKeyFrameImportConfig.GlobalKeyFrameImportConfigName Property

GlobalKeyFrameImportConfigGlobalKeyFrameImportConfigName Property

Gets the string name used by GlobalKeyFrameImportConfig.

Namespace: Assimp.Configs
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public static string GlobalKeyFrameImportConfigName { get; }

Property Value

Type: String
See Also

Reference

GlobalKeyFrameImportConfig Class
Assimp.Configs Namespace


GlobalKeyFrameImportConfig Methods

The GlobalKeyFrameImportConfig type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | SetDefaultValue | Sets the current value to the default value. (Inherited from IntegerPropertyConfig.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

GlobalKeyFrameImportConfig Class
Assimp.Configs Namespace


GlobalScaleConfig Class

Configures the GlobalScale step to scale the entire scene by a certain amount. Some importers provide a mechanism to define a scaling unit for the model, which this processing step can utilize.
Inheritance Hierarchy
SystemObject
Assimp.ConfigsPropertyConfig
Assimp.ConfigsFloatPropertyConfig
Assimp.ConfigsGlobalScaleConfig

Namespace: Assimp.Configs
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public sealed class GlobalScaleConfig : FloatPropertyConfig

The GlobalScaleConfig type exposes the following members.

Constructors
 | Name | Description
Public method | GlobalScaleConfig | Constructs a new GlobalScaleConfig.
Top
Properties
 | Name | Description
Public property | DefaultValue | Gets the default property value. (Inherited from FloatPropertyConfig.)
 | GlobalScaleConfigName | Gets the string name used by GlobalScaleConfig.
Public property | Name | Gets the property name. (Inherited from PropertyConfig.)
Public property | Value | Gets the property value. (Inherited from FloatPropertyConfig.)
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | SetDefaultValue | Sets the current value to the default value. (Inherited from FloatPropertyConfig.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Assimp.Configs Namespace
Assimp.ConfigsFloatPropertyConfig


GlobalScaleConfig Constructor

Constructs a new GlobalScaleConfig.

Namespace: Assimp.Configs
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public GlobalScaleConfig(
    float globalScale
)

Parameters

globalScale
Type: SystemSingle
Value to scale the entire scene by.
See Also

Reference

GlobalScaleConfig Class
Assimp.Configs Namespace


GlobalScaleConfig Properties

The GlobalScaleConfig type exposes the following members.

Properties
 | Name | Description
Public property | DefaultValue | Gets the default property value. (Inherited from FloatPropertyConfig.)
 | GlobalScaleConfigName | Gets the string name used by GlobalScaleConfig.
Public property | Name | Gets the property name. (Inherited from PropertyConfig.)
Public property | Value | Gets the property value. (Inherited from FloatPropertyConfig.)
Top
See Also

Reference

GlobalScaleConfig Class
Assimp.Configs Namespace


GlobalScaleConfig.GlobalScaleConfigName Property

GlobalScaleConfigGlobalScaleConfigName Property

Gets the string name used by GlobalScaleConfig.

Namespace: Assimp.Configs
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public static string GlobalScaleConfigName { get; }

Property Value

Type: String
See Also

Reference

GlobalScaleConfig Class
Assimp.Configs Namespace


GlobalScaleConfig Methods

The GlobalScaleConfig type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | SetDefaultValue | Sets the current value to the default value. (Inherited from FloatPropertyConfig.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

GlobalScaleConfig Class
Assimp.Configs Namespace


IFCCylindricalTessellationConfig Class

Specifies the tessellation for IFC cylindrical shapes. E.g. the number of segments used to approximate a circle. Accepted range of values is between [3, 180].
Inheritance Hierarchy
SystemObject
Assimp.ConfigsPropertyConfig
Assimp.ConfigsIntegerPropertyConfig
Assimp.ConfigsIFCCylindricalTessellationConfig

Namespace: Assimp.Configs
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public sealed class IFCCylindricalTessellationConfig : IntegerPropertyConfig

The IFCCylindricalTessellationConfig type exposes the following members.

Constructors
 | Name | Description
Public method | IFCCylindricalTessellationConfig | Constructs a new IFCCylindricalTessellationConfig.
Top
Properties
 | Name | Description
Public property | DefaultValue | Gets the default property value. (Inherited from IntegerPropertyConfig.)
 | IFCCylindricalTessellationConfigName | Gets the string name used by IFCCylindricalTessellationConfig.
Public property | Name | Gets the property name. (Inherited from PropertyConfig.)
Public property | Value | Gets the property value. (Inherited from IntegerPropertyConfig.)
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | SetDefaultValue | Sets the current value to the default value. (Inherited from IntegerPropertyConfig.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Assimp.Configs Namespace


IFCCylindricalTessellationConfig Constructor

Constructs a new IFCCylindricalTessellationConfig.

Namespace: Assimp.Configs
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public IFCCylindricalTessellationConfig(
    int tessellation
)

Parameters

tessellation
Type: SystemInt32
Tessellation of cylindrical shapes (e.g. the number of segments used to approximate a circle). Needs to be in the range of [3, 180].
See Also

Reference

IFCCylindricalTessellationConfig Class
Assimp.Configs Namespace


IFCCylindricalTessellationConfig Properties

The IFCCylindricalTessellationConfig type exposes the following members.

Properties
 | Name | Description
Public property | DefaultValue | Gets the default property value. (Inherited from IntegerPropertyConfig.)
 | IFCCylindricalTessellationConfigName | Gets the string name used by IFCCylindricalTessellationConfig.
Public property | Name | Gets the property name. (Inherited from PropertyConfig.)
Public property | Value | Gets the property value. (Inherited from IntegerPropertyConfig.)
Top
See Also

Reference

IFCCylindricalTessellationConfig Class
Assimp.Configs Namespace


IFCCylindricalTessellationConfig.IFCCylindricalTessellationConfigName Property

IFCCylindricalTessellationConfigIFCCylindricalTessellationConfigName Property

Gets the string name used by IFCCylindricalTessellationConfig.

Namespace: Assimp.Configs
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public static string IFCCylindricalTessellationConfigName { get; }

Property Value

Type: String
See Also

Reference

IFCCylindricalTessellationConfig Class
Assimp.Configs Namespace


IFCCylindricalTessellationConfig Methods

The IFCCylindricalTessellationConfig type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | SetDefaultValue | Sets the current value to the default value. (Inherited from IntegerPropertyConfig.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

IFCCylindricalTessellationConfig Class
Assimp.Configs Namespace


IFCSkipSpaceRepresentationsConfig Class

Specifies whether the IFC loader skips over IfcSpace elements. IfcSpace elements (and their geometric representations) are used to represent free space in a building story.
Inheritance Hierarchy
SystemObject
Assimp.ConfigsPropertyConfig
Assimp.ConfigsBooleanPropertyConfig
Assimp.ConfigsIFCSkipSpaceRepresentationsConfig

Namespace: Assimp.Configs
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public sealed class IFCSkipSpaceRepresentationsConfig : BooleanPropertyConfig

The IFCSkipSpaceRepresentationsConfig type exposes the following members.

Constructors
 | Name | Description
Public method | IFCSkipSpaceRepresentationsConfig | Constructs a new IFCSkipSpaceRepresentationsConfig.
Top
Properties
 | Name | Description
Public property | DefaultValue | Gets the default property value. (Inherited from BooleanPropertyConfig.)
 | IFCSkipSpaceRepresentationsConfigName | Gets the string name used by IFCSkipSpaceRepresentationsConfig.
Public property | Name | Gets the property name. (Inherited from PropertyConfig.)
Public property | Value | Gets the property value. (Inherited from BooleanPropertyConfig.)
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | SetDefaultValue | Sets the current value to the default value. (Inherited from BooleanPropertyConfig.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Assimp.Configs Namespace


IFCSkipSpaceRepresentationsConfig Constructor

Constructs a new IFCSkipSpaceRepresentationsConfig.

Namespace: Assimp.Configs
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public IFCSkipSpaceRepresentationsConfig(
    bool skipSpaceRepresentations
)

Parameters

skipSpaceRepresentations
Type: SystemBoolean
True if the IfcSpace elements are skipped, false if otherwise.
See Also

Reference

IFCSkipSpaceRepresentationsConfig Class
Assimp.Configs Namespace


IFCSkipSpaceRepresentationsConfig Properties

The IFCSkipSpaceRepresentationsConfig type exposes the following members.

Properties
 | Name | Description
Public property | DefaultValue | Gets the default property value. (Inherited from BooleanPropertyConfig.)
 | IFCSkipSpaceRepresentationsConfigName | Gets the string name used by IFCSkipSpaceRepresentationsConfig.
Public property | Name | Gets the property name. (Inherited from PropertyConfig.)
Public property | Value | Gets the property value. (Inherited from BooleanPropertyConfig.)
Top
See Also

Reference

IFCSkipSpaceRepresentationsConfig Class
Assimp.Configs Namespace


IFCSkipSpaceRepresentationsConfig.IFCSkipSpaceRepresentationsConfigName Property

IFCSkipSpaceRepresentationsConfigIFCSkipSpaceRepresentationsConfigName Property

Gets the string name used by IFCSkipSpaceRepresentationsConfig.

Namespace: Assimp.Configs
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public static string IFCSkipSpaceRepresentationsConfigName { get; }

Property Value

Type: String
See Also

Reference

IFCSkipSpaceRepresentationsConfig Class
Assimp.Configs Namespace


IFCSkipSpaceRepresentationsConfig Methods

The IFCSkipSpaceRepresentationsConfig type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | SetDefaultValue | Sets the current value to the default value. (Inherited from BooleanPropertyConfig.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

IFCSkipSpaceRepresentationsConfig Class
Assimp.Configs Namespace


IFCSmoothingAngleConfig Class

Specifies the tessellation conic angle for IFC smoothing curves. Accepted range of values is between [5, 120]
Inheritance Hierarchy
SystemObject
Assimp.ConfigsPropertyConfig
Assimp.ConfigsFloatPropertyConfig
Assimp.ConfigsIFCSmoothingAngleConfig

Namespace: Assimp.Configs
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public sealed class IFCSmoothingAngleConfig : FloatPropertyConfig

The IFCSmoothingAngleConfig type exposes the following members.

Constructors
 | Name | Description
Public method | IFCSmoothingAngleConfig | Constructs a new IFCSmoothingAngleConfig.
Top
Properties
 | Name | Description
Public property | DefaultValue | Gets the default property value. (Inherited from FloatPropertyConfig.)
 | IFCSmoothingAngleConfigName | Gets the string name used by IFCSmoothingAngleConfig.
Public property | Name | Gets the property name. (Inherited from PropertyConfig.)
Public property | Value | Gets the property value. (Inherited from FloatPropertyConfig.)
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | SetDefaultValue | Sets the current value to the default value. (Inherited from FloatPropertyConfig.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Assimp.Configs Namespace


IFCSmoothingAngleConfig Constructor

Constructs a new IFCSmoothingAngleConfig.

Namespace: Assimp.Configs
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public IFCSmoothingAngleConfig(
    float angle
)

Parameters

angle
Type: SystemSingle
Smoothing angle when tessellating curves. Needs to be in the range of [5, 120].
See Also

Reference

IFCSmoothingAngleConfig Class
Assimp.Configs Namespace


IFCSmoothingAngleConfig Properties

The IFCSmoothingAngleConfig type exposes the following members.

Properties
 | Name | Description
Public property | DefaultValue | Gets the default property value. (Inherited from FloatPropertyConfig.)
 | IFCSmoothingAngleConfigName | Gets the string name used by IFCSmoothingAngleConfig.
Public property | Name | Gets the property name. (Inherited from PropertyConfig.)
Public property | Value | Gets the property value. (Inherited from FloatPropertyConfig.)
Top
See Also

Reference

IFCSmoothingAngleConfig Class
Assimp.Configs Namespace


IFCSmoothingAngleConfig.IFCSmoothingAngleConfigName Property

IFCSmoothingAngleConfigIFCSmoothingAngleConfigName Property

Gets the string name used by IFCSmoothingAngleConfig.

Namespace: Assimp.Configs
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public static string IFCSmoothingAngleConfigName { get; }

Property Value

Type: String
See Also

Reference

IFCSmoothingAngleConfig Class
Assimp.Configs Namespace


IFCSmoothingAngleConfig Methods

The IFCSmoothingAngleConfig type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | SetDefaultValue | Sets the current value to the default value. (Inherited from FloatPropertyConfig.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

IFCSmoothingAngleConfig Class
Assimp.Configs Namespace


IFCUseCustomTriangulationConfig Class

Specifies whether the IFC loader will use its own, custom triangulation algorithm to triangulate wall and floor meshes. If this is set to false, walls will be either triangulated by the post process triangulation or will be passed through as huge polygons with faked holes (e.g. holes that are connected with the outer boundary using a dummy edge). It is highly recommended to leave this property set to true as the default post process has some known issues with these kind of polygons.
Inheritance Hierarchy
SystemObject
Assimp.ConfigsPropertyConfig
Assimp.ConfigsBooleanPropertyConfig
Assimp.ConfigsIFCUseCustomTriangulationConfig

Namespace: Assimp.Configs
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public sealed class IFCUseCustomTriangulationConfig : BooleanPropertyConfig

The IFCUseCustomTriangulationConfig type exposes the following members.

Constructors
 | Name | Description
Public method | IFCUseCustomTriangulationConfig | Constructs a new IFCUseCustomTriangulationConfig.
Top
Properties
 | Name | Description
Public property | DefaultValue | Gets the default property value. (Inherited from BooleanPropertyConfig.)
 | IFCUseCustomTriangulationConfigName | Gets the string name used by IFCUseCustomTriangulationConfig.
Public property | Name | Gets the property name. (Inherited from PropertyConfig.)
Public property | Value | Gets the property value. (Inherited from BooleanPropertyConfig.)
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | SetDefaultValue | Sets the current value to the default value. (Inherited from BooleanPropertyConfig.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Assimp.Configs Namespace


IFCUseCustomTriangulationConfig Constructor

Constructs a new IFCUseCustomTriangulationConfig.

Namespace: Assimp.Configs
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public IFCUseCustomTriangulationConfig(
    bool useCustomTriangulation
)

Parameters

useCustomTriangulation
Type: SystemBoolean
True if the loader should use its own triangulation routine for walls/floors, false otherwise.
See Also

Reference

IFCUseCustomTriangulationConfig Class
Assimp.Configs Namespace


IFCUseCustomTriangulationConfig Properties

The IFCUseCustomTriangulationConfig type exposes the following members.

Properties
 | Name | Description
Public property | DefaultValue | Gets the default property value. (Inherited from BooleanPropertyConfig.)
 | IFCUseCustomTriangulationConfigName | Gets the string name used by IFCUseCustomTriangulationConfig.
Public property | Name | Gets the property name. (Inherited from PropertyConfig.)
Public property | Value | Gets the property value. (Inherited from BooleanPropertyConfig.)
Top
See Also

Reference

IFCUseCustomTriangulationConfig Class
Assimp.Configs Namespace


IFCUseCustomTriangulationConfig.IFCUseCustomTriangulationConfigName Property

IFCUseCustomTriangulationConfigIFCUseCustomTriangulationConfigName Property

Gets the string name used by IFCUseCustomTriangulationConfig.

Namespace: Assimp.Configs
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public static string IFCUseCustomTriangulationConfigName { get; }

Property Value

Type: String
See Also

Reference

IFCUseCustomTriangulationConfig Class
Assimp.Configs Namespace


IFCUseCustomTriangulationConfig Methods

The IFCUseCustomTriangulationConfig type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | SetDefaultValue | Sets the current value to the default value. (Inherited from BooleanPropertyConfig.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

IFCUseCustomTriangulationConfig Class
Assimp.Configs Namespace


IntegerPropertyConfig Class

Describes an integer configuration property.
Inheritance Hierarchy
SystemObject
Assimp.ConfigsPropertyConfig
Assimp.ConfigsIntegerPropertyConfig
More...

Namespace: Assimp.Configs
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public class IntegerPropertyConfig : PropertyConfig

The IntegerPropertyConfig type exposes the following members.

Constructors
 | Name | Description
Public method | IntegerPropertyConfig(String, Int32) | Constructs a new IntengerPropertyConfig.
Public method | IntegerPropertyConfig(String, Int32, Int32) | constructs a new IntegerPropertyConfig with a default value.
Top
Properties
 | Name | Description
Public property | DefaultValue | Gets the default property value.
Public property | Name | Gets the property name. (Inherited from PropertyConfig.)
Public property | Value | Gets the property value.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | OnApplyValue | Applies the property value to the given Assimp property store. (Overrides PropertyConfigOnApplyValue(IntPtr).)
Public method | SetDefaultValue | Sets the current value to the default value. (Overrides PropertyConfigSetDefaultValue.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Assimp.Configs Namespace
Inheritance Hierarchy
SystemObject
Assimp.ConfigsPropertyConfig
Assimp.ConfigsIntegerPropertyConfig
Assimp.ConfigsGlobalKeyFrameImportConfig
Assimp.ConfigsIFCCylindricalTessellationConfig
Assimp.ConfigsIRRAnimationFrameRateConfig
Assimp.ConfigsLWSAnimationEndConfig
Assimp.ConfigsLWSAnimationStartConfig
Assimp.ConfigsMaxBoneCountConfig
Assimp.ConfigsMD2KeyFrameImportConfig
Assimp.ConfigsMD3KeyFrameImportConfig
Assimp.ConfigsMDLKeyFrameImportConfig
Assimp.ConfigsMeshTriangleLimitConfig
Assimp.ConfigsMeshVertexLimitConfig
Assimp.ConfigsMultithreadingConfig
Assimp.ConfigsRemoveComponentConfig
Assimp.ConfigsSMDKeyFrameImportConfig
Assimp.ConfigsSortByPrimitiveTypeConfig
Assimp.ConfigsTangentTextureChannelIndexConfig
Assimp.ConfigsTransformUVConfig
Assimp.ConfigsUnrealKeyFrameImportConfig
Assimp.ConfigsVertexBoneWeightLimitConfig
Assimp.ConfigsVertexCacheSizeConfig


IntegerPropertyConfig Constructor

Overload List
 | Name | Description
Public method | IntegerPropertyConfig(String, Int32) | Constructs a new IntengerPropertyConfig.
Public method | IntegerPropertyConfig(String, Int32, Int32) | constructs a new IntegerPropertyConfig with a default value.
Top
See Also

Reference

IntegerPropertyConfig Class
Assimp.Configs Namespace


IntegerPropertyConfig Constructor (String, Int32)

Constructs a new IntengerPropertyConfig.

Namespace: Assimp.Configs
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public IntegerPropertyConfig(
    string name,
    int value
)

Parameters

name
Type: SystemString
Name of the property
value
Type: SystemInt32
Property value
See Also

Reference

IntegerPropertyConfig Class
IntegerPropertyConfig Overload
Assimp.Configs Namespace


IntegerPropertyConfig Constructor (String, Int32, Int32)

constructs a new IntegerPropertyConfig with a default value.

Namespace: Assimp.Configs
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public IntegerPropertyConfig(
    string name,
    int value,
    int defaultValue
)

Parameters

name
Type: SystemString
Name of the property
value
Type: SystemInt32
Property value
defaultValue
Type: SystemInt32
The default property value
See Also

Reference

IntegerPropertyConfig Class
IntegerPropertyConfig Overload
Assimp.Configs Namespace


IntegerPropertyConfig Properties

The IntegerPropertyConfig type exposes the following members.

Properties
 | Name | Description
Public property | DefaultValue | Gets the default property value.
Public property | Name | Gets the property name. (Inherited from PropertyConfig.)
Public property | Value | Gets the property value.
Top
See Also

Reference

IntegerPropertyConfig Class
Assimp.Configs Namespace


IntegerPropertyConfig.DefaultValue Property

IntegerPropertyConfigDefaultValue Property

Gets the default property value.

Namespace: Assimp.Configs
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public int DefaultValue { get; }

Property Value

Type: Int32
See Also

Reference

IntegerPropertyConfig Class
Assimp.Configs Namespace


IntegerPropertyConfig.Value Property

IntegerPropertyConfigValue Property

Gets the property value.

Namespace: Assimp.Configs
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public int Value { get; set; }

Property Value

Type: Int32
See Also

Reference

IntegerPropertyConfig Class
Assimp.Configs Namespace


IntegerPropertyConfig Methods

The IntegerPropertyConfig type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | OnApplyValue | Applies the property value to the given Assimp property store. (Overrides PropertyConfigOnApplyValue(IntPtr).)
Public method | SetDefaultValue | Sets the current value to the default value. (Overrides PropertyConfigSetDefaultValue.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

IntegerPropertyConfig Class
Assimp.Configs Namespace


IntegerPropertyConfig.OnApplyValue Method

IntegerPropertyConfigOnApplyValue Method

Applies the property value to the given Assimp property store.

Namespace: Assimp.Configs
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
protected override void OnApplyValue(
    IntPtr propStore
)

Parameters

propStore
Type: SystemIntPtr
Assimp property store
See Also

Reference

IntegerPropertyConfig Class
Assimp.Configs Namespace


IntegerPropertyConfig.SetDefaultValue Method

IntegerPropertyConfigSetDefaultValue Method

Sets the current value to the default value.

Namespace: Assimp.Configs
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public override void SetDefaultValue()
See Also

Reference

IntegerPropertyConfig Class
Assimp.Configs Namespace


IRRAnimationFrameRateConfig Class

Defines the output frame rate of the IRR loader.

IRR animations are difficult to convert for Assimp and there will always be a loss of quality. This setting defines how many keys per second are returned by the converter.

The default value is 100 frames per second.
Inheritance Hierarchy
SystemObject
Assimp.ConfigsPropertyConfig
Assimp.ConfigsIntegerPropertyConfig
Assimp.ConfigsIRRAnimationFrameRateConfig

Namespace: Assimp.Configs
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public sealed class IRRAnimationFrameRateConfig : IntegerPropertyConfig

The IRRAnimationFrameRateConfig type exposes the following members.

Constructors
 | Name | Description
Public method | IRRAnimationFrameRateConfig | Constructs a new IRRAnimationFramerateConfig.
Top
Properties
 | Name | Description
Public property | DefaultValue | Gets the default property value. (Inherited from IntegerPropertyConfig.)
 | IRRAnimationFrameRateConfigName | Gets the string name used by IRRAnimationFrameRateConfig.
Public property | Name | Gets the property name. (Inherited from PropertyConfig.)
Public property | Value | Gets the property value. (Inherited from IntegerPropertyConfig.)
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | SetDefaultValue | Sets the current value to the default value. (Inherited from IntegerPropertyConfig.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Assimp.Configs Namespace


IRRAnimationFrameRateConfig Constructor

Constructs a new IRRAnimationFramerateConfig.

Namespace: Assimp.Configs
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public IRRAnimationFrameRateConfig(
    int frameRate
)

Parameters

frameRate
Type: SystemInt32
Number of frames per second to output.
See Also

Reference

IRRAnimationFrameRateConfig Class
Assimp.Configs Namespace


IRRAnimationFrameRateConfig Properties

The IRRAnimationFrameRateConfig type exposes the following members.

Properties
 | Name | Description
Public property | DefaultValue | Gets the default property value. (Inherited from IntegerPropertyConfig.)
 | IRRAnimationFrameRateConfigName | Gets the string name used by IRRAnimationFrameRateConfig.
Public property | Name | Gets the property name. (Inherited from PropertyConfig.)
Public property | Value | Gets the property value. (Inherited from IntegerPropertyConfig.)
Top
See Also

Reference

IRRAnimationFrameRateConfig Class
Assimp.Configs Namespace


IRRAnimationFrameRateConfig.IRRAnimationFrameRateConfigName Property

IRRAnimationFrameRateConfigIRRAnimationFrameRateConfigName Property

Gets the string name used by IRRAnimationFrameRateConfig.

Namespace: Assimp.Configs
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public static string IRRAnimationFrameRateConfigName { get; }

Property Value

Type: String
See Also

Reference

IRRAnimationFrameRateConfig Class
Assimp.Configs Namespace


IRRAnimationFrameRateConfig Methods

The IRRAnimationFrameRateConfig type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | SetDefaultValue | Sets the current value to the default value. (Inherited from IntegerPropertyConfig.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

IRRAnimationFrameRateConfig Class
Assimp.Configs Namespace


KeepSceneHierarchyConfig Class

Configuration for the PreTransformVertices step to keep the scene hierarchy. Meshes are moved to worldspace, but no optimization is performed where meshes with the same materials are not joined. This option can be useful if you have a scene hierarchy that contains important additional information which you intend to parse. The default value is false.
Inheritance Hierarchy
SystemObject
Assimp.ConfigsPropertyConfig
Assimp.ConfigsBooleanPropertyConfig
Assimp.ConfigsKeepSceneHierarchyConfig

Namespace: Assimp.Configs
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public sealed class KeepSceneHierarchyConfig : BooleanPropertyConfig

The KeepSceneHierarchyConfig type exposes the following members.

Constructors
 | Name | Description
Public method | KeepSceneHierarchyConfig | Constructs a new KeepHierarchyConfig.
Top
Properties
 | Name | Description
Public property | DefaultValue | Gets the default property value. (Inherited from BooleanPropertyConfig.)
 | KeepSceneHierarchyConfigName | Gets the string name used by KeepSceneHierarchyConfig.
Public property | Name | Gets the property name. (Inherited from PropertyConfig.)
Public property | Value | Gets the property value. (Inherited from BooleanPropertyConfig.)
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | SetDefaultValue | Sets the current value to the default value. (Inherited from BooleanPropertyConfig.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Assimp.Configs Namespace


KeepSceneHierarchyConfig Constructor

Constructs a new KeepHierarchyConfig.

Namespace: Assimp.Configs
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public KeepSceneHierarchyConfig(
    bool keepHierarchy
)

Parameters

keepHierarchy
Type: SystemBoolean
True to keep the hierarchy, false otherwise.
See Also

Reference

KeepSceneHierarchyConfig Class
Assimp.Configs Namespace


KeepSceneHierarchyConfig Properties

The KeepSceneHierarchyConfig type exposes the following members.

Properties
 | Name | Description
Public property | DefaultValue | Gets the default property value. (Inherited from BooleanPropertyConfig.)
 | KeepSceneHierarchyConfigName | Gets the string name used by KeepSceneHierarchyConfig.
Public property | Name | Gets the property name. (Inherited from PropertyConfig.)
Public property | Value | Gets the property value. (Inherited from BooleanPropertyConfig.)
Top
See Also

Reference

KeepSceneHierarchyConfig Class
Assimp.Configs Namespace


KeepSceneHierarchyConfig.KeepSceneHierarchyConfigName Property

KeepSceneHierarchyConfigKeepSceneHierarchyConfigName Property

Gets the string name used by KeepSceneHierarchyConfig.

Namespace: Assimp.Configs
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public static string KeepSceneHierarchyConfigName { get; }

Property Value

Type: String
See Also

Reference

KeepSceneHierarchyConfig Class
Assimp.Configs Namespace


KeepSceneHierarchyConfig Methods

The KeepSceneHierarchyConfig type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | SetDefaultValue | Sets the current value to the default value. (Inherited from BooleanPropertyConfig.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

KeepSceneHierarchyConfig Class
Assimp.Configs Namespace


LWOImportOneLayerConfig Class

Configures the LWO loader to load just one layer from the model.

LWO files consist of layers and in some cases it could be useful to load only one of them. This property can be either a string - which specifies the name of the layer - or an integer - the index of the layer. If the property is not set then the whole LWO model is loaded. Loading fails if the requested layer is not vailable. The layer index is zero-based and the layer name may not be empty

The default value is false (all layers are loaded).
Inheritance Hierarchy
SystemObject
Assimp.ConfigsPropertyConfig
Assimp.ConfigsBooleanPropertyConfig
Assimp.ConfigsLWOImportOneLayerConfig

Namespace: Assimp.Configs
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public sealed class LWOImportOneLayerConfig : BooleanPropertyConfig

The LWOImportOneLayerConfig type exposes the following members.

Constructors
 | Name | Description
Public method | LWOImportOneLayerConfig | Constructs a new LWOImportOneLayerConfig.
Top
Properties
 | Name | Description
Public property | DefaultValue | Gets the default property value. (Inherited from BooleanPropertyConfig.)
 | LWOImportOneLayerConfigName | Gets the string name used by LWOImportOneLayerConfig.
Public property | Name | Gets the property name. (Inherited from PropertyConfig.)
Public property | Value | Gets the property value. (Inherited from BooleanPropertyConfig.)
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | SetDefaultValue | Sets the current value to the default value. (Inherited from BooleanPropertyConfig.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Assimp.Configs Namespace


LWOImportOneLayerConfig Constructor

Constructs a new LWOImportOneLayerConfig.

Namespace: Assimp.Configs
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public LWOImportOneLayerConfig(
    bool importOneLayerOnly
)

Parameters

importOneLayerOnly
Type: SystemBoolean
True if only one layer should be imported, false if all layers should be imported.
See Also

Reference

LWOImportOneLayerConfig Class
Assimp.Configs Namespace


LWOImportOneLayerConfig Properties

The LWOImportOneLayerConfig type exposes the following members.

Properties
 | Name | Description
Public property | DefaultValue | Gets the default property value. (Inherited from BooleanPropertyConfig.)
 | LWOImportOneLayerConfigName | Gets the string name used by LWOImportOneLayerConfig.
Public property | Name | Gets the property name. (Inherited from PropertyConfig.)
Public property | Value | Gets the property value. (Inherited from BooleanPropertyConfig.)
Top
See Also

Reference

LWOImportOneLayerConfig Class
Assimp.Configs Namespace


LWOImportOneLayerConfig.LWOImportOneLayerConfigName Property

LWOImportOneLayerConfigLWOImportOneLayerConfigName Property

Gets the string name used by LWOImportOneLayerConfig.

Namespace: Assimp.Configs
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public static string LWOImportOneLayerConfigName { get; }

Property Value

Type: String
See Also

Reference

LWOImportOneLayerConfig Class
Assimp.Configs Namespace


LWOImportOneLayerConfig Methods

The LWOImportOneLayerConfig type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | SetDefaultValue | Sets the current value to the default value. (Inherited from BooleanPropertyConfig.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

LWOImportOneLayerConfig Class
Assimp.Configs Namespace


LWSAnimationEndConfig Class

Defines the ending of the time range for which the LWS loader evaluates animations and computes AiNodeAnim's. The default value is the one taken from the file

Assimp provides full conversion of Lightwave's envelope system, including pre and post conditions. The loader computes linearly subsampled animation channels with the frame rate given in the LWS file. This property defines the end time.

Animation channels are only generated if a node has at least one envelope with more than one key assigned. This property is given in frames where '0' is the first. By default, if this property is not set, the importer takes the animation end from the input LWS file.

Inheritance Hierarchy
SystemObject
Assimp.ConfigsPropertyConfig
Assimp.ConfigsIntegerPropertyConfig
Assimp.ConfigsLWSAnimationEndConfig

Namespace: Assimp.Configs
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public sealed class LWSAnimationEndConfig : IntegerPropertyConfig

The LWSAnimationEndConfig type exposes the following members.

Constructors
 | Name | Description
Public method | LWSAnimationEndConfig | Constructs a new LWSAnimationEndConfig.
Top
Properties
 | Name | Description
Public property | DefaultValue | Gets the default property value. (Inherited from IntegerPropertyConfig.)
 | LWSAnimationEndConfigName | Gets the string name used by LWSAnimationEndConfig.
Public property | Name | Gets the property name. (Inherited from PropertyConfig.)
Public property | Value | Gets the property value. (Inherited from IntegerPropertyConfig.)
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | SetDefaultValue | Sets the current value to the default value. (Inherited from IntegerPropertyConfig.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Assimp.Configs Namespace


LWSAnimationEndConfig Constructor

Constructs a new LWSAnimationEndConfig.

Namespace: Assimp.Configs
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public LWSAnimationEndConfig(
    int animEnd
)

Parameters

animEnd
Type: SystemInt32
Ending of the time range
See Also

Reference

LWSAnimationEndConfig Class
Assimp.Configs Namespace


LWSAnimationEndConfig Properties

The LWSAnimationEndConfig type exposes the following members.

Properties
 | Name | Description
Public property | DefaultValue | Gets the default property value. (Inherited from IntegerPropertyConfig.)
 | LWSAnimationEndConfigName | Gets the string name used by LWSAnimationEndConfig.
Public property | Name | Gets the property name. (Inherited from PropertyConfig.)
Public property | Value | Gets the property value. (Inherited from IntegerPropertyConfig.)
Top
See Also

Reference

LWSAnimationEndConfig Class
Assimp.Configs Namespace


LWSAnimationEndConfig.LWSAnimationEndConfigName Property

LWSAnimationEndConfigLWSAnimationEndConfigName Property

Gets the string name used by LWSAnimationEndConfig.

Namespace: Assimp.Configs
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public static string LWSAnimationEndConfigName { get; }

Property Value

Type: String
See Also

Reference

LWSAnimationEndConfig Class
Assimp.Configs Namespace


LWSAnimationEndConfig Methods

The LWSAnimationEndConfig type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | SetDefaultValue | Sets the current value to the default value. (Inherited from IntegerPropertyConfig.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

LWSAnimationEndConfig Class
Assimp.Configs Namespace


LWSAnimationStartConfig Class

Defines the beginning of the time range for which the LWS loader evaluates animations and computes AiNodeAnim's. The default value is the one taken from the file.

Assimp provides full conversion of Lightwave's envelope system, including pre and post conditions. The loader computes linearly subsampled animation channels with the frame rate given in the LWS file. This property defines the start time.

Animation channels are only generated if a node has at least one envelope with more than one key assigned. This property is given in frames where '0' is the first. By default, if this property is not set, the importer takes the animation start from the input LWS file ('FirstFrame' line)

Inheritance Hierarchy
SystemObject
Assimp.ConfigsPropertyConfig
Assimp.ConfigsIntegerPropertyConfig
Assimp.ConfigsLWSAnimationStartConfig

Namespace: Assimp.Configs
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public sealed class LWSAnimationStartConfig : IntegerPropertyConfig

The LWSAnimationStartConfig type exposes the following members.

Constructors
 | Name | Description
Public method | LWSAnimationStartConfig | Constructs a new LWSAnimationStartConfig.
Top
Properties
 | Name | Description
Public property | DefaultValue | Gets the default property value. (Inherited from IntegerPropertyConfig.)
 | LWSAnimationStartConfigName | Gets the string name used by LWSAnimationStartConfig.
Public property | Name | Gets the property name. (Inherited from PropertyConfig.)
Public property | Value | Gets the property value. (Inherited from IntegerPropertyConfig.)
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | SetDefaultValue | Sets the current value to the default value. (Inherited from IntegerPropertyConfig.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Assimp.Configs Namespace


LWSAnimationStartConfig Constructor

Constructs a new LWSAnimationStartConfig.

Namespace: Assimp.Configs
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public LWSAnimationStartConfig(
    int animStart
)

Parameters

animStart
Type: SystemInt32
Beginning of the time range
See Also

Reference

LWSAnimationStartConfig Class
Assimp.Configs Namespace


LWSAnimationStartConfig Properties

The LWSAnimationStartConfig type exposes the following members.

Properties
 | Name | Description
Public property | DefaultValue | Gets the default property value. (Inherited from IntegerPropertyConfig.)
 | LWSAnimationStartConfigName | Gets the string name used by LWSAnimationStartConfig.
Public property | Name | Gets the property name. (Inherited from PropertyConfig.)
Public property | Value | Gets the property value. (Inherited from IntegerPropertyConfig.)
Top
See Also

Reference

LWSAnimationStartConfig Class
Assimp.Configs Namespace


LWSAnimationStartConfig.LWSAnimationStartConfigName Property

LWSAnimationStartConfigLWSAnimationStartConfigName Property

Gets the string name used by LWSAnimationStartConfig.

Namespace: Assimp.Configs
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public static string LWSAnimationStartConfigName { get; }

Property Value

Type: String
See Also

Reference

LWSAnimationStartConfig Class
Assimp.Configs Namespace


LWSAnimationStartConfig Methods

The LWSAnimationStartConfig type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | SetDefaultValue | Sets the current value to the default value. (Inherited from IntegerPropertyConfig.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

LWSAnimationStartConfig Class
Assimp.Configs Namespace


MaterialExcludeListConfig Class

Configuration for the the RemoveRedundantMaterials step to determine what materials to keep. If a material matches one of these names it will not be modified or removed by the post processing step. Default is an empty string.
Inheritance Hierarchy
SystemObject
Assimp.ConfigsPropertyConfig
Assimp.ConfigsStringPropertyConfig
Assimp.ConfigsMaterialExcludeListConfig

Namespace: Assimp.Configs
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public sealed class MaterialExcludeListConfig : StringPropertyConfig

The MaterialExcludeListConfig type exposes the following members.

Constructors
 | Name | Description
Public method | MaterialExcludeListConfig | Constructs a new MaterialExcludeListConfig. Material names containing whitespace must be enclosed in single quotation marks.
Top
Properties
 | Name | Description
Public property | DefaultValue | Gets the default property value. (Inherited from StringPropertyConfig.)
 | MaterialExcludeListConfigName | Gets the string name used by MaterialExcludeListConfig.
Public property | Name | Gets the property name. (Inherited from PropertyConfig.)
Public property | Value | Gets the property value. (Inherited from StringPropertyConfig.)
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | SetDefaultValue | Sets the current value to the default value. (Inherited from StringPropertyConfig.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Assimp.Configs Namespace


MaterialExcludeListConfig Constructor

Constructs a new MaterialExcludeListConfig. Material names containing whitespace must be enclosed in single quotation marks.

Namespace: Assimp.Configs
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public MaterialExcludeListConfig(
    string[] materialNames
)

Parameters

materialNames
Type: SystemString
List of material names that will not be modified or replaced by the remove redundant materials post process step.
See Also

Reference

MaterialExcludeListConfig Class
Assimp.Configs Namespace


MaterialExcludeListConfig Properties

The MaterialExcludeListConfig type exposes the following members.

Properties
 | Name | Description
Public property | DefaultValue | Gets the default property value. (Inherited from StringPropertyConfig.)
 | MaterialExcludeListConfigName | Gets the string name used by MaterialExcludeListConfig.
Public property | Name | Gets the property name. (Inherited from PropertyConfig.)
Public property | Value | Gets the property value. (Inherited from StringPropertyConfig.)
Top
See Also

Reference

MaterialExcludeListConfig Class
Assimp.Configs Namespace


MaterialExcludeListConfig.MaterialExcludeListConfigName Property

MaterialExcludeListConfigMaterialExcludeListConfigName Property

Gets the string name used by MaterialExcludeListConfig.

Namespace: Assimp.Configs
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public static string MaterialExcludeListConfigName { get; }

Property Value

Type: String
See Also

Reference

MaterialExcludeListConfig Class
Assimp.Configs Namespace


MaterialExcludeListConfig Methods

The MaterialExcludeListConfig type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | SetDefaultValue | Sets the current value to the default value. (Inherited from StringPropertyConfig.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

MaterialExcludeListConfig Class
Assimp.Configs Namespace


MatrixPropertyConfig Class

Describes a Matrix4x4 configuration property.
Inheritance Hierarchy
SystemObject
Assimp.ConfigsPropertyConfig
Assimp.ConfigsMatrixPropertyConfig
Assimp.ConfigsRootTransformationConfig

Namespace: Assimp.Configs
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public class MatrixPropertyConfig : PropertyConfig

The MatrixPropertyConfig type exposes the following members.

Constructors
 | Name | Description
Public method | MatrixPropertyConfig(String, Matrix4x4) | Constructs a new MatrixPropertyConfig.
Public method | MatrixPropertyConfig(String, Matrix4x4, Matrix4x4) | Constructs a new MatrixPropertyConfig.
Top
Properties
 | Name | Description
Public property | DefaultValue | Gets the default property value.
Public property | Name | Gets the property name. (Inherited from PropertyConfig.)
Public property | Value | Gets the property value.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | OnApplyValue | Applies the property value to the given Assimp property store. (Overrides PropertyConfigOnApplyValue(IntPtr).)
Public method | SetDefaultValue | Sets the current value to the default value. (Overrides PropertyConfigSetDefaultValue.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Assimp.Configs Namespace


MatrixPropertyConfig Constructor

Overload List
 | Name | Description
Public method | MatrixPropertyConfig(String, Matrix4x4) | Constructs a new MatrixPropertyConfig.
Public method | MatrixPropertyConfig(String, Matrix4x4, Matrix4x4) | Constructs a new MatrixPropertyConfig.
Top
See Also

Reference

MatrixPropertyConfig Class
Assimp.Configs Namespace


MatrixPropertyConfig Constructor (String, Matrix4x4)

Constructs a new MatrixPropertyConfig.

Namespace: Assimp.Configs
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public MatrixPropertyConfig(
    string name,
    Matrix4x4 value
)

Parameters

name
Type: SystemString
Name of the property
value
Type: AssimpMatrix4x4
Property value
See Also

Reference

MatrixPropertyConfig Class
MatrixPropertyConfig Overload
Assimp.Configs Namespace


MatrixPropertyConfig Constructor (String, Matrix4x4, Matrix4x4)

Constructs a new MatrixPropertyConfig.

Namespace: Assimp.Configs
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public MatrixPropertyConfig(
    string name,
    Matrix4x4 value,
    Matrix4x4 defaultValue
)

Parameters

name
Type: SystemString
Name of the property
value
Type: AssimpMatrix4x4
Property value
defaultValue
Type: AssimpMatrix4x4
The default property value
See Also

Reference

MatrixPropertyConfig Class
MatrixPropertyConfig Overload
Assimp.Configs Namespace


MatrixPropertyConfig Properties

The MatrixPropertyConfig type exposes the following members.

Properties
 | Name | Description
Public property | DefaultValue | Gets the default property value.
Public property | Name | Gets the property name. (Inherited from PropertyConfig.)
Public property | Value | Gets the property value.
Top
See Also

Reference

MatrixPropertyConfig Class
Assimp.Configs Namespace


MatrixPropertyConfig.DefaultValue Property

MatrixPropertyConfigDefaultValue Property

Gets the default property value.

Namespace: Assimp.Configs
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public Matrix4x4 DefaultValue { get; }

Property Value

Type: Matrix4x4
See Also

Reference

MatrixPropertyConfig Class
Assimp.Configs Namespace


MatrixPropertyConfig.Value Property

MatrixPropertyConfigValue Property

Gets the property value.

Namespace: Assimp.Configs
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public Matrix4x4 Value { get; set; }

Property Value

Type: Matrix4x4
See Also

Reference

MatrixPropertyConfig Class
Assimp.Configs Namespace


MatrixPropertyConfig Methods

The MatrixPropertyConfig type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | OnApplyValue | Applies the property value to the given Assimp property store. (Overrides PropertyConfigOnApplyValue(IntPtr).)
Public method | SetDefaultValue | Sets the current value to the default value. (Overrides PropertyConfigSetDefaultValue.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

MatrixPropertyConfig Class
Assimp.Configs Namespace


MatrixPropertyConfig.OnApplyValue Method

MatrixPropertyConfigOnApplyValue Method

Applies the property value to the given Assimp property store.

Namespace: Assimp.Configs
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
protected override void OnApplyValue(
    IntPtr propStore
)

Parameters

propStore
Type: SystemIntPtr
Assimp property store
See Also

Reference

MatrixPropertyConfig Class
Assimp.Configs Namespace


MatrixPropertyConfig.SetDefaultValue Method

MatrixPropertyConfigSetDefaultValue Method

Sets the current value to the default value.

Namespace: Assimp.Configs
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public override void SetDefaultValue()
See Also

Reference

MatrixPropertyConfig Class
Assimp.Configs Namespace


MaxBoneCountConfig Class

Configures the maximum bone count per mesh for the SplitByBoneCount step. Meshes are split until the maximum number of bones is reached.
Inheritance Hierarchy
SystemObject
Assimp.ConfigsPropertyConfig
Assimp.ConfigsIntegerPropertyConfig
Assimp.ConfigsMaxBoneCountConfig

Namespace: Assimp.Configs
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public sealed class MaxBoneCountConfig : IntegerPropertyConfig

The MaxBoneCountConfig type exposes the following members.

Constructors
 | Name | Description
Public method | MaxBoneCountConfig | Constructs a new MaxBoneCountConfig.
Top
Properties
 | Name | Description
Public property | DefaultValue | Gets the default property value. (Inherited from IntegerPropertyConfig.)
 | MaxBoneCountConfigName | Gets the string name used by MaxBoneCountConfig.
Public property | Name | Gets the property name. (Inherited from PropertyConfig.)
Public property | Value | Gets the property value. (Inherited from IntegerPropertyConfig.)
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | SetDefaultValue | Sets the current value to the default value. (Inherited from IntegerPropertyConfig.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Assimp.Configs Namespace


MaxBoneCountConfig Constructor

Constructs a new MaxBoneCountConfig.

Namespace: Assimp.Configs
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public MaxBoneCountConfig(
    int maxBones
)

Parameters

maxBones
Type: SystemInt32
The maximum bone count.
See Also

Reference

MaxBoneCountConfig Class
Assimp.Configs Namespace


MaxBoneCountConfig Properties

The MaxBoneCountConfig type exposes the following members.

Properties
 | Name | Description
Public property | DefaultValue | Gets the default property value. (Inherited from IntegerPropertyConfig.)
 | MaxBoneCountConfigName | Gets the string name used by MaxBoneCountConfig.
Public property | Name | Gets the property name. (Inherited from PropertyConfig.)
Public property | Value | Gets the property value. (Inherited from IntegerPropertyConfig.)
Top
See Also

Reference

MaxBoneCountConfig Class
Assimp.Configs Namespace


MaxBoneCountConfig.MaxBoneCountConfigName Property

MaxBoneCountConfigMaxBoneCountConfigName Property

Gets the string name used by MaxBoneCountConfig.

Namespace: Assimp.Configs
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public static string MaxBoneCountConfigName { get; }

Property Value

Type: String
See Also

Reference

MaxBoneCountConfig Class
Assimp.Configs Namespace


MaxBoneCountConfig Methods

The MaxBoneCountConfig type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | SetDefaultValue | Sets the current value to the default value. (Inherited from IntegerPropertyConfig.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

MaxBoneCountConfig Class
Assimp.Configs Namespace


MD2KeyFrameImportConfig Class

Sets the vertex animation keyframe to be imported. Assimp does not support vertex keyframes (only bone animation is supported). the library reads only one keyframe with vertex animations. By default this is the first frame. This config sets the global override for the MD2 format.
Inheritance Hierarchy
SystemObject
Assimp.ConfigsPropertyConfig
Assimp.ConfigsIntegerPropertyConfig
Assimp.ConfigsMD2KeyFrameImportConfig

Namespace: Assimp.Configs
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public sealed class MD2KeyFrameImportConfig : IntegerPropertyConfig

The MD2KeyFrameImportConfig type exposes the following members.

Constructors
 | Name | Description
Public method | MD2KeyFrameImportConfig | Constructs a new MD2KeyFrameImportConfig.
Top
Properties
 | Name | Description
Public property | DefaultValue | Gets the default property value. (Inherited from IntegerPropertyConfig.)
 | MD2KeyFrameImportConfigName | Gets the string name used by MD2KeyFrameImportConfig.
Public property | Name | Gets the property name. (Inherited from PropertyConfig.)
Public property | Value | Gets the property value. (Inherited from IntegerPropertyConfig.)
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | SetDefaultValue | Sets the current value to the default value. (Inherited from IntegerPropertyConfig.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Assimp.Configs Namespace


MD2KeyFrameImportConfig Constructor

Constructs a new MD2KeyFrameImportConfig.

Namespace: Assimp.Configs
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public MD2KeyFrameImportConfig(
    int keyFrame
)

Parameters

keyFrame
Type: SystemInt32
Keyframe index
See Also

Reference

MD2KeyFrameImportConfig Class
Assimp.Configs Namespace


MD2KeyFrameImportConfig Properties

The MD2KeyFrameImportConfig type exposes the following members.

Properties
 | Name | Description
Public property | DefaultValue | Gets the default property value. (Inherited from IntegerPropertyConfig.)
 | MD2KeyFrameImportConfigName | Gets the string name used by MD2KeyFrameImportConfig.
Public property | Name | Gets the property name. (Inherited from PropertyConfig.)
Public property | Value | Gets the property value. (Inherited from IntegerPropertyConfig.)
Top
See Also

Reference

MD2KeyFrameImportConfig Class
Assimp.Configs Namespace


MD2KeyFrameImportConfig.MD2KeyFrameImportConfigName Property

MD2KeyFrameImportConfigMD2KeyFrameImportConfigName Property

Gets the string name used by MD2KeyFrameImportConfig.

Namespace: Assimp.Configs
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public static string MD2KeyFrameImportConfigName { get; }

Property Value

Type: String
See Also

Reference

MD2KeyFrameImportConfig Class
Assimp.Configs Namespace


MD2KeyFrameImportConfig Methods

The MD2KeyFrameImportConfig type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | SetDefaultValue | Sets the current value to the default value. (Inherited from IntegerPropertyConfig.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

MD2KeyFrameImportConfig Class
Assimp.Configs Namespace


MD3HandleMultiPartConfig Class

Configures the M3D loader to detect and process multi-part Quake player models. These models usually consit of three files, lower.md3, upper.md3 and head.md3. If this propery is set to true, Assimp will try to load and combine all three files if one of them is loaded. The default value is true.
Inheritance Hierarchy
SystemObject
Assimp.ConfigsPropertyConfig
Assimp.ConfigsBooleanPropertyConfig
Assimp.ConfigsMD3HandleMultiPartConfig

Namespace: Assimp.Configs
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public sealed class MD3HandleMultiPartConfig : BooleanPropertyConfig

The MD3HandleMultiPartConfig type exposes the following members.

Constructors
 | Name | Description
Public method | MD3HandleMultiPartConfig | Constructs a new MD3HandleMultiPartConfig.
Top
Properties
 | Name | Description
Public property | DefaultValue | Gets the default property value. (Inherited from BooleanPropertyConfig.)
 | MD3HandleMultiPartConfigName | Gets the string name used by MD3HandleMultiPartConfig.
Public property | Name | Gets the property name. (Inherited from PropertyConfig.)
Public property | Value | Gets the property value. (Inherited from BooleanPropertyConfig.)
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | SetDefaultValue | Sets the current value to the default value. (Inherited from BooleanPropertyConfig.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Assimp.Configs Namespace


MD3HandleMultiPartConfig Constructor

Constructs a new MD3HandleMultiPartConfig.

Namespace: Assimp.Configs
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public MD3HandleMultiPartConfig(
    bool handleMultiParts
)

Parameters

handleMultiParts
Type: SystemBoolean
True if the split files should be loaded and combined, false otherwise.
See Also

Reference

MD3HandleMultiPartConfig Class
Assimp.Configs Namespace


MD3HandleMultiPartConfig Properties

The MD3HandleMultiPartConfig type exposes the following members.

Properties
 | Name | Description
Public property | DefaultValue | Gets the default property value. (Inherited from BooleanPropertyConfig.)
 | MD3HandleMultiPartConfigName | Gets the string name used by MD3HandleMultiPartConfig.
Public property | Name | Gets the property name. (Inherited from PropertyConfig.)
Public property | Value | Gets the property value. (Inherited from BooleanPropertyConfig.)
Top
See Also

Reference

MD3HandleMultiPartConfig Class
Assimp.Configs Namespace


MD3HandleMultiPartConfig.MD3HandleMultiPartConfigName Property

MD3HandleMultiPartConfigMD3HandleMultiPartConfigName Property

Gets the string name used by MD3HandleMultiPartConfig.

Namespace: Assimp.Configs
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public static string MD3HandleMultiPartConfigName { get; }

Property Value

Type: String
See Also

Reference

MD3HandleMultiPartConfig Class
Assimp.Configs Namespace


MD3HandleMultiPartConfig Methods

The MD3HandleMultiPartConfig type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | SetDefaultValue | Sets the current value to the default value. (Inherited from BooleanPropertyConfig.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

MD3HandleMultiPartConfig Class
Assimp.Configs Namespace


MD3KeyFrameImportConfig Class

Sets the vertex animation keyframe to be imported. Assimp does not support vertex keyframes (only bone animation is supported). the library reads only one keyframe with vertex animations. By default this is the first frame. This config sets the global override for the MD3 format.
Inheritance Hierarchy
SystemObject
Assimp.ConfigsPropertyConfig
Assimp.ConfigsIntegerPropertyConfig
Assimp.ConfigsMD3KeyFrameImportConfig

Namespace: Assimp.Configs
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public sealed class MD3KeyFrameImportConfig : IntegerPropertyConfig

The MD3KeyFrameImportConfig type exposes the following members.

Constructors
 | Name | Description
Public method | MD3KeyFrameImportConfig | Constructs a new MD3KeyFrameImportConfig.
Top
Properties
 | Name | Description
Public property | DefaultValue | Gets the default property value. (Inherited from IntegerPropertyConfig.)
 | MD3KeyFrameImportConfigName | Gets the string name used by MD3KeyFrameImportConfig.
Public property | Name | Gets the property name. (Inherited from PropertyConfig.)
Public property | Value | Gets the property value. (Inherited from IntegerPropertyConfig.)
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | SetDefaultValue | Sets the current value to the default value. (Inherited from IntegerPropertyConfig.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Assimp.Configs Namespace


MD3KeyFrameImportConfig Constructor

Constructs a new MD3KeyFrameImportConfig.

Namespace: Assimp.Configs
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public MD3KeyFrameImportConfig(
    int keyFrame
)

Parameters

keyFrame
Type: SystemInt32
Keyframe index
See Also

Reference

MD3KeyFrameImportConfig Class
Assimp.Configs Namespace


MD3KeyFrameImportConfig Properties

The MD3KeyFrameImportConfig type exposes the following members.

Properties
 | Name | Description
Public property | DefaultValue | Gets the default property value. (Inherited from IntegerPropertyConfig.)
 | MD3KeyFrameImportConfigName | Gets the string name used by MD3KeyFrameImportConfig.
Public property | Name | Gets the property name. (Inherited from PropertyConfig.)
Public property | Value | Gets the property value. (Inherited from IntegerPropertyConfig.)
Top
See Also

Reference

MD3KeyFrameImportConfig Class
Assimp.Configs Namespace


MD3KeyFrameImportConfig.MD3KeyFrameImportConfigName Property

MD3KeyFrameImportConfigMD3KeyFrameImportConfigName Property

Gets the string name used by MD3KeyFrameImportConfig.

Namespace: Assimp.Configs
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public static string MD3KeyFrameImportConfigName { get; }

Property Value

Type: String
See Also

Reference

MD3KeyFrameImportConfig Class
Assimp.Configs Namespace


MD3KeyFrameImportConfig Methods

The MD3KeyFrameImportConfig type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | SetDefaultValue | Sets the current value to the default value. (Inherited from IntegerPropertyConfig.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

MD3KeyFrameImportConfig Class
Assimp.Configs Namespace


MD3ShaderSourceConfig Class

Specifies the Quake 3 shader file to be used for a particular MD3 file. This can be a full path or relative to where all MD3 shaders reside. the default string value is an empty string.
Inheritance Hierarchy
SystemObject
Assimp.ConfigsPropertyConfig
Assimp.ConfigsStringPropertyConfig
Assimp.ConfigsMD3ShaderSourceConfig

Namespace: Assimp.Configs
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public sealed class MD3ShaderSourceConfig : StringPropertyConfig

The MD3ShaderSourceConfig type exposes the following members.

Constructors
 | Name | Description
Public method | MD3ShaderSourceConfig | Constructs a new MD3ShaderSourceConfig.
Top
Properties
 | Name | Description
Public property | DefaultValue | Gets the default property value. (Inherited from StringPropertyConfig.)
 | MD3ShaderSourceConfigName | Gets the string name used by MD3ShaderSourceConfig.
Public property | Name | Gets the property name. (Inherited from PropertyConfig.)
Public property | Value | Gets the property value. (Inherited from StringPropertyConfig.)
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | SetDefaultValue | Sets the current value to the default value. (Inherited from StringPropertyConfig.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Assimp.Configs Namespace


MD3ShaderSourceConfig Constructor

Constructs a new MD3ShaderSourceConfig.

Namespace: Assimp.Configs
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public MD3ShaderSourceConfig(
    string shaderFile
)

Parameters

shaderFile
Type: SystemString
The shader file.
See Also

Reference

MD3ShaderSourceConfig Class
Assimp.Configs Namespace


MD3ShaderSourceConfig Properties

The MD3ShaderSourceConfig type exposes the following members.

Properties
 | Name | Description
Public property | DefaultValue | Gets the default property value. (Inherited from StringPropertyConfig.)
 | MD3ShaderSourceConfigName | Gets the string name used by MD3ShaderSourceConfig.
Public property | Name | Gets the property name. (Inherited from PropertyConfig.)
Public property | Value | Gets the property value. (Inherited from StringPropertyConfig.)
Top
See Also

Reference

MD3ShaderSourceConfig Class
Assimp.Configs Namespace


MD3ShaderSourceConfig.MD3ShaderSourceConfigName Property

MD3ShaderSourceConfigMD3ShaderSourceConfigName Property

Gets the string name used by MD3ShaderSourceConfig.

Namespace: Assimp.Configs
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public static string MD3ShaderSourceConfigName { get; }

Property Value

Type: String
See Also

Reference

MD3ShaderSourceConfig Class
Assimp.Configs Namespace


MD3ShaderSourceConfig Methods

The MD3ShaderSourceConfig type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | SetDefaultValue | Sets the current value to the default value. (Inherited from StringPropertyConfig.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

MD3ShaderSourceConfig Class
Assimp.Configs Namespace


MD3SkinNameConfig Class

Tells the MD3 loader which skin files to load. When loading MD3 files, Assimp checks whether a file named "md3_file_name"_"skin_name".skin exists. These files are used by Quake III to be able to assign different skins (e.g. red and blue team) to models. 'default', 'red', 'blue' are typical skin names. The default string value is "default".
Inheritance Hierarchy
SystemObject
Assimp.ConfigsPropertyConfig
Assimp.ConfigsStringPropertyConfig
Assimp.ConfigsMD3SkinNameConfig

Namespace: Assimp.Configs
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public sealed class MD3SkinNameConfig : StringPropertyConfig

The MD3SkinNameConfig type exposes the following members.

Constructors
 | Name | Description
Public method | MD3SkinNameConfig | Constructs a new MD3SkinNameConfig.
Top
Properties
 | Name | Description
Public property | DefaultValue | Gets the default property value. (Inherited from StringPropertyConfig.)
 | MD3SkinNameConfigName | Gets the string name used by MD3SkinNameConfig.
Public property | Name | Gets the property name. (Inherited from PropertyConfig.)
Public property | Value | Gets the property value. (Inherited from StringPropertyConfig.)
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | SetDefaultValue | Sets the current value to the default value. (Inherited from StringPropertyConfig.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Assimp.Configs Namespace


MD3SkinNameConfig Constructor

Constructs a new MD3SkinNameConfig.

Namespace: Assimp.Configs
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public MD3SkinNameConfig(
    string skinName
)

Parameters

skinName
Type: SystemString
The skin name.
See Also

Reference

MD3SkinNameConfig Class
Assimp.Configs Namespace


MD3SkinNameConfig Properties

The MD3SkinNameConfig type exposes the following members.

Properties
 | Name | Description
Public property | DefaultValue | Gets the default property value. (Inherited from StringPropertyConfig.)
 | MD3SkinNameConfigName | Gets the string name used by MD3SkinNameConfig.
Public property | Name | Gets the property name. (Inherited from PropertyConfig.)
Public property | Value | Gets the property value. (Inherited from StringPropertyConfig.)
Top
See Also

Reference

MD3SkinNameConfig Class
Assimp.Configs Namespace


MD3SkinNameConfig.MD3SkinNameConfigName Property

MD3SkinNameConfigMD3SkinNameConfigName Property

Gets the string name used by MD3SkinNameConfig.

Namespace: Assimp.Configs
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public static string MD3SkinNameConfigName { get; }

Property Value

Type: String
See Also

Reference

MD3SkinNameConfig Class
Assimp.Configs Namespace


MD3SkinNameConfig Methods

The MD3SkinNameConfig type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | SetDefaultValue | Sets the current value to the default value. (Inherited from StringPropertyConfig.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

MD3SkinNameConfig Class
Assimp.Configs Namespace


MD5NoAnimationAutoLoadConfig Class

Configures the MD5 loader to not load the MD5ANIM file for a MD5MESH file automatically. The default value is false.

The default strategy is to look for a file with the same name but with the MD5ANIm extension in the same directory. If it is found it is loaded and combined with the MD5MESH file. This configuration option can be used to disable this behavior.

Inheritance Hierarchy
SystemObject
Assimp.ConfigsPropertyConfig
Assimp.ConfigsBooleanPropertyConfig
Assimp.ConfigsMD5NoAnimationAutoLoadConfig

Namespace: Assimp.Configs
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public sealed class MD5NoAnimationAutoLoadConfig : BooleanPropertyConfig

The MD5NoAnimationAutoLoadConfig type exposes the following members.

Constructors
 | Name | Description
Public method | MD5NoAnimationAutoLoadConfig | Constructs a new MD5NoAnimationAutoLoadConfig.
Top
Properties
 | Name | Description
Public property | DefaultValue | Gets the default property value. (Inherited from BooleanPropertyConfig.)
 | MD5NoAnimationAutoLoadConfigName | Gets the string name used by MD5NoAnimationAutoLoadConfig.
Public property | Name | Gets the property name. (Inherited from PropertyConfig.)
Public property | Value | Gets the property value. (Inherited from BooleanPropertyConfig.)
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | SetDefaultValue | Sets the current value to the default value. (Inherited from BooleanPropertyConfig.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Assimp.Configs Namespace


MD5NoAnimationAutoLoadConfig Constructor

Constructs a new MD5NoAnimationAutoLoadConfig.

Namespace: Assimp.Configs
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public MD5NoAnimationAutoLoadConfig(
    bool noAutoLoadAnim
)

Parameters

noAutoLoadAnim
Type: SystemBoolean
True if animations should not be automatically loaded, false if they should be.
See Also

Reference

MD5NoAnimationAutoLoadConfig Class
Assimp.Configs Namespace


MD5NoAnimationAutoLoadConfig Properties

The MD5NoAnimationAutoLoadConfig type exposes the following members.

Properties
 | Name | Description
Public property | DefaultValue | Gets the default property value. (Inherited from BooleanPropertyConfig.)
 | MD5NoAnimationAutoLoadConfigName | Gets the string name used by MD5NoAnimationAutoLoadConfig.
Public property | Name | Gets the property name. (Inherited from PropertyConfig.)
Public property | Value | Gets the property value. (Inherited from BooleanPropertyConfig.)
Top
See Also

Reference

MD5NoAnimationAutoLoadConfig Class
Assimp.Configs Namespace


MD5NoAnimationAutoLoadConfig.MD5NoAnimationAutoLoadConfigName Property

MD5NoAnimationAutoLoadConfigMD5NoAnimationAutoLoadConfigName Property

Gets the string name used by MD5NoAnimationAutoLoadConfig.

Namespace: Assimp.Configs
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public static string MD5NoAnimationAutoLoadConfigName { get; }

Property Value

Type: String
See Also

Reference

MD5NoAnimationAutoLoadConfig Class
Assimp.Configs Namespace


MD5NoAnimationAutoLoadConfig Methods

The MD5NoAnimationAutoLoadConfig type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | SetDefaultValue | Sets the current value to the default value. (Inherited from BooleanPropertyConfig.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

MD5NoAnimationAutoLoadConfig Class
Assimp.Configs Namespace


MDLColorMapConfig Class

Configuration to set the colormap (palette) to be used to decode embedded textures in MDL (Quake or 3DG5) files. This must be a valid path to a file. The file is 768 (256 * 3) bytes alrge and contains RGB triplets for each of the 256 palette entries. If the file is not found, a default palette (from Quake 1) is used. The default value is "colormap.lmp".
Inheritance Hierarchy
SystemObject
Assimp.ConfigsPropertyConfig
Assimp.ConfigsStringPropertyConfig
Assimp.ConfigsMDLColorMapConfig

Namespace: Assimp.Configs
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public sealed class MDLColorMapConfig : StringPropertyConfig

The MDLColorMapConfig type exposes the following members.

Constructors
 | Name | Description
Public method | MDLColorMapConfig | Constructs a new MDLColorMapConfig.
Top
Properties
 | Name | Description
Public property | DefaultValue | Gets the default property value. (Inherited from StringPropertyConfig.)
 | MDLColorMapConfigName | Gets the string name used by MDLColorMapConfig.
Public property | Name | Gets the property name. (Inherited from PropertyConfig.)
Public property | Value | Gets the property value. (Inherited from StringPropertyConfig.)
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | SetDefaultValue | Sets the current value to the default value. (Inherited from StringPropertyConfig.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Assimp.Configs Namespace


MDLColorMapConfig Constructor

Constructs a new MDLColorMapConfig.

Namespace: Assimp.Configs
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public MDLColorMapConfig(
    string fileName
)

Parameters

fileName
Type: SystemString
Colormap filename
See Also

Reference

MDLColorMapConfig Class
Assimp.Configs Namespace


MDLColorMapConfig Properties

The MDLColorMapConfig type exposes the following members.

Properties
 | Name | Description
Public property | DefaultValue | Gets the default property value. (Inherited from StringPropertyConfig.)
 | MDLColorMapConfigName | Gets the string name used by MDLColorMapConfig.
Public property | Name | Gets the property name. (Inherited from PropertyConfig.)
Public property | Value | Gets the property value. (Inherited from StringPropertyConfig.)
Top
See Also

Reference

MDLColorMapConfig Class
Assimp.Configs Namespace


MDLColorMapConfig.MDLColorMapConfigName Property

MDLColorMapConfigMDLColorMapConfigName Property

Gets the string name used by MDLColorMapConfig.

Namespace: Assimp.Configs
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public static string MDLColorMapConfigName { get; }

Property Value

Type: String
See Also

Reference

MDLColorMapConfig Class
Assimp.Configs Namespace


MDLColorMapConfig Methods

The MDLColorMapConfig type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | SetDefaultValue | Sets the current value to the default value. (Inherited from StringPropertyConfig.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

MDLColorMapConfig Class
Assimp.Configs Namespace


MDLKeyFrameImportConfig Class

Sets the vertex animation keyframe to be imported. Assimp does not support vertex keyframes (only bone animation is supported). the library reads only one keyframe with vertex animations. By default this is the first frame. This config sets the global override for the MDL format.
Inheritance Hierarchy
SystemObject
Assimp.ConfigsPropertyConfig
Assimp.ConfigsIntegerPropertyConfig
Assimp.ConfigsMDLKeyFrameImportConfig

Namespace: Assimp.Configs
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public sealed class MDLKeyFrameImportConfig : IntegerPropertyConfig

The MDLKeyFrameImportConfig type exposes the following members.

Constructors
 | Name | Description
Public method | MDLKeyFrameImportConfig | Constructs a new MDLKeyFrameImportConfig.
Top
Properties
 | Name | Description
Public property | DefaultValue | Gets the default property value. (Inherited from IntegerPropertyConfig.)
 | MDLKeyFrameImportConfigName | Gets the string name used by MDLKeyFrameImportConfig.
Public property | Name | Gets the property name. (Inherited from PropertyConfig.)
Public property | Value | Gets the property value. (Inherited from IntegerPropertyConfig.)
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | SetDefaultValue | Sets the current value to the default value. (Inherited from IntegerPropertyConfig.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Assimp.Configs Namespace


MDLKeyFrameImportConfig Constructor

Constructs a new MDLKeyFrameImportConfig.

Namespace: Assimp.Configs
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public MDLKeyFrameImportConfig(
    int keyFrame
)

Parameters

keyFrame
Type: SystemInt32
Keyframe index
See Also

Reference

MDLKeyFrameImportConfig Class
Assimp.Configs Namespace


MDLKeyFrameImportConfig Properties

The MDLKeyFrameImportConfig type exposes the following members.

Properties
 | Name | Description
Public property | DefaultValue | Gets the default property value. (Inherited from IntegerPropertyConfig.)
 | MDLKeyFrameImportConfigName | Gets the string name used by MDLKeyFrameImportConfig.
Public property | Name | Gets the property name. (Inherited from PropertyConfig.)
Public property | Value | Gets the property value. (Inherited from IntegerPropertyConfig.)
Top
See Also

Reference

MDLKeyFrameImportConfig Class
Assimp.Configs Namespace


MDLKeyFrameImportConfig.MDLKeyFrameImportConfigName Property

MDLKeyFrameImportConfigMDLKeyFrameImportConfigName Property

Gets the string name used by MDLKeyFrameImportConfig.

Namespace: Assimp.Configs
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public static string MDLKeyFrameImportConfigName { get; }

Property Value

Type: String
See Also

Reference

MDLKeyFrameImportConfig Class
Assimp.Configs Namespace


MDLKeyFrameImportConfig Methods

The MDLKeyFrameImportConfig type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | SetDefaultValue | Sets the current value to the default value. (Inherited from IntegerPropertyConfig.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

MDLKeyFrameImportConfig Class
Assimp.Configs Namespace


MeasureTimeConfig Class

Configuration to enable time measurements. If enabled, each part of the loading process is timed and logged. Default value is false.
Inheritance Hierarchy
SystemObject
Assimp.ConfigsPropertyConfig
Assimp.ConfigsBooleanPropertyConfig
Assimp.ConfigsMeasureTimeConfig

Namespace: Assimp.Configs
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public sealed class MeasureTimeConfig : BooleanPropertyConfig

The MeasureTimeConfig type exposes the following members.

Constructors
 | Name | Description
Public method | MeasureTimeConfig | Constructs a new MeasureTimeConfig.
Top
Properties
 | Name | Description
Public property | DefaultValue | Gets the default property value. (Inherited from BooleanPropertyConfig.)
 | MeasureTimeConfigName | Gets the string name used by MeasureTimeConfig.
Public property | Name | Gets the property name. (Inherited from PropertyConfig.)
Public property | Value | Gets the property value. (Inherited from BooleanPropertyConfig.)
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | SetDefaultValue | Sets the current value to the default value. (Inherited from BooleanPropertyConfig.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Assimp.Configs Namespace


MeasureTimeConfig Constructor

Constructs a new MeasureTimeConfig.

Namespace: Assimp.Configs
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public MeasureTimeConfig(
    bool measureTime
)

Parameters

measureTime
Type: SystemBoolean
True if the loading process should be timed or not.
See Also

Reference

MeasureTimeConfig Class
Assimp.Configs Namespace


MeasureTimeConfig Properties

The MeasureTimeConfig type exposes the following members.

Properties
 | Name | Description
Public property | DefaultValue | Gets the default property value. (Inherited from BooleanPropertyConfig.)
 | MeasureTimeConfigName | Gets the string name used by MeasureTimeConfig.
Public property | Name | Gets the property name. (Inherited from PropertyConfig.)
Public property | Value | Gets the property value. (Inherited from BooleanPropertyConfig.)
Top
See Also

Reference

MeasureTimeConfig Class
Assimp.Configs Namespace


MeasureTimeConfig.MeasureTimeConfigName Property

MeasureTimeConfigMeasureTimeConfigName Property

Gets the string name used by MeasureTimeConfig.

Namespace: Assimp.Configs
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public static string MeasureTimeConfigName { get; }

Property Value

Type: String
See Also

Reference

MeasureTimeConfig Class
Assimp.Configs Namespace


MeasureTimeConfig Methods

The MeasureTimeConfig type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | SetDefaultValue | Sets the current value to the default value. (Inherited from BooleanPropertyConfig.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

MeasureTimeConfig Class
Assimp.Configs Namespace


MeshTriangleLimitConfig Class

Configuration for the SplitLargeMeshes step that specifies the maximum number of triangles a mesh can contain. The default value is MeshTriangleLimitConfigDefaultValue.
Inheritance Hierarchy
SystemObject
Assimp.ConfigsPropertyConfig
Assimp.ConfigsIntegerPropertyConfig
Assimp.ConfigsMeshTriangleLimitConfig

Namespace: Assimp.Configs
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public sealed class MeshTriangleLimitConfig : IntegerPropertyConfig

The MeshTriangleLimitConfig type exposes the following members.

Constructors
 | Name | Description
Public method | MeshTriangleLimitConfig | Constructs a new MeshTriangleLimitConfig.
Top
Properties
 | Name | Description
Public property | DefaultValue | Gets the default property value. (Inherited from IntegerPropertyConfig.)
 | MeshTriangleLimitConfigDefaultValue | Gets the defined default limit value, this corresponds to the AI_SLM_DEFAULT_MAX_TRIANGLES constant.
 | MeshTriangleLimitConfigName | Gets the string name used by MeshTriangleLimitConfig.
Public property | Name | Gets the property name. (Inherited from PropertyConfig.)
Public property | Value | Gets the property value. (Inherited from IntegerPropertyConfig.)
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | SetDefaultValue | Sets the current value to the default value. (Inherited from IntegerPropertyConfig.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Assimp.Configs Namespace


MeshTriangleLimitConfig Constructor

Constructs a new MeshTriangleLimitConfig.

Namespace: Assimp.Configs
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public MeshTriangleLimitConfig(
    int maxTriangleLimit
)

Parameters

maxTriangleLimit
Type: SystemInt32
Max number of triangles a mesh can contain.
See Also

Reference

MeshTriangleLimitConfig Class
Assimp.Configs Namespace


MeshTriangleLimitConfig Properties

The MeshTriangleLimitConfig type exposes the following members.

Properties
 | Name | Description
Public property | DefaultValue | Gets the default property value. (Inherited from IntegerPropertyConfig.)
 | MeshTriangleLimitConfigDefaultValue | Gets the defined default limit value, this corresponds to the AI_SLM_DEFAULT_MAX_TRIANGLES constant.
 | MeshTriangleLimitConfigName | Gets the string name used by MeshTriangleLimitConfig.
Public property | Name | Gets the property name. (Inherited from PropertyConfig.)
Public property | Value | Gets the property value. (Inherited from IntegerPropertyConfig.)
Top
See Also

Reference

MeshTriangleLimitConfig Class
Assimp.Configs Namespace


MeshTriangleLimitConfig.MeshTriangleLimitConfigDefaultValue Property

MeshTriangleLimitConfigMeshTriangleLimitConfigDefaultValue Property

Gets the defined default limit value, this corresponds to the AI_SLM_DEFAULT_MAX_TRIANGLES constant.

Namespace: Assimp.Configs
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public static int MeshTriangleLimitConfigDefaultValue { get; }

Property Value

Type: Int32
See Also

Reference

MeshTriangleLimitConfig Class
Assimp.Configs Namespace


MeshTriangleLimitConfig.MeshTriangleLimitConfigName Property

MeshTriangleLimitConfigMeshTriangleLimitConfigName Property

Gets the string name used by MeshTriangleLimitConfig.

Namespace: Assimp.Configs
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public static string MeshTriangleLimitConfigName { get; }

Property Value

Type: String
See Also

Reference

MeshTriangleLimitConfig Class
Assimp.Configs Namespace


MeshTriangleLimitConfig Methods

The MeshTriangleLimitConfig type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | SetDefaultValue | Sets the current value to the default value. (Inherited from IntegerPropertyConfig.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

MeshTriangleLimitConfig Class
Assimp.Configs Namespace


MeshVertexLimitConfig Class

Configuration for the SplitLargeMeshes step that specifies the maximum number of vertices a mesh can contain. The default value is MeshVertexLimitConfigDefaultValue.
Inheritance Hierarchy
SystemObject
Assimp.ConfigsPropertyConfig
Assimp.ConfigsIntegerPropertyConfig
Assimp.ConfigsMeshVertexLimitConfig

Namespace: Assimp.Configs
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public sealed class MeshVertexLimitConfig : IntegerPropertyConfig

The MeshVertexLimitConfig type exposes the following members.

Constructors
 | Name | Description
Public method | MeshVertexLimitConfig | Constructs a new MeshVertexLimitConfig.
Top
Properties
 | Name | Description
Public property | DefaultValue | Gets the default property value. (Inherited from IntegerPropertyConfig.)
 | MeshVertexLimitConfigDefaultValue | Gets the defined default limit value, this corresponds to the AI_SLM_DEFAULT_MAX_VERTICES constant.
 | MeshVertexLimitConfigName | Gets the string name used by MeshVertexLimitConfig.
Public property | Name | Gets the property name. (Inherited from PropertyConfig.)
Public property | Value | Gets the property value. (Inherited from IntegerPropertyConfig.)
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | SetDefaultValue | Sets the current value to the default value. (Inherited from IntegerPropertyConfig.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Assimp.Configs Namespace


MeshVertexLimitConfig Constructor

Constructs a new MeshVertexLimitConfig.

Namespace: Assimp.Configs
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public MeshVertexLimitConfig(
    int maxVertexLimit
)

Parameters

maxVertexLimit
Type: SystemInt32
Max number of vertices a mesh can contain.
See Also

Reference

MeshVertexLimitConfig Class
Assimp.Configs Namespace


MeshVertexLimitConfig Properties

The MeshVertexLimitConfig type exposes the following members.

Properties
 | Name | Description
Public property | DefaultValue | Gets the default property value. (Inherited from IntegerPropertyConfig.)
 | MeshVertexLimitConfigDefaultValue | Gets the defined default limit value, this corresponds to the AI_SLM_DEFAULT_MAX_VERTICES constant.
 | MeshVertexLimitConfigName | Gets the string name used by MeshVertexLimitConfig.
Public property | Name | Gets the property name. (Inherited from PropertyConfig.)
Public property | Value | Gets the property value. (Inherited from IntegerPropertyConfig.)
Top
See Also

Reference

MeshVertexLimitConfig Class
Assimp.Configs Namespace


MeshVertexLimitConfig.MeshVertexLimitConfigDefaultValue Property

MeshVertexLimitConfigMeshVertexLimitConfigDefaultValue Property

Gets the defined default limit value, this corresponds to the AI_SLM_DEFAULT_MAX_VERTICES constant.

Namespace: Assimp.Configs
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public static int MeshVertexLimitConfigDefaultValue { get; }

Property Value

Type: Int32
See Also

Reference

MeshVertexLimitConfig Class
Assimp.Configs Namespace


MeshVertexLimitConfig.MeshVertexLimitConfigName Property

MeshVertexLimitConfigMeshVertexLimitConfigName Property

Gets the string name used by MeshVertexLimitConfig.

Namespace: Assimp.Configs
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public static string MeshVertexLimitConfigName { get; }

Property Value

Type: String
See Also

Reference

MeshVertexLimitConfig Class
Assimp.Configs Namespace


MeshVertexLimitConfig Methods

The MeshVertexLimitConfig type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | SetDefaultValue | Sets the current value to the default value. (Inherited from IntegerPropertyConfig.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

MeshVertexLimitConfig Class
Assimp.Configs Namespace


MultithreadingConfig Class

Configuration to set Assimp's multithreading policy. Possible values are -1 to let Assimp decide, 0 to disable multithreading, or any number larger than zero to force a specific number of threads. This is only a hint and may be ignored by Assimp. Default value is -1.
Inheritance Hierarchy
SystemObject
Assimp.ConfigsPropertyConfig
Assimp.ConfigsIntegerPropertyConfig
Assimp.ConfigsMultithreadingConfig

Namespace: Assimp.Configs
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public sealed class MultithreadingConfig : IntegerPropertyConfig

The MultithreadingConfig type exposes the following members.

Constructors
 | Name | Description
Public method | MultithreadingConfig | Constructs a new MultithreadingConfig.
Top
Properties
 | Name | Description
Public property | DefaultValue | Gets the default property value. (Inherited from IntegerPropertyConfig.)
 | MultithreadingConfigName | Gets the string name used by MultithreadingConfig.
Public property | Name | Gets the property name. (Inherited from PropertyConfig.)
Public property | Value | Gets the property value. (Inherited from IntegerPropertyConfig.)
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | SetDefaultValue | Sets the current value to the default value. (Inherited from IntegerPropertyConfig.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Assimp.Configs Namespace


MultithreadingConfig Constructor

Constructs a new MultithreadingConfig.

Namespace: Assimp.Configs
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public MultithreadingConfig(
    int value
)

Parameters

value
Type: SystemInt32
A value of -1 will let Assimp decide, a value of zero to disable multithreading, and a value greater than zero to force a specific number of threads.
See Also

Reference

MultithreadingConfig Class
Assimp.Configs Namespace


MultithreadingConfig Properties

The MultithreadingConfig type exposes the following members.

Properties
 | Name | Description
Public property | DefaultValue | Gets the default property value. (Inherited from IntegerPropertyConfig.)
 | MultithreadingConfigName | Gets the string name used by MultithreadingConfig.
Public property | Name | Gets the property name. (Inherited from PropertyConfig.)
Public property | Value | Gets the property value. (Inherited from IntegerPropertyConfig.)
Top
See Also

Reference

MultithreadingConfig Class
Assimp.Configs Namespace


MultithreadingConfig.MultithreadingConfigName Property

MultithreadingConfigMultithreadingConfigName Property

Gets the string name used by MultithreadingConfig.

Namespace: Assimp.Configs
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public static string MultithreadingConfigName { get; }

Property Value

Type: String
See Also

Reference

MultithreadingConfig Class
Assimp.Configs Namespace


MultithreadingConfig Methods

The MultithreadingConfig type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | SetDefaultValue | Sets the current value to the default value. (Inherited from IntegerPropertyConfig.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

MultithreadingConfig Class
Assimp.Configs Namespace


NodeExcludeListConfig Class

Configuration for the OptimizeGraph step to preserve nodes matching a name in the given list. Nodes that match the names in the list will not be modified or removed. Identifiers containing whitespaces must be enclosed in single quotation marks. The default value is an empty string.
Inheritance Hierarchy
SystemObject
Assimp.ConfigsPropertyConfig
Assimp.ConfigsStringPropertyConfig
Assimp.ConfigsNodeExcludeListConfig

Namespace: Assimp.Configs
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public sealed class NodeExcludeListConfig : StringPropertyConfig

The NodeExcludeListConfig type exposes the following members.

Constructors
 | Name | Description
Public method | NodeExcludeListConfig | Constructs a new NodeExcludeListConfig.
Top
Properties
 | Name | Description
Public property | DefaultValue | Gets the default property value. (Inherited from StringPropertyConfig.)
Public property | Name | Gets the property name. (Inherited from PropertyConfig.)
 | NodeExcludeListConfigName | Gets the string name used by NodeExcludeListConfig.
Public property | Value | Gets the property value. (Inherited from StringPropertyConfig.)
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | SetDefaultValue | Sets the current value to the default value. (Inherited from StringPropertyConfig.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Assimp.Configs Namespace


NodeExcludeListConfig Constructor

Constructs a new NodeExcludeListConfig.

Namespace: Assimp.Configs
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public NodeExcludeListConfig(
    params string[] nodeNames
)

Parameters

nodeNames
Type: SystemString
List of node names
See Also

Reference

NodeExcludeListConfig Class
Assimp.Configs Namespace


NodeExcludeListConfig Properties

The NodeExcludeListConfig type exposes the following members.

Properties
 | Name | Description
Public property | DefaultValue | Gets the default property value. (Inherited from StringPropertyConfig.)
Public property | Name | Gets the property name. (Inherited from PropertyConfig.)
 | NodeExcludeListConfigName | Gets the string name used by NodeExcludeListConfig.
Public property | Value | Gets the property value. (Inherited from StringPropertyConfig.)
Top
See Also

Reference

NodeExcludeListConfig Class
Assimp.Configs Namespace


NodeExcludeListConfig.NodeExcludeListConfigName Property

NodeExcludeListConfigNodeExcludeListConfigName Property

Gets the string name used by NodeExcludeListConfig.

Namespace: Assimp.Configs
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public static string NodeExcludeListConfigName { get; }

Property Value

Type: String
See Also

Reference

NodeExcludeListConfig Class
Assimp.Configs Namespace


NodeExcludeListConfig Methods

The NodeExcludeListConfig type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | SetDefaultValue | Sets the current value to the default value. (Inherited from StringPropertyConfig.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

NodeExcludeListConfig Class
Assimp.Configs Namespace


NormalizeVertexComponentsConfig Class

Configuration for the PreTransformVertices step to normalize all vertex components into the -1...1 range. The default value is false.
Inheritance Hierarchy
SystemObject
Assimp.ConfigsPropertyConfig
Assimp.ConfigsBooleanPropertyConfig
Assimp.ConfigsNormalizeVertexComponentsConfig

Namespace: Assimp.Configs
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public sealed class NormalizeVertexComponentsConfig : BooleanPropertyConfig

The NormalizeVertexComponentsConfig type exposes the following members.

Constructors
 | Name | Description
Public method | NormalizeVertexComponentsConfig | Constructs a new NormalizeVertexComponentsConfig.
Top
Properties
 | Name | Description
Public property | DefaultValue | Gets the default property value. (Inherited from BooleanPropertyConfig.)
Public property | Name | Gets the property name. (Inherited from PropertyConfig.)
 | NormalizeVertexComponentsConfigName | Gets the string name used by NormalizeVertexComponentsConfig.
Public property | Value | Gets the property value. (Inherited from BooleanPropertyConfig.)
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | SetDefaultValue | Sets the current value to the default value. (Inherited from BooleanPropertyConfig.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Assimp.Configs Namespace


NormalizeVertexComponentsConfig Constructor

Constructs a new NormalizeVertexComponentsConfig.

Namespace: Assimp.Configs
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public NormalizeVertexComponentsConfig(
    bool normalizeVertexComponents
)

Parameters

normalizeVertexComponents
Type: SystemBoolean
True if the post process step should normalize vertex components, false otherwise.
See Also

Reference

NormalizeVertexComponentsConfig Class
Assimp.Configs Namespace


NormalizeVertexComponentsConfig Properties

The NormalizeVertexComponentsConfig type exposes the following members.

Properties
 | Name | Description
Public property | DefaultValue | Gets the default property value. (Inherited from BooleanPropertyConfig.)
Public property | Name | Gets the property name. (Inherited from PropertyConfig.)
 | NormalizeVertexComponentsConfigName | Gets the string name used by NormalizeVertexComponentsConfig.
Public property | Value | Gets the property value. (Inherited from BooleanPropertyConfig.)
Top
See Also

Reference

NormalizeVertexComponentsConfig Class
Assimp.Configs Namespace


NormalizeVertexComponentsConfig.NormalizeVertexComponentsConfigName Property

NormalizeVertexComponentsConfigNormalizeVertexComponentsConfigName Property

Gets the string name used by NormalizeVertexComponentsConfig.

Namespace: Assimp.Configs
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public static string NormalizeVertexComponentsConfigName { get; }

Property Value

Type: String
See Also

Reference

NormalizeVertexComponentsConfig Class
Assimp.Configs Namespace


NormalizeVertexComponentsConfig Methods

The NormalizeVertexComponentsConfig type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | SetDefaultValue | Sets the current value to the default value. (Inherited from BooleanPropertyConfig.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

NormalizeVertexComponentsConfig Class
Assimp.Configs Namespace


NormalSmoothingAngleConfig Class

Configuration to set the maximum angle between two face normals at a vertex when they are smoothed during the step to calculate smooth normals. This is frequently called the "crease angle". The maximum and default value is 175 degrees.
Inheritance Hierarchy
SystemObject
Assimp.ConfigsPropertyConfig
Assimp.ConfigsFloatPropertyConfig
Assimp.ConfigsNormalSmoothingAngleConfig

Namespace: Assimp.Configs
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public sealed class NormalSmoothingAngleConfig : FloatPropertyConfig

The NormalSmoothingAngleConfig type exposes the following members.

Constructors
 | Name | Description
Public method | NormalSmoothingAngleConfig | Constructs a new NormalSmoothingAngleConfig.
Top
Properties
 | Name | Description
Public property | DefaultValue | Gets the default property value. (Inherited from FloatPropertyConfig.)
Public property | Name | Gets the property name. (Inherited from PropertyConfig.)
 | NormalSmoothingAngleConfigName | Gets the string name used by NormalSmoothingAngleConfig.
Public property | Value | Gets the property value. (Inherited from FloatPropertyConfig.)
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | SetDefaultValue | Sets the current value to the default value. (Inherited from FloatPropertyConfig.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Assimp.Configs Namespace


NormalSmoothingAngleConfig Constructor

Constructs a new NormalSmoothingAngleConfig.

Namespace: Assimp.Configs
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public NormalSmoothingAngleConfig(
    float angle
)

Parameters

angle
Type: SystemSingle
Smoothing angle, in degrees.
See Also

Reference

NormalSmoothingAngleConfig Class
Assimp.Configs Namespace


NormalSmoothingAngleConfig Properties

The NormalSmoothingAngleConfig type exposes the following members.

Properties
 | Name | Description
Public property | DefaultValue | Gets the default property value. (Inherited from FloatPropertyConfig.)
Public property | Name | Gets the property name. (Inherited from PropertyConfig.)
 | NormalSmoothingAngleConfigName | Gets the string name used by NormalSmoothingAngleConfig.
Public property | Value | Gets the property value. (Inherited from FloatPropertyConfig.)
Top
See Also

Reference

NormalSmoothingAngleConfig Class
Assimp.Configs Namespace


NormalSmoothingAngleConfig.NormalSmoothingAngleConfigName Property

NormalSmoothingAngleConfigNormalSmoothingAngleConfigName Property

Gets the string name used by NormalSmoothingAngleConfig.

Namespace: Assimp.Configs
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public static string NormalSmoothingAngleConfigName { get; }

Property Value

Type: String
See Also

Reference

NormalSmoothingAngleConfig Class
Assimp.Configs Namespace


NormalSmoothingAngleConfig Methods

The NormalSmoothingAngleConfig type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | SetDefaultValue | Sets the current value to the default value. (Inherited from FloatPropertyConfig.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

NormalSmoothingAngleConfig Class
Assimp.Configs Namespace


NoSkeletonMeshesConfig Class

Global setting to disable generation of skeleton dummy meshes. These are generated as a visualization aid in cases which the input data contains no geometry, but only animation data. So the geometry are visualizing the bones. Default value is false.
Inheritance Hierarchy
SystemObject
Assimp.ConfigsPropertyConfig
Assimp.ConfigsBooleanPropertyConfig
Assimp.ConfigsNoSkeletonMeshesConfig

Namespace: Assimp.Configs
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public sealed class NoSkeletonMeshesConfig : BooleanPropertyConfig

The NoSkeletonMeshesConfig type exposes the following members.

Constructors
 | Name | Description
Public method | NoSkeletonMeshesConfig | Constructs a new NoSkeletonMeshConfig.
Top
Properties
 | Name | Description
Public property | DefaultValue | Gets the default property value. (Inherited from BooleanPropertyConfig.)
Public property | Name | Gets the property name. (Inherited from PropertyConfig.)
 | NoSkeletonMeshesConfigName | Gets the string name used by NoSkeletonMeshConfig.
Public property | Value | Gets the property value. (Inherited from BooleanPropertyConfig.)
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | SetDefaultValue | Sets the current value to the default value. (Inherited from BooleanPropertyConfig.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Assimp.Configs Namespace


NoSkeletonMeshesConfig Constructor

Constructs a new NoSkeletonMeshConfig.

Namespace: Assimp.Configs
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public NoSkeletonMeshesConfig(
    bool disableDummySkeletonMeshes
)

Parameters

disableDummySkeletonMeshes
Type: SystemBoolean
True if dummy skeleton mesh generation should be disabled, false otherwise.
See Also

Reference

NoSkeletonMeshesConfig Class
Assimp.Configs Namespace


NoSkeletonMeshesConfig Properties

The NoSkeletonMeshesConfig type exposes the following members.

Properties
 | Name | Description
Public property | DefaultValue | Gets the default property value. (Inherited from BooleanPropertyConfig.)
Public property | Name | Gets the property name. (Inherited from PropertyConfig.)
 | NoSkeletonMeshesConfigName | Gets the string name used by NoSkeletonMeshConfig.
Public property | Value | Gets the property value. (Inherited from BooleanPropertyConfig.)
Top
See Also

Reference

NoSkeletonMeshesConfig Class
Assimp.Configs Namespace


NoSkeletonMeshesConfig.NoSkeletonMeshesConfigName Property

NoSkeletonMeshesConfigNoSkeletonMeshesConfigName Property

Gets the string name used by NoSkeletonMeshConfig.

Namespace: Assimp.Configs
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public static string NoSkeletonMeshesConfigName { get; }

Property Value

Type: String
See Also

Reference

NoSkeletonMeshesConfig Class
Assimp.Configs Namespace


NoSkeletonMeshesConfig Methods

The NoSkeletonMeshesConfig type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | SetDefaultValue | Sets the current value to the default value. (Inherited from BooleanPropertyConfig.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

NoSkeletonMeshesConfig Class
Assimp.Configs Namespace


OgreMaterialFileConfig Class

The Ogre importer will try to load this MaterialFile. Ogre meshes reference with material names, this does not tell Assimp where the file is located. Assimp will try to find the source file in the following order: [material-name].material, [mesh-filename-base].material, and lastly the material name defined by this config property. The default value is "Scene.Material".
Inheritance Hierarchy
SystemObject
Assimp.ConfigsPropertyConfig
Assimp.ConfigsStringPropertyConfig
Assimp.ConfigsOgreMaterialFileConfig

Namespace: Assimp.Configs
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public sealed class OgreMaterialFileConfig : StringPropertyConfig

The OgreMaterialFileConfig type exposes the following members.

Constructors
 | Name | Description
Public method | OgreMaterialFileConfig | Constructs a new OgreMaterialFileConfig.
Top
Properties
 | Name | Description
Public property | DefaultValue | Gets the default property value. (Inherited from StringPropertyConfig.)
Public property | Name | Gets the property name. (Inherited from PropertyConfig.)
 | OgreMaterialFileConfigName | Gets the string name used by OgreMaterialFileConfig.
Public property | Value | Gets the property value. (Inherited from StringPropertyConfig.)
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | SetDefaultValue | Sets the current value to the default value. (Inherited from StringPropertyConfig.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Assimp.Configs Namespace


OgreMaterialFileConfig Constructor

Constructs a new OgreMaterialFileConfig.

Namespace: Assimp.Configs
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public OgreMaterialFileConfig(
    string materialFileName
)

Parameters

materialFileName
Type: SystemString
Material file name to load.
See Also

Reference

OgreMaterialFileConfig Class
Assimp.Configs Namespace


OgreMaterialFileConfig Properties

The OgreMaterialFileConfig type exposes the following members.

Properties
 | Name | Description
Public property | DefaultValue | Gets the default property value. (Inherited from StringPropertyConfig.)
Public property | Name | Gets the property name. (Inherited from PropertyConfig.)
 | OgreMaterialFileConfigName | Gets the string name used by OgreMaterialFileConfig.
Public property | Value | Gets the property value. (Inherited from StringPropertyConfig.)
Top
See Also

Reference

OgreMaterialFileConfig Class
Assimp.Configs Namespace


OgreMaterialFileConfig.OgreMaterialFileConfigName Property

OgreMaterialFileConfigOgreMaterialFileConfigName Property

Gets the string name used by OgreMaterialFileConfig.

Namespace: Assimp.Configs
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public static string OgreMaterialFileConfigName { get; }

Property Value

Type: String
See Also

Reference

OgreMaterialFileConfig Class
Assimp.Configs Namespace


OgreMaterialFileConfig Methods

The OgreMaterialFileConfig type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | SetDefaultValue | Sets the current value to the default value. (Inherited from StringPropertyConfig.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

OgreMaterialFileConfig Class
Assimp.Configs Namespace


OgreTextureTypeFromFilenameConfig Class

The Ogre importer will detect the texture usage from the filename. Normally a texture is loaded as a color map, if no target is specified in the material file. If this is enabled, then Assimp will try to detect the type from the texture filename postfix:
  • Normal Maps: _n, _nrm, _nrml, _normal, _normals, _normalmap
  • Specular Maps: _s, _spec, _specular, _specularmap
  • Light Maps: _l, _light, _lightmap, _occ, _occlusion
  • Displacement Maps: _dis, _displacement
The matching is case insensitive. Postfix is taken between the last "_" and last ".". The default behavior is to detect type from lower cased texture unit name by matching against: normalmap, specularmap, lightmap, and displacementmap. For both cases if no match is found then, Diffuse is used. The default value is false.
Inheritance Hierarchy
SystemObject
Assimp.ConfigsPropertyConfig
Assimp.ConfigsBooleanPropertyConfig
Assimp.ConfigsOgreTextureTypeFromFilenameConfig

Namespace: Assimp.Configs
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public sealed class OgreTextureTypeFromFilenameConfig : BooleanPropertyConfig

The OgreTextureTypeFromFilenameConfig type exposes the following members.

Constructors
 | Name | Description
Public method | OgreTextureTypeFromFilenameConfig | Constructs a new OgreTextureTypeFromFilenameConfig.
Top
Properties
 | Name | Description
Public property | DefaultValue | Gets the default property value. (Inherited from BooleanPropertyConfig.)
Public property | Name | Gets the property name. (Inherited from PropertyConfig.)
 | OgreTextureTypeFromFilenameConfigName | Gets the string name used by OgreTextureTypeFromFilenameConfig.
Public property | Value | Gets the property value. (Inherited from BooleanPropertyConfig.)
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | SetDefaultValue | Sets the current value to the default value. (Inherited from BooleanPropertyConfig.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Assimp.Configs Namespace


OgreTextureTypeFromFilenameConfig Constructor

Constructs a new OgreTextureTypeFromFilenameConfig.

Namespace: Assimp.Configs
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public OgreTextureTypeFromFilenameConfig(
    bool fileNameDefinesTextureUsage
)

Parameters

fileNameDefinesTextureUsage
Type: SystemBoolean
True if the filename defines texture usage, false otherwise.
See Also

Reference

OgreTextureTypeFromFilenameConfig Class
Assimp.Configs Namespace


OgreTextureTypeFromFilenameConfig Properties

The OgreTextureTypeFromFilenameConfig type exposes the following members.

Properties
 | Name | Description
Public property | DefaultValue | Gets the default property value. (Inherited from BooleanPropertyConfig.)
Public property | Name | Gets the property name. (Inherited from PropertyConfig.)
 | OgreTextureTypeFromFilenameConfigName | Gets the string name used by OgreTextureTypeFromFilenameConfig.
Public property | Value | Gets the property value. (Inherited from BooleanPropertyConfig.)
Top
See Also

Reference

OgreTextureTypeFromFilenameConfig Class
Assimp.Configs Namespace


OgreTextureTypeFromFilenameConfig.OgreTextureTypeFromFilenameConfigName Property

OgreTextureTypeFromFilenameConfigOgreTextureTypeFromFilenameConfigName Property

Gets the string name used by OgreTextureTypeFromFilenameConfig.

Namespace: Assimp.Configs
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public static string OgreTextureTypeFromFilenameConfigName { get; }

Property Value

Type: String
See Also

Reference

OgreTextureTypeFromFilenameConfig Class
Assimp.Configs Namespace


OgreTextureTypeFromFilenameConfig Methods

The OgreTextureTypeFromFilenameConfig type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | SetDefaultValue | Sets the current value to the default value. (Inherited from BooleanPropertyConfig.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

OgreTextureTypeFromFilenameConfig Class
Assimp.Configs Namespace


PropertyConfig Class

Base property config.
Inheritance Hierarchy
SystemObject
Assimp.ConfigsPropertyConfig
Assimp.ConfigsBooleanPropertyConfig
Assimp.ConfigsFloatPropertyConfig
Assimp.ConfigsIntegerPropertyConfig
Assimp.ConfigsMatrixPropertyConfig
Assimp.ConfigsStringPropertyConfig

Namespace: Assimp.Configs
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public abstract class PropertyConfig

The PropertyConfig type exposes the following members.

Constructors
 | Name | Description
Protected method | PropertyConfig | Creates a new property config that has no active Assimp property store.
Top
Properties
 | Name | Description
Public property | Name | Gets the property name.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | OnApplyValue | Applies the property value to the given Assimp property store.
Public method | SetDefaultValue | Sets the current value to the default value.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Assimp.Configs Namespace


PropertyConfig Constructor

Creates a new property config that has no active Assimp property store.

Namespace: Assimp.Configs
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
protected PropertyConfig(
    string name
)

Parameters

name
Type: SystemString
Name of the property.
See Also

Reference

PropertyConfig Class
Assimp.Configs Namespace


PropertyConfig Properties

The PropertyConfig type exposes the following members.

Properties
 | Name | Description
Public property | Name | Gets the property name.
Top
See Also

Reference

PropertyConfig Class
Assimp.Configs Namespace


PropertyConfig.Name Property

PropertyConfigName Property

Gets the property name.

Namespace: Assimp.Configs
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public string Name { get; }

Property Value

Type: String
See Also

Reference

PropertyConfig Class
Assimp.Configs Namespace


PropertyConfig Methods

The PropertyConfig type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | OnApplyValue | Applies the property value to the given Assimp property store.
Public method | SetDefaultValue | Sets the current value to the default value.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

PropertyConfig Class
Assimp.Configs Namespace


PropertyConfig.OnApplyValue Method

PropertyConfigOnApplyValue Method

Applies the property value to the given Assimp property store.

Namespace: Assimp.Configs
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
protected abstract void OnApplyValue(
    IntPtr propStore
)

Parameters

propStore
Type: SystemIntPtr
Assimp property store
See Also

Reference

PropertyConfig Class
Assimp.Configs Namespace


PropertyConfig.SetDefaultValue Method

PropertyConfigSetDefaultValue Method

Sets the current value to the default value.

Namespace: Assimp.Configs
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public abstract void SetDefaultValue()
See Also

Reference

PropertyConfig Class
Assimp.Configs Namespace


RemoveComponentConfig Class

Configuration for the RemoveComponent step that specifies which parts of the data structure is to be removed. If no valid mesh remains after the step, the import fails. The default value i None.
Inheritance Hierarchy
SystemObject
Assimp.ConfigsPropertyConfig
Assimp.ConfigsIntegerPropertyConfig
Assimp.ConfigsRemoveComponentConfig

Namespace: Assimp.Configs
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public sealed class RemoveComponentConfig : IntegerPropertyConfig

The RemoveComponentConfig type exposes the following members.

Constructors
 | Name | Description
Public method | RemoveComponentConfig | Constructs a new RemoveComponentConfig.
Top
Properties
 | Name | Description
Public property | DefaultValue | Gets the default property value. (Inherited from IntegerPropertyConfig.)
Public property | Name | Gets the property name. (Inherited from PropertyConfig.)
 | RemoveComponentConfigName | Gets the string name used by RemoveComponentConfig.
Public property | Value | Gets the property value. (Inherited from IntegerPropertyConfig.)
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | SetDefaultValue | Sets the current value to the default value. (Inherited from IntegerPropertyConfig.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Assimp.Configs Namespace


RemoveComponentConfig Constructor

Constructs a new RemoveComponentConfig.

Namespace: Assimp.Configs
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public RemoveComponentConfig(
    ExcludeComponent componentsToExclude
)

Parameters

componentsToExclude
Type: AssimpExcludeComponent
Bit-wise combination of components to exclude.
See Also

Reference

RemoveComponentConfig Class
Assimp.Configs Namespace


RemoveComponentConfig Properties

The RemoveComponentConfig type exposes the following members.

Properties
 | Name | Description
Public property | DefaultValue | Gets the default property value. (Inherited from IntegerPropertyConfig.)
Public property | Name | Gets the property name. (Inherited from PropertyConfig.)
 | RemoveComponentConfigName | Gets the string name used by RemoveComponentConfig.
Public property | Value | Gets the property value. (Inherited from IntegerPropertyConfig.)
Top
See Also

Reference

RemoveComponentConfig Class
Assimp.Configs Namespace


RemoveComponentConfig.RemoveComponentConfigName Property

RemoveComponentConfigRemoveComponentConfigName Property

Gets the string name used by RemoveComponentConfig.

Namespace: Assimp.Configs
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public static string RemoveComponentConfigName { get; }

Property Value

Type: String
See Also

Reference

RemoveComponentConfig Class
Assimp.Configs Namespace


RemoveComponentConfig Methods

The RemoveComponentConfig type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | SetDefaultValue | Sets the current value to the default value. (Inherited from IntegerPropertyConfig.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

RemoveComponentConfig Class
Assimp.Configs Namespace


RemoveDegeneratePrimitivesCheckAreaConfig Class

Configuration for the FindDegenerates step. If true, the area of the triangles are checked to see if they are greater than 1e-6. If so, the triangle is removed if RemoveDegeneratePrimitivesConfig is set to true.
Inheritance Hierarchy
SystemObject
Assimp.ConfigsPropertyConfig
Assimp.ConfigsBooleanPropertyConfig
Assimp.ConfigsRemoveDegeneratePrimitivesCheckAreaConfig

Namespace: Assimp.Configs
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public sealed class RemoveDegeneratePrimitivesCheckAreaConfig : BooleanPropertyConfig

The RemoveDegeneratePrimitivesCheckAreaConfig type exposes the following members.

Constructors
 | Name | Description
Public method | RemoveDegeneratePrimitivesCheckAreaConfig | Constructs a new RemoveDegeneratePrimitivesCheckAreaConfig.
Top
Properties
 | Name | Description
Public property | DefaultValue | Gets the default property value. (Inherited from BooleanPropertyConfig.)
Public property | Name | Gets the property name. (Inherited from PropertyConfig.)
 | RemoveDegeneratePrimitivesCheckAreaConfigName | Gets the string name used by RemoveDegeneratePrimitivesCheckAreaConfig.
Public property | Value | Gets the property value. (Inherited from BooleanPropertyConfig.)
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | SetDefaultValue | Sets the current value to the default value. (Inherited from BooleanPropertyConfig.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Assimp.Configs Namespace


RemoveDegeneratePrimitivesCheckAreaConfig Constructor

Constructs a new RemoveDegeneratePrimitivesCheckAreaConfig.

Namespace: Assimp.Configs
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public RemoveDegeneratePrimitivesCheckAreaConfig(
    bool checkArea
)

Parameters

checkArea
Type: SystemBoolean
True if the post process step should check the area of triangles when finding degenerate primitives, false otherwise.
See Also

Reference

RemoveDegeneratePrimitivesCheckAreaConfig Class
Assimp.Configs Namespace


RemoveDegeneratePrimitivesCheckAreaConfig Properties

The RemoveDegeneratePrimitivesCheckAreaConfig type exposes the following members.

Properties
 | Name | Description
Public property | DefaultValue | Gets the default property value. (Inherited from BooleanPropertyConfig.)
Public property | Name | Gets the property name. (Inherited from PropertyConfig.)
 | RemoveDegeneratePrimitivesCheckAreaConfigName | Gets the string name used by RemoveDegeneratePrimitivesCheckAreaConfig.
Public property | Value | Gets the property value. (Inherited from BooleanPropertyConfig.)
Top
See Also

Reference

RemoveDegeneratePrimitivesCheckAreaConfig Class
Assimp.Configs Namespace


RemoveDegeneratePrimitivesCheckAreaConfig.RemoveDegeneratePrimitivesCheckAreaConfigName Property

RemoveDegeneratePrimitivesCheckAreaConfigRemoveDegeneratePrimitivesCheckAreaConfigName Property

Gets the string name used by RemoveDegeneratePrimitivesCheckAreaConfig.

Namespace: Assimp.Configs
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public static string RemoveDegeneratePrimitivesCheckAreaConfigName { get; }

Property Value

Type: String
See Also

Reference

RemoveDegeneratePrimitivesCheckAreaConfig Class
Assimp.Configs Namespace


RemoveDegeneratePrimitivesCheckAreaConfig Methods

The RemoveDegeneratePrimitivesCheckAreaConfig type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | SetDefaultValue | Sets the current value to the default value. (Inherited from BooleanPropertyConfig.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

RemoveDegeneratePrimitivesCheckAreaConfig Class
Assimp.Configs Namespace


RemoveDegeneratePrimitivesConfig Class

Configuration for the FindDegenerates step to remove degenerted primitives from the import immediately. The default value is false, where degenerated triangles are converted to lines, and degenerated lines to points.
Inheritance Hierarchy
SystemObject
Assimp.ConfigsPropertyConfig
Assimp.ConfigsBooleanPropertyConfig
Assimp.ConfigsRemoveDegeneratePrimitivesConfig

Namespace: Assimp.Configs
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public sealed class RemoveDegeneratePrimitivesConfig : BooleanPropertyConfig

The RemoveDegeneratePrimitivesConfig type exposes the following members.

Constructors
 | Name | Description
Public method | RemoveDegeneratePrimitivesConfig | Constructs a new RemoveDegeneratePrimitivesConfig.
Top
Properties
 | Name | Description
Public property | DefaultValue | Gets the default property value. (Inherited from BooleanPropertyConfig.)
Public property | Name | Gets the property name. (Inherited from PropertyConfig.)
 | RemoveDegeneratePrimitivesConfigName | Gets the string name used by RemoveDegeneratePrimitivesConfig.
Public property | Value | Gets the property value. (Inherited from BooleanPropertyConfig.)
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | SetDefaultValue | Sets the current value to the default value. (Inherited from BooleanPropertyConfig.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Assimp.Configs Namespace


RemoveDegeneratePrimitivesConfig Constructor

Constructs a new RemoveDegeneratePrimitivesConfig.

Namespace: Assimp.Configs
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public RemoveDegeneratePrimitivesConfig(
    bool removeDegenerates
)

Parameters

removeDegenerates
Type: SystemBoolean
True if the post process step should remove degenerate primitives, false otherwise.
See Also

Reference

RemoveDegeneratePrimitivesConfig Class
Assimp.Configs Namespace


RemoveDegeneratePrimitivesConfig Properties

The RemoveDegeneratePrimitivesConfig type exposes the following members.

Properties
 | Name | Description
Public property | DefaultValue | Gets the default property value. (Inherited from BooleanPropertyConfig.)
Public property | Name | Gets the property name. (Inherited from PropertyConfig.)
 | RemoveDegeneratePrimitivesConfigName | Gets the string name used by RemoveDegeneratePrimitivesConfig.
Public property | Value | Gets the property value. (Inherited from BooleanPropertyConfig.)
Top
See Also

Reference

RemoveDegeneratePrimitivesConfig Class
Assimp.Configs Namespace


RemoveDegeneratePrimitivesConfig.RemoveDegeneratePrimitivesConfigName Property

RemoveDegeneratePrimitivesConfigRemoveDegeneratePrimitivesConfigName Property

Gets the string name used by RemoveDegeneratePrimitivesConfig.

Namespace: Assimp.Configs
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public static string RemoveDegeneratePrimitivesConfigName { get; }

Property Value

Type: String
See Also

Reference

RemoveDegeneratePrimitivesConfig Class
Assimp.Configs Namespace


RemoveDegeneratePrimitivesConfig Methods

The RemoveDegeneratePrimitivesConfig type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | SetDefaultValue | Sets the current value to the default value. (Inherited from BooleanPropertyConfig.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

RemoveDegeneratePrimitivesConfig Class
Assimp.Configs Namespace


RootTransformationConfig Class

Configuration for PreTransformVertices that sets a user defined matrix as the scene root node transformation before transforming vertices. Default value is the identity matrix.
Inheritance Hierarchy
SystemObject
Assimp.ConfigsPropertyConfig
Assimp.ConfigsMatrixPropertyConfig
Assimp.ConfigsRootTransformationConfig

Namespace: Assimp.Configs
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public sealed class RootTransformationConfig : MatrixPropertyConfig

The RootTransformationConfig type exposes the following members.

Constructors
 | Name | Description
Public method | RootTransformationConfig | Constructs a new RootTransformationConfig.
Top
Properties
 | Name | Description
Public property | DefaultValue | Gets the default property value. (Inherited from MatrixPropertyConfig.)
Public property | Name | Gets the property name. (Inherited from PropertyConfig.)
 | RootTransformationConfigName | Gets the string name used by RootTransformationConfig.
Public property | Value | Gets the property value. (Inherited from MatrixPropertyConfig.)
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | SetDefaultValue | Sets the current value to the default value. (Inherited from MatrixPropertyConfig.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Assimp.Configs Namespace


RootTransformationConfig Constructor

Constructs a new RootTransformationConfig.

Namespace: Assimp.Configs
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public RootTransformationConfig(
    Matrix4x4 rootTransform
)

Parameters

rootTransform
Type: AssimpMatrix4x4
Root transformation matrix to be set to the root scene node during the pretransform post process step.
See Also

Reference

RootTransformationConfig Class
Assimp.Configs Namespace


RootTransformationConfig Properties

The RootTransformationConfig type exposes the following members.

Properties
 | Name | Description
Public property | DefaultValue | Gets the default property value. (Inherited from MatrixPropertyConfig.)
Public property | Name | Gets the property name. (Inherited from PropertyConfig.)
 | RootTransformationConfigName | Gets the string name used by RootTransformationConfig.
Public property | Value | Gets the property value. (Inherited from MatrixPropertyConfig.)
Top
See Also

Reference

RootTransformationConfig Class
Assimp.Configs Namespace


RootTransformationConfig.RootTransformationConfigName Property

RootTransformationConfigRootTransformationConfigName Property

Gets the string name used by RootTransformationConfig.

Namespace: Assimp.Configs
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public static string RootTransformationConfigName { get; }

Property Value

Type: String
See Also

Reference

RootTransformationConfig Class
Assimp.Configs Namespace


RootTransformationConfig Methods

The RootTransformationConfig type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | SetDefaultValue | Sets the current value to the default value. (Inherited from MatrixPropertyConfig.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

RootTransformationConfig Class
Assimp.Configs Namespace


SMDKeyFrameImportConfig Class

Sets the vertex animation keyframe to be imported. Assimp does not support vertex keyframes (only bone animation is supported). the library reads only one keyframe with vertex animations. By default this is the first frame. This config sets the global override for the SMD format.
Inheritance Hierarchy
SystemObject
Assimp.ConfigsPropertyConfig
Assimp.ConfigsIntegerPropertyConfig
Assimp.ConfigsSMDKeyFrameImportConfig

Namespace: Assimp.Configs
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public sealed class SMDKeyFrameImportConfig : IntegerPropertyConfig

The SMDKeyFrameImportConfig type exposes the following members.

Constructors
 | Name | Description
Public method | SMDKeyFrameImportConfig | Constructs a new SMDKeyFrameImportConfig.
Top
Properties
 | Name | Description
Public property | DefaultValue | Gets the default property value. (Inherited from IntegerPropertyConfig.)
Public property | Name | Gets the property name. (Inherited from PropertyConfig.)
 | SMDKeyFrameImportConfigName | Gets the string name used by SMDKeyFrameImportConfig.
Public property | Value | Gets the property value. (Inherited from IntegerPropertyConfig.)
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | SetDefaultValue | Sets the current value to the default value. (Inherited from IntegerPropertyConfig.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Assimp.Configs Namespace


SMDKeyFrameImportConfig Constructor

Constructs a new SMDKeyFrameImportConfig.

Namespace: Assimp.Configs
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public SMDKeyFrameImportConfig(
    int keyFrame
)

Parameters

keyFrame
Type: SystemInt32
Keyframe index
See Also

Reference

SMDKeyFrameImportConfig Class
Assimp.Configs Namespace


SMDKeyFrameImportConfig Properties

The SMDKeyFrameImportConfig type exposes the following members.

Properties
 | Name | Description
Public property | DefaultValue | Gets the default property value. (Inherited from IntegerPropertyConfig.)
Public property | Name | Gets the property name. (Inherited from PropertyConfig.)
 | SMDKeyFrameImportConfigName | Gets the string name used by SMDKeyFrameImportConfig.
Public property | Value | Gets the property value. (Inherited from IntegerPropertyConfig.)
Top
See Also

Reference

SMDKeyFrameImportConfig Class
Assimp.Configs Namespace


SMDKeyFrameImportConfig.SMDKeyFrameImportConfigName Property

SMDKeyFrameImportConfigSMDKeyFrameImportConfigName Property

Gets the string name used by SMDKeyFrameImportConfig.

Namespace: Assimp.Configs
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public static string SMDKeyFrameImportConfigName { get; }

Property Value

Type: String
See Also

Reference

SMDKeyFrameImportConfig Class
Assimp.Configs Namespace


SMDKeyFrameImportConfig Methods

The SMDKeyFrameImportConfig type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | SetDefaultValue | Sets the current value to the default value. (Inherited from IntegerPropertyConfig.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

SMDKeyFrameImportConfig Class
Assimp.Configs Namespace


SortByPrimitiveTypeConfig Class

Configuration for the SortByPrimitiveType step that specifies which primitive types are to be removed by the step. Specifying all primitive types is illegal. The default value is zero specifying none.
Inheritance Hierarchy
SystemObject
Assimp.ConfigsPropertyConfig
Assimp.ConfigsIntegerPropertyConfig
Assimp.ConfigsSortByPrimitiveTypeConfig

Namespace: Assimp.Configs
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public sealed class SortByPrimitiveTypeConfig : IntegerPropertyConfig

The SortByPrimitiveTypeConfig type exposes the following members.

Constructors
 | Name | Description
Public method | SortByPrimitiveTypeConfig | Constructs a new SortByPrimitiveTypeConfig.
Top
Properties
 | Name | Description
Public property | DefaultValue | Gets the default property value. (Inherited from IntegerPropertyConfig.)
Public property | Name | Gets the property name. (Inherited from PropertyConfig.)
 | SortByPrimitiveTypeConfigName | Gets the string name used by SortByPrimitiveTypeConfig.
Public property | Value | Gets the property value. (Inherited from IntegerPropertyConfig.)
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | SetDefaultValue | Sets the current value to the default value. (Inherited from IntegerPropertyConfig.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Assimp.Configs Namespace


SortByPrimitiveTypeConfig Constructor

Constructs a new SortByPrimitiveTypeConfig.

Namespace: Assimp.Configs
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public SortByPrimitiveTypeConfig(
    PrimitiveType typesToRemove
)

Parameters

typesToRemove
Type: AssimpPrimitiveType
Bit-wise combination of primitive types to remove
See Also

Reference

SortByPrimitiveTypeConfig Class
Assimp.Configs Namespace


SortByPrimitiveTypeConfig Properties

The SortByPrimitiveTypeConfig type exposes the following members.

Properties
 | Name | Description
Public property | DefaultValue | Gets the default property value. (Inherited from IntegerPropertyConfig.)
Public property | Name | Gets the property name. (Inherited from PropertyConfig.)
 | SortByPrimitiveTypeConfigName | Gets the string name used by SortByPrimitiveTypeConfig.
Public property | Value | Gets the property value. (Inherited from IntegerPropertyConfig.)
Top
See Also

Reference

SortByPrimitiveTypeConfig Class
Assimp.Configs Namespace


SortByPrimitiveTypeConfig.SortByPrimitiveTypeConfigName Property

SortByPrimitiveTypeConfigSortByPrimitiveTypeConfigName Property

Gets the string name used by SortByPrimitiveTypeConfig.

Namespace: Assimp.Configs
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public static string SortByPrimitiveTypeConfigName { get; }

Property Value

Type: String
See Also

Reference

SortByPrimitiveTypeConfig Class
Assimp.Configs Namespace


SortByPrimitiveTypeConfig Methods

The SortByPrimitiveTypeConfig type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | SetDefaultValue | Sets the current value to the default value. (Inherited from IntegerPropertyConfig.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

SortByPrimitiveTypeConfig Class
Assimp.Configs Namespace


StringPropertyConfig Class

Describes a string configuration property.
Inheritance Hierarchy
SystemObject
Assimp.ConfigsPropertyConfig
Assimp.ConfigsStringPropertyConfig
More...

Namespace: Assimp.Configs
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public class StringPropertyConfig : PropertyConfig

The StringPropertyConfig type exposes the following members.

Constructors
 | Name | Description
Public method | StringPropertyConfig(String, String) | Constructs a new StringPropertyConfig.
Public method | StringPropertyConfig(String, String, String) | Constructs a new StringPropertyConfig with a default value.
Top
Properties
 | Name | Description
Public property | DefaultValue | Gets the default property value.
Public property | Name | Gets the property name. (Inherited from PropertyConfig.)
Public property | Value | Gets the property value.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | OnApplyValue | Applies the property value to the given Assimp property store. (Overrides PropertyConfigOnApplyValue(IntPtr).)
 | ProcessNames | Convience method for constructing a whitespace delimited name list.
Public method | SetDefaultValue | Sets the current value to the default value. (Overrides PropertyConfigSetDefaultValue.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Assimp.Configs Namespace
Inheritance Hierarchy
SystemObject
Assimp.ConfigsPropertyConfig
Assimp.ConfigsStringPropertyConfig
Assimp.ConfigsMaterialExcludeListConfig
Assimp.ConfigsMD3ShaderSourceConfig
Assimp.ConfigsMD3SkinNameConfig
Assimp.ConfigsMDLColorMapConfig
Assimp.ConfigsNodeExcludeListConfig
Assimp.ConfigsOgreMaterialFileConfig


StringPropertyConfig Constructor

Overload List
 | Name | Description
Public method | StringPropertyConfig(String, String) | Constructs a new StringPropertyConfig.
Public method | StringPropertyConfig(String, String, String) | Constructs a new StringPropertyConfig with a default value.
Top
See Also

Reference

StringPropertyConfig Class
Assimp.Configs Namespace


StringPropertyConfig Constructor (String, String)

Constructs a new StringPropertyConfig.

Namespace: Assimp.Configs
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public StringPropertyConfig(
    string name,
    string value
)

Parameters

name
Type: SystemString
Name of the property
value
Type: SystemString
Property value
See Also

Reference

StringPropertyConfig Class
StringPropertyConfig Overload
Assimp.Configs Namespace


StringPropertyConfig Constructor (String, String, String)

Constructs a new StringPropertyConfig with a default value.

Namespace: Assimp.Configs
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public StringPropertyConfig(
    string name,
    string value,
    string defaultValue
)

Parameters

name
Type: SystemString
Name of the property
value
Type: SystemString
Property value
defaultValue
Type: SystemString
The default property value
See Also

Reference

StringPropertyConfig Class
StringPropertyConfig Overload
Assimp.Configs Namespace


StringPropertyConfig Properties

The StringPropertyConfig type exposes the following members.

Properties
 | Name | Description
Public property | DefaultValue | Gets the default property value.
Public property | Name | Gets the property name. (Inherited from PropertyConfig.)
Public property | Value | Gets the property value.
Top
See Also

Reference

StringPropertyConfig Class
Assimp.Configs Namespace


StringPropertyConfig.DefaultValue Property

StringPropertyConfigDefaultValue Property

Gets the default property value.

Namespace: Assimp.Configs
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public string DefaultValue { get; }

Property Value

Type: String
See Also

Reference

StringPropertyConfig Class
Assimp.Configs Namespace


StringPropertyConfig.Value Property

StringPropertyConfigValue Property

Gets the property value.

Namespace: Assimp.Configs
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public string Value { get; set; }

Property Value

Type: String
See Also

Reference

StringPropertyConfig Class
Assimp.Configs Namespace


StringPropertyConfig Methods

The StringPropertyConfig type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | OnApplyValue | Applies the property value to the given Assimp property store. (Overrides PropertyConfigOnApplyValue(IntPtr).)
 | ProcessNames | Convience method for constructing a whitespace delimited name list.
Public method | SetDefaultValue | Sets the current value to the default value. (Overrides PropertyConfigSetDefaultValue.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

StringPropertyConfig Class
Assimp.Configs Namespace


StringPropertyConfig.OnApplyValue Method

StringPropertyConfigOnApplyValue Method

Applies the property value to the given Assimp property store.

Namespace: Assimp.Configs
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
protected override void OnApplyValue(
    IntPtr propStore
)

Parameters

propStore
Type: SystemIntPtr
Assimp property store
See Also

Reference

StringPropertyConfig Class
Assimp.Configs Namespace


StringPropertyConfig.ProcessNames Method

StringPropertyConfigProcessNames Method

Convience method for constructing a whitespace delimited name list.

Namespace: Assimp.Configs
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
protected static string ProcessNames(
    string[] names
)

Parameters

names
Type: SystemString
Array of names

Return Value

Type: String
White-space delimited list as a string
See Also

Reference

StringPropertyConfig Class
Assimp.Configs Namespace


StringPropertyConfig.SetDefaultValue Method

StringPropertyConfigSetDefaultValue Method

Sets the current value to the default value.

Namespace: Assimp.Configs
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public override void SetDefaultValue()
See Also

Reference

StringPropertyConfig Class
Assimp.Configs Namespace


TangentSmoothingAngleConfig Class

Configuration to set the maximum angle that may be between two vertex tangents/bitangents when they are smoothed during the step to calculate the tangent basis. The default value is 45 degrees.
Inheritance Hierarchy
SystemObject
Assimp.ConfigsPropertyConfig
Assimp.ConfigsFloatPropertyConfig
Assimp.ConfigsTangentSmoothingAngleConfig

Namespace: Assimp.Configs
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public sealed class TangentSmoothingAngleConfig : FloatPropertyConfig

The TangentSmoothingAngleConfig type exposes the following members.

Constructors
 | Name | Description
Public method | TangentSmoothingAngleConfig | Constructs a new TangentSmoothingAngleConfig.
Top
Properties
 | Name | Description
Public property | DefaultValue | Gets the default property value. (Inherited from FloatPropertyConfig.)
Public property | Name | Gets the property name. (Inherited from PropertyConfig.)
 | TangentSmoothingAngleConfigName | Gets the string name used by TangentSmoothingAngleConfig.
Public property | Value | Gets the property value. (Inherited from FloatPropertyConfig.)
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | SetDefaultValue | Sets the current value to the default value. (Inherited from FloatPropertyConfig.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Assimp.Configs Namespace


TangentSmoothingAngleConfig Constructor

Constructs a new TangentSmoothingAngleConfig.

Namespace: Assimp.Configs
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public TangentSmoothingAngleConfig(
    float angle
)

Parameters

angle
Type: SystemSingle
Smoothing angle, in degrees.
See Also

Reference

TangentSmoothingAngleConfig Class
Assimp.Configs Namespace


TangentSmoothingAngleConfig Properties

The TangentSmoothingAngleConfig type exposes the following members.

Properties
 | Name | Description
Public property | DefaultValue | Gets the default property value. (Inherited from FloatPropertyConfig.)
Public property | Name | Gets the property name. (Inherited from PropertyConfig.)
 | TangentSmoothingAngleConfigName | Gets the string name used by TangentSmoothingAngleConfig.
Public property | Value | Gets the property value. (Inherited from FloatPropertyConfig.)
Top
See Also

Reference

TangentSmoothingAngleConfig Class
Assimp.Configs Namespace


TangentSmoothingAngleConfig.TangentSmoothingAngleConfigName Property

TangentSmoothingAngleConfigTangentSmoothingAngleConfigName Property

Gets the string name used by TangentSmoothingAngleConfig.

Namespace: Assimp.Configs
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public static string TangentSmoothingAngleConfigName { get; }

Property Value

Type: String
See Also

Reference

TangentSmoothingAngleConfig Class
Assimp.Configs Namespace


TangentSmoothingAngleConfig Methods

The TangentSmoothingAngleConfig type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | SetDefaultValue | Sets the current value to the default value. (Inherited from FloatPropertyConfig.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

TangentSmoothingAngleConfig Class
Assimp.Configs Namespace


TangentTextureChannelIndexConfig Class

Configures which texture channel is used for tangent space computations. The channel must exist or an error will be raised.
Inheritance Hierarchy
SystemObject
Assimp.ConfigsPropertyConfig
Assimp.ConfigsIntegerPropertyConfig
Assimp.ConfigsTangentTextureChannelIndexConfig

Namespace: Assimp.Configs
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public sealed class TangentTextureChannelIndexConfig : IntegerPropertyConfig

The TangentTextureChannelIndexConfig type exposes the following members.

Constructors
 | Name | Description
Public method | TangentTextureChannelIndexConfig | Constructs a new TangentTextureChannelIndexConfig.
Top
Properties
 | Name | Description
Public property | DefaultValue | Gets the default property value. (Inherited from IntegerPropertyConfig.)
Public property | Name | Gets the property name. (Inherited from PropertyConfig.)
 | TangentTextureChannelIndexConfigName | Gets the string name used by TangentTextureChannelIndexConfig.
Public property | Value | Gets the property value. (Inherited from IntegerPropertyConfig.)
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | SetDefaultValue | Sets the current value to the default value. (Inherited from IntegerPropertyConfig.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Assimp.Configs Namespace


TangentTextureChannelIndexConfig Constructor

Constructs a new TangentTextureChannelIndexConfig.

Namespace: Assimp.Configs
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public TangentTextureChannelIndexConfig(
    int textureChannelIndex
)

Parameters

textureChannelIndex
Type: SystemInt32
The zero-based texture channel index.
See Also

Reference

TangentTextureChannelIndexConfig Class
Assimp.Configs Namespace


TangentTextureChannelIndexConfig Properties

The TangentTextureChannelIndexConfig type exposes the following members.

Properties
 | Name | Description
Public property | DefaultValue | Gets the default property value. (Inherited from IntegerPropertyConfig.)
Public property | Name | Gets the property name. (Inherited from PropertyConfig.)
 | TangentTextureChannelIndexConfigName | Gets the string name used by TangentTextureChannelIndexConfig.
Public property | Value | Gets the property value. (Inherited from IntegerPropertyConfig.)
Top
See Also

Reference

TangentTextureChannelIndexConfig Class
Assimp.Configs Namespace


TangentTextureChannelIndexConfig.TangentTextureChannelIndexConfigName Property

TangentTextureChannelIndexConfigTangentTextureChannelIndexConfigName Property

Gets the string name used by TangentTextureChannelIndexConfig.

Namespace: Assimp.Configs
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public static string TangentTextureChannelIndexConfigName { get; }

Property Value

Type: String
See Also

Reference

TangentTextureChannelIndexConfig Class
Assimp.Configs Namespace


TangentTextureChannelIndexConfig Methods

The TangentTextureChannelIndexConfig type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | SetDefaultValue | Sets the current value to the default value. (Inherited from IntegerPropertyConfig.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

TangentTextureChannelIndexConfig Class
Assimp.Configs Namespace


TerragenComputeTexCoordsConfig Class

Configures the terragen import plugin to compute UV's for terrains, if they are not given. Furthermore, a default texture is assigned. The default value is false.

UV coordinates for terrains are so simple to compute that you'll usually want to compute them on your own, if you need them. This option is intended for model viewers which want to offer an easy way to apply textures to terrains.

Inheritance Hierarchy
SystemObject
Assimp.ConfigsPropertyConfig
Assimp.ConfigsBooleanPropertyConfig
Assimp.ConfigsTerragenComputeTexCoordsConfig

Namespace: Assimp.Configs
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public sealed class TerragenComputeTexCoordsConfig : BooleanPropertyConfig

The TerragenComputeTexCoordsConfig type exposes the following members.

Constructors
 | Name | Description
Public method | TerragenComputeTexCoordsConfig | Constructs a new TerragenComputeTexCoordsConfig.
Top
Properties
 | Name | Description
Public property | DefaultValue | Gets the default property value. (Inherited from BooleanPropertyConfig.)
Public property | Name | Gets the property name. (Inherited from PropertyConfig.)
 | TerragenComputeTexCoordsConfigName | Gets the string name used by TerragenComputeTexCoordsConfig.
Public property | Value | Gets the property value. (Inherited from BooleanPropertyConfig.)
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | SetDefaultValue | Sets the current value to the default value. (Inherited from BooleanPropertyConfig.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Assimp.Configs Namespace


TerragenComputeTexCoordsConfig Constructor

Constructs a new TerragenComputeTexCoordsConfig.

Namespace: Assimp.Configs
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public TerragenComputeTexCoordsConfig(
    bool computeTexCoords
)

Parameters

computeTexCoords
Type: SystemBoolean
True if terran UV coordinates should be computed, false otherwise.
See Also

Reference

TerragenComputeTexCoordsConfig Class
Assimp.Configs Namespace


TerragenComputeTexCoordsConfig Properties

The TerragenComputeTexCoordsConfig type exposes the following members.

Properties
 | Name | Description
Public property | DefaultValue | Gets the default property value. (Inherited from BooleanPropertyConfig.)
Public property | Name | Gets the property name. (Inherited from PropertyConfig.)
 | TerragenComputeTexCoordsConfigName | Gets the string name used by TerragenComputeTexCoordsConfig.
Public property | Value | Gets the property value. (Inherited from BooleanPropertyConfig.)
Top
See Also

Reference

TerragenComputeTexCoordsConfig Class
Assimp.Configs Namespace


TerragenComputeTexCoordsConfig.TerragenComputeTexCoordsConfigName Property

TerragenComputeTexCoordsConfigTerragenComputeTexCoordsConfigName Property

Gets the string name used by TerragenComputeTexCoordsConfig.

Namespace: Assimp.Configs
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public static string TerragenComputeTexCoordsConfigName { get; }

Property Value

Type: String
See Also

Reference

TerragenComputeTexCoordsConfig Class
Assimp.Configs Namespace


TerragenComputeTexCoordsConfig Methods

The TerragenComputeTexCoordsConfig type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | SetDefaultValue | Sets the current value to the default value. (Inherited from BooleanPropertyConfig.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

TerragenComputeTexCoordsConfig Class
Assimp.Configs Namespace


TransformUVConfig Class

Configuration for the TransformUVCoords step that specifies which UV transformations are to be evaluated. The default value is for all combinations (scaling, rotation, translation).
Inheritance Hierarchy
SystemObject
Assimp.ConfigsPropertyConfig
Assimp.ConfigsIntegerPropertyConfig
Assimp.ConfigsTransformUVConfig

Namespace: Assimp.Configs
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public sealed class TransformUVConfig : IntegerPropertyConfig

The TransformUVConfig type exposes the following members.

Constructors
 | Name | Description
Public method | TransformUVConfig | Constructs a new TransformUVConfig.
Top
Properties
 | Name | Description
Public property | DefaultValue | Gets the default property value. (Inherited from IntegerPropertyConfig.)
Public property | Name | Gets the property name. (Inherited from PropertyConfig.)
 | TransformUVConfigName | Gets the string name used by TransformUVConfig.
Public property | Value | Gets the property value. (Inherited from IntegerPropertyConfig.)
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | SetDefaultValue | Sets the current value to the default value. (Inherited from IntegerPropertyConfig.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Assimp.Configs Namespace


TransformUVConfig Constructor

Constructs a new TransformUVConfig.

Namespace: Assimp.Configs
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public TransformUVConfig(
    UVTransformFlags transformFlags
)

Parameters

transformFlags
Type: AssimpUVTransformFlags
Bit-wise combination specifying which UV transforms that should be evaluated.
See Also

Reference

TransformUVConfig Class
Assimp.Configs Namespace


TransformUVConfig Properties

The TransformUVConfig type exposes the following members.

Properties
 | Name | Description
Public property | DefaultValue | Gets the default property value. (Inherited from IntegerPropertyConfig.)
Public property | Name | Gets the property name. (Inherited from PropertyConfig.)
 | TransformUVConfigName | Gets the string name used by TransformUVConfig.
Public property | Value | Gets the property value. (Inherited from IntegerPropertyConfig.)
Top
See Also

Reference

TransformUVConfig Class
Assimp.Configs Namespace


TransformUVConfig.TransformUVConfigName Property

TransformUVConfigTransformUVConfigName Property

Gets the string name used by TransformUVConfig.

Namespace: Assimp.Configs
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public static string TransformUVConfigName { get; }

Property Value

Type: String
See Also

Reference

TransformUVConfig Class
Assimp.Configs Namespace


TransformUVConfig Methods

The TransformUVConfig type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | SetDefaultValue | Sets the current value to the default value. (Inherited from IntegerPropertyConfig.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

TransformUVConfig Class
Assimp.Configs Namespace


UnrealHandleFlagsConfig Class

Configures the UNREAL 3D loader to separate faces with different surface flags (e.g. two-sided vs single-sided). The default value is true.
Inheritance Hierarchy
SystemObject
Assimp.ConfigsPropertyConfig
Assimp.ConfigsBooleanPropertyConfig
Assimp.ConfigsUnrealHandleFlagsConfig

Namespace: Assimp.Configs
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public sealed class UnrealHandleFlagsConfig : BooleanPropertyConfig

The UnrealHandleFlagsConfig type exposes the following members.

Constructors
 | Name | Description
Public method | UnrealHandleFlagsConfig | Constructs a new UnrealHandleFlagsConfig.
Top
Properties
 | Name | Description
Public property | DefaultValue | Gets the default property value. (Inherited from BooleanPropertyConfig.)
Public property | Name | Gets the property name. (Inherited from PropertyConfig.)
 | UnrealHandleFlagsConfigName | Gets the string name used by UnrealHandleFlagsConfig.
Public property | Value | Gets the property value. (Inherited from BooleanPropertyConfig.)
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | SetDefaultValue | Sets the current value to the default value. (Inherited from BooleanPropertyConfig.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Assimp.Configs Namespace


UnrealHandleFlagsConfig Constructor

Constructs a new UnrealHandleFlagsConfig.

Namespace: Assimp.Configs
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public UnrealHandleFlagsConfig(
    bool handleFlags
)

Parameters

handleFlags
Type: SystemBoolean
True if the unreal loader should separate faces with different surface flags, false otherwise.
See Also

Reference

UnrealHandleFlagsConfig Class
Assimp.Configs Namespace


UnrealHandleFlagsConfig Properties

The UnrealHandleFlagsConfig type exposes the following members.

Properties
 | Name | Description
Public property | DefaultValue | Gets the default property value. (Inherited from BooleanPropertyConfig.)
Public property | Name | Gets the property name. (Inherited from PropertyConfig.)
 | UnrealHandleFlagsConfigName | Gets the string name used by UnrealHandleFlagsConfig.
Public property | Value | Gets the property value. (Inherited from BooleanPropertyConfig.)
Top
See Also

Reference

UnrealHandleFlagsConfig Class
Assimp.Configs Namespace


UnrealHandleFlagsConfig.UnrealHandleFlagsConfigName Property

UnrealHandleFlagsConfigUnrealHandleFlagsConfigName Property

Gets the string name used by UnrealHandleFlagsConfig.

Namespace: Assimp.Configs
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public static string UnrealHandleFlagsConfigName { get; }

Property Value

Type: String
See Also

Reference

UnrealHandleFlagsConfig Class
Assimp.Configs Namespace


UnrealHandleFlagsConfig Methods

The UnrealHandleFlagsConfig type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | SetDefaultValue | Sets the current value to the default value. (Inherited from BooleanPropertyConfig.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

UnrealHandleFlagsConfig Class
Assimp.Configs Namespace


UnrealKeyFrameImportConfig Class

Sets the vertex animation keyframe to be imported. Assimp does not support vertex keyframes (only bone animation is supported). the library reads only one keyframe with vertex animations. By default this is the first frame. This config sets the global override for the Unreal format.
Inheritance Hierarchy
SystemObject
Assimp.ConfigsPropertyConfig
Assimp.ConfigsIntegerPropertyConfig
Assimp.ConfigsUnrealKeyFrameImportConfig

Namespace: Assimp.Configs
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public sealed class UnrealKeyFrameImportConfig : IntegerPropertyConfig

The UnrealKeyFrameImportConfig type exposes the following members.

Constructors
 | Name | Description
Public method | UnrealKeyFrameImportConfig | Constructs a new UnrealKeyFrameImportConfig.
Top
Properties
 | Name | Description
Public property | DefaultValue | Gets the default property value. (Inherited from IntegerPropertyConfig.)
Public property | Name | Gets the property name. (Inherited from PropertyConfig.)
 | UnrealKeyFrameImportConfigName | Gets the string name used by UnrealKeyFrameImportConfig.
Public property | Value | Gets the property value. (Inherited from IntegerPropertyConfig.)
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | SetDefaultValue | Sets the current value to the default value. (Inherited from IntegerPropertyConfig.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Assimp.Configs Namespace


UnrealKeyFrameImportConfig Constructor

Constructs a new UnrealKeyFrameImportConfig.

Namespace: Assimp.Configs
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public UnrealKeyFrameImportConfig(
    int keyFrame
)

Parameters

keyFrame
Type: SystemInt32
Keyframe index
See Also

Reference

UnrealKeyFrameImportConfig Class
Assimp.Configs Namespace


UnrealKeyFrameImportConfig Properties

The UnrealKeyFrameImportConfig type exposes the following members.

Properties
 | Name | Description
Public property | DefaultValue | Gets the default property value. (Inherited from IntegerPropertyConfig.)
Public property | Name | Gets the property name. (Inherited from PropertyConfig.)
 | UnrealKeyFrameImportConfigName | Gets the string name used by UnrealKeyFrameImportConfig.
Public property | Value | Gets the property value. (Inherited from IntegerPropertyConfig.)
Top
See Also

Reference

UnrealKeyFrameImportConfig Class
Assimp.Configs Namespace


UnrealKeyFrameImportConfig.UnrealKeyFrameImportConfigName Property

UnrealKeyFrameImportConfigUnrealKeyFrameImportConfigName Property

Gets the string name used by UnrealKeyFrameImportConfig.

Namespace: Assimp.Configs
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public static string UnrealKeyFrameImportConfigName { get; }

Property Value

Type: String
See Also

Reference

UnrealKeyFrameImportConfig Class
Assimp.Configs Namespace


UnrealKeyFrameImportConfig Methods

The UnrealKeyFrameImportConfig type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | SetDefaultValue | Sets the current value to the default value. (Inherited from IntegerPropertyConfig.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

UnrealKeyFrameImportConfig Class
Assimp.Configs Namespace


VertexBoneWeightLimitConfig Class

Configuration for the LimitBoneWeights step that specifies the maximum number of bone weights per vertex. The default value is VertexBoneWeightLimitConfigDefaultValue.
Inheritance Hierarchy
SystemObject
Assimp.ConfigsPropertyConfig
Assimp.ConfigsIntegerPropertyConfig
Assimp.ConfigsVertexBoneWeightLimitConfig

Namespace: Assimp.Configs
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public sealed class VertexBoneWeightLimitConfig : IntegerPropertyConfig

The VertexBoneWeightLimitConfig type exposes the following members.

Constructors
 | Name | Description
Public method | VertexBoneWeightLimitConfig | Constructs a new VertexBoneWeightLimitConfig.
Top
Properties
 | Name | Description
Public property | DefaultValue | Gets the default property value. (Inherited from IntegerPropertyConfig.)
Public property | Name | Gets the property name. (Inherited from PropertyConfig.)
Public property | Value | Gets the property value. (Inherited from IntegerPropertyConfig.)
 | VertexBoneWeightLimitConfigDefaultValue | Gets the defined default limit value, this corresponds to the AI_LBW_MAX_WEIGHTS constant.
 | VertexBoneWeightLimitConfigName | gets the string name used by VertexBoneWeightLimitConfig.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | SetDefaultValue | Sets the current value to the default value. (Inherited from IntegerPropertyConfig.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Assimp.Configs Namespace


VertexBoneWeightLimitConfig Constructor

Constructs a new VertexBoneWeightLimitConfig.

Namespace: Assimp.Configs
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public VertexBoneWeightLimitConfig(
    int maxBoneWeights
)

Parameters

maxBoneWeights
Type: SystemInt32
Max number of bone weights per vertex.
See Also

Reference

VertexBoneWeightLimitConfig Class
Assimp.Configs Namespace


VertexBoneWeightLimitConfig Properties

The VertexBoneWeightLimitConfig type exposes the following members.

Properties
 | Name | Description
Public property | DefaultValue | Gets the default property value. (Inherited from IntegerPropertyConfig.)
Public property | Name | Gets the property name. (Inherited from PropertyConfig.)
Public property | Value | Gets the property value. (Inherited from IntegerPropertyConfig.)
 | VertexBoneWeightLimitConfigDefaultValue | Gets the defined default limit value, this corresponds to the AI_LBW_MAX_WEIGHTS constant.
 | VertexBoneWeightLimitConfigName | gets the string name used by VertexBoneWeightLimitConfig.
Top
See Also

Reference

VertexBoneWeightLimitConfig Class
Assimp.Configs Namespace


VertexBoneWeightLimitConfig.VertexBoneWeightLimitConfigDefaultValue Property

VertexBoneWeightLimitConfigVertexBoneWeightLimitConfigDefaultValue Property

Gets the defined default limit value, this corresponds to the AI_LBW_MAX_WEIGHTS constant.

Namespace: Assimp.Configs
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public static int VertexBoneWeightLimitConfigDefaultValue { get; }

Property Value

Type: Int32
See Also

Reference

VertexBoneWeightLimitConfig Class
Assimp.Configs Namespace


VertexBoneWeightLimitConfig.VertexBoneWeightLimitConfigName Property

VertexBoneWeightLimitConfigVertexBoneWeightLimitConfigName Property

gets the string name used by VertexBoneWeightLimitConfig.

Namespace: Assimp.Configs
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public static string VertexBoneWeightLimitConfigName { get; }

Property Value

Type: String
See Also

Reference

VertexBoneWeightLimitConfig Class
Assimp.Configs Namespace


VertexBoneWeightLimitConfig Methods

The VertexBoneWeightLimitConfig type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | SetDefaultValue | Sets the current value to the default value. (Inherited from IntegerPropertyConfig.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

VertexBoneWeightLimitConfig Class
Assimp.Configs Namespace


VertexCacheSizeConfig Class

Configuration for the ImproveCacheLocality step that specifies the size of the post-transform vertex cache. The size is given in number of vertices and the default value is VertexCacheSizeConfigDefaultValue.
Inheritance Hierarchy
SystemObject
Assimp.ConfigsPropertyConfig
Assimp.ConfigsIntegerPropertyConfig
Assimp.ConfigsVertexCacheSizeConfig

Namespace: Assimp.Configs
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public sealed class VertexCacheSizeConfig : IntegerPropertyConfig

The VertexCacheSizeConfig type exposes the following members.

Constructors
 | Name | Description
Public method | VertexCacheSizeConfig | Constructs a new VertexCacheSizeConfig.
Top
Properties
 | Name | Description
Public property | DefaultValue | Gets the default property value. (Inherited from IntegerPropertyConfig.)
Public property | Name | Gets the property name. (Inherited from PropertyConfig.)
Public property | Value | Gets the property value. (Inherited from IntegerPropertyConfig.)
 | VertexCacheSizeConfigDefaultValue | Gets the defined default vertex cache size, this corresponds to the PP_ICL_PTCACHE_SIZE.
 | VertexCacheSizeConfigName | Gets the string name used by VertexCacheConfig.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | SetDefaultValue | Sets the current value to the default value. (Inherited from IntegerPropertyConfig.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Assimp.Configs Namespace


VertexCacheSizeConfig Constructor

Constructs a new VertexCacheSizeConfig.

Namespace: Assimp.Configs
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public VertexCacheSizeConfig(
    int vertexCacheSize
)

Parameters

vertexCacheSize
Type: SystemInt32
Size of the post-transform vertex cache, in number of vertices.
See Also

Reference

VertexCacheSizeConfig Class
Assimp.Configs Namespace


VertexCacheSizeConfig Properties

The VertexCacheSizeConfig type exposes the following members.

Properties
 | Name | Description
Public property | DefaultValue | Gets the default property value. (Inherited from IntegerPropertyConfig.)
Public property | Name | Gets the property name. (Inherited from PropertyConfig.)
Public property | Value | Gets the property value. (Inherited from IntegerPropertyConfig.)
 | VertexCacheSizeConfigDefaultValue | Gets the defined default vertex cache size, this corresponds to the PP_ICL_PTCACHE_SIZE.
 | VertexCacheSizeConfigName | Gets the string name used by VertexCacheConfig.
Top
See Also

Reference

VertexCacheSizeConfig Class
Assimp.Configs Namespace


VertexCacheSizeConfig.VertexCacheSizeConfigDefaultValue Property

VertexCacheSizeConfigVertexCacheSizeConfigDefaultValue Property

Gets the defined default vertex cache size, this corresponds to the PP_ICL_PTCACHE_SIZE.

Namespace: Assimp.Configs
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public static int VertexCacheSizeConfigDefaultValue { get; }

Property Value

Type: Int32
See Also

Reference

VertexCacheSizeConfig Class
Assimp.Configs Namespace


VertexCacheSizeConfig.VertexCacheSizeConfigName Property

VertexCacheSizeConfigVertexCacheSizeConfigName Property

Gets the string name used by VertexCacheConfig.

Namespace: Assimp.Configs
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public static string VertexCacheSizeConfigName { get; }

Property Value

Type: String
See Also

Reference

VertexCacheSizeConfig Class
Assimp.Configs Namespace


VertexCacheSizeConfig Methods

The VertexCacheSizeConfig type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | SetDefaultValue | Sets the current value to the default value. (Inherited from IntegerPropertyConfig.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

VertexCacheSizeConfig Class
Assimp.Configs Namespace


XFileUseDoublesConfig Class

Specifies if the X-file exporter should use 64-bit doubles rather than 32-bit floats.
Inheritance Hierarchy
SystemObject
Assimp.ConfigsPropertyConfig
Assimp.ConfigsBooleanPropertyConfig
Assimp.ConfigsXFileUseDoublesConfig

Namespace: Assimp.Configs
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public sealed class XFileUseDoublesConfig : BooleanPropertyConfig

The XFileUseDoublesConfig type exposes the following members.

Constructors
 | Name | Description
Public method | XFileUseDoublesConfig | Constructs a new XFileUseDoublesConfig.
Top
Properties
 | Name | Description
Public property | DefaultValue | Gets the default property value. (Inherited from BooleanPropertyConfig.)
Public property | Name | Gets the property name. (Inherited from PropertyConfig.)
Public property | Value | Gets the property value. (Inherited from BooleanPropertyConfig.)
 | XFileUseDoublesConfigName | Gets the string name used by XFileUseDoublesConfig.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | SetDefaultValue | Sets the current value to the default value. (Inherited from BooleanPropertyConfig.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Assimp.Configs Namespace


XFileUseDoublesConfig Constructor

Constructs a new XFileUseDoublesConfig.

Namespace: Assimp.Configs
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public XFileUseDoublesConfig(
    bool useDoubles
)

Parameters

useDoubles
Type: SystemBoolean
True if the x file uses 64-bit double values rather than 32-bit float values.
See Also

Reference

XFileUseDoublesConfig Class
Assimp.Configs Namespace


XFileUseDoublesConfig Properties

The XFileUseDoublesConfig type exposes the following members.

Properties
 | Name | Description
Public property | DefaultValue | Gets the default property value. (Inherited from BooleanPropertyConfig.)
Public property | Name | Gets the property name. (Inherited from PropertyConfig.)
Public property | Value | Gets the property value. (Inherited from BooleanPropertyConfig.)
 | XFileUseDoublesConfigName | Gets the string name used by XFileUseDoublesConfig.
Top
See Also

Reference

XFileUseDoublesConfig Class
Assimp.Configs Namespace


XFileUseDoublesConfig.XFileUseDoublesConfigName Property

XFileUseDoublesConfigXFileUseDoublesConfigName Property

Gets the string name used by XFileUseDoublesConfig.

Namespace: Assimp.Configs
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public static string XFileUseDoublesConfigName { get; }

Property Value

Type: String
See Also

Reference

XFileUseDoublesConfig Class
Assimp.Configs Namespace


XFileUseDoublesConfig Methods

The XFileUseDoublesConfig type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | SetDefaultValue | Sets the current value to the default value. (Inherited from BooleanPropertyConfig.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

XFileUseDoublesConfig Class
Assimp.Configs Namespace


Assimp.Unmanaged Namespace

Contains the low-level P/Invoke functions and unmanaged structures.
Classes
 | Class | Description
Public class | AiConfigs | Defines configurable properties for importing models. All properties have default values. Setting config properties are done via the SetProperty* methods in AssimpMethods.
Public class | AiDefines | Static class that has a number of constants that are found in Assimp. These can be limits to configuration property default values. The constants are grouped according to their usage or where they're found in the Assimp include files.
Public class | AiMatKeys | Static class containing material key constants. A fully qualified mat key name here means that it's a string that combines the mat key (base) name, its texture type semantic, and its texture index into a single string delimited by commas. For non-texture material properties, the texture type semantic and texture index are always zero.
Public class | AssimpLibrary | Singleton that governs access to the unmanaged Assimp library functions.
Public class | UnmanagedFunctionNameAttribute | An attribute that represents the name of an unmanaged function to import.
Public class | UnmanagedLibrary | Represents management and access to an unmanaged library. An unmanaged library can be loaded and unloaded dynamically. The library then searches for a list of exported functions to create managed delegates for, allowing callers to access the library. Each OS platform has its own implementation to determine how to load unmanaged libraries.
Public class | UnmanagedLibraryResolver | Resolves unmanaged DLLs for UnmanagedLibrary. The process is completely configurable, where the user can supply alternative library names (e.g. versioned libs), an override library name, and probing paths. These can be set for both 32/64 bit, or seperately for 32 or 64 bit. See ResolveLibraryPath(String) for the search strategy.
Structures
 | Structure | Description
Public structure | AiAnimation | Represents an aiAnimation struct.
Public structure | AiAnimMesh | Represents an aiAnimMesh struct. Note: This structure requires marshaling, due to the array of IntPtrs.
Public structure | AiBone | Represents an aiBone struct.
Public structure | AiCamera | Represents an aiCamera struct.
Public structure | AiExportDataBlob | Describes a blob of exported scene data. Blobs can be nested, the first blob always has an empty name. Nested blobs represent auxillary files produced by the exporter (e.g. material files) and are named accordingly.
Public structure | AiExportFormatDesc | Describes a file format which Assimp can export to.
Public structure | AiFace | Represents an aiFace struct.
Public structure | AiFile | Contains callbacks to read and write to a file opened by a custom file system.
Public structure | AiFileIO | Contains callbacks to implement a custom file system to open and close files.
Public structure | AiImporterDesc | Describes a variety of information about an importer.
Public structure | AiLight | Represents an aiLight struct.
Public structure | AiLogStream | Represents a log stream, which receives all log messages and streams them somewhere.
Public structure | AiMaterial | Represents an aiMaterial struct.
Public structure | AiMaterialProperty | Represents an aiMaterialProperty struct.
Public structure | AiMemoryInfo | Represents the memory requirements for the different components of an imported scene. All sizes in in bytes.
Public structure | AiMesh | Represents an aiMesh struct. Note: This structure requires marshaling, due to the arrays of IntPtrs.
Public structure | AiMeshAnim | Represents an aiMeshAnim struct.
Public structure | AiMeshColorArray | Fixed length array for representing the color channels of a mesh. Length is equal to AI_MAX_NUMBER_OF_COLOR_SETS.
Public structure | AiMeshMorphAnim | Represents an aiMeshMorphAnim struct.
Public structure | AiMeshMorphKey | Represents an aiMeshMorphKey struct.
Public structure | AiMeshTextureCoordinateArray | Fixed length array for representing the texture coordinate channels of a mesh. Length is equal to AI_MAX_NUMBER_OF_TEXTURECOORDS.
Public structure | AiMeshUVComponentArray | Fixed length array for representing the number of UV components for each texture coordinate channel of a mesh. Length is equal to AI_MAX_NUMBER_OF_TEXTURECOORDS.
Public structure | AiMetadata | Represents an aiMetadata struct.
Public structure | AiMetadataEntry | Represents an aiMetadataEntry struct.
Public structure | AiNode | Represents an aiNode struct.
Public structure | AiNodeAnim | Represents an aiNodeAnim struct.
Public structure | AiScene | Represents an aiScene struct.
Public structure | AiString | Represents an aiString struct.
Public structure | AiTexture | Represents an aiTexture struct.
Delegates
 | Delegate | Description
Public delegate | AiFileCloseProc | Callback delegate for a custom file system, to close a given file and free its memory.
Public delegate | AiFileFlushProc | Callback delegate for a custom file system, to flush the contents of the file to the disk.
Public delegate | AiFileOpenProc | Callback delegate for a custom file system, to open a given file and create a new AiFile instance.
Public delegate | AiFileReadProc | Callback delegate for a custom file system, to read from a file.
Public delegate | AiFileSeek | Callback delegate for a custom file system, to set the current position of the file cursor.
Public delegate | AiFileTellProc | Callback delegate for a custom file system, to tell offset/size information about the file.
Public delegate | AiFileWriteProc | Callback delegate for a custom file system, to write to a file.
Public delegate | AiLogStreamCallback | Callback delegate for Assimp's LogStream.
Enumerations
 | Enumeration | Description
Public enumeration | Platform | Enumerates supported platforms.


AiAnimation Structure

Represents an aiAnimation struct.

Namespace: Assimp.Unmanaged
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public struct AiAnimation

The AiAnimation type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Indicates whether this instance and a specified object are equal. (Inherited from ValueType.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from ValueType.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns the fully qualified type name of this instance. (Inherited from ValueType.)
Top
Fields
 | Name | Description
Public field | Channels | aiNodeAnim**, node animation channels. Each channel affects a single node.
Public field | Duration | Duration of the animation in ticks.
Public field | MeshChannels | aiMeshAnim**, mesh animation channels. Each channel affects a single mesh.
Public field | MeshMorphChannels | aiMeshMorphAnim**, mesh morph animation channels. Each channel affects a single mesh.
Public field | Name | Name of the animation.
Public field | NumChannels | Number of bone animation channels, each channel affects a single node.
Public field | NumMeshChannels | Number of mesh animation channels. Each channel affects a single mesh and defines vertex-based animation.
Public field | NumMeshMorphChannels | Number of mesh morph animation channels. Each channel affects a single mesh and defines morphing animation.
Public field | TicksPerSecond | Ticks per second, 0 if not specified in imported file.
Top
See Also

Reference

Assimp.Unmanaged Namespace


AiAnimation Methods

The AiAnimation type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Indicates whether this instance and a specified object are equal. (Inherited from ValueType.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from ValueType.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns the fully qualified type name of this instance. (Inherited from ValueType.)
Top
See Also

Reference

AiAnimation Structure
Assimp.Unmanaged Namespace


AiAnimation Fields

The AiAnimation type exposes the following members.

Fields
 | Name | Description
Public field | Channels | aiNodeAnim**, node animation channels. Each channel affects a single node.
Public field | Duration | Duration of the animation in ticks.
Public field | MeshChannels | aiMeshAnim**, mesh animation channels. Each channel affects a single mesh.
Public field | MeshMorphChannels | aiMeshMorphAnim**, mesh morph animation channels. Each channel affects a single mesh.
Public field | Name | Name of the animation.
Public field | NumChannels | Number of bone animation channels, each channel affects a single node.
Public field | NumMeshChannels | Number of mesh animation channels. Each channel affects a single mesh and defines vertex-based animation.
Public field | NumMeshMorphChannels | Number of mesh morph animation channels. Each channel affects a single mesh and defines morphing animation.
Public field | TicksPerSecond | Ticks per second, 0 if not specified in imported file.
Top
See Also

Reference

AiAnimation Structure
Assimp.Unmanaged Namespace


AiAnimation.Channels Field

AiAnimationChannels Field

aiNodeAnim**, node animation channels. Each channel affects a single node.

Namespace: Assimp.Unmanaged
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public IntPtr Channels

Field Value

Type: IntPtr
See Also

Reference

AiAnimation Structure
Assimp.Unmanaged Namespace


AiAnimation.Duration Field

AiAnimationDuration Field

Duration of the animation in ticks.

Namespace: Assimp.Unmanaged
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public double Duration

Field Value

Type: Double
See Also

Reference

AiAnimation Structure
Assimp.Unmanaged Namespace


AiAnimation.MeshChannels Field

AiAnimationMeshChannels Field

aiMeshAnim**, mesh animation channels. Each channel affects a single mesh.

Namespace: Assimp.Unmanaged
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public IntPtr MeshChannels

Field Value

Type: IntPtr
See Also

Reference

AiAnimation Structure
Assimp.Unmanaged Namespace


AiAnimation.MeshMorphChannels Field

AiAnimationMeshMorphChannels Field

aiMeshMorphAnim**, mesh morph animation channels. Each channel affects a single mesh.

Namespace: Assimp.Unmanaged
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public IntPtr MeshMorphChannels

Field Value

Type: IntPtr
See Also

Reference

AiAnimation Structure
Assimp.Unmanaged Namespace


AiAnimation.Name Field

AiAnimationName Field

Name of the animation.

Namespace: Assimp.Unmanaged
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public AiString Name

Field Value

Type: AiString
See Also

Reference

AiAnimation Structure
Assimp.Unmanaged Namespace


AiAnimation.NumChannels Field

AiAnimationNumChannels Field

Number of bone animation channels, each channel affects a single node.

Namespace: Assimp.Unmanaged
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public uint NumChannels

Field Value

Type: UInt32
See Also

Reference

AiAnimation Structure
Assimp.Unmanaged Namespace


AiAnimation.NumMeshChannels Field

AiAnimationNumMeshChannels Field

Number of mesh animation channels. Each channel affects a single mesh and defines vertex-based animation.

Namespace: Assimp.Unmanaged
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public uint NumMeshChannels

Field Value

Type: UInt32
See Also

Reference

AiAnimation Structure
Assimp.Unmanaged Namespace


AiAnimation.NumMeshMorphChannels Field

AiAnimationNumMeshMorphChannels Field

Number of mesh morph animation channels. Each channel affects a single mesh and defines morphing animation.

Namespace: Assimp.Unmanaged
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public uint NumMeshMorphChannels

Field Value

Type: UInt32
See Also

Reference

AiAnimation Structure
Assimp.Unmanaged Namespace


AiAnimation.TicksPerSecond Field

AiAnimationTicksPerSecond Field

Ticks per second, 0 if not specified in imported file.

Namespace: Assimp.Unmanaged
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public double TicksPerSecond

Field Value

Type: Double
See Also

Reference

AiAnimation Structure
Assimp.Unmanaged Namespace


AiAnimMesh Structure

Represents an aiAnimMesh struct. Note: This structure requires marshaling, due to the array of IntPtrs.

Namespace: Assimp.Unmanaged
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public struct AiAnimMesh

The AiAnimMesh type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Indicates whether this instance and a specified object are equal. (Inherited from ValueType.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from ValueType.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns the fully qualified type name of this instance. (Inherited from ValueType.)
Top
Fields
 | Name | Description
Public field | BiTangents | aiVector3D*, replacement bitangent array.
Public field | Colors | aiColor4D*[Max_Value], array of arrays of vertex colors. Max_Value is defined as AI_MAX_NUMBER_OF_COLOR_SETS.
Public field | Normals | aiVector3D*, replacement normal array.
Public field | NumVertices | unsigned int, number of vertices.
Public field | Tangents | aiVector3D*, replacement tangent array.
Public field | TextureCoords | aiVector3D*[Max_Value], array of arrays of texture coordinates. Max_Value is defined as AI_MAX_NUMBER_OF_TEXTURECOORDS.
Public field | Vertices | aiVector3D*, replacement position array.
Public field | Weight | float, weight of the AnimMesh.
Top
See Also

Reference

Assimp.Unmanaged Namespace


AiAnimMesh Methods

The AiAnimMesh type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Indicates whether this instance and a specified object are equal. (Inherited from ValueType.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from ValueType.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns the fully qualified type name of this instance. (Inherited from ValueType.)
Top
See Also

Reference

AiAnimMesh Structure
Assimp.Unmanaged Namespace


AiAnimMesh Fields

The AiAnimMesh type exposes the following members.

Fields
 | Name | Description
Public field | BiTangents | aiVector3D*, replacement bitangent array.
Public field | Colors | aiColor4D*[Max_Value], array of arrays of vertex colors. Max_Value is defined as AI_MAX_NUMBER_OF_COLOR_SETS.
Public field | Normals | aiVector3D*, replacement normal array.
Public field | NumVertices | unsigned int, number of vertices.
Public field | Tangents | aiVector3D*, replacement tangent array.
Public field | TextureCoords | aiVector3D*[Max_Value], array of arrays of texture coordinates. Max_Value is defined as AI_MAX_NUMBER_OF_TEXTURECOORDS.
Public field | Vertices | aiVector3D*, replacement position array.
Public field | Weight | float, weight of the AnimMesh.
Top
See Also

Reference

AiAnimMesh Structure
Assimp.Unmanaged Namespace


AiAnimMesh.BiTangents Field

AiAnimMeshBiTangents Field

aiVector3D*, replacement bitangent array.

Namespace: Assimp.Unmanaged
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public IntPtr BiTangents

Field Value

Type: IntPtr
See Also

Reference

AiAnimMesh Structure
Assimp.Unmanaged Namespace


AiAnimMesh.Colors Field

AiAnimMeshColors Field

aiColor4D*[Max_Value], array of arrays of vertex colors. Max_Value is defined as AI_MAX_NUMBER_OF_COLOR_SETS.

Namespace: Assimp.Unmanaged
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public AiMeshColorArray Colors

Field Value

Type: AiMeshColorArray
See Also

Reference

AiAnimMesh Structure
Assimp.Unmanaged Namespace


AiAnimMesh.Normals Field

AiAnimMeshNormals Field

aiVector3D*, replacement normal array.

Namespace: Assimp.Unmanaged
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public IntPtr Normals

Field Value

Type: IntPtr
See Also

Reference

AiAnimMesh Structure
Assimp.Unmanaged Namespace


AiAnimMesh.NumVertices Field

AiAnimMeshNumVertices Field

unsigned int, number of vertices.

Namespace: Assimp.Unmanaged
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public uint NumVertices

Field Value

Type: UInt32
See Also

Reference

AiAnimMesh Structure
Assimp.Unmanaged Namespace


AiAnimMesh.Tangents Field

AiAnimMeshTangents Field

aiVector3D*, replacement tangent array.

Namespace: Assimp.Unmanaged
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public IntPtr Tangents

Field Value

Type: IntPtr
See Also

Reference

AiAnimMesh Structure
Assimp.Unmanaged Namespace


AiAnimMesh.TextureCoords Field

AiAnimMeshTextureCoords Field

aiVector3D*[Max_Value], array of arrays of texture coordinates. Max_Value is defined as AI_MAX_NUMBER_OF_TEXTURECOORDS.

Namespace: Assimp.Unmanaged
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public AiMeshTextureCoordinateArray TextureCoords

Field Value

Type: AiMeshTextureCoordinateArray
See Also

Reference

AiAnimMesh Structure
Assimp.Unmanaged Namespace


AiAnimMesh.Vertices Field

AiAnimMeshVertices Field

aiVector3D*, replacement position array.

Namespace: Assimp.Unmanaged
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public IntPtr Vertices

Field Value

Type: IntPtr
See Also

Reference

AiAnimMesh Structure
Assimp.Unmanaged Namespace


AiAnimMesh.Weight Field

AiAnimMeshWeight Field

float, weight of the AnimMesh.

Namespace: Assimp.Unmanaged
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public float Weight

Field Value

Type: Single
See Also

Reference

AiAnimMesh Structure
Assimp.Unmanaged Namespace


AiBone Structure

Represents an aiBone struct.

Namespace: Assimp.Unmanaged
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public struct AiBone

The AiBone type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Indicates whether this instance and a specified object are equal. (Inherited from ValueType.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from ValueType.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns the fully qualified type name of this instance. (Inherited from ValueType.)
Top
Fields
 | Name | Description
Public field | Name | Name of the bone.
Public field | NumWeights | Number of weights.
Public field | OffsetMatrix | Matrix that transforms the vertex from mesh to bone space in bind pose
Public field | Weights | VertexWeight*, array of vertex weights.
Top
See Also

Reference

Assimp.Unmanaged Namespace


AiBone Methods

The AiBone type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Indicates whether this instance and a specified object are equal. (Inherited from ValueType.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from ValueType.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns the fully qualified type name of this instance. (Inherited from ValueType.)
Top
See Also

Reference

AiBone Structure
Assimp.Unmanaged Namespace


AiBone Fields

The AiBone type exposes the following members.

Fields
 | Name | Description
Public field | Name | Name of the bone.
Public field | NumWeights | Number of weights.
Public field | OffsetMatrix | Matrix that transforms the vertex from mesh to bone space in bind pose
Public field | Weights | VertexWeight*, array of vertex weights.
Top
See Also

Reference

AiBone Structure
Assimp.Unmanaged Namespace


AiBone.Name Field

AiBoneName Field

Name of the bone.

Namespace: Assimp.Unmanaged
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public AiString Name

Field Value

Type: AiString
See Also

Reference

AiBone Structure
Assimp.Unmanaged Namespace


AiBone.NumWeights Field

AiBoneNumWeights Field

Number of weights.

Namespace: Assimp.Unmanaged
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public uint NumWeights

Field Value

Type: UInt32
See Also

Reference

AiBone Structure
Assimp.Unmanaged Namespace


AiBone.OffsetMatrix Field

AiBoneOffsetMatrix Field

Matrix that transforms the vertex from mesh to bone space in bind pose

Namespace: Assimp.Unmanaged
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public Matrix4x4 OffsetMatrix

Field Value

Type: Matrix4x4
See Also

Reference

AiBone Structure
Assimp.Unmanaged Namespace


AiBone.Weights Field

AiBoneWeights Field

VertexWeight*, array of vertex weights.

Namespace: Assimp.Unmanaged
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public IntPtr Weights

Field Value

Type: IntPtr
See Also

Reference

AiBone Structure
Assimp.Unmanaged Namespace


AiCamera Structure

Represents an aiCamera struct.

Namespace: Assimp.Unmanaged
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public struct AiCamera

The AiCamera type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Indicates whether this instance and a specified object are equal. (Inherited from ValueType.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from ValueType.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns the fully qualified type name of this instance. (Inherited from ValueType.)
Top
Fields
 | Name | Description
Public field | Aspect | The Aspect ratio.
Public field | ClipPlaneFar | Far clip plane distance.
Public field | ClipPlaneNear | Near clip plane distance.
Public field | HorizontalFOV | Field Of View of the camera.
Public field | LookAt | Viewing direction of the camera.
Public field | Name | Name of the camera.
Public field | Position | Position of the camera.
Public field | Up | Up vector of the camera.
Top
See Also

Reference

Assimp.Unmanaged Namespace


AiCamera Methods

The AiCamera type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Indicates whether this instance and a specified object are equal. (Inherited from ValueType.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from ValueType.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns the fully qualified type name of this instance. (Inherited from ValueType.)
Top
See Also

Reference

AiCamera Structure
Assimp.Unmanaged Namespace


AiCamera Fields

The AiCamera type exposes the following members.

Fields
 | Name | Description
Public field | Aspect | The Aspect ratio.
Public field | ClipPlaneFar | Far clip plane distance.
Public field | ClipPlaneNear | Near clip plane distance.
Public field | HorizontalFOV | Field Of View of the camera.
Public field | LookAt | Viewing direction of the camera.
Public field | Name | Name of the camera.
Public field | Position | Position of the camera.
Public field | Up | Up vector of the camera.
Top
See Also

Reference

AiCamera Structure
Assimp.Unmanaged Namespace


AiCamera.Aspect Field

AiCameraAspect Field

The Aspect ratio.

Namespace: Assimp.Unmanaged
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public float Aspect

Field Value

Type: Single
See Also

Reference

AiCamera Structure
Assimp.Unmanaged Namespace


AiCamera.ClipPlaneFar Field

AiCameraClipPlaneFar Field

Far clip plane distance.

Namespace: Assimp.Unmanaged
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public float ClipPlaneFar

Field Value

Type: Single
See Also

Reference

AiCamera Structure
Assimp.Unmanaged Namespace


AiCamera.ClipPlaneNear Field

AiCameraClipPlaneNear Field

Near clip plane distance.

Namespace: Assimp.Unmanaged
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public float ClipPlaneNear

Field Value

Type: Single
See Also

Reference

AiCamera Structure
Assimp.Unmanaged Namespace


AiCamera.HorizontalFOV Field

AiCameraHorizontalFOV Field

Field Of View of the camera.

Namespace: Assimp.Unmanaged
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public float HorizontalFOV

Field Value

Type: Single
See Also

Reference

AiCamera Structure
Assimp.Unmanaged Namespace


AiCamera.LookAt Field

AiCameraLookAt Field

Viewing direction of the camera.

Namespace: Assimp.Unmanaged
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public Vector3D LookAt

Field Value

Type: Vector3D
See Also

Reference

AiCamera Structure
Assimp.Unmanaged Namespace


AiCamera.Name Field

AiCameraName Field

Name of the camera.

Namespace: Assimp.Unmanaged
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public AiString Name

Field Value

Type: AiString
See Also

Reference

AiCamera Structure
Assimp.Unmanaged Namespace


AiCamera.Position Field

AiCameraPosition Field

Position of the camera.

Namespace: Assimp.Unmanaged
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public Vector3D Position

Field Value

Type: Vector3D
See Also

Reference

AiCamera Structure
Assimp.Unmanaged Namespace


AiCamera.Up Field

AiCameraUp Field

Up vector of the camera.

Namespace: Assimp.Unmanaged
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public Vector3D Up

Field Value

Type: Vector3D
See Also

Reference

AiCamera Structure
Assimp.Unmanaged Namespace


AiConfigs Class

Defines configurable properties for importing models. All properties have default values. Setting config properties are done via the SetProperty* methods in AssimpMethods.
Inheritance Hierarchy
SystemObject
Assimp.UnmanagedAiConfigs

Namespace: Assimp.Unmanaged
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public static class AiConfigs

The AiConfigs type exposes the following members.

Fields
Name Description
AI_CONFIG_EXPORT_XFILE_64BIT
Specifies if the X-file exporter should use 64-bit doubles rather than 32-bit floats.

Type: Bool. Default: false.

AI_CONFIG_FAVOUR_SPEED
A hint to Assimp to favour speed against import quality. Enabling this option may result in faster loading, or it may not. It is just a hint to loaders and post-processing steps to use faster code paths if possible. A value not equal to zero stands for true.

Type: integer. Default: 0

AI_CONFIG_GLOB_MEASURE_TIME
Enables time measurements. If enabled the time needed for each part of the loading process is timed and logged.

Type: bool. Default: false

AI_CONFIG_GLOB_MULTITHREADING
Sets Assimp's multithreading policy. This is ignored if Assimp is built without boost.thread support. Possible values are: -1 to let Assimp decide, 0 to disable multithreading, and nay number larger than 0 to force a specific number of threads. This is only a hint and may be ignored by Assimp.

Type: integer. Default: -1

AI_CONFIG_GLOBAL_SCALE_FACTOR_KEY
Configures the GlobalScale step to scale the entire scene by a certain amount. Some importers provide a mechanism to define a scaling unit for the model, which this processing step can utilize.

Type: Float. Default: 1.0f.

AI_CONFIG_IMPORT_AC_EVAL_SUBDIVISION
Configures whether the AC loader evaluates subdivision surfaces (indicated by the presence of the 'subdiv' attribute in the file). By default, Assimp performs the subdivision using the standard Catmull-Clark algorithm.

Type: bool. Default: true

AI_CONFIG_IMPORT_AC_SEPARATE_BFCULL
Configures the AC loader to collect all surfaces which have the "Backface cull" flag set in separate meshes.

Type: bool. Default: true

AI_CONFIG_IMPORT_ASE_RECONSTRUCT_NORMALS
Configures the ASE loader to always reconstruct normal vectors basing on the smoothing groups loaded from the file. Some ASE files carry invalid normals, others don't.

Type: bool. Default: true

AI_CONFIG_IMPORT_COLLADA_IGNORE_UP_DIRECTION
Specifies whether the collada loader will ignore the up direction.

Type: Bool. Default: false

AI_CONFIG_IMPORT_FBX_OPTIMIZE_EMPTY_ANIMATION_CURVES
Specifies whether the importer will drop empty animation curves or animation curves which match the bind pose transformation over their entire defined range.

Type: Bool. Default: true.

AI_CONFIG_IMPORT_FBX_PRESERVE_PIVOTS
Specifies whether the FBX importer will preserve pivot points for transformations (as extra nodes). If set to false, pivots and offsets will be evaluated whenever possible.

Type: Bool. Default: true.

AI_CONFIG_IMPORT_FBX_READ_ALL_GEOMETRY_LAYERS
Specifies whether the FBX importer will merge all geometry layers present in the source file or take only the first.

Type: bool. Default: true.

AI_CONFIG_IMPORT_FBX_READ_ALL_MATERIALS
Specifies whether the FBX importer will read all materials present in the source file or take only the referenced materials, if the importer will read materials, otherwise this has no effect.

Type: Bool. Default: false.

AI_CONFIG_IMPORT_FBX_READ_ANIMATIONS
Specifies whether the FBX importer will read animations.

Type: Bool. default: true.

AI_CONFIG_IMPORT_FBX_READ_CAMERAS
Specifies whether the FBX importer will read cameras.

Type: Bool. Default: true.

AI_CONFIG_IMPORT_FBX_READ_LIGHTS
Specifies whether the FBX importer will read light sources.

Type: Bool. Default: true.

AI_CONFIG_IMPORT_FBX_READ_MATERIALS
Specifies whether the FBX importer will read materials.

Type: Bool. Default: true.

AI_CONFIG_IMPORT_FBX_READ_TEXTURES
Specifies whether the FBX importer will read embedded textures.

Type: Bool. Default: true.

AI_CONFIG_IMPORT_FBX_SEARCH_EMBEDDED_TEXTURES
Specifies whether the FBX importer will search for embedded loaded textures, where no embedded texture data is provided.

Type: Bool. Default: false.

AI_CONFIG_IMPORT_FBX_STRICT_MODE
Specifies whether the FBX importer will act in strict mode in which only the FBX 2013 format is supported and any other sub formats are rejected. FBX 2013 is the primary target for the importer, so this format is best supported and well-tested.

Type: Bool. Default: false.

AI_CONFIG_IMPORT_GLOBAL_KEYFRAME
Sets the vertex animation keyframe to be imported. Assimp does not support vertex keyframes (only bone animation is supported). The libary reads only one frame of models with vertex animations. By default this is the first frame.

The default value is 0. This option applies to all importers. However, it is also possible to override the global setting for a specific loader. You can use the AI_CONFIG_IMPORT_XXX_KEYFRAME options where XXX is a placeholder for the file format which you want to override the global setting.

Type: integer. Default: 0

AI_CONFIG_IMPORT_IFC_CUSTOM_TRIANGULATION
Specifies whether the IFC loader will use its own, custom triangulation algorithm to triangulate wall and floor meshes. If this is set to false, walls will be either triangulated by the post process triangulation or will be passed through as huge polygons with faked holes (e.g. holes that are connected with the outer boundary using a dummy edge). It is highly recommended to leave this property set to true as the default post process has some known issues with these kind of polygons.

Type: Bool. Default: true.

AI_CONFIG_IMPORT_IFC_CYLINDRICAL_TESSELLATION
Specifies the tessellation for IFC cylindrical shapes. E.g. the number of segments used to approximate a circle. Accepted range of values is between [3, 180].

Type: Integer. Default: 32

AI_CONFIG_IMPORT_IFC_SKIP_SPACE_REPRESENTATIONS
Specifies whether the IFC loader skips over IfcSpace elements. IfcSpace elements (and their geometric representations) are used to represent free space in a building story.

Type: Bool. Default: true.

AI_CONFIG_IMPORT_IFC_SMOOTHING_ANGLE
Specifies the tessellation conic angle for IFC smoothing curves. Accepted range of values is between [5, 120]

Type: Float. Default: 10.0f

AI_CONFIG_IMPORT_IRR_ANIM_FPS
Defines the output frame rate of the IRR loader.

IRR animations are difficult to convert for Assimp and there will always be a loss of quality. This setting defines how many keys per second are returned by the converter.

Type: integer. Default: 100

AI_CONFIG_IMPORT_LWO_ONE_LAYER_ONLY
Configures the LWO loader to load just one layer from the model.

LWO files consist of layers and in some cases it could be useful to load only one of them. This property can be either a string - which specifies the name of the layer - or an integer - the index of the layer. If the property is not set then the whole LWO model is loaded. Loading fails if the requested layer is not vailable. The layer index is zero-based and the layer name may not be empty

Type: bool. Default: false (All layers are loaded)

AI_CONFIG_IMPORT_LWS_ANIM_END
Defines the ending of the time range for which the LWS loader evaluates animations and computes AiNodeAnim's.

Assimp provides full conversion of Lightwave's envelope system, including pre and post conditions. The loader computes linearly subsampled animation channels with the frame rate given in the LWS file. This property defines the end time.

Animation channels are only generated if a node has at least one envelope with more than one key assigned. This property is given in frames where '0' is the first. By default, if this property is not set, the importer takes the animation end from the input LWS file.

Type: integer. Default: taken from file

AI_CONFIG_IMPORT_LWS_ANIM_START
Defines the beginning of the time range for which the LWS loader evaluates animations and computes AiNodeAnim's.

Assimp provides full conversion of Lightwave's envelope system, including pre and post conditions. The loader computes linearly subsampled animation channels with the frame rate given in the LWS file. This property defines the start time.

Animation channels are only generated if a node has at least one envelope with more than one key assigned. This property is given in frames where '0' is the first. By default, if this property is not set, the importer takes the animation start from the input LWS file ('FirstFrame' line)

Type: integer. Default: taken from file

AI_CONFIG_IMPORT_MD2_KEYFRAME
See the documentation for AI_CONFIG_IMPORT_GLOBAL_KEYFRAME.
AI_CONFIG_IMPORT_MD3_HANDLE_MULTIPART
Configures the M3D loader to detect and process multi-part Quake player models. These models usually consit of three files, lower.md3, upper.md3 and head.md3. If this propery is set to true, Assimp will try to load and combine all three files if one of them is loaded.

Type: bool. Default: true

AI_CONFIG_IMPORT_MD3_KEYFRAME
See the documentation for AI_CONFIG_IMPORT_GLOBAL_KEYFRAME.
AI_CONFIG_IMPORT_MD3_SHADER_SRC
Specifies the Quake 3 shader file to be used for a particular MD3 file. This can be a full path or relative to where all MD3 shaders reside.

Type: string. Default: ""

AI_CONFIG_IMPORT_MD3_SKIN_NAME
Tells the MD3 loader which skin files to load. When loading MD3 files, Assimp checks whether a file named "md3_file_name"_"skin_name".skin exists. These files are used by Quake III to be able to assign different skins (e.g. red and blue team) to models. 'default', 'red', 'blue' are typical skin names.

Type: string. Default: "default"

AI_CONFIG_IMPORT_MD5_NO_ANIM_AUTOLOAD
Configures the MD5 loader to not load the MD5ANIM file for a MD5MESH file automatically.

The default strategy is to look for a file with the same name but with the MD5ANIm extension in the same directory. If it is found it is loaded and combined with the MD5MESH file. This configuration option can be used to disable this behavior.

Type: bool. Default: false

AI_CONFIG_IMPORT_MDC_KEYFRAME
See the documentation for AI_CONFIG_IMPORT_GLOBAL_KEYFRAME.
AI_CONFIG_IMPORT_MDL_COLORMAP
Sets the colormap(= palette) to be used to decode embedded textures in MDL (Quake or 3DG5) files. This must be a valid path to a file. The file is 768 (256 * 3) bytes large and contains RGB triplets for each of the 256 palette entries. If the file is not found, a default palette (from Quake 1) is used.

Type: string. Default: "colormap.lmp"

AI_CONFIG_IMPORT_MDL_KEYFRAME
See the documentation for AI_CONFIG_IMPORT_GLOBAL_KEYFRAME.
AI_CONFIG_IMPORT_NO_SKELETON_MESHES
Global setting to disable generation of skeleton dummy meshes. These are generated as a visualization aid in cases which the input data contains no geometry, but only animation data. So the geometry are visualizing the bones.

Type: Bool. Default: false.

AI_CONFIG_IMPORT_OGRE_MATERIAL_FILE
The Ogre importer will try to load this MaterialFile. Ogre meshes reference with material names, this does not tell Assimp where the file is located. Assimp will try to find the source file in the following order: [material-name].material, [mesh-filename-base].material, and lastly the material name defined by this config property.

Type: string. Default: "Scene.Material"

AI_CONFIG_IMPORT_OGRE_TEXTURETYPE_FROM_FILENAME
The Ogre importer will detect the texture usage from the filename. Normally a texture is loaded as a color map, if no target is specified in the material file. If this is enabled, then Assimp will try to detect the type from the texture filename postfix:
  • Normal Maps: _n, _nrm, _nrml, _normal, _normals, _normalmap
  • Specular Maps: _s, _spec, _specular, _specularmap
  • Light Maps: _l, _light, _lightmap, _occ, _occlusion
  • Displacement Maps: _dis, _displacement
The matching is case insensitive. Postfix is taken between the last "_" and last ".". The default behavior is to detect type from lower cased texture unit name by matching against: normalmap, specularmap, lightmap, and displacementmap. For both cases if no match is found then, Diffuse is used.

Type: Bool. Default: false.

AI_CONFIG_IMPORT_SMD_KEYFRAME
See the documentation for AI_CONFIG_IMPORT_GLOBAL_KEYFRAME.
AI_CONFIG_IMPORT_TER_MAKE_UVS
Configures the terragen import plugin to compute UV's for terrains, if they are not given. Furthermore, a default texture is assigned.

UV coordinates for terrains are so simple to compute that you'll usually want to compute them on your own, if you need them. This option is intended for model viewers which want to offer an easy way to apply textures to terrains.

Type: bool. Default: false

AI_CONFIG_IMPORT_UNREAL_HANDLE_FLAGS
Configures the UNREAL 3D loader to separate faces with different surface flags (e.g. two-sided vs single-sided).

Type: bool. Default: true

AI_CONFIG_IMPORT_UNREAL_KEYFRAME
See the documentation for AI_CONFIG_IMPORT_GLOBAL_KEYFRAME.
AI_CONFIG_PP_CT_MAX_SMOOTHING_ANGLE
Specifies the maximum angle that may be between two vertex tangents that their tangents and bitangents are smoothed during the step to calculate the tangent basis. The angle specified is in degrees. The maximum value is 175 degrees.

Type: float. Default: 45 degrees

AI_CONFIG_PP_CT_TEXTURE_CHANNEL_INDEX
Source UV channel for tangent space computation. The specified channel must exist or an error will be raised.

Type: integer. Default: 0

AI_CONFIG_PP_DB_ALL_OR_NONE
Require all bones to qualify for deboning before any are removed.

Type: bool. Default: false

AI_CONFIG_PP_DB_THRESHOLD
Threshold used to determine if a bone is kept or removed during the Debone step.

Type: float. Default: 1.0f

AI_CONFIG_PP_FD_CHECKAREA
Configures the FindDegenerates step to check the area of a triangle to be greater than 1e-6. If this is not the case, the triangle will be removed if AI_CONFIG_PP_FD_REMOVE is set to true.

Type: bool. Default: false

AI_CONFIG_PP_FD_REMOVE
Configures the FindDegenerates step to remove degenerated primitives from the import immediately.

The default behavior converts degenerated triangles to lines and degenerated lines to points.

Type: bool. Default: false

AI_CONFIG_PP_FID_ANIM_ACCURACY
Input parameter to the FindInvalidData step. It specifies the floating point accuracy for animation values, specifically the epislon during the comparison. The step checks for animation tracks where all frame values are absolutely equal and removes them. Two floats are considered equal if the invariant abs(n0-n1) > epislon holds true for all vector/quaternion components.

Type: float. Default: 0.0f (comparisons are exact)

AI_CONFIG_PP_GSN_MAX_SMOOTHING_ANGLE
Specifies the maximum angle that may be between two face normals at the same vertex position that their normals will be smoothed together during the calculate smooth normals step. This is commonly called the "crease angle". The angle is specified in degrees. Maximum value is 175 degrees (all vertices smoothed).

Type: float. Default: 175 degrees

AI_CONFIG_PP_ICL_PTCACHE_SIZE
Sets the size of the post-transform vertex cache to optimize vertices for. This is for the ImproveCacheLocality step. The size is given in vertices. Of course you can't know how the vertex format will exactly look like after the import returns, but you can still guess what your meshes will probably have. The default value *has* resulted in slight performance improvements for most Nvidia/AMD cards since 2002.

Type: integer. Default: AiDefines.PP_ICL_PTCACHE_SIZE

AI_CONFIG_PP_LBW_MAX_WEIGHTS
Sets the maximum number of bones that can affect a single vertex. This is used by the LimitBoneWeights step.

Type: integer. Default: AiDefines.AI_LBW_MAX_WEIGHTS

AI_CONFIG_PP_OG_EXCLUDE_LIST
Configures the OptimizeGraph step to preserve nodes matching a name in a given list. This is a list of 1 to n strings, whitespace ' ' serves as a delimter character. Identifiers containing whitespaces must be enclosed in *single* quotation marks. Carriage returns and tabs are treated as white space.

If a node matches one of these names, it will not be modified or removed by the postprocessing step.

Type: string. Default: ""

AI_CONFIG_PP_PTV_ADD_ROOT_TRANSFORMATION
Configures the PreTransformVertices step to use a user defined matrix as the scene root node transformation before transforming vertices.

Type: bool. Default: false

AI_CONFIG_PP_PTV_KEEP_HIERARCHY
Configures the PreTransformVertices step to keep the scene hierarchy. Meshes are moved to worldspace, but no optimization is performed where meshes with the same materials are not joined.

This option could be of used if you have a scene hierarchy that contains important additional information which you intend to parse.

Type: bool. Default: false

AI_CONFIG_PP_PTV_NORMALIZE
Configures the PreTransformVertices step to normalize all vertex components into the -1...1 range. That is, a bounding box for the whole scene is computed where the maximum component is taken and all meshes are scaled uniformly. This is useful if you don't know the spatial dimension of the input data.

Type: bool. Default: false

AI_CONFIG_PP_PTV_ROOT_TRANSFORMATION
Configures the PreTransformVertices step to use a user defined matrix as the scene root node transformation before transforming vertices.

Type: Matrix4x4. Default: Identity Matrix

AI_CONFIG_PP_RRM_EXCLUDE_LIST
Configures the RemoveRedundantMaterials step to keep materials matching a name in a given list. This is a list of 1 to n strings where whitespace ' ' serves as a delimiter character. Identifiers containing whitespaces must be enclosed in *single* quotation marks. Tabs or carriage returns are treated as whitespace.

If a material matches one of these names, it will not be modified or removed by the post processing step nor will other materials be replaced by a reference to it.

Default: string. Default: ""

AI_CONFIG_PP_RVC_FLAGS
Input parameter to the RemoveComponent step. It specifies the parts of the data structure to be removed.

This is a bitwise combination of the ExcludeComponent flag. If no valid mesh is remaining after the step is executed, the import FAILS.

Type: integer. Default: 0

AI_CONFIG_PP_SBBC_MAX_BONES
Maximum bone cone per mesh for the SplitByBoneCount step. Meshes are split until the max number of bones is reached.

Type: integer. Default: 60

AI_CONFIG_PP_SBP_REMOVE
Input parameter to the SortByPrimitiveType step. It specifies which primitive types are to be removed by the step.

This is a bitwise combination of the PrimitiveType flag. Specifying ALL types is illegal.

Type: integer. Default: 0

AI_CONFIG_PP_SLM_TRIANGLE_LIMIT
Sets the maximum number of triangles a mesh can contain. This is used by the SplitLargeMeshes step to determine whether a mesh must be split or not.

Type: int. Default: AiDefines.AI_SLM_DEFAULT_MAX_TRIANGLES

AI_CONFIG_PP_SLM_VERTEX_LIMIT
Sets the maximum number of vertices in a mesh. This is used by the SplitLargeMeshes step to determine whether a mesh must be split or not.

Type: integer. Default: AiDefines.AI_SLM_DEFAULT_MAX_VERTICES

AI_CONFIG_PP_TUV_EVALUATE
Input parameter to the TransformUVCoords step. It specifies which UV transformations are to be evaluated.

This is bitwise combination of the UVTransformFlags flag.

Type: integer. Default: AiDefines.AI_UV_TRAFO_ALL (All combinations)

Top
See Also

Reference

Assimp.Unmanaged Namespace


AiConfigs Fields

The AiConfigs type exposes the following members.

Fields
Name Description
AI_CONFIG_EXPORT_XFILE_64BIT
Specifies if the X-file exporter should use 64-bit doubles rather than 32-bit floats.

Type: Bool. Default: false.

AI_CONFIG_FAVOUR_SPEED
A hint to Assimp to favour speed against import quality. Enabling this option may result in faster loading, or it may not. It is just a hint to loaders and post-processing steps to use faster code paths if possible. A value not equal to zero stands for true.

Type: integer. Default: 0

AI_CONFIG_GLOB_MEASURE_TIME
Enables time measurements. If enabled the time needed for each part of the loading process is timed and logged.

Type: bool. Default: false

AI_CONFIG_GLOB_MULTITHREADING
Sets Assimp's multithreading policy. This is ignored if Assimp is built without boost.thread support. Possible values are: -1 to let Assimp decide, 0 to disable multithreading, and nay number larger than 0 to force a specific number of threads. This is only a hint and may be ignored by Assimp.

Type: integer. Default: -1

AI_CONFIG_GLOBAL_SCALE_FACTOR_KEY
Configures the GlobalScale step to scale the entire scene by a certain amount. Some importers provide a mechanism to define a scaling unit for the model, which this processing step can utilize.

Type: Float. Default: 1.0f.

AI_CONFIG_IMPORT_AC_EVAL_SUBDIVISION
Configures whether the AC loader evaluates subdivision surfaces (indicated by the presence of the 'subdiv' attribute in the file). By default, Assimp performs the subdivision using the standard Catmull-Clark algorithm.

Type: bool. Default: true

AI_CONFIG_IMPORT_AC_SEPARATE_BFCULL
Configures the AC loader to collect all surfaces which have the "Backface cull" flag set in separate meshes.

Type: bool. Default: true

AI_CONFIG_IMPORT_ASE_RECONSTRUCT_NORMALS
Configures the ASE loader to always reconstruct normal vectors basing on the smoothing groups loaded from the file. Some ASE files carry invalid normals, others don't.

Type: bool. Default: true

AI_CONFIG_IMPORT_COLLADA_IGNORE_UP_DIRECTION
Specifies whether the collada loader will ignore the up direction.

Type: Bool. Default: false

AI_CONFIG_IMPORT_FBX_OPTIMIZE_EMPTY_ANIMATION_CURVES
Specifies whether the importer will drop empty animation curves or animation curves which match the bind pose transformation over their entire defined range.

Type: Bool. Default: true.

AI_CONFIG_IMPORT_FBX_PRESERVE_PIVOTS
Specifies whether the FBX importer will preserve pivot points for transformations (as extra nodes). If set to false, pivots and offsets will be evaluated whenever possible.

Type: Bool. Default: true.

AI_CONFIG_IMPORT_FBX_READ_ALL_GEOMETRY_LAYERS
Specifies whether the FBX importer will merge all geometry layers present in the source file or take only the first.

Type: bool. Default: true.

AI_CONFIG_IMPORT_FBX_READ_ALL_MATERIALS
Specifies whether the FBX importer will read all materials present in the source file or take only the referenced materials, if the importer will read materials, otherwise this has no effect.

Type: Bool. Default: false.

AI_CONFIG_IMPORT_FBX_READ_ANIMATIONS
Specifies whether the FBX importer will read animations.

Type: Bool. default: true.

AI_CONFIG_IMPORT_FBX_READ_CAMERAS
Specifies whether the FBX importer will read cameras.

Type: Bool. Default: true.

AI_CONFIG_IMPORT_FBX_READ_LIGHTS
Specifies whether the FBX importer will read light sources.

Type: Bool. Default: true.

AI_CONFIG_IMPORT_FBX_READ_MATERIALS
Specifies whether the FBX importer will read materials.

Type: Bool. Default: true.

AI_CONFIG_IMPORT_FBX_READ_TEXTURES
Specifies whether the FBX importer will read embedded textures.

Type: Bool. Default: true.

AI_CONFIG_IMPORT_FBX_SEARCH_EMBEDDED_TEXTURES
Specifies whether the FBX importer will search for embedded loaded textures, where no embedded texture data is provided.

Type: Bool. Default: false.

AI_CONFIG_IMPORT_FBX_STRICT_MODE
Specifies whether the FBX importer will act in strict mode in which only the FBX 2013 format is supported and any other sub formats are rejected. FBX 2013 is the primary target for the importer, so this format is best supported and well-tested.

Type: Bool. Default: false.

AI_CONFIG_IMPORT_GLOBAL_KEYFRAME
Sets the vertex animation keyframe to be imported. Assimp does not support vertex keyframes (only bone animation is supported). The libary reads only one frame of models with vertex animations. By default this is the first frame.

The default value is 0. This option applies to all importers. However, it is also possible to override the global setting for a specific loader. You can use the AI_CONFIG_IMPORT_XXX_KEYFRAME options where XXX is a placeholder for the file format which you want to override the global setting.

Type: integer. Default: 0

AI_CONFIG_IMPORT_IFC_CUSTOM_TRIANGULATION
Specifies whether the IFC loader will use its own, custom triangulation algorithm to triangulate wall and floor meshes. If this is set to false, walls will be either triangulated by the post process triangulation or will be passed through as huge polygons with faked holes (e.g. holes that are connected with the outer boundary using a dummy edge). It is highly recommended to leave this property set to true as the default post process has some known issues with these kind of polygons.

Type: Bool. Default: true.

AI_CONFIG_IMPORT_IFC_CYLINDRICAL_TESSELLATION
Specifies the tessellation for IFC cylindrical shapes. E.g. the number of segments used to approximate a circle. Accepted range of values is between [3, 180].

Type: Integer. Default: 32

AI_CONFIG_IMPORT_IFC_SKIP_SPACE_REPRESENTATIONS
Specifies whether the IFC loader skips over IfcSpace elements. IfcSpace elements (and their geometric representations) are used to represent free space in a building story.

Type: Bool. Default: true.

AI_CONFIG_IMPORT_IFC_SMOOTHING_ANGLE
Specifies the tessellation conic angle for IFC smoothing curves. Accepted range of values is between [5, 120]

Type: Float. Default: 10.0f

AI_CONFIG_IMPORT_IRR_ANIM_FPS
Defines the output frame rate of the IRR loader.

IRR animations are difficult to convert for Assimp and there will always be a loss of quality. This setting defines how many keys per second are returned by the converter.

Type: integer. Default: 100

AI_CONFIG_IMPORT_LWO_ONE_LAYER_ONLY
Configures the LWO loader to load just one layer from the model.

LWO files consist of layers and in some cases it could be useful to load only one of them. This property can be either a string - which specifies the name of the layer - or an integer - the index of the layer. If the property is not set then the whole LWO model is loaded. Loading fails if the requested layer is not vailable. The layer index is zero-based and the layer name may not be empty

Type: bool. Default: false (All layers are loaded)

AI_CONFIG_IMPORT_LWS_ANIM_END
Defines the ending of the time range for which the LWS loader evaluates animations and computes AiNodeAnim's.

Assimp provides full conversion of Lightwave's envelope system, including pre and post conditions. The loader computes linearly subsampled animation channels with the frame rate given in the LWS file. This property defines the end time.

Animation channels are only generated if a node has at least one envelope with more than one key assigned. This property is given in frames where '0' is the first. By default, if this property is not set, the importer takes the animation end from the input LWS file.

Type: integer. Default: taken from file

AI_CONFIG_IMPORT_LWS_ANIM_START
Defines the beginning of the time range for which the LWS loader evaluates animations and computes AiNodeAnim's.

Assimp provides full conversion of Lightwave's envelope system, including pre and post conditions. The loader computes linearly subsampled animation channels with the frame rate given in the LWS file. This property defines the start time.

Animation channels are only generated if a node has at least one envelope with more than one key assigned. This property is given in frames where '0' is the first. By default, if this property is not set, the importer takes the animation start from the input LWS file ('FirstFrame' line)

Type: integer. Default: taken from file

AI_CONFIG_IMPORT_MD2_KEYFRAME
See the documentation for AI_CONFIG_IMPORT_GLOBAL_KEYFRAME.
AI_CONFIG_IMPORT_MD3_HANDLE_MULTIPART
Configures the M3D loader to detect and process multi-part Quake player models. These models usually consit of three files, lower.md3, upper.md3 and head.md3. If this propery is set to true, Assimp will try to load and combine all three files if one of them is loaded.

Type: bool. Default: true

AI_CONFIG_IMPORT_MD3_KEYFRAME
See the documentation for AI_CONFIG_IMPORT_GLOBAL_KEYFRAME.
AI_CONFIG_IMPORT_MD3_SHADER_SRC
Specifies the Quake 3 shader file to be used for a particular MD3 file. This can be a full path or relative to where all MD3 shaders reside.

Type: string. Default: ""

AI_CONFIG_IMPORT_MD3_SKIN_NAME
Tells the MD3 loader which skin files to load. When loading MD3 files, Assimp checks whether a file named "md3_file_name"_"skin_name".skin exists. These files are used by Quake III to be able to assign different skins (e.g. red and blue team) to models. 'default', 'red', 'blue' are typical skin names.

Type: string. Default: "default"

AI_CONFIG_IMPORT_MD5_NO_ANIM_AUTOLOAD
Configures the MD5 loader to not load the MD5ANIM file for a MD5MESH file automatically.

The default strategy is to look for a file with the same name but with the MD5ANIm extension in the same directory. If it is found it is loaded and combined with the MD5MESH file. This configuration option can be used to disable this behavior.

Type: bool. Default: false

AI_CONFIG_IMPORT_MDC_KEYFRAME
See the documentation for AI_CONFIG_IMPORT_GLOBAL_KEYFRAME.
AI_CONFIG_IMPORT_MDL_COLORMAP
Sets the colormap(= palette) to be used to decode embedded textures in MDL (Quake or 3DG5) files. This must be a valid path to a file. The file is 768 (256 * 3) bytes large and contains RGB triplets for each of the 256 palette entries. If the file is not found, a default palette (from Quake 1) is used.

Type: string. Default: "colormap.lmp"

AI_CONFIG_IMPORT_MDL_KEYFRAME
See the documentation for AI_CONFIG_IMPORT_GLOBAL_KEYFRAME.
AI_CONFIG_IMPORT_NO_SKELETON_MESHES
Global setting to disable generation of skeleton dummy meshes. These are generated as a visualization aid in cases which the input data contains no geometry, but only animation data. So the geometry are visualizing the bones.

Type: Bool. Default: false.

AI_CONFIG_IMPORT_OGRE_MATERIAL_FILE
The Ogre importer will try to load this MaterialFile. Ogre meshes reference with material names, this does not tell Assimp where the file is located. Assimp will try to find the source file in the following order: [material-name].material, [mesh-filename-base].material, and lastly the material name defined by this config property.

Type: string. Default: "Scene.Material"

AI_CONFIG_IMPORT_OGRE_TEXTURETYPE_FROM_FILENAME
The Ogre importer will detect the texture usage from the filename. Normally a texture is loaded as a color map, if no target is specified in the material file. If this is enabled, then Assimp will try to detect the type from the texture filename postfix:
  • Normal Maps: _n, _nrm, _nrml, _normal, _normals, _normalmap
  • Specular Maps: _s, _spec, _specular, _specularmap
  • Light Maps: _l, _light, _lightmap, _occ, _occlusion
  • Displacement Maps: _dis, _displacement
The matching is case insensitive. Postfix is taken between the last "_" and last ".". The default behavior is to detect type from lower cased texture unit name by matching against: normalmap, specularmap, lightmap, and displacementmap. For both cases if no match is found then, Diffuse is used.

Type: Bool. Default: false.

AI_CONFIG_IMPORT_SMD_KEYFRAME
See the documentation for AI_CONFIG_IMPORT_GLOBAL_KEYFRAME.
AI_CONFIG_IMPORT_TER_MAKE_UVS
Configures the terragen import plugin to compute UV's for terrains, if they are not given. Furthermore, a default texture is assigned.

UV coordinates for terrains are so simple to compute that you'll usually want to compute them on your own, if you need them. This option is intended for model viewers which want to offer an easy way to apply textures to terrains.

Type: bool. Default: false

AI_CONFIG_IMPORT_UNREAL_HANDLE_FLAGS
Configures the UNREAL 3D loader to separate faces with different surface flags (e.g. two-sided vs single-sided).

Type: bool. Default: true

AI_CONFIG_IMPORT_UNREAL_KEYFRAME
See the documentation for AI_CONFIG_IMPORT_GLOBAL_KEYFRAME.
AI_CONFIG_PP_CT_MAX_SMOOTHING_ANGLE
Specifies the maximum angle that may be between two vertex tangents that their tangents and bitangents are smoothed during the step to calculate the tangent basis. The angle specified is in degrees. The maximum value is 175 degrees.

Type: float. Default: 45 degrees

AI_CONFIG_PP_CT_TEXTURE_CHANNEL_INDEX
Source UV channel for tangent space computation. The specified channel must exist or an error will be raised.

Type: integer. Default: 0

AI_CONFIG_PP_DB_ALL_OR_NONE
Require all bones to qualify for deboning before any are removed.

Type: bool. Default: false

AI_CONFIG_PP_DB_THRESHOLD
Threshold used to determine if a bone is kept or removed during the Debone step.

Type: float. Default: 1.0f

AI_CONFIG_PP_FD_CHECKAREA
Configures the FindDegenerates step to check the area of a triangle to be greater than 1e-6. If this is not the case, the triangle will be removed if AI_CONFIG_PP_FD_REMOVE is set to true.

Type: bool. Default: false

AI_CONFIG_PP_FD_REMOVE
Configures the FindDegenerates step to remove degenerated primitives from the import immediately.

The default behavior converts degenerated triangles to lines and degenerated lines to points.

Type: bool. Default: false

AI_CONFIG_PP_FID_ANIM_ACCURACY
Input parameter to the FindInvalidData step. It specifies the floating point accuracy for animation values, specifically the epislon during the comparison. The step checks for animation tracks where all frame values are absolutely equal and removes them. Two floats are considered equal if the invariant abs(n0-n1) > epislon holds true for all vector/quaternion components.

Type: float. Default: 0.0f (comparisons are exact)

AI_CONFIG_PP_GSN_MAX_SMOOTHING_ANGLE
Specifies the maximum angle that may be between two face normals at the same vertex position that their normals will be smoothed together during the calculate smooth normals step. This is commonly called the "crease angle". The angle is specified in degrees. Maximum value is 175 degrees (all vertices smoothed).

Type: float. Default: 175 degrees

AI_CONFIG_PP_ICL_PTCACHE_SIZE
Sets the size of the post-transform vertex cache to optimize vertices for. This is for the ImproveCacheLocality step. The size is given in vertices. Of course you can't know how the vertex format will exactly look like after the import returns, but you can still guess what your meshes will probably have. The default value *has* resulted in slight performance improvements for most Nvidia/AMD cards since 2002.

Type: integer. Default: AiDefines.PP_ICL_PTCACHE_SIZE

AI_CONFIG_PP_LBW_MAX_WEIGHTS
Sets the maximum number of bones that can affect a single vertex. This is used by the LimitBoneWeights step.

Type: integer. Default: AiDefines.AI_LBW_MAX_WEIGHTS

AI_CONFIG_PP_OG_EXCLUDE_LIST
Configures the OptimizeGraph step to preserve nodes matching a name in a given list. This is a list of 1 to n strings, whitespace ' ' serves as a delimter character. Identifiers containing whitespaces must be enclosed in *single* quotation marks. Carriage returns and tabs are treated as white space.

If a node matches one of these names, it will not be modified or removed by the postprocessing step.

Type: string. Default: ""

AI_CONFIG_PP_PTV_ADD_ROOT_TRANSFORMATION
Configures the PreTransformVertices step to use a user defined matrix as the scene root node transformation before transforming vertices.

Type: bool. Default: false

AI_CONFIG_PP_PTV_KEEP_HIERARCHY
Configures the PreTransformVertices step to keep the scene hierarchy. Meshes are moved to worldspace, but no optimization is performed where meshes with the same materials are not joined.

This option could be of used if you have a scene hierarchy that contains important additional information which you intend to parse.

Type: bool. Default: false

AI_CONFIG_PP_PTV_NORMALIZE
Configures the PreTransformVertices step to normalize all vertex components into the -1...1 range. That is, a bounding box for the whole scene is computed where the maximum component is taken and all meshes are scaled uniformly. This is useful if you don't know the spatial dimension of the input data.

Type: bool. Default: false

AI_CONFIG_PP_PTV_ROOT_TRANSFORMATION
Configures the PreTransformVertices step to use a user defined matrix as the scene root node transformation before transforming vertices.

Type: Matrix4x4. Default: Identity Matrix

AI_CONFIG_PP_RRM_EXCLUDE_LIST
Configures the RemoveRedundantMaterials step to keep materials matching a name in a given list. This is a list of 1 to n strings where whitespace ' ' serves as a delimiter character. Identifiers containing whitespaces must be enclosed in *single* quotation marks. Tabs or carriage returns are treated as whitespace.

If a material matches one of these names, it will not be modified or removed by the post processing step nor will other materials be replaced by a reference to it.

Default: string. Default: ""

AI_CONFIG_PP_RVC_FLAGS
Input parameter to the RemoveComponent step. It specifies the parts of the data structure to be removed.

This is a bitwise combination of the ExcludeComponent flag. If no valid mesh is remaining after the step is executed, the import FAILS.

Type: integer. Default: 0

AI_CONFIG_PP_SBBC_MAX_BONES
Maximum bone cone per mesh for the SplitByBoneCount step. Meshes are split until the max number of bones is reached.

Type: integer. Default: 60

AI_CONFIG_PP_SBP_REMOVE
Input parameter to the SortByPrimitiveType step. It specifies which primitive types are to be removed by the step.

This is a bitwise combination of the PrimitiveType flag. Specifying ALL types is illegal.

Type: integer. Default: 0

AI_CONFIG_PP_SLM_TRIANGLE_LIMIT
Sets the maximum number of triangles a mesh can contain. This is used by the SplitLargeMeshes step to determine whether a mesh must be split or not.

Type: int. Default: AiDefines.AI_SLM_DEFAULT_MAX_TRIANGLES

AI_CONFIG_PP_SLM_VERTEX_LIMIT
Sets the maximum number of vertices in a mesh. This is used by the SplitLargeMeshes step to determine whether a mesh must be split or not.

Type: integer. Default: AiDefines.AI_SLM_DEFAULT_MAX_VERTICES

AI_CONFIG_PP_TUV_EVALUATE
Input parameter to the TransformUVCoords step. It specifies which UV transformations are to be evaluated.

This is bitwise combination of the UVTransformFlags flag.

Type: integer. Default: AiDefines.AI_UV_TRAFO_ALL (All combinations)

Top
See Also

Reference

AiConfigs Class
Assimp.Unmanaged Namespace


AiConfigs.AI_CONFIG_EXPORT_XFILE_64BIT Field

AiConfigsAI_CONFIG_EXPORT_XFILE_64BIT Field

Specifies if the X-file exporter should use 64-bit doubles rather than 32-bit floats.

Type: Bool. Default: false.

Namespace: Assimp.Unmanaged
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public const string AI_CONFIG_EXPORT_XFILE_64BIT = "EXPORT_XFILE_64BIT"

Field Value

Type: String
See Also

Reference

AiConfigs Class
Assimp.Unmanaged Namespace


AiConfigs.AI_CONFIG_FAVOUR_SPEED Field

AiConfigsAI_CONFIG_FAVOUR_SPEED Field

A hint to Assimp to favour speed against import quality. Enabling this option may result in faster loading, or it may not. It is just a hint to loaders and post-processing steps to use faster code paths if possible. A value not equal to zero stands for true.

Type: integer. Default: 0

Namespace: Assimp.Unmanaged
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public const string AI_CONFIG_FAVOUR_SPEED = "FAVOUR_SPEED"

Field Value

Type: String
See Also

Reference

AiConfigs Class
Assimp.Unmanaged Namespace


AiConfigs.AI_CONFIG_GLOB_MEASURE_TIME Field

AiConfigsAI_CONFIG_GLOB_MEASURE_TIME Field

Enables time measurements. If enabled the time needed for each part of the loading process is timed and logged.

Type: bool. Default: false

Namespace: Assimp.Unmanaged
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public const string AI_CONFIG_GLOB_MEASURE_TIME = "GLOB_MEASURE_TIME"

Field Value

Type: String
See Also

Reference

AiConfigs Class
Assimp.Unmanaged Namespace


AiConfigs.AI_CONFIG_GLOB_MULTITHREADING Field

AiConfigsAI_CONFIG_GLOB_MULTITHREADING Field

Sets Assimp's multithreading policy. This is ignored if Assimp is built without boost.thread support. Possible values are: -1 to let Assimp decide, 0 to disable multithreading, and nay number larger than 0 to force a specific number of threads. This is only a hint and may be ignored by Assimp.

Type: integer. Default: -1

Namespace: Assimp.Unmanaged
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public const string AI_CONFIG_GLOB_MULTITHREADING = "GLOB_MULTITHREADING"

Field Value

Type: String
See Also

Reference

AiConfigs Class
Assimp.Unmanaged Namespace


AiConfigs.AI_CONFIG_GLOBAL_SCALE_FACTOR_KEY Field

AiConfigsAI_CONFIG_GLOBAL_SCALE_FACTOR_KEY Field

Configures the GlobalScale step to scale the entire scene by a certain amount. Some importers provide a mechanism to define a scaling unit for the model, which this processing step can utilize.

Type: Float. Default: 1.0f.

Namespace: Assimp.Unmanaged
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public const string AI_CONFIG_GLOBAL_SCALE_FACTOR_KEY = "GLOBAL_SCALE_FACTOR"

Field Value

Type: String
See Also

Reference

AiConfigs Class
Assimp.Unmanaged Namespace


AiConfigs.AI_CONFIG_IMPORT_AC_EVAL_SUBDIVISION Field

AiConfigsAI_CONFIG_IMPORT_AC_EVAL_SUBDIVISION Field

Configures whether the AC loader evaluates subdivision surfaces (indicated by the presence of the 'subdiv' attribute in the file). By default, Assimp performs the subdivision using the standard Catmull-Clark algorithm.

Type: bool. Default: true

Namespace: Assimp.Unmanaged
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public const string AI_CONFIG_IMPORT_AC_EVAL_SUBDIVISION = "IMPORT_AC_EVAL_SUBDIVISION"

Field Value

Type: String
See Also

Reference

AiConfigs Class
Assimp.Unmanaged Namespace


AiConfigs.AI_CONFIG_IMPORT_AC_SEPARATE_BFCULL Field

AiConfigsAI_CONFIG_IMPORT_AC_SEPARATE_BFCULL Field

Configures the AC loader to collect all surfaces which have the "Backface cull" flag set in separate meshes.

Type: bool. Default: true

Namespace: Assimp.Unmanaged
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public const string AI_CONFIG_IMPORT_AC_SEPARATE_BFCULL = "IMPORT_AC_SEPARATE_BFCULL"

Field Value

Type: String
See Also

Reference

AiConfigs Class
Assimp.Unmanaged Namespace


AiConfigs.AI_CONFIG_IMPORT_ASE_RECONSTRUCT_NORMALS Field

AiConfigsAI_CONFIG_IMPORT_ASE_RECONSTRUCT_NORMALS Field

Configures the ASE loader to always reconstruct normal vectors basing on the smoothing groups loaded from the file. Some ASE files carry invalid normals, others don't.

Type: bool. Default: true

Namespace: Assimp.Unmanaged
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public const string AI_CONFIG_IMPORT_ASE_RECONSTRUCT_NORMALS = "IMPORT_ASE_RECONSTRUCT_NORMALS"

Field Value

Type: String
See Also

Reference

AiConfigs Class
Assimp.Unmanaged Namespace


AiConfigs.AI_CONFIG_IMPORT_COLLADA_IGNORE_UP_DIRECTION Field

AiConfigsAI_CONFIG_IMPORT_COLLADA_IGNORE_UP_DIRECTION Field

Specifies whether the collada loader will ignore the up direction.

Type: Bool. Default: false

Namespace: Assimp.Unmanaged
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public const string AI_CONFIG_IMPORT_COLLADA_IGNORE_UP_DIRECTION = "IMPORT_COLLADA_IGNORE_UP_DIRECTION"

Field Value

Type: String
See Also

Reference

AiConfigs Class
Assimp.Unmanaged Namespace


AiConfigs.AI_CONFIG_IMPORT_FBX_OPTIMIZE_EMPTY_ANIMATION_CURVES Field

AiConfigsAI_CONFIG_IMPORT_FBX_OPTIMIZE_EMPTY_ANIMATION_CURVES Field

Specifies whether the importer will drop empty animation curves or animation curves which match the bind pose transformation over their entire defined range.

Type: Bool. Default: true.

Namespace: Assimp.Unmanaged
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public const string AI_CONFIG_IMPORT_FBX_OPTIMIZE_EMPTY_ANIMATION_CURVES = "IMPORT_FBX_OPTIMIZE_EMPTY_ANIMATION_CURVES"

Field Value

Type: String
See Also

Reference

AiConfigs Class
Assimp.Unmanaged Namespace


AiConfigs.AI_CONFIG_IMPORT_FBX_PRESERVE_PIVOTS Field

AiConfigsAI_CONFIG_IMPORT_FBX_PRESERVE_PIVOTS Field

Specifies whether the FBX importer will preserve pivot points for transformations (as extra nodes). If set to false, pivots and offsets will be evaluated whenever possible.

Type: Bool. Default: true.

Namespace: Assimp.Unmanaged
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public const string AI_CONFIG_IMPORT_FBX_PRESERVE_PIVOTS = "IMPORT_FBX_PRESERVE_PIVOTS"

Field Value

Type: String
See Also

Reference

AiConfigs Class
Assimp.Unmanaged Namespace


AiConfigs.AI_CONFIG_IMPORT_FBX_READ_ALL_GEOMETRY_LAYERS Field

AiConfigsAI_CONFIG_IMPORT_FBX_READ_ALL_GEOMETRY_LAYERS Field

Specifies whether the FBX importer will merge all geometry layers present in the source file or take only the first.

Type: bool. Default: true.

Namespace: Assimp.Unmanaged
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public const string AI_CONFIG_IMPORT_FBX_READ_ALL_GEOMETRY_LAYERS = "IMPORT_FBX_READ_ALL_GEOMETRY_LAYERS"

Field Value

Type: String
See Also

Reference

AiConfigs Class
Assimp.Unmanaged Namespace


AiConfigs.AI_CONFIG_IMPORT_FBX_READ_ALL_MATERIALS Field

AiConfigsAI_CONFIG_IMPORT_FBX_READ_ALL_MATERIALS Field

Specifies whether the FBX importer will read all materials present in the source file or take only the referenced materials, if the importer will read materials, otherwise this has no effect.

Type: Bool. Default: false.

Namespace: Assimp.Unmanaged
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public const string AI_CONFIG_IMPORT_FBX_READ_ALL_MATERIALS = "IMPORT_FBX_READ_ALL_MATERIALS"

Field Value

Type: String
See Also

Reference

AiConfigs Class
Assimp.Unmanaged Namespace


AiConfigs.AI_CONFIG_IMPORT_FBX_READ_ANIMATIONS Field

AiConfigsAI_CONFIG_IMPORT_FBX_READ_ANIMATIONS Field

Specifies whether the FBX importer will read animations.

Type: Bool. default: true.

Namespace: Assimp.Unmanaged
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public const string AI_CONFIG_IMPORT_FBX_READ_ANIMATIONS = "IMPORT_FBX_READ_ANIMATIONS"

Field Value

Type: String
See Also

Reference

AiConfigs Class
Assimp.Unmanaged Namespace


AiConfigs.AI_CONFIG_IMPORT_FBX_READ_CAMERAS Field

AiConfigsAI_CONFIG_IMPORT_FBX_READ_CAMERAS Field

Specifies whether the FBX importer will read cameras.

Type: Bool. Default: true.

Namespace: Assimp.Unmanaged
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public const string AI_CONFIG_IMPORT_FBX_READ_CAMERAS = "IMPORT_FBX_READ_CAMERAS"

Field Value

Type: String
See Also

Reference

AiConfigs Class
Assimp.Unmanaged Namespace


AiConfigs.AI_CONFIG_IMPORT_FBX_READ_LIGHTS Field

AiConfigsAI_CONFIG_IMPORT_FBX_READ_LIGHTS Field

Specifies whether the FBX importer will read light sources.

Type: Bool. Default: true.

Namespace: Assimp.Unmanaged
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public const string AI_CONFIG_IMPORT_FBX_READ_LIGHTS = "IMPORT_FBX_READ_LIGHTS"

Field Value

Type: String
See Also

Reference

AiConfigs Class
Assimp.Unmanaged Namespace


AiConfigs.AI_CONFIG_IMPORT_FBX_READ_MATERIALS Field

AiConfigsAI_CONFIG_IMPORT_FBX_READ_MATERIALS Field

Specifies whether the FBX importer will read materials.

Type: Bool. Default: true.

Namespace: Assimp.Unmanaged
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public const string AI_CONFIG_IMPORT_FBX_READ_MATERIALS = "IMPORT_FBX_READ_MATERIALS"

Field Value

Type: String
See Also

Reference

AiConfigs Class
Assimp.Unmanaged Namespace


AiConfigs.AI_CONFIG_IMPORT_FBX_READ_TEXTURES Field

AiConfigsAI_CONFIG_IMPORT_FBX_READ_TEXTURES Field

Specifies whether the FBX importer will read embedded textures.

Type: Bool. Default: true.

Namespace: Assimp.Unmanaged
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public const string AI_CONFIG_IMPORT_FBX_READ_TEXTURES = "IMPORT_FBX_READ_TEXTURES"

Field Value

Type: String
See Also

Reference

AiConfigs Class
Assimp.Unmanaged Namespace


AiConfigs.AI_CONFIG_IMPORT_FBX_SEARCH_EMBEDDED_TEXTURES Field

AiConfigsAI_CONFIG_IMPORT_FBX_SEARCH_EMBEDDED_TEXTURES Field

Specifies whether the FBX importer will search for embedded loaded textures, where no embedded texture data is provided.

Type: Bool. Default: false.

Namespace: Assimp.Unmanaged
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public const string AI_CONFIG_IMPORT_FBX_SEARCH_EMBEDDED_TEXTURES = "IMPORT_FBX_SEARCH_EMBEDDED_TEXTURES"

Field Value

Type: String
See Also

Reference

AiConfigs Class
Assimp.Unmanaged Namespace


AiConfigs.AI_CONFIG_IMPORT_FBX_STRICT_MODE Field

AiConfigsAI_CONFIG_IMPORT_FBX_STRICT_MODE Field

Specifies whether the FBX importer will act in strict mode in which only the FBX 2013 format is supported and any other sub formats are rejected. FBX 2013 is the primary target for the importer, so this format is best supported and well-tested.

Type: Bool. Default: false.

Namespace: Assimp.Unmanaged
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public const string AI_CONFIG_IMPORT_FBX_STRICT_MODE = "IMPORT_FBX_STRICT_MODE"

Field Value

Type: String
See Also

Reference

AiConfigs Class
Assimp.Unmanaged Namespace


AiConfigs.AI_CONFIG_IMPORT_GLOBAL_KEYFRAME Field

AiConfigsAI_CONFIG_IMPORT_GLOBAL_KEYFRAME Field

Sets the vertex animation keyframe to be imported. Assimp does not support vertex keyframes (only bone animation is supported). The libary reads only one frame of models with vertex animations. By default this is the first frame.

The default value is 0. This option applies to all importers. However, it is also possible to override the global setting for a specific loader. You can use the AI_CONFIG_IMPORT_XXX_KEYFRAME options where XXX is a placeholder for the file format which you want to override the global setting.

Type: integer. Default: 0

Namespace: Assimp.Unmanaged
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public const string AI_CONFIG_IMPORT_GLOBAL_KEYFRAME = "IMPORT_GLOBAL_KEYFRAME"

Field Value

Type: String
See Also

Reference

AiConfigs Class
Assimp.Unmanaged Namespace


AiConfigs.AI_CONFIG_IMPORT_IFC_CUSTOM_TRIANGULATION Field

AiConfigsAI_CONFIG_IMPORT_IFC_CUSTOM_TRIANGULATION Field

Specifies whether the IFC loader will use its own, custom triangulation algorithm to triangulate wall and floor meshes. If this is set to false, walls will be either triangulated by the post process triangulation or will be passed through as huge polygons with faked holes (e.g. holes that are connected with the outer boundary using a dummy edge). It is highly recommended to leave this property set to true as the default post process has some known issues with these kind of polygons.

Type: Bool. Default: true.

Namespace: Assimp.Unmanaged
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public const string AI_CONFIG_IMPORT_IFC_CUSTOM_TRIANGULATION = "IMPORT_IFC_CUSTOM_TRIANGULATION"

Field Value

Type: String
See Also

Reference

AiConfigs Class
Assimp.Unmanaged Namespace


AiConfigs.AI_CONFIG_IMPORT_IFC_CYLINDRICAL_TESSELLATION Field

AiConfigsAI_CONFIG_IMPORT_IFC_CYLINDRICAL_TESSELLATION Field

Specifies the tessellation for IFC cylindrical shapes. E.g. the number of segments used to approximate a circle. Accepted range of values is between [3, 180].

Type: Integer. Default: 32

Namespace: Assimp.Unmanaged
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public const string AI_CONFIG_IMPORT_IFC_CYLINDRICAL_TESSELLATION = "IMPORT_IFC_CYLINDRICAL_TESSELLATION"

Field Value

Type: String
See Also

Reference

AiConfigs Class
Assimp.Unmanaged Namespace


AiConfigs.AI_CONFIG_IMPORT_IFC_SKIP_SPACE_REPRESENTATIONS Field

AiConfigsAI_CONFIG_IMPORT_IFC_SKIP_SPACE_REPRESENTATIONS Field

Specifies whether the IFC loader skips over IfcSpace elements. IfcSpace elements (and their geometric representations) are used to represent free space in a building story.

Type: Bool. Default: true.

Namespace: Assimp.Unmanaged
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public const string AI_CONFIG_IMPORT_IFC_SKIP_SPACE_REPRESENTATIONS = "IMPORT_IFC_SKIP_SPACE_REPRESENTATIONS"

Field Value

Type: String
See Also

Reference

AiConfigs Class
Assimp.Unmanaged Namespace


AiConfigs.AI_CONFIG_IMPORT_IFC_SMOOTHING_ANGLE Field

AiConfigsAI_CONFIG_IMPORT_IFC_SMOOTHING_ANGLE Field

Specifies the tessellation conic angle for IFC smoothing curves. Accepted range of values is between [5, 120]

Type: Float. Default: 10.0f

Namespace: Assimp.Unmanaged
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public const string AI_CONFIG_IMPORT_IFC_SMOOTHING_ANGLE = "IMPORT_IFC_SMOOTHING_ANGLE"

Field Value

Type: String
See Also

Reference

AiConfigs Class
Assimp.Unmanaged Namespace


AiConfigs.AI_CONFIG_IMPORT_IRR_ANIM_FPS Field

AiConfigsAI_CONFIG_IMPORT_IRR_ANIM_FPS Field

Defines the output frame rate of the IRR loader.

IRR animations are difficult to convert for Assimp and there will always be a loss of quality. This setting defines how many keys per second are returned by the converter.

Type: integer. Default: 100

Namespace: Assimp.Unmanaged
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public const string AI_CONFIG_IMPORT_IRR_ANIM_FPS = "IMPORT_IRR_ANIM_FPS"

Field Value

Type: String
See Also

Reference

AiConfigs Class
Assimp.Unmanaged Namespace


AiConfigs.AI_CONFIG_IMPORT_LWO_ONE_LAYER_ONLY Field

AiConfigsAI_CONFIG_IMPORT_LWO_ONE_LAYER_ONLY Field

Configures the LWO loader to load just one layer from the model.

LWO files consist of layers and in some cases it could be useful to load only one of them. This property can be either a string - which specifies the name of the layer - or an integer - the index of the layer. If the property is not set then the whole LWO model is loaded. Loading fails if the requested layer is not vailable. The layer index is zero-based and the layer name may not be empty

Type: bool. Default: false (All layers are loaded)

Namespace: Assimp.Unmanaged
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public const string AI_CONFIG_IMPORT_LWO_ONE_LAYER_ONLY = "IMPORT_LWO_ONE_LAYER_ONLY"

Field Value

Type: String
See Also

Reference

AiConfigs Class
Assimp.Unmanaged Namespace


AiConfigs.AI_CONFIG_IMPORT_LWS_ANIM_END Field

AiConfigsAI_CONFIG_IMPORT_LWS_ANIM_END Field

Defines the ending of the time range for which the LWS loader evaluates animations and computes AiNodeAnim's.

Assimp provides full conversion of Lightwave's envelope system, including pre and post conditions. The loader computes linearly subsampled animation channels with the frame rate given in the LWS file. This property defines the end time.

Animation channels are only generated if a node has at least one envelope with more than one key assigned. This property is given in frames where '0' is the first. By default, if this property is not set, the importer takes the animation end from the input LWS file.

Type: integer. Default: taken from file

Namespace: Assimp.Unmanaged
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public const string AI_CONFIG_IMPORT_LWS_ANIM_END = "IMPORT_LWS_ANIM_END"

Field Value

Type: String
See Also

Reference

AiConfigs Class
Assimp.Unmanaged Namespace


AiConfigs.AI_CONFIG_IMPORT_LWS_ANIM_START Field

AiConfigsAI_CONFIG_IMPORT_LWS_ANIM_START Field

Defines the beginning of the time range for which the LWS loader evaluates animations and computes AiNodeAnim's.

Assimp provides full conversion of Lightwave's envelope system, including pre and post conditions. The loader computes linearly subsampled animation channels with the frame rate given in the LWS file. This property defines the start time.

Animation channels are only generated if a node has at least one envelope with more than one key assigned. This property is given in frames where '0' is the first. By default, if this property is not set, the importer takes the animation start from the input LWS file ('FirstFrame' line)

Type: integer. Default: taken from file

Namespace: Assimp.Unmanaged
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public const string AI_CONFIG_IMPORT_LWS_ANIM_START = "IMPORT_LWS_ANIM_START"

Field Value

Type: String
See Also

Reference

AiConfigs Class
Assimp.Unmanaged Namespace


AiConfigs.AI_CONFIG_IMPORT_MD2_KEYFRAME Field

AiConfigsAI_CONFIG_IMPORT_MD2_KEYFRAME Field

See the documentation for AI_CONFIG_IMPORT_GLOBAL_KEYFRAME.

Namespace: Assimp.Unmanaged
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public const string AI_CONFIG_IMPORT_MD2_KEYFRAME = "IMPORT_MD3_KEYFRAME"

Field Value

Type: String
See Also

Reference

AiConfigs Class
Assimp.Unmanaged Namespace


AiConfigs.AI_CONFIG_IMPORT_MD3_HANDLE_MULTIPART Field

AiConfigsAI_CONFIG_IMPORT_MD3_HANDLE_MULTIPART Field

Configures the M3D loader to detect and process multi-part Quake player models. These models usually consit of three files, lower.md3, upper.md3 and head.md3. If this propery is set to true, Assimp will try to load and combine all three files if one of them is loaded.

Type: bool. Default: true

Namespace: Assimp.Unmanaged
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public const string AI_CONFIG_IMPORT_MD3_HANDLE_MULTIPART = "IMPORT_MD3_HANDLE_MULTIPART"

Field Value

Type: String
See Also

Reference

AiConfigs Class
Assimp.Unmanaged Namespace


AiConfigs.AI_CONFIG_IMPORT_MD3_KEYFRAME Field

AiConfigsAI_CONFIG_IMPORT_MD3_KEYFRAME Field

See the documentation for AI_CONFIG_IMPORT_GLOBAL_KEYFRAME.

Namespace: Assimp.Unmanaged
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public const string AI_CONFIG_IMPORT_MD3_KEYFRAME = "IMPORT_MD3_KEYFRAME"

Field Value

Type: String
See Also

Reference

AiConfigs Class
Assimp.Unmanaged Namespace


AiConfigs.AI_CONFIG_IMPORT_MD3_SHADER_SRC Field

AiConfigsAI_CONFIG_IMPORT_MD3_SHADER_SRC Field

Specifies the Quake 3 shader file to be used for a particular MD3 file. This can be a full path or relative to where all MD3 shaders reside.

Type: string. Default: ""

Namespace: Assimp.Unmanaged
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public const string AI_CONFIG_IMPORT_MD3_SHADER_SRC = "IMPORT_MD3_SHADER_SRC"

Field Value

Type: String
See Also

Reference

AiConfigs Class
Assimp.Unmanaged Namespace


AiConfigs.AI_CONFIG_IMPORT_MD3_SKIN_NAME Field

AiConfigsAI_CONFIG_IMPORT_MD3_SKIN_NAME Field

Tells the MD3 loader which skin files to load. When loading MD3 files, Assimp checks whether a file named "md3_file_name"_"skin_name".skin exists. These files are used by Quake III to be able to assign different skins (e.g. red and blue team) to models. 'default', 'red', 'blue' are typical skin names.

Type: string. Default: "default"

Namespace: Assimp.Unmanaged
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public const string AI_CONFIG_IMPORT_MD3_SKIN_NAME = "IMPORT_MD3_SKIN_NAME"

Field Value

Type: String
See Also

Reference

AiConfigs Class
Assimp.Unmanaged Namespace


AiConfigs.AI_CONFIG_IMPORT_MD5_NO_ANIM_AUTOLOAD Field

AiConfigsAI_CONFIG_IMPORT_MD5_NO_ANIM_AUTOLOAD Field

Configures the MD5 loader to not load the MD5ANIM file for a MD5MESH file automatically.

The default strategy is to look for a file with the same name but with the MD5ANIm extension in the same directory. If it is found it is loaded and combined with the MD5MESH file. This configuration option can be used to disable this behavior.

Type: bool. Default: false

Namespace: Assimp.Unmanaged
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public const string AI_CONFIG_IMPORT_MD5_NO_ANIM_AUTOLOAD = "IMPORT_MD5_NO_ANIM_AUTOLOAD"

Field Value

Type: String
See Also

Reference

AiConfigs Class
Assimp.Unmanaged Namespace


AiConfigs.AI_CONFIG_IMPORT_MDC_KEYFRAME Field

AiConfigsAI_CONFIG_IMPORT_MDC_KEYFRAME Field

See the documentation for AI_CONFIG_IMPORT_GLOBAL_KEYFRAME.

Namespace: Assimp.Unmanaged
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public const string AI_CONFIG_IMPORT_MDC_KEYFRAME = "IMPORT_MDC_KEYFRAME"

Field Value

Type: String
See Also

Reference

AiConfigs Class
Assimp.Unmanaged Namespace


AiConfigs.AI_CONFIG_IMPORT_MDL_COLORMAP Field

AiConfigsAI_CONFIG_IMPORT_MDL_COLORMAP Field

Sets the colormap(= palette) to be used to decode embedded textures in MDL (Quake or 3DG5) files. This must be a valid path to a file. The file is 768 (256 * 3) bytes large and contains RGB triplets for each of the 256 palette entries. If the file is not found, a default palette (from Quake 1) is used.

Type: string. Default: "colormap.lmp"

Namespace: Assimp.Unmanaged
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public const string AI_CONFIG_IMPORT_MDL_COLORMAP = "IMPORT_MDL_COLORMAP"

Field Value

Type: String
See Also

Reference

AiConfigs Class
Assimp.Unmanaged Namespace


AiConfigs.AI_CONFIG_IMPORT_MDL_KEYFRAME Field

AiConfigsAI_CONFIG_IMPORT_MDL_KEYFRAME Field

See the documentation for AI_CONFIG_IMPORT_GLOBAL_KEYFRAME.

Namespace: Assimp.Unmanaged
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public const string AI_CONFIG_IMPORT_MDL_KEYFRAME = "IMPORT_MDL_KEYFRAME"

Field Value

Type: String
See Also

Reference

AiConfigs Class
Assimp.Unmanaged Namespace


AiConfigs.AI_CONFIG_IMPORT_NO_SKELETON_MESHES Field

AiConfigsAI_CONFIG_IMPORT_NO_SKELETON_MESHES Field

Global setting to disable generation of skeleton dummy meshes. These are generated as a visualization aid in cases which the input data contains no geometry, but only animation data. So the geometry are visualizing the bones.

Type: Bool. Default: false.

Namespace: Assimp.Unmanaged
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public const string AI_CONFIG_IMPORT_NO_SKELETON_MESHES = "IMPORT_NO_SKELETON_MESHES"

Field Value

Type: String
See Also

Reference

AiConfigs Class
Assimp.Unmanaged Namespace


AiConfigs.AI_CONFIG_IMPORT_OGRE_MATERIAL_FILE Field

AiConfigsAI_CONFIG_IMPORT_OGRE_MATERIAL_FILE Field

The Ogre importer will try to load this MaterialFile. Ogre meshes reference with material names, this does not tell Assimp where the file is located. Assimp will try to find the source file in the following order: [material-name].material, [mesh-filename-base].material, and lastly the material name defined by this config property.

Type: string. Default: "Scene.Material"

Namespace: Assimp.Unmanaged
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public const string AI_CONFIG_IMPORT_OGRE_MATERIAL_FILE = "IMPORT_OGRE_MATERIAL_FILE"

Field Value

Type: String
See Also

Reference

AiConfigs Class
Assimp.Unmanaged Namespace


AiConfigs.AI_CONFIG_IMPORT_OGRE_TEXTURETYPE_FROM_FILENAME Field

AiConfigsAI_CONFIG_IMPORT_OGRE_TEXTURETYPE_FROM_FILENAME Field

The Ogre importer will detect the texture usage from the filename. Normally a texture is loaded as a color map, if no target is specified in the material file. If this is enabled, then Assimp will try to detect the type from the texture filename postfix:
  • Normal Maps: _n, _nrm, _nrml, _normal, _normals, _normalmap
  • Specular Maps: _s, _spec, _specular, _specularmap
  • Light Maps: _l, _light, _lightmap, _occ, _occlusion
  • Displacement Maps: _dis, _displacement
The matching is case insensitive. Postfix is taken between the last "_" and last ".". The default behavior is to detect type from lower cased texture unit name by matching against: normalmap, specularmap, lightmap, and displacementmap. For both cases if no match is found then, Diffuse is used.

Type: Bool. Default: false.

Namespace: Assimp.Unmanaged
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public const string AI_CONFIG_IMPORT_OGRE_TEXTURETYPE_FROM_FILENAME = "IMPORT_OGRE_TEXTURETYPE_FROM_FILENAME"

Field Value

Type: String
See Also

Reference

AiConfigs Class
Assimp.Unmanaged Namespace


AiConfigs.AI_CONFIG_IMPORT_SMD_KEYFRAME Field

AiConfigsAI_CONFIG_IMPORT_SMD_KEYFRAME Field

See the documentation for AI_CONFIG_IMPORT_GLOBAL_KEYFRAME.

Namespace: Assimp.Unmanaged
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public const string AI_CONFIG_IMPORT_SMD_KEYFRAME = "IMPORT_SMD_KEYFRAME"

Field Value

Type: String
See Also

Reference

AiConfigs Class
Assimp.Unmanaged Namespace


AiConfigs.AI_CONFIG_IMPORT_TER_MAKE_UVS Field

AiConfigsAI_CONFIG_IMPORT_TER_MAKE_UVS Field

Configures the terragen import plugin to compute UV's for terrains, if they are not given. Furthermore, a default texture is assigned.

UV coordinates for terrains are so simple to compute that you'll usually want to compute them on your own, if you need them. This option is intended for model viewers which want to offer an easy way to apply textures to terrains.

Type: bool. Default: false

Namespace: Assimp.Unmanaged
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public const string AI_CONFIG_IMPORT_TER_MAKE_UVS = "IMPORT_TER_MAKE_UVS"

Field Value

Type: String
See Also

Reference

AiConfigs Class
Assimp.Unmanaged Namespace


AiConfigs.AI_CONFIG_IMPORT_UNREAL_HANDLE_FLAGS Field

AiConfigsAI_CONFIG_IMPORT_UNREAL_HANDLE_FLAGS Field

Configures the UNREAL 3D loader to separate faces with different surface flags (e.g. two-sided vs single-sided).

Type: bool. Default: true

Namespace: Assimp.Unmanaged
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public const string AI_CONFIG_IMPORT_UNREAL_HANDLE_FLAGS = "UNREAL_HANDLE_FLAGS"

Field Value

Type: String
See Also

Reference

AiConfigs Class
Assimp.Unmanaged Namespace


AiConfigs.AI_CONFIG_IMPORT_UNREAL_KEYFRAME Field

AiConfigsAI_CONFIG_IMPORT_UNREAL_KEYFRAME Field

See the documentation for AI_CONFIG_IMPORT_GLOBAL_KEYFRAME.

Namespace: Assimp.Unmanaged
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public const string AI_CONFIG_IMPORT_UNREAL_KEYFRAME = "IMPORT_UNREAL_KEYFRAME"

Field Value

Type: String
See Also

Reference

AiConfigs Class
Assimp.Unmanaged Namespace


AiConfigs.AI_CONFIG_PP_CT_MAX_SMOOTHING_ANGLE Field

AiConfigsAI_CONFIG_PP_CT_MAX_SMOOTHING_ANGLE Field

Specifies the maximum angle that may be between two vertex tangents that their tangents and bitangents are smoothed during the step to calculate the tangent basis. The angle specified is in degrees. The maximum value is 175 degrees.

Type: float. Default: 45 degrees

Namespace: Assimp.Unmanaged
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public const string AI_CONFIG_PP_CT_MAX_SMOOTHING_ANGLE = "PP_CT_MAX_SMOOTHING_ANGLE"

Field Value

Type: String
See Also

Reference

AiConfigs Class
Assimp.Unmanaged Namespace


AiConfigs.AI_CONFIG_PP_CT_TEXTURE_CHANNEL_INDEX Field

AiConfigsAI_CONFIG_PP_CT_TEXTURE_CHANNEL_INDEX Field

Source UV channel for tangent space computation. The specified channel must exist or an error will be raised.

Type: integer. Default: 0

Namespace: Assimp.Unmanaged
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public const string AI_CONFIG_PP_CT_TEXTURE_CHANNEL_INDEX = "AI_CONFIG_PP_CT_TEXTURE_CHANNEL_INDEX"

Field Value

Type: String
See Also

Reference

AiConfigs Class
Assimp.Unmanaged Namespace


AiConfigs.AI_CONFIG_PP_DB_ALL_OR_NONE Field

AiConfigsAI_CONFIG_PP_DB_ALL_OR_NONE Field

Require all bones to qualify for deboning before any are removed.

Type: bool. Default: false

Namespace: Assimp.Unmanaged
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public const string AI_CONFIG_PP_DB_ALL_OR_NONE = "PP_DB_ALL_OR_NONE"

Field Value

Type: String
See Also

Reference

AiConfigs Class
Assimp.Unmanaged Namespace


AiConfigs.AI_CONFIG_PP_DB_THRESHOLD Field

AiConfigsAI_CONFIG_PP_DB_THRESHOLD Field

Threshold used to determine if a bone is kept or removed during the Debone step.

Type: float. Default: 1.0f

Namespace: Assimp.Unmanaged
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public const string AI_CONFIG_PP_DB_THRESHOLD = "PP_DB_THRESHOLD"

Field Value

Type: String
See Also

Reference

AiConfigs Class
Assimp.Unmanaged Namespace


AiConfigs.AI_CONFIG_PP_FD_CHECKAREA Field

AiConfigsAI_CONFIG_PP_FD_CHECKAREA Field

Configures the FindDegenerates step to check the area of a triangle to be greater than 1e-6. If this is not the case, the triangle will be removed if AI_CONFIG_PP_FD_REMOVE is set to true.

Type: bool. Default: false

Namespace: Assimp.Unmanaged
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public const string AI_CONFIG_PP_FD_CHECKAREA = "PP_FD_CHECKAREA"

Field Value

Type: String
See Also

Reference

AiConfigs Class
Assimp.Unmanaged Namespace


AiConfigs.AI_CONFIG_PP_FD_REMOVE Field

AiConfigsAI_CONFIG_PP_FD_REMOVE Field

Configures the FindDegenerates step to remove degenerated primitives from the import immediately.

The default behavior converts degenerated triangles to lines and degenerated lines to points.

Type: bool. Default: false

Namespace: Assimp.Unmanaged
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public const string AI_CONFIG_PP_FD_REMOVE = "PP_FD_REMOVE"

Field Value

Type: String
See Also

Reference

AiConfigs Class
Assimp.Unmanaged Namespace


AiConfigs.AI_CONFIG_PP_FID_ANIM_ACCURACY Field

AiConfigsAI_CONFIG_PP_FID_ANIM_ACCURACY Field

Input parameter to the FindInvalidData step. It specifies the floating point accuracy for animation values, specifically the epislon during the comparison. The step checks for animation tracks where all frame values are absolutely equal and removes them. Two floats are considered equal if the invariant abs(n0-n1) > epislon holds true for all vector/quaternion components.

Type: float. Default: 0.0f (comparisons are exact)

Namespace: Assimp.Unmanaged
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public const string AI_CONFIG_PP_FID_ANIM_ACCURACY = "PP_FID_ANIM_ACCURACY"

Field Value

Type: String
See Also

Reference

AiConfigs Class
Assimp.Unmanaged Namespace


AiConfigs.AI_CONFIG_PP_GSN_MAX_SMOOTHING_ANGLE Field

AiConfigsAI_CONFIG_PP_GSN_MAX_SMOOTHING_ANGLE Field

Specifies the maximum angle that may be between two face normals at the same vertex position that their normals will be smoothed together during the calculate smooth normals step. This is commonly called the "crease angle". The angle is specified in degrees. Maximum value is 175 degrees (all vertices smoothed).

Type: float. Default: 175 degrees

Namespace: Assimp.Unmanaged
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public const string AI_CONFIG_PP_GSN_MAX_SMOOTHING_ANGLE = "PP_GSN_MAX_SMOOTHING_ANGLE"

Field Value

Type: String
See Also

Reference

AiConfigs Class
Assimp.Unmanaged Namespace


AiConfigs.AI_CONFIG_PP_ICL_PTCACHE_SIZE Field

AiConfigsAI_CONFIG_PP_ICL_PTCACHE_SIZE Field

Sets the size of the post-transform vertex cache to optimize vertices for. This is for the ImproveCacheLocality step. The size is given in vertices. Of course you can't know how the vertex format will exactly look like after the import returns, but you can still guess what your meshes will probably have. The default value *has* resulted in slight performance improvements for most Nvidia/AMD cards since 2002.

Type: integer. Default: AiDefines.PP_ICL_PTCACHE_SIZE

Namespace: Assimp.Unmanaged
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public const string AI_CONFIG_PP_ICL_PTCACHE_SIZE = "PP_ICL_PTCACHE_SIZE"

Field Value

Type: String
See Also

Reference

AiConfigs Class
Assimp.Unmanaged Namespace


AiConfigs.AI_CONFIG_PP_LBW_MAX_WEIGHTS Field

AiConfigsAI_CONFIG_PP_LBW_MAX_WEIGHTS Field

Sets the maximum number of bones that can affect a single vertex. This is used by the LimitBoneWeights step.

Type: integer. Default: AiDefines.AI_LBW_MAX_WEIGHTS

Namespace: Assimp.Unmanaged
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public const string AI_CONFIG_PP_LBW_MAX_WEIGHTS = "PP_LBW_MAX_WEIGHTS"

Field Value

Type: String
See Also

Reference

AiConfigs Class
Assimp.Unmanaged Namespace


AiConfigs.AI_CONFIG_PP_OG_EXCLUDE_LIST Field

AiConfigsAI_CONFIG_PP_OG_EXCLUDE_LIST Field

Configures the OptimizeGraph step to preserve nodes matching a name in a given list. This is a list of 1 to n strings, whitespace ' ' serves as a delimter character. Identifiers containing whitespaces must be enclosed in *single* quotation marks. Carriage returns and tabs are treated as white space.

If a node matches one of these names, it will not be modified or removed by the postprocessing step.

Type: string. Default: ""

Namespace: Assimp.Unmanaged
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public const string AI_CONFIG_PP_OG_EXCLUDE_LIST = "PP_OG_EXCLUDE_LIST"

Field Value

Type: String
See Also

Reference

AiConfigs Class
Assimp.Unmanaged Namespace


AiConfigs.AI_CONFIG_PP_PTV_ADD_ROOT_TRANSFORMATION Field

AiConfigsAI_CONFIG_PP_PTV_ADD_ROOT_TRANSFORMATION Field

Configures the PreTransformVertices step to use a user defined matrix as the scene root node transformation before transforming vertices.

Type: bool. Default: false

Namespace: Assimp.Unmanaged
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public const string AI_CONFIG_PP_PTV_ADD_ROOT_TRANSFORMATION = "PP_PTV_ADD_ROOT_TRANSFORMATION"

Field Value

Type: String
See Also

Reference

AiConfigs Class
Assimp.Unmanaged Namespace


AiConfigs.AI_CONFIG_PP_PTV_KEEP_HIERARCHY Field

AiConfigsAI_CONFIG_PP_PTV_KEEP_HIERARCHY Field

Configures the PreTransformVertices step to keep the scene hierarchy. Meshes are moved to worldspace, but no optimization is performed where meshes with the same materials are not joined.

This option could be of used if you have a scene hierarchy that contains important additional information which you intend to parse.

Type: bool. Default: false

Namespace: Assimp.Unmanaged
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public const string AI_CONFIG_PP_PTV_KEEP_HIERARCHY = "PP_PTV_KEEP_HIERARCHY"

Field Value

Type: String
See Also

Reference

AiConfigs Class
Assimp.Unmanaged Namespace


AiConfigs.AI_CONFIG_PP_PTV_NORMALIZE Field

AiConfigsAI_CONFIG_PP_PTV_NORMALIZE Field

Configures the PreTransformVertices step to normalize all vertex components into the -1...1 range. That is, a bounding box for the whole scene is computed where the maximum component is taken and all meshes are scaled uniformly. This is useful if you don't know the spatial dimension of the input data.

Type: bool. Default: false

Namespace: Assimp.Unmanaged
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public const string AI_CONFIG_PP_PTV_NORMALIZE = "PP_PTV_NORMALIZE"

Field Value

Type: String
See Also

Reference

AiConfigs Class
Assimp.Unmanaged Namespace


AiConfigs.AI_CONFIG_PP_PTV_ROOT_TRANSFORMATION Field

AiConfigsAI_CONFIG_PP_PTV_ROOT_TRANSFORMATION Field

Configures the PreTransformVertices step to use a user defined matrix as the scene root node transformation before transforming vertices.

Type: Matrix4x4. Default: Identity Matrix

Namespace: Assimp.Unmanaged
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public const string AI_CONFIG_PP_PTV_ROOT_TRANSFORMATION = "PP_PTV_ROOT_TRANSFORMATION"

Field Value

Type: String
See Also

Reference

AiConfigs Class
Assimp.Unmanaged Namespace


AiConfigs.AI_CONFIG_PP_RRM_EXCLUDE_LIST Field

AiConfigsAI_CONFIG_PP_RRM_EXCLUDE_LIST Field

Configures the RemoveRedundantMaterials step to keep materials matching a name in a given list. This is a list of 1 to n strings where whitespace ' ' serves as a delimiter character. Identifiers containing whitespaces must be enclosed in *single* quotation marks. Tabs or carriage returns are treated as whitespace.

If a material matches one of these names, it will not be modified or removed by the post processing step nor will other materials be replaced by a reference to it.

Default: string. Default: ""

Namespace: Assimp.Unmanaged
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public const string AI_CONFIG_PP_RRM_EXCLUDE_LIST = "PP_RRM_EXCLUDE_LIST"

Field Value

Type: String
See Also

Reference

AiConfigs Class
Assimp.Unmanaged Namespace


AiConfigs.AI_CONFIG_PP_RVC_FLAGS Field

AiConfigsAI_CONFIG_PP_RVC_FLAGS Field

Input parameter to the RemoveComponent step. It specifies the parts of the data structure to be removed.

This is a bitwise combination of the ExcludeComponent flag. If no valid mesh is remaining after the step is executed, the import FAILS.

Type: integer. Default: 0

Namespace: Assimp.Unmanaged
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public const string AI_CONFIG_PP_RVC_FLAGS = "PP_RVC_FLAGS"

Field Value

Type: String
See Also

Reference

AiConfigs Class
Assimp.Unmanaged Namespace


AiConfigs.AI_CONFIG_PP_SBBC_MAX_BONES Field

AiConfigsAI_CONFIG_PP_SBBC_MAX_BONES Field

Maximum bone cone per mesh for the SplitByBoneCount step. Meshes are split until the max number of bones is reached.

Type: integer. Default: 60

Namespace: Assimp.Unmanaged
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public const string AI_CONFIG_PP_SBBC_MAX_BONES = "PP_SBBC_MAX_BONES"

Field Value

Type: String
See Also

Reference

AiConfigs Class
Assimp.Unmanaged Namespace


AiConfigs.AI_CONFIG_PP_SBP_REMOVE Field

AiConfigsAI_CONFIG_PP_SBP_REMOVE Field

Input parameter to the SortByPrimitiveType step. It specifies which primitive types are to be removed by the step.

This is a bitwise combination of the PrimitiveType flag. Specifying ALL types is illegal.

Type: integer. Default: 0

Namespace: Assimp.Unmanaged
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public const string AI_CONFIG_PP_SBP_REMOVE = "PP_SBP_REMOVE"

Field Value

Type: String
See Also

Reference

AiConfigs Class
Assimp.Unmanaged Namespace


AiConfigs.AI_CONFIG_PP_SLM_TRIANGLE_LIMIT Field

AiConfigsAI_CONFIG_PP_SLM_TRIANGLE_LIMIT Field

Sets the maximum number of triangles a mesh can contain. This is used by the SplitLargeMeshes step to determine whether a mesh must be split or not.

Type: int. Default: AiDefines.AI_SLM_DEFAULT_MAX_TRIANGLES

Namespace: Assimp.Unmanaged
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public const string AI_CONFIG_PP_SLM_TRIANGLE_LIMIT = "PP_SLM_TRIANGLE_LIMIT"

Field Value

Type: String
See Also

Reference

AiConfigs Class
Assimp.Unmanaged Namespace


AiConfigs.AI_CONFIG_PP_SLM_VERTEX_LIMIT Field

AiConfigsAI_CONFIG_PP_SLM_VERTEX_LIMIT Field

Sets the maximum number of vertices in a mesh. This is used by the SplitLargeMeshes step to determine whether a mesh must be split or not.

Type: integer. Default: AiDefines.AI_SLM_DEFAULT_MAX_VERTICES

Namespace: Assimp.Unmanaged
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public const string AI_CONFIG_PP_SLM_VERTEX_LIMIT = "PP_SLM_VERTEX_LIMIT"

Field Value

Type: String
See Also

Reference

AiConfigs Class
Assimp.Unmanaged Namespace


AiConfigs.AI_CONFIG_PP_TUV_EVALUATE Field

AiConfigsAI_CONFIG_PP_TUV_EVALUATE Field

Input parameter to the TransformUVCoords step. It specifies which UV transformations are to be evaluated.

This is bitwise combination of the UVTransformFlags flag.

Type: integer. Default: AiDefines.AI_UV_TRAFO_ALL (All combinations)

Namespace: Assimp.Unmanaged
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public const string AI_CONFIG_PP_TUV_EVALUATE = "PP_TUV_EVALUATE"

Field Value

Type: String
See Also

Reference

AiConfigs Class
Assimp.Unmanaged Namespace


AiDefines Class

Static class that has a number of constants that are found in Assimp. These can be limits to configuration property default values. The constants are grouped according to their usage or where they're found in the Assimp include files.
Inheritance Hierarchy
SystemObject
Assimp.UnmanagedAiDefines

Namespace: Assimp.Unmanaged
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public static class AiDefines

The AiDefines type exposes the following members.

Fields
Name | Description
AI_DEBONE_THRESHOLD | Defines the deboning threshold.
AI_DEFAULT_MATERIAL_NAME | Defines the default color material.
AI_DEFAULT_TEXTURED_MATERIAL_NAME | Defines the default textured material (if the meshes have UV coords).
AI_LBW_MAX_WEIGHTS | Default value for AI_CONFIG_PP_LBW_MAX_WEIGHTS.
AI_MAX_BONE_WEIGHTS | Defines the maximum number of bone weights.
AI_MAX_FACE_INDICES | Defines the maximum number of indices per face (polygon).
AI_MAX_FACES | Defines the maximum number of faces per mesh.
AI_MAX_NUMBER_OF_COLOR_SETS | Defines the maximum number of vertex color sets per mesh.
AI_MAX_NUMBER_OF_TEXTURECOORDS | Defines the maximum number of texture coordinate sets (UV(W) channels) per mesh.
AI_MAX_VERTICES | Defines the maximum number of vertices per mesh.
AI_SBBC_DEFAULT_MAX_BONES | Defines the default bone count limit.
AI_SLM_DEFAULT_MAX_TRIANGLES | Default value for AI_CONFIG_PP_SLM_TRIANGLE_LIMIT.
AI_SLM_DEFAULT_MAX_VERTICES | Default value for AI_CONFIG_PP_SLM_VERTEX_LIMIT.
AI_UVTRAFO_ALL | Default value for AI_CONFIG_PP_TUV_EVALUATE
MAX_LENGTH | Defines the maximum length of a string used in AiString.
PP_ICL_PTCACHE_SIZE | Default value for AI_CONFIG_PP_ICL_PTCACHE_SIZE.
Top
See Also

Reference

Assimp.Unmanaged Namespace


AiDefines Fields

The AiDefines type exposes the following members.

Fields
Name | Description
AI_DEBONE_THRESHOLD | Defines the deboning threshold.
AI_DEFAULT_MATERIAL_NAME | Defines the default color material.
AI_DEFAULT_TEXTURED_MATERIAL_NAME | Defines the default textured material (if the meshes have UV coords).
AI_LBW_MAX_WEIGHTS | Default value for AI_CONFIG_PP_LBW_MAX_WEIGHTS.
AI_MAX_BONE_WEIGHTS | Defines the maximum number of bone weights.
AI_MAX_FACE_INDICES | Defines the maximum number of indices per face (polygon).
AI_MAX_FACES | Defines the maximum number of faces per mesh.
AI_MAX_NUMBER_OF_COLOR_SETS | Defines the maximum number of vertex color sets per mesh.
AI_MAX_NUMBER_OF_TEXTURECOORDS | Defines the maximum number of texture coordinate sets (UV(W) channels) per mesh.
AI_MAX_VERTICES | Defines the maximum number of vertices per mesh.
AI_SBBC_DEFAULT_MAX_BONES | Defines the default bone count limit.
AI_SLM_DEFAULT_MAX_TRIANGLES | Default value for AI_CONFIG_PP_SLM_TRIANGLE_LIMIT.
AI_SLM_DEFAULT_MAX_VERTICES | Default value for AI_CONFIG_PP_SLM_VERTEX_LIMIT.
AI_UVTRAFO_ALL | Default value for AI_CONFIG_PP_TUV_EVALUATE
MAX_LENGTH | Defines the maximum length of a string used in AiString.
PP_ICL_PTCACHE_SIZE | Default value for AI_CONFIG_PP_ICL_PTCACHE_SIZE.
Top
See Also

Reference

AiDefines Class
Assimp.Unmanaged Namespace


AiDefines.AI_DEBONE_THRESHOLD Field

AiDefinesAI_DEBONE_THRESHOLD Field

Defines the deboning threshold.

Namespace: Assimp.Unmanaged
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public const float AI_DEBONE_THRESHOLD = 1f

Field Value

Type: Single
See Also

Reference

AiDefines Class
Assimp.Unmanaged Namespace


AiDefines.AI_DEFAULT_MATERIAL_NAME Field

AiDefinesAI_DEFAULT_MATERIAL_NAME Field

Defines the default color material.

Namespace: Assimp.Unmanaged
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public const string AI_DEFAULT_MATERIAL_NAME = "DefaultMaterial"

Field Value

Type: String
See Also

Reference

AiDefines Class
Assimp.Unmanaged Namespace


AiDefines.AI_DEFAULT_TEXTURED_MATERIAL_NAME Field

AiDefinesAI_DEFAULT_TEXTURED_MATERIAL_NAME Field

Defines the default textured material (if the meshes have UV coords).

Namespace: Assimp.Unmanaged
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public const string AI_DEFAULT_TEXTURED_MATERIAL_NAME = "TexturedDefaultMaterial"

Field Value

Type: String
See Also

Reference

AiDefines Class
Assimp.Unmanaged Namespace


AiDefines.AI_LBW_MAX_WEIGHTS Field

AiDefinesAI_LBW_MAX_WEIGHTS Field

Default value for AI_CONFIG_PP_LBW_MAX_WEIGHTS.

Namespace: Assimp.Unmanaged
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public const int AI_LBW_MAX_WEIGHTS = 4

Field Value

Type: Int32
See Also

Reference

AiDefines Class
Assimp.Unmanaged Namespace


AiDefines.AI_MAX_BONE_WEIGHTS Field

AiDefinesAI_MAX_BONE_WEIGHTS Field

Defines the maximum number of bone weights.

Namespace: Assimp.Unmanaged
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public const int AI_MAX_BONE_WEIGHTS = 2147483647

Field Value

Type: Int32
See Also

Reference

AiDefines Class
Assimp.Unmanaged Namespace


AiDefines.AI_MAX_FACE_INDICES Field

AiDefinesAI_MAX_FACE_INDICES Field

Defines the maximum number of indices per face (polygon).

Namespace: Assimp.Unmanaged
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public const int AI_MAX_FACE_INDICES = 32767

Field Value

Type: Int32
See Also

Reference

AiDefines Class
Assimp.Unmanaged Namespace


AiDefines.AI_MAX_FACES Field

AiDefinesAI_MAX_FACES Field

Defines the maximum number of faces per mesh.

Namespace: Assimp.Unmanaged
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public const int AI_MAX_FACES = 2147483647

Field Value

Type: Int32
See Also

Reference

AiDefines Class
Assimp.Unmanaged Namespace


AiDefines.AI_MAX_NUMBER_OF_COLOR_SETS Field

AiDefinesAI_MAX_NUMBER_OF_COLOR_SETS Field

Defines the maximum number of vertex color sets per mesh.

Namespace: Assimp.Unmanaged
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public const int AI_MAX_NUMBER_OF_COLOR_SETS = 8

Field Value

Type: Int32
See Also

Reference

AiDefines Class
Assimp.Unmanaged Namespace


AiDefines.AI_MAX_NUMBER_OF_TEXTURECOORDS Field

AiDefinesAI_MAX_NUMBER_OF_TEXTURECOORDS Field

Defines the maximum number of texture coordinate sets (UV(W) channels) per mesh.

Namespace: Assimp.Unmanaged
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public const int AI_MAX_NUMBER_OF_TEXTURECOORDS = 8

Field Value

Type: Int32
See Also

Reference

AiDefines Class
Assimp.Unmanaged Namespace


AiDefines.AI_MAX_VERTICES Field

AiDefinesAI_MAX_VERTICES Field

Defines the maximum number of vertices per mesh.

Namespace: Assimp.Unmanaged
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public const int AI_MAX_VERTICES = 2147483647

Field Value

Type: Int32
See Also

Reference

AiDefines Class
Assimp.Unmanaged Namespace


AiDefines.AI_SBBC_DEFAULT_MAX_BONES Field

AiDefinesAI_SBBC_DEFAULT_MAX_BONES Field

Defines the default bone count limit.

Namespace: Assimp.Unmanaged
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public const int AI_SBBC_DEFAULT_MAX_BONES = 60

Field Value

Type: Int32
See Also

Reference

AiDefines Class
Assimp.Unmanaged Namespace


AiDefines.AI_SLM_DEFAULT_MAX_TRIANGLES Field

AiDefinesAI_SLM_DEFAULT_MAX_TRIANGLES Field

Default value for AI_CONFIG_PP_SLM_TRIANGLE_LIMIT.

Namespace: Assimp.Unmanaged
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public const int AI_SLM_DEFAULT_MAX_TRIANGLES = 1000000

Field Value

Type: Int32
See Also

Reference

AiDefines Class
Assimp.Unmanaged Namespace


AiDefines.AI_SLM_DEFAULT_MAX_VERTICES Field

AiDefinesAI_SLM_DEFAULT_MAX_VERTICES Field

Default value for AI_CONFIG_PP_SLM_VERTEX_LIMIT.

Namespace: Assimp.Unmanaged
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public const int AI_SLM_DEFAULT_MAX_VERTICES = 1000000

Field Value

Type: Int32
See Also

Reference

AiDefines Class
Assimp.Unmanaged Namespace


AiDefines.AI_UVTRAFO_ALL Field

AiDefinesAI_UVTRAFO_ALL Field

Default value for AI_CONFIG_PP_TUV_EVALUATE

Namespace: Assimp.Unmanaged
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public const int AI_UVTRAFO_ALL = 7

Field Value

Type: Int32
See Also

Reference

AiDefines Class
Assimp.Unmanaged Namespace


AiDefines.MAX_LENGTH Field

AiDefinesMAX_LENGTH Field

Defines the maximum length of a string used in AiString.

Namespace: Assimp.Unmanaged
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public const int MAX_LENGTH = 1024

Field Value

Type: Int32
See Also

Reference

AiDefines Class
Assimp.Unmanaged Namespace


AiDefines.PP_ICL_PTCACHE_SIZE Field

AiDefinesPP_ICL_PTCACHE_SIZE Field

Default value for AI_CONFIG_PP_ICL_PTCACHE_SIZE.

Namespace: Assimp.Unmanaged
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public const int PP_ICL_PTCACHE_SIZE = 12

Field Value

Type: Int32
See Also

Reference

AiDefines Class
Assimp.Unmanaged Namespace


AiExportDataBlob Structure

Describes a blob of exported scene data. Blobs can be nested, the first blob always has an empty name. Nested blobs represent auxillary files produced by the exporter (e.g. material files) and are named accordingly.

Namespace: Assimp.Unmanaged
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public struct AiExportDataBlob

The AiExportDataBlob type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Indicates whether this instance and a specified object are equal. (Inherited from ValueType.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from ValueType.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns the fully qualified type name of this instance. (Inherited from ValueType.)
Top
Fields
 | Name | Description
Public field | Data | void*, the data.
Public field | Name | AiString, name of the blob.
Public field | NextBlob | aiExportDataBlob*, pointer to the next blob in the chain.
Public field | Size | size_t, size of the data in bytes.
Top
See Also

Reference

Assimp.Unmanaged Namespace


AiExportDataBlob Methods

The AiExportDataBlob type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Indicates whether this instance and a specified object are equal. (Inherited from ValueType.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from ValueType.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns the fully qualified type name of this instance. (Inherited from ValueType.)
Top
See Also

Reference

AiExportDataBlob Structure
Assimp.Unmanaged Namespace


AiExportDataBlob Fields

The AiExportDataBlob type exposes the following members.

Fields
 | Name | Description
Public field | Data | void*, the data.
Public field | Name | AiString, name of the blob.
Public field | NextBlob | aiExportDataBlob*, pointer to the next blob in the chain.
Public field | Size | size_t, size of the data in bytes.
Top
See Also

Reference

AiExportDataBlob Structure
Assimp.Unmanaged Namespace


AiExportDataBlob.Data Field

AiExportDataBlobData Field

void*, the data.

Namespace: Assimp.Unmanaged
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public IntPtr Data

Field Value

Type: IntPtr
See Also

Reference

AiExportDataBlob Structure
Assimp.Unmanaged Namespace


AiExportDataBlob.Name Field

AiExportDataBlobName Field

AiString, name of the blob.

Namespace: Assimp.Unmanaged
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public AiString Name

Field Value

Type: AiString
See Also

Reference

AiExportDataBlob Structure
Assimp.Unmanaged Namespace


AiExportDataBlob.NextBlob Field

AiExportDataBlobNextBlob Field

aiExportDataBlob*, pointer to the next blob in the chain.

Namespace: Assimp.Unmanaged
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public IntPtr NextBlob

Field Value

Type: IntPtr
See Also

Reference

AiExportDataBlob Structure
Assimp.Unmanaged Namespace


AiExportDataBlob.Size Field

AiExportDataBlobSize Field

size_t, size of the data in bytes.

Namespace: Assimp.Unmanaged
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public UIntPtr Size

Field Value

Type: UIntPtr
See Also

Reference

AiExportDataBlob Structure
Assimp.Unmanaged Namespace


AiExportFormatDesc Structure

Describes a file format which Assimp can export to.

Namespace: Assimp.Unmanaged
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public struct AiExportFormatDesc

The AiExportFormatDesc type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Indicates whether this instance and a specified object are equal. (Inherited from ValueType.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from ValueType.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns the fully qualified type name of this instance. (Inherited from ValueType.)
Top
Fields
 | Name | Description
Public field | Description | char*, a short description of the file format to present to users.
Public field | FileExtension | char*, a recommended file extension of the exported file in lower case.
Public field | FormatId | char*, a short string ID to uniquely identify the export format. e.g. "collada" or "obj"
Top
See Also

Reference

Assimp.Unmanaged Namespace


AiExportFormatDesc Methods

The AiExportFormatDesc type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Indicates whether this instance and a specified object are equal. (Inherited from ValueType.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from ValueType.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns the fully qualified type name of this instance. (Inherited from ValueType.)
Top
See Also

Reference

AiExportFormatDesc Structure
Assimp.Unmanaged Namespace


AiExportFormatDesc Fields

The AiExportFormatDesc type exposes the following members.

Fields
 | Name | Description
Public field | Description | char*, a short description of the file format to present to users.
Public field | FileExtension | char*, a recommended file extension of the exported file in lower case.
Public field | FormatId | char*, a short string ID to uniquely identify the export format. e.g. "collada" or "obj"
Top
See Also

Reference

AiExportFormatDesc Structure
Assimp.Unmanaged Namespace


AiExportFormatDesc.Description Field

AiExportFormatDescDescription Field

char*, a short description of the file format to present to users.

Namespace: Assimp.Unmanaged
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public IntPtr Description

Field Value

Type: IntPtr
See Also

Reference

AiExportFormatDesc Structure
Assimp.Unmanaged Namespace


AiExportFormatDesc.FileExtension Field

AiExportFormatDescFileExtension Field

char*, a recommended file extension of the exported file in lower case.

Namespace: Assimp.Unmanaged
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public IntPtr FileExtension

Field Value

Type: IntPtr
See Also

Reference

AiExportFormatDesc Structure
Assimp.Unmanaged Namespace


AiExportFormatDesc.FormatId Field

AiExportFormatDescFormatId Field

char*, a short string ID to uniquely identify the export format. e.g. "collada" or "obj"

Namespace: Assimp.Unmanaged
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public IntPtr FormatId

Field Value

Type: IntPtr
See Also

Reference

AiExportFormatDesc Structure
Assimp.Unmanaged Namespace


AiFace Structure

Represents an aiFace struct.

Namespace: Assimp.Unmanaged
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public struct AiFace

The AiFace type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Indicates whether this instance and a specified object are equal. (Inherited from ValueType.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from ValueType.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns the fully qualified type name of this instance. (Inherited from ValueType.)
Top
Fields
 | Name | Description
Public field | Indices | unsigned int*, array of indices.
Public field | NumIndices | Number of indices in the face.
Top
See Also

Reference

Assimp.Unmanaged Namespace


AiFace Methods

The AiFace type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Indicates whether this instance and a specified object are equal. (Inherited from ValueType.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from ValueType.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns the fully qualified type name of this instance. (Inherited from ValueType.)
Top
See Also

Reference

AiFace Structure
Assimp.Unmanaged Namespace


AiFace Fields

The AiFace type exposes the following members.

Fields
 | Name | Description
Public field | Indices | unsigned int*, array of indices.
Public field | NumIndices | Number of indices in the face.
Top
See Also

Reference

AiFace Structure
Assimp.Unmanaged Namespace


AiFace.Indices Field

AiFaceIndices Field

unsigned int*, array of indices.

Namespace: Assimp.Unmanaged
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public IntPtr Indices

Field Value

Type: IntPtr
See Also

Reference

AiFace Structure
Assimp.Unmanaged Namespace


AiFace.NumIndices Field

AiFaceNumIndices Field

Number of indices in the face.

Namespace: Assimp.Unmanaged
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public uint NumIndices

Field Value

Type: UInt32
See Also

Reference

AiFace Structure
Assimp.Unmanaged Namespace


AiFile Structure

Contains callbacks to read and write to a file opened by a custom file system.

Namespace: Assimp.Unmanaged
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public struct AiFile

The AiFile type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Indicates whether this instance and a specified object are equal. (Inherited from ValueType.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from ValueType.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns the fully qualified type name of this instance. (Inherited from ValueType.)
Top
Fields
 | Name | Description
Public field | FileSizeProc | Function pointer to retrieve the size of the file.
Public field | FlushProc | Function pointer to flush the file contents.
Public field | ReadProc | Function pointer to read from a file.
Public field | SeekProc | Function pointer to set the current position of the file cursor.
Public field | TellProc | Function pointer to retrieve the current position of the file cursor.
Public field | UserData | Char*, user defined opaque data.
Public field | WriteProc | Function pointer to write to a file.
Top
See Also

Reference

Assimp.Unmanaged Namespace


AiFile Methods

The AiFile type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Indicates whether this instance and a specified object are equal. (Inherited from ValueType.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from ValueType.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns the fully qualified type name of this instance. (Inherited from ValueType.)
Top
See Also

Reference

AiFile Structure
Assimp.Unmanaged Namespace


AiFile Fields

The AiFile type exposes the following members.

Fields
 | Name | Description
Public field | FileSizeProc | Function pointer to retrieve the size of the file.
Public field | FlushProc | Function pointer to flush the file contents.
Public field | ReadProc | Function pointer to read from a file.
Public field | SeekProc | Function pointer to set the current position of the file cursor.
Public field | TellProc | Function pointer to retrieve the current position of the file cursor.
Public field | UserData | Char*, user defined opaque data.
Public field | WriteProc | Function pointer to write to a file.
Top
See Also

Reference

AiFile Structure
Assimp.Unmanaged Namespace


AiFile.FileSizeProc Field

AiFileFileSizeProc Field

Function pointer to retrieve the size of the file.

Namespace: Assimp.Unmanaged
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public IntPtr FileSizeProc

Field Value

Type: IntPtr
See Also

Reference

AiFile Structure
Assimp.Unmanaged Namespace


AiFile.FlushProc Field

AiFileFlushProc Field

Function pointer to flush the file contents.

Namespace: Assimp.Unmanaged
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public IntPtr FlushProc

Field Value

Type: IntPtr
See Also

Reference

AiFile Structure
Assimp.Unmanaged Namespace


AiFile.ReadProc Field

AiFileReadProc Field

Function pointer to read from a file.

Namespace: Assimp.Unmanaged
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public IntPtr ReadProc

Field Value

Type: IntPtr
See Also

Reference

AiFile Structure
Assimp.Unmanaged Namespace


AiFile.SeekProc Field

AiFileSeekProc Field

Function pointer to set the current position of the file cursor.

Namespace: Assimp.Unmanaged
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public IntPtr SeekProc

Field Value

Type: IntPtr
See Also

Reference

AiFile Structure
Assimp.Unmanaged Namespace


AiFile.TellProc Field

AiFileTellProc Field

Function pointer to retrieve the current position of the file cursor.

Namespace: Assimp.Unmanaged
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public IntPtr TellProc

Field Value

Type: IntPtr
See Also

Reference

AiFile Structure
Assimp.Unmanaged Namespace


AiFile.UserData Field

AiFileUserData Field

Char*, user defined opaque data.

Namespace: Assimp.Unmanaged
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public IntPtr UserData

Field Value

Type: IntPtr
See Also

Reference

AiFile Structure
Assimp.Unmanaged Namespace


AiFile.WriteProc Field

AiFileWriteProc Field

Function pointer to write to a file.

Namespace: Assimp.Unmanaged
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public IntPtr WriteProc

Field Value

Type: IntPtr
See Also

Reference

AiFile Structure
Assimp.Unmanaged Namespace


AiFileCloseProc Delegate

Callback delegate for a custom file system, to close a given file and free its memory.

Namespace: Assimp.Unmanaged
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public delegate void AiFileCloseProc(
    IntPtr fileIO,
    IntPtr file
)

Parameters

fileIO
Type: SystemIntPtr
Pointer to an AiFileIO instance.
file
Type: SystemIntPtr
Pointer to an AiFile instance that will be closed.
See Also

Reference

Assimp.Unmanaged Namespace


AiFileFlushProc Delegate

Callback delegate for a custom file system, to flush the contents of the file to the disk.

Namespace: Assimp.Unmanaged
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public delegate void AiFileFlushProc(
    IntPtr file
)

Parameters

file
Type: SystemIntPtr
Pointer to an AiFile instance.
See Also

Reference

Assimp.Unmanaged Namespace


AiFileIO Structure

Contains callbacks to implement a custom file system to open and close files.

Namespace: Assimp.Unmanaged
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public struct AiFileIO

The AiFileIO type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Indicates whether this instance and a specified object are equal. (Inherited from ValueType.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from ValueType.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns the fully qualified type name of this instance. (Inherited from ValueType.)
Top
Fields
 | Name | Description
Public field | CloseProc | Function pointer used to close an existing file.
Public field | OpenProc | Function pointer to open a new file.
Public field | UserData | Char*, user defined opaque data.
Top
See Also

Reference

Assimp.Unmanaged Namespace


AiFileIO Methods

The AiFileIO type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Indicates whether this instance and a specified object are equal. (Inherited from ValueType.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from ValueType.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns the fully qualified type name of this instance. (Inherited from ValueType.)
Top
See Also

Reference

AiFileIO Structure
Assimp.Unmanaged Namespace


AiFileIO Fields

The AiFileIO type exposes the following members.

Fields
 | Name | Description
Public field | CloseProc | Function pointer used to close an existing file.
Public field | OpenProc | Function pointer to open a new file.
Public field | UserData | Char*, user defined opaque data.
Top
See Also

Reference

AiFileIO Structure
Assimp.Unmanaged Namespace


AiFileIO.CloseProc Field

AiFileIOCloseProc Field

Function pointer used to close an existing file.

Namespace: Assimp.Unmanaged
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public IntPtr CloseProc

Field Value

Type: IntPtr
See Also

Reference

AiFileIO Structure
Assimp.Unmanaged Namespace


AiFileIO.OpenProc Field

AiFileIOOpenProc Field

Function pointer to open a new file.

Namespace: Assimp.Unmanaged
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public IntPtr OpenProc

Field Value

Type: IntPtr
See Also

Reference

AiFileIO Structure
Assimp.Unmanaged Namespace


AiFileIO.UserData Field

AiFileIOUserData Field

Char*, user defined opaque data.

Namespace: Assimp.Unmanaged
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public IntPtr UserData

Field Value

Type: IntPtr
See Also

Reference

AiFileIO Structure
Assimp.Unmanaged Namespace


AiFileOpenProc Delegate

Callback delegate for a custom file system, to open a given file and create a new AiFile instance.

Namespace: Assimp.Unmanaged
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public delegate IntPtr AiFileOpenProc(
    IntPtr fileIO,
    string pathToFile,
    string mode
)

Parameters

fileIO
Type: SystemIntPtr
Pointer to an AiFileIO instance.
pathToFile
Type: SystemString
Path to the target file
mode
Type: SystemString
Read-write permissions to request

Return Value

Type: IntPtr
Pointer to an AiFile instance.
See Also

Reference

Assimp.Unmanaged Namespace


AiFileReadProc Delegate

Callback delegate for a custom file system, to read from a file.

Namespace: Assimp.Unmanaged
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public delegate UIntPtr AiFileReadProc(
    IntPtr file,
    IntPtr dataToRead,
    UIntPtr sizeOfElemInBytes,
    UIntPtr numElements
)

Parameters

file
Type: SystemIntPtr
Pointer to an AiFile instance.
dataToRead
Type: SystemIntPtr
Char* pointer that will store the data read (casted from a void*)
sizeOfElemInBytes
Type: SystemUIntPtr
Size of a single element in bytes to read
numElements
Type: SystemUIntPtr
Number of elements to read

Return Value

Type: UIntPtr
Number of elements succesfully read. Should be zero if either size or numElements is zero. May be less than numElements if end of file is encountered, or if an error occured.
See Also

Reference

Assimp.Unmanaged Namespace


AiFileSeek Delegate

Callback delegate for a custom file system, to set the current position of the file cursor.

Namespace: Assimp.Unmanaged
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public delegate ReturnCode AiFileSeek(
    IntPtr file,
    UIntPtr offset,
    Origin seekOrigin
)

Parameters

file
Type: SystemIntPtr
Pointer to An AiFile instance.
offset
Type: SystemUIntPtr
Offset from the origin.
seekOrigin
Type: AssimpOrigin
Position used as a reference

Return Value

Type: ReturnCode
Returns success, if successful
See Also

Reference

Assimp.Unmanaged Namespace


AiFileTellProc Delegate

Callback delegate for a custom file system, to tell offset/size information about the file.

Namespace: Assimp.Unmanaged
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public delegate UIntPtr AiFileTellProc(
    IntPtr file
)

Parameters

file
Type: SystemIntPtr
Pointer to an AiFile instance.

Return Value

Type: UIntPtr
Returns the current file cursor or the file size in bytes. May be -1 if an error has occured.
See Also

Reference

Assimp.Unmanaged Namespace


AiFileWriteProc Delegate

Callback delegate for a custom file system, to write to a file.

Namespace: Assimp.Unmanaged
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public delegate UIntPtr AiFileWriteProc(
    IntPtr file,
    IntPtr dataToWrite,
    UIntPtr sizeOfElemInBytes,
    UIntPtr numElements
)

Parameters

file
Type: SystemIntPtr
Pointer to an AiFile instance
dataToWrite
Type: SystemIntPtr
Char* pointer to data to write (casted from a void*)
sizeOfElemInBytes
Type: SystemUIntPtr
Size of a single element in bytes to write
numElements
Type: SystemUIntPtr
Number of elements to write

Return Value

Type: UIntPtr
Number of elements successfully written. Should be zero if either size or numElements is zero. May be less than numElements if an error occured.
See Also

Reference

Assimp.Unmanaged Namespace


AiImporterDesc Structure

Describes a variety of information about an importer.

Namespace: Assimp.Unmanaged
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public struct AiImporterDesc

The AiImporterDesc type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Indicates whether this instance and a specified object are equal. (Inherited from ValueType.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from ValueType.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns the fully qualified type name of this instance. (Inherited from ValueType.)
Top
Fields
 | Name | Description
Public field | Author | char*, original author (blank if unknown or assimp team)
Public field | Comments | char*, implementation comments. E.g. unimplemented features.
Public field | FileExtensions | char*, list of file extensions the importer can handle. Entries are separated by space characters, and all entries are lower case WITHOUT a leading dot. (e.g. "xml dae"). Multiple importers may respond to the same file extension, assim
Public field | Flags | unsigned int, features supported by the importer.
Public field | Maintainer | char*, current maintainer, left blank if the author maintains.
Public field | MaxMajor | unsigned int, max major version of format supported. If no version scheme, forwards compatible, or importer doesn't care, will be zero.
Public field | MaxMinor | unsigned int, min major version of format supported. If no version scheme, forwards compatible, or importer doesn't care, will be zero.
Public field | MinMajor | unsigned int, max major version of format supported. If no version scheme or importer doesn't care, will be zero.
Public field | MinMinor | unsigned int, min major version of format supported. If no version scheme or importer doesn't care, will be zero.
Public field | Name | char*, full name of the importer (e.g. Blender3D Importer)
Top
See Also

Reference

Assimp.Unmanaged Namespace


AiImporterDesc Methods

The AiImporterDesc type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Indicates whether this instance and a specified object are equal. (Inherited from ValueType.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from ValueType.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns the fully qualified type name of this instance. (Inherited from ValueType.)
Top
See Also

Reference

AiImporterDesc Structure
Assimp.Unmanaged Namespace


AiImporterDesc Fields

The AiImporterDesc type exposes the following members.

Fields
 | Name | Description
Public field | Author | char*, original author (blank if unknown or assimp team)
Public field | Comments | char*, implementation comments. E.g. unimplemented features.
Public field | FileExtensions | char*, list of file extensions the importer can handle. Entries are separated by space characters, and all entries are lower case WITHOUT a leading dot. (e.g. "xml dae"). Multiple importers may respond to the same file extension, assim
Public field | Flags | unsigned int, features supported by the importer.
Public field | Maintainer | char*, current maintainer, left blank if the author maintains.
Public field | MaxMajor | unsigned int, max major version of format supported. If no version scheme, forwards compatible, or importer doesn't care, will be zero.
Public field | MaxMinor | unsigned int, min major version of format supported. If no version scheme, forwards compatible, or importer doesn't care, will be zero.
Public field | MinMajor | unsigned int, max major version of format supported. If no version scheme or importer doesn't care, will be zero.
Public field | MinMinor | unsigned int, min major version of format supported. If no version scheme or importer doesn't care, will be zero.
Public field | Name | char*, full name of the importer (e.g. Blender3D Importer)
Top
See Also

Reference

AiImporterDesc Structure
Assimp.Unmanaged Namespace


AiImporterDesc.Author Field

AiImporterDescAuthor Field

char*, original author (blank if unknown or assimp team)

Namespace: Assimp.Unmanaged
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public IntPtr Author

Field Value

Type: IntPtr
See Also

Reference

AiImporterDesc Structure
Assimp.Unmanaged Namespace


AiImporterDesc.Comments Field

AiImporterDescComments Field

char*, implementation comments. E.g. unimplemented features.

Namespace: Assimp.Unmanaged
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public IntPtr Comments

Field Value

Type: IntPtr
See Also

Reference

AiImporterDesc Structure
Assimp.Unmanaged Namespace


AiImporterDesc.FileExtensions Field

AiImporterDescFileExtensions Field

char*, list of file extensions the importer can handle. Entries are separated by space characters, and all entries are lower case WITHOUT a leading dot. (e.g. "xml dae"). Multiple importers may respond to the same file extension, assim

Namespace: Assimp.Unmanaged
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public IntPtr FileExtensions

Field Value

Type: IntPtr
See Also

Reference

AiImporterDesc Structure
Assimp.Unmanaged Namespace


AiImporterDesc.Flags Field

AiImporterDescFlags Field

unsigned int, features supported by the importer.

Namespace: Assimp.Unmanaged
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public ImporterFeatureFlags Flags

Field Value

Type: ImporterFeatureFlags
See Also

Reference

AiImporterDesc Structure
Assimp.Unmanaged Namespace


AiImporterDesc.Maintainer Field

AiImporterDescMaintainer Field

char*, current maintainer, left blank if the author maintains.

Namespace: Assimp.Unmanaged
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public IntPtr Maintainer

Field Value

Type: IntPtr
See Also

Reference

AiImporterDesc Structure
Assimp.Unmanaged Namespace


AiImporterDesc.MaxMajor Field

AiImporterDescMaxMajor Field

unsigned int, max major version of format supported. If no version scheme, forwards compatible, or importer doesn't care, will be zero.

Namespace: Assimp.Unmanaged
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public uint MaxMajor

Field Value

Type: UInt32
See Also

Reference

AiImporterDesc Structure
Assimp.Unmanaged Namespace


AiImporterDesc.MaxMinor Field

AiImporterDescMaxMinor Field

unsigned int, min major version of format supported. If no version scheme, forwards compatible, or importer doesn't care, will be zero.

Namespace: Assimp.Unmanaged
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public uint MaxMinor

Field Value

Type: UInt32
See Also

Reference

AiImporterDesc Structure
Assimp.Unmanaged Namespace


AiImporterDesc.MinMajor Field

AiImporterDescMinMajor Field

unsigned int, max major version of format supported. If no version scheme or importer doesn't care, will be zero.

Namespace: Assimp.Unmanaged
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public uint MinMajor

Field Value

Type: UInt32
See Also

Reference

AiImporterDesc Structure
Assimp.Unmanaged Namespace


AiImporterDesc.MinMinor Field

AiImporterDescMinMinor Field

unsigned int, min major version of format supported. If no version scheme or importer doesn't care, will be zero.

Namespace: Assimp.Unmanaged
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public uint MinMinor

Field Value

Type: UInt32
See Also

Reference

AiImporterDesc Structure
Assimp.Unmanaged Namespace


AiImporterDesc.Name Field

AiImporterDescName Field

char*, full name of the importer (e.g. Blender3D Importer)

Namespace: Assimp.Unmanaged
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public IntPtr Name

Field Value

Type: IntPtr
See Also

Reference

AiImporterDesc Structure
Assimp.Unmanaged Namespace


AiLight Structure

Represents an aiLight struct.

Namespace: Assimp.Unmanaged
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public struct AiLight

The AiLight type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Indicates whether this instance and a specified object are equal. (Inherited from ValueType.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from ValueType.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns the fully qualified type name of this instance. (Inherited from ValueType.)
Top
Fields
 | Name | Description
Public field | AngleInnerCone | Spot light inner angle.
Public field | AngleOuterCone | Spot light outer angle.
Public field | AreaSize | Width (X) and Height (Y) of the area that represents an Area light.
Public field | AttenuationConstant | Attenuation constant value.
Public field | AttenuationLinear | Attenuation linear value.
Public field | AttenuationQuadratic | Attenuation quadratic value.
Public field | ColorAmbient | Ambient color.
Public field | ColorDiffuse | Diffuse color.
Public field | ColorSpecular | Specular color.
Public field | Direction | Direction of the spot/directional light.
Public field | Name | Name of the light.
Public field | Position | Position of the light.
Public field | Type | Type of light.
Public field | Up | Up direction of the light source in space. Undefined for point lights.
Top
See Also

Reference

Assimp.Unmanaged Namespace


AiLight Methods

The AiLight type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Indicates whether this instance and a specified object are equal. (Inherited from ValueType.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from ValueType.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns the fully qualified type name of this instance. (Inherited from ValueType.)
Top
See Also

Reference

AiLight Structure
Assimp.Unmanaged Namespace


AiLight Fields

The AiLight type exposes the following members.

Fields
 | Name | Description
Public field | AngleInnerCone | Spot light inner angle.
Public field | AngleOuterCone | Spot light outer angle.
Public field | AreaSize | Width (X) and Height (Y) of the area that represents an Area light.
Public field | AttenuationConstant | Attenuation constant value.
Public field | AttenuationLinear | Attenuation linear value.
Public field | AttenuationQuadratic | Attenuation quadratic value.
Public field | ColorAmbient | Ambient color.
Public field | ColorDiffuse | Diffuse color.
Public field | ColorSpecular | Specular color.
Public field | Direction | Direction of the spot/directional light.
Public field | Name | Name of the light.
Public field | Position | Position of the light.
Public field | Type | Type of light.
Public field | Up | Up direction of the light source in space. Undefined for point lights.
Top
See Also

Reference

AiLight Structure
Assimp.Unmanaged Namespace


AiLight.AngleInnerCone Field

AiLightAngleInnerCone Field

Spot light inner angle.

Namespace: Assimp.Unmanaged
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public float AngleInnerCone

Field Value

Type: Single
See Also

Reference

AiLight Structure
Assimp.Unmanaged Namespace


AiLight.AngleOuterCone Field

AiLightAngleOuterCone Field

Spot light outer angle.

Namespace: Assimp.Unmanaged
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public float AngleOuterCone

Field Value

Type: Single
See Also

Reference

AiLight Structure
Assimp.Unmanaged Namespace


AiLight.AreaSize Field

AiLightAreaSize Field

Width (X) and Height (Y) of the area that represents an Area light.

Namespace: Assimp.Unmanaged
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public Vector2D AreaSize

Field Value

Type: Vector2D
See Also

Reference

AiLight Structure
Assimp.Unmanaged Namespace


AiLight.AttenuationConstant Field

AiLightAttenuationConstant Field

Attenuation constant value.

Namespace: Assimp.Unmanaged
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public float AttenuationConstant

Field Value

Type: Single
See Also

Reference

AiLight Structure
Assimp.Unmanaged Namespace


AiLight.AttenuationLinear Field

AiLightAttenuationLinear Field

Attenuation linear value.

Namespace: Assimp.Unmanaged
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public float AttenuationLinear

Field Value

Type: Single
See Also

Reference

AiLight Structure
Assimp.Unmanaged Namespace


AiLight.AttenuationQuadratic Field

AiLightAttenuationQuadratic Field

Attenuation quadratic value.

Namespace: Assimp.Unmanaged
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public float AttenuationQuadratic

Field Value

Type: Single
See Also

Reference

AiLight Structure
Assimp.Unmanaged Namespace


AiLight.ColorAmbient Field

AiLightColorAmbient Field

Ambient color.

Namespace: Assimp.Unmanaged
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public Color3D ColorAmbient

Field Value

Type: Color3D
See Also

Reference

AiLight Structure
Assimp.Unmanaged Namespace


AiLight.ColorDiffuse Field

AiLightColorDiffuse Field

Diffuse color.

Namespace: Assimp.Unmanaged
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public Color3D ColorDiffuse

Field Value

Type: Color3D
See Also

Reference

AiLight Structure
Assimp.Unmanaged Namespace


AiLight.ColorSpecular Field

AiLightColorSpecular Field

Specular color.

Namespace: Assimp.Unmanaged
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public Color3D ColorSpecular

Field Value

Type: Color3D
See Also

Reference

AiLight Structure
Assimp.Unmanaged Namespace


AiLight.Direction Field

AiLightDirection Field

Direction of the spot/directional light.

Namespace: Assimp.Unmanaged
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public Vector3D Direction

Field Value

Type: Vector3D
See Also

Reference

AiLight Structure
Assimp.Unmanaged Namespace


AiLight.Name Field

AiLightName Field

Name of the light.

Namespace: Assimp.Unmanaged
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public AiString Name

Field Value

Type: AiString
See Also

Reference

AiLight Structure
Assimp.Unmanaged Namespace


AiLight.Position Field

AiLightPosition Field

Position of the light.

Namespace: Assimp.Unmanaged
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public Vector3D Position

Field Value

Type: Vector3D
See Also

Reference

AiLight Structure
Assimp.Unmanaged Namespace


AiLight.Type Field

AiLightType Field

Type of light.

Namespace: Assimp.Unmanaged
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public LightSourceType Type

Field Value

Type: LightSourceType
See Also

Reference

AiLight Structure
Assimp.Unmanaged Namespace


AiLight.Up Field

AiLightUp Field

Up direction of the light source in space. Undefined for point lights.

Namespace: Assimp.Unmanaged
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public Vector3D Up

Field Value

Type: Vector3D
See Also

Reference

AiLight Structure
Assimp.Unmanaged Namespace


AiLogStream Structure

Represents a log stream, which receives all log messages and streams them somewhere.

Namespace: Assimp.Unmanaged
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public struct AiLogStream

The AiLogStream type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Indicates whether this instance and a specified object are equal. (Inherited from ValueType.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from ValueType.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns the fully qualified type name of this instance. (Inherited from ValueType.)
Top
Fields
 | Name | Description
Public field | Callback | Function pointer that gets called when a message is to be logged.
Public field | UserData | char*, user defined opaque data.
Top
See Also

Reference

Assimp.Unmanaged Namespace


AiLogStream Methods

The AiLogStream type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Indicates whether this instance and a specified object are equal. (Inherited from ValueType.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from ValueType.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns the fully qualified type name of this instance. (Inherited from ValueType.)
Top
See Also

Reference

AiLogStream Structure
Assimp.Unmanaged Namespace


AiLogStream Fields

The AiLogStream type exposes the following members.

Fields
 | Name | Description
Public field | Callback | Function pointer that gets called when a message is to be logged.
Public field | UserData | char*, user defined opaque data.
Top
See Also

Reference

AiLogStream Structure
Assimp.Unmanaged Namespace


AiLogStream.Callback Field

AiLogStreamCallback Field

Function pointer that gets called when a message is to be logged.

Namespace: Assimp.Unmanaged
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public IntPtr Callback

Field Value

Type: IntPtr
See Also

Reference

AiLogStream Structure
Assimp.Unmanaged Namespace


AiLogStream.UserData Field

AiLogStreamUserData Field

char*, user defined opaque data.

Namespace: Assimp.Unmanaged
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public IntPtr UserData

Field Value

Type: IntPtr
See Also

Reference

AiLogStream Structure
Assimp.Unmanaged Namespace


AiLogStreamCallback Delegate

Callback delegate for Assimp's LogStream.

Namespace: Assimp.Unmanaged
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public delegate void AiLogStreamCallback(
    string msg,
    IntPtr userData
)

Parameters

msg
Type: SystemString
Log message
userData
Type: SystemIntPtr
char* pointer to user data that is passed to the callback
See Also

Reference

Assimp.Unmanaged Namespace


AiMaterial Structure

Represents an aiMaterial struct.

Namespace: Assimp.Unmanaged
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public struct AiMaterial

The AiMaterial type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Indicates whether this instance and a specified object are equal. (Inherited from ValueType.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from ValueType.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns the fully qualified type name of this instance. (Inherited from ValueType.)
Top
Fields
 | Name | Description
Public field | NumAllocated | Storage allocated for key-value properties.
Public field | NumProperties | Number of key-value properties.
Public field | Properties | aiMaterialProperty**, array of material properties.
Top
See Also

Reference

Assimp.Unmanaged Namespace


AiMaterial Methods

The AiMaterial type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Indicates whether this instance and a specified object are equal. (Inherited from ValueType.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from ValueType.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns the fully qualified type name of this instance. (Inherited from ValueType.)
Top
See Also

Reference

AiMaterial Structure
Assimp.Unmanaged Namespace


AiMaterial Fields

The AiMaterial type exposes the following members.

Fields
 | Name | Description
Public field | NumAllocated | Storage allocated for key-value properties.
Public field | NumProperties | Number of key-value properties.
Public field | Properties | aiMaterialProperty**, array of material properties.
Top
See Also

Reference

AiMaterial Structure
Assimp.Unmanaged Namespace


AiMaterial.NumAllocated Field

AiMaterialNumAllocated Field

Storage allocated for key-value properties.

Namespace: Assimp.Unmanaged
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public uint NumAllocated

Field Value

Type: UInt32
See Also

Reference

AiMaterial Structure
Assimp.Unmanaged Namespace


AiMaterial.NumProperties Field

AiMaterialNumProperties Field

Number of key-value properties.

Namespace: Assimp.Unmanaged
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public uint NumProperties

Field Value

Type: UInt32
See Also

Reference

AiMaterial Structure
Assimp.Unmanaged Namespace


AiMaterial.Properties Field

AiMaterialProperties Field

aiMaterialProperty**, array of material properties.

Namespace: Assimp.Unmanaged
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public IntPtr Properties

Field Value

Type: IntPtr
See Also

Reference

AiMaterial Structure
Assimp.Unmanaged Namespace


AiMaterialProperty Structure

Represents an aiMaterialProperty struct.

Namespace: Assimp.Unmanaged
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public struct AiMaterialProperty

The AiMaterialProperty type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Indicates whether this instance and a specified object are equal. (Inherited from ValueType.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from ValueType.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns the fully qualified type name of this instance. (Inherited from ValueType.)
Top
Fields
 | Name | Description
Public field | Data | char*, byte buffer to hold the property's value.
Public field | DataLength | Size of the buffer data in bytes. This value may not be zero.
Public field | Index | Textures: Specifies the index of the texture. For non-texture properties this is always zero.
Public field | Key | Name of the property (key).
Public field | Semantic | Textures: Specifies texture usage. None texture properties have this zero (or None).
Public field | Type | Type of value contained in the buffer.
Top
See Also

Reference

Assimp.Unmanaged Namespace


AiMaterialProperty Methods

The AiMaterialProperty type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Indicates whether this instance and a specified object are equal. (Inherited from ValueType.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from ValueType.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns the fully qualified type name of this instance. (Inherited from ValueType.)
Top
See Also

Reference

AiMaterialProperty Structure
Assimp.Unmanaged Namespace


AiMaterialProperty Fields

The AiMaterialProperty type exposes the following members.

Fields
 | Name | Description
Public field | Data | char*, byte buffer to hold the property's value.
Public field | DataLength | Size of the buffer data in bytes. This value may not be zero.
Public field | Index | Textures: Specifies the index of the texture. For non-texture properties this is always zero.
Public field | Key | Name of the property (key).
Public field | Semantic | Textures: Specifies texture usage. None texture properties have this zero (or None).
Public field | Type | Type of value contained in the buffer.
Top
See Also

Reference

AiMaterialProperty Structure
Assimp.Unmanaged Namespace


AiMaterialProperty.Data Field

AiMaterialPropertyData Field

char*, byte buffer to hold the property's value.

Namespace: Assimp.Unmanaged
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public IntPtr Data

Field Value

Type: IntPtr
See Also

Reference

AiMaterialProperty Structure
Assimp.Unmanaged Namespace


AiMaterialProperty.DataLength Field

AiMaterialPropertyDataLength Field

Size of the buffer data in bytes. This value may not be zero.

Namespace: Assimp.Unmanaged
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public uint DataLength

Field Value

Type: UInt32
See Also

Reference

AiMaterialProperty Structure
Assimp.Unmanaged Namespace


AiMaterialProperty.Index Field

AiMaterialPropertyIndex Field

Textures: Specifies the index of the texture. For non-texture properties this is always zero.

Namespace: Assimp.Unmanaged
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public uint Index

Field Value

Type: UInt32
See Also

Reference

AiMaterialProperty Structure
Assimp.Unmanaged Namespace


AiMaterialProperty.Key Field

AiMaterialPropertyKey Field

Name of the property (key).

Namespace: Assimp.Unmanaged
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public AiString Key

Field Value

Type: AiString
See Also

Reference

AiMaterialProperty Structure
Assimp.Unmanaged Namespace


AiMaterialProperty.Semantic Field

AiMaterialPropertySemantic Field

Textures: Specifies texture usage. None texture properties have this zero (or None).

Namespace: Assimp.Unmanaged
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public TextureType Semantic

Field Value

Type: TextureType
See Also

Reference

AiMaterialProperty Structure
Assimp.Unmanaged Namespace


AiMaterialProperty.Type Field

AiMaterialPropertyType Field

Type of value contained in the buffer.

Namespace: Assimp.Unmanaged
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public PropertyType Type

Field Value

Type: PropertyType
See Also

Reference

AiMaterialProperty Structure
Assimp.Unmanaged Namespace


AiMatKeys Class

Static class containing material key constants. A fully qualified mat key name here means that it's a string that combines the mat key (base) name, its texture type semantic, and its texture index into a single string delimited by commas. For non-texture material properties, the texture type semantic and texture index are always zero.
Inheritance Hierarchy
SystemObject
Assimp.UnmanagedAiMatKeys

Namespace: Assimp.Unmanaged
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public static class AiMatKeys

The AiMatKeys type exposes the following members.

Methods
Name | Description
GetBaseName | Helper function to get the base name from a fully qualified name of a material property type name. The format of such a string is: "baseName,TextureType,texIndex"
GetFullTextureName | Helper function to get the fully qualified name of a texture property type name. Takes in a base name constant, a texture type, and a texture index and outputs the name in the format: "baseName,TextureType,texIndex"
Top
Fields
Name | Description
BLEND_FUNC | Blending function (BlendMode)
BLEND_FUNC_BASE | Blending function (BlendMode)
BUMPSCALING | Bumpscaling (float)
BUMPSCALING_BASE | Bumpscaling (float)
COLOR_AMBIENT | Ambient color (Color4D)
COLOR_AMBIENT_BASE | Ambient color (Color4D)
COLOR_DIFFUSE | Diffuse color (Color4D)
COLOR_DIFFUSE_BASE | Diffuse color (Color4D)
COLOR_EMISSIVE | Emissive color (Color4D)
COLOR_EMISSIVE_BASE | Emissive color (Color4D)
COLOR_REFLECTIVE | Reflective color (Color4D)
COLOR_REFLECTIVE_BASE | Reflective color (Color4D)
COLOR_SPECULAR | Specular color (Color4D)
COLOR_SPECULAR_BASE | Specular color (Color4D)
COLOR_TRANSPARENT | Transparent color (Color4D)
COLOR_TRANSPARENT_BASE | Transparent color (Color4D)
ENABLE_WIREFRAME | Enable wireframe property (boolean)
ENABLE_WIREFRAME_BASE | Enable wireframe property (boolean)
GLOBAL_BACKGROUND_IMAGE | Background image (String)
GLOBAL_BACKGROUND_IMAGE_BASE | Background image (String)
MAPPING_BASE | Mapping base name
MAPPINGMODE_U_BASE | Mapping mode U base name
MAPPINGMODE_V_BASE | Mapping mode V base name
NAME | Material name (String)
NAME_BASE | Material name (String)
OPACITY | Opacity (float)
OPACITY_BASE | Opacity (float)
REFLECTIVITY | Reflectivity (float)
REFLECTIVITY_BASE | Reflectivity (float)
REFRACTI | Refracti (float)
REFRACTI_BASE | Refracti (float)
SHADING_MODEL | Shading mode property (ShadingMode)
SHADING_MODEL_BASE | Shading mode property (ShadingMode)
SHININESS | Shininess (float)
SHININESS_BASE | Shininess (float)
SHININESS_STRENGTH | Shininess strength (float)
SHININESS_STRENGTH_BASE | Shininess strength (float)
TEXBLEND_BASE | Texture blend base name.
TEXFLAGS_BASE | Texture flags base name
TEXMAP_AXIS_BASE | Texture map axis base name
TEXOP_BASE | Texture op base name
TEXTURE_BASE | Texture base name
TWOSIDED | Two sided property (boolean)
TWOSIDED_BASE | Two sided property (boolean)
UVTRANSFORM_BASE | UV transform base name
UVWSRC_BASE | UVWSRC base name
Top
See Also

Reference

Assimp.Unmanaged Namespace


AiMatKeys Methods

The AiMatKeys type exposes the following members.

Methods
Name | Description
GetBaseName | Helper function to get the base name from a fully qualified name of a material property type name. The format of such a string is: "baseName,TextureType,texIndex"
GetFullTextureName | Helper function to get the fully qualified name of a texture property type name. Takes in a base name constant, a texture type, and a texture index and outputs the name in the format: "baseName,TextureType,texIndex"
Top
See Also

Reference

AiMatKeys Class
Assimp.Unmanaged Namespace


AiMatKeys.GetBaseName Method

AiMatKeysGetBaseName Method

Helper function to get the base name from a fully qualified name of a material property type name. The format of such a string is:

"baseName,TextureType,texIndex"

Namespace: Assimp.Unmanaged
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public static string GetBaseName(
    string fullyQualifiedName
)

Parameters

fullyQualifiedName
Type: SystemString
Fully qualified material property name.

Return Value

Type: String
Base name of the property type.
See Also

Reference

AiMatKeys Class
Assimp.Unmanaged Namespace


AiMatKeys.GetFullTextureName Method

AiMatKeysGetFullTextureName Method

Helper function to get the fully qualified name of a texture property type name. Takes in a base name constant, a texture type, and a texture index and outputs the name in the format:

"baseName,TextureType,texIndex"

Namespace: Assimp.Unmanaged
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public static string GetFullTextureName(
    string baseName,
    TextureType texType,
    int texIndex
)

Parameters

baseName
Type: SystemString
Base name
texType
Type: AssimpTextureType
Texture type
texIndex
Type: SystemInt32
Texture index

Return Value

Type: String
Fully qualified texture name
See Also

Reference

AiMatKeys Class
Assimp.Unmanaged Namespace


AiMatKeys Fields

The AiMatKeys type exposes the following members.

Fields
Name | Description
BLEND_FUNC | Blending function (BlendMode)
BLEND_FUNC_BASE | Blending function (BlendMode)
BUMPSCALING | Bumpscaling (float)
BUMPSCALING_BASE | Bumpscaling (float)
COLOR_AMBIENT | Ambient color (Color4D)
COLOR_AMBIENT_BASE | Ambient color (Color4D)
COLOR_DIFFUSE | Diffuse color (Color4D)
COLOR_DIFFUSE_BASE | Diffuse color (Color4D)
COLOR_EMISSIVE | Emissive color (Color4D)
COLOR_EMISSIVE_BASE | Emissive color (Color4D)
COLOR_REFLECTIVE | Reflective color (Color4D)
COLOR_REFLECTIVE_BASE | Reflective color (Color4D)
COLOR_SPECULAR | Specular color (Color4D)
COLOR_SPECULAR_BASE | Specular color (Color4D)
COLOR_TRANSPARENT | Transparent color (Color4D)
COLOR_TRANSPARENT_BASE | Transparent color (Color4D)
ENABLE_WIREFRAME | Enable wireframe property (boolean)
ENABLE_WIREFRAME_BASE | Enable wireframe property (boolean)
GLOBAL_BACKGROUND_IMAGE | Background image (String)
GLOBAL_BACKGROUND_IMAGE_BASE | Background image (String)
MAPPING_BASE | Mapping base name
MAPPINGMODE_U_BASE | Mapping mode U base name
MAPPINGMODE_V_BASE | Mapping mode V base name
NAME | Material name (String)
NAME_BASE | Material name (String)
OPACITY | Opacity (float)
OPACITY_BASE | Opacity (float)
REFLECTIVITY | Reflectivity (float)
REFLECTIVITY_BASE | Reflectivity (float)
REFRACTI | Refracti (float)
REFRACTI_BASE | Refracti (float)
SHADING_MODEL | Shading mode property (ShadingMode)
SHADING_MODEL_BASE | Shading mode property (ShadingMode)
SHININESS | Shininess (float)
SHININESS_BASE | Shininess (float)
SHININESS_STRENGTH | Shininess strength (float)
SHININESS_STRENGTH_BASE | Shininess strength (float)
TEXBLEND_BASE | Texture blend base name.
TEXFLAGS_BASE | Texture flags base name
TEXMAP_AXIS_BASE | Texture map axis base name
TEXOP_BASE | Texture op base name
TEXTURE_BASE | Texture base name
TWOSIDED | Two sided property (boolean)
TWOSIDED_BASE | Two sided property (boolean)
UVTRANSFORM_BASE | UV transform base name
UVWSRC_BASE | UVWSRC base name
Top
See Also

Reference

AiMatKeys Class
Assimp.Unmanaged Namespace


AiMatKeys.BLEND_FUNC Field

AiMatKeysBLEND_FUNC Field

Blending function (BlendMode)

Namespace: Assimp.Unmanaged
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public const string BLEND_FUNC = "$mat.blend,0,0"

Field Value

Type: String
See Also

Reference

AiMatKeys Class
Assimp.Unmanaged Namespace


AiMatKeys.BLEND_FUNC_BASE Field

AiMatKeysBLEND_FUNC_BASE Field

Blending function (BlendMode)

Namespace: Assimp.Unmanaged
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public const string BLEND_FUNC_BASE = "$mat.blend"

Field Value

Type: String
See Also

Reference

AiMatKeys Class
Assimp.Unmanaged Namespace


AiMatKeys.BUMPSCALING Field

AiMatKeysBUMPSCALING Field

Bumpscaling (float)

Namespace: Assimp.Unmanaged
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public const string BUMPSCALING = "$mat.bumpscaling,0,0"

Field Value

Type: String
See Also

Reference

AiMatKeys Class
Assimp.Unmanaged Namespace


AiMatKeys.BUMPSCALING_BASE Field

AiMatKeysBUMPSCALING_BASE Field

Bumpscaling (float)

Namespace: Assimp.Unmanaged
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public const string BUMPSCALING_BASE = "$mat.bumpscaling"

Field Value

Type: String
See Also

Reference

AiMatKeys Class
Assimp.Unmanaged Namespace


AiMatKeys.COLOR_AMBIENT Field

AiMatKeysCOLOR_AMBIENT Field

Ambient color (Color4D)

Namespace: Assimp.Unmanaged
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public const string COLOR_AMBIENT = "$clr.ambient,0,0"

Field Value

Type: String
See Also

Reference

AiMatKeys Class
Assimp.Unmanaged Namespace


AiMatKeys.COLOR_AMBIENT_BASE Field

AiMatKeysCOLOR_AMBIENT_BASE Field

Ambient color (Color4D)

Namespace: Assimp.Unmanaged
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public const string COLOR_AMBIENT_BASE = "$clr.ambient"

Field Value

Type: String
See Also

Reference

AiMatKeys Class
Assimp.Unmanaged Namespace


AiMatKeys.COLOR_DIFFUSE Field

AiMatKeysCOLOR_DIFFUSE Field

Diffuse color (Color4D)

Namespace: Assimp.Unmanaged
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public const string COLOR_DIFFUSE = "$clr.diffuse,0,0"

Field Value

Type: String
See Also

Reference

AiMatKeys Class
Assimp.Unmanaged Namespace


AiMatKeys.COLOR_DIFFUSE_BASE Field

AiMatKeysCOLOR_DIFFUSE_BASE Field

Diffuse color (Color4D)

Namespace: Assimp.Unmanaged
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public const string COLOR_DIFFUSE_BASE = "$clr.diffuse"

Field Value

Type: String
See Also

Reference

AiMatKeys Class
Assimp.Unmanaged Namespace


AiMatKeys.COLOR_EMISSIVE Field

AiMatKeysCOLOR_EMISSIVE Field

Emissive color (Color4D)

Namespace: Assimp.Unmanaged
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public const string COLOR_EMISSIVE = "$clr.emissive,0,0"

Field Value

Type: String
See Also

Reference

AiMatKeys Class
Assimp.Unmanaged Namespace


AiMatKeys.COLOR_EMISSIVE_BASE Field

AiMatKeysCOLOR_EMISSIVE_BASE Field

Emissive color (Color4D)

Namespace: Assimp.Unmanaged
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public const string COLOR_EMISSIVE_BASE = "$clr.emissive"

Field Value

Type: String
See Also

Reference

AiMatKeys Class
Assimp.Unmanaged Namespace


AiMatKeys.COLOR_REFLECTIVE Field

AiMatKeysCOLOR_REFLECTIVE Field

Reflective color (Color4D)

Namespace: Assimp.Unmanaged
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public const string COLOR_REFLECTIVE = "$clr.reflective,0,0"

Field Value

Type: String
See Also

Reference

AiMatKeys Class
Assimp.Unmanaged Namespace


AiMatKeys.COLOR_REFLECTIVE_BASE Field

AiMatKeysCOLOR_REFLECTIVE_BASE Field

Reflective color (Color4D)

Namespace: Assimp.Unmanaged
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public const string COLOR_REFLECTIVE_BASE = "$clr.reflective"

Field Value

Type: String
See Also

Reference

AiMatKeys Class
Assimp.Unmanaged Namespace


AiMatKeys.COLOR_SPECULAR Field

AiMatKeysCOLOR_SPECULAR Field

Specular color (Color4D)

Namespace: Assimp.Unmanaged
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public const string COLOR_SPECULAR = "$clr.specular,0,0"

Field Value

Type: String
See Also

Reference

AiMatKeys Class
Assimp.Unmanaged Namespace


AiMatKeys.COLOR_SPECULAR_BASE Field

AiMatKeysCOLOR_SPECULAR_BASE Field

Specular color (Color4D)

Namespace: Assimp.Unmanaged
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public const string COLOR_SPECULAR_BASE = "$clr.specular"

Field Value

Type: String
See Also

Reference

AiMatKeys Class
Assimp.Unmanaged Namespace


AiMatKeys.COLOR_TRANSPARENT Field

AiMatKeysCOLOR_TRANSPARENT Field

Transparent color (Color4D)

Namespace: Assimp.Unmanaged
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public const string COLOR_TRANSPARENT = "$clr.transparent,0,0"

Field Value

Type: String
See Also

Reference

AiMatKeys Class
Assimp.Unmanaged Namespace


AiMatKeys.COLOR_TRANSPARENT_BASE Field

AiMatKeysCOLOR_TRANSPARENT_BASE Field

Transparent color (Color4D)

Namespace: Assimp.Unmanaged
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public const string COLOR_TRANSPARENT_BASE = "$clr.transparent"

Field Value

Type: String
See Also

Reference

AiMatKeys Class
Assimp.Unmanaged Namespace


AiMatKeys.ENABLE_WIREFRAME Field

AiMatKeysENABLE_WIREFRAME Field

Enable wireframe property (boolean)

Namespace: Assimp.Unmanaged
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public const string ENABLE_WIREFRAME = "$mat.wireframe,0,0"

Field Value

Type: String
See Also

Reference

AiMatKeys Class
Assimp.Unmanaged Namespace


AiMatKeys.ENABLE_WIREFRAME_BASE Field

AiMatKeysENABLE_WIREFRAME_BASE Field

Enable wireframe property (boolean)

Namespace: Assimp.Unmanaged
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public const string ENABLE_WIREFRAME_BASE = "$mat.wireframe"

Field Value

Type: String
See Also

Reference

AiMatKeys Class
Assimp.Unmanaged Namespace


AiMatKeys.GLOBAL_BACKGROUND_IMAGE Field

AiMatKeysGLOBAL_BACKGROUND_IMAGE Field

Background image (String)

Namespace: Assimp.Unmanaged
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public const string GLOBAL_BACKGROUND_IMAGE = "?bg.global,0,0"

Field Value

Type: String
See Also

Reference

AiMatKeys Class
Assimp.Unmanaged Namespace


AiMatKeys.GLOBAL_BACKGROUND_IMAGE_BASE Field

AiMatKeysGLOBAL_BACKGROUND_IMAGE_BASE Field

Background image (String)

Namespace: Assimp.Unmanaged
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public const string GLOBAL_BACKGROUND_IMAGE_BASE = "?bg.global"

Field Value

Type: String
See Also

Reference

AiMatKeys Class
Assimp.Unmanaged Namespace


AiMatKeys.MAPPING_BASE Field

AiMatKeysMAPPING_BASE Field

Mapping base name

Namespace: Assimp.Unmanaged
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public const string MAPPING_BASE = "$tex.mapping"

Field Value

Type: String
See Also

Reference

AiMatKeys Class
Assimp.Unmanaged Namespace


AiMatKeys.MAPPINGMODE_U_BASE Field

AiMatKeysMAPPINGMODE_U_BASE Field

Mapping mode U base name

Namespace: Assimp.Unmanaged
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public const string MAPPINGMODE_U_BASE = "$tex.mapmodeu"

Field Value

Type: String
See Also

Reference

AiMatKeys Class
Assimp.Unmanaged Namespace


AiMatKeys.MAPPINGMODE_V_BASE Field

AiMatKeysMAPPINGMODE_V_BASE Field

Mapping mode V base name

Namespace: Assimp.Unmanaged
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public const string MAPPINGMODE_V_BASE = "$tex.mapmodev"

Field Value

Type: String
See Also

Reference

AiMatKeys Class
Assimp.Unmanaged Namespace


AiMatKeys.NAME Field

AiMatKeysNAME Field

Material name (String)

Namespace: Assimp.Unmanaged
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public const string NAME = "?mat.name,0,0"

Field Value

Type: String
See Also

Reference

AiMatKeys Class
Assimp.Unmanaged Namespace


AiMatKeys.NAME_BASE Field

AiMatKeysNAME_BASE Field

Material name (String)

Namespace: Assimp.Unmanaged
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public const string NAME_BASE = "?mat.name"

Field Value

Type: String
See Also

Reference

AiMatKeys Class
Assimp.Unmanaged Namespace


AiMatKeys.OPACITY Field

AiMatKeysOPACITY Field

Opacity (float)

Namespace: Assimp.Unmanaged
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public const string OPACITY = "$mat.opacity,0,0"

Field Value

Type: String
See Also

Reference

AiMatKeys Class
Assimp.Unmanaged Namespace


AiMatKeys.OPACITY_BASE Field

AiMatKeysOPACITY_BASE Field

Opacity (float)

Namespace: Assimp.Unmanaged
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public const string OPACITY_BASE = "$mat.opacity"

Field Value

Type: String
See Also

Reference

AiMatKeys Class
Assimp.Unmanaged Namespace


AiMatKeys.REFLECTIVITY Field

AiMatKeysREFLECTIVITY Field

Reflectivity (float)

Namespace: Assimp.Unmanaged
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public const string REFLECTIVITY = "$mat.reflectivity,0,0"

Field Value

Type: String
See Also

Reference

AiMatKeys Class
Assimp.Unmanaged Namespace


AiMatKeys.REFLECTIVITY_BASE Field

AiMatKeysREFLECTIVITY_BASE Field

Reflectivity (float)

Namespace: Assimp.Unmanaged
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public const string REFLECTIVITY_BASE = "$mat.reflectivity"

Field Value

Type: String
See Also

Reference

AiMatKeys Class
Assimp.Unmanaged Namespace


AiMatKeys.REFRACTI Field

AiMatKeysREFRACTI Field

Refracti (float)

Namespace: Assimp.Unmanaged
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public const string REFRACTI = "$mat.refracti,0,0"

Field Value

Type: String
See Also

Reference

AiMatKeys Class
Assimp.Unmanaged Namespace


AiMatKeys.REFRACTI_BASE Field

AiMatKeysREFRACTI_BASE Field

Refracti (float)

Namespace: Assimp.Unmanaged
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public const string REFRACTI_BASE = "$mat.refracti"

Field Value

Type: String
See Also

Reference

AiMatKeys Class
Assimp.Unmanaged Namespace


AiMatKeys.SHADING_MODEL Field

AiMatKeysSHADING_MODEL Field

Shading mode property (ShadingMode)

Namespace: Assimp.Unmanaged
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public const string SHADING_MODEL = "$mat.shadingm,0,0"

Field Value

Type: String
See Also

Reference

AiMatKeys Class
Assimp.Unmanaged Namespace


AiMatKeys.SHADING_MODEL_BASE Field

AiMatKeysSHADING_MODEL_BASE Field

Shading mode property (ShadingMode)

Namespace: Assimp.Unmanaged
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public const string SHADING_MODEL_BASE = "$mat.shadingm"

Field Value

Type: String
See Also

Reference

AiMatKeys Class
Assimp.Unmanaged Namespace


AiMatKeys.SHININESS Field

AiMatKeysSHININESS Field

Shininess (float)

Namespace: Assimp.Unmanaged
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public const string SHININESS = "$mat.shininess,0,0"

Field Value

Type: String
See Also

Reference

AiMatKeys Class
Assimp.Unmanaged Namespace


AiMatKeys.SHININESS_BASE Field

AiMatKeysSHININESS_BASE Field

Shininess (float)

Namespace: Assimp.Unmanaged
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public const string SHININESS_BASE = "$mat.shininess"

Field Value

Type: String
See Also

Reference

AiMatKeys Class
Assimp.Unmanaged Namespace


AiMatKeys.SHININESS_STRENGTH Field

AiMatKeysSHININESS_STRENGTH Field

Shininess strength (float)

Namespace: Assimp.Unmanaged
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public const string SHININESS_STRENGTH = "$mat.shinpercent,0,0"

Field Value

Type: String
See Also

Reference

AiMatKeys Class
Assimp.Unmanaged Namespace


AiMatKeys.SHININESS_STRENGTH_BASE Field

AiMatKeysSHININESS_STRENGTH_BASE Field

Shininess strength (float)

Namespace: Assimp.Unmanaged
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public const string SHININESS_STRENGTH_BASE = "$mat.shinpercent"

Field Value

Type: String
See Also

Reference

AiMatKeys Class
Assimp.Unmanaged Namespace


AiMatKeys.TEXBLEND_BASE Field

AiMatKeysTEXBLEND_BASE Field

Texture blend base name.

Namespace: Assimp.Unmanaged
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public const string TEXBLEND_BASE = "$tex.blend"

Field Value

Type: String
See Also

Reference

AiMatKeys Class
Assimp.Unmanaged Namespace


AiMatKeys.TEXFLAGS_BASE Field

AiMatKeysTEXFLAGS_BASE Field

Texture flags base name

Namespace: Assimp.Unmanaged
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public const string TEXFLAGS_BASE = "$tex.flags"

Field Value

Type: String
See Also

Reference

AiMatKeys Class
Assimp.Unmanaged Namespace


AiMatKeys.TEXMAP_AXIS_BASE Field

AiMatKeysTEXMAP_AXIS_BASE Field

Texture map axis base name

Namespace: Assimp.Unmanaged
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public const string TEXMAP_AXIS_BASE = "$tex.mapaxis"

Field Value

Type: String
See Also

Reference

AiMatKeys Class
Assimp.Unmanaged Namespace


AiMatKeys.TEXOP_BASE Field

AiMatKeysTEXOP_BASE Field

Texture op base name

Namespace: Assimp.Unmanaged
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public const string TEXOP_BASE = "$tex.op"

Field Value

Type: String
See Also

Reference

AiMatKeys Class
Assimp.Unmanaged Namespace


AiMatKeys.TEXTURE_BASE Field

AiMatKeysTEXTURE_BASE Field

Texture base name

Namespace: Assimp.Unmanaged
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public const string TEXTURE_BASE = "$tex.file"

Field Value

Type: String
See Also

Reference

AiMatKeys Class
Assimp.Unmanaged Namespace


AiMatKeys.TWOSIDED Field

AiMatKeysTWOSIDED Field

Two sided property (boolean)

Namespace: Assimp.Unmanaged
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public const string TWOSIDED = "$mat.twosided,0,0"

Field Value

Type: String
See Also

Reference

AiMatKeys Class
Assimp.Unmanaged Namespace


AiMatKeys.TWOSIDED_BASE Field

AiMatKeysTWOSIDED_BASE Field

Two sided property (boolean)

Namespace: Assimp.Unmanaged
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public const string TWOSIDED_BASE = "$mat.twosided"

Field Value

Type: String
See Also

Reference

AiMatKeys Class
Assimp.Unmanaged Namespace


AiMatKeys.UVTRANSFORM_BASE Field

AiMatKeysUVTRANSFORM_BASE Field

UV transform base name

Namespace: Assimp.Unmanaged
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public const string UVTRANSFORM_BASE = "$tex.uvtrafo"

Field Value

Type: String
See Also

Reference

AiMatKeys Class
Assimp.Unmanaged Namespace


AiMatKeys.UVWSRC_BASE Field

AiMatKeysUVWSRC_BASE Field

UVWSRC base name

Namespace: Assimp.Unmanaged
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public const string UVWSRC_BASE = "$tex.uvwsrc"

Field Value

Type: String
See Also

Reference

AiMatKeys Class
Assimp.Unmanaged Namespace


AiMemoryInfo Structure

Represents the memory requirements for the different components of an imported scene. All sizes in in bytes.

Namespace: Assimp.Unmanaged
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public struct AiMemoryInfo

The AiMemoryInfo type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Indicates whether this instance and a specified object are equal. (Inherited from ValueType.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from ValueType.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns the fully qualified type name of this instance. (Inherited from ValueType.)
Top
Fields
 | Name | Description
Public field | Animations | Size of the storage allocated for animation data, in bytes.
Public field | Cameras | Size of the storage allocated for camera data, in bytes.
Public field | Lights | Size of the storage allocated for light data, in bytes.
Public field | Materials | Size of the storage allocated for material data, in bytes.
Public field | Meshes | Size of the storage allocated for mesh data, in bytes.
Public field | Nodes | Size of the storage allocated for node data, in bytes.
Public field | Textures | Size of the storage allocated for texture data, in bytes.
Public field | Total | Total storage allocated for the imported scene, in bytes.
Top
See Also

Reference

Assimp.Unmanaged Namespace


AiMemoryInfo Methods

The AiMemoryInfo type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Indicates whether this instance and a specified object are equal. (Inherited from ValueType.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from ValueType.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns the fully qualified type name of this instance. (Inherited from ValueType.)
Top
See Also

Reference

AiMemoryInfo Structure
Assimp.Unmanaged Namespace


AiMemoryInfo Fields

The AiMemoryInfo type exposes the following members.

Fields
 | Name | Description
Public field | Animations | Size of the storage allocated for animation data, in bytes.
Public field | Cameras | Size of the storage allocated for camera data, in bytes.
Public field | Lights | Size of the storage allocated for light data, in bytes.
Public field | Materials | Size of the storage allocated for material data, in bytes.
Public field | Meshes | Size of the storage allocated for mesh data, in bytes.
Public field | Nodes | Size of the storage allocated for node data, in bytes.
Public field | Textures | Size of the storage allocated for texture data, in bytes.
Public field | Total | Total storage allocated for the imported scene, in bytes.
Top
See Also

Reference

AiMemoryInfo Structure
Assimp.Unmanaged Namespace


AiMemoryInfo.Animations Field

AiMemoryInfoAnimations Field

Size of the storage allocated for animation data, in bytes.

Namespace: Assimp.Unmanaged
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public uint Animations

Field Value

Type: UInt32
See Also

Reference

AiMemoryInfo Structure
Assimp.Unmanaged Namespace


AiMemoryInfo.Cameras Field

AiMemoryInfoCameras Field

Size of the storage allocated for camera data, in bytes.

Namespace: Assimp.Unmanaged
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public uint Cameras

Field Value

Type: UInt32
See Also

Reference

AiMemoryInfo Structure
Assimp.Unmanaged Namespace


AiMemoryInfo.Lights Field

AiMemoryInfoLights Field

Size of the storage allocated for light data, in bytes.

Namespace: Assimp.Unmanaged
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public uint Lights

Field Value

Type: UInt32
See Also

Reference

AiMemoryInfo Structure
Assimp.Unmanaged Namespace


AiMemoryInfo.Materials Field

AiMemoryInfoMaterials Field

Size of the storage allocated for material data, in bytes.

Namespace: Assimp.Unmanaged
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public uint Materials

Field Value

Type: UInt32
See Also

Reference

AiMemoryInfo Structure
Assimp.Unmanaged Namespace


AiMemoryInfo.Meshes Field

AiMemoryInfoMeshes Field

Size of the storage allocated for mesh data, in bytes.

Namespace: Assimp.Unmanaged
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public uint Meshes

Field Value

Type: UInt32
See Also

Reference

AiMemoryInfo Structure
Assimp.Unmanaged Namespace


AiMemoryInfo.Nodes Field

AiMemoryInfoNodes Field

Size of the storage allocated for node data, in bytes.

Namespace: Assimp.Unmanaged
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public uint Nodes

Field Value

Type: UInt32
See Also

Reference

AiMemoryInfo Structure
Assimp.Unmanaged Namespace


AiMemoryInfo.Textures Field

AiMemoryInfoTextures Field

Size of the storage allocated for texture data, in bytes.

Namespace: Assimp.Unmanaged
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public uint Textures

Field Value

Type: UInt32
See Also

Reference

AiMemoryInfo Structure
Assimp.Unmanaged Namespace


AiMemoryInfo.Total Field

AiMemoryInfoTotal Field

Total storage allocated for the imported scene, in bytes.

Namespace: Assimp.Unmanaged
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public uint Total

Field Value

Type: UInt32
See Also

Reference

AiMemoryInfo Structure
Assimp.Unmanaged Namespace


AiMesh Structure

Represents an aiMesh struct. Note: This structure requires marshaling, due to the arrays of IntPtrs.

Namespace: Assimp.Unmanaged
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public struct AiMesh

The AiMesh type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Indicates whether this instance and a specified object are equal. (Inherited from ValueType.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from ValueType.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns the fully qualified type name of this instance. (Inherited from ValueType.)
Top
Fields
 | Name | Description
Public field | AnimMeshes | aiAnimMesh**, array of attachment meshes for vertex-based animation. NOT CURRENTLY IN USE.
Public field | BiTangents | aiVector3D*, array of bitangents.
Public field | Bones | aiBone**, array of bones.
Public field | Colors | aiColor4D*[Max_Value], array of arrays of vertex colors. Max_Value is defined as AI_MAX_NUMBER_OF_COLOR_SETS.
Public field | Faces | aiFace*, array of faces.
Public field | MaterialIndex | Material index referencing the material in the scene.
Public field | MorphMethod | unsigned int, method of morphing when anim meshes are specified.
Public field | Name | Optional name of the mesh.
Public field | Normals | aiVector3D*, array of normals.
Public field | NumAnimMeshes | Number of attachment meshes. NOT CURRENTLY IN USE.
Public field | NumBones | Number of bones in the mesh.
Public field | NumFaces | Number of faces in the mesh.
Public field | NumUVComponents | unsigned int[Max_Value], array of ints denoting the number of components for each set of texture coordinates - UV (2), UVW (3) for example. Max_Value is defined as AI_MAX_NUMBER_OF_TEXTURECOORDS.
Public field | NumVertices | Number of vertices in the mesh, denotes length of -all- per-vertex arrays.
Public field | PrimitiveTypes | unsigned int, bitwise flag detailing types of primitives contained.
Public field | Tangents | aiVector3D*, array of tangents.
Public field | TextureCoords | aiVector3D*[Max_Value], array of arrays of texture coordinates. Max_Value is defined as AI_MAX_NUMBER_OF_TEXTURECOORDS.
Public field | Vertices | aiVector3D*, array of positions.
Top
See Also

Reference

Assimp.Unmanaged Namespace


AiMesh Methods

The AiMesh type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Indicates whether this instance and a specified object are equal. (Inherited from ValueType.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from ValueType.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns the fully qualified type name of this instance. (Inherited from ValueType.)
Top
See Also

Reference

AiMesh Structure
Assimp.Unmanaged Namespace


AiMesh Fields

The AiMesh type exposes the following members.

Fields
 | Name | Description
Public field | AnimMeshes | aiAnimMesh**, array of attachment meshes for vertex-based animation. NOT CURRENTLY IN USE.
Public field | BiTangents | aiVector3D*, array of bitangents.
Public field | Bones | aiBone**, array of bones.
Public field | Colors | aiColor4D*[Max_Value], array of arrays of vertex colors. Max_Value is defined as AI_MAX_NUMBER_OF_COLOR_SETS.
Public field | Faces | aiFace*, array of faces.
Public field | MaterialIndex | Material index referencing the material in the scene.
Public field | MorphMethod | unsigned int, method of morphing when anim meshes are specified.
Public field | Name | Optional name of the mesh.
Public field | Normals | aiVector3D*, array of normals.
Public field | NumAnimMeshes | Number of attachment meshes. NOT CURRENTLY IN USE.
Public field | NumBones | Number of bones in the mesh.
Public field | NumFaces | Number of faces in the mesh.
Public field | NumUVComponents | unsigned int[Max_Value], array of ints denoting the number of components for each set of texture coordinates - UV (2), UVW (3) for example. Max_Value is defined as AI_MAX_NUMBER_OF_TEXTURECOORDS.
Public field | NumVertices | Number of vertices in the mesh, denotes length of -all- per-vertex arrays.
Public field | PrimitiveTypes | unsigned int, bitwise flag detailing types of primitives contained.
Public field | Tangents | aiVector3D*, array of tangents.
Public field | TextureCoords | aiVector3D*[Max_Value], array of arrays of texture coordinates. Max_Value is defined as AI_MAX_NUMBER_OF_TEXTURECOORDS.
Public field | Vertices | aiVector3D*, array of positions.
Top
See Also

Reference

AiMesh Structure
Assimp.Unmanaged Namespace


AiMesh.AnimMeshes Field

AiMeshAnimMeshes Field

aiAnimMesh**, array of attachment meshes for vertex-based animation. NOT CURRENTLY IN USE.

Namespace: Assimp.Unmanaged
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public IntPtr AnimMeshes

Field Value

Type: IntPtr
See Also

Reference

AiMesh Structure
Assimp.Unmanaged Namespace


AiMesh.BiTangents Field

AiMeshBiTangents Field

aiVector3D*, array of bitangents.

Namespace: Assimp.Unmanaged
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public IntPtr BiTangents

Field Value

Type: IntPtr
See Also

Reference

AiMesh Structure
Assimp.Unmanaged Namespace


AiMesh.Bones Field

AiMeshBones Field

aiBone**, array of bones.

Namespace: Assimp.Unmanaged
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public IntPtr Bones

Field Value

Type: IntPtr
See Also

Reference

AiMesh Structure
Assimp.Unmanaged Namespace


AiMesh.Colors Field

AiMeshColors Field

aiColor4D*[Max_Value], array of arrays of vertex colors. Max_Value is defined as AI_MAX_NUMBER_OF_COLOR_SETS.

Namespace: Assimp.Unmanaged
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public AiMeshColorArray Colors

Field Value

Type: AiMeshColorArray
See Also

Reference

AiMesh Structure
Assimp.Unmanaged Namespace


AiMesh.Faces Field

AiMeshFaces Field

aiFace*, array of faces.

Namespace: Assimp.Unmanaged
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public IntPtr Faces

Field Value

Type: IntPtr
See Also

Reference

AiMesh Structure
Assimp.Unmanaged Namespace


AiMesh.MaterialIndex Field

AiMeshMaterialIndex Field

Material index referencing the material in the scene.

Namespace: Assimp.Unmanaged
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public uint MaterialIndex

Field Value

Type: UInt32
See Also

Reference

AiMesh Structure
Assimp.Unmanaged Namespace


AiMesh.MorphMethod Field

AiMeshMorphMethod Field

unsigned int, method of morphing when anim meshes are specified.

Namespace: Assimp.Unmanaged
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public MeshMorphingMethod MorphMethod

Field Value

Type: MeshMorphingMethod
See Also

Reference

AiMesh Structure
Assimp.Unmanaged Namespace


AiMesh.Name Field

AiMeshName Field

Optional name of the mesh.

Namespace: Assimp.Unmanaged
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public AiString Name

Field Value

Type: AiString
See Also

Reference

AiMesh Structure
Assimp.Unmanaged Namespace


AiMesh.Normals Field

AiMeshNormals Field

aiVector3D*, array of normals.

Namespace: Assimp.Unmanaged
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public IntPtr Normals

Field Value

Type: IntPtr
See Also

Reference

AiMesh Structure
Assimp.Unmanaged Namespace


AiMesh.NumAnimMeshes Field

AiMeshNumAnimMeshes Field

Number of attachment meshes. NOT CURRENTLY IN USE.

Namespace: Assimp.Unmanaged
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public uint NumAnimMeshes

Field Value

Type: UInt32
See Also

Reference

AiMesh Structure
Assimp.Unmanaged Namespace


AiMesh.NumBones Field

AiMeshNumBones Field

Number of bones in the mesh.

Namespace: Assimp.Unmanaged
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public uint NumBones

Field Value

Type: UInt32
See Also

Reference

AiMesh Structure
Assimp.Unmanaged Namespace


AiMesh.NumFaces Field

AiMeshNumFaces Field

Number of faces in the mesh.

Namespace: Assimp.Unmanaged
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public uint NumFaces

Field Value

Type: UInt32
See Also

Reference

AiMesh Structure
Assimp.Unmanaged Namespace


AiMesh.NumUVComponents Field

AiMeshNumUVComponents Field

unsigned int[Max_Value], array of ints denoting the number of components for each set of texture coordinates - UV (2), UVW (3) for example. Max_Value is defined as AI_MAX_NUMBER_OF_TEXTURECOORDS.

Namespace: Assimp.Unmanaged
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public AiMeshUVComponentArray NumUVComponents

Field Value

Type: AiMeshUVComponentArray
See Also

Reference

AiMesh Structure
Assimp.Unmanaged Namespace


AiMesh.NumVertices Field

AiMeshNumVertices Field

Number of vertices in the mesh, denotes length of -all- per-vertex arrays.

Namespace: Assimp.Unmanaged
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public uint NumVertices

Field Value

Type: UInt32
See Also

Reference

AiMesh Structure
Assimp.Unmanaged Namespace


AiMesh.PrimitiveTypes Field

AiMeshPrimitiveTypes Field

unsigned int, bitwise flag detailing types of primitives contained.

Namespace: Assimp.Unmanaged
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public PrimitiveType PrimitiveTypes

Field Value

Type: PrimitiveType
See Also

Reference

AiMesh Structure
Assimp.Unmanaged Namespace


AiMesh.Tangents Field

AiMeshTangents Field

aiVector3D*, array of tangents.

Namespace: Assimp.Unmanaged
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public IntPtr Tangents

Field Value

Type: IntPtr
See Also

Reference

AiMesh Structure
Assimp.Unmanaged Namespace


AiMesh.TextureCoords Field

AiMeshTextureCoords Field

aiVector3D*[Max_Value], array of arrays of texture coordinates. Max_Value is defined as AI_MAX_NUMBER_OF_TEXTURECOORDS.

Namespace: Assimp.Unmanaged
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public AiMeshTextureCoordinateArray TextureCoords

Field Value

Type: AiMeshTextureCoordinateArray
See Also

Reference

AiMesh Structure
Assimp.Unmanaged Namespace


AiMesh.Vertices Field

AiMeshVertices Field

aiVector3D*, array of positions.

Namespace: Assimp.Unmanaged
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public IntPtr Vertices

Field Value

Type: IntPtr
See Also

Reference

AiMesh Structure
Assimp.Unmanaged Namespace


AiMeshAnim Structure

Represents an aiMeshAnim struct.

Namespace: Assimp.Unmanaged
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public struct AiMeshAnim

The AiMeshAnim type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Indicates whether this instance and a specified object are equal. (Inherited from ValueType.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from ValueType.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns the fully qualified type name of this instance. (Inherited from ValueType.)
Top
Fields
 | Name | Description
Public field | Keys | aiMeshkey*, the key frames of the animation. There must exist at least one.
Public field | Name | Name of the mesh to be animated. Empty string not allowed.
Public field | NumKeys | Number of keys, there is at least one.
Top
See Also

Reference

Assimp.Unmanaged Namespace


AiMeshAnim Methods

The AiMeshAnim type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Indicates whether this instance and a specified object are equal. (Inherited from ValueType.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from ValueType.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns the fully qualified type name of this instance. (Inherited from ValueType.)
Top
See Also

Reference

AiMeshAnim Structure
Assimp.Unmanaged Namespace


AiMeshAnim Fields

The AiMeshAnim type exposes the following members.

Fields
 | Name | Description
Public field | Keys | aiMeshkey*, the key frames of the animation. There must exist at least one.
Public field | Name | Name of the mesh to be animated. Empty string not allowed.
Public field | NumKeys | Number of keys, there is at least one.
Top
See Also

Reference

AiMeshAnim Structure
Assimp.Unmanaged Namespace


AiMeshAnim.Keys Field

AiMeshAnimKeys Field

aiMeshkey*, the key frames of the animation. There must exist at least one.

Namespace: Assimp.Unmanaged
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public IntPtr Keys

Field Value

Type: IntPtr
See Also

Reference

AiMeshAnim Structure
Assimp.Unmanaged Namespace


AiMeshAnim.Name Field

AiMeshAnimName Field

Name of the mesh to be animated. Empty string not allowed.

Namespace: Assimp.Unmanaged
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public AiString Name

Field Value

Type: AiString
See Also

Reference

AiMeshAnim Structure
Assimp.Unmanaged Namespace


AiMeshAnim.NumKeys Field

AiMeshAnimNumKeys Field

Number of keys, there is at least one.

Namespace: Assimp.Unmanaged
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public uint NumKeys

Field Value

Type: UInt32
See Also

Reference

AiMeshAnim Structure
Assimp.Unmanaged Namespace


AiMeshColorArray Structure

Fixed length array for representing the color channels of a mesh. Length is equal to AI_MAX_NUMBER_OF_COLOR_SETS.

Namespace: Assimp.Unmanaged
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public struct AiMeshColorArray

The AiMeshColorArray type exposes the following members.

Properties
 | Name | Description
Public property | Item | Gets or sets an array value at the specified index.
Public property | Length | Gets the length of the array.
Top
Methods
 | Name | Description
Public method | Equals | Indicates whether this instance and a specified object are equal. (Inherited from ValueType.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from ValueType.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns the fully qualified type name of this instance. (Inherited from ValueType.)
Top
See Also

Reference

Assimp.Unmanaged Namespace


AiMeshColorArray Properties

The AiMeshColorArray type exposes the following members.

Properties
 | Name | Description
Public property | Item | Gets or sets an array value at the specified index.
Public property | Length | Gets the length of the array.
Top
See Also

Reference

AiMeshColorArray Structure
Assimp.Unmanaged Namespace


AiMeshColorArray.Item Property

AiMeshColorArrayItem Property

Gets or sets an array value at the specified index.

Namespace: Assimp.Unmanaged
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public IntPtr this[
    int index
] { get; set; }

Parameters

index
Type: SystemInt32
Zero-based index.

Property Value

Type: IntPtr
See Also

Reference

AiMeshColorArray Structure
Assimp.Unmanaged Namespace


AiMeshColorArray.Length Property

AiMeshColorArrayLength Property

Gets the length of the array.

Namespace: Assimp.Unmanaged
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public int Length { get; }

Property Value

Type: Int32
See Also

Reference

AiMeshColorArray Structure
Assimp.Unmanaged Namespace


AiMeshColorArray Methods

The AiMeshColorArray type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Indicates whether this instance and a specified object are equal. (Inherited from ValueType.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from ValueType.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns the fully qualified type name of this instance. (Inherited from ValueType.)
Top
See Also

Reference

AiMeshColorArray Structure
Assimp.Unmanaged Namespace


AiMeshMorphAnim Structure

Represents an aiMeshMorphAnim struct.

Namespace: Assimp.Unmanaged
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public struct AiMeshMorphAnim

The AiMeshMorphAnim type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Indicates whether this instance and a specified object are equal. (Inherited from ValueType.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from ValueType.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns the fully qualified type name of this instance. (Inherited from ValueType.)
Top
Fields
 | Name | Description
Public field | Keys | aiMeshMorphKey*, key frames of the animation.
Public field | Name | aiString, the name of the mesh to be animated. Empty strings are not allowed, animated meshes need to be named (not necessarily uniquely, the name can basically serve as a wildcard to select a group of meshes with similar animation setup).
Public field | NumKeys | unsigned int, number of key frames. Must be at least one.
Top
See Also

Reference

Assimp.Unmanaged Namespace


AiMeshMorphAnim Methods

The AiMeshMorphAnim type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Indicates whether this instance and a specified object are equal. (Inherited from ValueType.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from ValueType.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns the fully qualified type name of this instance. (Inherited from ValueType.)
Top
See Also

Reference

AiMeshMorphAnim Structure
Assimp.Unmanaged Namespace


AiMeshMorphAnim Fields

The AiMeshMorphAnim type exposes the following members.

Fields
 | Name | Description
Public field | Keys | aiMeshMorphKey*, key frames of the animation.
Public field | Name | aiString, the name of the mesh to be animated. Empty strings are not allowed, animated meshes need to be named (not necessarily uniquely, the name can basically serve as a wildcard to select a group of meshes with similar animation setup).
Public field | NumKeys | unsigned int, number of key frames. Must be at least one.
Top
See Also

Reference

AiMeshMorphAnim Structure
Assimp.Unmanaged Namespace


AiMeshMorphAnim.Keys Field

AiMeshMorphAnimKeys Field

aiMeshMorphKey*, key frames of the animation.

Namespace: Assimp.Unmanaged
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public IntPtr Keys

Field Value

Type: IntPtr
See Also

Reference

AiMeshMorphAnim Structure
Assimp.Unmanaged Namespace


AiMeshMorphAnim.Name Field

AiMeshMorphAnimName Field

aiString, the name of the mesh to be animated. Empty strings are not allowed, animated meshes need to be named (not necessarily uniquely, the name can basically serve as a wildcard to select a group of meshes with similar animation setup).

Namespace: Assimp.Unmanaged
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public AiString Name

Field Value

Type: AiString
See Also

Reference

AiMeshMorphAnim Structure
Assimp.Unmanaged Namespace


AiMeshMorphAnim.NumKeys Field

AiMeshMorphAnimNumKeys Field

unsigned int, number of key frames. Must be at least one.

Namespace: Assimp.Unmanaged
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public uint NumKeys

Field Value

Type: UInt32
See Also

Reference

AiMeshMorphAnim Structure
Assimp.Unmanaged Namespace


AiMeshMorphKey Structure

Represents an aiMeshMorphKey struct.

Namespace: Assimp.Unmanaged
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public struct AiMeshMorphKey

The AiMeshMorphKey type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Indicates whether this instance and a specified object are equal. (Inherited from ValueType.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from ValueType.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns the fully qualified type name of this instance. (Inherited from ValueType.)
Top
Fields
 | Name | Description
Public field | NumValuesAndWeights | unsigned int, the number of values/weights.
Public field | Time | The time of this key.
Public field | Values | unsigned int*, values at the time of this key.
Public field | Weights | double*, weights at the time of this key.
Top
See Also

Reference

Assimp.Unmanaged Namespace


AiMeshMorphKey Methods

The AiMeshMorphKey type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Indicates whether this instance and a specified object are equal. (Inherited from ValueType.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from ValueType.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns the fully qualified type name of this instance. (Inherited from ValueType.)
Top
See Also

Reference

AiMeshMorphKey Structure
Assimp.Unmanaged Namespace


AiMeshMorphKey Fields

The AiMeshMorphKey type exposes the following members.

Fields
 | Name | Description
Public field | NumValuesAndWeights | unsigned int, the number of values/weights.
Public field | Time | The time of this key.
Public field | Values | unsigned int*, values at the time of this key.
Public field | Weights | double*, weights at the time of this key.
Top
See Also

Reference

AiMeshMorphKey Structure
Assimp.Unmanaged Namespace


AiMeshMorphKey.NumValuesAndWeights Field

AiMeshMorphKeyNumValuesAndWeights Field

unsigned int, the number of values/weights.

Namespace: Assimp.Unmanaged
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public uint NumValuesAndWeights

Field Value

Type: UInt32
See Also

Reference

AiMeshMorphKey Structure
Assimp.Unmanaged Namespace


AiMeshMorphKey.Time Field

AiMeshMorphKeyTime Field

The time of this key.

Namespace: Assimp.Unmanaged
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public double Time

Field Value

Type: Double
See Also

Reference

AiMeshMorphKey Structure
Assimp.Unmanaged Namespace


AiMeshMorphKey.Values Field

AiMeshMorphKeyValues Field

unsigned int*, values at the time of this key.

Namespace: Assimp.Unmanaged
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public IntPtr Values

Field Value

Type: IntPtr
See Also

Reference

AiMeshMorphKey Structure
Assimp.Unmanaged Namespace


AiMeshMorphKey.Weights Field

AiMeshMorphKeyWeights Field

double*, weights at the time of this key.

Namespace: Assimp.Unmanaged
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public IntPtr Weights

Field Value

Type: IntPtr
See Also

Reference

AiMeshMorphKey Structure
Assimp.Unmanaged Namespace


AiMeshTextureCoordinateArray Structure

Fixed length array for representing the texture coordinate channels of a mesh. Length is equal to AI_MAX_NUMBER_OF_TEXTURECOORDS.

Namespace: Assimp.Unmanaged
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public struct AiMeshTextureCoordinateArray

The AiMeshTextureCoordinateArray type exposes the following members.

Properties
 | Name | Description
Public property | Item | Gets or sets an array value at the specified index.
Public property | Length | Gets the length of the array.
Top
Methods
 | Name | Description
Public method | Equals | Indicates whether this instance and a specified object are equal. (Inherited from ValueType.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from ValueType.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns the fully qualified type name of this instance. (Inherited from ValueType.)
Top
See Also

Reference

Assimp.Unmanaged Namespace


AiMeshTextureCoordinateArray Properties

The AiMeshTextureCoordinateArray type exposes the following members.

Properties
 | Name | Description
Public property | Item | Gets or sets an array value at the specified index.
Public property | Length | Gets the length of the array.
Top
See Also

Reference

AiMeshTextureCoordinateArray Structure
Assimp.Unmanaged Namespace


AiMeshTextureCoordinateArray.Item Property

AiMeshTextureCoordinateArrayItem Property

Gets or sets an array value at the specified index.

Namespace: Assimp.Unmanaged
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public IntPtr this[
    int index
] { get; set; }

Parameters

index
Type: SystemInt32
Zero-based index.

Property Value

Type: IntPtr
See Also

Reference

AiMeshTextureCoordinateArray Structure
Assimp.Unmanaged Namespace


AiMeshTextureCoordinateArray.Length Property

AiMeshTextureCoordinateArrayLength Property

Gets the length of the array.

Namespace: Assimp.Unmanaged
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public int Length { get; }

Property Value

Type: Int32
See Also

Reference

AiMeshTextureCoordinateArray Structure
Assimp.Unmanaged Namespace


AiMeshTextureCoordinateArray Methods

The AiMeshTextureCoordinateArray type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Indicates whether this instance and a specified object are equal. (Inherited from ValueType.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from ValueType.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns the fully qualified type name of this instance. (Inherited from ValueType.)
Top
See Also

Reference

AiMeshTextureCoordinateArray Structure
Assimp.Unmanaged Namespace


AiMeshUVComponentArray Structure

Fixed length array for representing the number of UV components for each texture coordinate channel of a mesh. Length is equal to AI_MAX_NUMBER_OF_TEXTURECOORDS.

Namespace: Assimp.Unmanaged
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public struct AiMeshUVComponentArray

The AiMeshUVComponentArray type exposes the following members.

Properties
 | Name | Description
Public property | Item | Gets or sets an array value at the specified index.
Public property | Length | Gets the length of the array.
Top
Methods
 | Name | Description
Public method | Equals | Indicates whether this instance and a specified object are equal. (Inherited from ValueType.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from ValueType.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns the fully qualified type name of this instance. (Inherited from ValueType.)
Top
See Also

Reference

Assimp.Unmanaged Namespace


AiMeshUVComponentArray Properties

The AiMeshUVComponentArray type exposes the following members.

Properties
 | Name | Description
Public property | Item | Gets or sets an array value at the specified index.
Public property | Length | Gets the length of the array.
Top
See Also

Reference

AiMeshUVComponentArray Structure
Assimp.Unmanaged Namespace


AiMeshUVComponentArray.Item Property

AiMeshUVComponentArrayItem Property

Gets or sets an array value at the specified index.

Namespace: Assimp.Unmanaged
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public uint this[
    int index
] { get; set; }

Parameters

index
Type: SystemInt32
Zero-based index.

Property Value

Type: UInt32
See Also

Reference

AiMeshUVComponentArray Structure
Assimp.Unmanaged Namespace


AiMeshUVComponentArray.Length Property

AiMeshUVComponentArrayLength Property

Gets the length of the array.

Namespace: Assimp.Unmanaged
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public int Length { get; }

Property Value

Type: Int32
See Also

Reference

AiMeshUVComponentArray Structure
Assimp.Unmanaged Namespace


AiMeshUVComponentArray Methods

The AiMeshUVComponentArray type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Indicates whether this instance and a specified object are equal. (Inherited from ValueType.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from ValueType.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns the fully qualified type name of this instance. (Inherited from ValueType.)
Top
See Also

Reference

AiMeshUVComponentArray Structure
Assimp.Unmanaged Namespace


AiMetadata Structure

Represents an aiMetadata struct.

Namespace: Assimp.Unmanaged
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public struct AiMetadata

The AiMetadata type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Indicates whether this instance and a specified object are equal. (Inherited from ValueType.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from ValueType.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns the fully qualified type name of this instance. (Inherited from ValueType.)
Top
Fields
 | Name | Description
Public field | keys | aiString*, array of keys. May not be NULL. Each entry must exist.
Public field | NumProperties | Length of the Keys and Values arrays.
Public field | Values | aiMetadataEntry*, array of values. May not be NULL. Entries may be NULL if the corresponding property key has no assigned value.
Top
See Also

Reference

Assimp.Unmanaged Namespace


AiMetadata Methods

The AiMetadata type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Indicates whether this instance and a specified object are equal. (Inherited from ValueType.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from ValueType.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns the fully qualified type name of this instance. (Inherited from ValueType.)
Top
See Also

Reference

AiMetadata Structure
Assimp.Unmanaged Namespace


AiMetadata Fields

The AiMetadata type exposes the following members.

Fields
 | Name | Description
Public field | keys | aiString*, array of keys. May not be NULL. Each entry must exist.
Public field | NumProperties | Length of the Keys and Values arrays.
Public field | Values | aiMetadataEntry*, array of values. May not be NULL. Entries may be NULL if the corresponding property key has no assigned value.
Top
See Also

Reference

AiMetadata Structure
Assimp.Unmanaged Namespace


AiMetadata.keys Field

AiMetadatakeys Field

aiString*, array of keys. May not be NULL. Each entry must exist.

Namespace: Assimp.Unmanaged
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public IntPtr keys

Field Value

Type: IntPtr
See Also

Reference

AiMetadata Structure
Assimp.Unmanaged Namespace


AiMetadata.NumProperties Field

AiMetadataNumProperties Field

Length of the Keys and Values arrays.

Namespace: Assimp.Unmanaged
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public uint NumProperties

Field Value

Type: UInt32
See Also

Reference

AiMetadata Structure
Assimp.Unmanaged Namespace


AiMetadata.Values Field

AiMetadataValues Field

aiMetadataEntry*, array of values. May not be NULL. Entries may be NULL if the corresponding property key has no assigned value.

Namespace: Assimp.Unmanaged
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public IntPtr Values

Field Value

Type: IntPtr
See Also

Reference

AiMetadata Structure
Assimp.Unmanaged Namespace


AiMetadataEntry Structure

Represents an aiMetadataEntry struct.

Namespace: Assimp.Unmanaged
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public struct AiMetadataEntry

The AiMetadataEntry type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Indicates whether this instance and a specified object are equal. (Inherited from ValueType.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from ValueType.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns the fully qualified type name of this instance. (Inherited from ValueType.)
Top
Fields
 | Name | Description
Public field | Data | Pointer to data.
Public field | DataType | Type of metadata.
Top
See Also

Reference

Assimp.Unmanaged Namespace


AiMetadataEntry Methods

The AiMetadataEntry type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Indicates whether this instance and a specified object are equal. (Inherited from ValueType.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from ValueType.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns the fully qualified type name of this instance. (Inherited from ValueType.)
Top
See Also

Reference

AiMetadataEntry Structure
Assimp.Unmanaged Namespace


AiMetadataEntry Fields

The AiMetadataEntry type exposes the following members.

Fields
 | Name | Description
Public field | Data | Pointer to data.
Public field | DataType | Type of metadata.
Top
See Also

Reference

AiMetadataEntry Structure
Assimp.Unmanaged Namespace


AiMetadataEntry.Data Field

AiMetadataEntryData Field

Pointer to data.

Namespace: Assimp.Unmanaged
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public IntPtr Data

Field Value

Type: IntPtr
See Also

Reference

AiMetadataEntry Structure
Assimp.Unmanaged Namespace


AiMetadataEntry.DataType Field

AiMetadataEntryDataType Field

Type of metadata.

Namespace: Assimp.Unmanaged
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public MetaDataType DataType

Field Value

Type: MetaDataType
See Also

Reference

AiMetadataEntry Structure
Assimp.Unmanaged Namespace


AiNode Structure

Represents an aiNode struct.

Namespace: Assimp.Unmanaged
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public struct AiNode

The AiNode type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Indicates whether this instance and a specified object are equal. (Inherited from ValueType.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from ValueType.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns the fully qualified type name of this instance. (Inherited from ValueType.)
Top
Fields
 | Name | Description
Public field | Children | aiNode**, array of nodes this node owns.
Public field | Meshes | unsigned int*, array of mesh indices.
Public field | MetaData | aiMetadata*, pointer to a metadata container. May be NULL, if an importer doesn't document metadata then it doesn't write any.
Public field | Name | Name of the node.
Public field | NumChildren | Number of children the node owns.
Public field | NumMeshes | Number of meshes referenced by this node.
Public field | Parent | aiNode*, node's parent.
Public field | Transformation | Node's transform relative to its parent.
Top
See Also

Reference

Assimp.Unmanaged Namespace


AiNode Methods

The AiNode type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Indicates whether this instance and a specified object are equal. (Inherited from ValueType.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from ValueType.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns the fully qualified type name of this instance. (Inherited from ValueType.)
Top
See Also

Reference

AiNode Structure
Assimp.Unmanaged Namespace


AiNode Fields

The AiNode type exposes the following members.

Fields
 | Name | Description
Public field | Children | aiNode**, array of nodes this node owns.
Public field | Meshes | unsigned int*, array of mesh indices.
Public field | MetaData | aiMetadata*, pointer to a metadata container. May be NULL, if an importer doesn't document metadata then it doesn't write any.
Public field | Name | Name of the node.
Public field | NumChildren | Number of children the node owns.
Public field | NumMeshes | Number of meshes referenced by this node.
Public field | Parent | aiNode*, node's parent.
Public field | Transformation | Node's transform relative to its parent.
Top
See Also

Reference

AiNode Structure
Assimp.Unmanaged Namespace


AiNode.Children Field

AiNodeChildren Field

aiNode**, array of nodes this node owns.

Namespace: Assimp.Unmanaged
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public IntPtr Children

Field Value

Type: IntPtr
See Also

Reference

AiNode Structure
Assimp.Unmanaged Namespace


AiNode.Meshes Field

AiNodeMeshes Field

unsigned int*, array of mesh indices.

Namespace: Assimp.Unmanaged
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public IntPtr Meshes

Field Value

Type: IntPtr
See Also

Reference

AiNode Structure
Assimp.Unmanaged Namespace


AiNode.MetaData Field

AiNodeMetaData Field

aiMetadata*, pointer to a metadata container. May be NULL, if an importer doesn't document metadata then it doesn't write any.

Namespace: Assimp.Unmanaged
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public IntPtr MetaData

Field Value

Type: IntPtr
See Also

Reference

AiNode Structure
Assimp.Unmanaged Namespace


AiNode.Name Field

AiNodeName Field

Name of the node.

Namespace: Assimp.Unmanaged
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public AiString Name

Field Value

Type: AiString
See Also

Reference

AiNode Structure
Assimp.Unmanaged Namespace


AiNode.NumChildren Field

AiNodeNumChildren Field

Number of children the node owns.

Namespace: Assimp.Unmanaged
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public uint NumChildren

Field Value

Type: UInt32
See Also

Reference

AiNode Structure
Assimp.Unmanaged Namespace


AiNode.NumMeshes Field

AiNodeNumMeshes Field

Number of meshes referenced by this node.

Namespace: Assimp.Unmanaged
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public uint NumMeshes

Field Value

Type: UInt32
See Also

Reference

AiNode Structure
Assimp.Unmanaged Namespace


AiNode.Parent Field

AiNodeParent Field

aiNode*, node's parent.

Namespace: Assimp.Unmanaged
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public IntPtr Parent

Field Value

Type: IntPtr
See Also

Reference

AiNode Structure
Assimp.Unmanaged Namespace


AiNode.Transformation Field

AiNodeTransformation Field

Node's transform relative to its parent.

Namespace: Assimp.Unmanaged
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public Matrix4x4 Transformation

Field Value

Type: Matrix4x4
See Also

Reference

AiNode Structure
Assimp.Unmanaged Namespace


AiNodeAnim Structure

Represents an aiNodeAnim struct.

Namespace: Assimp.Unmanaged
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public struct AiNodeAnim

The AiNodeAnim type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Indicates whether this instance and a specified object are equal. (Inherited from ValueType.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from ValueType.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns the fully qualified type name of this instance. (Inherited from ValueType.)
Top
Fields
 | Name | Description
Public field | NodeName | Name of the node affected by the animation. The node must exist and be unique.
Public field | NumPositionKeys | Number of position keys.
Public field | NumRotationKeys | The number of rotation keys.
Public field | NumScalingKeys | Number of scaling keys.
Public field | PositionKeys | VectorKey*, position keys of this animation channel. Positions are 3D vectors and are accompanied by at least one scaling and one rotation key.
Public field | PostState | Defines how the animation behaves after the last key was processed.
Public field | Prestate | Defines how the animation behaves before the first key is encountered.
Public field | RotationKeys | QuaternionKey*, rotation keys of this animation channel. Rotations are 4D vectors (quaternions). If there are rotation keys there will be at least one scaling and one position key.
Public field | ScalingKeys | VectorKey*, scaling keys of this animation channel. Scalings are specified as a 3D vector, and if there are scaling keys, there will at least be one position and one rotation key.
Top
See Also

Reference

Assimp.Unmanaged Namespace


AiNodeAnim Methods

The AiNodeAnim type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Indicates whether this instance and a specified object are equal. (Inherited from ValueType.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from ValueType.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns the fully qualified type name of this instance. (Inherited from ValueType.)
Top
See Also

Reference

AiNodeAnim Structure
Assimp.Unmanaged Namespace


AiNodeAnim Fields

The AiNodeAnim type exposes the following members.

Fields
 | Name | Description
Public field | NodeName | Name of the node affected by the animation. The node must exist and be unique.
Public field | NumPositionKeys | Number of position keys.
Public field | NumRotationKeys | The number of rotation keys.
Public field | NumScalingKeys | Number of scaling keys.
Public field | PositionKeys | VectorKey*, position keys of this animation channel. Positions are 3D vectors and are accompanied by at least one scaling and one rotation key.
Public field | PostState | Defines how the animation behaves after the last key was processed.
Public field | Prestate | Defines how the animation behaves before the first key is encountered.
Public field | RotationKeys | QuaternionKey*, rotation keys of this animation channel. Rotations are 4D vectors (quaternions). If there are rotation keys there will be at least one scaling and one position key.
Public field | ScalingKeys | VectorKey*, scaling keys of this animation channel. Scalings are specified as a 3D vector, and if there are scaling keys, there will at least be one position and one rotation key.
Top
See Also

Reference

AiNodeAnim Structure
Assimp.Unmanaged Namespace


AiNodeAnim.NodeName Field

AiNodeAnimNodeName Field

Name of the node affected by the animation. The node must exist and be unique.

Namespace: Assimp.Unmanaged
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public AiString NodeName

Field Value

Type: AiString
See Also

Reference

AiNodeAnim Structure
Assimp.Unmanaged Namespace


AiNodeAnim.NumPositionKeys Field

AiNodeAnimNumPositionKeys Field

Number of position keys.

Namespace: Assimp.Unmanaged
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public uint NumPositionKeys

Field Value

Type: UInt32
See Also

Reference

AiNodeAnim Structure
Assimp.Unmanaged Namespace


AiNodeAnim.NumRotationKeys Field

AiNodeAnimNumRotationKeys Field

The number of rotation keys.

Namespace: Assimp.Unmanaged
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public uint NumRotationKeys

Field Value

Type: UInt32
See Also

Reference

AiNodeAnim Structure
Assimp.Unmanaged Namespace


AiNodeAnim.NumScalingKeys Field

AiNodeAnimNumScalingKeys Field

Number of scaling keys.

Namespace: Assimp.Unmanaged
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public uint NumScalingKeys

Field Value

Type: UInt32
See Also

Reference

AiNodeAnim Structure
Assimp.Unmanaged Namespace


AiNodeAnim.PositionKeys Field

AiNodeAnimPositionKeys Field

VectorKey*, position keys of this animation channel. Positions are 3D vectors and are accompanied by at least one scaling and one rotation key.

Namespace: Assimp.Unmanaged
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public IntPtr PositionKeys

Field Value

Type: IntPtr
See Also

Reference

AiNodeAnim Structure
Assimp.Unmanaged Namespace


AiNodeAnim.PostState Field

AiNodeAnimPostState Field

Defines how the animation behaves after the last key was processed.

Namespace: Assimp.Unmanaged
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public AnimationBehaviour PostState

Field Value

Type: AnimationBehaviour
See Also

Reference

AiNodeAnim Structure
Assimp.Unmanaged Namespace


AiNodeAnim.Prestate Field

AiNodeAnimPrestate Field

Defines how the animation behaves before the first key is encountered.

Namespace: Assimp.Unmanaged
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public AnimationBehaviour Prestate

Field Value

Type: AnimationBehaviour
See Also

Reference

AiNodeAnim Structure
Assimp.Unmanaged Namespace


AiNodeAnim.RotationKeys Field

AiNodeAnimRotationKeys Field

QuaternionKey*, rotation keys of this animation channel. Rotations are 4D vectors (quaternions). If there are rotation keys there will be at least one scaling and one position key.

Namespace: Assimp.Unmanaged
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public IntPtr RotationKeys

Field Value

Type: IntPtr
See Also

Reference

AiNodeAnim Structure
Assimp.Unmanaged Namespace


AiNodeAnim.ScalingKeys Field

AiNodeAnimScalingKeys Field

VectorKey*, scaling keys of this animation channel. Scalings are specified as a 3D vector, and if there are scaling keys, there will at least be one position and one rotation key.

Namespace: Assimp.Unmanaged
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public IntPtr ScalingKeys

Field Value

Type: IntPtr
See Also

Reference

AiNodeAnim Structure
Assimp.Unmanaged Namespace


AiScene Structure

Represents an aiScene struct.

Namespace: Assimp.Unmanaged
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public struct AiScene

The AiScene type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Indicates whether this instance and a specified object are equal. (Inherited from ValueType.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from ValueType.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns the fully qualified type name of this instance. (Inherited from ValueType.)
Top
Fields
 | Name | Description
Public field | Animations | aiAnimation**, animations in the scene.
Public field | Cameras | aiCamera**, cameras in the scene.
Public field | Flags | unsigned int, flags about the state of the scene
Public field | Lights | aiLight**, lights in the scene.
Public field | Materials | aiMaterial**, materials in the scene.
Public field | Meshes | aiMesh**, meshes in the scene.
Public field | NumAnimations | Number of animations contained.
Public field | NumCameras | Number of cameras contained.
Public field | NumLights | Number of lights contained.
Public field | NumMaterials | Number of materials contained.
Public field | NumMeshes | Number of meshes contained.
Public field | NumTextures | Number of embedded textures contained.
Public field | PrivateData | void*, Private data do not touch!
Public field | RootNode | aiNode*, root node of the scenegraph.
Public field | Textures | aiTexture**, textures in the scene.
Top
See Also

Reference

Assimp.Unmanaged Namespace


AiScene Methods

The AiScene type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Indicates whether this instance and a specified object are equal. (Inherited from ValueType.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from ValueType.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns the fully qualified type name of this instance. (Inherited from ValueType.)
Top
See Also

Reference

AiScene Structure
Assimp.Unmanaged Namespace


AiScene Fields

The AiScene type exposes the following members.

Fields
 | Name | Description
Public field | Animations | aiAnimation**, animations in the scene.
Public field | Cameras | aiCamera**, cameras in the scene.
Public field | Flags | unsigned int, flags about the state of the scene
Public field | Lights | aiLight**, lights in the scene.
Public field | Materials | aiMaterial**, materials in the scene.
Public field | Meshes | aiMesh**, meshes in the scene.
Public field | NumAnimations | Number of animations contained.
Public field | NumCameras | Number of cameras contained.
Public field | NumLights | Number of lights contained.
Public field | NumMaterials | Number of materials contained.
Public field | NumMeshes | Number of meshes contained.
Public field | NumTextures | Number of embedded textures contained.
Public field | PrivateData | void*, Private data do not touch!
Public field | RootNode | aiNode*, root node of the scenegraph.
Public field | Textures | aiTexture**, textures in the scene.
Top
See Also

Reference

AiScene Structure
Assimp.Unmanaged Namespace


AiScene.Animations Field

AiSceneAnimations Field

aiAnimation**, animations in the scene.

Namespace: Assimp.Unmanaged
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public IntPtr Animations

Field Value

Type: IntPtr
See Also

Reference

AiScene Structure
Assimp.Unmanaged Namespace


AiScene.Cameras Field

AiSceneCameras Field

aiCamera**, cameras in the scene.

Namespace: Assimp.Unmanaged
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public IntPtr Cameras

Field Value

Type: IntPtr
See Also

Reference

AiScene Structure
Assimp.Unmanaged Namespace


AiScene.Flags Field

AiSceneFlags Field

unsigned int, flags about the state of the scene

Namespace: Assimp.Unmanaged
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public SceneFlags Flags

Field Value

Type: SceneFlags
See Also

Reference

AiScene Structure
Assimp.Unmanaged Namespace


AiScene.Lights Field

AiSceneLights Field

aiLight**, lights in the scene.

Namespace: Assimp.Unmanaged
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public IntPtr Lights

Field Value

Type: IntPtr
See Also

Reference

AiScene Structure
Assimp.Unmanaged Namespace


AiScene.Materials Field

AiSceneMaterials Field

aiMaterial**, materials in the scene.

Namespace: Assimp.Unmanaged
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public IntPtr Materials

Field Value

Type: IntPtr
See Also

Reference

AiScene Structure
Assimp.Unmanaged Namespace


AiScene.Meshes Field

AiSceneMeshes Field

aiMesh**, meshes in the scene.

Namespace: Assimp.Unmanaged
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public IntPtr Meshes

Field Value

Type: IntPtr
See Also

Reference

AiScene Structure
Assimp.Unmanaged Namespace


AiScene.NumAnimations Field

AiSceneNumAnimations Field

Number of animations contained.

Namespace: Assimp.Unmanaged
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public uint NumAnimations

Field Value

Type: UInt32
See Also

Reference

AiScene Structure
Assimp.Unmanaged Namespace


AiScene.NumCameras Field

AiSceneNumCameras Field

Number of cameras contained.

Namespace: Assimp.Unmanaged
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public uint NumCameras

Field Value

Type: UInt32
See Also

Reference

AiScene Structure
Assimp.Unmanaged Namespace


AiScene.NumLights Field

AiSceneNumLights Field

Number of lights contained.

Namespace: Assimp.Unmanaged
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public uint NumLights

Field Value

Type: UInt32
See Also

Reference

AiScene Structure
Assimp.Unmanaged Namespace


AiScene.NumMaterials Field

AiSceneNumMaterials Field

Number of materials contained.

Namespace: Assimp.Unmanaged
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public uint NumMaterials

Field Value

Type: UInt32
See Also

Reference

AiScene Structure
Assimp.Unmanaged Namespace


AiScene.NumMeshes Field

AiSceneNumMeshes Field

Number of meshes contained.

Namespace: Assimp.Unmanaged
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public uint NumMeshes

Field Value

Type: UInt32
See Also

Reference

AiScene Structure
Assimp.Unmanaged Namespace


AiScene.NumTextures Field

AiSceneNumTextures Field

Number of embedded textures contained.

Namespace: Assimp.Unmanaged
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public uint NumTextures

Field Value

Type: UInt32
See Also

Reference

AiScene Structure
Assimp.Unmanaged Namespace


AiScene.PrivateData Field

AiScenePrivateData Field

void*, Private data do not touch!

Namespace: Assimp.Unmanaged
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public IntPtr PrivateData

Field Value

Type: IntPtr
See Also

Reference

AiScene Structure
Assimp.Unmanaged Namespace


AiScene.RootNode Field

AiSceneRootNode Field

aiNode*, root node of the scenegraph.

Namespace: Assimp.Unmanaged
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public IntPtr RootNode

Field Value

Type: IntPtr
See Also

Reference

AiScene Structure
Assimp.Unmanaged Namespace


AiScene.Textures Field

AiSceneTextures Field

aiTexture**, textures in the scene.

Namespace: Assimp.Unmanaged
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public IntPtr Textures

Field Value

Type: IntPtr
See Also

Reference

AiScene Structure
Assimp.Unmanaged Namespace


AiString Structure

Represents an aiString struct.

Namespace: Assimp.Unmanaged
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public struct AiString

The AiString type exposes the following members.

Constructors
 | Name | Description
Public method | AiString | Constructs a new instance of the AiString struct.
Top
Methods
 | Name | Description
Public method | Equals | Indicates whether this instance and a specified object are equal. (Inherited from ValueType.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from ValueType.)
Public method | GetString | Convienence method for getting the AiString string - if the length is not greater than zero, it returns an empty string rather than garbage.
 | GetString(AiString) | Convienence method for getting the AiString string - if the length is not greater than zero, it returns an empty string rather than garbage. Use this to avoid struct copy if the string was passed by read-only ref.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | SetString | Convienence method for setting the AiString string (and length).
Public method | ToString | Returns the fully qualified type name of this instance. (Overrides ValueTypeToString.)
Top
Fields
 | Name | Description
Public field | Data | Actual string data.
Public field | Length | Byte length of the UTF-8 string.
Top
See Also

Reference

Assimp.Unmanaged Namespace


AiString Constructor

Constructs a new instance of the AiString struct.

Namespace: Assimp.Unmanaged
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public AiString(
    string data
)

Parameters

data
Type: SystemString
The string data
See Also

Reference

AiString Structure
Assimp.Unmanaged Namespace


AiString Methods

The AiString type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Indicates whether this instance and a specified object are equal. (Inherited from ValueType.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from ValueType.)
Public method | GetString | Convienence method for getting the AiString string - if the length is not greater than zero, it returns an empty string rather than garbage.
 | GetString(AiString) | Convienence method for getting the AiString string - if the length is not greater than zero, it returns an empty string rather than garbage. Use this to avoid struct copy if the string was passed by read-only ref.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | SetString | Convienence method for setting the AiString string (and length).
Public method | ToString | Returns the fully qualified type name of this instance. (Overrides ValueTypeToString.)
Top
See Also

Reference

AiString Structure
Assimp.Unmanaged Namespace


AiString.GetString Method

AiStringGetString Method

Overload List
 | Name | Description
Public method | GetString | Convienence method for getting the AiString string - if the length is not greater than zero, it returns an empty string rather than garbage.
 | GetString(AiString) | Convienence method for getting the AiString string - if the length is not greater than zero, it returns an empty string rather than garbage. Use this to avoid struct copy if the string was passed by read-only ref.
Top
See Also

Reference

AiString Structure
Assimp.Unmanaged Namespace


AiString.GetString Method

AiStringGetString Method

Convienence method for getting the AiString string - if the length is not greater than zero, it returns an empty string rather than garbage.

Namespace: Assimp.Unmanaged
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public string GetString()

Return Value

Type: String
AiString string data
See Also

Reference

AiString Structure
GetString Overload
Assimp.Unmanaged Namespace


AiString.GetString Method (AiString)

AiStringGetString Method (AiString)

Convienence method for getting the AiString string - if the length is not greater than zero, it returns an empty string rather than garbage. Use this to avoid struct copy if the string was passed by read-only ref.

Namespace: Assimp.Unmanaged
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public static string GetString(
    ref AiString aiStr
)

Parameters

aiStr
Type: Assimp.UnmanagedAiString
AiString

Return Value

Type: String
AiString string data
See Also

Reference

AiString Structure
GetString Overload
Assimp.Unmanaged Namespace


AiString.SetString Method

AiStringSetString Method

Convienence method for setting the AiString string (and length).

Namespace: Assimp.Unmanaged
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public bool SetString(
    string data
)

Parameters

data
Type: SystemString
String data to set

Return Value

Type: Boolean
True if the operation was successful, false otherwise.
See Also

Reference

AiString Structure
Assimp.Unmanaged Namespace


AiString.ToString Method

AiStringToString Method

Returns the fully qualified type name of this instance.

Namespace: Assimp.Unmanaged
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public override string ToString()

Return Value

Type: String
A String containing a fully qualified type name.
See Also

Reference

AiString Structure
Assimp.Unmanaged Namespace


AiString Fields

The AiString type exposes the following members.

Fields
 | Name | Description
Public field | Data | Actual string data.
Public field | Length | Byte length of the UTF-8 string.
Top
See Also

Reference

AiString Structure
Assimp.Unmanaged Namespace


AiString.Data Field

AiStringData Field

Actual string data.

Namespace: Assimp.Unmanaged
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public fixed byte Data[1024]

Field Value

Type: SystemByte
See Also

Reference

AiString Structure
Assimp.Unmanaged Namespace


AiString.Length Field

AiStringLength Field

Byte length of the UTF-8 string.

Namespace: Assimp.Unmanaged
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public UIntPtr Length

Field Value

Type: UIntPtr
See Also

Reference

AiString Structure
Assimp.Unmanaged Namespace


AiTexture Structure

Represents an aiTexture struct.

Namespace: Assimp.Unmanaged
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public struct AiTexture

The AiTexture type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Indicates whether this instance and a specified object are equal. (Inherited from ValueType.)
Public method | GetFormatHint | Gets the format hint.
 | GetFormatHint(AiTexture) | Gets the format hint. Use this to avoid struct copy if the string was passed by read-only ref.
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from ValueType.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | SetFormatHint | Sets the format hint.
Public method | ToString | Returns the fully qualified type name of this instance. (Inherited from ValueType.)
Top
Fields
 | Name | Description
Public field | Data | aiTexel*, array of texel data.
Public field | FormatHint | sbyte[9], format extension hint. Fixed size char is two bytes regardless of encoding. Unmanaged assimp uses a char that maps to one byte. 8 for string + 1 for terminator.
Public field | Height | Height of the texture.
Public field | Width | Width of the texture.
Top
See Also

Reference

Assimp.Unmanaged Namespace


AiTexture Methods

The AiTexture type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Indicates whether this instance and a specified object are equal. (Inherited from ValueType.)
Public method | GetFormatHint | Gets the format hint.
 | GetFormatHint(AiTexture) | Gets the format hint. Use this to avoid struct copy if the string was passed by read-only ref.
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from ValueType.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | SetFormatHint | Sets the format hint.
Public method | ToString | Returns the fully qualified type name of this instance. (Inherited from ValueType.)
Top
See Also

Reference

AiTexture Structure
Assimp.Unmanaged Namespace


AiTexture.GetFormatHint Method

AiTextureGetFormatHint Method

Overload List
 | Name | Description
Public method | GetFormatHint | Gets the format hint.
 | GetFormatHint(AiTexture) | Gets the format hint. Use this to avoid struct copy if the string was passed by read-only ref.
Top
See Also

Reference

AiTexture Structure
Assimp.Unmanaged Namespace


AiTexture.GetFormatHint Method

AiTextureGetFormatHint Method

Gets the format hint.

Namespace: Assimp.Unmanaged
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public string GetFormatHint()

Return Value

Type: String
The format hint
See Also

Reference

AiTexture Structure
GetFormatHint Overload
Assimp.Unmanaged Namespace


AiTexture.GetFormatHint Method (AiTexture)

AiTextureGetFormatHint Method (AiTexture)

Gets the format hint. Use this to avoid struct copy if the string was passed by read-only ref.

Namespace: Assimp.Unmanaged
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public static string GetFormatHint(
    ref AiTexture aiTex
)

Parameters

aiTex
Type: Assimp.UnmanagedAiTexture
AiTexture

Return Value

Type: String
The format hint
See Also

Reference

AiTexture Structure
GetFormatHint Overload
Assimp.Unmanaged Namespace


AiTexture.SetFormatHint Method

AiTextureSetFormatHint Method

Sets the format hint.

Namespace: Assimp.Unmanaged
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public void SetFormatHint(
    string formatHint
)

Parameters

formatHint
Type: SystemString
Format hint - must be 3 characters or less
See Also

Reference

AiTexture Structure
Assimp.Unmanaged Namespace


AiTexture Fields

The AiTexture type exposes the following members.

Fields
 | Name | Description
Public field | Data | aiTexel*, array of texel data.
Public field | FormatHint | sbyte[9], format extension hint. Fixed size char is two bytes regardless of encoding. Unmanaged assimp uses a char that maps to one byte. 8 for string + 1 for terminator.
Public field | Height | Height of the texture.
Public field | Width | Width of the texture.
Top
See Also

Reference

AiTexture Structure
Assimp.Unmanaged Namespace


AiTexture.Data Field

AiTextureData Field

aiTexel*, array of texel data.

Namespace: Assimp.Unmanaged
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public IntPtr Data

Field Value

Type: IntPtr
See Also

Reference

AiTexture Structure
Assimp.Unmanaged Namespace


AiTexture.FormatHint Field

AiTextureFormatHint Field

sbyte[9], format extension hint. Fixed size char is two bytes regardless of encoding. Unmanaged assimp uses a char that maps to one byte. 8 for string + 1 for terminator.

Namespace: Assimp.Unmanaged
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public fixed sbyte FormatHint[9]

Field Value

Type: SystemSByte
See Also

Reference

AiTexture Structure
Assimp.Unmanaged Namespace


AiTexture.Height Field

AiTextureHeight Field

Height of the texture.

Namespace: Assimp.Unmanaged
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public uint Height

Field Value

Type: UInt32
See Also

Reference

AiTexture Structure
Assimp.Unmanaged Namespace


AiTexture.Width Field

AiTextureWidth Field

Width of the texture.

Namespace: Assimp.Unmanaged
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public uint Width

Field Value

Type: UInt32
See Also

Reference

AiTexture Structure
Assimp.Unmanaged Namespace


AssimpLibrary Class

Singleton that governs access to the unmanaged Assimp library functions.
Inheritance Hierarchy
SystemObject
Assimp.UnmanagedUnmanagedLibrary
Assimp.UnmanagedAssimpLibrary

Namespace: Assimp.Unmanaged
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public sealed class AssimpLibrary : UnmanagedLibrary

The AssimpLibrary type exposes the following members.

Properties
 | Name | Description
Public property | DefaultLibraryName | Gets the default name of the unmanaged library DLL. This is dependent based on the platform extension and name prefix. Additional names can be set in the UnmanagedLibraryResolver (e.g. to load versioned DLLs) (Inherited from UnmanagedLibrary.)
 | Instance | Gets the AssimpLibrary instance.
Public property | IsLibraryLoaded | Queries if the unmanaged library has been loaded or not. (Inherited from UnmanagedLibrary.)
Public property | IsMultithreadingSupported | Gets if the Assimp unmanaged library supports multithreading. If it was compiled for single threading only, then it will not utilize multiple threads during import.
Public property | LibraryPath | Gets the path to the unmanaged library DLL that is currently loaded. (Inherited from UnmanagedLibrary.)
Public property | Resolver | Gets the resolver used to find the unmanaged library DLL when loading. (Inherited from UnmanagedLibrary.)
Public property | ThrowOnLoadFailure | Gets or sets whether an AssimpException is thrown if the unmanaged DLL fails to load for whatever reason. By default this is true. (Inherited from UnmanagedLibrary.)
Top
Methods
 | Name | Description
Public method | ApplyPostProcessing | Applies a post-processing step on an already imported scene.
Public method | AttachLogStream | Attaches a log stream callback to catch Assimp messages.
Public method | CopyScene | Creates a modifyable copy of a scene, useful for copying the scene that was imported so its topology can be modified and the scene be exported.
Public method | CreatePropertyStore | Create an empty property store. Property stores are used to collect import settings.
Public method | CreateQuaternionFromMatrix | Creates a quaternion from the 3x3 rotation matrix.
Public method | DecomposeMatrix | Decomposes a 4x4 matrix into its scaling, rotation, and translation parts.
Public method | DetachAllLogStreams | Detaches all logstream callbacks currently attached to Assimp.
Public method | DetachLogStream | Detaches a logstream callback.
Public method | EnableVerboseLogging | Enables verbose logging.
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | ExportScene(IntPtr, String, String, PostProcessSteps) | Exports the given scene to a chosen file format and writes the result file(s) to disk.
Public method | ExportScene(IntPtr, String, String, IntPtr, PostProcessSteps) | Exports the given scene to a chosen file format and writes the result file(s) to disk.
Public method | ExportSceneToBlob | Exports the given scene to a chosen file format. Returns the exported data as a binary blob which you can embed into another data structure or file.
Public method | FreeLibrary | Frees the unmanaged library that is currently loaded. (Inherited from UnmanagedLibrary.)
Public method | GetCompileFlags | Get the compilation flags that describe how the native Assimp DLL was compiled.
Public method | GetErrorString | Gets the last error logged in Assimp.
Public method | GetExportFormatDescriptions | Gets all supported export formats.
Public method | GetExtensionList | Gets all the model format extensions that are currently supported by Assimp.
Public method | GetFunctionT | Gets a delegate based on the unmanaged function name. (Inherited from UnmanagedLibrary.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetImporterDescriptions | Gets a collection of importer descriptions that detail metadata and feature support for each importer.
Public method | GetLegalString | Gets the Assimp legal info.
Public method | GetMaterialColor | Retrieves a color value from the material property table.
Public method | GetMaterialFloatArray | Retrieves an array of float values with the specific key from the material.
Public method | GetMaterialIntegerArray | Retrieves an array of integer values with the specific key from the material.
Public method | GetMaterialProperty | Retrieves a material property with the specific key from the material.
Public method | GetMaterialString | Retrieves a string from the material property table.
Public method | GetMaterialTexture | Gets all values pertaining to a particular texture from a material.
Public method | GetMaterialTextureCount | Gets the number of textures contained in the material for a particular texture type.
Public method | GetMaterialTextureFilePath | Gets the texture filepath contained in the material.
Public method | GetMemoryRequirements | Gets the memory requirements of the scene.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetVerboseLoggingEnabled | Gets if verbose logging is enabled.
Public method | GetVersion | Gets the native Assimp DLL's current version number as "major.minor.revision" string. This is the version of Assimp that this wrapper is currently using.
Public method | GetVersionAsVersion | Gets the native Assimp DLL's current version number as a .NET version object.
Public method | GetVersionMajor | Gets the native Assimp DLL's major version number.
Public method | GetVersionMinor | Gets the native Assimp DLL's minor version number.
Public method | GetVersionRevision | Gets the native Assimp DLL's revision version number.
Public method | IdentityMatrix3 | Creates a 3x3 identity matrix.
Public method | IdentityMatrix4 | Creates a 4x4 identity matrix.
Public method | ImportFile(String, PostProcessSteps, IntPtr) | Imports a file.
Public method | ImportFile(String, PostProcessSteps, IntPtr, IntPtr) | Imports a file.
Public method | ImportFileFromStream | Imports a scene from a stream. This uses the "aiImportFileFromMemory" function. The stream can be from anyplace, not just a memory stream. It is up to the caller to dispose of the stream.
Public method | IsExtensionSupported | Checks whether the model format extension is supported by Assimp.
Public method | LoadLibrary | Loads the unmanaged library using the UnmanagedLibraryResolver. (Inherited from UnmanagedLibrary.)
Public method | LoadLibrary(String) | Loads the unmanaged library using the supplied path. (Inherited from UnmanagedLibrary.)
Public method | LoadLibrary(String, String) | Loads the unmanaged library using the supplied 32 and 64 bit paths, the one chosen is based on the OS bitness. (Inherited from UnmanagedLibrary.)
Public method | MultiplyMatrix3 | Multiplies two 3x3 matrices. The destination matrix receives the result.
Public method | MultiplyMatrix4 | Multiplies two 4x4 matrices. The destination matrix receives the result.
Public method | ReleaseImport | Releases the unmanaged scene data structure. This should NOT be used for unmanaged scenes that were marshaled from the managed scene structure - only for scenes whose memory was allocated by the native library!
Public method | ReleasePropertyStore | Deletes a property store.
Public method | SetImportPropertyFloat | Sets a float property value.
Public method | SetImportPropertyInteger | Sets an integer property value.
Public method | SetImportPropertyMatrix | Sets a matrix property value.
Public method | SetImportPropertyString | Sets a string property value.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | TransformVecByMatrix3 | Transforms the vector by the 3x3 rotation matrix.
Public method | TransformVecByMatrix4 | Transforms the vector by the 4x4 matrix.
Public method | TransposeMatrix3 | Transposes the 3x3 matrix.
Public method | TransposeMatrix4 | Transposes the 4x4 matrix.
Top
Events
 | Name | Description
Public event | LibraryFreed | Occurs when the unmanaged library is freed. (Inherited from UnmanagedLibrary.)
Public event | LibraryLoaded | Occurs when the unmanaged library is loaded. (Inherited from UnmanagedLibrary.)
Top
See Also

Reference

Assimp.Unmanaged Namespace


AssimpLibrary Properties

The AssimpLibrary type exposes the following members.

Properties
 | Name | Description
Public property | DefaultLibraryName | Gets the default name of the unmanaged library DLL. This is dependent based on the platform extension and name prefix. Additional names can be set in the UnmanagedLibraryResolver (e.g. to load versioned DLLs) (Inherited from UnmanagedLibrary.)
 | Instance | Gets the AssimpLibrary instance.
Public property | IsLibraryLoaded | Queries if the unmanaged library has been loaded or not. (Inherited from UnmanagedLibrary.)
Public property | IsMultithreadingSupported | Gets if the Assimp unmanaged library supports multithreading. If it was compiled for single threading only, then it will not utilize multiple threads during import.
Public property | LibraryPath | Gets the path to the unmanaged library DLL that is currently loaded. (Inherited from UnmanagedLibrary.)
Public property | Resolver | Gets the resolver used to find the unmanaged library DLL when loading. (Inherited from UnmanagedLibrary.)
Public property | ThrowOnLoadFailure | Gets or sets whether an AssimpException is thrown if the unmanaged DLL fails to load for whatever reason. By default this is true. (Inherited from UnmanagedLibrary.)
Top
See Also

Reference

AssimpLibrary Class
Assimp.Unmanaged Namespace


AssimpLibrary.Instance Property

AssimpLibraryInstance Property

Gets the AssimpLibrary instance.

Namespace: Assimp.Unmanaged
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public static AssimpLibrary Instance { get; }

Property Value

Type: AssimpLibrary
See Also

Reference

AssimpLibrary Class
Assimp.Unmanaged Namespace


AssimpLibrary.IsMultithreadingSupported Property

AssimpLibraryIsMultithreadingSupported Property

Gets if the Assimp unmanaged library supports multithreading. If it was compiled for single threading only, then it will not utilize multiple threads during import.

Namespace: Assimp.Unmanaged
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public bool IsMultithreadingSupported { get; }

Property Value

Type: Boolean
See Also

Reference

AssimpLibrary Class
Assimp.Unmanaged Namespace


AssimpLibrary Methods

The AssimpLibrary type exposes the following members.

Methods
 | Name | Description
Public method | ApplyPostProcessing | Applies a post-processing step on an already imported scene.
Public method | AttachLogStream | Attaches a log stream callback to catch Assimp messages.
Public method | CopyScene | Creates a modifyable copy of a scene, useful for copying the scene that was imported so its topology can be modified and the scene be exported.
Public method | CreatePropertyStore | Create an empty property store. Property stores are used to collect import settings.
Public method | CreateQuaternionFromMatrix | Creates a quaternion from the 3x3 rotation matrix.
Public method | DecomposeMatrix | Decomposes a 4x4 matrix into its scaling, rotation, and translation parts.
Public method | DetachAllLogStreams | Detaches all logstream callbacks currently attached to Assimp.
Public method | DetachLogStream | Detaches a logstream callback.
Public method | EnableVerboseLogging | Enables verbose logging.
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | ExportScene(IntPtr, String, String, PostProcessSteps) | Exports the given scene to a chosen file format and writes the result file(s) to disk.
Public method | ExportScene(IntPtr, String, String, IntPtr, PostProcessSteps) | Exports the given scene to a chosen file format and writes the result file(s) to disk.
Public method | ExportSceneToBlob | Exports the given scene to a chosen file format. Returns the exported data as a binary blob which you can embed into another data structure or file.
Public method | FreeLibrary | Frees the unmanaged library that is currently loaded. (Inherited from UnmanagedLibrary.)
Public method | GetCompileFlags | Get the compilation flags that describe how the native Assimp DLL was compiled.
Public method | GetErrorString | Gets the last error logged in Assimp.
Public method | GetExportFormatDescriptions | Gets all supported export formats.
Public method | GetExtensionList | Gets all the model format extensions that are currently supported by Assimp.
Public method | GetFunctionT | Gets a delegate based on the unmanaged function name. (Inherited from UnmanagedLibrary.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetImporterDescriptions | Gets a collection of importer descriptions that detail metadata and feature support for each importer.
Public method | GetLegalString | Gets the Assimp legal info.
Public method | GetMaterialColor | Retrieves a color value from the material property table.
Public method | GetMaterialFloatArray | Retrieves an array of float values with the specific key from the material.
Public method | GetMaterialIntegerArray | Retrieves an array of integer values with the specific key from the material.
Public method | GetMaterialProperty | Retrieves a material property with the specific key from the material.
Public method | GetMaterialString | Retrieves a string from the material property table.
Public method | GetMaterialTexture | Gets all values pertaining to a particular texture from a material.
Public method | GetMaterialTextureCount | Gets the number of textures contained in the material for a particular texture type.
Public method | GetMaterialTextureFilePath | Gets the texture filepath contained in the material.
Public method | GetMemoryRequirements | Gets the memory requirements of the scene.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetVerboseLoggingEnabled | Gets if verbose logging is enabled.
Public method | GetVersion | Gets the native Assimp DLL's current version number as "major.minor.revision" string. This is the version of Assimp that this wrapper is currently using.
Public method | GetVersionAsVersion | Gets the native Assimp DLL's current version number as a .NET version object.
Public method | GetVersionMajor | Gets the native Assimp DLL's major version number.
Public method | GetVersionMinor | Gets the native Assimp DLL's minor version number.
Public method | GetVersionRevision | Gets the native Assimp DLL's revision version number.
Public method | IdentityMatrix3 | Creates a 3x3 identity matrix.
Public method | IdentityMatrix4 | Creates a 4x4 identity matrix.
Public method | ImportFile(String, PostProcessSteps, IntPtr) | Imports a file.
Public method | ImportFile(String, PostProcessSteps, IntPtr, IntPtr) | Imports a file.
Public method | ImportFileFromStream | Imports a scene from a stream. This uses the "aiImportFileFromMemory" function. The stream can be from anyplace, not just a memory stream. It is up to the caller to dispose of the stream.
Public method | IsExtensionSupported | Checks whether the model format extension is supported by Assimp.
Public method | LoadLibrary | Loads the unmanaged library using the UnmanagedLibraryResolver. (Inherited from UnmanagedLibrary.)
Public method | LoadLibrary(String) | Loads the unmanaged library using the supplied path. (Inherited from UnmanagedLibrary.)
Public method | LoadLibrary(String, String) | Loads the unmanaged library using the supplied 32 and 64 bit paths, the one chosen is based on the OS bitness. (Inherited from UnmanagedLibrary.)
Public method | MultiplyMatrix3 | Multiplies two 3x3 matrices. The destination matrix receives the result.
Public method | MultiplyMatrix4 | Multiplies two 4x4 matrices. The destination matrix receives the result.
Public method | ReleaseImport | Releases the unmanaged scene data structure. This should NOT be used for unmanaged scenes that were marshaled from the managed scene structure - only for scenes whose memory was allocated by the native library!
Public method | ReleasePropertyStore | Deletes a property store.
Public method | SetImportPropertyFloat | Sets a float property value.
Public method | SetImportPropertyInteger | Sets an integer property value.
Public method | SetImportPropertyMatrix | Sets a matrix property value.
Public method | SetImportPropertyString | Sets a string property value.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | TransformVecByMatrix3 | Transforms the vector by the 3x3 rotation matrix.
Public method | TransformVecByMatrix4 | Transforms the vector by the 4x4 matrix.
Public method | TransposeMatrix3 | Transposes the 3x3 matrix.
Public method | TransposeMatrix4 | Transposes the 4x4 matrix.
Top
See Also

Reference

AssimpLibrary Class
Assimp.Unmanaged Namespace


AssimpLibrary.ApplyPostProcessing Method

AssimpLibraryApplyPostProcessing Method

Applies a post-processing step on an already imported scene.

Namespace: Assimp.Unmanaged
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public IntPtr ApplyPostProcessing(
    IntPtr scene,
    PostProcessSteps flags
)

Parameters

scene
Type: SystemIntPtr
Pointer to the unmanaged scene data structure.
flags
Type: AssimpPostProcessSteps
Post processing steps to run.

Return Value

Type: IntPtr
Pointer to the unmanaged scene data structure.
See Also

Reference

AssimpLibrary Class
Assimp.Unmanaged Namespace


AssimpLibrary.AttachLogStream Method

AssimpLibraryAttachLogStream Method

Attaches a log stream callback to catch Assimp messages.

Namespace: Assimp.Unmanaged
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public void AttachLogStream(
    IntPtr logStreamPtr
)

Parameters

logStreamPtr
Type: SystemIntPtr
Pointer to an instance of AiLogStream.
See Also

Reference

AssimpLibrary Class
Assimp.Unmanaged Namespace


AssimpLibrary.CopyScene Method

AssimpLibraryCopyScene Method

Creates a modifyable copy of a scene, useful for copying the scene that was imported so its topology can be modified and the scene be exported.

Namespace: Assimp.Unmanaged
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public IntPtr CopyScene(
    IntPtr sceneToCopy
)

Parameters

sceneToCopy
Type: SystemIntPtr
Valid scene to be copied

Return Value

Type: IntPtr
Modifyable copy of the scene
See Also

Reference

AssimpLibrary Class
Assimp.Unmanaged Namespace


AssimpLibrary.CreatePropertyStore Method

AssimpLibraryCreatePropertyStore Method

Create an empty property store. Property stores are used to collect import settings.

Namespace: Assimp.Unmanaged
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public IntPtr CreatePropertyStore()

Return Value

Type: IntPtr
Pointer to property store
See Also

Reference

AssimpLibrary Class
Assimp.Unmanaged Namespace


AssimpLibrary.CreateQuaternionFromMatrix Method

AssimpLibraryCreateQuaternionFromMatrix Method

Creates a quaternion from the 3x3 rotation matrix.

Namespace: Assimp.Unmanaged
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public void CreateQuaternionFromMatrix(
    out Quaternion quat,
    ref Matrix3x3 mat
)

Parameters

quat
Type: AssimpQuaternion
Quaternion struct to fill
mat
Type: AssimpMatrix3x3
Rotation matrix
See Also

Reference

AssimpLibrary Class
Assimp.Unmanaged Namespace


AssimpLibrary.DecomposeMatrix Method

AssimpLibraryDecomposeMatrix Method

Decomposes a 4x4 matrix into its scaling, rotation, and translation parts.

Namespace: Assimp.Unmanaged
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public void DecomposeMatrix(
    ref Matrix4x4 mat,
    out Vector3D scaling,
    out Quaternion rotation,
    out Vector3D position
)

Parameters

mat
Type: AssimpMatrix4x4
4x4 Matrix to decompose
scaling
Type: AssimpVector3D
Scaling vector
rotation
Type: AssimpQuaternion
Quaternion containing the rotation
position
Type: AssimpVector3D
Translation vector
See Also

Reference

AssimpLibrary Class
Assimp.Unmanaged Namespace


AssimpLibrary.DetachAllLogStreams Method

AssimpLibraryDetachAllLogStreams Method

Detaches all logstream callbacks currently attached to Assimp.

Namespace: Assimp.Unmanaged
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public void DetachAllLogStreams()
See Also

Reference

AssimpLibrary Class
Assimp.Unmanaged Namespace


AssimpLibrary.DetachLogStream Method

AssimpLibraryDetachLogStream Method

Detaches a logstream callback.

Namespace: Assimp.Unmanaged
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public ReturnCode DetachLogStream(
    IntPtr logStreamPtr
)

Parameters

logStreamPtr
Type: SystemIntPtr
Pointer to an instance of AiLogStream.

Return Value

Type: ReturnCode
A return code signifying if the function was successful or not.
See Also

Reference

AssimpLibrary Class
Assimp.Unmanaged Namespace


AssimpLibrary.EnableVerboseLogging Method

AssimpLibraryEnableVerboseLogging Method

Enables verbose logging.

Namespace: Assimp.Unmanaged
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public void EnableVerboseLogging(
    bool enable
)

Parameters

enable
Type: SystemBoolean
True if verbose logging is to be enabled or not.
See Also

Reference

AssimpLibrary Class
Assimp.Unmanaged Namespace


AssimpLibrary.ExportScene Method

AssimpLibraryExportScene Method

Overload List
 | Name | Description
Public method | ExportScene(IntPtr, String, String, PostProcessSteps) | Exports the given scene to a chosen file format and writes the result file(s) to disk.
Public method | ExportScene(IntPtr, String, String, IntPtr, PostProcessSteps) | Exports the given scene to a chosen file format and writes the result file(s) to disk.
Top
See Also

Reference

AssimpLibrary Class
Assimp.Unmanaged Namespace


AssimpLibrary.ExportScene Method (IntPtr, String, String, PostProcessSteps)

AssimpLibraryExportScene Method (IntPtr, String, String, PostProcessSteps)

Exports the given scene to a chosen file format and writes the result file(s) to disk.

Namespace: Assimp.Unmanaged
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public ReturnCode ExportScene(
    IntPtr scene,
    string formatId,
    string fileName,
    PostProcessSteps preProcessing
)

Parameters

scene
Type: SystemIntPtr
The scene to export, which needs to be freed by the caller. The scene is expected to conform to Assimp's Importer output format. In short, this means the model data should use a right handed coordinate system, face winding should be counter clockwise, and the UV coordinate origin assumed to be upper left. If the input is different, specify the pre processing flags appropiately.
formatId
Type: SystemString
Format id describing which format to export to.
fileName
Type: SystemString
Output filename to write to
preProcessing
Type: AssimpPostProcessSteps
Pre processing flags - accepts any post processing step flag. In reality only a small subset are actually supported, e.g. to ensure the input conforms to the standard Assimp output format. Some may be redundant, such as triangulation, which some exporters may have to enforce due to the export format.

Return Value

Type: ReturnCode
Return code specifying if the operation was a success.
See Also

Reference

AssimpLibrary Class
ExportScene Overload
Assimp.Unmanaged Namespace


AssimpLibrary.ExportScene Method (IntPtr, String, String, IntPtr, PostProcessSteps)

AssimpLibraryExportScene Method (IntPtr, String, String, IntPtr, PostProcessSteps)

Exports the given scene to a chosen file format and writes the result file(s) to disk.

Namespace: Assimp.Unmanaged
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public ReturnCode ExportScene(
    IntPtr scene,
    string formatId,
    string fileName,
    IntPtr fileIO,
    PostProcessSteps preProcessing
)

Parameters

scene
Type: SystemIntPtr
The scene to export, which needs to be freed by the caller. The scene is expected to conform to Assimp's Importer output format. In short, this means the model data should use a right handed coordinate system, face winding should be counter clockwise, and the UV coordinate origin assumed to be upper left. If the input is different, specify the pre processing flags appropiately.
formatId
Type: SystemString
Format id describing which format to export to.
fileName
Type: SystemString
Output filename to write to
fileIO
Type: SystemIntPtr
Pointer to an instance of AiFileIO, a custom file IO system used to open the model and any associated file the loader needs to open, passing NULL uses the default implementation.
preProcessing
Type: AssimpPostProcessSteps
Pre processing flags - accepts any post processing step flag. In reality only a small subset are actually supported, e.g. to ensure the input conforms to the standard Assimp output format. Some may be redundant, such as triangulation, which some exporters may have to enforce due to the export format.

Return Value

Type: ReturnCode
Return code specifying if the operation was a success.
See Also

Reference

AssimpLibrary Class
ExportScene Overload
Assimp.Unmanaged Namespace


AssimpLibrary.ExportSceneToBlob Method

AssimpLibraryExportSceneToBlob Method

Exports the given scene to a chosen file format. Returns the exported data as a binary blob which you can embed into another data structure or file.

Namespace: Assimp.Unmanaged
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public ExportDataBlob ExportSceneToBlob(
    IntPtr scene,
    string formatId,
    PostProcessSteps preProcessing
)

Parameters

scene
Type: SystemIntPtr
Scene to export, it is the responsibility of the caller to free this when finished.
formatId
Type: SystemString
Format id describing which format to export to.
preProcessing
Type: AssimpPostProcessSteps
Pre processing flags to operate on the scene during the export.

Return Value

Type: ExportDataBlob
Exported binary blob, or null if there was an error.
See Also

Reference

AssimpLibrary Class
Assimp.Unmanaged Namespace


AssimpLibrary.GetCompileFlags Method

AssimpLibraryGetCompileFlags Method

Get the compilation flags that describe how the native Assimp DLL was compiled.

Namespace: Assimp.Unmanaged
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public CompileFlags GetCompileFlags()

Return Value

Type: CompileFlags
Compilation flags
See Also

Reference

AssimpLibrary Class
Assimp.Unmanaged Namespace


AssimpLibrary.GetErrorString Method

AssimpLibraryGetErrorString Method

Gets the last error logged in Assimp.

Namespace: Assimp.Unmanaged
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public string GetErrorString()

Return Value

Type: String
The last error message logged.
See Also

Reference

AssimpLibrary Class
Assimp.Unmanaged Namespace


AssimpLibrary.GetExportFormatDescriptions Method

AssimpLibraryGetExportFormatDescriptions Method

Gets all supported export formats.

Namespace: Assimp.Unmanaged
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public ExportFormatDescription[] GetExportFormatDescriptions()

Return Value

Type: ExportFormatDescription
Array of supported export formats.
See Also

Reference

AssimpLibrary Class
Assimp.Unmanaged Namespace


AssimpLibrary.GetExtensionList Method

AssimpLibraryGetExtensionList Method

Gets all the model format extensions that are currently supported by Assimp.

Namespace: Assimp.Unmanaged
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public string[] GetExtensionList()

Return Value

Type: String
Array of supported format extensions
See Also

Reference

AssimpLibrary Class
Assimp.Unmanaged Namespace


AssimpLibrary.GetImporterDescriptions Method

AssimpLibraryGetImporterDescriptions Method

Gets a collection of importer descriptions that detail metadata and feature support for each importer.

Namespace: Assimp.Unmanaged
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public ImporterDescription[] GetImporterDescriptions()

Return Value

Type: ImporterDescription
Collection of importer descriptions
See Also

Reference

AssimpLibrary Class
Assimp.Unmanaged Namespace


AssimpLibrary.GetLegalString Method

AssimpLibraryGetLegalString Method

Gets the Assimp legal info.

Namespace: Assimp.Unmanaged
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public string GetLegalString()

Return Value

Type: String
String containing Assimp legal info.
See Also

Reference

AssimpLibrary Class
Assimp.Unmanaged Namespace


AssimpLibrary.GetMaterialColor Method

AssimpLibraryGetMaterialColor Method

Retrieves a color value from the material property table.

Namespace: Assimp.Unmanaged
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public Color4D GetMaterialColor(
    ref AiMaterial mat,
    string key,
    TextureType texType,
    uint texIndex
)

Parameters

mat
Type: Assimp.UnmanagedAiMaterial
Material to retrieve the data from
key
Type: SystemString
Ai mat key (base) name to search for
texType
Type: AssimpTextureType
Texture Type semantic, always zero for non-texture properties
texIndex
Type: SystemUInt32
Texture index, always zero for non-texture properties

Return Value

Type: Color4D
The color if it exists. If not, the default Color4D value is returned.
See Also

Reference

AssimpLibrary Class
Assimp.Unmanaged Namespace


AssimpLibrary.GetMaterialFloatArray Method

AssimpLibraryGetMaterialFloatArray Method

Retrieves an array of float values with the specific key from the material.

Namespace: Assimp.Unmanaged
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public float[] GetMaterialFloatArray(
    ref AiMaterial mat,
    string key,
    TextureType texType,
    uint texIndex,
    uint floatCount
)

Parameters

mat
Type: Assimp.UnmanagedAiMaterial
Material to retrieve the data from
key
Type: SystemString
Ai mat key (base) name to search for
texType
Type: AssimpTextureType
Texture Type semantic, always zero for non-texture properties
texIndex
Type: SystemUInt32
Texture index, always zero for non-texture properties
floatCount
Type: SystemUInt32
The maximum number of floats to read. This may not accurately describe the data returned, as it may not exist or be smaller. If this value is less than the available floats, then only the requested number is returned (e.g. 1 or 2 out of a 4 float array).

Return Value

Type: Single
The float array, if it exists
See Also

Reference

AssimpLibrary Class
Assimp.Unmanaged Namespace


AssimpLibrary.GetMaterialIntegerArray Method

AssimpLibraryGetMaterialIntegerArray Method

Retrieves an array of integer values with the specific key from the material.

Namespace: Assimp.Unmanaged
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public int[] GetMaterialIntegerArray(
    ref AiMaterial mat,
    string key,
    TextureType texType,
    uint texIndex,
    uint intCount
)

Parameters

mat
Type: Assimp.UnmanagedAiMaterial
Material to retrieve the data from
key
Type: SystemString
Ai mat key (base) name to search for
texType
Type: AssimpTextureType
Texture Type semantic, always zero for non-texture properties
texIndex
Type: SystemUInt32
Texture index, always zero for non-texture properties
intCount
Type: SystemUInt32
The maximum number of integers to read. This may not accurately describe the data returned, as it may not exist or be smaller. If this value is less than the available integers, then only the requested number is returned (e.g. 1 or 2 out of a 4 float array).

Return Value

Type: Int32
The integer array, if it exists
See Also

Reference

AssimpLibrary Class
Assimp.Unmanaged Namespace


AssimpLibrary.GetMaterialProperty Method

AssimpLibraryGetMaterialProperty Method

Retrieves a material property with the specific key from the material.

Namespace: Assimp.Unmanaged
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public AiMaterialProperty GetMaterialProperty(
    ref AiMaterial mat,
    string key,
    TextureType texType,
    uint texIndex
)

Parameters

mat
Type: Assimp.UnmanagedAiMaterial
Material to retrieve the property from
key
Type: SystemString
Ai mat key (base) name to search for
texType
Type: AssimpTextureType
Texture Type semantic, always zero for non-texture properties
texIndex
Type: SystemUInt32
Texture index, always zero for non-texture properties

Return Value

Type: AiMaterialProperty
The material property, if found.
See Also

Reference

AssimpLibrary Class
Assimp.Unmanaged Namespace


AssimpLibrary.GetMaterialString Method

AssimpLibraryGetMaterialString Method

Retrieves a string from the material property table.

Namespace: Assimp.Unmanaged
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public string GetMaterialString(
    ref AiMaterial mat,
    string key,
    TextureType texType,
    uint texIndex
)

Parameters

mat
Type: Assimp.UnmanagedAiMaterial
Material to retrieve the data from
key
Type: SystemString
Ai mat key (base) name to search for
texType
Type: AssimpTextureType
Texture Type semantic, always zero for non-texture properties
texIndex
Type: SystemUInt32
Texture index, always zero for non-texture properties

Return Value

Type: String
The string, if it exists. If not, an empty string is returned.
See Also

Reference

AssimpLibrary Class
Assimp.Unmanaged Namespace


AssimpLibrary.GetMaterialTexture Method

AssimpLibraryGetMaterialTexture Method

Gets all values pertaining to a particular texture from a material.

Namespace: Assimp.Unmanaged
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public TextureSlot GetMaterialTexture(
    ref AiMaterial mat,
    TextureType type,
    uint index
)

Parameters

mat
Type: Assimp.UnmanagedAiMaterial
Material to retrieve the data from
type
Type: AssimpTextureType
Texture type semantic
index
Type: SystemUInt32
Texture index

Return Value

Type: TextureSlot
Returns the texture slot struct containing all the information.
See Also

Reference

AssimpLibrary Class
Assimp.Unmanaged Namespace


AssimpLibrary.GetMaterialTextureCount Method

AssimpLibraryGetMaterialTextureCount Method

Gets the number of textures contained in the material for a particular texture type.

Namespace: Assimp.Unmanaged
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public uint GetMaterialTextureCount(
    ref AiMaterial mat,
    TextureType type
)

Parameters

mat
Type: Assimp.UnmanagedAiMaterial
Material to retrieve the data from
type
Type: AssimpTextureType
Texture Type semantic

Return Value

Type: UInt32
The number of textures for the type.
See Also

Reference

AssimpLibrary Class
Assimp.Unmanaged Namespace


AssimpLibrary.GetMaterialTextureFilePath Method

AssimpLibraryGetMaterialTextureFilePath Method

Gets the texture filepath contained in the material.

Namespace: Assimp.Unmanaged
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public string GetMaterialTextureFilePath(
    ref AiMaterial mat,
    TextureType type,
    uint index
)

Parameters

mat
Type: Assimp.UnmanagedAiMaterial
Material to retrieve the data from
type
Type: AssimpTextureType
Texture type semantic
index
Type: SystemUInt32
Texture index

Return Value

Type: String
The texture filepath, if it exists. If not an empty string is returned.
See Also

Reference

AssimpLibrary Class
Assimp.Unmanaged Namespace


AssimpLibrary.GetMemoryRequirements Method

AssimpLibraryGetMemoryRequirements Method

Gets the memory requirements of the scene.

Namespace: Assimp.Unmanaged
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public AiMemoryInfo GetMemoryRequirements(
    IntPtr scene
)

Parameters

scene
Type: SystemIntPtr
Pointer to the unmanaged scene data structure.

Return Value

Type: AiMemoryInfo
The memory information about the scene.
See Also

Reference

AssimpLibrary Class
Assimp.Unmanaged Namespace


AssimpLibrary.GetVerboseLoggingEnabled Method

AssimpLibraryGetVerboseLoggingEnabled Method

Gets if verbose logging is enabled.

Namespace: Assimp.Unmanaged
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public bool GetVerboseLoggingEnabled()

Return Value

Type: Boolean
True if verbose logging is enabled, false otherwise.
See Also

Reference

AssimpLibrary Class
Assimp.Unmanaged Namespace


AssimpLibrary.GetVersion Method

AssimpLibraryGetVersion Method

Gets the native Assimp DLL's current version number as "major.minor.revision" string. This is the version of Assimp that this wrapper is currently using.

Namespace: Assimp.Unmanaged
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public string GetVersion()

Return Value

Type: String
Unmanaged DLL version
See Also

Reference

AssimpLibrary Class
Assimp.Unmanaged Namespace


AssimpLibrary.GetVersionAsVersion Method

AssimpLibraryGetVersionAsVersion Method

Gets the native Assimp DLL's current version number as a .NET version object.

Namespace: Assimp.Unmanaged
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public Version GetVersionAsVersion()

Return Value

Type: Version
Unmanaged DLL version
See Also

Reference

AssimpLibrary Class
Assimp.Unmanaged Namespace


AssimpLibrary.GetVersionMajor Method

AssimpLibraryGetVersionMajor Method

Gets the native Assimp DLL's major version number.

Namespace: Assimp.Unmanaged
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public uint GetVersionMajor()

Return Value

Type: UInt32
Assimp major version number
See Also

Reference

AssimpLibrary Class
Assimp.Unmanaged Namespace


AssimpLibrary.GetVersionMinor Method

AssimpLibraryGetVersionMinor Method

Gets the native Assimp DLL's minor version number.

Namespace: Assimp.Unmanaged
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public uint GetVersionMinor()

Return Value

Type: UInt32
Assimp minor version number
See Also

Reference

AssimpLibrary Class
Assimp.Unmanaged Namespace


AssimpLibrary.GetVersionRevision Method

AssimpLibraryGetVersionRevision Method

Gets the native Assimp DLL's revision version number.

Namespace: Assimp.Unmanaged
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public uint GetVersionRevision()

Return Value

Type: UInt32
Assimp revision version number
See Also

Reference

AssimpLibrary Class
Assimp.Unmanaged Namespace


AssimpLibrary.IdentityMatrix3 Method

AssimpLibraryIdentityMatrix3 Method

Creates a 3x3 identity matrix.

Namespace: Assimp.Unmanaged
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public void IdentityMatrix3(
    out Matrix3x3 mat
)

Parameters

mat
Type: AssimpMatrix3x3
Matrix to hold the identity
See Also

Reference

AssimpLibrary Class
Assimp.Unmanaged Namespace


AssimpLibrary.IdentityMatrix4 Method

AssimpLibraryIdentityMatrix4 Method

Creates a 4x4 identity matrix.

Namespace: Assimp.Unmanaged
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public void IdentityMatrix4(
    out Matrix4x4 mat
)

Parameters

mat
Type: AssimpMatrix4x4
Matrix to hold the identity
See Also

Reference

AssimpLibrary Class
Assimp.Unmanaged Namespace


AssimpLibrary.ImportFile Method

AssimpLibraryImportFile Method

Overload List
 | Name | Description
Public method | ImportFile(String, PostProcessSteps, IntPtr) | Imports a file.
Public method | ImportFile(String, PostProcessSteps, IntPtr, IntPtr) | Imports a file.
Top
See Also

Reference

AssimpLibrary Class
Assimp.Unmanaged Namespace


AssimpLibrary.ImportFile Method (String, PostProcessSteps, IntPtr)

AssimpLibraryImportFile Method (String, PostProcessSteps, IntPtr)

Imports a file.

Namespace: Assimp.Unmanaged
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public IntPtr ImportFile(
    string file,
    PostProcessSteps flags,
    IntPtr propStore
)

Parameters

file
Type: SystemString
Valid filename
flags
Type: AssimpPostProcessSteps
Post process flags specifying what steps are to be run after the import.
propStore
Type: SystemIntPtr
Property store containing config name-values, may be null.

Return Value

Type: IntPtr
Pointer to the unmanaged data structure.
See Also

Reference

AssimpLibrary Class
ImportFile Overload
Assimp.Unmanaged Namespace


AssimpLibrary.ImportFile Method (String, PostProcessSteps, IntPtr, IntPtr)

AssimpLibraryImportFile Method (String, PostProcessSteps, IntPtr, IntPtr)

Imports a file.

Namespace: Assimp.Unmanaged
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public IntPtr ImportFile(
    string file,
    PostProcessSteps flags,
    IntPtr fileIO,
    IntPtr propStore
)

Parameters

file
Type: SystemString
Valid filename
flags
Type: AssimpPostProcessSteps
Post process flags specifying what steps are to be run after the import.
fileIO
Type: SystemIntPtr
Pointer to an instance of AiFileIO, a custom file IO system used to open the model and any associated file the loader needs to open, passing NULL uses the default implementation.
propStore
Type: SystemIntPtr
Property store containing config name-values, may be null.

Return Value

Type: IntPtr
Pointer to the unmanaged data structure.
See Also

Reference

AssimpLibrary Class
ImportFile Overload
Assimp.Unmanaged Namespace


AssimpLibrary.ImportFileFromStream Method

AssimpLibraryImportFileFromStream Method

Imports a scene from a stream. This uses the "aiImportFileFromMemory" function. The stream can be from anyplace, not just a memory stream. It is up to the caller to dispose of the stream.

Namespace: Assimp.Unmanaged
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public IntPtr ImportFileFromStream(
    Stream stream,
    PostProcessSteps flags,
    string formatHint,
    IntPtr propStore
)

Parameters

stream
Type: System.IOStream
Stream containing the scene data
flags
Type: AssimpPostProcessSteps
Post processing flags
formatHint
Type: SystemString
A hint to Assimp to decide which importer to use to process the data
propStore
Type: SystemIntPtr
Property store containing the config name-values, may be null.

Return Value

Type: IntPtr
Pointer to the unmanaged data structure.
See Also

Reference

AssimpLibrary Class
Assimp.Unmanaged Namespace


AssimpLibrary.IsExtensionSupported Method

AssimpLibraryIsExtensionSupported Method

Checks whether the model format extension is supported by Assimp.

Namespace: Assimp.Unmanaged
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public bool IsExtensionSupported(
    string extension
)

Parameters

extension
Type: SystemString
Model format extension, e.g. ".3ds"

Return Value

Type: Boolean
True if the format is supported, false otherwise.
See Also

Reference

AssimpLibrary Class
Assimp.Unmanaged Namespace


AssimpLibrary.MultiplyMatrix3 Method

AssimpLibraryMultiplyMatrix3 Method

Multiplies two 3x3 matrices. The destination matrix receives the result.

Namespace: Assimp.Unmanaged
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public void MultiplyMatrix3(
    ref Matrix3x3 dst,
    ref Matrix3x3 src
)

Parameters

dst
Type: AssimpMatrix3x3
First input matrix and is also the Matrix to receive the result
src
Type: AssimpMatrix3x3
Second input matrix, to be multiplied with "dst".
See Also

Reference

AssimpLibrary Class
Assimp.Unmanaged Namespace


AssimpLibrary.MultiplyMatrix4 Method

AssimpLibraryMultiplyMatrix4 Method

Multiplies two 4x4 matrices. The destination matrix receives the result.

Namespace: Assimp.Unmanaged
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public void MultiplyMatrix4(
    ref Matrix4x4 dst,
    ref Matrix4x4 src
)

Parameters

dst
Type: AssimpMatrix4x4
First input matrix and is also the Matrix to receive the result
src
Type: AssimpMatrix4x4
Second input matrix, to be multiplied with "dst".
See Also

Reference

AssimpLibrary Class
Assimp.Unmanaged Namespace


AssimpLibrary.ReleaseImport Method

AssimpLibraryReleaseImport Method

Releases the unmanaged scene data structure. This should NOT be used for unmanaged scenes that were marshaled from the managed scene structure - only for scenes whose memory was allocated by the native library!

Namespace: Assimp.Unmanaged
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public void ReleaseImport(
    IntPtr scene
)

Parameters

scene
Type: SystemIntPtr
Pointer to the unmanaged scene data structure.
See Also

Reference

AssimpLibrary Class
Assimp.Unmanaged Namespace


AssimpLibrary.ReleasePropertyStore Method

AssimpLibraryReleasePropertyStore Method

Deletes a property store.

Namespace: Assimp.Unmanaged
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public void ReleasePropertyStore(
    IntPtr propertyStore
)

Parameters

propertyStore
Type: SystemIntPtr
Pointer to property store
See Also

Reference

AssimpLibrary Class
Assimp.Unmanaged Namespace


AssimpLibrary.SetImportPropertyFloat Method

AssimpLibrarySetImportPropertyFloat Method

Sets a float property value.

Namespace: Assimp.Unmanaged
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public void SetImportPropertyFloat(
    IntPtr propertyStore,
    string name,
    float value
)

Parameters

propertyStore
Type: SystemIntPtr
Pointer to property store
name
Type: SystemString
Property name
value
Type: SystemSingle
Property value
See Also

Reference

AssimpLibrary Class
Assimp.Unmanaged Namespace


AssimpLibrary.SetImportPropertyInteger Method

AssimpLibrarySetImportPropertyInteger Method

Sets an integer property value.

Namespace: Assimp.Unmanaged
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public void SetImportPropertyInteger(
    IntPtr propertyStore,
    string name,
    int value
)

Parameters

propertyStore
Type: SystemIntPtr
Pointer to property store
name
Type: SystemString
Property name
value
Type: SystemInt32
Property value
See Also

Reference

AssimpLibrary Class
Assimp.Unmanaged Namespace


AssimpLibrary.SetImportPropertyMatrix Method

AssimpLibrarySetImportPropertyMatrix Method

Sets a matrix property value.

Namespace: Assimp.Unmanaged
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public void SetImportPropertyMatrix(
    IntPtr propertyStore,
    string name,
    Matrix4x4 value
)

Parameters

propertyStore
Type: SystemIntPtr
Pointer to property store
name
Type: SystemString
Property name
value
Type: AssimpMatrix4x4
Property value
See Also

Reference

AssimpLibrary Class
Assimp.Unmanaged Namespace


AssimpLibrary.SetImportPropertyString Method

AssimpLibrarySetImportPropertyString Method

Sets a string property value.

Namespace: Assimp.Unmanaged
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public void SetImportPropertyString(
    IntPtr propertyStore,
    string name,
    string value
)

Parameters

propertyStore
Type: SystemIntPtr
Pointer to property store
name
Type: SystemString
Property name
value
Type: SystemString
Property value
See Also

Reference

AssimpLibrary Class
Assimp.Unmanaged Namespace


AssimpLibrary.TransformVecByMatrix3 Method

AssimpLibraryTransformVecByMatrix3 Method

Transforms the vector by the 3x3 rotation matrix.

Namespace: Assimp.Unmanaged
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public void TransformVecByMatrix3(
    ref Vector3D vec,
    ref Matrix3x3 mat
)

Parameters

vec
Type: AssimpVector3D
Vector to transform
mat
Type: AssimpMatrix3x3
Rotation matrix
See Also

Reference

AssimpLibrary Class
Assimp.Unmanaged Namespace


AssimpLibrary.TransformVecByMatrix4 Method

AssimpLibraryTransformVecByMatrix4 Method

Transforms the vector by the 4x4 matrix.

Namespace: Assimp.Unmanaged
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public void TransformVecByMatrix4(
    ref Vector3D vec,
    ref Matrix4x4 mat
)

Parameters

vec
Type: AssimpVector3D
Vector to transform
mat
Type: AssimpMatrix4x4
Matrix transformation
See Also

Reference

AssimpLibrary Class
Assimp.Unmanaged Namespace


AssimpLibrary.TransposeMatrix3 Method

AssimpLibraryTransposeMatrix3 Method

Transposes the 3x3 matrix.

Namespace: Assimp.Unmanaged
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public void TransposeMatrix3(
    ref Matrix3x3 mat
)

Parameters

mat
Type: AssimpMatrix3x3
Matrix to transpose
See Also

Reference

AssimpLibrary Class
Assimp.Unmanaged Namespace


AssimpLibrary.TransposeMatrix4 Method

AssimpLibraryTransposeMatrix4 Method

Transposes the 4x4 matrix.

Namespace: Assimp.Unmanaged
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public void TransposeMatrix4(
    ref Matrix4x4 mat
)

Parameters

mat
Type: AssimpMatrix4x4
Matrix to transpose
See Also

Reference

AssimpLibrary Class
Assimp.Unmanaged Namespace


AssimpLibrary Events

The AssimpLibrary type exposes the following members.

Events
 | Name | Description
Public event | LibraryFreed | Occurs when the unmanaged library is freed. (Inherited from UnmanagedLibrary.)
Public event | LibraryLoaded | Occurs when the unmanaged library is loaded. (Inherited from UnmanagedLibrary.)
Top
See Also

Reference

AssimpLibrary Class
Assimp.Unmanaged Namespace


Platform Enumeration

Enumerates supported platforms.

Namespace: Assimp.Unmanaged
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public enum Platform
Members
Member name | Value | Description
Windows | 0 | Windows platform.
Linux | 1 | Linux platform.
Mac | 2 | Mac platform.
See Also

Reference

Assimp.Unmanaged Namespace


UnmanagedFunctionNameAttribute Class

An attribute that represents the name of an unmanaged function to import.
Inheritance Hierarchy
SystemObject
SystemAttribute
Assimp.UnmanagedUnmanagedFunctionNameAttribute

Namespace: Assimp.Unmanaged
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public class UnmanagedFunctionNameAttribute : Attribute

The UnmanagedFunctionNameAttribute type exposes the following members.

Constructors
 | Name | Description
Public method | UnmanagedFunctionNameAttribute | Constructs a new UnmanagedFunctionName.
Top
Properties
 | Name | Description
Public property | TypeId | When implemented in a derived class, gets a unique identifier for this Attribute. (Inherited from Attribute.)
Public property | UnmanagedFunctionName | Name of the unmanaged function.
Top
Methods
 | Name | Description
Public method | Equals | Returns a value that indicates whether this instance is equal to a specified object. (Inherited from Attribute.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from Attribute.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsDefaultAttribute | When overridden in a derived class, indicates whether the value of this instance is the default value for the derived class. (Inherited from Attribute.)
Public method | Match | When overridden in a derived class, returns a value that indicates whether this instance equals a specified object. (Inherited from Attribute.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Assimp.Unmanaged Namespace


UnmanagedFunctionNameAttribute Constructor

Constructs a new UnmanagedFunctionName.

Namespace: Assimp.Unmanaged
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public UnmanagedFunctionNameAttribute(
    string unmanagedFunctionName
)

Parameters

unmanagedFunctionName
Type: SystemString
Name of the function.
See Also

Reference

UnmanagedFunctionNameAttribute Class
Assimp.Unmanaged Namespace


UnmanagedFunctionNameAttribute Properties

The UnmanagedFunctionNameAttribute type exposes the following members.

Properties
 | Name | Description
Public property | TypeId | When implemented in a derived class, gets a unique identifier for this Attribute. (Inherited from Attribute.)
Public property | UnmanagedFunctionName | Name of the unmanaged function.
Top
See Also

Reference

UnmanagedFunctionNameAttribute Class
Assimp.Unmanaged Namespace


UnmanagedFunctionNameAttribute.UnmanagedFunctionName Property

UnmanagedFunctionNameAttributeUnmanagedFunctionName Property

Name of the unmanaged function.

Namespace: Assimp.Unmanaged
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public string UnmanagedFunctionName { get; }

Property Value

Type: String
See Also

Reference

UnmanagedFunctionNameAttribute Class
Assimp.Unmanaged Namespace


UnmanagedFunctionNameAttribute Methods

The UnmanagedFunctionNameAttribute type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Returns a value that indicates whether this instance is equal to a specified object. (Inherited from Attribute.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from Attribute.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsDefaultAttribute | When overridden in a derived class, indicates whether the value of this instance is the default value for the derived class. (Inherited from Attribute.)
Public method | Match | When overridden in a derived class, returns a value that indicates whether this instance equals a specified object. (Inherited from Attribute.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

UnmanagedFunctionNameAttribute Class
Assimp.Unmanaged Namespace


UnmanagedLibrary Class

Represents management and access to an unmanaged library. An unmanaged library can be loaded and unloaded dynamically. The library then searches for a list of exported functions to create managed delegates for, allowing callers to access the library. Each OS platform has its own implementation to determine how to load unmanaged libraries.
Inheritance Hierarchy
SystemObject
Assimp.UnmanagedUnmanagedLibrary
Assimp.UnmanagedAssimpLibrary

Namespace: Assimp.Unmanaged
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public abstract class UnmanagedLibrary

The UnmanagedLibrary type exposes the following members.

Constructors
 | Name | Description
Protected method | UnmanagedLibrary | Constructs a new UnmanagedLibrary.
Top
Properties
 | Name | Description
Public property | DefaultLibraryName | Gets the default name of the unmanaged library DLL. This is dependent based on the platform extension and name prefix. Additional names can be set in the UnmanagedLibraryResolver (e.g. to load versioned DLLs)
 | Is64Bit | Queries if the OS is 64-bit, if false then it is 32-bit.
Public property | IsLibraryLoaded | Queries if the unmanaged library has been loaded or not.
Public property | LibraryPath | Gets the path to the unmanaged library DLL that is currently loaded.
Public property | Resolver | Gets the resolver used to find the unmanaged library DLL when loading.
Public property | ThrowOnLoadFailure | Gets or sets whether an AssimpException is thrown if the unmanaged DLL fails to load for whatever reason. By default this is true.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | FreeLibrary | Frees the unmanaged library that is currently loaded.
Public method | GetFunctionT | Gets a delegate based on the unmanaged function name.
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
 | GetPlatform | Gets an enum representing the current OS that is application is executing on.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | LoadIfNotLoaded | If library is not explicitly loaded by user, call this when trying to call an unmanaged function to load the unmanaged library from the default path. This function is thread safe.
Public method | LoadLibrary | Loads the unmanaged library using the UnmanagedLibraryResolver.
Public method | LoadLibrary(String) | Loads the unmanaged library using the supplied path.
Public method | LoadLibrary(String, String) | Loads the unmanaged library using the supplied 32 and 64 bit paths, the one chosen is based on the OS bitness.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | OnLibraryFreed | Called when the library is freed.
Protected method | OnLibraryLoaded | Called when the library is loaded.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Events
 | Name | Description
Public event | LibraryFreed | Occurs when the unmanaged library is freed.
Public event | LibraryLoaded | Occurs when the unmanaged library is loaded.
Top
See Also

Reference

Assimp.Unmanaged Namespace


UnmanagedLibrary Constructor

Constructs a new UnmanagedLibrary.

Namespace: Assimp.Unmanaged
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
protected UnmanagedLibrary(
    string defaultName,
    Type[] unmanagedFunctionDelegateTypes
)

Parameters

defaultName
Type: SystemString
Default name (NOT path) of the unmanaged library.
unmanagedFunctionDelegateTypes
Type: SystemType
Delegate types to instantiate and load.
See Also

Reference

UnmanagedLibrary Class
Assimp.Unmanaged Namespace


UnmanagedLibrary Properties

The UnmanagedLibrary type exposes the following members.

Properties
 | Name | Description
Public property | DefaultLibraryName | Gets the default name of the unmanaged library DLL. This is dependent based on the platform extension and name prefix. Additional names can be set in the UnmanagedLibraryResolver (e.g. to load versioned DLLs)
 | Is64Bit | Queries if the OS is 64-bit, if false then it is 32-bit.
Public property | IsLibraryLoaded | Queries if the unmanaged library has been loaded or not.
Public property | LibraryPath | Gets the path to the unmanaged library DLL that is currently loaded.
Public property | Resolver | Gets the resolver used to find the unmanaged library DLL when loading.
Public property | ThrowOnLoadFailure | Gets or sets whether an AssimpException is thrown if the unmanaged DLL fails to load for whatever reason. By default this is true.
Top
See Also

Reference

UnmanagedLibrary Class
Assimp.Unmanaged Namespace


UnmanagedLibrary.DefaultLibraryName Property

UnmanagedLibraryDefaultLibraryName Property

Gets the default name of the unmanaged library DLL. This is dependent based on the platform extension and name prefix. Additional names can be set in the UnmanagedLibraryResolver (e.g. to load versioned DLLs)

Namespace: Assimp.Unmanaged
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public string DefaultLibraryName { get; }

Property Value

Type: String
See Also

Reference

UnmanagedLibrary Class
Assimp.Unmanaged Namespace


UnmanagedLibrary.Is64Bit Property

UnmanagedLibraryIs64Bit Property

Queries if the OS is 64-bit, if false then it is 32-bit.

Namespace: Assimp.Unmanaged
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public static bool Is64Bit { get; }

Property Value

Type: Boolean
See Also

Reference

UnmanagedLibrary Class
Assimp.Unmanaged Namespace


UnmanagedLibrary.IsLibraryLoaded Property

UnmanagedLibraryIsLibraryLoaded Property

Queries if the unmanaged library has been loaded or not.

Namespace: Assimp.Unmanaged
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public bool IsLibraryLoaded { get; }

Property Value

Type: Boolean
See Also

Reference

UnmanagedLibrary Class
Assimp.Unmanaged Namespace


UnmanagedLibrary.LibraryPath Property

UnmanagedLibraryLibraryPath Property

Gets the path to the unmanaged library DLL that is currently loaded.

Namespace: Assimp.Unmanaged
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public string LibraryPath { get; }

Property Value

Type: String
See Also

Reference

UnmanagedLibrary Class
Assimp.Unmanaged Namespace


UnmanagedLibrary.Resolver Property

UnmanagedLibraryResolver Property

Gets the resolver used to find the unmanaged library DLL when loading.

Namespace: Assimp.Unmanaged
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public UnmanagedLibraryResolver Resolver { get; }

Property Value

Type: UnmanagedLibraryResolver
See Also

Reference

UnmanagedLibrary Class
Assimp.Unmanaged Namespace


UnmanagedLibrary.ThrowOnLoadFailure Property

UnmanagedLibraryThrowOnLoadFailure Property

Gets or sets whether an AssimpException is thrown if the unmanaged DLL fails to load for whatever reason. By default this is true.

Namespace: Assimp.Unmanaged
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public bool ThrowOnLoadFailure { get; set; }

Property Value

Type: Boolean
See Also

Reference

UnmanagedLibrary Class
Assimp.Unmanaged Namespace


UnmanagedLibrary Methods

The UnmanagedLibrary type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | FreeLibrary | Frees the unmanaged library that is currently loaded.
Public method | GetFunctionT | Gets a delegate based on the unmanaged function name.
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
 | GetPlatform | Gets an enum representing the current OS that is application is executing on.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | LoadIfNotLoaded | If library is not explicitly loaded by user, call this when trying to call an unmanaged function to load the unmanaged library from the default path. This function is thread safe.
Public method | LoadLibrary | Loads the unmanaged library using the UnmanagedLibraryResolver.
Public method | LoadLibrary(String) | Loads the unmanaged library using the supplied path.
Public method | LoadLibrary(String, String) | Loads the unmanaged library using the supplied 32 and 64 bit paths, the one chosen is based on the OS bitness.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | OnLibraryFreed | Called when the library is freed.
Protected method | OnLibraryLoaded | Called when the library is loaded.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

UnmanagedLibrary Class
Assimp.Unmanaged Namespace


UnmanagedLibrary.FreeLibrary Method

UnmanagedLibraryFreeLibrary Method

Frees the unmanaged library that is currently loaded.

Namespace: Assimp.Unmanaged
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public bool FreeLibrary()

Return Value

Type: Boolean
True if the library was sucessfully freed.
See Also

Reference

UnmanagedLibrary Class
Assimp.Unmanaged Namespace


UnmanagedLibrary.GetFunction(T) Method

UnmanagedLibraryGetFunctionT Method

Gets a delegate based on the unmanaged function name.

Namespace: Assimp.Unmanaged
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public T GetFunction<T>(
    string funcName
)
where T : class

Parameters

funcName
Type: SystemString
Name of unmanaged function that is exported by the library.

Type Parameters

T
Type of delegate.

Return Value

Type: T
The delegate, or null if not found.
See Also

Reference

UnmanagedLibrary Class
Assimp.Unmanaged Namespace


UnmanagedLibrary.GetPlatform Method

UnmanagedLibraryGetPlatform Method

Gets an enum representing the current OS that is application is executing on.

Namespace: Assimp.Unmanaged
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public static Platform GetPlatform()

Return Value

Type: Platform
Platform enumeration.
See Also

Reference

UnmanagedLibrary Class
Assimp.Unmanaged Namespace


UnmanagedLibrary.LoadIfNotLoaded Method

UnmanagedLibraryLoadIfNotLoaded Method

If library is not explicitly loaded by user, call this when trying to call an unmanaged function to load the unmanaged library from the default path. This function is thread safe.

Namespace: Assimp.Unmanaged
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
protected void LoadIfNotLoaded()
See Also

Reference

UnmanagedLibrary Class
Assimp.Unmanaged Namespace


UnmanagedLibrary.LoadLibrary Method

UnmanagedLibraryLoadLibrary Method

Overload List
 | Name | Description
Public method | LoadLibrary | Loads the unmanaged library using the UnmanagedLibraryResolver.
Public method | LoadLibrary(String) | Loads the unmanaged library using the supplied path.
Public method | LoadLibrary(String, String) | Loads the unmanaged library using the supplied 32 and 64 bit paths, the one chosen is based on the OS bitness.
Top
See Also

Reference

UnmanagedLibrary Class
Assimp.Unmanaged Namespace


UnmanagedLibrary.LoadLibrary Method

UnmanagedLibraryLoadLibrary Method

Loads the unmanaged library using the UnmanagedLibraryResolver.

Namespace: Assimp.Unmanaged
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public bool LoadLibrary()

Return Value

Type: Boolean
True if the library was found and successfully loaded.
See Also

Reference

UnmanagedLibrary Class
LoadLibrary Overload
Assimp.Unmanaged Namespace


UnmanagedLibrary.LoadLibrary Method (String)

UnmanagedLibraryLoadLibrary Method (String)

Loads the unmanaged library using the supplied path.

Namespace: Assimp.Unmanaged
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public bool LoadLibrary(
    string libPath
)

Parameters

libPath
Type: SystemString
Path to the unmanaged DLL.

Return Value

Type: Boolean
True if the library was found and successfully loaded.
See Also

Reference

UnmanagedLibrary Class
LoadLibrary Overload
Assimp.Unmanaged Namespace


UnmanagedLibrary.LoadLibrary Method (String, String)

UnmanagedLibraryLoadLibrary Method (String, String)

Loads the unmanaged library using the supplied 32 and 64 bit paths, the one chosen is based on the OS bitness.

Namespace: Assimp.Unmanaged
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public bool LoadLibrary(
    string lib32Path,
    string lib64Path
)

Parameters

lib32Path
Type: SystemString
Path to the 32-bit DLL
lib64Path
Type: SystemString
Path to the 64-bit DLL

Return Value

Type: Boolean
True if the library was found and successfully loaded.
See Also

Reference

UnmanagedLibrary Class
LoadLibrary Overload
Assimp.Unmanaged Namespace


UnmanagedLibrary.OnLibraryFreed Method

UnmanagedLibraryOnLibraryFreed Method

Called when the library is freed.

Namespace: Assimp.Unmanaged
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
protected virtual void OnLibraryFreed()
See Also

Reference

UnmanagedLibrary Class
Assimp.Unmanaged Namespace


UnmanagedLibrary.OnLibraryLoaded Method

UnmanagedLibraryOnLibraryLoaded Method

Called when the library is loaded.

Namespace: Assimp.Unmanaged
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
protected virtual void OnLibraryLoaded()
See Also

Reference

UnmanagedLibrary Class
Assimp.Unmanaged Namespace


UnmanagedLibrary Events

The UnmanagedLibrary type exposes the following members.

Events
 | Name | Description
Public event | LibraryFreed | Occurs when the unmanaged library is freed.
Public event | LibraryLoaded | Occurs when the unmanaged library is loaded.
Top
See Also

Reference

UnmanagedLibrary Class
Assimp.Unmanaged Namespace


UnmanagedLibrary.LibraryFreed Event

UnmanagedLibraryLibraryFreed Event

Occurs when the unmanaged library is freed.

Namespace: Assimp.Unmanaged
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public event EventHandler LibraryFreed

Value

Type: SystemEventHandler
See Also

Reference

UnmanagedLibrary Class
Assimp.Unmanaged Namespace


UnmanagedLibrary.LibraryLoaded Event

UnmanagedLibraryLibraryLoaded Event

Occurs when the unmanaged library is loaded.

Namespace: Assimp.Unmanaged
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public event EventHandler LibraryLoaded

Value

Type: SystemEventHandler
See Also

Reference

UnmanagedLibrary Class
Assimp.Unmanaged Namespace


UnmanagedLibraryResolver Class

Resolves unmanaged DLLs for UnmanagedLibrary. The process is completely configurable, where the user can supply alternative library names (e.g. versioned libs), an override library name, and probing paths. These can be set for both 32/64 bit, or seperately for 32 or 64 bit. See ResolveLibraryPath(String) for the search strategy.
Inheritance Hierarchy
SystemObject
Assimp.UnmanagedUnmanagedLibraryResolver

Namespace: Assimp.Unmanaged
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public sealed class UnmanagedLibraryResolver

The UnmanagedLibraryResolver type exposes the following members.

Properties
 | Name | Description
Public property | Platform | Gets the platform that the application is running on.
Top
Methods
Name Description
Public method Equals
Determines whether the specified object is equal to the current object.
(Inherited from Object.)
Public method GetHashCode
Serves as the default hash function.
(Inherited from Object.)
Public method GetType
Gets the Type of the current instance.
(Inherited from Object.)
Public method ResolveLibraryPath
Given a library name, this function attempts to resolve the file path from which it can be loaded. Each step of the search strategy uses the fallback library names if the given name was not found in the current step. If the search is unsuccessfully, the library name is returned which means the OS will try and do its own search strategy when attempting to load the library (this is dependent on the OS). The search strategy is the following, in order of execution:

  1. Search user-specified probing paths.
  2. Search {AppBaseDirectory}/runtimes/{RID}/native/.
  3. Search {AppBaseDirectory}/.
  4. Search nuget package path, e.g. {UserProfile}/.nuget/packages/{PackageId}/{PackageVersion}/runtimes/{RID}/native/.

The search strategy gives priority to user-specified probing paths, then local paths to the application, then finally examining the global nuget cache. The RID is the Runtime Identifier based on the platform/architecture, see also Microsoft's RID Catalog.

Public method SetFallbackLibraryNames
Sets the collection of fallback library names (e.g. versioned libs) for both 32-bit and 64-bit probing.
Public method SetFallbackLibraryNames32
Sets the collection of fallback library names (e.g. versioned libs) for 32-bit probing.
Public method SetFallbackLibraryNames64
Sets the collection of fallback library names (e.g. versioned libs) for 64-bit probing.
Public method SetOverrideLibraryName
Sets an override 32-bit and 64-bit library name. By default, the UnmanagedLibrary implementations creates a default name for the library, which is passed into ResolveLibraryPath(String) for resolving. If the override is non-null, it will be used instead. This is useful if the library to be loaded is not conforming to the platform's default prefix/extension scheme (e.g. libXYZ.so on linux where "lib" is the prefix and ".so" the extension).
Public method SetOverrideLibraryName32
Sets an override 32-bit library name. By default, the UnmanagedLibrary implementations creates a default name for the library, which is passed into ResolveLibraryPath(String) for resolving. If the override is non-null, it will be used instead. This is useful if the library to be loaded is not conforming to the platform's default prefix/extension scheme (e.g. libXYZ.so on linux where "lib" is the prefix and ".so" the extension).
Public method SetOverrideLibraryName64
Sets an override 64-bit library name. By default, the UnmanagedLibrary implementations creates a default name for the library, which is passed into ResolveLibraryPath(String) for resolving. If the override is non-null, it will be used instead. This is useful if the library to be loaded is not conforming to the platform's default prefix/extension scheme (e.g. libXYZ.so on linux where "lib" is the prefix and ".so" the extension).
Public method SetProbingPaths
Sets the collection of file paths to probe for both 32-bit and 64-bit libraries. These paths always are first to be searched, in the order that they are given.
Public method SetProbingPaths32
Sets the collection of file paths to probe for 32-bit libraries. These paths always are first to be searched, in the order that they are given.
Public method SetProbingPaths64
Sets the collection of file paths to probe for 64-bit libraries. These paths always are first to be searched, in the order that they are given.
Public method ToString
Returns a string that represents the current object.
(Inherited from Object.)
Top
See Also

Reference

Assimp.Unmanaged Namespace


UnmanagedLibraryResolver Properties

The UnmanagedLibraryResolver type exposes the following members.

Properties
 | Name | Description
Public property | Platform | Gets the platform that the application is running on.
Top
See Also

Reference

UnmanagedLibraryResolver Class
Assimp.Unmanaged Namespace


UnmanagedLibraryResolver.Platform Property

UnmanagedLibraryResolverPlatform Property

Gets the platform that the application is running on.

Namespace: Assimp.Unmanaged
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public Platform Platform { get; }

Property Value

Type: Platform
See Also

Reference

UnmanagedLibraryResolver Class
Assimp.Unmanaged Namespace


UnmanagedLibraryResolver Methods

The UnmanagedLibraryResolver type exposes the following members.

Methods
Name Description
Public method Equals
Determines whether the specified object is equal to the current object.
(Inherited from Object.)
Public method GetHashCode
Serves as the default hash function.
(Inherited from Object.)
Public method GetType
Gets the Type of the current instance.
(Inherited from Object.)
Public method ResolveLibraryPath
Given a library name, this function attempts to resolve the file path from which it can be loaded. Each step of the search strategy uses the fallback library names if the given name was not found in the current step. If the search is unsuccessfully, the library name is returned which means the OS will try and do its own search strategy when attempting to load the library (this is dependent on the OS). The search strategy is the following, in order of execution:

  1. Search user-specified probing paths.
  2. Search {AppBaseDirectory}/runtimes/{RID}/native/.
  3. Search {AppBaseDirectory}/.
  4. Search nuget package path, e.g. {UserProfile}/.nuget/packages/{PackageId}/{PackageVersion}/runtimes/{RID}/native/.

The search strategy gives priority to user-specified probing paths, then local paths to the application, then finally examining the global nuget cache. The RID is the Runtime Identifier based on the platform/architecture, see also Microsoft's RID Catalog.

Public method SetFallbackLibraryNames
Sets the collection of fallback library names (e.g. versioned libs) for both 32-bit and 64-bit probing.
Public method SetFallbackLibraryNames32
Sets the collection of fallback library names (e.g. versioned libs) for 32-bit probing.
Public method SetFallbackLibraryNames64
Sets the collection of fallback library names (e.g. versioned libs) for 64-bit probing.
Public method SetOverrideLibraryName
Sets an override 32-bit and 64-bit library name. By default, the UnmanagedLibrary implementations creates a default name for the library, which is passed into ResolveLibraryPath(String) for resolving. If the override is non-null, it will be used instead. This is useful if the library to be loaded is not conforming to the platform's default prefix/extension scheme (e.g. libXYZ.so on linux where "lib" is the prefix and ".so" the extension).
Public method SetOverrideLibraryName32
Sets an override 32-bit library name. By default, the UnmanagedLibrary implementations creates a default name for the library, which is passed into ResolveLibraryPath(String) for resolving. If the override is non-null, it will be used instead. This is useful if the library to be loaded is not conforming to the platform's default prefix/extension scheme (e.g. libXYZ.so on linux where "lib" is the prefix and ".so" the extension).
Public method SetOverrideLibraryName64
Sets an override 64-bit library name. By default, the UnmanagedLibrary implementations creates a default name for the library, which is passed into ResolveLibraryPath(String) for resolving. If the override is non-null, it will be used instead. This is useful if the library to be loaded is not conforming to the platform's default prefix/extension scheme (e.g. libXYZ.so on linux where "lib" is the prefix and ".so" the extension).
Public method SetProbingPaths
Sets the collection of file paths to probe for both 32-bit and 64-bit libraries. These paths always are first to be searched, in the order that they are given.
Public method SetProbingPaths32
Sets the collection of file paths to probe for 32-bit libraries. These paths always are first to be searched, in the order that they are given.
Public method SetProbingPaths64
Sets the collection of file paths to probe for 64-bit libraries. These paths always are first to be searched, in the order that they are given.
Public method ToString
Returns a string that represents the current object.
(Inherited from Object.)
Top
See Also

Reference

UnmanagedLibraryResolver Class
Assimp.Unmanaged Namespace


UnmanagedLibraryResolver.ResolveLibraryPath Method

UnmanagedLibraryResolverResolveLibraryPath Method

Given a library name, this function attempts to resolve the file path from which it can be loaded. Each step of the search strategy uses the fallback library names if the given name was not found in the current step. If the search is unsuccessfully, the library name is returned which means the OS will try and do its own search strategy when attempting to load the library (this is dependent on the OS). The search strategy is the following, in order of execution:

  1. Search user-specified probing paths.
  2. Search {AppBaseDirectory}/runtimes/{RID}/native/.
  3. Search {AppBaseDirectory}/.
  4. Search nuget package path, e.g. {UserProfile}/.nuget/packages/{PackageId}/{PackageVersion}/runtimes/{RID}/native/.

The search strategy gives priority to user-specified probing paths, then local paths to the application, then finally examining the global nuget cache. The RID is the Runtime Identifier based on the platform/architecture, see also Microsoft's RID Catalog.

Namespace: Assimp.Unmanaged
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public string ResolveLibraryPath(
    string libName
)

Parameters

libName
Type: SystemString
Name of the library to attempt to resolve.

Return Value

Type: String
Full file path to the library, or the file name if not found (e.g. "libXYZ.so").
See Also

Reference

UnmanagedLibraryResolver Class
Assimp.Unmanaged Namespace


UnmanagedLibraryResolver.SetFallbackLibraryNames Method

UnmanagedLibraryResolverSetFallbackLibraryNames Method

Sets the collection of fallback library names (e.g. versioned libs) for both 32-bit and 64-bit probing.

Namespace: Assimp.Unmanaged
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public void SetFallbackLibraryNames(
    params string[] fallbackLibNames
)

Parameters

fallbackLibNames
Type: SystemString
Null to clear, or set of fallback library names.
See Also

Reference

UnmanagedLibraryResolver Class
Assimp.Unmanaged Namespace


UnmanagedLibraryResolver.SetFallbackLibraryNames32 Method

UnmanagedLibraryResolverSetFallbackLibraryNames32 Method

Sets the collection of fallback library names (e.g. versioned libs) for 32-bit probing.

Namespace: Assimp.Unmanaged
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public void SetFallbackLibraryNames32(
    params string[] fallbackLibNames
)

Parameters

fallbackLibNames
Type: SystemString
Null to clear, or set of fallback library names.
See Also

Reference

UnmanagedLibraryResolver Class
Assimp.Unmanaged Namespace


UnmanagedLibraryResolver.SetFallbackLibraryNames64 Method

UnmanagedLibraryResolverSetFallbackLibraryNames64 Method

Sets the collection of fallback library names (e.g. versioned libs) for 64-bit probing.

Namespace: Assimp.Unmanaged
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public void SetFallbackLibraryNames64(
    params string[] fallbackLibNames
)

Parameters

fallbackLibNames
Type: SystemString
Null to clear, or set of fallback library names.
See Also

Reference

UnmanagedLibraryResolver Class
Assimp.Unmanaged Namespace


UnmanagedLibraryResolver.SetOverrideLibraryName Method

UnmanagedLibraryResolverSetOverrideLibraryName Method

Sets an override 32-bit and 64-bit library name. By default, the UnmanagedLibrary implementations creates a default name for the library, which is passed into ResolveLibraryPath(String) for resolving. If the override is non-null, it will be used instead. This is useful if the library to be loaded is not conforming to the platform's default prefix/extension scheme (e.g. libXYZ.so on linux where "lib" is the prefix and ".so" the extension).

Namespace: Assimp.Unmanaged
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public void SetOverrideLibraryName(
    string overrideName
)

Parameters

overrideName
Type: SystemString
Null to clear, or override library name.
See Also

Reference

UnmanagedLibraryResolver Class
Assimp.Unmanaged Namespace


UnmanagedLibraryResolver.SetOverrideLibraryName32 Method

UnmanagedLibraryResolverSetOverrideLibraryName32 Method

Sets an override 32-bit library name. By default, the UnmanagedLibrary implementations creates a default name for the library, which is passed into ResolveLibraryPath(String) for resolving. If the override is non-null, it will be used instead. This is useful if the library to be loaded is not conforming to the platform's default prefix/extension scheme (e.g. libXYZ.so on linux where "lib" is the prefix and ".so" the extension).

Namespace: Assimp.Unmanaged
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public void SetOverrideLibraryName32(
    string overrideName
)

Parameters

overrideName
Type: SystemString
Null to clear, or override library name.
See Also

Reference

UnmanagedLibraryResolver Class
Assimp.Unmanaged Namespace


UnmanagedLibraryResolver.SetOverrideLibraryName64 Method

UnmanagedLibraryResolverSetOverrideLibraryName64 Method

Sets an override 64-bit library name. By default, the UnmanagedLibrary implementations creates a default name for the library, which is passed into ResolveLibraryPath(String) for resolving. If the override is non-null, it will be used instead. This is useful if the library to be loaded is not conforming to the platform's default prefix/extension scheme (e.g. libXYZ.so on linux where "lib" is the prefix and ".so" the extension).

Namespace: Assimp.Unmanaged
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public void SetOverrideLibraryName64(
    string overrideName
)

Parameters

overrideName
Type: SystemString
Null to clear, or override library name.
See Also

Reference

UnmanagedLibraryResolver Class
Assimp.Unmanaged Namespace


UnmanagedLibraryResolver.SetProbingPaths Method

UnmanagedLibraryResolverSetProbingPaths Method

Sets the collection of file paths to probe for both 32-bit and 64-bit libraries. These paths always are first to be searched, in the order that they are given.

Namespace: Assimp.Unmanaged
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public void SetProbingPaths(
    params string[] probingPaths
)

Parameters

probingPaths
Type: SystemString
Null to clear, or set of paths to probe.
See Also

Reference

UnmanagedLibraryResolver Class
Assimp.Unmanaged Namespace


UnmanagedLibraryResolver.SetProbingPaths32 Method

UnmanagedLibraryResolverSetProbingPaths32 Method

Sets the collection of file paths to probe for 32-bit libraries. These paths always are first to be searched, in the order that they are given.

Namespace: Assimp.Unmanaged
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public void SetProbingPaths32(
    params string[] probingPaths
)

Parameters

probingPaths
Type: SystemString
Null to clear, or set of paths to probe.
See Also

Reference

UnmanagedLibraryResolver Class
Assimp.Unmanaged Namespace


UnmanagedLibraryResolver.SetProbingPaths64 Method

UnmanagedLibraryResolverSetProbingPaths64 Method

Sets the collection of file paths to probe for 64-bit libraries. These paths always are first to be searched, in the order that they are given.

Namespace: Assimp.Unmanaged
Assembly: AssimpNet (in AssimpNet.dll) Version: 4.1.0
Syntax
C#
Copy
public void SetProbingPaths64(
    params string[] probingPaths
)

Parameters

probingPaths
Type: SystemString
Null to clear, or set of paths to probe.
See Also

Reference

UnmanagedLibraryResolver Class
Assimp.Unmanaged Namespace